Subject: [manet] AD review of draft-ietf-manet-olsrv2-rmpr-optimization

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 18 Jan 2014 16:35:13 -0000

Hi Authors,

I have done my usual AD review of this document and found only a few
trivial editorial issues (well, it is a short document, and the 
authors are reported to be competent).

I will start the IETF last call and raise these issues to be addressed
as part of the last call.

Thanks for the work.

Adrian

===

The Shepherd write-up notes idnits that need to be fixed, but I see
none.

---

I think MPR could usefully be expanded in the document title, in the
Abstract, and on first use in the body.  Then you won't need to expand 
it in Section 3.

---

It seems odd that Section 4 has a bullet numbered "1." but no other
numbered bullets.

---

I think Section 4 uses the notation of 18.2 of [OLSRv2] not 18.3. At 
least, that is where d1() etc. are defined for revision -19 of that 
document.

---

---

From: Ulrich Herberg <[email-masked]>
Date: Sat, 18 Jan 2014 09:11:31 -0800

Hi Adrian,

thank you very much for the review.

The idnit I meant is not an error, just a warning:

"The copyright year in the IETF Trust and authors Copyright Line does not
match the current year"

That should be a trivial fix.

Best regards
Ulrich

On Sat, Jan 18, 2014 at 8:35 AM, Adrian Farrel <[email-masked]> wrote:

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 20 Jan 2014 10:00:17 +0000

Adrian

Thanks for these.

With regard to MPR, I think this has, at least among people working with MPR, a more familiar term than its expansion. So I think the title is better with MPR than MultiPoint Relay. Expansion in abstract is a style thing, I've tended to be influenced by people who don't like it in an abstract. But I haven't checked RFC style. But it certainly should be expanded in the Introduction, not for the first time in Section 3.

I know why Section 4 has a single bullet numbered 1, which is that throughout the OLSRv2 documents we've used numbers for algorithm/specification bullets, and bullets for other lists. Whether that's sufficient justification I don't know. (I don't know if it's happened elsewhere, I suspect it has. If so I'm inclined to leave it.)

Yes, should be 18.2.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: 18 January 2014 16:35
To: [email-masked]
Cc: [email-masked]
Subject: [manet] AD review of draft-ietf-manet-olsrv2-rmpr-optimization

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hi Authors,

I have done my usual AD review of this document and found only a few trivial editorial issues (well, it is a short document, and the authors are reported to be competent).

I will start the IETF last call and raise these issues to be addressed as part of the last call.

Thanks for the work.

Adrian

===

The Shepherd write-up notes idnits that need to be fixed, but I see none.

---

I think MPR could usefully be expanded in the document title, in the Abstract, and on first use in the body.  Then you won't need to expand it in Section 3.

---

It seems odd that Section 4 has a bullet numbered "1." but no other numbered bullets.

---

I think Section 4 uses the notation of 18.2 of [OLSRv2] not 18.3. At least, that is where d1() etc. are defined for revision -19 of that document.

---

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 20 Jan 2014 10:43:13 -0000

Thanks!

OK, leave the document title. RFC Editor house style has expansion in Abstract,
so we'll go that way (it'll end up happening anyway).

I can live with a single bullet numbered 1. All I can say is that you will
probably get to answer the same question another five of six times before
publication :-)

I expect the last call announcement to come out today. For the sake of form I
will then send my comments and you can respond in a perfect piece of rehearsed
pageantry, and then at the end of last call you can do the updates.

Cheers,
Adrian

> From: Dearlove, Christopher (UK) [mailto:[email-masked]]
> Sent: 20 January 2014 10:00
> To: [email-masked]; draft-ietf-manet-olsrv2-rmpr-
> [email-masked]
> Cc: [email-masked]
> Subject: RE: [manet] AD review of draft-ietf-manet-olsrv2-rmpr-optimization
> 
> Adrian
> 
> Thanks for these.
> 
> With regard to MPR, I think this has, at least among people working with MPR,
a
> more familiar term than its expansion. So I think the title is better with MPR
than
> MultiPoint Relay. Expansion in abstract is a style thing, I've tended to be
> influenced by people who don't like it in an abstract. But I haven't checked
RFC
> style. But it certainly should be expanded in the Introduction, not for the
first
> time in Section 3.
> 
> I know why Section 4 has a single bullet numbered 1, which is that throughout
the
> OLSRv2 documents we've used numbers for algorithm/specification bullets, and
> bullets for other lists. Whether that's sufficient justification I don't know.
(I don't
> know if it's happened elsewhere, I suspect it has. If so I'm inclined to leave
it.)
> ----------------------! WARNING ! ---------------------- This message
originates from
> outside our organisation, either from an external partner or from the
internet.
> I have done my usual AD review of this document and found only a few trivial
> editorial issues (well, it is a short document, and the authors are reported
to be
> competent).
> 
> I will start the IETF last call and raise these issues to be addressed as part
of the
> last call.
> I think MPR could usefully be expanded in the document title, in the Abstract,
> and on first use in the body.  Then you won't need to expand it in Section 3.
> 
> ---
> 
> I think Section 4 uses the notation of 18.2 of [OLSRv2] not 18.3. At least,
that is
> where d1() etc. are defined for revision -19 of that document.
> 
> ---
>