Subject: Re: [manet] draft-dearlove-manet-olsrv2-multitopology-02 -> WG

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Wed, 29 Jan 2014 16:17:00 +0000

Chris/Thomas,

My apologies for the delay.

Working Group,

What say you? Do we have consensus to proceed with this document as a WG doc?

Regards,
Stan

On Jan 29, 2014, at 11:14 AM, Ulrich Herberg <[email-masked]<mailto:[email-masked]>>
 wrote:

Joe, Stan,

have you received the below email? Can you please respond?

Thanks
Ulrich

---------- Forwarded message ----------
From: Thomas Heide Clausen <[email-masked]<mailto:[email-masked]>>
Date: Wed, Jan 22, 2014 at 11:44 PM
Subject: Re: draft-dearlove-manet-olsrv2-multitopology-02 -> WG
To: Christopher Dearlove <[email-masked]<mailto:[email-masked]>>
Cc: Joe Macker <[email-masked]<mailto:[email-masked]>>, Stan Ratliff <[email-masked]<mailto:[email-masked]>>, Ulrich Herberg <[email-masked]<mailto:[email-masked]>>, Adrian Farrel <[email-masked]<mailto:[email-masked]>>

Dear WG chairs, WG secretary, Area Director,

First, happy new year. I hope that you were able to spend some time with your loved ones over the holidays, and that health and happiness may be with you in the new year.

I wanted to remind you of the request from Chris (below), sent to you a bit more than a month ago. As I've seen no emails from you to regarding this, I permit myself to reiterate the request for WG adoption of draft-dearlove-manet-olsrv2-multitopolgy-02 - so that we may advance also this document forward, hopefully rapidly, towards publication as experimental RFC.

Thank you in advance for your consideration.

Respectfully,

Thomas

On 20 Dec 2013, at 17:07 , Dearlove, Christopher (UK) <[email-masked]<mailto:[email-masked]>> wrote:

Joe, Stan

We have submitted draft-dearlove-manet-olsrv2-multitopology-02, which includes what we knew we were missing from the previous draft.

We would therefore like to ask the WG to accept this. Obviously this close to the Christmas/New Year holiday, after those (as immediately after those as possible) would be appropriate. (Same timeframe as IETF LC on other drafts I hope).

In the meanwhile, Merry Christmas and Happy New Year to all,

Christopher

--
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194<tel:%2B44%201245%20242194> |  Fax: +44 1245 242124<tel:%2B44%201245%20242124>
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com<http://www.baesystems.com/>

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 29 Jan 2014 16:59:01 +0000

Of course if and when we make it a WG document, we've got details to discuss. But the authors believe this is a coherent document that covers all the bases for a set of design decisions (which was not true of the previous draft, which had some significant omissions). Made possible by the earlier acceptance (now at IETF LC) of the TLV extensions draft.

--
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

From: manet [mailto:[email-masked]] On Behalf Of Stan Ratliff (sratliff)
Sent: 29 January 2014 16:17
To: Ulrich Herberg; List List
Subject: Re: [manet] draft-dearlove-manet-olsrv2-multitopology-02 -> WG

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.
Chris/Thomas,

Working Group,

Regards,
Stan

Joe, Stan,

---------- Forwarded message ----------
From: Thomas Heide Clausen <[email-masked]<mailto:[email-masked]>>
Date: Wed, Jan 22, 2014 at 11:44 PM
Subject: Re: draft-dearlove-manet-olsrv2-multitopology-02 -> WG
To: Christopher Dearlove <[email-masked]<mailto:[email-masked]>>
Cc: Joe Macker <[email-masked]<mailto:[email-masked]>>, Stan Ratliff <[email-masked]<mailto:[email-masked]>>, Ulrich Herberg <[email-masked]<mailto:[email-masked]>>, Adrian Farrel <[email-masked]<mailto:[email-masked]>>

Respectfully,

Thomas

Joe, Stan

Christopher

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Wed, 29 Jan 2014 17:14:54 +0000

Hello again working group participants -

Ulrich reminds me that open-ended questions such as the one I asked are usually not a good idea. Therefore, I'll rephrase:

If there are any significant objections to accepting this document as a WG doc, please post to the list by Feb. 7. Otherwise, we will consider lack of comment as acceptance, and make the draft a WG document.

Regards,
Stan

On Jan 29, 2014, at 11:17 AM, Stan Ratliff (sratliff) <[email-masked]<mailto:[email-masked]>> wrote:

Chris/Thomas,

Working Group,

Regards,
Stan

Joe, Stan,

Thanks
Ulrich

---------- Forwarded message ----------
From: Thomas Heide Clausen <[email-masked]<mailto:[email-masked]>>
Date: Wed, Jan 22, 2014 at 11:44 PM
Subject: Re: draft-dearlove-manet-olsrv2-multitopology-02 -> WG
To: Christopher Dearlove <[email-masked]<mailto:[email-masked]>>
Cc: Joe Macker <[email-masked]<mailto:[email-masked]>>, Stan Ratliff <[email-masked]<mailto:[email-masked]>>, Ulrich Herberg <[email-masked]<mailto:[email-masked]>>, Adrian Farrel <[email-masked]<mailto:[email-masked]>>

Respectfully,

Thomas

Joe, Stan

Christopher

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 29 Jan 2014 23:21:28 +0100

Hello,

I think it is early for adopting and should need us asking for document
discussed on the list. My question before reading is why is this work
important for OLSR? Please explain or discuss.

Do we have priority works within milestone?Did we finish delay work to
adopt more work? Please help,

AB

On Wednesday, January 29, 2014, Stan Ratliff (sratliff) wrote:

>  Ulrich reminds me that open-ended questions such as the one I asked are
> usually not a good idea. Therefore, I'll rephrase:
>
>  If there are any significant objections to accepting this document as a
> WG doc, please post to the list by Feb. 7. Otherwise, we will consider lack
> of comment as acceptance, and make the draft a WG document.
>
>  Regards,
> Stan
>
>  On Jan 29, 2014, at 11:17 AM, Stan Ratliff (sratliff) <[email-masked]<javascript:_e({}, 'cvml', [email-masked]');>>
> wrote:
>
>  Chris/Thomas,
>
>  On Jan 29, 2014, at 11:14 AM, Ulrich Herberg <[email-masked]>
>  wrote:
>
>   Joe, Stan,
>
> From: *Thomas Heide Clausen* <[email-masked]>
> To: Christopher Dearlove <[email-masked]>
> Cc: Joe Macker <[email-masked]>, Stan Ratliff <
> [email-masked]>, Ulrich Herberg <[email-masked]>, Adrian Farrel <
> [email-masked]>
>
>
>  First, happy new year. I hope that you were able to spend some time with
> your loved ones over the holidays, and that health and happiness may be
> with you in the new year.
>
>  I wanted to remind you of the request from Chris (below), sent to you a
> bit more than a month ago. As I've seen no emails from you to regarding
> this, I permit myself to reiterate the request for WG adoption of
> draft-dearlove-manet-olsrv2-multitopolgy-02 - so that we may advance also
> this document forward, hopefully rapidly, towards publication as
> experimental RFC.
>
>  On 20 Dec 2013, at 17:07 , Dearlove, Christopher (UK) <
> [email-masked]> wrote:
>
>   Joe, Stan
>
>  We have submitted draft-dearlove-manet-olsrv2-multitopology-02, which
> includes what we knew we were missing from the previous draft.
>
>  We would therefore like to ask the WG to accept this. Obviously this
> close to the Christmas/New Year holiday, after those (as immediately after
> those as possible) would be appropriate. (Same timeframe as IETF LC on
> other drafts I hope).
>
> [email-masked] <javascript:_e({}, 'cvml', [email-masked]');>

---

From: Joe Macker <[email-masked]>
Date: Wed, 29 Jan 2014 19:51:25 -0500

To answer broadly, now that olsrv2 core document work is reaching its basic framework milestones in my opinion the consideration of such extension work is not delaying or harming other milestone work but is targets at extending and enhancing initial design capabilities.  As metric-based routing is matured and the support for multiple types of traffic flows is also considered multi-topology routing is a natural engineering candidate that network designers consider.  This is the basic applicability statement and is not a new concept although WG designs for OLSRv2 do not exist.  This is the value-added engineering purpose.
 
There are plenty of known operational reasons why one would consider multi topology routing and it already has precedence in being used with link state protocols.  Not saying its always the right choice but its a potential tool in your toolbox.
 
From the ID, its seems clear that its purpose is to specify a way to establish and maintain such topologies with OLSRv2 and related metrics support designs.  It would be great to hear from others in the WG what they think especially after they look over and read the document.

Regards,
-Joe

On Jan 29, 2014, at 5:21 PM, Abdussalam Baryun <[email-masked]> wrote:

> Hello,
> 
> I think it is early for adopting and should need us asking for document discussed on the list. My question before reading is why is this work important for OLSR? Please explain or discuss. 
> 
> Do we have priority works within milestone?Did we finish delay work to adopt more work? Please help,
> 
> AB
> 
> On Jan 29, 2014, at 11:17 AM, Stan Ratliff (sratliff) <[email-masked]> wrote:
> 
>> Chris/Thomas, 
>> 
>>> From: Thomas Heide Clausen <[email-masked]>
>>> Cc: Joe Macker <[email-masked]>, Stan Ratliff <[email-masked]>, Ulrich Herberg <[email-masked]>, Adrian Farrel <[email-masked]>
>>> 
>>> 
>>> On 20 Dec 2013, at 17:07 , Dearlove, Christopher (UK) <[email-masked]> wrote:
>>> 
>>>> Joe, Stan
>>>>  
>> [email-masked]
> [email-masked]

---

From: Christopher Dearlove <[email-masked]>
Date: Thu, 30 Jan 2014 01:22:18 +0000

To be even more definite, there is no other core work this is competing with. The only incomplete core work is the quite independent reactive protocol. All the core OLSRv2 documents are with the RFC Editor. There are two other OLSRv2 related documents in IETF LC, i.e. accepted by this WG, the primary purpose of one of which is to enable extensions such as this.

In short, the objection has no substance in this regard. On the positive side, Joe has described the basic reasons.

> On 30 Jan 2014, at 00:51, Joe Macker <[email-masked]> wrote:
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 30 Jan 2014 07:46:56 +0100

On Thursday, January 30, 2014, Joe Macker
>
>
> From the ID, its seems clear that its purpose is to specify a way to
> establish and maintain such topologies with OLSRv2 and related metrics
> support designs.  It would be great to hear from others in the WG what they
> think especially after they look over and read the document.
>

Thanks Joe. Ok, I will read the document, but usually I like to get
discussion/answers from authors on their individual drafts before reviewing
it but I did quickly look over it and I asked to get motivated.
The purpose mentioned in the draft was not clear to me why our WG-OLSRv2
cannot do multi-topology without this extension, so I need answer from
authors. Your above purpose does not describe why OLSRv2 is not able to do
what this draft can.

AB

---

From: Henning Rogge <[email-masked]>
Date: Thu, 30 Jan 2014 08:42:36 +0100

I say we should adopt this document as a WG doc, multitopology routing
without the need of multiple completely independent OLSRv2 instances
is one of the missing features of the protocol.

As I discussed with Christopher in Berlin we at Fraunhofer FKIE see
already two applications for MTR... one is multi-metric routing (e.g.
one metric measuring airtime use, another one delay), the other one is
overlapping network partitions (let everyone participating in normal
messages, but keep "priority/secret" messages among a subgroup of
nodes you explicitly trust).

Henning Rogge

On Wed, Jan 29, 2014 at 6:14 PM, Stan Ratliff (sratliff)
<[email-masked]> wrote:
> If there are any significant objections to accepting this document as a WG
> doc, please post to the list by Feb. 7. Otherwise, we will consider lack of
> comment as acceptance, and make the draft a WG document.
>
> Regards,
> Stan
>
> Cc: Joe Macker <[email-masked]>, Stan Ratliff
> <[email-masked]>, Ulrich Herberg <[email-masked]>, Adrian Farrel
> <[email-masked]>
>
>
> your loved ones over the holidays, and that health and happiness may be with
> you in the new year.
>
> I wanted to remind you of the request from Chris (below), sent to you a bit
> more than a month ago. As I've seen no emails from you to regarding this, I
> permit myself to reiterate the request for WG adoption of
> We would therefore like to ask the WG to accept this. Obviously this close
> to the Christmas/New Year holiday, after those (as immediately after those
> as possible) would be appropriate. (Same timeframe as IETF LC on other
> drafts I hope).
>
> [email-masked] | http://www.baesystems.com
>

---

From: <[email-masked]>
Date: Thu, 30 Jan 2014 07:54:12 +0000

Abdussalam,

> Ok, I will read the document, but usually I like to get discussion/answers from
> authors on their individual drafts before reviewing it but I did quickly look over it and I asked to get motivated.

So the authors have to spend time writing their draft and spend time answering your questions satisfactorily before you condescend to exert effort on reading their draft. Despite the fact that reading is a far quicker process than writing.

Your time must be far, far more valuable that that of the authors.

> was not clear to me why our WG-OLSRv2 cannot do multi-topology without this extension

it's mentioned in the draft that you haven't read.

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: manet [[email-masked]] On Behalf Of Abdussalam Baryun [[email-masked]]
Sent: 30 January 2014 06:46
To: Joe Macker
Cc: List List
Subject: Re: [manet] draft-dearlove-manet-olsrv2-multitopology-02 -> WG

>From the ID, its seems clear that its purpose is to specify a way to establish and maintain such topologies with OLSRv2 and related metrics support designs.  It would be great to hear from others in…

Thanks Joe. Ok, I will read the document, but usually I like to get discussion/answers from authors on their individual drafts before reviewing it but I did quickly look over it and I asked to get motivated.
The purpose mentioned in the draft was not clear to me why our WG-OLSRv2 cannot do multi-topology without this extension, so I need answer from authors. Your above purpose does not describe why OLSRv2 is not able to do what this draft can.

AB

---

From: Christopher Dearlove <[email-masked]>
Date: Thu, 30 Jan 2014 09:31:34 +0000

The point is of course once you have the tool, you can use it in various ways, Henning has mentioned two, no doubt others can find more. Of course if you have a use, WG discussion on whether this draft supports it, or supports it well, is what this is all about.

And as a reminder, the aim here at this time is experimental.

-- 
Christopher Dearlove
[email-masked] (iPhone)
[email-masked] (home)

> On 30 Jan 2014, at 07:42, Henning Rogge <[email-masked]> wrote:
>

---

From: Christopher Dearlove <[email-masked]>
Date: Thu, 30 Jan 2014 09:35:13 +0000

It happens at this time I'm on a train, so I'm just diverted from Edward Frenkel's book Love & Math. But reading the draft is always a good idea. If nothing else, read the Introduction. I don't have it in front of me to check how much background it gives, but I would expect it to do so, both in general and because that's our usual style.

> On 30 Jan 2014, at 07:54, <[email-masked]> wrote:
> 
> Abdussalam,
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 30 Jan 2014 12:52:30 +0100

Thanks Chris, I never object adoptions just need to know related
whys/informations, but I like discussions and answered questions,
which helps my readings background. The most important time is the WG
times, I opened a discussion question, and I think we needed to get a
motivation to start reading/reviewing.

AB

On 1/30/14, Christopher Dearlove <[email-masked]> wrote:
> It happens at this time I'm on a train, so I'm just diverted from Edward
> Frenkel's book Love & Math. But reading the draft is always a good idea. If
> nothing else, read the Introduction. I don't have it in front of me to check
> how much background it gives, but I would expect it to do so, both in
> general and because that's our usual style.
>
>> So the authors have to spend time writing their draft and spend time
>> answering your questions satisfactorily before you condescend to exert
>> effort on reading their draft. Despite the fact that reading is a far
>> quicker process than writing.
>>

---

From: Christopher Dearlove <[email-masked]>
Date: Thu, 30 Jan 2014 14:14:49 +0000

It's not actually up to me to motivate you, I'm not your supervisor.

> On 30 Jan 2014, at 11:52, Abdussalam Baryun <[email-masked]> wrote:
>

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Thu, 30 Jan 2014 15:10:45 +0000

Speaking as a working group participant, I support making the document a working group document.

Regards,
Stan

---

From: Joe Macker <[email-masked]>
Date: Thu, 30 Jan 2014 11:15:18 -0500

I also as a WG member support adoption.

-Joe