Subject: [manet] MANET Parameters Review (Related to IANA sections of RFC7181 - RFC7188)

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 22 Aug 2014 03:26:34 +0200

Reviewer: Abdussalam Baryun (AB)
Dated: 25.04.2014 (not completed)

This is AB review of the MANET parameters documents [1][2] that were
updated on 14.04.2014 in relation of the new RFCs [7181-7188]. However, not
completed for future review, but it may help.

[1] https://www.iana.org/assignments/manet-parameters/manet-parameters.txt
[2] ftp://ftp.ietf.org/iana/manet-parameters/manet-parameters.txt

Comments below as [AB]:

+++++++++++++++++++++++++++++++++++++++++

Mobile Ad hoc NETwork (MANET) Parameters

   Created
           2008-12-23

   Last Updated
           2014-04-14

   Available Formats
           [IMG]
           XML [IMG]
           HTML [IMG]
           Plain text
Created
           2008-12-23

   Last Updated
           2014-04-14

   Available Formats
           [IMG]
           XML [IMG]
           HTML [IMG]
           Plain text

   Registries included below

     * Message Types

     * TC Message-Type-specific Message TLV Types

[AB] please amend registery to: Message-Type-Specific Message TLV Types for
the TC Message Type.
 [AB] or amend registery to: Message-Type-Specific Message TLV Types for
Message Type 1.

     * TC Message-Type-specific Address Block TLV Types

 [AB] please amend registery to: Message-Type-Specific Address Block TLV
Types for the TC Message Type.
[AB] or amend registery to: Message-Type-Specific Address Block TLV Types
for Message Type 1.

     * Packet TLV Types
     * Message TLV Types

     * INTERVAL_TIME Message Type Extensions

[AB] INTERVAL_TIME is a message TLV Type, please amend from message Type to
message TLV Type

     * VALIDITY_TIME Message Type Extensions

[AB] VALIDITY_TIME is a message TLV Type, please amend from message Type to
message TLV Type.

     * MPR_WILLING Message Type Extensions

[AB] MPR_WILLING is a message TLV Type, please amend from message Type to
message TLV Type.

     * CONT_SEQ_NUM Message Type Extensions

[AB] CONT_SEQ_NUM is a message TLV Type, please amend from message Type to
message TLV Type.

-------------

I think the WG should review the parameters/registries.

AB

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 22 Aug 2014 09:24:44 +0000

You’d find people more receptive if you worded things as suggestions rather than instructions (which you can’t give). And it’s registry.

But putting that on one side, let’s consider your first, where you suggest changing "TC Message-Type-specific Message TLV Types" to "Message-Type-Specific Message TLV Types for the TC Message Type" (I’m going to ignore the much less useful type 1).

Why Type-specific rather than Type-Specific? Because that matches the source document case usage. Which, if I remember correctly, was the RFC Editor (who wanted to change a lot of the authors' usage). But not important either way.

The other suggested change, from an initial "TC Message" to a final "for the TC Message Type"? Both say the same thing. Some may prefer one, some may prefer the other. My preference is for not making IANA do things with little or no value.

(Until you've actually dealt with making registry changes through IANA, you may not realise it's a non-trivial process for all concerned.)

However your last four points appear (I haven't checked the registry directly) to be correct. But we may (given some recent comments by Adrian) have to address a separate naming issue here, and it would therefore probably be sensible to hold this until then.

-- 
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

From: manet [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: 22 August 2014 02:27
To: manet
Cc: [email-masked]; [email-masked]
Subject: [manet] MANET Parameters Review (Related to IANA sections of RFC7181 - RFC7188)

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here.
If you feel the email is suspicious, please follow this process.
Reviewer: Abdussalam Baryun (AB)
Dated: 25.04.2014 (not completed)
 
This is AB review of the MANET parameters documents [1][2] that were updated on 14.04.2014 in relation of the new RFCs [7181-7188]. However, not completed for future review, but it may help. 

Comments below as [AB]:

   Created
           2008-12-23

   Last Updated
           2014-04-14

   Available Formats
           [IMG]
           XML [IMG]
           HTML [IMG]
           Plain text
Created
           2008-12-23

   Last Updated
           2014-04-14

   Available Formats
           [IMG]
           XML [IMG]
           HTML [IMG]
           Plain text

     * Message Types

[AB] please amend registery to: Message-Type-Specific Message TLV Types for the TC Message Type.
[AB] or amend registery to: Message-Type-Specific Message TLV Types for Message Type 1.

[AB] please amend registery to: Message-Type-Specific Address Block TLV Types for the TC Message Type.
[AB] or amend registery to: Message-Type-Specific Address Block TLV Types for Message Type 1.
 
     * Packet TLV Types
     * Message TLV Types

[AB] INTERVAL_TIME is a message TLV Type, please amend from message Type to message TLV Type

[AB] VALIDITY_TIME is a message TLV Type, please amend from message Type to message TLV Type.

[AB] MPR_WILLING is a message TLV Type, please amend from message Type to message TLV Type.

[AB] CONT_SEQ_NUM is a message TLV Type, please amend from message Type to message TLV Type.

-------------

AB 
********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************