Subject: [manet] AD review of draft-ietf-manet-nhdp-optimization

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 20 Oct 2014 12:32:31 +0100

Authors,

Thanks for this document. I have done my AD review and have nothing to
add except to note that your work probably makes a slight security 
improvement by making the 2-hop neighbor relations more resilient to
short-term quality attacks (such as radio interference) on links. You
could add that to the Security Considerations section, but there is no
need to hold up the document while you think about that.

I will start the IETF last call.

Adrian

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 20 Oct 2014 13:46:30 +0200

Dear AD,

Thank you for having processed this document.

With regards to security, I think that the operative word in what you observe is “slight” ;) 

AFAIK, Chris is currently off the grid for a bit, but he should be back in a few days. My personal point of view, which made me not suggest text to this effect, was, that while it is true that it offers a bit more resilience, that in and by itself was "not enough” to be a security property that might affect the use (or not) of this extension. I can swing either way on this, though.

Glad that you are sending this document forward while we think about it.

Respectfully,

Thomas

> On Oct 20, 2014, at 13:32, Adrian Farrel <[email-masked]> wrote:
> 
> Authors,
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 21 Oct 2014 09:37:34 +0000

I think Adrian's comment makes the current text

   As such, this protocol introduces
   no new security considerations to an implementation of [RFC6130] or
   of any other protocol that uses it, such as [RFC7181].

Not quite 100% right, as that is a consideration, albeit as Thomas says not a very major one. To be more precise I might change "security considerations" to "vulnerabilities" and then could add something like: "It may sometimes provide a small improvement in availability against attacks such as short bursts of deliberate interference." (Wording just a suggestion.)

But I could live with it unchanged. Especially if any change caused a delay.

-- 
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Thomas Clausen
Sent: 20 October 2014 12:47
To: Adrian Farrel
Cc: [email-masked]; [email-masked]
Subject: Re: [manet] AD review of draft-ietf-manet-nhdp-optimization

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

Dear AD,

Respectfully,

Thomas

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet
********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************