Subject: [manet] I-D Action: draft-ietf-manet-dlep-07.txt

From: [email-masked]
Date: Fri, 24 Oct 2014 07:37:58 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Mobile Ad-hoc Networks Working Group of the IETF.

        Title           : Dynamic Link Exchange Protocol (DLEP)
        Authors         : Stan Ratliff
                          Bo Berry
                          Greg Harrison
                          Shawn Jury
                          Darryl Satterwhite
	Filename        : draft-ietf-manet-dlep-07.txt
	Pages           : 55
	Date            : 2014-10-24

Abstract:
   When routing devices rely on modems to effect communications over
   wireless links, they need timely and accurate knowledge of the
   characteristics of the link (speed, state, etc.) in order to make
   forwarding decisions. In mobile or other environments where these
   characteristics change frequently, manual configurations or the
   inference of state through routing or transport protocols does not
   allow the router to make the best decisions. A bidirectional, event-
   driven communication channel between the router and the modem is
   necessary.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-manet-dlep/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-manet-dlep-07

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-manet-dlep-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Henning Rogge <[email-masked]>
Date: Fri, 24 Oct 2014 17:16:16 +0200

It took a long time but I think it was worth all the work.

There will be an Open Source implementation of this draft available on
Olsr.org very soon (maybe just before Honolulu IETF).

Henning Rogge

On Fri, Oct 24, 2014 at 4:37 PM,  <[email-masked]> wrote:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Joseph Macker <[email-masked]>
Date: Sun, 26 Oct 2014 16:23:30 -0400

Henning:

A prototype implementation of the draft sounds really good.
Thanks for the post.

Regards,
-Joe

---

From: "Taylor, Rick" <[email-masked]>
Date: Mon, 27 Oct 2014 09:35:30 +0000

All,

As a follow up, there will be an MIT licensed DLEP router validator released onto GitHub as soon as I can get corporate signoff from my end (Hopefully before Hawaii).  So a grand interop is looking more possible.

Cheers,

Rick

From: manet [mailto:[email-masked]] On Behalf Of Joseph Macker
Sent: 26 October 2014 20:24
To: Henning Rogge
Cc: MANET IETF
Subject: Re: [manet] I-D Action: draft-ietf-manet-dlep-07.txt

Henning:

Regards,
-Joe

On Fri, Oct 24, 2014 at 11:16 AM, Henning Rogge <[email-masked]<mailto:[email-masked]>> wrote:
It took a long time but I think it was worth all the work.

Henning Rogge

On Fri, Oct 24, 2014 at 4:37 PM,  <[email-masked]<mailto:[email-masked]>> wrote:
> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

The information contained within this e-mail and any files attached to this e-mail is private and in addition may include commercially sensitive information. The contents of this e-mail are for the intended recipient only and therefore if you wish to disclose the information contained within this e-mail or attached files, please contact the sender prior to any such disclosure.

If you are not the intended recipient, any disclosure, copying or distribution is prohibited. Please also contact the sender and inform them of the error and delete the e-mail, including any attached files from your system.

Emails to Airbus DS Limited may be processed, recorded and monitored anywhere in the European Community.

Airbus DS Limited

Registered Office: Quadrant House, Celtic Springs, Coedkernew, Newport , NP10 8FZ.
Registered in England and Wales under company number 04191036

---

From: Rick Taylor <[email-masked]>
Date: Wed, 29 Oct 2014 14:56:04 +0000

All,

For those who are interested, the source for a sample DLEP-07 'router' 
is now available at: https://github.com/ricktaylor/dlep_router

The code does not actually route, but acts as a protocol validator by 
taking on the role of a DLEP router.  The license is MIT.

It has been successfully used to implement and validate a DLEP modem 
implementation, and hopefully will be of use to others.

Cheers,

Rick Taylor

On 27/10/14 09:35, Taylor, Rick wrote:
> All,
>
> As a follow up, there will be an MIT licensed DLEP router validator
> released onto GitHub as soon as I can get corporate signoff from my end
> (Hopefully before Hawaii).  So a grand interop is looking more possible.
>
> Cheers,
>
> Rick
>
> *From:*manet [mailto:[email-masked]] *On Behalf Of *Joseph Macker
> *Sent:* 26 October 2014 20:24
> *To:* Henning Rogge
> *Cc:* MANET IETF
> *Subject:* Re: [manet] I-D Action: draft-ietf-manet-dlep-07.txt
>
> Henning:
>
> On Fri, Oct 24, 2014 at 4:37 PM,  <[email-masked]
> <mailto:[email-masked]>> wrote:
>  >
>  > [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> The information contained within this e-mail and any files attached to
> this e-mail is private and in addition may include commercially
> sensitive information. The contents of this e-mail are for the intended
> recipient only and therefore if you wish to disclose the information
> contained within this e-mail or attached files, please contact the
> sender prior to any such disclosure.
>
> If you are not the intended recipient, any disclosure, copying or
> distribution is prohibited. Please also contact the sender and inform
> them of the error and delete the e-mail, including any attached files
> from your system.
>