Subject: Re: [manet] #61 (aodvv2): Difference between "broken" and "expired" (Submitted for Justin Dean)

From: "manet issue tracker" <[email-masked]>
Date: Wed, 18 Feb 2015 04:35:41 -0000

#61: Difference between "broken" and "expired" (Submitted for Justin Dean)

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 Except for the possibility of differences in error logging, the two states
 do not lead to any differences in processing.  They can be coalesced into
 a single state, which may properly be called the "Invalid" state.  No
 difficulties have been observed or mentioned on the mailing list.  With
 this resolution, the issue can be closed.  The corresponding changes have
 been made to the specification document.

-- 
-----------------------------------+------------------------------
 Reporter:  [email-masked]  |       Owner:  Charles Perkins
     Type:  defect                 |      Status:  closed
 Priority:  minor                  |   Milestone:
Component:  aodvv2                 |     Version:
 Severity:  Active WG Document     |  Resolution:  fixed
 Keywords:  broken, expired        |
-----------------------------------+------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/manet/trac/ticket/61#comment:1>
manet <http://tools.ietf.org/manet/>

---

From: Jiazi YI <[email-masked]>
Date: Wed, 25 Feb 2015 00:36:32 +0100

Hi,

>From the latest revision of the draft (
http://tools.ietf.org/html/draft-ietf-manet-aodvv2-06), I don't know how
the ticket is fixed.

For example, there are still definition of state "expired" and "broken".
Those two terms are still used in the drafts.

It's very kind that the author creates tickets based on the comments from
other participants -- I appreciate the efforts. But on the other hand, I
believe it would be even better to verify the issue with the one who raised
the comments before closing related tickets.

This comment applies to other tickets.

regards

Jiazi

On Wed, Feb 18, 2015 at 5:35 AM, manet issue tracker <
[email-masked]> wrote:

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 24 Feb 2015 16:05:39 -0800

Hello Jiazi,

A new revision of the draft will be forthcoming very shortly with this issue
resolution incorporated.  If there is any doubt or concern the ticket can be
reopened.

In this case, the request was to coalesce the states.  The states were
coalesced after a thoroughgoing review of the draft.

Regards,
Charlie P.

On 2/24/2015 3:36 PM, Jiazi YI wrote:
> Hi,
>
> From the latest revision of the draft 
> (http://tools.ietf.org/html/draft-ietf-manet-aodvv2-06), I don't know 
> how the ticket is fixed.
>
> For example, there are still definition of state "expired" and 
> "broken". Those two terms are still used in the drafts.
>
> It's very kind that the author creates tickets based on the comments 
> from other participants -- I appreciate the efforts. But on the other 
> hand, I believe it would be even better to verify the issue with the 
> one who raised the comments before closing related tickets.
>
> On Wed, Feb 18, 2015 at 5:35 AM, manet issue tracker 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Changes (by [email-masked] <mailto:[email-masked]>):
>
>      * status:  new => closed
>      * resolution:   => fixed
>
>
>     Comment:
>
>      Reporter: [email-masked] <mailto:[email-masked]> | 
>          Owner:  Charles Perkins
>     Ticket URL:
>     <http://trac.tools.ietf.org/wg/manet/trac/ticket/61#comment:1>
>     [email-masked] <mailto:[email-masked]>

-- 
Regards,
Charlie P.

---

From: Jiazi YI <[email-masked]>
Date: Wed, 25 Feb 2015 01:24:19 +0100

Hi,

In my opinion, the ticket is fixed only when the comments are reflected in
a published draft. So the ticket can get closed when:

      - related modification is made in a published draft, and
      - the ticket creator (in the case for this ticket, the comment
raiser), or the WG agrees that the issue is resolved.

Regarding to this ticket, without the actual text, it's hard for the WG
participants to tell if the ticket is resolved or not (actually, it's
confusing when checking the issue tracker and the latest revision of the
draft).

best

Jiazi

On Wed, Feb 25, 2015 at 1:05 AM, Charles E. Perkins <[email-masked]>
wrote:

> from other participants -- I appreciate the efforts. But on the other hand,
> I believe it would be even better to verify the issue with the one who
> raised the comments before closing related tickets.
>
>> Ticket URL: <http://trac.tools.ietf.org/wg/manet/trac/ticket/61#comment:1
>> >

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 24 Feb 2015 21:25:26 -0800

Hello Jiazi,

I think that's a very reasonable request.  I hope you'll be willing to
take a look!

Regards,
Charlie P.

On 2/24/2015 4:24 PM, Jiazi YI wrote:
> Hi,
>
> In my opinion, the ticket is fixed only when the comments are 
> reflected in a published draft. So the ticket can get closed when:
>
> Regarding to this ticket, without the actual text, it's hard for the 
> WG participants to tell if the ticket is resolved or not (actually, 
> it's confusing when checking the issue tracker and the latest revision 
> of the draft).
>
> best
>
> Jiazi
>
> On Wed, Feb 25, 2015 at 1:05 AM, Charles E. Perkins 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hello Jiazi,
>
>>     (http://tools.ietf.org/html/draft-ietf-manet-aodvv2-06), I don't
>>     know how the ticket is fixed.
>>
>>     It's very kind that the author creates tickets based on the
>>     comments from other participants -- I appreciate the efforts. But
>>     on the other hand, I believe it would be even better to verify
>>     the issue with the one who raised the comments before closing
>>     related tickets.
>>
>>          Reporter: [email-masked]
>>         <mailto:[email-masked]> |       Owner:  Charles Perkins

-- 
Regards,
Charlie P.