Subject: [manet] DLEP-15: Timers

From: RJ Atkinson <[email-masked]>
Date: Mon, 13 Jul 2015 15:45:06 -0400

Section 2, pages 8-9, have a discussion of timers,
which are optional.  

I think the current text is likely to lead to
non-interoperability between implementations 
that use timers and those that don’t support
timers.  

Requested Actions:
	Make implementation and use of the DLEP timers
	mandatory.  “MUST” instead of “SHOULD” or “MAY”.

	Add clearer discussion of DLEP Timers, the correct
	behavior, and put that into its own sub-section
	so that it is easy to locate by a naive reader
	who has not participated in the WG but has been
	handed an RFC and told to implement DLEP in a
	radio/router product.

Yours,

Ran

---

From: Henning Rogge <[email-masked]>
Date: Tue, 14 Jul 2015 10:09:58 +0200

Hi,

are you talking about the Heartbeat Timer or the Link Characteristics
Response Timer?

(or both?)

Henning Rogge

On Mon, Jul 13, 2015 at 9:45 PM, RJ Atkinson <[email-masked]> wrote:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: RJ Atkinson <[email-masked]>
Date: Tue, 14 Jul 2015 08:52:14 -0400

> On 14  Jul 2015, at 04:09 , Henning Rogge <[email-masked]> wrote:
> 
> Hi,
> 
> are you talking about the Heartbeat Timer
> or the Link Characteristics Response Timer?
> 
> (or both?)

My comment was intended to be generic - 
so it applies for all timers in DLEP.

My initial focus was the Heartbeat Timer,
but the same prospective interoperability
(e.g. unexpected results/behavior) issue 
applies to any timer where one side implements
the timer and the other side doesn’t.

It is entirely possible that this is merely
a matter of some additional text explaining
what happens in such cases and why those
outcomes are not problematic.

Thanks,

Ran