Subject: [manet] DLEP-15: Introductory text

From: RJ Atkinson <[email-masked]>
Date: Mon, 13 Jul 2015 15:41:10 -0400

1) Readability of DLEP Specification

I find it odd that some of the diagrams needed to understand
the DLEP Concept of Operations are buried in Appendix A and
Appendix B.

I would find the specification much more readable if a
distinct “Concept of Operations” sub-section were created
out of some existing text in 1.0 plus Appendices A & B.

1A) I would suggest that the existing 1.0 text be retained,
  but that 1.0 end after the phrase “…data loss and additional
  retransmissions on the link.”

1B) The remaining text from the current 1.0 should move into
    a new sub-section:
	"1.1  Concept of Operations”

1C)  This new subsection would also include the text (and
     crucially the diagrams) from current Appendices A & B.

2) DLEP Applicability

Being VERY familiar with the DOCSIS (including EuroDOCSIS) cable
modems, I am confident they will NOT be using DLEP.  Those cable
modem standards require a plain IP/Ethernet user interface.
Further, while cable modems do support varying data rates,
the data rates for a cable modem are **provisioned** from
a centralized provisioned system.  So DLEP really is not-applicable
to a cable modem system.

Separately, given the huge installed base of DSL systems
and WiFI/802.11 systems, I doubt that very many of the
already deployed DSL systems or WiFi/802.11 systems will
be upgraded to implement DLEP.

DLEP’s likely deployment base consists of IP/Ethernet-enabled
radios that are not already widely deployed as of the
date that the DLEP specification is published — plus maybe
some of the IP/Ethernet radios that are using PPPoE
extensions at present.

Requested Action:

	Please remove the mention of cable modems.  

	DLEP really is not applicable to cable modems, which 
	have a widely deployed set of inter-related standards
	(not including PPPoE and not likely to include DLEP).

Yours,

Ran

---

From: Rick Taylor <[email-masked]>
Date: Mon, 13 Jul 2015 19:49:02 +0000

Ran,

I'm happy to remove references to cable modems.  You make good points. DLEP is radios and sat-modems in reality.

I'll address your other concerns when I get back to the office.

Rick

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of RJ Atkinson
Sent: 13 July 2015 20:41
To: MANET IETF
Subject: [manet] DLEP-15: Introductory text

I find it odd that some of the diagrams needed to understand the DLEP Concept of Operations are buried in Appendix A and Appendix B.

I would find the specification much more readable if a distinct “Concept of Operations” sub-section were created out of some existing text in 1.0 plus Appendices A & B.

2) DLEP Applicability

Being VERY familiar with the DOCSIS (including EuroDOCSIS) cable modems, I am confident they will NOT be using DLEP.  Those cable modem standards require a plain IP/Ethernet user interface.
Further, while cable modems do support varying data rates, the data rates for a cable modem are **provisioned** from a centralized provisioned system.  So DLEP really is not-applicable to a cable modem system.

Separately, given the huge installed base of DSL systems and WiFI/802.11 systems, I doubt that very many of the already deployed DSL systems or WiFi/802.11 systems will be upgraded to implement DLEP.

DLEP’s likely deployment base consists of IP/Ethernet-enabled radios that are not already widely deployed as of the date that the DLEP specification is published — plus maybe some of the IP/Ethernet radios that are using PPPoE extensions at present.

Requested Action:

Yours,

Ran

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: Rick Taylor <[email-masked]>
Date: Thu, 16 Jul 2015 15:20:31 +0000

Ran,

I'm going to have to change my mind on this one.  I was kicking my ISP 
last night getting them to do a SNR reset on my ADSL2+ modem, and as I 
watched it bounce up and down I imagined a world where the modem used 
DLEP to inform my local network what connection speed I was getting, and 
I could trigger some kind of alert when the SNR changed to such a point 
that my bandwidth was restricted.

I don't think it is the authors' responsibility to take the current 
state of other standards bodies into account when writing introductory text.

I think we have a use-case in cable modems, just as we have in any other 
class of modem.

Rick

---

From: Rick Taylor <[email-masked]>
Date: Fri, 17 Jul 2015 10:17:52 +0000

Follow-up...

Yes, I understand the difference between a cable modems and an ADSL 
modems, but even in a centrally provisioned system, letting the routers 
at the spokes know that connection characteristics that the spoke modem 
is getting is useful.

Rick

---

From: RJ Atkinson <[email-masked]>
Date: Fri, 17 Jul 2015 15:45:19 -0400

> On 16  Jul 2015, at 11:20 , Rick Taylor <[email-masked]> wrote:
> 
> Ran,
> 

ADSL != DOCSIS Cable Modem.
My note was about DOCSIS Cable systems, including EuroDOCSIS.
So the paragraph above is non-responsive to my note about 
cable modems.

> state of other standards bodies into account when writing introductory text.

I’m not sure I agree with the sentence above, but really that
comment just above is irrelevant from an IETF process perspective.

Clearly it is the authors responsibility to take into account 
feedback from MANET WG members.  I am such a person.  I am very 
familiar with DOCSIS.  My team deployed the first DOCSIS modems 
on the planet back in the late 1990s. 

How familiar are you with how DOCSIS works ?

> I think we have a use-case in cable modems, just as we have in any other 

I like DLEP, but there is no DLEP use-case in cable modems.
Certainly one has not been outlined or shown here.  That
does not detract from the usefulness of DLEP.  It does make
the current claim in the DLEP-15 introduction look very silly.

Yours,

Ran

---

From: Henning Rogge <[email-masked]>
Date: Fri, 17 Jul 2015 21:48:41 +0200

> the current claim in the DLEP-15 introduction look very silly.

DLEP would allow the modem to tell the router about its link-speed...
which could be useful for multi-homed installations.

Henning Rogge

---

From: RJ Atkinson <[email-masked]>
Date: Fri, 17 Jul 2015 15:53:33 -0400

> On 17  Jul 2015, at 15:48 , Henning Rogge <[email-masked]> wrote:
> 

The cable router already knows the link-speed (both 
upstream and downstream) for each of its associated
cable modems.  The DOCSIS standard takes care of that.

Yours,

Ran

---

From: Henning Rogge <[email-masked]>
Date: Fri, 17 Jul 2015 22:00:48 +0200

> cable modems.  The DOCSIS standard takes care of that.

Does DOCSIS exports this data to an external user via UDP or TCP?

If you want to connect multiple modems to a single router you will not
be using the integrated ones.

Henning Rogge

---

From: RJ Atkinson <[email-masked]>
Date: Fri, 17 Jul 2015 18:55:39 -0400

> On 17  Jul 2015, at 16:00 , Henning Rogge <[email-masked]> wrote:
> 

As near as I can tell, the answer is yes, but the details vary.  
Many implementations have at least a read-only web interface.
All modems support the published DOCSIS MIB, and that can be 
read (but not written) from the user side of the CM.

I think DLEP is useful — in fact it is useful without even needing
to mention Cable Modems.  I’m confused that the authors are so
worried that deleting cable modems as a use case will harm DLEP
somehow, even though ample other use cases exist and are already
documented.

> If you want to connect multiple modems to a single router
> you will not be using the integrated ones.

True, but DOCSIS 3.0 already includes channel-bonding,
integrated inside the CM, that’s part of how a DOCSIS 3 
cable modem achieves higher data rates than the original 
DOCSIS 1.0 devices did.

Cheers,

Ran