Subject: [manet] Partial comments to draft-ietf-manet-aodvv2-11 -- section 5 & 6

From: Thomas Clausen <[email-masked]>
Date: Thu, 6 Aug 2015 17:44:17 +0200

All,

I stole a bit of time and transcribed my  dead-tree comments to section 5 & 6 — included (as a pdf inside a zip again, because of message size — apologies). Will endeavour to get remaining parts out as soon as possible.

I think that there are two  important points to make to this lot of comments:

		o	It is clear that the lack of a distinct conceptual routing set (as opposed to 
			mashing all together in a “routing table”) is the source of some complexity
			in the specification — see, for example, in the last paragraph before section 7. 

		o	It is also clear that the interface between the forwarding plane and the
			routing process is non-trivial — yet, the different “hooks needed” for the
			routing process to be able to operate are scattered through the document.

			A solid, normative, section assembling all these various requirements for
			access to the forwarding plane innards should be added to the document.

Again, apologies for sending my review piecemeal like that: it takes time to type up my comments (and, those who has had to do so can attest, to decipher my handwriting - which is why I am not just sending a scan).

Best,

Thomas

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Tue, 11 Aug 2015 12:56:08 +0000

Thomas,

> 
> Again, apologies for sending my review piecemeal like that: it takes time to
> type up my comments (and, those who has had to do so can attest, to
> decipher my handwriting - which is why I am not just sending a scan).
> 

No apologies necessary; we understand that this has to be fit-in, over, and around "the day job".

To the WG - the AODVv2 team committed to having an updated revision of the document 2 weeks after the meeting in Prague. That deadline is upon us. However, timing being what it is, we're faced with a conundrum - we simply haven't had the time to process all of Thomas' review comments. Therefore, any -12 version of AODVv2 produced this week would not include them. So, I'm asking for guidance from the WG: do we

1. Post a  -12 version of the document, knowing that a -13 is coming "soon" to address Thomas' review comments? Or, 
2. hold off on the -12 (thereby breaking our 2-week commitment), so that we may properly address the comments received to-date? 

FWIW, my preference is option 2, so I'm going to state that "silence on the list will be taken as agreement with option 2". 
Opposing opinions please? 

Regards,
Stan

_____________________________________________________
This electronic message and any files transmitted with it contains
information from iDirect, which may be privileged, proprietary
and/or confidential. It is intended solely for the use of the individual
or entity to whom they are addressed. If you are not the original
recipient or the person responsible for delivering the email to the
intended recipient, be advised that you have received this email
in error, and that any use, dissemination, forwarding, printing, or
copying of this email is strictly prohibited. If you received this email
in error, please delete it and immediately notify the sender.
_____________________________________________________

---

From: Henning Rogge <[email-masked]>
Date: Tue, 11 Aug 2015 15:14:56 +0200

> Opposing opinions please?

If the -12 draft is already done I would say post it... if it still
needs work, including the new reviews sounds better.

Henning Rogge

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 11 Aug 2015 14:11:14 +0000

It doesn't matter to me which approach you take, but if you follow 1, I probably won't read -12 and wait for -13 to be out. Exception: if someone says "could you read section X.Y.Z to see if it addresses your review comment" then I may (but no guarantees) do that.

-- 
Christopher Dearlove
Senior Principal Engineer
BAE Systems Applied Intelligence
__________________________________________________________________________

T:  +44 (0)1245 242194  |  E: [email-masked]

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai
BAE Systems Applied Intelligence Limited
Registered in England & Wales No: 01337451
Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Ratliff, Stanley
Sent: 11 August 2015 13:56
To: Thomas Clausen; manet
Subject: Re: [manet] Partial comments to draft-ietf-manet-aodvv2-11 -- section 5 & 6

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

*** WARNING ***
This message originates from outside our organization, either from an external partner or the internet. Consider carefully whether you should click on any links, open any attachments or reply. For additional information about Spearphishing, click here <http://intranet.ent.baesystems.com/howwework/security/spotlights/Pages/SpearphishingTips.aspx>. If you feel the email is suspicious, please follow this process. <http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>

Thomas,

> 
> Again, apologies for sending my review piecemeal like that: it takes 
> time to type up my comments (and, those who has had to do so can 
> attest, to decipher my handwriting - which is why I am not just sending a scan).
> 

1. Post a  -12 version of the document, knowing that a -13 is coming "soon" to address Thomas' review comments? Or, 2. hold off on the -12 (thereby breaking our 2-week commitment), so that we may properly address the comments received to-date? 

Regards,
Stan

_____________________________________________________
This electronic message and any files transmitted with it contains information from iDirect, which may be privileged, proprietary and/or confidential. It is intended solely for the use of the individual or entity to whom they are addressed. If you are not the original recipient or the person responsible for delivering the email to the intended recipient, be advised that you have received this email in error, and that any use, dissemination, forwarding, printing, or copying of this email is strictly prohibited. If you received this email in error, please delete it and immediately notify the sender.
_____________________________________________________
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Teco Boot <[email-masked]>
Date: Tue, 11 Aug 2015 16:36:07 +0200

I think option 2 and silence procedure is reasonable.

Can you suggest an ETA for option 2, -12 version? So it won't be open ended.

Teco

> Op 11 aug. 2015, om 14:56 heeft Ratliff, Stanley <[email-masked]> het volgende geschreven:
> 
> Thomas,
> 
>>

---

From: Thomas Clausen <[email-masked]>
Date: Thu, 13 Aug 2015 01:06:09 +0200

All,

Given that this is a working group document, I'd much prefer if the authors engage here, on the list, on each of the different points raised in the different reviews, to get consensus on a resolution for each, and then and only then post an updated I-D. 

I do not know if the WG needs 1 week, or 1 month, to discuss and resolve the raised issues. Moving ahead with outstanding issues, or issues-raised-and-presumed-yet-not-confirmed-resolved seems irregular.  Holding off several weeks with the authors working "behind the curtain" on new text, then publishing a monolithic update, makes it a lot harder, and much more time-consuming, for the working group to track if all issues have been properly addressed.

FWIW,  I do know that it's August, and in my neck of the woods that means people generally are on vacation and may not be checking mail religiously.

Best,

Thomas

> On 11 Aug 2015, at 14:56, Ratliff, Stanley <[email-masked]> wrote:
> 
> Thomas,
> 
>>

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 13 Aug 2015 15:16:31 +0200

I prefer to have draft -12 as it was the meeting suggestion and then we
review it. So maybe option 1, but I have no opposing to any option authors
take.

Thanks,
AB

On Tue, Aug 11, 2015 at 2:56 PM, Ratliff, Stanley <[email-masked]>
wrote:

> time to
> To the WG - the AODVv2 team committed to having an updated revision of the
> document 2 weeks after the meeting in Prague. That deadline is upon us.
> However, timing being what it is, we're faced with a conundrum - we simply
> haven't had the time to process all of Thomas' review comments. Therefore,
> any -12 version of AODVv2 produced this week would not include them. So,
> I'm asking for guidance from the WG: do we
>
> 1. Post a  -12 version of the document, knowing that a -13 is coming
> "soon" to address Thomas' review comments? Or,
> 2. hold off on the -12 (thereby breaking our 2-week commitment), so that
> we may properly address the comments received to-date?
>
> FWIW, my preference is option 2, so I'm going to state that "silence on
> the list will be taken as agreement with option 2".

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Fri, 14 Aug 2015 12:05:34 +0000

I don't believe I've seen any comments here on my comments that I made (just) before the meeting.

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Thomas Clausen
Sent: 13 August 2015 00:06
To: Ratliff, Stanley
Cc: manet
Subject: Re: [manet] Partial comments to draft-ietf-manet-aodvv2-11 -- section 5 & 6

*** WARNING ***

All,

Best,

Thomas

> To the WG - the AODVv2 team committed to having an updated revision of 
> the document 2 weeks after the meeting in Prague. That deadline is 
> upon us. However, timing being what it is, we're faced with a 
> conundrum - we simply haven't had the time to process all of Thomas' 
> review comments. Therefore, any -12 version of AODVv2 produced this 
> week would not include them. So, I'm asking for guidance from the WG: 
> do we
> 
> "soon" to address Thomas' review comments? Or, 2. hold off on the -12 (thereby breaking our 2-week commitment), so that we may properly address the comments received to-date?
> 
> information from iDirect, which may be privileged, proprietary and/or 
> confidential. It is intended solely for the use of the individual or 
> entity to whom they are addressed. If you are not the original 
> intended recipient, be advised that you have received this email in 
> error, and that any use, dissemination, forwarding, printing, or 
> copying of this email is strictly prohibited. If you received this 
> email in error, please delete it and immediately notify the sender.