Subject: [manet] Section 5.2 - handling implementation errors

From: RJ Atkinson <[email-masked]>
Date: Tue, 24 Nov 2015 11:28:22 -0500

Section 5.2 is quite clear (which is good) that 
“an implementation MUST NOT emit any … not specified
in the received initialization message from its peer”.

If a misbehaving implementation DID send a (message,
data item, signal, status code) that was NOT in the
received initialization message from the peer, how
ought the implementation react ?

My suggestion is that it ought to IGNORE the offending
(message, data item, signal, status code) and keep
going, but maybe the intended behavior is something
else (e.g. close the DLEP session and start over).

Either way, the correct behavior for the receiver of
invalid/unexpected stuff ought to be clearly specified.

(An old IETF motto is: “Be conservative in what one sends, 
and liberal in what one receives.”)

Thanks,

Ran

---

From: Henning Rogge <[email-masked]>
Date: Tue, 24 Nov 2015 17:43:22 +0100

> ought the implementation react ?

I think the standard reaction should be to drop the session completely.

Henning Rogge

---

From: Rick Taylor <[email-masked]>
Date: Tue, 24 Nov 2015 16:50:04 +0000

> I think the standard reaction should be to drop the session completely.

I think it is mentioned in Section 10.

Also, there is text in the Status codes about how to react after sending 
various codes, the mode for 'Invalid Data', 'Unexpected Message' are all 
'Terminate'.

Rick