Subject: [manet] I-D Action: draft-ietf-manet-rfc5444-usage-01.txt

From: [email-masked]
Date: Tue, 22 Dec 2015 06:42:30 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Mobile Ad-hoc Networks Working Group of the IETF.

        Title           : Rules For Designing Protocols Using the RFC 5444 Generalized Packet/ Message Format
        Authors         : Thomas Clausen
                          Christopher Dearlove
                          Ulrich Herberg
                          Henning Rogge
	Filename        : draft-ietf-manet-rfc5444-usage-01.txt
	Pages           : 19
	Date            : 2015-12-22

Abstract:
   This document updates the generalized MANET packet/message format,
   specified in RFC 5444, by providing rules and recommendations for how
   protocols can use that packet/message format.  In particular, the
   mandatory rules prohibit a number of uses of RFC 5444 that have been
   suggested in various proposals, and which would have led to
   interoperability problems, to the impediment of protocol extension
   development, and to an inability to use generic RFC 5444 parsers.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-manet-rfc5444-usage/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-manet-rfc5444-usage-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-manet-rfc5444-usage-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 22 Dec 2015 14:51:05 +0000

A quick note to say this mostly (a) cleans up quite a few things that often shouldn't have been there, (b) adds a few details in some places (most significantly discussing TLV efficiency better) and (c) stops the draft expiring.

In the new year the authors, plus of course any input from the WG, will consider if there are any other areas we should add to this draft, or whether we should go ahead and try to publish this basically as it is (corrections and clarifications included of course).

And if you see this in time, Happy Christmas and New Year. Otherwise hope it was good in hindsight.

Christopher

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 22 December 2015 14:43
To: [email-masked]
Cc: [email-masked]
Subject: [manet] I-D Action: draft-ietf-manet-rfc5444-usage-01.txt

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************