Subject: [manet] I-D Action: draft-ietf-manet-aodvv2-16.txt

From: [email-masked]
Date: Wed, 04 May 2016 03:00:08 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Mobile Ad-hoc Networks of the IETF.

        Title           : Ad Hoc On-demand Distance Vector Version 2 (AODVv2) Routing
        Authors         : Charles E. Perkins
                          Stan Ratliff
                          John Dowdell
                          Lotte Steenbrink
                          Victoria Mercieca
	Filename        : draft-ietf-manet-aodvv2-16.txt
	Pages           : 84
	Date            : 2016-05-04

Abstract:
   The Ad Hoc On-demand Distance Vector Version 2 (AODVv2) routing
   protocol is intended for use by mobile routers in wireless, multihop
   networks.  AODVv2 determines unicast routes among AODVv2 routers
   within the network in an on-demand fashion.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-manet-aodvv2/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-manet-aodvv2-16

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-manet-aodvv2-16

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Lotte Steenbrink <[email-masked]>
Date: Wed, 4 May 2016 14:49:07 +0200

Hello everyone,
based on the responses gathered during WGLC, we’ve published a new revision. Again, thank you for the constructive, detailed and helpful reviews and feedback. We know AODVv2 is a long document, so we’re grateful you made it through despite the very short notice and time frame.

Here’s a summary of what we’ve changed:

• Message types are now allocated from the Experimental range of the "Message Types“ namespace of RFC5444 and there is no golbal registry for MetricType allocations anymore.
• All messages except RERR are forwarded instead of regenerated*. The change from regeneration to forwarding was made possible by a bunch of other changes:
	+ ValidityTime has been removed.
	+ The AckReq flag is not part of a RREP anymore. Bidirectionality is checked with the use of RREP_Ack messages.
	+ Instructions on how to zero out the metric value when calculating the ICV have been added.

In consequence, the following changes were made as well:
	+ RREP are unicast again.
	+ Since RREP are unicast, they aren’t stored in the Multicast Route Message Set anymore. We relied on the MRMS to determine when a RREP_Ack wasn’t received within the expected time, so now the fact that we’re waiting for a RREP_Ack is recorded in the Neighbor Set. (So now checking if the RREP_Ack was expected means "go look in the neighbor set and see if the state is Unknown and the Timeout hasn't been reached yet." and the timer is handled as part of the Neighbor Set too.)

• <msg-hop-limit> is in use again.
• The  language used in the draft has been updated that while routes to prefixes can’t be directly requested, they *can* be discovered „on the fly“.
• The instructions on how to calculate and evaluate ICVs are more detailed and bullet point-y now.
• As suggested by Jiazi, the experiment description got its own section and has been extended.
• The applicability statement details which network characteristics might be problematic for AODVv2.
• Key Management considerations have ben added.
• Some language has (hopefully) been clarified based on the reviews by Ulrich and Jiazi.
• As requested by him, Thomas Clausen has ben removed from the Acknowledgements .

With kind regards,
Lotte Steenbrink

*RERRs are a special case since they are one hop messages: routers only pass on information about broken links if they concern their own routes. The exception is that if an RERR is triggered by an undeliverable packet, it's both a one-hop message from each router that deletes the route to all its neighbors, and also a message that needs forwarding multi-hop to PktSource.

> Am 04.05.2016 um 12:00 schrieb [email-masked]:
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet