Subject: [manet] Updated after meeting Draft Recharter

From: Justin Dean <[email-masked]>
Date: Thu, 12 May 2016 10:57:02 -0400

Thanks to everyone who was able to participate in the voice chat today
regarding the recharter.  Below is an updated draft charter based upon
discussions had in the chat.  I've also included inline comments with
(JWD ...) which of course will be removed when officially adopting the
draft.  If something is missing or misrepresented please provide
feedback on the list so we may adjust it and update it accordingly.
The plan is to present the charter to Alvaro for adoption to be
completed before the next IETF meeting so get your comments in ASAP.

DRAFT CHARTER

The purpose of the MANET working group is to standardize IP routing
protocol functionality suitable for wireless routing application
within both static and dynamic topologies with increased dynamics due
to node motion or other factors.

Approaches are intended to be relatively lightweight in nature,
suitable for multiple hardware and wireless environments, and address
scenarios where MANETs are deployed at the edges of an IP
infrastructure. Hybrid mesh infrastructures (e.g., a mixture of fixed
and mobile routers) should also be supported by MANET specifications
and management features.

The MANET WG is responsible for the maintenance of RFC5444, NHDP,
OLSRv2, and DLEP. Of possible particular interest: type extensions for
DLEP, security enhancements for RFC5444/NHDP/OLSRv2, best practices
for MANET deployment/management, source specific extensions for
OLSRv2, and import/export of routing state for NHDP/OLSRv2.

(JWD these are not promised deliverable items and we may want to
remove them and just go with maintenance without listing them, also
please correct me if I misrepresented the work talked about in the
webex meeting head on May 12th)

The MANET WG will standardize a multicast MANET protocol framework
based on previous work and lessons learned for scoped forwarding
within MANET networks.  As part of this framework the WG will produce
a well defined MANET multicast forwarding information base.

The WG will produce an informational draft outlining challenges and
best practices for deploying and managing MANET networks.

The MANET WG will interact with the PIM working group on issues
relating to the multicast work.  The WG will also pay attention to
other IETF and IRTF work that is addressing topics related to MANET
environments.

In summary, the WG will develop the following drafts:
(JWD MANET Management Document is removed as the requirement for
producing the document is no longer valid but the working group may
work on this if there is interest)

MANET Maintenance

 - DLEP multiple flow extensions (JWD updated item)

 (JWD RFC5444 Security Extensions document has been removed as a
deliverable but may still be worked upon under the auspices of MANET
maintenance.)
MANET Multicast

  - Multicast FIB (Standards)

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 12 May 2016 15:20:01 +0000

As you know I had to duck out early, and you were gone when I came back.

Also not for a specific item, but I presume would be permitted, is if anyone decided to work on concepts such as hierarchical or hybrid developments of OLSRv2. Someone actually mentioned one of those recently, but I’m not aware of anyone actively pushing one. But in case they did, I presume would be allowed.

--
Christopher Dearlove
Senior Principal Engineer
BAE Systems Applied Intelligence Laboratories
__________________________________________________________________________

T:  +44 (0)1245 242194  |  E: [email-masked]<mailto:[email-masked]>

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai<http://www.baesystems.com/ai>
BAE Systems Applied Intelligence Limited
Registered in England & Wales No: 01337451
Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

From: manet [mailto:[email-masked]] On Behalf Of Justin Dean
Sent: 12 May 2016 15:57
To: [email-masked]
Subject: [manet] Updated after meeting Draft Recharter

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.
*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.

Thanks to everyone who was able to participate in the voice chat today regarding the recharter.  Below is an updated draft charter based upon discussions had in the chat.  I've also included inline comments with (JWD ...) which of course will be removed when officially adopting the draft.  If something is missing or misrepresented please provide feedback on the list so we may adjust it and update it accordingly.  The plan is to present the charter to Alvaro for adoption to be completed before the next IETF meeting so get your comments in ASAP.

DRAFT CHARTER

The purpose of the MANET working group is to standardize IP routing protocol functionality suitable for wireless routing application within both static and dynamic topologies with increased dynamics due to node motion or other factors.

Approaches are intended to be relatively lightweight in nature, suitable for multiple hardware and wireless environments, and address scenarios where MANETs are deployed at the edges of an IP infrastructure. Hybrid mesh infrastructures (e.g., a mixture of fixed and mobile routers) should also be supported by MANET specifications and management features.

The MANET WG is responsible for the maintenance of RFC5444, NHDP, OLSRv2, and DLEP. Of possible particular interest: type extensions for DLEP, security enhancements for RFC5444/NHDP/OLSRv2, best practices for MANET deployment/management, source specific extensions for OLSRv2, and import/export of routing state for NHDP/OLSRv2.

(JWD these are not promised deliverable items and we may want to remove them and just go with maintenance without listing them, also please correct me if I misrepresented the work talked about in the webex meeting head on May 12th)

The MANET WG will standardize a multicast MANET protocol framework based on previous work and lessons learned for scoped forwarding within MANET networks.  As part of this framework the WG will produce a well defined MANET multicast forwarding information base.

The WG will produce an informational draft outlining challenges and best practices for deploying and managing MANET networks.

The MANET WG will interact with the PIM working group on issues relating to the multicast work.  The WG will also pay attention to other IETF and IRTF work that is addressing topics related to MANET environments.

(JWD MANET Management Document is removed as the requirement for producing the document is no longer valid but the working group may work on this if there is interest)

MANET Maintenance

 (JWD RFC5444 Security Extensions document has been removed as a deliverable but may still be worked upon under the auspices of MANET maintenance.)

MANET Multicast

  - Multicast FIB (Standards)
********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: James Nguyen <[email-masked]>
Date: Thu, 12 May 2016 11:43:22 -0400

On Thu, May 12, 2016 at 11:20 AM, Dearlove, Christopher (UK) <
[email-masked]> wrote:

> Also not for a specific item, but I presume would be permitted, is if
> anyone decided to work on concepts such as hierarchical or hybrid
> developments of OLSRv2. Someone actually mentioned one of those recently,
> but I’m not aware of anyone actively pushing one. But in case they did, I
> presume would be allowed.
>
>
>
+1

I'm interested in hierarchical OLSRv2 deployment.  In addition, I'm also
interested how to make OLSRv2 networks interoperable with other non-OLSRv2
networks.

James

> *-- *
>
>
>
>
> *Christopher Dearlove Senior Principal Engineer BAE Systems Applied
> Intelligence Laboratories *
> *__________________________________________________________________________
> *
> *T*:  +44 (0)1245 242194  |  *E: [email-masked]
>
> www.baesystems.com/ai
> *From:* manet [mailto:[email-masked]] *On Behalf Of *Justin Dean
> *Sent:* 12 May 2016 15:57
> *To:* [email-masked]
> *Subject:* [manet] Updated after meeting Draft Recharter
>
>
>
>
>
> **** WARNING ****
>
> *This message originates from outside our organisation, either from an
> external partner or the internet.*
>
> * Consider carefully whether you should click on any links, open any
> attachments or reply. For information regarding **Red Flags** that you
> can look out for in emails you receive, click here
> <http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.*
> * If you feel the email is suspicious, please follow this process
> <http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.*
>
> **** **WARNING ******
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>
>

-- 
James Nguyen
Email: [email-masked]

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 12 May 2016 15:50:32 +0000

Can you expand on the latter?

(I started writing my thoughts, but decided just to ask. Except my thoughts run to scenarios, which already work, which need new work?)

From: James Nguyen [mailto:[email-masked]]
Sent: 12 May 2016 16:43
To: Dearlove, Christopher (UK)
Cc: Justin Dean; [email-masked]
Subject: Re: [manet] Updated after meeting Draft Recharter

*** WARNING ***

On Thu, May 12, 2016 at 11:20 AM, Dearlove, Christopher (UK) <[email-masked]<mailto:[email-masked]>> wrote:
As you know I had to duck out early, and you were gone when I came back.

+1
I'm interested in hierarchical OLSRv2 deployment.  In addition, I'm also interested how to make OLSRv2 networks interoperable with other non-OLSRv2 networks.
James

T:  +44 (0)1245 242194<tel:%2B44%20%280%291245%20242194>  |  E: [email-masked]<mailto:[email-masked]>

From: manet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Justin Dean
Sent: 12 May 2016 15:57
To: [email-masked]<mailto:[email-masked]>
Subject: [manet] Updated after meeting Draft Recharter

*** WARNING ***

DRAFT CHARTER

MANET Maintenance

MANET Multicast

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

--
James Nguyen
Email: [email-masked]<mailto:[email-masked]>

---

From: Stan Ratliff <[email-masked]>
Date: Thu, 12 May 2016 11:56:58 -0400

> Can you expand on the latter?

Ditto. I'm interested in this as well, depending on the scenario.

Regards,
Stan

>
>
> (I started writing my thoughts, but decided just to ask. Except my
> thoughts run to scenarios, which already work, which need new work?)
>
>
>
> *-- *
>
>
>
>
> *From:* James Nguyen [mailto:[email-masked]]
> *Sent:* 12 May 2016 16:43
> *To:* Dearlove, Christopher (UK)
> *Cc:* Justin Dean; [email-masked]
> *Subject:* Re: [manet] Updated after meeting Draft Recharter
>
>
>
>
>
> **** WARNING ****
>
> external partner or the internet. Consider carefully whether you should
> click on any links, open any attachments or reply. For information
> regarding **Red Flags*
> * that you can look out for in emails you receive, click here
> <http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
> If you feel the email is suspicious, please follow this process

---

From: James Nguyen <[email-masked]>
Date: Thu, 12 May 2016 12:04:51 -0400

On Thu, May 12, 2016 at 11:50 AM, Dearlove, Christopher (UK) <
[email-masked]> wrote:

> You could take coalition force communication as an example.  If Force A
runs OLSRv2 and Force B runs any other non-OLSRv2 protocol, I'm interested
in making them interoperable.

Another case, natural disaster's search and rescue mission, how can we help
the law enforcement and the military to communicate well with each other?

---

From: Stan Ratliff <[email-masked]>
Date: Thu, 12 May 2016 12:32:00 -0400

> in making them interoperable.

Provided Force A is in one general locale, and Force B is in another, with
some finite number of pre-defined gateway points, I think that already
works. My interest is in environments where, due to mobility, the
connectivity of the two routing protocols in play overlaps, and/or in cases
where one protocol might be asked to carry traffic for the other (e.g.,
Force A gets dispersed to either side of a very wide formation, with Force
B in the middle - Can B carry A's traffic?).

The usual answer given in cases like this is to exploit route
redistribution - each protocol takes the other's routes as external. In
mobile scenarios, there's a whole host of problems associated with that. It
quickly gets to a "boiling the ocean" scenario, so I wonder if there's an
approach to bound at least part of the problem in order to focus on it and
get a resolution.

Regards,
Stan

>
> Another case, natural disaster's search and rescue mission, how can we
> help the law enforcement and the military to communicate well with each
> other?
>
>
>> *-- *
>>
>>
>>
>>

---

From: Christopher Dearlove <[email-masked]>
Date: Thu, 12 May 2016 19:00:28 +0100

I was thinking about a discussion at a lower level. Where are the packets going, what's missing from the basic capabilities each has, assuming a gateway between them. Which depends on questions like numbers of gateways, whether packets can transit networks and so on.

--  
Christopher Dearlove

> On 12 May 2016, at 17:04, James Nguyen <[email-masked]> wrote:
> 
> 
> 
>> On Thu, May 12, 2016 at 11:50 AM, Dearlove, Christopher (UK) <[email-masked]> wrote:
> > You could take coalition force communication as an example.  If Force A runs OLSRv2 and Force B runs any other non-OLSRv2 protocol, I'm interested in making them interoperable.  
> 
> Another case, natural disaster's search and rescue mission, how can we help the law enforcement and the military to communicate well with each other?  
>  
>> --
>> 
>> Christopher Dearlove
>> T:  +44 (0)1245 242194  |  E: [email-masked]
>> 
>> For information regarding Red Flags that you can look out for in emails you receive, click here.
>> If you feel the email is suspicious, please follow this process.
>> 
>>  
>> 
>>  
>> 
>> On Thu, May 12, 2016 at 11:20 AM, Dearlove, Christopher (UK) <[email-masked]> wrote:
>> 
>> T:  +44 (0)1245 242194  |  E: [email-masked]
>> 
>> For information regarding Red Flags that you can look out for in emails you receive, click here.
>> If you feel the email is suspicious, please follow this process.
>> 
>> *** WARNING ***

---

From: Teco Boot <[email-masked]>
Date: Fri, 13 May 2016 15:34:27 +0200

My thoughts on interconnecting MANETs are: what can we do when we have dst-src-routing in place?

Teco

> Op 12 mei 2016, om 20:00 heeft Christopher Dearlove <[email-masked]> het volgende geschreven:
>