Subject: [manet] I-D Action: draft-ietf-manet-rfc5444-usage-04.txt

From: [email-masked]
Date: Wed, 04 May 2016 10:04:44 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Mobile Ad-hoc Networks of the IETF.

        Title           : Rules For Designing Protocols Using the RFC 5444 Generalized Packet/ Message Format
        Authors         : Thomas Clausen
                          Christopher Dearlove
                          Ulrich Herberg
                          Henning Rogge
	Filename        : draft-ietf-manet-rfc5444-usage-04.txt
	Pages           : 24
	Date            : 2016-05-04

Abstract:
   RFC 5444 specifies a generalized MANET packet/message format and
   describes an intended use to multiplex MANET routing protocol
   messages that is mandated for use by RFC 5498.  This document updates
   RFC 5444 by providing rules and recommendations for how the
   multiplexer operates and how protocols can use the packet/message
   format.  In particular, the mandatory rules prohibit a number of uses
   of RFC 5444 that have been suggested in various proposals, and which
   would have led to interoperability problems, to the impediment of
   protocol extension development, and to an inability to use optional
   generic RFC 5444 parsers.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-manet-rfc5444-usage/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-manet-rfc5444-usage-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-manet-rfc5444-usage-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 4 May 2016 17:06:41 +0000

This includes all of the issues I listed in my previous email of comments made at WGLC.

The authors request starting all the post-WGLC things to do.

-- 
Christopher Dearlove
Senior Principal Engineer
BAE Systems Applied Intelligence Laboratories
__________________________________________________________________________

T:  +44 (0)1245 242194  |  E: [email-masked]

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai
BAE Systems Applied Intelligence Limited
Registered in England & Wales No: 01337451
Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 04 May 2016 18:05
To: [email-masked]
Cc: [email-masked]
Subject: [manet] I-D Action: draft-ietf-manet-rfc5444-usage-04.txt

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Justin Dean <[email-masked]>
Date: Wed, 4 May 2016 22:55:24 -0400

Ack. I'll talk with Stan ASAP and keep things moving.

Justin

---

From: Ulrich Herberg <[email-masked]>
Date: Wed, 4 May 2016 22:31:58 -0700

Thanks!

On Wed, May 4, 2016 at 7:55 PM, Justin Dean <[email-masked]> wrote:
> On Wed, May 4, 2016 at 1:06 PM, Dearlove, Christopher (UK)
> <[email-masked]> wrote:
>>

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 23 May 2016 08:26:16 +0300

So, how did that conversation with Mr. Ratliff go? Unless I've missed a datatracker notification, motion has grind to a halt regarding this doc?

Thomas

--
Thomas Heide Clausen  •  @thclausen  	• 	thomasclausen.org 
www.arkko.com/tools/allstats/thomasheideclausen.html

> On 05 May 2016, at 05:55, Justin Dean <[email-masked]> wrote:
> 
>> On Wed, May 4, 2016 at 1:06 PM, Dearlove, Christopher (UK) <[email-masked]> wrote:

---

From: Stan Ratliff <[email-masked]>
Date: Mon, 23 May 2016 11:17:31 -0400

Mr. Clausen,

The referenced discussion did take place. The consensus going forward was
to begin the post-WGLC effort (e.g. find a document shepherd, do  the
write-up, etc).

Regards,
Stan

On Mon, May 23, 2016 at 1:26 AM, Thomas Clausen <[email-masked]>
wrote:

> So, how did that conversation with Mr. Ratliff go? Unless I've missed a
> datatracker notification, motion has grind to a halt regarding this doc?
>
> Thomas
>
> --
>
> *Thomas Heide Clausen  <[email-masked]> •  @thclausen
> <http://twitter.com/thclausen>  •  thomasclausen.org
> <http://www.thomasclausen.org/>www.arkko.com/tools/allstats/thomasheideclausen.html
> <http://www.arkko.com/tools/allstats/thomasheideclausen.html>*
>

---

From: [email-masked]
Date: Mon, 30 May 2016 18:03:50 +0200

Mr. Ratliff,

> On 23 May 2016, at 17:17, Stan Ratliff <[email-masked]> wrote:
> 
> Mr. Clausen, 
> 
> The referenced discussion did take place.

Very well.

Given that you affirmed a week ago that:

> The consensus going forward was to begin the post-WGLC effort (e.g. find a document shepherd, do  the write-up, etc). 

I believe that it is legitimate to ask: has any progress been made by the chairs on those post-WGLC efforts?

WGLC closed 4+ weeks ago on this document. 

Thomas

> 
> Regards,
> Stan
> 
> 
> On Mon, May 23, 2016 at 1:26 AM, Thomas Clausen <[email-masked] <mailto:[email-masked]>> wrote:
> Thomas Heide Clausen  <mailto:[email-masked]> •  @thclausen  <http://twitter.com/thclausen> 	• 	thomasclausen.org  <http://www.thomasclausen.org/>
> www.arkko.com/tools/allstats/thomasheideclausen.html <http://www.arkko.com/tools/allstats/thomasheideclausen.html>
> 
> On 05 May 2016, at 05:55, Justin Dean <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> On Wed, May 4, 2016 at 1:06 PM, Dearlove, Christopher (UK) <[email-masked] <mailto:[email-masked]>> wrote:
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/manet <https://www.ietf.org/mailman/listinfo/manet>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/manet <https://www.ietf.org/mailman/listinfo/manet>
> 
>

---

From: Justin Dean <[email-masked]>
Date: Mon, 30 May 2016 12:19:37 -0400

Ack.  Thanks for the poke. This will be taken care of post haste.

Justin

On Mon, May 30, 2016 at 12:03 PM, <[email-masked]> wrote:

> The consensus going forward was to begin the post-WGLC effort (e.g. find a
> document shepherd, do  the write-up, etc).
>
>