Subject: [manet] Combined Gen-art and secdir LC review: draft-ietf-manet-smc-sec-threats-05

From: Robert Sparks <[email-masked]>
Date: Mon, 8 Aug 2016 10:17:48 -0500

I am the assigned Gen-ART and secdir reviewer for this draft. The 
General Area
Review Team (Gen-ART) reviews all IETF documents being processed by the IESG
for the IETF Chair. The secdir does the same for the security area 
directors.
Please treat these comments just like any other last call comments.

For more information on Gen-Art, please see the FAQ at
<https://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

For moe information on secdir, see the wiki at
<https://trac.tools.ietf.org/area/sec/trac/wiki/SecDirReview>

Document: draft-ietf-manet-smf-sec-threats-05
Reviewer: Robert Sparks
Review Date: 8 Aug 2016
IETF LC End Date: 11 Aug 2016
IESG Telechat date: 18 Aug 2016

Summary: Ready for publication as an Informational RFC

This draft provides a discussion of vulnerabilities in Simplified Multicast
Forwarding (SMF), focusing on attacking the Duplicate Packet Detection and
Relay Set Selection mechanisms. It positions itself as being useful 
information
for those deploying SMF as currently defined.  It does not propose 
mitigations,
but does have a section that identifies potential future work that might.

I have sent several editorial nits directly to the authors.

---

From: Thomas Clausen <[email-masked]>
Date: Tue, 9 Aug 2016 11:24:10 +0200

Hello Robert, all,

Thank you for this review. Much appreciated. As I understand it, there are no major issues to address?

If it is alright with you (& with our AD), We propose to fold the "nits" (as you call them) that you found in with a couple of "nits" raised by Alvaro already, and with whatever else the ongoing LC raises, and spin a revision capturing it all when the LC is closed?

Thanks again for your help,

Thomas

--
Thomas Heide Clausen  •  @thclausen  	• 	thomasclausen.org 
www.arkko.com/tools/allstats/thomasheideclausen.html

> On 8 Aug 2016, at 17:17, Robert Sparks <[email-masked]> wrote:
> 
> I am the assigned Gen-ART and secdir reviewer for this draft. The General Area
> for the IETF Chair. The secdir does the same for the security area directors.
> Relay Set Selection mechanisms. It positions itself as being useful information
> for those deploying SMF as currently defined.  It does not propose mitigations,
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Jari Arkko <[email-masked]>
Date: Thu, 18 Aug 2016 14:24:00 +0200

Many thanks for your review, Robert.

Jari