Subject: [manet] DLEP IP addr conflicting add/drop

From: "Wiggins, David - 0665 - MITLL" <[email-masked]>
Date: Thu, 20 Oct 2016 14:36:11 +0000

What should happen if a DLEP message contains an IPv4/6 Address or Attached
Subnet data item with Flags=Add, and also contains another data item with
the *same* IP address/subnet, but with Flags=Drop?  I don't think the
handling in this case specified.

I think this condition should result in a DLEP error, since it indicates
that the sender is quite confused.

This is similar to my message to the list on August 4, but this is a
different case.

David

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Thu, 20 Oct 2016 15:01:02 +0000

David,

The current thinking amongst the editing team is that these types of "logical inconsistencies" will, indeed, result in an error - the message should be acknowledged, but with a Status Data Item indicating the error. We've gone around and around as to whether the error should be fatal or not (e.g. is the mode "Terminate" or "Continue"). Our thinking is that the mode should be "Continue".

Any other opinions on that?

Regards,
Stan

From: manet [mailto:[email-masked]] On Behalf Of Wiggins, David - 0665 - MITLL
Sent: Thursday, October 20, 2016 10:36 AM
To: [email-masked]
Subject: [manet] DLEP IP addr conflicting add/drop

What should happen if a DLEP message contains an IPv4/6 Address or Attached Subnet data item with Flags=Add, and also contains another data item with the *same* IP address/subnet, but with Flags=Drop?  I don't think the handling in this case specified.

I think this condition should result in a DLEP error, since it indicates that the sender is quite confused.

This is similar to my message to the list on August 4, but this is a different case.

David

============================================================================================================================================
This electronic message and any files transmitted with it contains
information from iDirect, which may be privileged, proprietary
and/or confidential. It is intended solely for the use of the individual
or entity to whom they are addressed. If you are not the original
recipient or the person responsible for delivering the email to the
intended recipient, be advised that you have received this email
in error, and that any use, dissemination, forwarding, printing, or
copying of this email is strictly prohibited. If you received this email
in error, please delete it and immediately notify the sender.

---

From: "Wiggins, David - 0665 - MITLL" <[email-masked]>
Date: Thu, 20 Oct 2016 15:24:28 +0000

I could argue either way, but I'm fine with Continue.

David

From:  "Ratliff, Stanley" <[email-masked]>
Date:  Thursday, October 20, 2016 at 11:01 AM
To:  David Wiggins <[email-masked]>, "[email-masked]"
<[email-masked]>
Subject:  RE: DLEP IP addr conflicting add/drop

> David, 
>  
> The current thinking amongst the editing team is that these types of ³logical
> inconsistencies² will, indeed, result in an error  the message should be
> acknowledged, but with a Status Data Item indicating the error. We¹ve gone
> around and around as to whether the error should be fatal or not (e.g. is the
> mode ³Terminate² or ³Continue²). Our thinking is that the mode should be
> ³Continue². 
>  
> Subnet data item with Flags=Add, and also contains another data item with the
> *same* IP address/subnet, but with Flags=Drop?  I don't think the handling in
> this case specified.
> 
>  
>