Subject: [manet] [Technical Errata Reported] RFC7181 (4874)

From: RFC Errata System <[email-masked]>
Date: Thu, 1 Dec 2016 00:29:42 -0800 (PST)

The following errata report has been submitted for RFC7181,
"The Optimized Link State Routing Protocol Version 2".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7181&eid=4874

--------------------------------------
Type: Technical
Reported by: Nikolai Malykh <[email-masked]>

Section: 17.1

Original Text
-------------
   If the router changes its originator address, then:

   1.  If there is no Originator Tuple with:

       *  O_orig_addr = old originator address

       then create an Originator Tuple with:

       *  O_orig_addr := old originator address

       The Originator Tuple (existing or new) with:

       *  O_orig_addr = new originator address

       is then modified as follows:

       *  O_time := current time + O_HOLD_TIME

Corrected Text
--------------
   If the router changes its originator address, then:

   1.  If there is no Originator Tuple with:

       *  O_orig_addr = old originator address

       then create an Originator Tuple with:

       *  O_orig_addr := old originator address

       The Originator Tuple (existing or new) with:

       *  O_orig_addr = old originator address

       is then modified as follows:

       *  O_orig_addr := new originator address

       *  O_time := current time + O_HOLD_TIME

Notes
-----
At the time of the modification Originator Tuple with O_orig_addr = new originator address does not yet exist.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7181 (draft-ietf-manet-olsrv2-19)
--------------------------------------
Title               : The Optimized Link State Routing Protocol Version 2
Publication Date    : April 2014
Author(s)           : T. Clausen, C. Dearlove, P. Jacquet, U. Herberg
Category            : PROPOSED STANDARD
Source              : Mobile Ad-hoc Networks
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 1 Dec 2016 10:00:04 +0000

Author.

There is an issue, and the proposed resolution would work, and is probably the minimal textual change. But it's potentially confusing creating a tuple to immediately change it.

I can see two possible better (in my opinion) texts, I'd appreciate comment (especially from co-author) on preference to recommend as correction (including possibly for version I dislike).

NEW (1):

   1.  If there is an Originator Tuple with:

       then modify it as follows:

       otherwise create an Originator Tuple with:

NEW (2):

   1.  If there is an Originator Tuple with:

       then remove it.

   2.  Create an Originator Tuple with:

I think I prefer NEW (2).

-- 
Christopher Dearlove
Senior Principal Engineer
BAE Systems Applied Intelligence Laboratories
__________________________________________________________________________

T:  +44 (0)1245 242194  |  E: [email-masked]

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai
BAE Systems Applied Intelligence Limited
Registered in England & Wales No: 01337451
Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: 01 December 2016 08:30
To: [email-masked]; Dearlove, Christopher (UK); [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Technical Errata Reported] RFC7181 (4874)

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

The following errata report has been submitted for RFC7181, "The Optimized Link State Routing Protocol Version 2".

Section: 17.1

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party can log in to change the status and edit the report, if necessary. 

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************