Subject: [manet] Alissa Cooper's No Objection on draft-ietf-manet-dlep-26: (with COMMENT)

From: "Alissa Cooper" <[email-masked]>
Date: Wed, 14 Dec 2016 11:05:40 -0800

Alissa Cooper has entered the following ballot position for
draft-ietf-manet-dlep-26: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-manet-dlep/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

For the Latency and Relative Link Quality metrics, it seems like allowing
their measurement methods to be implementation-dependent reduces their
usefulness. If two different implementations calculate these in different
ways, then the results may not be comparable. Are these not meant to be
compared between different destination implementations?

---

From: "Taylor, Rick (External)" <[email-masked]>
Date: Thu, 15 Dec 2016 10:35:55 +0000

Hi Alissa,

Thank you for the review.  A few replies to your comments inline...

(Sorry for the multiple postings, but my local mailserver hates the IETF mailing lists)

> -----Original Message-----
> From: Alissa Cooper [mailto:[email-masked]]
> Sent: 14 December 2016 19:06
> To: The IESG
> Cc: [email-masked]; [email-masked]; manet-
> [email-masked]; [email-masked]; [email-masked]
> Subject: Alissa Cooper's No Objection on draft-ietf-manet-dlep-26:
> (with
> COMMENT)
>
> email addresses included in the To and CC lines. (Feel free to cut
> this introductory paragraph, however.)
>
>
> Please refer to
> https://www.ietf.org/iesg/statement/discuss-criteria.html
> For the Latency and Relative Link Quality metrics, it seems like
> allowing their measurement methods to be implementation-dependent
> reduces their usefulness. If two different implementations calculate
> these in different ways, then the results may not be comparable. Are
> these not meant to be compared between different destination implementations?

Yes, this is indeed a difficult issue.  The underlying concept behind DLEP is that modem implementers have their own low-level mechanisms for measuring such things as latency, and exposing these metrics to the routing layer rather than forcing the up layers to measure such things can be useful.  However, we didn't want to prescribe how a lower-layer might calculate such metrics, as we couldn't see a 'one size fits all' mechanism being useful.

When comparing metrics between destinations reported by a single modem, it is considered a safe assumption that the metrics are sensibly comparable.  When comparing metrics reported between different modems, it gets more complicated.  For metrics such as latency, it's fairly well understood what latency means.  However, for Relative Link Quality, that is by design subjective, the suggestion from DLEP is that this metric is most useful when used as a modifier to other metrics, hence the second paragraph in Section 11.18 and 11.19.

Hope that goes some way to explaining our rationale?

Regards,

Rick Taylor
The information contained within this e-mail and any files attached to this e-mail is private and in addition may include commercially sensitive information. The contents of this e-mail are for the intended recipient only and therefore if you wish to disclose the information contained within this e-mail or attached files, please contact the sender prior to any such disclosure.

If you are not the intended recipient, any disclosure, copying or distribution is prohibited. Please also contact the sender and inform them of the error and delete the e-mail, including any attached files from your system.

Emails to Airbus Defence and Space Limited may be processed, recorded and monitored anywhere in the European Community.

Airbus Defence and Space Limited

Registered Office: Gunnels Wood Road, Stevenage, Hertfordshire, SG1 2AS.
Registered in England and Wales under company number 02449259.

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 15 Dec 2016 09:09:49 -0500

Hi Rick,

> On Dec 15, 2016, at 5:35 AM, Taylor, Rick (External) <[email-masked]> wrote:
> 
> Hi Alissa,
> 
> When comparing metrics between destinations reported by a single modem, it is considered a safe assumption that the metrics are sensibly comparable.  When comparing metrics reported between different modems, it gets more complicated.  For metrics such as latency, it's fairly well understood what latency means.  

I believe that, but as Mirja points out, the document doesn’t specify whether what is being reported is an average or max or min over some period of time. It seems like at least a little more detail could be provided to make this one more useful. 

> However, for Relative Link Quality, that is by design subjective, the suggestion from DLEP is that this metric is most useful when used as a modifier to other metrics, hence the second paragraph in Section 11.18 and 11.19.

Makes sense. That point is quite implicit in those two paragraphs, so it may be worth stating it more explicitly as you do above.

Thanks,
Alissa

---

From: Rick Taylor <[email-masked]>
Date: Thu, 15 Dec 2016 15:45:22 +0000

Hi Alissa,

On Thu, 2016-12-15 at 09:09 -0500, Alissa Cooper wrote:
> > Yes, this is indeed a difficult issue.  The underlying concept
> > behind DLEP is that modem implementers have their own low-level
> > mechanisms for measuring such things as latency, and exposing these
> > metrics to the routing layer rather than forcing the up layers to
> > measure such things can be useful.  However, we didn't want to
> > prescribe how a lower-layer might calculate such metrics, as we
> > couldn't see a 'one size fits all' mechanism being useful.
> > 
> > When comparing metrics between destinations reported by a single
> > modem, it is considered a safe assumption that the metrics are
> > sensibly comparable.  When comparing metrics reported between
> > different modems, it gets more complicated.  For metrics such as
> > latency, it's fairly well understood what latency means.  
> I believe that, but as Mirja points out, the document doesn’t specify
> whether what is being reported is an average or max or min over some
> period of time. It seems like at least a little more detail could be
> provided to make this one more useful. 

Ironically, there is a draft that has just been adopted by the WG, that
describes a DLEP extension for min/max for the latency metric.

The first paragraph of Section 4 attempts to suggest that metrics
should be an (perhaps rolling) average over a "...large enough sample
sizes will preclude short traffic bursts from adversely skewing
reported values..."

But perhaps that text needs improving? 

Thanks,

Rick

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 15 Dec 2016 12:56:46 -0500

Hi Rick,

> On Dec 15, 2016, at 10:45 AM, Rick Taylor <[email-masked]> wrote:
> 

Oh good.

> But perhaps that text needs improving? 

I would say so, I found it to be vague.

Thanks,
Alissa