Subject: Re: [manet] Call for acceptance as Working Group documents

From: Henning Rogge <[email-masked]>
Date: Tue, 6 Dec 2016 12:26:35 +0100

On Mon, Nov 28, 2016 at 4:26 PM, Stan Ratliff <[email-masked]> wrote:
> Hello working group participants,
>
> One of the items identified during the WG meeting in Seoul was to formally
> request, via the list, Working Group adoption of 5 extension drafts related
> to DLEP. This email is that formal request.
>
> The drafts are:
> 1.
> https://tools.ietf.org/html/draft-cheng-manet-dlep-latency-extension-00.html
> 2. https://tools.ietf.org/html/draft-cheng-manet-dlep-pause-extension-00
> 3. https://tools.ietf.org/html/draft-cheng-manet-dlep-multi-hop-extension-00
> 4. https://tools.ietf.org/html/draft-cheng-manet-dlep-latency-extension-00
> 5. https://tools.ietf.org/html/draft-cheng-manet-dlep-da-credit-extension-00

All of these drafts contain valid (and important) extensions for DLEP,
as long as we keep in mind that we might need to shuffle the ideas
around between documents I definitely support adopting them.

establishing a concept of "flows" for DLEP would be a good start for a
more generic document, which we then could use to describe how to
select these flows (e.g. DSCP) and how they are handled by the radio
(e.g. prioritization order) and to control the flow for each of them.

Henning

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Tue, 6 Dec 2016 17:56:07 +0000

Henning, 

Interesting. You're the second person I've heard lately that mentioned the notion of DLEP flows.

So, what do you envision a DLEP flow to look like? I'll be honest - this sounds like a lot of complexity, and I'm not entirely sure what it buys us. Can you enlighten me? 

Regards,
Stan

> -----Original Message-----
> From: manet [mailto:[email-masked]] On Behalf Of Henning Rogge
> Sent: Tuesday, December 06, 2016 6:27 AM
> To: Stan Ratliff <[email-masked]>
> Cc: MANET IETF <[email-masked]>
> Subject: Re: [manet] Call for acceptance as Working Group documents
> 
> > One of the items identified during the WG meeting in Seoul was to
> > formally request, via the list, Working Group adoption of 5 extension
> > drafts related to DLEP. This email is that formal request.
> >
> > The drafts are:
> > 1.
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht
> > ml_draft-2Dcheng-2Dmanet-2Ddlep-2Dlatency-2Dextension-
> 2D00.html&d=DgIC
> > Ag&c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbLW5r8KZAL9L_yqNON1dbKtMa-Wbx
> > na8&m=BCoPI7uYl2VWWZLOiT2_hvChwZeOzOv5lfyrfADyR_8&s=0WQ-
> snJj88VGKf7xJj
> > 3iHvybVGepqcFgS1dnP_67erE&e= 2.
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht
> > ml_draft-2Dcheng-2Dmanet-2Ddlep-2Dpause-2Dextension-
> 2D00&d=DgICAg&c=Ll
> > UvidvlhStGUSxQl0giOA&r=QzgCKlK-eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=B
> >
> CoPI7uYl2VWWZLOiT2_hvChwZeOzOv5lfyrfADyR_8&s=Cy0zgSTLb9cojir1_ars
> JUAqn
> > lWqY3yr2_cJGplaSfA&e= 3.
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht
> > ml_draft-2Dcheng-2Dmanet-2Ddlep-2Dmulti-2Dhop-2Dextension-
> 2D00&d=DgICA
> > g&c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbLW5r8KZAL9L_yqNON1dbKtMa-Wbxn
> >
> a8&m=BCoPI7uYl2VWWZLOiT2_hvChwZeOzOv5lfyrfADyR_8&s=iPynr3nKX2q
> hgYAEdfd
> > oEJAblVkiRDiQCgQ1oS8BtbQ&e= 4.
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht
> > ml_draft-2Dcheng-2Dmanet-2Ddlep-2Dlatency-2Dextension-
> 2D00&d=DgICAg&c=
> > LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m
> >
> =BCoPI7uYl2VWWZLOiT2_hvChwZeOzOv5lfyrfADyR_8&s=3Zl09TGLH5nuj_vy
> h8ih-GL
> > BQzufwZxd6g-2DK1JHm4&e= 5.
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht
> > ml_draft-2Dcheng-2Dmanet-2Ddlep-2Dda-2Dcredit-2Dextension-
> 2D00&d=DgICA
> > g&c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbLW5r8KZAL9L_yqNON1dbKtMa-Wbxn
> >
> a8&m=BCoPI7uYl2VWWZLOiT2_hvChwZeOzOv5lfyrfADyR_8&s=XN5_qWwK2
> x8PWHRRT8y
> > xW9Dv6hITxVGv4xxGBQ4o9JY&e=
> 
> All of these drafts contain valid (and important) extensions for DLEP, as long
> as we keep in mind that we might need to shuffle the ideas around between
> documents I definitely support adopting them.
> 
> establishing a concept of "flows" for DLEP would be a good start for a more
> generic document, which we then could use to describe how to select these
> flows (e.g. DSCP) and how they are handled by the radio (e.g. prioritization
> order) and to control the flow for each of them.
> 
> Henning
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_manet&d=DgICAg&c=LlUvidvlhStGUSx
> Ql0giOA&r=QzgCKlK-eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=BCoPI7uYl2VWWZLOiT2_hvChwZeOzOv5lfyrfADyR_8&s=ADneD
> atu54Qas369e3xZr1qA4a6zsMVEVzReVdEUjYo&e=

============================================================================================================================================
This electronic message and any files transmitted with it contains
information from iDirect, which may be privileged, proprietary
and/or confidential. It is intended solely for the use of the individual
or entity to whom they are addressed. If you are not the original
recipient or the person responsible for delivering the email to the
intended recipient, be advised that you have received this email
in error, and that any use, dissemination, forwarding, printing, or
copying of this email is strictly prohibited. If you received this email
in error, please delete it and immediately notify the sender.

---

From: Henning Rogge <[email-masked]>
Date: Fri, 9 Dec 2016 16:10:08 +0100

> So, what do you envision a DLEP flow to look like? I'll be honest - this sounds like a lot of complexity, and I'm not entirely sure what it buys us. Can you enlighten me?

Anything that provide different DLEP data (or even different flow
control) not based on the destination MAC address.

Easiest example is DSCP-based priority classes... but maybe also
things like a special "voice slot" in a TDMA waveform... or
reservation based mechanisms in TDMA.

Henning