Subject: [Manycouches] identifying issues with O(1000) folks at home...

From: Stephen Farrell <[email-masked]>
Date: Fri, 1 Jul 2016 15:13:02 +0100

Hiya,

So I think our task here is to identify issues and possible
experiments that might help explore those issues.

Here are some issues, please add yours and/or argue about
these:

- How to approach the intractable timezone problem
- Mechanics of such large numbers connecting at once
  (incl. handling failures, incl. warm-body fails)
- Impacts on funding, meeting fees, sponsors,...
- How to make up for being anti-social with us all
  sitting on couches alone
- How to be (more) effective in getting work done
  while
- Security and privacy issues with such a fully
  online meeting - a new style of meeting network
  and NOC?
- Phasing in stuff, when to run what experiments?
- Maximising overall cost (incl. time) reduction
  for participants, esp. those for whom cost (incl.
  time) is a bigger deal
- Is there still a need for at least a vestigial
  meeting site?
- If we could do this, wouldn't companies quickly reduce
  what they're willing to pay to send a person to a
  physical IETF meeting?

I think it'd be good to bat these about for a bit and
then see if we figure if we have a near (enough) complete
list and if we think some one of us could draft a
paragraph describing the issue that'd be non-controversial.

Separately, we might also want to talk about whether we or
a subset of us might want to get together in Berlin. And if
so... when. I guess unless there's a resounding "no, don't
want to meet" we should start a doodle poll and see which
is the least bad slot.

Lastly, please do feel very free to question the entire
framing of the issues or overall discussion here.

S.

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 6 Jul 2016 10:15:52 +0100

No responses?

S.

On 01/07/16 15:13, Stephen Farrell wrote:
> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches
>

---

From: S Moonesamy <[email-masked]>
Date: Wed, 06 Jul 2016 03:08:59 -0700

Hi Stephen,
>paragraph describing the issue that'd be non-controversial.

The above is a good list to start with as I could classify some of 
the issues within what is in the list.

For ease of discussion I'll define the problem differently: how to 
move from discussing by writing to each other to discussing where we 
can all talk to each other.  I'll assume that there aren't any 
technical problems to tackle.

The first issue is scheduling as I'll have to choose a time (and a 
date) which is convenient to most of the participants instead of 
following the local time zone.  The second issue is that some people 
might find video from the home intrusive.  There is already the 
ability to hold virtual meetings.  That could be used to phase in stuff.

At the moment we are familiar with a WG slot work style.  Although 
there isn't a common practice across all WGs, we don't have to be 
concerned about that as there is some work being done at the end of 
the day.  Should the existing work style be mapped directly into the 
remote thing?  Here's a different angle; your constraint is that you 
are not allowed to use email for this design team.  How do you proceed?

Regards,
S. Moonesamy

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 6 Jul 2016 11:22:51 +0100

(Please feel free to make a better subject line:-)

On 06/07/16 11:08, S Moonesamy wrote:
> 
> The first issue is scheduling as I'll have to choose a time (and a date)
> which is convenient to most of the participants instead of following the
> local time zone.  

Well, with O(1000) remote folks, maybe we'll not really have any
"local" TZ at all.

I'm not sure there's any good way to handle TZ pain generally. One
not-great idea might be to have say 3 slots/sessions per WG during
a week (or two) where those are chosen to spread the TZ pain for
most participants, at the cost of some agenda repetition and of
fairly severe TZ pain for the most active participants/chairs.

That seems pretty awful, but maybe less so if one compares it to
the costs (time/money) of a full week's travel.

> The second issue is that some people might find video
> from the home intrusive.  There is already the ability to hold virtual
> meetings.  That could be used to phase in stuff.

I'd assume that video from the home/couch would be opt-in,
and that people can work around that ok.

> 
> At the moment we are familiar with a WG slot work style.  Although there
> isn't a common practice across all WGs, we don't have to be concerned
> about that as there is some work being done at the end of the day. 
> Should the existing work style be mapped directly into the remote
> thing? 

I'd guess that we'd want to start (via experiments) with something
that's relatively familiar for participants and then see how that
evolves.

> Here's a different angle; your constraint is that you are not
> allowed to use email for this design team.  How do you proceed?

I don't get the question tbh. I'm assuming that work on the mailing
list proceeds as it always ought.

Cheers,
S.

---

From: S Moonesamy <[email-masked]>
Date: Wed, 06 Jul 2016 03:49:06 -0700

Hi Stephen,
>(Please feel free to make a better subject line:-)

Ok. :-)

>Well, with O(1000) remote folks, maybe we'll not really have any

Even if we do not have any "local" TZ set it will be way past normal 
working hours for some folks and close to normal working hours for some folks.

>fairly severe TZ pain for the most active participants/chairs.

Yes.

>the costs (time/money) of a full week's travel.

I thought of remote hubs to reduce the cost instead of having 
everyone under one roof.  It might defeat the purpose of going fully-remote.

>and that people can work around that ok.

Ok.

Regards
S. Moonesamy

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 6 Jul 2016 12:27:24 +0100

On 06/07/16 11:49, S Moonesamy wrote:
>>
> 
> I thought of remote hubs to reduce the cost instead of having everyone
> under one roof.  It might defeat the purpose of going fully-remote.

I'd say remote hubs would be practical in some locations
(e.g. Boston, Santa Clara). It'd probably not be something
that'd work for me or you today, but maybe over time even
places like where we are might grow such things, if they
were sufficiently local to not require travel/hotels, and
were (somehow) a bit of fun. Definitely a thing to consider
though.

S.