Subject: [Manycouches] identifying issues with O(1000) folks at home...

From: Alexa Morris <[email-masked]>
Date: Thu, 21 Jul 2016 03:07:34 -0700

Catching up by skimming the archives and I have a couple of questions — I’ve copied and pasted the relevant email below. 

I think Stephen’s list is a good first list of issues. My questions are: what is the problem that we are trying to solve? Why are we undertaking this effort? 

SM said, "For ease of discussion I'll define the problem differently: how to move from discussing by writing to each other to discussing where we can all talk to each other.” 

Why do we want to move from discussing while writing to discussing while talking? Do we think that a mega-virtual meeting will progress technical work faster than a series of interim meetings? 

Note: I’m not arguing that we shouldn’t be trying to do this but I don’t yet understand why the trend of increased remote participation means that a mega-virtual meeting is a logical next step. (Except, potentially, in the case where a F2F meeting is cancelled at the last minute due to emergency). 

Alexa

Hi Stephen,
At 07:13 01-07-2016, Stephen Farrell wrote:
>So I think our task here is to identify issues and possible
>experiments that might help explore those issues.
>
>Here are some issues, please add yours and/or argue about
>these:
>
>- How to approach the intractable timezone problem
>- Mechanics of such large numbers connecting at once
>   (incl. handling failures, incl. warm-body fails)
>- Impacts on funding, meeting fees, sponsors,...
>- How to make up for being anti-social with us all
>   sitting on couches alone
>- How to be (more) effective in getting work done
>   while
>- Security and privacy issues with such a fully
>   online meeting - a new style of meeting network
>   and NOC?
>- Phasing in stuff, when to run what experiments?
>- Maximising overall cost (incl. time) reduction
>   for participants, esp. those for whom cost (incl.
>   time) is a bigger deal
>- Is there still a need for at least a vestigial
>   meeting site?
>- If we could do this, wouldn't companies quickly reduce
>   what they're willing to pay to send a person to a
>   physical IETF meeting?
>
>I think it'd be good to bat these about for a bit and
>then see if we figure if we have a near (enough) complete
>list and if we think some one of us could draft a
>paragraph describing the issue that'd be non-controversial.

The above is a good list to start with as I could classify some of 
the issues within what is in the list.

For ease of discussion I'll define the problem differently: how to 
move from discussing by writing to each other to discussing where we 
can all talk to each other.  I'll assume that there aren't any 
technical problems to tackle.

The first issue is scheduling as I'll have to choose a time (and a 
date) which is convenient to most of the participants instead of 
following the local time zone.  The second issue is that some people 
might find video from the home intrusive.  There is already the 
ability to hold virtual meetings.  That could be used to phase in stuff.

At the moment we are familiar with a WG slot work style.  Although 
there isn't a common practice across all WGs, we don't have to be 
concerned about that as there is some work being done at the end of 
the day.  Should the existing work style be mapped directly into the 
remote thing?  Here's a different angle; your constraint is that you 
are not allowed to use email for this design team.  How do you proceed?

Regards,
S. Moonesamy 

----------
Alexa Morris / Executive Director / IETF
+1.510.492.4001
Email: [email-masked]

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 21 Jul 2016 15:00:19 +0200

Hi, Alexa,

On Thu, Jul 21, 2016 at 12:07 PM, Alexa Morris <[email-masked]> wrote:

> Catching up by skimming the archives and I have a couple of questions —
> I’ve copied and pasted the relevant email below.
>
> I think Stephen’s list is a good first list of issues. My questions are:
> what is the problem that we are trying to solve? Why are we undertaking
> this effort?
>
> SM said, "For ease of discussion I'll define the problem differently: how
> to move from discussing by writing to each other to discussing where we can
> all talk to each other.”
>
> Why do we want to move from discussing while writing to discussing while
> talking? Do we think that a mega-virtual meeting will progress technical
> work faster than a series of interim meetings?
>
> Note: I’m not arguing that we shouldn’t be trying to do this but I don’t
> yet understand why the trend of increased remote participation means that a
> mega-virtual meeting is a logical next step. (Except, potentially, in the
> case where a F2F meeting is cancelled at the last minute due to emergency).

That's exactly what I'm thinking - that it would be helpful to start
planning for a mega-virtual meeting, because if there is an emergency and
you cancel a F2F, we won't be reacting from a standing start.

Now, if people wanted to run smaller-scale experiments as part of planning
for a mega-virtual meeting, that sounds like a fine idea to me. As one
example, didn't the IESG and IAOC talk about making Meetecho work as the
default environment for WG virtual interims when we met on Monday morning?
That could be a reasonable step along the path ... ("if we can't make that
work well, adding O(1000)s of people isn't going to make it work better").

Spencer

> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches
>

---

From: Melinda Shore <[email-masked]>
Date: Thu, 21 Jul 2016 16:08:12 +0200

Has anybody talked with Meetecho about doing some experiments
with a load generator, so they can start getting a handle on
where they run into scaling issues, etc., without having to
involve large numbers of people?  Once they're confident that
they've identified what they can with a synthetic load, then
they can move towards experiments with actual meetings.  Seems
like starting the scaling experiments by involving humans
is bound to lead to frustration.

Melinda

---

From: S Moonesamy <[email-masked]>
Date: Thu, 21 Jul 2016 07:49:19 -0700

Hi Alexa,
At 03:07 21-07-2016, Alexa Morris wrote:
>Why do we want to move from discussing while writing to discussing 
>while talking? Do we think that a mega-virtual meeting will progress 
>technical work faster than a series of interim meetings?

The reason I asked about discussing while talking (instead of using 
email) is to try and figure out some of the issues.  For example, the 
persons on this list tried to meet in person.  It was done by writing 
to each other.  There are other ways to do it.  However, the security 
or privacy aspects could be a problem as we go beyond a small group 
of people who know each other.

There was an interesting comment from Mark Nottingham during the 
plenary about meetings and the advantages of meeting in person.  I 
don't think that it is currently possible to progress technical work 
faster though a mega-virtual meeting.  Stephen identified some of the 
issues.  Assuming that the technical issues are resolved in future, 
could the IETF move to a mega-virtual meeting?  I don't know.  There 
are a few hundred remote attendees for this week's meeting.  If the 
number increases, the IETF will reach a point where it will have to 
find answers to some questions (e.g. see message from Lou Berger).

Regards,
S. Moonesamy

---

From: Simon Pietro Romano <[email-masked]>
Date: Thu, 21 Jul 2016 17:22:05 +0200

Hi Melinda,

we do have such a load generating tool and we do perform extensive stress-testing campaigns. Obviously, the results of those tests depend on a number of factors, among which the networking and server-side infrastructure obviously play a major role. We’ll be sharing with you the results of a typical stress-testing campaign in the next few weeks, so to give you a flavour of the figures we have collected so far.

Cheers,

Simon

                     				            _\\|//_
                           				   ( O-O )
      ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                    				Simon Pietro Romano
             				 Universita' di Napoli Federico II
                		     Computer Engineering Department 
	             Phone: +39 081 7683823 -- Fax: +39 081 7683816
                                           e-mail: [email-masked] <mailto:[email-masked]>

		    <<Molti mi dicono che lo scoraggiamento è l'alibi degli 
		    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
               			                     oooO
       ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
					                 \ (            (   )
			                                  \_)          ) /
                                                                       (_/

> On 21 Jul 2016, at 16:08, Melinda Shore <[email-masked]> wrote:
>