Subject: RE: Backward compatibility with deployed SPF records (and choice of domain)

From: "Harry Katz" <[email-masked]>
Date: Sun, 27 Jun 2004 14:40:28 -0700

On Friday, June 25, 2004 10:28 PM, Greg Connor wrote:

> > 1. Placement of TXT records.
> >
> >     The co-chairs find that the working group has not come 
> to consensus on
> >     the use of a record prefix vs [unprefixed] TXT records
> 
> 
> I think I would agree with Roy that allowing MARID-compliant 
> MTAs to check 
> the unprefixed name is desirable.
> 
> In other words, if MARID-Brand LMAP works substantially similar to 
> SPF-Brand, let's go ahead and use their data.
> 
> One concern here is that we would want the semantics to be 
> similar enough 
> to not upset or surprise anyone who isn't expecting their 
> data to be used a 
> slightly different way, but I think we are able to do that.  (That 
> certainly was the intent of the SenderID merged proposal)
> 
> In a straight race, I would probably root for the 
> non-prefixed records to 
> win, simply because the underscore might scare and confuse 
> people (it was 
> removed from early versions of SPF for mostly that reason).  I do 
> understand the issue that the prefix is intended to address, 
> but I don't 
> think the research we have shows it is anything to worry 
> about.  I think 
> most users will not have TXT records of any other type, and 
> of those that 
> do, the records will mostly be small enough to coexist 
> peacefully.  I don't 
> have a strong preference in this area, except that backward 
> compatibility 
> would allow MARID to harness and redirect the momentum SPF 
> has built up. 
> (Of course we will be going through the process of getting 
> our own RR so we 
> will eventually have an escape plan)
> 
> Does anyone have a strong objection to using unprefixed txt records?
> 

I think this is just going to invite problems down the road.  Although
data may correctly show that TXT records are not used frequently today,
that's no guarantee of future use.  Likewise we cannot predict the
length of data stored in future TXT records.  Multiple TXT records could
push responses over the 512 byte threshhold. 

Segregating MARID records into their own subdomain addresses these
issues.  

We advocate the use of an underscore as a way to celarly distinguish
this record from a hostname, but we're not married to it.

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Sun, 27 Jun 2004 19:30:50 -0700

> > > The reason _spf prefix was dropped from SPF was NON-technical, but
> > > still an issue we should consider... people didn't 
> understand it, and
> > > some still believed underscore was illegal, etc.
> >
> > underscore is illegal for hostnames. service names are not 
> hostnames.
> >
> 
> Did you see my message on this thread?
> 
> So the customer was right about his ISP saying it was illegal to use
> _EP.hostname.com for a TXT record?

Prefixes are already used for SRV.

People who would not follow the spf group are much more likely to 
follow advice from the IETF.

	Phill