Subject: RE: Why XML

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 22 Jun 2004 12:19:36 -0700

>     Hallam-Baker,> So I really don't expect that the term 'mail admin'
>     Hallam-Baker,> will have much relevance in the future as a
>     Hallam-Baker,> distinct specialization. 
> 
> That's quibbling over terminology.  _Someone_ is going to have to be
> responsible for publishing and debugging MARID records, assuming we're
> still using MARID by that time.

No, my point is that the messaging admin is going to be admining several
services, most of which will be Web Services running over pure XML.

>     Hallam-Baker,> If a mail admin can't hack
>     Hallam-Baker,> XML then they won't be able to find much of a job.
> 
> That isn't quite what I said.  I didn't say that mail admins won't be
> able to cope with XML, I just said that IMHO SPF syntax is easier to
> read than the unformatted XML we're contemplating putting in TXT
> records.

With XML it is a simple matter to add a feature to the DNS retreive 
tool to format the data in a comprehensible way - take a look at how
IE displays XML.

that is not possible with the SPF syntax unless the tool understands the
version of the syntax used. 

With XML - extensions to the data structure do not affect tools
With SPF - extensions to the data structure require all tools to be
rewritten

---

From: <[email-masked]>
Date: Tue, 22 Jun 2004 15:52:42 -0400

*Displaying* the new extension and actually doing something with it are *completely* different
things.

With XML programmers might save a bit of coding time in the parser when a new extension arrives, but
ultimately someone has to code and produce a new version of the MTA which is actually going to
implement the new extension.  No matter how you transmit the data for the new extension, that is the
inescapable reality.

Terry Fielder
Manager Software Development and Deployment
Great Gulf Homes / Ashton Woods Homes
[email-masked]
Fax: (416) 441-9085

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Hallam-Baker,
> Phillip
> Sent: Tuesday, June 22, 2004 3:20 PM
> To: 'Roy Badami'; Hallam-Baker, Phillip
> Cc: [email-masked]'; 'IETF MARID WG'
> Subject: RE: Why XML
>

---

From: Chris Zumbrunn <[email-masked]>
Date: Tue, 22 Jun 2004 22:22:33 +0200

On 22. Jun 2004, at 20:15, Hadmut Danisch wrote:

> Don't design the protocol for those few people who
> fiddle around with DNS records directly.
>
> Design the protocol for those who need to handle
> tens and hundreds of thousands domains automatedly
> and to provide a web interface.

> tool to format the data in a comprehensible way - take a look at how

These are really arguments for an XML based DNS system. Of course, 
defining tomorrows DNS is outside the scope of MARID. XML doesn't 
belong in todays DNS. In fact, allowing XML in TXT records now might 
turn into a headache later when a conversion of DNS to XML is 
considered.

Chris