Subject: RE: draft-ietf-marid-submitter-01.txt

From: "Harry Katz" <[email-masked]>
Date: Mon, 28 Jun 2004 16:40:42 -0700

On Monday, June 28, 2004 1:50 PM, Matthew Elvey wrote:
 
> On 6/28/04 11:09 AM, Harry Katz sent forth electrons to convey:
> 
> >On Monday, June 28, 2004 9:36 AM, Greg Connor wrote:
> >
> >  
> >
> >>On Mon, 28 Jun 2004, Matthew Elvey wrote:
> >>

[snip]

> >
> Yes.  The paragraph you quote is preceeded by:
> 
>    "If the above tests indicate that the connecting SMTP 
> client is not 
>    authorized to transmit e-mail messages on behalf of the SUBMITTER 
>    domain, the receiving SMTP server MAY reject the message 
> using "550 
>    5.7.1 Submitter not allowed."  The receiving SMTP server MAY 
>    alternatively proceed to read the message and apply local policy." 
> 
> If the spec is interpreted procedurally, the above could take 
> precedence over the below. 
> That threw me.  The reverse precedence is desired.  (Case 
> where SUBMITTER does not match header and is not allowed.)

Good point.  If the last sentence of this paragraph is removed, would
that make things clearer?  It's redundant with the paragraph I quoted
(repeated below).

> 
> > From section 4.2:
> >
> >   If the receiving SMTP server allows the connecting SMTP client to
> >   transmit message data, then the server SHOULD determine 
> the purported
> >   responsible address of the message by examining the RFC 
> 2822 message
> >   headers as described in [SENDER-ID].  If this purported 
> responsible
> >   address does not match the address appearing in the SUBMITTER 
> >   parameter, the receiving SMTP server MUST reject the 
> message using 
> >   "550 5.7.1 Submitter does not match header."
> >
> >If this needs some further clarification, please let me know.
> >
> >

---

From: Matthew Elvey <[email-masked]>
Date: Mon, 28 Jun 2004 17:30:09 -0700

>that make things clearer?  It's redundant with the paragraph I quoted
Still isn't clear to me.  You've still got a MAY in the first paragraph, 
followed by a SHOULD in the second.  One should have precedence (also I 
don't see why one is MAY and the other SHOULD).
Got the s/firm/entity/ fix?