Subject: RE: alternate submitter syntax

From: "Terje Petersen" <[email-masked]>
Date: Mon, 26 Jul 2004 14:30:17 +1000

-----Original Message-----
From: Meng Weng Wong [mailto:[email-masked]] 
Sent: Monday, 26 July 2004 1:28 PM
To: Terje Petersen
Cc: [email-masked]
Subject: Re: alternate submitter syntax

On Mon, Jul 26, 2004 at 11:05:29AM +1000, Terje Petersen wrote:
| 
| The term SUBMITTER is getting confused even by smart people. 
| 
| SUBMITTER is merely the reply address. The parameter would have been
| a lot less confusing if it was simply called REPLYTO. 
| 
| The RFC.2822 FROM address is supposed to be identical to this
parameter.

In the forwarding case, where

  [email-masked] sends mail to [email-masked]
                        [email-masked] forwards to [email-masked],

When c.com receives the message, it sees

  MAIL FROM:<[email-masked]> SUBMITTER=<[email-masked]>

Due to the nature of the forwarding relationship, [email-masked]
and [email-masked] can be said to represent the same entity.

In this case, SUBMITTER is not the reply address, and it is
not identical to the 2822.From header.

SUBMITTER identifies the entity responsible for the most
recent logical insertion of the message into the mailstream.

[email-masked] -> [email-masked] is one logical delivery.

[email-masked] -> [email-masked] is another logical delivery.

A logical delivery may consist of more than one physical
SMTP transaction due to the presence of smarthosts and
intramural relaying.

==== reply from TERJE below ===============================

Thankyou Meng for the example. 

I am not sure that you got the sequence correct in your example
however as an MTA/MUA/USER sitting at "C" this is how I would expect
to interpret it.

Your example says that sitting at "C" I receive:-

  MAIL FROM:<[email-masked]> SUBMITTER=<[email-masked]>
  RFC.2822.FROM not equal to <[email-masked]>

If I am [email-masked] then when I hit REPLY in MS-Outlook or any other MUA
I would expect my email to be sent to [email-masked]. After all they are the
nominated responsible sender in your example. 

When I hit reply I expect to be corresponding with the PRA. 

The text of the proposed SUBMITTER standard says:-

"
   Furthermore, SMTP clients MUST, if necessary, insert such RFC 2822
   headers as defined in section 4 of [SENDER-ID] in order to ensure
   that the purported responsible address determined from the RFC 2822
   headers by the receiving SMTP server will match the SUBMITTER
   address.
"

QUESTION1: Are you suggesting that when [email-masked] presses the reply button
the email should be directed to somebody other than the PRA.  

QUESTION2: If the example you detail is correct then what are the 
RFC.2822 headers that should match SUBMITTER as per the above quote
from the proposed standard. And if the reply address is different then 
should it not also be SPF checked.

---

From: Meng Weng Wong <[email-masked]>
Date: Mon, 26 Jul 2004 09:35:00 -0400

On Mon, Jul 26, 2004 at 02:30:17PM +1000, Terje Petersen wrote:
| 
| When I hit reply I expect to be corresponding with the PRA. 
| 

That would be funny, because the PRA should be [email-masked],
which is yourself!

| 
| The text of the proposed SUBMITTER standard says:-
| 
| "
|    Furthermore, SMTP clients MUST, if necessary, insert such RFC 2822
|    headers as defined in section 4 of [SENDER-ID] in order to ensure
|    that the purported responsible address determined from the RFC 2822
|    headers by the receiving SMTP server will match the SUBMITTER
|    address.
| "
| 
| 
| 
| 
| QUESTION1: Are you suggesting that when [email-masked] presses the reply button
| the email should be directed to somebody other than the PRA.  

The email should be directed to whoever's in the Reply-To or
From headers, just as things work today.

| QUESTION2: If the example you detail is correct then what are the 
| RFC.2822 headers that should match SUBMITTER as per the above quote
| from the proposed standard. And if the reply address is different then 
| should it not also be SPF checked. 

Resent-From, I think.  See the latest marid-core spec, which
describes PRA.