Subject: alternate submitter syntax

From: "Terje Petersen" <[email-masked]>
Date: Mon, 26 Jul 2004 11:05:29 +1000

I know that this is cosmetic. However the standards are forever. 
And words seem to cause so much confusion that getting the cosmetics of
terminology correct makes a huge difference.

This proposal may be too far down the road to wind back the clock. 
However I will offer my two bob worth. 

The term SUBMITTER is getting confused even by smart people. 

SUBMITTER is merely the reply address. The parameter would have been
a lot less confusing if it was simply called REPLYTO. 

The RFC.2822 FROM address is supposed to be identical to this parameter.

If it is not then the RFC.2822 header is malformed. 

We would say that we use an SPF test to check a servers authority to
instruct a specific REPLYTO address. But we would not imagine that the 
parameter referred to the actual real author or originator of the email.

In dialogue people seem to often mentally infer that SUBMITTER relates
to 
the address from which the email entered the system. Even people who
have 
read and understood the standards. People easily flip back into thinking
in 
common english terms. 

Your servers need authority (granted through SPF) to specify either.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

MAIL FROM address = BOUNCETO address
SUBMITTER address = REPLYTO address

MAIL FROM:<[email-masked]> SUBMITTER:<[email-masked]>

MAIL FROM:<[email-masked]> REPLYTO:<[email-masked]>

SPF checks the authority of a server to specify a given BOUNCETO
address. 
SPF checks the authority of a server to specify a given REPLYTO address.

---

From: Meng Weng Wong <[email-masked]>
Date: Sun, 25 Jul 2004 23:28:12 -0400

On Mon, Jul 26, 2004 at 11:05:29AM +1000, Terje Petersen wrote:
| 
| The term SUBMITTER is getting confused even by smart people. 
| 
| SUBMITTER is merely the reply address. The parameter would have been
| a lot less confusing if it was simply called REPLYTO. 
| 
| The RFC.2822 FROM address is supposed to be identical to this parameter.

In the forwarding case, where

  [email-masked] sends mail to [email-masked]
                        [email-masked] forwards to [email-masked],

When c.com receives the message, it sees

  MAIL FROM:<[email-masked]> SUBMITTER=<[email-masked]>

Due to the nature of the forwarding relationship, [email-masked]
and [email-masked] can be said to represent the same entity.

In this case, SUBMITTER is not the reply address, and it is
not identical to the 2822.From header.

SUBMITTER identifies the entity responsible for the most
recent logical insertion of the message into the mailstream.

[email-masked] -> [email-masked] is one logical delivery.

[email-masked] -> [email-masked] is another logical delivery.

A logical delivery may consist of more than one physical
SMTP transaction due to the presence of smarthosts and
intramural relaying.