Subject: RE: Licensing issues

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 16 Jul 2004 07:17:53 -0700

This is the second first time post on this thread.

Licensing issues are being dealt with, your paranoias are irrelevant,
take it to the IETF IPR forum.

And BTW GNU would be an entirely unacceptable licensing scheme for
a patent controlling a protocol standard in any case. 

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Koen Martens
> Sent: Friday, July 16, 2004 5:57 AM
> To: IETF MARID WG
> Subject: Licensing issues
> 
> 
> People,
> 
> I hope I'm not out of order with this post, I've been lurking 
> on this list
> for a while and now feel I have to voice my worries. I said 
> this before
> on other lists, but I think I should revoice this opinion right here.
> 
> I'm frankly quite worried about the way microsoft is involved in all
> this. To be honest, if the end of your efforts are something that even
> hints at stuff I have to hire an attorney for to figure out in
> connection with microsoft, I will not even consider the 
> protocol itself
> for me and my customers. Mind you, I don't know the facts 
> simply because
> I'm not a lawyer. I don't have the expertise to root around in legal
> documents and international law to see what microsoft claims, and what
> it will mean for me. 
> 
> I hope this concern of mine is not waived by blaming it on my emotions
> or anything. I'm just being practical here. I don't have the legal
> expertise to figure out what microsoft has licensed and what not, and
> what I can do without being afraid of the Wrath of the Giant. 
> 
> I liked good old SPF-Classic, and I will continue to support 
> this, both
> by publishing, checking & writing code. I will never ever contribute
> even half a line of code on something if there is a chance that
> half a line of code ends up being owned by Microsoft. 
> 
> Ok, I've spoken up. I will go back to lurking now. Thanks for 
> your time,
> 
> Koen Martens
> 
> -- 
> K.F.J. Martens, Sonologic, http://www.sonologic.nl/
> Networking, embedded systems, unix expertise, artificial intelligence.
> Public PGP key: http://www.metro.cx/pubkey-gmc.asc
> Wondering about the funny attachment your mail program
> can't read? Visit http://www.openpgp.org/
>

---

From: Chuck Mead <[email-masked]>
Date: Fri, 16 Jul 2004 11:10:12 -0400

Hallam-Baker, Phillip wrote:
| This is the second first time post on this thread.
|
| Licensing issues are being dealt with, your paranoias are irrelevant,
| take it to the IETF IPR forum.

You corporate guys appear to have bunched together in a group and *DO
NOT* appear to want to *HEAR* what the non-corporates think! You may
want to start passing out tin foil hats to the OSS crowd but it is not
paranoia! We are being told repeatedly that the license is going to be
the one M$ put forward for Caller-ID and that's just not realistic now
that CID has been kicked to the curb. Address *THAT* and I suspect most
of us will shut up about this issue.

If I sound irritated it's because I am. "your paranoias are irrelevant"
was uncalled for. If people do not understand they might end up sounding
paranoid but that does not, in any way, minimize the reality of their
concern.

| And BTW GNU would be an entirely unacceptable licensing scheme for
| a patent controlling a protocol standard in any case.

Fine. Then use SPF-Classic which is unencumbered and let's have done
with it. How in the sam hill do you patent something which is
pre-defined in pre-existing RFC's? Sheesh! I did not "PRA" for this! :-)

- --
Chuck Mead
[email-masked]
Chief Tech @ http://moongroup.com - http://anirononline.com

---

From: "Chris Haynes" <[email-masked]>
Date: Fri, 16 Jul 2004 17:13:52 +0100

"Hallam-Baker, Phillip" <[email-masked]> commented:

<...
>...

My I register my concern, as someone who has been professionally involved with
protocol design and implementation for over 40 years, that the IETF is even
_considering_ the adoption of a protocol of this significance in such a way that
it may be beholden to commercial interests.

I'm sure it is proper to seek the advice of IPR specialists to examine the
nature and scope of any such encumberance, but it is surely for _this_ list to
gather opinions on whether or not commercial rights over the protocol in this
particular domain would be acceptable to the Internet Community as a whole -
whatever shape or form they  took; this is a valid aspect of the overall
decision-making process which this list supports.

The retention of an 'open', vendor-neutral eMail infrastructure for the world is
a duty on us all.

And may I just say how disappointed I am by the tone and language just used
('paranoia') by someone who appears to be representing a corporate organization.

A disappointed and concerned,

Chris Haynes

---

From: "John Glube" <[email-masked]>
Date: Fri, 16 Jul 2004 12:13:48 -0400

Hallam-Baker, Phillip <pbaker@...> writes:

> > This is the second first time post on this thread. > >
Licensing issues are being dealt with, your paranoias are
irrelevant, > take it to the IETF IPR forum.

With all due respect, this is the appropriate place for the
issue. RFC 3688 sets out the criteria for dealing with
issues of this sort by working groups. People are now
expressing their views within the context of those criteria.

I can only speak for myself, but my concerns are not
paranoia. The issue is quite straight forward. It is one of
perception.

Like it or not, this is an extremely sensitive topic. To
simply brush off peoples concerns as fear, is not going to
help.

If the protocol which is proposed by the IETF for sender
authentication is "perceived" to be controlled by any one
group, even if the license is royalty free, this will
likely result in a huge uproar. 

It does not matter whether the holder is Microsoft, Yahoo!,
or Acme Holdings Limited. 

Why are people suggesting a GNU General Public License? Out
of respect for the principles outlined in RFC 3688, while
avoiding any negative perceptions and in fact enhancing
goodwill for the particular claimant.

> > And BTW GNU would be an entirely unacceptable licensing
scheme for > a patent controlling a protocol standard in
any case. > 

People claim a property right in a program. One method of
protecting this interest is by way of patent. The patent
holder grants others a license to use the property. To my
understanding the GNU General Public License speaks to this
issue.

However, if for some reason the GNU General Public License
or any other form of Open Source Initiative license is not
acceptable, then I suggest the claimant release its claims
either outright or to The Internet Society for the good of
the Internet.

The vast majority of consumers use the Internet for email
and to surf for information. 

If the public at large believes any one business group has
taken control of email, in my humble opinion, this is the
kiss of death for the protocol.

Not only will implementers be upset. But so will business.
People should not forget. The vast majority of online
businesses in North America are very small operations.
These people are consumers, vote and pay taxes. 

One reason email has become so vital is no one group
controls or is perceived to control the situation. 

Also, we should not forget at least in North America, the
Federal Trade Commission will be holding a summit this fall
on Sender Authentication. The purpose? To ascertain whether
the market can develop and implement one base standard.

However, if proponents come before the Summit with a
protocol which requires users to enter into a royalty free
license that gives even the whiff of one group having
control, how will the FTC, with its mandate to protect the
consumer and ensure competition be obliged to respond?

I believe the FTC will have no choice but to say, no. 

This is an election year in the United States. The public
is upset, angry and confused.

At the same the Government of Canada is in the midst of a
review of anti-spam policy. In Canada we just had an
election. The Liberal party was re-elected but with a
minority. These are sensitive times.

Some may say the IETF should not be concerned about how any
particular national government feels about a standard. This
is understood. At the same time, ignoring a potential
reality, especially when dealing with a vital communication
medium like email, will likely result in implementation
failure, making the exercise for naught.

Moving from an open to a closed email system, albeit
necessary is not going to be easy. Let's not compound the
problem but rather instead focus on the common good.

Many, many folks have worked long hours in the development
of all the proposals on the table. A lot of thought and
consideration has gone into the efforts by each of the
proponents. At the same time, when vital issues are raised,
it is important for people to come forward and properly
express their views.

Otherwise, the process is perceived rightly or wrongly as
simply another exercise by "they." This would be sad as the
IETF commands its authority within the community at large
because it is perceived to be fair and acting in the
interests of all concerned. 

Having said all of this, I gather from posts made to this
list and others that a good faith effort is being made to
resolve these issues. Hopefully the questions and genuine
concerns being raised will become moot and the working
group can propose a base standard which best suits the
desired objectives within the stated time frame.

John Glube
Toronto, Canada

The FTC Calls For One Standard For Sender Authentication
http://www.learnsteps4profit.com/dne.html 

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.718 / Virus Database: 474 - Release Date: 09/07/2004

---

From: Ryan Ordway <[email-masked]>
Date: Fri, 16 Jul 2004 09:50:00 -0700

> take it to the IETF IPR forum.

	I wouldn't say that our 'paranoias', which they
are not, are irrelevant.

	I don't hate Microsoft, and I seriously doubt they
are out to take over the universe. I am not a conspiracy
theorist. I DO have concerns about standards supported by
corporations, ANY corporations, when they attempt to assert
IP claims over those standards or portions thereof
irregardless of their possibly benign intentions. I don't
think that those concerns are irrelevant. 

> a patent controlling a protocol standard in any case. 

	Irregardless of the license, the crazy paranoid
people of the Internet community aren't going to use a
standard that is encumbered by patent issues. That will
be a really sad thing.

	Ryan

-- 
HELO, my name is root... you have SIGKILLed my father... prepare to vi!

---

From: Shevek <[email-masked]>
Date: Fri, 16 Jul 2004 16:23:25 +0100 (BST)

> This is the second first time post on this thread.

And therefore the second (actually the fourth[0]) vote from a person who
feels more strongly about the licensing than about any other issue so far
raised. This should be putting up serious warning flags, especially as
regards consensus within the working group.

> take it to the IETF IPR forum.

This is a specific discussion of a particular piece of alleged IPR with
respect to a specific technology being discussed in this working group. My
reading of RFC3669 therefore makes it our problem to discuss.

The IPR forum is appropriate for generic discussion of IPR within the
IETF. It would be strongly inappropriate for this discussion, since this
is a specific, and not a generic IPR issue.

The opinions of these posters are clearly stated and valid, and should not
be swept under the carpet like this.[1]

S.

[0] But who's counting?
[1] Deja vu.

> > connection with microsoft, I will not even consider the protocol
> > itself for me and my customers. Mind you, I don't know the facts
> > simply because I'm not a lawyer. I don't have the expertise to root
> > around in legal documents and international law to see what microsoft
> > claims, and what it will mean for me.
> > 
> > I liked good old SPF-Classic, and I will continue to support this,
> > both by publishing, checking & writing code. I will never ever
> > contribute even half a line of code on something if there is a chance
> > that half a line of code ends up being owned by Microsoft.
> > 
> > Ok, I've spoken up. I will go back to lurking now. Thanks for your
> > time,
> > 
> > Koen Martens

-- 
Shevek                                    http://www.anarres.org/
I am the Borg.                         http://www.gothnicity.org/

---

From: Koen Martens <[email-masked]>
Date: Sat, 17 Jul 2004 13:34:55 +0200

> take it to the IETF IPR forum.

Let me explain a few things. I waited this long with posting, because
these licensing issues 'are being dealt with' for months now, and still
nothing has come out. Each time I see the issue raised on this list,
people yell 'keep your emotions out of this list', 'no discussion of
hidden agenda's' etc.. Effectivelly, the whole issue is being swept
under the carpet, and before we know it the IETF is spreading a patented
protocol around the world. 

I am not paranoid. I know how microsoft has used the law before to crush
anything that is in their way of dominating the software market. They
_will_ use this patent to crush anything that they don't like, this is
not paranoia, this is extrapolated fact. They have done before on
numerous occasions, they will keep doing this until the sun goes
supernova. This is not something i say because of my emotions, this is
pure rational extrapolation of empirical observation. I'm not going to
paste the endless list here where microsoft has used the law + the fact
that no-one has more money to pay to lawyers, since I assume you know
pretty well what I'm talking about. Time after time, microsoft has
attacked small companies that have to struggle to pay just the one
lawyer with an overwhelming force of 30 lawyers. 

And the more people like you attack the people who voice their concern by
saying they are emotional paranoid nobodies, the more you will alienate the
large (and apparently in your eyes irrelevant) community of smaller network 
operators and consultancy companies that in the end will have to implement 
your patented protocol.

Many of us simply will not. No matter how many times you call us
paranoid, emotional unstable, etc.. There are some strong opinions on
this subject matter, ignoring them as you do would be foolish. The fact
that lawyers will have to go over this, means I will have to get a
lawyer if I ever want to do something with the protocol.

> a patent controlling a protocol standard in any case. 

I never said anything about GNU and I never said that I want any
protocol controlled by patents. I don't understand this 'argument' of
yours.

Frankly, I think you are the one reacting emotional here, out of some 
disgust for us open source guys or something. Please, be rational.
Without the open source community on board, your protocol is doomed.

Koen