Subject: RE: MTAs should focus on email TRANSPORT not email CONTENT

From: "Terje Petersen" <[email-masked]>
Date: Thu, 22 Jul 2004 10:58:17 +1000

> 
> Currently the MUA displays the FROM address to the end user as being
the
> originator of the email. Once the SUBMITTER extension is in use then
the
> MUA can do one of two things to stop phishing:-
> 
> 1. Instead of displaying the FROM address as the originator it can
> display the SUBMITTER address. 
> 
>   Or 
> 
> 2. Dump messages where FROM <> SUBMITTER.
> 

I would pefer that the MUA say

From SUBMITTER on behalf of FROM

And it should reply to FROM unless there is a "Reply-To:" Header.

dave.

TP> That's nice but SUBMITTER = FROM unless the content is malformed.
TP> And SUBMITTER is verified by the MTA using SPF records. 
TP> So the reply should go to SUBMITTER as its verified as being the
TP> real sender. And if the real sender is sending malformed email
TP> then they should get any replies in any case.

---

From: "David Beveridge" <[email-masked]>
Date: Thu, 22 Jul 2004 12:05:19 +1000

> TP> That's nice but SUBMITTER = FROM unless the content is malformed.

Not always,  I host a web page with a payment gateway for my customer.  My
web server contacts the bank with all the details to process the
transaction.  Then the bank (SUBMITTER) sends an email on my behalf (FROM
ME) to my customer confirming the transaction.

> TP> then they should get any replies in any case.

I want my customer to reply to me, not the banks computer.

dave.