Subject: RE: TECH-ERROR: Name of SUBMITTER parameter

From: "Harry Katz" <[email-masked]>
Date: Fri, 3 Sep 2004 09:40:10 -0700

On Friday, September 03, 2004 9:20 AM, [email-masked]
wrote:

> wayne wrote:
> > In <[email-masked]> Roy Badami 
> > <[email-masked]> writes:
> >>     MAIL FROM:<foo@bar> PRA=<baz@qux>
> >> 
> >> is far more natural than the SUBMITTER alternative.
> > So, I think we can count at least four people who would like to see 
> > SUBMITTER= renamed to PRA=.
> 
> I respectfully disagree.  Acronyms are harder to understand 
> than fully-spelled-out names.  A search on AcronymFinder for 
> PRA returned 41 results:
> Paint Research Association (UK)
> Paperwork Reduction Act of 1995
> Parabolic Reflector Antenna
> Parti pour le Renouveau Algerien
> Participatory Rural Appraisal
> 
> How about spelling PRA out rather than using the acronym?
> 
> [email-masked]                      805.964.4554 x902
> Hispanic Business Inc./HireDiversity.com         Software Engineer
> perl -e"map{y/a-z/l-za-k/;print}shift" "Jjhi pcdiwtg Ptga wprztg,"
> 

Actually, I prefer the name SUBMITTER and would like to stick with it.
I believe that, from the sender's perspective, the name accurately
conveys what the parameter means.  It is only on the receiving side that
the value becomes "purported."

---

From: Roy Badami <[email-masked]>
Date: Sat, 4 Sep 2004 18:10:40 +0100

Harry> Actually, I prefer the name SUBMITTER and would like to
    Harry> stick with it.  I believe that, from the sender's
    Harry> perspective, the name accurately conveys what the parameter
    Harry> means.  It is only on the receiving side that the value
    Harry> becomes "purported."

Yeah.  I guess with hindsight including 'purported' in the name of the
identity was a mistake, since whether 'purported' is appropriate
depends on context.

We could always repurpose PRA to stand for Primary Responsible
Address; I'll make a separete post proposing that.

	 -roy