Subject: RE: The SSL license offer.

From: "Ryan Malayter" <[email-masked]>
Date: Thu, 2 Sep 2004 12:52:10 -0500

[Guillaume Filion]
> I may be talking throught my hat, but reading the SSL patent 
> license, I see
> no restriction on redistribution.

I thought that all rights were reserved unless specifically granted. If
so, it would seem the SSL license grants NO rights to redistribute
whatsoever. Perhaps I am wrong.

In any case, I cannot seem to find an "official" version of this license
on the netscape or AOL sites, so who the hell knows.

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Thu, 2 Sep 2004 16:12:44 -0700

> In <[email-masked]> 
> "Ryan Malayter" <[email-masked]> writes:
> 
> > [Hallam-Baker, Phillip]
> >>The patent is held by Netscape (AOL) and covers transport layer 
> >>security. The terms are considerably more vague than in the SenderID
> >>case. Netscape does not promise to offer a sublicensable patent or
> >>even to offer reasonable or non discriminatory terms.
> 
> The terms "reasonable" and "non descriminatory" of RAND are almost
> meaningless.  

I bet that I could define terms that you would intersubjectively 
agree to be unreasonable and discriminatory.

> The problem isn't the patents, the problem is the license.  It is the
> terms of the licenses that make the SenderID patent license
> incompatible with the GPL and causes folks like sourceforge need a
> license in order to redistribute the senderid-milter.
> 
> The OpenSSL TLS patent and license dates 1996 or 1997.  It is hard to
> even dig up information to refresh my memory about this issue.

But the terms were never even published.