Subject: RE: Status of MARID WG?

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 23 Nov 2004 09:59:13 -0800

> From: Andrew Newton [mailto:[email-masked]] 

> On Nov 23, 2004, at 11:22 AM, Hallam-Baker, Phillip wrote:
> 
> > There is a difference between a prototype and a product. 
> Unfortunately
> > we
> > have a habbit of inflicting PERL lash up style schemes that 
> are really 
> > no
> > more than prototypes onto end users.
> 
> What's the saying... "Build a foolproof system and only fools 
> will use 
> it."

That has been the cry of the COBOL lobby, the FORTRAN lobby and every group
that has promoted an obsolete legacy product as the future.

> The computer sciences have been taking a 
> beating lately because the technology being produced cannot 
> be quickly grasped by simpletons.

Deservedly so.

> Well, guess what?  Despite all the research and will of the auto 
> industry, training and a drivers license are still required. 

But not for turning on the heater or a/c.

> After all, isn't the driver for mta-to-mta authorization 
> caused because our collective mothers simply will not take on this 
> responsibility with their click-driven MUAs?

I would argue that the need for the group is due to internet community
dumping an inadequate prototype for a spec onto the user base. SMTP is a bit
of an improvement over the days when email was a feature of FTP which was in
turn a feature of TELNET.

---

From: Andrew Newton <[email-masked]>
Date: Tue, 23 Nov 2004 13:09:32 -0500

> that has promoted an obsolete legacy product as the future.

COBOL failed because RPG-III was superior!

-andy

---

From: [email-masked]
Date: Tue, 23 Nov 2004 16:32:32 -0500

>COBOL failed because RPG-III was superior!

And RPG-III was superior because programmers didn't have to think about the 
underlying processing algorithm.  RPG had reduced the concern to what do I 
do with this (these) record(s).

Ed