Subject: [Masque] Adoption call for "The CONNECT-UDP HTTP Method"

From: "Christopher Wood" <[email-masked]>
Date: Wed, 29 Jul 2020 05:49:02 -0700

During yesterday's MASQUE WG meeting, there was strong support in favor of adopting draft-schinazi-masque-connect-udp as a WG item. To that end, this email begins the call for adoption of the document, in its current form, as a starting point. We expect to work through the issues raised both in the meeting and on the list going forward. 

Please let the WG know if you support adoption, and if so, are willing to contribute to the discussion and review drafts. If you oppose adoption, please explain why. 

The document may be found here:

   https://datatracker.ietf.org/doc/draft-schinazi-masque-connect-udp/

And the source may be found here:

   https://github.com/DavidSchinazi/masque-drafts

This call for adoption will conclude on August 14.

Thanks, 
Chris and Eric

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 29 Jul 2020 05:53:47 -0700

I am in fn favor of adoptin

On Wed, Jul 29, 2020 at 5:49 AM Christopher Wood <[email-masked]>
wrote:

> During yesterday's MASQUE WG meeting, there was strong support in favor of
> adopting draft-schinazi-masque-connect-udp as a WG item. To that end, this
> email begins the call for adoption of the document, in its current form, as
> a starting point. We expect to work through the issues raised both in the
> meeting and on the list going forward.
>
> Please let the WG know if you support adoption, and if so, are willing to
> contribute to the discussion and review drafts. If you oppose adoption,
> please explain why.
>
> --
> Masque mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/masque
>

---

From: David Schinazi <[email-masked]>
Date: Wed, 29 Jul 2020 06:00:59 -0700

(This shouldn't be a surprise since I'm an author, but) I support adoption.

David

On Wed, Jul 29, 2020 at 5:54 AM Eric Rescorla <[email-masked]> wrote:

>> During yesterday's MASQUE WG meeting, there was strong support in favor
>> of adopting draft-schinazi-masque-connect-udp as a WG item. To that end,
>> this email begins the call for adoption of the document, in its current
>> form, as a starting point. We expect to work through the issues raised both
>> in the meeting and on the list going forward.
>>

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 29 Jul 2020 14:17:34 +0100

I support adoption. I'll help review.

On Wed, 29 Jul 2020, 14:01 David Schinazi, <[email-masked]> wrote:

>>> Please let the WG know if you support adoption, and if so, are willing
>>> to contribute to the discussion and review drafts. If you oppose adoption,
>>> please explain why.
>>>

---

From: David Oliver <[email-masked]>
Date: Thu, 30 Jul 2020 07:59:14 -0400

I support adoption, and will help to review.

David M. Oliver | david@g <[email-masked]>uardianproject.info |
http://g <http://olivercoady.com>uardianproject.info | @davidmoliver | +1
970 368 2366

---------- Forwarded message ---------
From: Christopher Wood <[email-masked]>
Date: Wed, Jul 29, 2020 at 8:49 AM
Subject: [Masque] Adoption call for "The CONNECT-UDP HTTP Method"
To: <[email-masked]>

Thanks,
Chris and Eric

---

From: Martin Duke <[email-masked]>
Date: Thu, 30 Jul 2020 16:08:48 -0700

I support adoption. Here are some review comments:

Sec 3. "A tunnel is closed when a tunnel intermediary detects that either
side has closed its connection:" In some cases, the one side may be a
stream, not a connection.

sec 6. " Therefore it needs to respond to the CONNECT-UDP request without
waiting for a TCP SYN-ACK."

It might be good to clarify if this should happen before or after the
server attempts to resolve the target domain name.

On Thu, Jul 30, 2020 at 4:59 AM David Oliver <[email-masked]>
wrote:

> David M. Oliver | david@g <david@olivercoady..com>uardianproject.info |
> http://g <http://olivercoady.com>uardianproject.info
> <http://uardianproject..info> | @davidmoliver | +1 970 368 2366
>
>