Subject: Re: [Masque] Adoption call for "The CONNECT-UDP HTTP Method"

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 5 Aug 2020 11:12:05 +0000

I support adoption of this draft as a good starting point for this work. I think we further need to discussion how simple/minimal the approach could or should be. I'm in favor of defining a base protocol that covers a large set of the needs of signaling support rather than discovering later that we missed something important.

On 29.07.20, 14:49, "Masque on behalf of Christopher Wood" <[email-masked] on behalf of [email-masked]> wrote:

    During yesterday's MASQUE WG meeting, there was strong support in favor of adopting draft-schinazi-masque-connect-udp as a WG item. To that end, this email begins the call for adoption of the document, in its current form, as a starting point. We expect to work through the issues raised both in the meeting and on the list going forward. 

    Please let the WG know if you support adoption, and if so, are willing to contribute to the discussion and review drafts. If you oppose adoption, please explain why. 

    The document may be found here:

       https://datatracker.ietf.org/doc/draft-schinazi-masque-connect-udp/

    And the source may be found here:

       https://protect2.fireeye.com/v1/url?k=e2c02dcb-bc70b051-e2c06d50-867b36d1634c-47a43dded4330ced&q=1&e=ca4bfa5b-0195-4e68-bee9-59f18ae89756&u=https%3A%2F%2Fgithub.com%2FDavidSchinazi%2Fmasque-drafts

    This call for adoption will conclude on August 14.

    Thanks, 
    Chris and Eric

    -- 
    Masque mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/masque

---

From: Florin Baboescu <[email-masked]>
Date: Wed, 5 Aug 2020 08:50:05 -0700

Dear all,
I also support the adoption of this draft as well as the comments made by
Mirja below.
Thank you.
-Florin

-----Original Message-----
From: Masque [mailto:[email-masked]] On Behalf Of Mirja Kuehlewind
Sent: Wednesday, August 5, 2020 4:12 AM
To: Christopher Wood <[email-masked]>; [email-masked]
Subject: Re: [Masque] Adoption call for "The CONNECT-UDP HTTP Method"

I support adoption of this draft as a good starting point for this work. I
think we further need to discussion how simple/minimal the approach could or
should be. I'm in favor of defining a base protocol that covers a large set
of the needs of signaling support rather than discovering later that we
missed something important.

On 29.07.20, 14:49, "Masque on behalf of Christopher Wood"
<[email-masked] on behalf of [email-masked]> wrote:

    During yesterday's MASQUE WG meeting, there was strong support in favor
of adopting draft-schinazi-masque-connect-udp as a WG item. To that end,
this email begins the call for adoption of the document, in its current
form, as a starting point. We expect to work through the issues raised both
in the meeting and on the list going forward.

    Please let the WG know if you support adoption, and if so, are willing
to contribute to the discussion and review drafts. If you oppose adoption,
please explain why.

    Thanks,
    Chris and Eric

---

From: Sean Turner <[email-masked]>
Date: Thu, 6 Aug 2020 00:27:40 -0400

I would like to see this draft adopted. At a minimum I am willing to review, and may even have something useful to contribute (the draft comes in at a whopping 7 pages).

sspt

> On Jul 29, 2020, at 08:49, Christopher Wood <[email-masked]> wrote:
> 
>   https://github.com/DavidSchinazi/masque-drafts
>

---

From: Mike Bishop <[email-masked]>
Date: Thu, 13 Aug 2020 13:42:28 +0000

Late to the party, since I've been offline.  I support adoption for the
spirit of the solution, have already provided some comments on the specific
draft, and will doubtless have more.  My key piece of feedback remains that
draft-ietf-httpbis-semantics prohibits
<https://httpwg.org/http-core/draft-ietf-httpbis-semantics-latest.html#targe
t.resource>  the request target form used in this draft, so we'll need to
hash that out with the HTTP WG.

However, there are two special, method-specific forms allowed for the
request target in specific circumstances:

*        For CONNECT (Section 8.3.6), the request target is the host name
and port number of the tunnel destination, separated by a colon.

*        For OPTIONS (Section 8.3.7), the request target can be a single
asterisk ("*").

See the respective method definitions for details. These forms MUST NOT be
used with other methods.

-----Original Message-----
From: Masque <[email-masked]> On Behalf Of Christopher Wood
Sent: Wednesday, July 29, 2020 8:49 AM
To: [email-masked]
Subject: [Masque] Adoption call for "The CONNECT-UDP HTTP Method"

During yesterday's MASQUE WG meeting, there was strong support in favor of
adopting draft-schinazi-masque-connect-udp as a WG item. To that end, this
email begins the call for adoption of the document, in its current form, as
a starting point. We expect to work through the issues raised both in the
meeting and on the list going forward. 

Please let the WG know if you support adoption, and if so, are willing to
contribute to the discussion and review drafts. If you oppose adoption,
please explain why. 

    <https://datatracker.ietf.org/doc/draft-schinazi-masque-connect-udp/>
https://datatracker.ietf.org/doc/draft-schinazi-masque-connect-udp/

    <https://github.com/DavidSchinazi/masque-drafts>
https://github.com/DavidSchinazi/masque-drafts

Thanks, 

Chris and Eric

-- 

Masque mailing list

 <mailto:[email-masked]> [email-masked]

 <https://www.ietf.org/mailman/listinfo/masque>
https://www.ietf.org/mailman/listinfo/masque

---

From: "Roy T. Fielding" <[email-masked]>
Date: Thu, 13 Aug 2020 13:18:39 -0700

I don’t want to give folks the impression that this is a requirement in httpbis. It has been a requirement of HTTP/1.1 since 1995 and that will not change in this revision.

The short answer is that if a new method is defined, it must use a full URI or its absolute path as the request target.

No further exceptions are allowed by HTTP because intermediaries need to process messages even when they don’t know the method definition.

....Roy

> On Aug 13, 2020, at 6:42 AM, Mike Bishop <[email-masked]> wrote:
> 
> 
> Late to the party, since I've been offline.  I support adoption for the spirit of the solution, have already provided some comments on the specific draft, and will doubtless have more.  My key piece of feedback remains that draft-ietf-httpbis-semantics prohibits the request target form used in this draft, so we’ll need to hash that out with the HTTP WG.
>  
> However, there are two special, method-specific forms allowed for the request target in specific circumstances:
> ·        For CONNECT (Section 8.3.6), the request target is the host name and port number of the tunnel destination, separated by a colon.
> ·        For OPTIONS (Section 8.3.7), the request target can be a single asterisk ("*").
> See the respective method definitions for details. These forms MUST NOT be used with other methods.
>

---

From: David Schinazi <[email-masked]>
Date: Thu, 13 Aug 2020 15:30:45 -0700

Thanks Mike and Roy.

I've written up your points in the following GitHub issue:
https://github.com/DavidSchinazi/masque-drafts/issues/29

Since you consider this non-adoption-blocking, we can work on fixing it
post-adoption.

David

On Thu, Aug 13, 2020 at 1:18 PM Roy T. Fielding <[email-masked]> wrote:

> I don’t want to give folks the impression that this is a requirement in
> httpbis. It has been a requirement of HTTP/1.1 since 1995 and that will not
> change in this revision.
>
> The short answer is that if a new method is defined, it must use a full
> URI or its absolute path as the request target.
>
> No further exceptions are allowed by HTTP because intermediaries need to
> process messages even when they don’t know the method definition.
>
> .....Roy
>
>
> draft, and will doubtless have more.  My key piece of feedback remains that draft-ietf-httpbis-semantics
> prohibits
> <https://httpwg.org/http-core/draft-ietf-httpbis-semantics-latest.html#target.resource>
> the request target form used in this draft, so we’ll need to hash that out
> with the HTTP WG.
>
>
>
> ·        For CONNECT (Section 8.3.6), the request target is the host name

---

From: "Christopher Wood" <[email-masked]>
Date: Sat, 15 Aug 2020 06:08:10 -0700

The adoption call is now complete. It looks like we have consensus to adopt this draft as a WG item. David, can you please submit draft-ietf-masque-connect-udp-00 when convenient?

Thanks to everyone who chimed in and provided feedback!

Best,
Chris and Eric

On Thu, Aug 13, 2020, at 3:30 PM, David Schinazi wrote:
> >> Late to the party, since I've been offline.  I support adoption for the spirit of the solution, have already provided some comments on the specific draft, and will doubtless have more.  My key piece of feedback remains that draft-ietf-httpbis-semantics prohibits <https://httpwg.org/http-core/draft-ietf-httpbis-semantics-latest.html#target.resource> the request target form used in this draft, so we’ll need to hash that out with the HTTP WG.____
> 
> >> __ __
> 
> >> However, there are two special, method-specific forms allowed for the request target in specific circumstances:____
> 
> >> ·        For CONNECT (Section 8.3.6), the request target is the host name and port number of the tunnel destination, separated by a colon.____
> 
> >> ·        For OPTIONS (Section 8.3.7), the request target can be a single asterisk ("*").____
> 
> >> See the respective method definitions for details. These forms MUST NOT be used with other methods.____
> 
> >> __ __
> 
> >> __ __
> >> During yesterday's MASQUE WG meeting, there was strong support in favor of adopting draft-schinazi-masque-connect-udp as a WG item. To that end, this email begins the call for adoption of the document, in its current form, as a starting point. We expect to work through the issues raised both in the meeting and on the list going forward. ____
> 
> >> __ __
> 
> >> Please let the WG know if you support adoption, and if so, are willing to contribute to the discussion and review drafts. If you oppose adoption, please explain why. ____
> 
> >> __ __
> 
> >> The document may be found here:____
> 
> >> __ __
> 
> >>    https://datatracker.ietf.org/doc/draft-schinazi-masque-connect-udp/____
> 
> >> __ __
> 
> >> And the source may be found here:____
> 
> >> __ __
> 
> >>    https://github.com/DavidSchinazi/masque-drafts____
> 
> >> __ __
> 
> >> This call for adoption will conclude on August 14.____
> 
> >> __ __
> 
> >> Thanks, ____
> 
> >> Chris and Eric____
> 
> >> __ __
> 
> >> -- ____
> 
> >> Masque mailing list____
> 
> >> [email-masked]
> 
> >> https://www.ietf.org/mailman/listinfo/masque____
> 
> > -- 
> > Masque mailing list
> > [email-masked]