Subject: [Masque] CONNECT-IP

From: David Schinazi <[email-masked]>
Date: Mon, 12 Apr 2021 15:35:13 -0700

Hi MASQUE enthusiasts,

At IETF 110, there appeared to be a change in the MASQUE working group
mindset where the IP Proxying Requirements doc seemed to have produced its
desired outcome, and that it might now be the time to switch gears to
proposing designs and solutions. In order to help with this, the authors of
draft-ietf-masque-ip-proxy-reqs
<https://datatracker.ietf.org/doc/html/draft-ietf-masque-ip-proxy-reqs>
have written up a proposal that matches those requirements:
draft-cms-masque-connect-ip
<https://datatracker.ietf.org/doc/html/draft-cms-masque-connect-ip>. Our
intent was to build a minimal protocol that met the requirements previously
discussed in the working group.

Please let us know what you think!
David

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 13 Apr 2021 00:03:22 +0100

Hi MAQUE enthusiast enthusiasts!

(dons flame suit) Just as a matter of presentation, I quite like the way
HTTP/3 does it. So for all of your messages rather than

IP_PACKET Message {
  IP Packet (...),
}

Figure 3: IP_PACKET Message Format

you could present it like

IP_PACKET Message {
  CONNECT-IP Stream Chunk Type (i) = 0x00,
  CONNECT-IP Stream Chunk Length (i),
  IP Packet (..),
}

this works even nicer for the messages with well-sized fields

ROUTE_ADVERTISEMENT Message {
  CONNECT-IP Stream Chunk Type (i) = 0x03,
  CONNECT-IP Stream Chunk Length (i) = 64..144,
  IP Version (8),
  IP Address (32..128),
  IP Prefix Length (8),
}

ROUTE_RESET Message {
  CONNECT-IP Stream Chunk Type (i) = 0x05,
  CONNECT-IP Stream Chunk Length (i) = 0,
}

Cheers,

Lucas

---

From: David Schinazi <[email-masked]>
Date: Mon, 12 Apr 2021 16:51:50 -0700

Congratulations Lucas, you have won the prize of most editorial comment!
Please collect your trophy from the front desk, it is a small statue of a
bikeshed that you can paint at home as long as you reach WG consensus on a
color.

David

---

From: "Christopher Wood" <[email-masked]>
Date: Tue, 13 Apr 2021 06:29:15 -0700

On Mon, Apr 12, 2021, at 4:51 PM, David Schinazi wrote:
> Congratulations Lucas, you have won the prize of most editorial 
> comment! Please collect your trophy from the front desk, it is a small 
> statue of a bikeshed that you can paint at home as long as you reach WG 
> consensus on a color.

Heh :-) Jokes aside, Lucas, would you mind filing your suggestion as an issue?

Thanks,
Chris

> David
> 
> On Mon, Apr 12, 2021 at 4:03 PM Lucas Pardue <[email-masked]> wrote:
> > (dons flame suit) Just as a matter of presentation, I quite like the way HTTP/3 does it. So for all of your messages rather than 
> > 
> > IP_PACKET Message {
>   IP Packet (...),
> }
> 
> -- 
> Masque mailing list
> [email-masked] <mailto:Masque%40ietf.org>
> https://www.ietf.org/mailman/listinfo/masque
>

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 19 Apr 2021 11:51:24 +1000

On Tue, Apr 13, 2021, at 08:35, David Schinazi wrote:
> <https://datatracker.ietf.org/doc/html/draft-cms-masque-connect-ip>. 

This seems like a reasonable start.  The route advertisement stuff seems largely reasonable.  I opened an issue regarding MTU.  No doubt there are other things to work through, but that's what this group is here for.