Subject: [Masque] IP packet proxying

From: "Christopher Wood" <[email-masked]>
Date: Wed, 14 Apr 2021 06:01:34 -0700

During IETF 110, we had a show of hands as to whether or not the IP proxying requirements should accommodate proxying payloads (instead of whole IP packets). There was rough consensus to not support payload proxying in the base protocol, though we need to confirm on the list. This email starts that process. Specifically, we would like to know if you think the base protocol should support proxying IP packet payloads (in contrast to, say, this being negotiated and done with an extension). Please reply to this thread with your opinion before April 27.

Thanks,
Chris and Eric

---

From: Dallas McCall <[email-masked]>
Date: Wed, 14 Apr 2021 09:28:25 -0400

I believe that payload proxying should not be a part of the base protocol,
but that we should ensure it is possible to be negotiated by way of an
extension.

On Wed, Apr 14, 2021 at 9:02 AM Christopher Wood <[email-masked]>
wrote:

> During IETF 110, we had a show of hands as to whether or not the IP
> proxying requirements should accommodate proxying payloads (instead of
> whole IP packets). There was rough consensus to not support payload
> proxying in the base protocol, though we need to confirm on the list. This
> email starts that process. Specifically, we would like to know if you think
> the base protocol should support proxying IP packet payloads (in contrast
> to, say, this being negotiated and done with an extension). Please reply to
> this thread with your opinion before April 27.
>
> Thanks,
> Chris and Eric
>
> --
> Masque mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/masque
>

-- 
Dallas

---

From: Alex Chernyakhovsky <[email-masked]>
Date: Wed, 14 Apr 2021 10:31:30 -0400

I agree with Dallas, and believe it should not be part of the base protocol
but should be possible to do by way of extensions.

Sincerely,
-Alex

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 14 Apr 2021 16:33:36 +0000

I don't think that a 11/17 result can be called rough consensus. I would say we have no consensus so far how to move forward.

On 14.04.21, 15:02, "Masque on behalf of Christopher Wood" <[email-masked] on behalf of [email-masked]> wrote:

    Thanks,
    Chris and Eric

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 14 Apr 2021 09:41:19 -0700

Mirja,

I do sort of agree with you about the strength of the consensus call.

However, this is a *requirements* document, and so any new requirements
should have some level of consensus. Given that payload proxying doesn't
even have a majority, I don't think it could be called consensus, and
therefore it shouldn't go into a requirement. Of course, nothing prevents
the final protocol from having functionality that's not in the requirements
document, so you're free to propose something as part of the protocol work.

-Ekr

On Wed, Apr 14, 2021 at 9:34 AM Mirja Kuehlewind <mirja.kuehlewind=
[email-masked]> wrote:

> I don't think that a 11/17 result can be called rough consensus. I would
> say we have no consensus so far how to move forward.
>
> On 14.04.21, 15:02, "Masque on behalf of Christopher Wood" <
> [email-masked] on behalf of [email-masked]> wrote:
>

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 14 Apr 2021 09:52:17 -0700

I think we should not require payload processing in the requirements doc.

Second, I think we should try to declare victory on the requirements
document and start designing protocols. Are there any really hard blockers
on the requirements document, given that it's not even going to be
published as an RFC?

-Ekr

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 14 Apr 2021 10:06:25 -0700

> On Apr 14, 2021, at 9:52 AM, Eric Rescorla <[email-masked]> wrote:
> 
> Second, I think we should try to declare victory on the requirements document and start designing protocols. Are there any really hard blockers on the requirements document, given that it's not even going to be published as an RFC?

+1, let’s move on. It’s done what it needed to.

Tommy
> 
> -Ekr
> 
> 
> On Wed, Apr 14, 2021 at 6:02 AM Christopher Wood <[email-masked] <mailto:[email-masked]>> wrote:
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/masque <https://www.ietf.org/mailman/listinfo/masque>
> -- 
> Masque mailing list
> [email-masked]

---

From: David Schinazi <[email-masked]>
Date: Thu, 15 Apr 2021 14:44:54 -0700

+1. I agree that we're pretty much done with requirements. Let's build a
solution that proxies IP Packets, but that is extensible enough so that it
is possible to build an extension that can proxy IP Payloads.

David

---

From: Eric Kinnear <[email-masked]>
Date: Thu, 29 Apr 2021 02:38:00 -0700

Hi all, 

Thanks to everyone who chimed in on the remaining topics for this document. Chris and I are reviewing the feedback and discussing next steps. Stay tuned!

Thanks,
Eric

> On Apr 15, 2021, at 2:44 PM, David Schinazi <[email-masked]> wrote:
> 
> +1. I agree that we're pretty much done with requirements. Let's build a solution that proxies IP Packets, but that is extensible enough so that it is possible to build an extension that can proxy IP Payloads.
> 
> David
> 
> 
> On Wed, Apr 14, 2021 at 10:06 AM Tommy Pauly <tpauly=[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
>> On Apr 14, 2021, at 9:52 AM, Eric Rescorla <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Eric Kinnear <[email-masked]>
Date: Fri, 30 Apr 2021 15:34:29 -0700

Closing the loop here, please see the other thread: https://mailarchive.ietf.org/arch/msg/masque/JYdaIfDlK3T7RRzxt8L-luygg_8/ <https://mailarchive.ietf.org/arch/msg/masque/JYdaIfDlK3T7RRzxt8L-luygg_8/>

Thanks,
Eric and Chris

> On Apr 29, 2021, at 2:38 AM, Eric Kinnear <ekinnear=[email-masked]> wrote:
> 
> Hi all, 
> 
>> On Apr 15, 2021, at 2:44 PM, David Schinazi <[email-masked] <mailto:[email-masked]>> wrote:
>>