Subject: [mdnsext] shift from mdns to xmdns

From: Indtiny s <[email-masked]>
Date: Tue, 13 Nov 2012 12:43:18 -0500

Hi,

Basically I am trying to bridge the gap between mdns and xmdns on
mdnsrespondr from apple , after going through the few document
 I got the the below things ,
1. Change the mulitcast address from 224.0.0.251 to 224.0.0.x as per the
some RFC
2. And Hop Limit/TTL to supporting RFC  values
3. Change the local to site when supporting site TLD

If I think in the view of a device which register/ browse the service on
site . are the above steps enough or do I need consider still to support
xmdns ..?

Rgds
Indra

---

From: Stuart Cheshire <[email-masked]>
Date: Tue, 13 Nov 2012 21:28:33 -0800

On 13 Nov 2012, at 9:43, Indtiny s wrote:

> Hi,
> 
> Basically I am trying to bridge the gap between mdns and xmdns on mdnsrespondr from apple , after going through the few document 
> 1. Change the mulitcast address from 224.0.0.251 to 224.0.0.x as per the some RFC 
> If I think in the view of a device which register/ browse the service on site . are the above steps enough or do I need consider still to support xmdns ..?

The point of this mailing list is to work out the best solution for larger-area service discovery.

Merely changing the multicast address to a larger scope may not be the best answer. Multicast is good for small networks with no infrastructure. Just making the multicast go further works in some sense, but at a cost that is unacceptable on most large networks.

Hence the need to work out a solution that provides the desired results, but without an unacceptable traffic level.

Stuart Cheshire