Subject: Re: [mdnsext] xmDNS support in mdnsresponder for homenet

From: Ray Bellis <[email-masked]>
Date: Thu, 1 Nov 2012 08:19:36 +0000

On 31 Oct 2012, at 16:27, Indtiny s <[email-masked]<mailto:[email-masked]>> wrote:

Hi,
The document is almost concluded the basic status . http://tools.ietf.org/html/draft-lynn-homenet-site-mdns-01

Due to some urgent requirment I need to go with adding the basic ".site"  domain ,i.e Any DNS query for a name ending with ".site." MUST be sent to the xmDNS multicast address (FF05::FB ) and its IPv4 equivalent to 239.255.255.239.

Please note that there will very likely be a new gTLD of '.site' some time within the next 18 months.

Whilst IETF apparently has the right to reserve TLDs for 'special use', IMHO we are unable to pre-empt any of those that have been applied for in the current round of new gTLD applications.

Just sayin'

Ray

---

From: Indtiny s <[email-masked]>
Date: Sun, 4 Nov 2012 12:05:55 -0500

Hi,

Thanks for providing the useful suggestion , due to some
urgent requirement I have to support the xmDNS support  with TLD name
"site" .

Can someone help me , How and what exactly I can start with mdnsresponder
code(particularly changing the multicast address)  , in-order support the
homenet RFC ..?

Rgds
Indra

---

From: Joe Abley <[email-masked]>
Date: Thu, 15 Nov 2012 12:48:08 -0500

Hi Ray,

On 2012-11-01, at 04:19, Ray Bellis <[email-masked]> wrote:

> On 31 Oct 2012, at 16:27, Indtiny s <[email-masked]> wrote:
> 

I confess I'm not intimately familiar with the new gTLD application process, but I don't think that's quite right. There are numerous steps in the approval process by which names can be turned down on technical grounds, regardless of whether they have been formally reserved by the IETF.

For example, applications for the .WORKGROUP top-level domain are unlikely to be accepted, since they are likely to conflict with (non-standardised) operational reality. I understand that non-conflicted, qualified panellists have been assembled to make this determination.

It would be fairly straightforward to get an answer to this from ICANN if this list would like to know the possible implications of a design that made special use of .SITE. I can make introductions if that seems useful.

According to <http://gtldresult.icann.org/application-result/applicationstatus/viewstatus> five separate applications have been received for .SITE.

Joe