Subject: Re: [mdnsext] Interim Solution

From: "Holland, Ryan" <[email-masked]>
Date: Thu, 6 Dec 2012 20:55:45 +0000

Neil, well put. I second this specific request.

===========
Ryan Holland
Senior Network Engineer
Office of the Chief Information Officer
The Ohio State University
614-292-9906     [email-masked]<mailto:[email-masked]>

From: "Johnson, Neil M" <[email-masked]<mailto:[email-masked]>>
Subject: [mdnsext] Interim Solution
Date: December 6, 2012 2:47:08 PM EST
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

While pursuing a permanent solution for using mDNS  across L2 boundaries is all well and good,  demand continues to grow from our users to do something, anything to make this work.

Since the biggest demand seems to be from users wanting to use Airplay from IOS and MAC OS devices, I would propose as an Interim solution a change to the those devices to allow one to statically enter the DNS hostname or IPv4 address of the Airplay end-device (Apple TV or Airport Express). In addition the ability to save ("bookmark") the DNS name or IPv4 address of the Airplay end-device on an iPhone, iPad, or MacBook Pro would be greatly appreciated.

Thanks.

-Neil

--
Neil Johnson
Network Engineer
The University of Iowa
Phone: 319 384-0938
Fax: 319 335-2951
Mobile: 319 540-2081
E-Mail: [email-masked]<mailto:[email-masked]>

_______________________________________________
mdnsext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mdnsext

---

From: Alf Watt <[email-masked]>
Date: Thu, 6 Dec 2012 22:17:19 +0000

Neil,

This is really a request for Apple, there are probably a few Apple employees on the list but if you want them to look at it you should file a bug report:

	https://bugreport.apple.com/

The entire point of Zeroconf is to avoid users having to enter this type of information. One solution is to use either avahi or the dns-sd command line tool to create static proxy registration for specific devices:

	http://stackoverflow.com/questions/8153979/dns-sd-how-to-manually-register-a-remote-service

For e.g. you could add a proxy record for goggle as follows:

	dns-sd -P Google _http._tcp local 80 google.com google.com path=/

The charter of this working group is to come up with a dynamic solution to the same problem among other issues.

Best,
Alf

On Dec 6, 2012, at 12:00 PM, [email-masked] wrote:

> From: "Johnson, Neil M" <[email-masked]>
> Date: December 6, 2012 11:47:08 AM PST
> To: "[email-masked]" <[email-masked]>
> 
> 
>

---

From: james woodyatt <[email-masked]>
Date: Fri, 07 Dec 2012 16:46:47 -0800

> 	https://bugreport.apple.com/

This is exactly correct.

--
james woodyatt <[email-masked]>
core os networking