Subject: [mdnsext] dnssdext charter

From: "Ralph Droms (rdroms)" <[email-masked]>
Date: Mon, 26 Aug 2013 17:07:36 +0000

I'm revising the draft dnssdext charter according to the discussion during the BoF in Berlin.  One issue that occurs to me that we didn't explicitly discuss during the BoF is the list of the deployment scenarios to be considered by the WG.  The draft charter includes a list of four scenarios:

   a) Commercial enterprise networks
   b) Academic/educational/university campus networks
   c) Multi-link home networks, such as those envisaged by the
      HOMENET WG 
   d) Multi-link/single subnet (mesh) networks, such as those
      described by the ZigBee Alliance Z-IP specification

while draft-lynn-mdnsext-requirements includes a list of six scenarios:

   (A) Personal Area networks, e.g., one laptop and one printer.
   This is the simplest example of an mDNS network. 

   (B) Home networks, consisting of:

   * Single exit router: the network may have multiple upstream
     providers or networks, but all outgoing and incoming trafic goes
     through a single router.

   * One level depth: all links on the network are connected to the
     same default router.

   * Single administrative domain: all nodes under the same admin
     entity.

   (C) Like B but may have a tree of links behind the single exit
   router.  However, the forwarding nodes are almost self-configured
   and do not require routing protocol administrators.

   (D) Enterprise networks, consisting of:

   * Any depth of the forwarding tree, under a single administrative
     domain.  The large majority of the forwarding and security
     devices are configured.

   (E) Higher Education networks, consisting of:

   * Any depth of the forwarding tree, core network under a central
     administrative domain but leaf networks under multiple
     administrative entities.  The large majority of the forwarding
     and security devices are configured.

   (F) Mesh networks such as RPL/6LoWPAN, multi-link but single prefix
   networks.

The list of scenarios from draft-lynn-mdnsext-requirements was the basis for discussion of requirements during the BoF.

We likely need to coordinate the list of requirements in the charter with the list in the draft-lynn-mdnsext-requirements.  The two lists are actually not that far apart; the requirements docs includes (A) which is not in the draft charter, and (B) and (C) could perhaps be combined into one scenario, matching c) from the charter.

I'm looking for consensus about how to proceed:

* Modify the charter to align with draft-lynn-mdnsext-requirements
* Modify draft-lynn-mdnsext-requirements to align with the charter
* Replace the specific list of scenarios from the charter with a pointer to the requirements document
* Modify both draft-lynn-mdnsext-requirements and the charter to bring them into alignment

Note that I'm deferring consideration of specific edits to the scenarios, such as s/tree of links/arbitrary topology/ in (C) from draft-lynn-mdnsext-requirements.

- Ralph

---

From: peter van der Stok <[email-masked]>
Date: Tue, 27 Aug 2013 10:50:54 +0200

Ralph,

I would suggest to keep the 4 scenarios in the charter.
In the draft lynn-mdnsnext-requirements a mapping from req scenarios to 
charter scenarios can be done.
Remembering the discussions during the Bof, the req doc. may end up with 
more scenarios than its current 6.
Possibly they can be classified and then mapped to the 4 charter 
scenarios.

Peter

Ralph Droms (rdroms) schreef op 2013-08-26 19:07:
> I'm revising the draft dnssdext charter according to the discussion
> during the BoF in Berlin.  One issue that occurs to me that we didn't
> explicitly discuss during the BoF is the list of the deployment
> scenarios to be considered by the WG.  The draft charter includes a
> list of four scenarios:
> 
> The list of scenarios from draft-lynn-mdnsext-requirements was the
> basis for discussion of requirements during the BoF.
> 
> We likely need to coordinate the list of requirements in the charter
> with the list in the draft-lynn-mdnsext-requirements.  The two lists
> are actually not that far apart; the requirements docs includes (A)
> which is not in the draft charter, and (B) and (C) could perhaps be
> combined into one scenario, matching c) from the charter.
> 
> Note that I'm deferring consideration of specific edits to the
> scenarios, such as s/tree of links/arbitrary topology/ in (C) from
> draft-lynn-mdnsext-requirements.
> 
> - Ralph
> 
> _______________________________________________
> mdnsext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mdnsext

---

From: Kerry Lynn <[email-masked]>
Date: Tue, 27 Aug 2013 08:05:47 -0400

Ralph,

First, I'd propose that we put the proposed charter version(s) on github as
Carsten has done: https://github.com/6lo/charter.  Would you like me to do
that this evening?

Second, I believe the charter must include the base case that was added
in the last draft to make it explicit that any solution MUST NOT strand the
millions of mDNS servers (printers and the like) that have already been
deployed.

I agree with Peter that we probably don't need to include multiple homenet
scenarios in the charter, especially since we have no requirements from that
WG yet.

I would propose that we order the scenarios according to administrative
complexity, from base case to enterprise.  (It will be interesting to
define the
differences of enterprise dnssdext vs. fully managed DNS-SD.)

Lastly, are we set on the designation "dnssdext", and will it be in the Apps
area?

Regards, -K-

On Tue, Aug 27, 2013 at 4:50 AM, peter van der Stok <[email-masked]>wrote:

> Possibly they can be classified and then mapped to the 4 charter scenarios.
>
> Peter
>
>
>
>> b) Academic/educational/**university campus networks
>> while draft-lynn-mdnsext-**requirements includes a list of six scenarios:
>>
>> The list of scenarios from draft-lynn-mdnsext-**requirements was the
>> with the list in the draft-lynn-mdnsext-**requirements.  The two lists
>> * Modify the charter to align with draft-lynn-mdnsext-**requirements
>> * Modify draft-lynn-mdnsext-**requirements to align with the charter
>> * Modify both draft-lynn-mdnsext-**requirements and the charter to bring
>> them into alignment
>>
>> draft-lynn-mdnsext-**requirements.
>>
>> - Ralph
>>
>> ______________________________**_________________
>> mdnsext mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/**listinfo/mdnsext<https://www.ietf.org/mailman/listinfo/mdnsext>
>>
> ______________________________**_________________
> mdnsext mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/mdnsext<https://www.ietf.org/mailman/listinfo/mdnsext>
>

---

From: Ralph Droms <[email-masked]>
Date: Tue, 27 Aug 2013 15:34:49 -0700

> I would suggest to keep the 4 scenarios in the charter.

OK.  Keep them as is; no changes?

> In the draft lynn-mdnsnext-requirements a mapping from req scenarios to charter scenarios can be done.
> Remembering the discussions during the Bof, the req doc. may end up with more scenarios than its current 6.

OK.

- Ralph

---

From: Ralph Droms <[email-masked]>
Date: Tue, 27 Aug 2013 15:41:43 -0700

> Carsten has done: https://github.com/6lo/charter.  Would you like me to do

Although I think github is more mechanism than we need, I can't find a good alternative for posting a current charter so, yes, please put the proposed charter on github.  I've attached the initial draft charter from the BoF request and a revised charter with additional WG logistical info.

> complexity, from base case to enterprise.  (It will be interesting to define the

Please send text with a concrete proposal?

> Lastly, are we set on the designation "dnssdext", and will it be in the Apps

As far as I know, we're going with dnssdext.  Other suggestions can be considered.  I expect it will be in INT area.

- Ralph

> 
> Regards, -K-
> 
> 
> On Tue, Aug 27, 2013 at 4:50 AM, peter van der Stok <[email-masked]> wrote:
> Ralph,
>

---

From: Alf Watt <[email-masked]>
Date: Wed, 28 Aug 2013 01:11:45 +0000

I'd like to make sure we don't loose track of the 'A' Personal Area
Networks scenario, +1 for including that in the charter.

Best,
Alf

On 8/26/13 10:07 AM, "Ralph Droms (rdroms)" <[email-masked]> wrote:

>explicitly discuss during the BoF is the list of the deployment scenarios
>to be considered by the WG.  The draft charter includes a list of four
>scenarios:
>
>The list of scenarios from draft-lynn-mdnsext-requirements was the basis
>for discussion of requirements during the BoF.
>
>We likely need to coordinate the list of requirements in the charter with
>the list in the draft-lynn-mdnsext-requirements.  The two lists are
>actually not that far apart; the requirements docs includes (A) which is
>not in the draft charter, and (B) and (C) could perhaps be combined into
>one scenario, matching c) from the charter.
>
>Note that I'm deferring consideration of specific edits to the scenarios,
>such as s/tree of links/arbitrary topology/ in (C) from

---

From: "Albrecht, Harald" <[email-masked]>
Date: Wed, 28 Aug 2013 07:23:07 +0000

Hi,

just my two cents: I’m also under the impression that github is kind of too-big tool. I was thinking along the lines of a wiki system; is there one that the IETF operates for such purposes? It would give the opportunity to see the change history and multiple people may work on it simultaneously; similar to github but geared more towards texts. However, if there is no wiki then github surely is a good solution as it is readily available.

-- Harald

With best regards,
Harald Albrecht

Siemens AG
Industry Sector
Industry Automation Division
Industrial Automation Systems
I IA AS CTO DH 1
Gleiwitzer Str. 555
90475 Nuernberg, Germany
Tel: +49 911 895-3847
Fax: +49 911 895-2105
mailto:[email-masked]

Siemens Aktiengesellschaft: Chairman of the Supervisory Board: Gerhard Cromme; Managing Board: Joe Kaeser, Chairman, President and Chief Executive Officer; Roland Busch, Brigitte Ederer, Klaus Helmrich, Barbara Kux, Hermann Requardt, Siegfried Russwurm, Peter Y. Solmssen, Michael Suess; Registered offices: Berlin and Munich, Germany; Commercial registries: Berlin Charlottenburg, HRB 12300, Munich, HRB 6684; WEEE-Reg.-No. DE 23691322

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Ralph Droms
Gesendet: Mittwoch, 28. August 2013 00:42
An: Kerry Lynn
Cc: [email-masked]; [email-masked]
Betreff: Re: [mdnsext] dnssdext charter

- Ralph

>
> Regards, -K-
>
>
> On Tue, Aug 27, 2013 at 4:50 AM, peter van der Stok <[email-masked]<mailto:[email-masked]>> wrote:
> Ralph,
>
> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
_______________________________________________
mdnsext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mdnsext

---

From: Tim Chown <[email-masked]>
Date: Wed, 28 Aug 2013 09:44:08 +0100

> just my two cents: I’m also under the impression that github is kind of too-big tool. I was thinking along the lines of a wiki system; is there one that the IETF operates for such purposes? It woul…

I had also assumed we could use an IETF wiki, but it seems those are only available once a WG is formed, under the tools area.  

It would be nice for BoFs to have such a facility too - and very helpful for charter-bashing as we are here up to and even at a BoF meeting.  If there is such a facility, I can't find it, and would welcome a pointer. I have emailed the tools team to query/suggest it as github may be heavyweight for some.

Tim

---

From: SM <[email-masked]>
Date: Wed, 28 Aug 2013 01:54:00 -0700

Hi Tim,
At 01:44 28-08-2013, Tim Chown wrote:
>I had also assumed we could use an IETF wiki, but it seems those are 
>only available once a WG is formed, under the tools area.

See http://trac.tools.ietf.org/bof/trac/wiki/WikiStart

You could also use the Area wiki if the relevant Area Director is 
okay with that.

Regards,
-sm

---

From: Tim Chown <[email-masked]>
Date: Wed, 28 Aug 2013 10:44:29 +0100

> See http://trac.tools.ietf.org/bof/trac/wiki/WikiStart

Hi - thanks, I'm aware of that one, and used it for mdnsext/dnssdext, but it's somewhat clumsy being mixed in with other information and BoFs, espeially when we had over ten BoFs in Berlin; what I was hoping for was a dedicated wiki area as per the WGs, which could be used at the same time as a mailing list is formed and independently of whether/when a BoF is being held (for example there was no mdnsext BoF at IETF87, but there was a first one at 86 then a second at 88).

If candidate WGs were treated the same way as real WGs within the tools system, related drafts could presumably also be automatically listed, for example?

Tim

> You could also use the Area wiki if the relevant Area Director is okay with that.
> 
> Regards,
> -sm

---

From: Kerry Lynn <[email-masked]>
Date: Wed, 28 Aug 2013 08:47:07 -0400

There's Google Docs, but I think administering permissions might be work
than
the actual writing.  I can check into it if that will work for most people.

-K-

On Wed, Aug 28, 2013 at 5:44 AM, Tim Chown <[email-masked]> wrote:

> Hi - thanks, I'm aware of that one, and used it for mdnsext/dnssdext, but
> it's somewhat clumsy being mixed in with other information and BoFs,
> espeially when we had over ten BoFs in Berlin; what I was hoping for was a
> dedicated wiki area as per the WGs, which could be used at the same time as
> a mailing list is formed and independently of whether/when a BoF is being
> held (for example there was no mdnsext BoF at IETF87, but there was a first
> one at 86 then a second at 88).
>
> If candidate WGs were treated the same way as real WGs within the tools
> system, related drafts could presumably also be automatically listed, for
> example?
>
> Tim
>

---

From: Ralph Droms <[email-masked]>
Date: Wed, 28 Aug 2013 09:24:10 -0700

> If candidate WGs were treated the same way as real WGs within the tools system, related drafts could presumably also be automatically listed, for example?

The current set of tools seems to be part way there.  I've put a request in to see if BoFs can be made more equal to WGs in the tools.

- Ralph

---

From: SM <[email-masked]>
Date: Wed, 28 Aug 2013 14:47:46 -0700

Hi Tim,
At 02:44 28-08-2013, Tim Chown wrote:
>If candidate WGs were treated the same way as real WGs within the 
>tools system, related drafts could presumably also be automatically 
>listed, for example?

The IETF will end up having side-working groups.  It's not a good 
idea in my opinion. :-)

Regards,
-sm

---

From: Ralph Droms <[email-masked]>
Date: Wed, 28 Aug 2013 15:04:30 -0700

On Aug 28, 2013, at 2:47 PM 8/28/13, SM <[email-masked]> wrote:

> The IETF will end up having side-working groups.  It's not a good idea in my opinion. :-)

Suppose the instantiation of these candidate WGs were constrained with an expiration date?

- Ralph