Subject: [media-types] Review request for "application/vnd.imagemeter.image"

From: Dirk Farin <[email-masked]>
Date: Fri, 3 Mar 2017 12:50:17 +0100

Dear all,

please find at the end of this email the proposals for registering the two
related media-types "application/vnd.imagemeter.image" and
"application/vnd.imagemeter.folder".

Files of this type are specific for interchanging data of the "ImageMeter -
photo measure" application (currently Android only, but iOS, desktop
version will follow). These files are zip files containing images in
JPEG/PNG/PDF format enriched with overlaid user-drawn vector graphics,
geometric measurements, text annotations, spreadsheet tables, maybe audio
recordings, later.

The vnd.imagemeter.image subtype is for single, user annotated images,
while the vnd.imagemeter.folder subtype is for project folders with many
images, extra project metadata, summarizing spreadsheet tables...

My specific questions are:
- is the "application" type suitable, or would the "image" type be more
suitable, as these are basically images with user annotations and
supplementary information
- should I include the "+zip" suffix as these files are essentially zip
files of different pieces of data (similar as done for the OpenOffice
document formats).

Thank you,
  Dirk Farin

-------------------------------------------------------------------------

Type name: Application

Subtype name: Vendor Tree - vnd.imagemeter.image

Required parameters: none

Optional parameters: none

Encoding considerations: The content consists of an unrestricted sequence
of octets.

Security considerations:
1. Files do not contain executable content.
2. Files consist of image data in JPEG, PNG, or PDF format, and static
vector drawing and annotation data, encapsulated in a zip file.

Interoperability considerations: none

Published specification:
Files represent a ZIP archive of image data in JPEG, PNG, or PDF format,
and associated supplementary data like vector drawings, measurements, and
text annotations.
The specification of the supplementary data has not been published.

Applications that use this media type:
This media type is used only by the "ImageMeter - photo measure"
application.

Fragment identifier considerations:
N/A

Additional information:

  Deprecated alias names for this type: N/A
  Magic number(s): N/A
  File extension(s): .imi
  Macintosh file type code(s): N/A

Person & email address to contact for further information:
Dirk Farin
[email-masked]

Intended usage:    common
This media type is intended for exchange of images enriched with
measurements and annotations.

Restrictions on usage: none

Author:    Dirk Farin

Change controller: Dirk Farin

Provisional registration? (standards tree only):
N/A

-------------------------------------------------------------------------

Type name: Application

Subtype name: Vendor Tree - vnd.imagemeter.folder

Required parameters: none

Optional parameters: none

Encoding considerations: The content consists of an unrestricted sequence
of octets.

Security considerations:
1. Files do not contain executable content.
2. Files consist of several images in JPEG, PNG, or PDF format, and static
vector drawing and annotation data, encapsulated in a zip file.

Interoperability considerations: none

Published specification:
Files represent a ZIP archive of several images in JPEG, PNG, or PDF
format, and associated supplementary data like vector drawings,
measurements, spreadsheet tables, and text annotations.
The specification of the supplementary data has not been published.

Applications that use this media type:
This media type is used only by the "ImageMeter - photo measure"
application.

Fragment identifier considerations:
N/A

Additional information:

  Deprecated alias names for this type:    N/A
  Magic number(s): N/A
  File extension(s): .imf
  Macintosh file type code(s): N/A

Person & email address to contact for further information:
Dirk Farin
[email-masked]

Intended usage:    common
This media type is intended for exchange of images enriched with
measurements and annotations.

Restrictions on usage: none

Author:    Dirk Farin

Change controller: Dirk Farin

Provisional registration? (standards tree only):
N/A

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 3 Mar 2017 13:23:11 +0000

Hi Dirk,

> On 3 Mar 2017, at 11:50, Dirk Farin <[email-masked]> wrote:
> 
> Dear all,
> 
> please find at the end of this email the proposals for registering the two related media-types "application/vnd.imagemeter.image" and "application/vnd.imagemeter.folder".
> 
> Files of this type are specific for interchanging data of the "ImageMeter - photo measure" application (currently Android only, but iOS, desktop version will follow). These files are zip files containing images in JPEG/PNG/PDF format enriched with overlaid user-drawn vector graphics, geometric measurements, text annotations, spreadsheet tables, maybe audio recordings, later.
> 
> The vnd.imagemeter.image subtype is for single, user annotated images, while the vnd.imagemeter.folder subtype is for project folders with many images, extra project metadata, summarizing spreadsheet tables...
> 
> - is the "application" type suitable, or would the "image" type be more suitable, as these are basically images with user annotations and supplementary information

From your description "Image" seems to be a sensible top level media type to use.

> - should I include the "+zip" suffix as these files are essentially zip files of different pieces of data (similar as done for the OpenOffice document formats).

Yes.
> Encoding considerations: The content consists of an unrestricted sequence of octets.

Just say "binary" here.
> 2. Files consist of image data in JPEG, PNG, or PDF format, and static vector drawing and annotation data, encapsulated in a zip file.
> 
> Files represent a ZIP archive of image data in JPEG, PNG, or PDF format, and associated supplementary data like vector drawings, measurements, and text annotations.
> This media type is used only by the "ImageMeter - photo measure" application.
> 
> This media type is intended for exchange of images enriched with measurements and annotations.
> 
> Encoding considerations: The content consists of an unrestricted sequence of octets.
> 
> Security considerations:
> 2. Files consist of several images in JPEG, PNG, or PDF format, and static vector drawing and annotation data, encapsulated in a zip file.
> 
> Files represent a ZIP archive of several images in JPEG, PNG, or PDF format, and associated supplementary data like vector drawings, measurements, spreadsheet tables, and text annotations.
> This media type is used only by the "ImageMeter - photo measure" application.
> 
> This media type is intended for exchange of images enriched with measurements and annotations.
> 
> _______________________________________________
> media-types mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/media-types

---

From: Dirk Farin <[email-masked]>
Date: Fri, 3 Mar 2017 15:43:22 +0100

Hi Alexey,

thank you for the comments. I will add the "+zip" suffix.
BTW: is there any reason why there is no "+zip" suffix for other formats
that actually use zip archives (like OpenOffice ".odt")? Is that just
because they are older than when the suffix specification was introduced?
Or is it preferred to omit the suffix if there is no sensible way for the
user to manipulate the 'archive' manually in a consistent way?

After giving it more thoughts, I think I'll prefer to stick with the
"application" class, even though it would also fit into "image", because it
is not that clear that "vnd.imagemeter.folder" and possible future
extensions would fit into "image". Since distributing this over several
main types, it appears cleaner to me to use the "application" class.

Thanks,
  Dirk

2017-03-03 14:23 GMT+01:00 Alexey Melnikov <[email-masked]>:

> Files of this type are specific for interchanging data of the "ImageMeter
> - photo measure" application (currently Android only, but iOS, desktop

---

From: Graham Klyne <[email-masked]>
Date: Fri, 03 Mar 2017 16:00:21 +0000

Alexey,
Dirk,

>  From your description "Image" seems to be a sensible top level media type to use.

Hmmm... would "application" not be more appropriate for the "folder" type?  (I 
agree "image" for the other.)

#g
--

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 7 Mar 2017 12:56:21 +0000

Hi Dirk,

On 03/03/2017 14:43, Dirk Farin wrote:
> BTW: is there any reason why there is no "+zip" suffix for other 
> formats that actually use zip archives (like OpenOffice ".odt")? Is 
> that just because they are older than when the suffix specification 
> was introduced?
Yes, I think they predate the addition of the +zip suffix.
> Or is it preferred to omit the suffix if there is no sensible way for 
> the user to manipulate the 'archive' manually in a consistent way?
>
> "application" class, even though it would also fit into "image", 
> because it is not that clear that "vnd.imagemeter.folder" and possible 
> future extensions would fit into "image". Since distributing this over 
> several main types, it appears cleaner to me to use the "application" 
> class.
Fair enough.
>
> Thanks,
>   Dirk
>
>
> 2017-03-03 14:23 GMT+01:00 Alexey Melnikov <[email-masked] 
> <mailto:[email-masked]>>:
>
>     Hi Dirk,
>
>     On 3 Mar 2017, at 11:50, Dirk Farin <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>>     Dear all,
>>
>>     please find at the end of this email the proposals for
>>     registering the two related media-types
>>     "application/vnd.imagemeter.image" and
>>     Files of this type are specific for interchanging data of the
>>     "ImageMeter - photo measure" application (currently Android only,
>>     but iOS, desktop version will follow). These files are zip files
>>     containing images in JPEG/PNG/PDF format enriched with overlaid
>>     user-drawn vector graphics, geometric measurements, text
>>     annotations, spreadsheet tables, maybe audio recordings, later.
>>
>>     The vnd.imagemeter.image subtype is for single, user annotated
>>     images, while the vnd.imagemeter.folder subtype is for project
>>     folders with many images, extra project metadata, summarizing
>>     spreadsheet tables...
>>
>>     - is the "application" type suitable, or would the "image" type
>>     be more suitable, as these are basically images with user
>>     annotations and supplementary information
>
>>     - should I include the "+zip" suffix as these files are
>>     essentially zip files of different pieces of data (similar as
>>     done for the OpenOffice document formats).
>
>     Yes.
>>
>>     Thank you,
>>       Dirk Farin
>>
>>     2. Files consist of image data in JPEG, PNG, or PDF format, and
>>     static vector drawing and annotation data, encapsulated in a zip
>>     file.
>>
>>     Files represent a ZIP archive of image data in JPEG, PNG, or PDF
>>     measurements, and text annotations.
>>     [email-masked] <mailto:[email-masked]>
>>
>>     Intended usage:    common
>>     2. Files consist of several images in JPEG, PNG, or PDF format,
>>     and static vector drawing and annotation data, encapsulated in a
>>     zip file.
>>
>>     Files represent a ZIP archive of several images in JPEG, PNG, or
>>     PDF format, and associated supplementary data like vector
>>     drawings, measurements, spreadsheet tables, and text annotations.
>>     [email-masked] <mailto:[email-masked]>
>>
>>     Intended usage:    common
>>     [email-masked] <mailto:[email-masked]>
>>     <https://www.ietf.org/mailman/listinfo/media-types>
>
>
>
>

---

From: Mark Baker <[email-masked]>
Date: Wed, 8 Mar 2017 11:50:00 -0500

On Fri, Mar 3, 2017 at 11:00 AM, Graham Klyne <[email-masked]> wrote:
> Hmmm... would "application" not be more appropriate for the "folder" type?
> (I agree "image" for the other.)

+1