Subject: [media-types] Should the templates from https://www.iana.org/assignments/media-types/media-types.xhtml have names ending with .txt?

From: Guy Harris <[email-masked]>
Date: Sun, 20 Aug 2017 20:18:48 -0700

The names of the files you get when you click on the links in the "Template" columns of the tables are just the last components of the media type; that makes it harder to open them in text files.  (For example, application/vnd.tcpdump.pcap looks like a pcap capture file if you have Wireshark installed and it's registered for pcap files on your system.)

Should the template files have names ending with .txt?

Also, the download should perhaps offer a media type of application/text, to make it more likely that browsers will display them as text.

---

From: Guy Harris <[email-masked]>
Date: Sun, 20 Aug 2017 20:24:12 -0700

On Aug 20, 2017, at 8:18 PM, Guy Harris <[email-masked]> wrote:

> Also, the download should perhaps offer a media type of application/text

Sorry, text/plain.  Brain burp there.

(Change media type and suffix for any templates not in plain text form.)

---

From: Stian Soiland-Reyes <[email-masked]>
Date: Mon, 21 Aug 2017 08:16:48 +0000

I disagree – IMHO it’s more important that we have a 1:1 mapping from mime type to URI. In fact, it would to me be more important to add a web resource for those media types that for some reason (legacy or RFC) don’t have a corresponding web resource at https://www.iana.org/assignments/media-types/{mediatype} (even one that redirects)

--
Stian Soiland-Reyes, eScience Lab
School of Computer Science, The University of Manchester
http://orcid.org/0000-0001-9842-9718

From: Guy Harris<mailto:[email-masked]>
Sent: 21 August 2017 04:24
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [media-types] Should the templates from https://www.iana.org/assignments/media-types/media-types.xhtml have names ending with .txt?

_______________________________________________
media-types mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/media-types