Subject: RE: [mediactrl] Going forward with media server control - resend

From: Eric Burger <[email-masked]>
Date: Thu, 3 Feb 2005 19:55:03 GMT

No promises, but I usually get a suite at the Hilton, so I might be able to
host a small meeting.

> -----Original Message-----
> From: Even, Roni [mailto:[email-masked]]
> Sent: Monday, January 31, 2005 3:57 PM
> To: Chris Boulton; [email-masked]
> Subject: RE: [mediactrl] Going forward with media server control -
> resend
> 
> 
> Hi,
> I think Collin spoke with Allison and I am trying to find out from him
> what is the plan for Minneapolis
> Roni
> 
> -----Original Message-----
> From: Chris Boulton [mailto:[email-masked]] 
> Sent: Monday, January 31, 2005 3:21 PM
> To: Even, Roni; [email-masked]
> Subject: RE: [mediactrl] Going forward with media server control -
> resend
> 
> Roni,
> 
> 	This is starting to look good.  Specific comments will follow in
> a separate mail but it seems to capture most of the mailing list
> discussion so far.
> 
> Roni: Are we going to have a BOF in Minneapolis or an 
> informal meeting?
> 
> I don't think we had a conclusion in Boston apart from 
> agreement that:-
> 
> - We needed to speak to our 3GPP liaison officer to try and get
> sponsorship for this work.
> 
> - We needed to speak to Alison regarding best direction for the work
> (i.e. individual effort [to be attached to XCON at a later 
> date] vs. New
> WG).
> 
> - We need to provide more justification of our decision not to use
> H.248.
> 	- This leads to another question - 'Where should this work be
> documented?
> 
> I seem to recall that a rough consensus was that it may be a bit too
> early for a BOF in March, especially if we do not have the previous
> points adequately covered.  My preference would for us to 
> again have an
> informal meeting (admittedly this might be harder to 
> administer with the
> extra participants that a full IETF meeting provide).
> 
> I am more than happy to speak to the relevant parties on the groups
> behalf if this has not already happened - Could the guys in the know
> provide some feedback if they would like me to do this (Alan, Cullen,
> Adam).  Then I think we can move forward and by Paris have reasonable
> foundations for a BOF etc. 
> 
> Any thoughts welcomed on this as I feel we need to keep the wheels
> moving.
> 
> Best Regards,
> 
> Chris.
>   
> 
> -----Original Message-----
> From: Even, Roni [mailto:[email-masked]] 
> Sent: 31 January 2005 08:37
> To: [email-masked]
> Subject: [mediactrl] Going forward with media server control - resend
> 
> Hi guys,
> I submitted the attached draft.
> Are we going to have a BOF in Minneapolis or an informal meeting
> Roni
> 
> 
> This email and any attached files are confidential and copyright
> protected.  If you are not the addressee, any dissemination,
> distribution or copying of this communication is strictly prohibited.
> Unless otherwise expressly agreed in writing, nothing stated in this
> communication shall be legally binding.
> 
> --------------------------
> Ubiquity Software does not control or endorse the content, 
> messages or information found in this mail list and it 
> specifically disclaims any liability with regard to these 
> communications.
> Ubiquity Software reserves the right the restrict access to 
> any communications in violation of the Terms and Conditions 
> of Use for this website or as otherwise deemed improper.
> 
--------------------------
Ubiquity Software does not control or endorse the content, messages or information found in this mail list and it specifically disclaims any liability with regard to these communications.
Ubiquity Software reserves the right the restrict access to any communications in violation of the Terms and Conditions of Use for this website or as otherwise deemed improper.

---

From: "Chris Boulton" <[email-masked]>
Date: Fri, 4 Feb 2005 07:54:25 GMT

Why Eric - you are really spoiling us ;-).  Not sure what my mother
would say about that.

Sounds a good idea to me - might be worth polling the list closer to
time to try and get an approx figure (I wouldn't want to end up sitting
in Eric's bath).

Chris.

-----Original Message-----
From: Eric Burger [mailto:[email-masked]] 
Sent: 03 February 2005 19:50
To: [email-masked]
Subject: RE: [mediactrl] Going forward with media server control -
resend

No promises, but I usually get a suite at the Hilton, so I might be able
to
host a small meeting.

--------------------------
Ubiquity Software does not control or endorse the content, messages or
information found in this mail list and it specifically disclaims any
liability with regard to these communications.
Ubiquity Software reserves the right the restrict access to any
communications in violation of the Terms and Conditions of Use for this
website or as otherwise deemed improper.

---

From: "Chris Boulton" <[email-masked]>
Date: Mon, 7 Feb 2005 17:32:00 GMT

Hi all,
	Got some questions/observations on the current set of media
control requirements:-

Architecture:-

I'm not sure I fully agree with the diagram.  Can you explain more about
the role of the proxy server in this architecture?  I personally thought
the diagram should look as follows:-

                      XCON Protocol               +--------+
             +----------------------------------->|  XCON  |
             |                                  __|________|_
             |        SIP                      | Application |
             |     +-------------------------->| Server/Focus|
             |     |                           |   (B2BUA)   |
             |     |                           |_____________|
             |     |                               |    ^
             |     |                               |    |
             |     v                               |    |
        _____________                          SIP |    |
       |             |                             |    |AS-MS
       | Participant |                             |    |Protocol
       |_____________|                             |    |
                                                   |    |
                                                   |    |
                                                   |    |
                                                  _v____v_
                                                 |        |
                                                 | Media  |
                                                 | Server |
                                                 |________|

In this model the AS acts as a B2BUA which bridges the participant from
the Media server.  The AS would create a control leg between the media
server to negotiate the 'AS-MS' reliable control channel.  A participant
would then have an associated SIP session (for media etc.) 

General Protocol

11.  The MS should send a summary report when the session is terminated
by the AS.

Can we clarify this a little more please?  When we talk about 'session'
- are we referring to the Control session (reliable pipe that
set-up/control messages are being sent) OR the SIP session representing
an endpoint (Media negotiation).

13.  The MS should support DTMF detection (in band tones and RFC2833)

Should this really say something like 'The protocol should support the
reporting of DTMF digits detected using in band tones and RFC 2833'.

14.  The protocol shall include redundancy procedures.

Is this referring to the signaling protocol - If so wouldn't the focus
be on the associated SIP session for redundancy?  How does this impact
the new protocol?

16.  The AS should be able to reserve resources on the MS.  The
   resources models should be simple.  (this requirement needs more
   discussion)

I really think that we should start this discussion - especially when we
mention having 1:many and many:1 relationships.  How are we considering
this with multiple AS potentially connecting to one MS.  The only way I
can think of involves a centralized resource manager that certainly
moves away from being simple.   Same applies to 18:- 18.  The MS shall
inform the AS about any changes in it capacities.  The changes may be
due to reservation, internal usage or due to some malfunction.

21.  The MS shall supply the AS with sufficient information for the
   event package.

Can you clarify this please?

-----Original Message-----
From: Even, Roni [mailto:[email-masked]] 
Sent: 31 January 2005 08:37
To: [email-masked]
Subject: [mediactrl] Going forward with media server control - resend

Hi guys,

This email and any attached files are confidential and copyright protected.  If you are not the addressee, any dissemination, distribution or copying of this communication is strictly prohibited.  Unless otherwise expressly agreed in writing, nothing stated in this communication shall be legally binding.

---

From: "Even, Roni" <[email-masked]>
Date: Thu, 10 Feb 2005 15:32:15 GMT

Chris,

The issue of the proxy between the AS and MS was a point of discussion.
If SIP is going to be the protocol between the AS and MS then the
question was if the AS will handle the routing decision to the different
MS. If the AS has this functionality then you can say that he also acts
like a SIP proxy.
 
The other comments see inline
Roni

-----Original Message-----
From: Chris Boulton [mailto:[email-masked]] 
Sent: Monday, February 07, 2005 7:31 PM
To: Even, Roni; [email-masked]
Subject: RE: [mediactrl] Going forward with media server control -
resend

Hi all,

Architecture:-

                      XCON Protocol               +--------+

General Protocol

RE: My thought was the media usage and any RTCP information that only
the MS sees.

RE: OK

RE: I think we need to look at two directions. 
	1. If the AS fails what happens to the conference media session
on the MS. 
	2. If the MS fails how does the AS resume the conference (this
one is easier)

Can you clarify this please?
RE: An Example: The conference event package has information about who
are active speakers, this may be unknown to the AS.

-----Original Message-----
From: Even, Roni [mailto:[email-masked]] 
Sent: 31 January 2005 08:37
To: [email-masked]
Subject: [mediactrl] Going forward with media server control - resend

Hi guys,

---

From: "Chris Boulton" <[email-masked]>
Date: Thu, 10 Feb 2005 16:31:10 GMT

Some comments in-line.

-----Original Message-----
From: Even, Roni [mailto:[email-masked]] 
Sent: 10 February 2005 15:33
To: Chris Boulton; [email-masked]
Subject: RE: [mediactrl] Going forward with media server control -
resend

Chris,

[Chris Boulton] OK - perhaps I am taking the definition of the term
'proxy' in the purist form.  From the original diagram, the 'proxy' had
one incoming call leg and two outgoing.  For a proxy to act in this way
is surely a B2BUA?  This model seems a bit peculiar to me (and adds
complexity) but I'm sure it could be that I am missing something ;-).

Chris.

[snipped]

---

From: "Even, Roni" <[email-masked]>
Date: Thu, 10 Feb 2005 17:02:19 GMT

Chris,
Yes the two out going legs are misleading. They represent the SIP call
from the participant to the AS and from the AS to the MS. The proxy is
used for routing only. (it may be a CSCF in IMS)
Roni

-----Original Message-----
From: Chris Boulton [mailto:[email-masked]] 
Sent: Thursday, February 10, 2005 6:30 PM
To: Even, Roni; [email-masked]
Subject: RE: [mediactrl] Going forward with media server control -
resend

Some comments in-line.

-----Original Message-----
From: Even, Roni [mailto:[email-masked]] 
Sent: 10 February 2005 15:33
To: Chris Boulton; [email-masked]
Subject: RE: [mediactrl] Going forward with media server control -
resend

Chris,

Chris.

[snipped]

---

From: "Chris Boulton" <[email-masked]>
Date: Mon, 14 Feb 2005 10:18:17 GMT

OK - that makes more sense (Although I'm still in favor of the direct
interaction between the Application Server and the Media server).

Chris.

-----Original Message-----
From: Even, Roni [mailto:[email-masked]] 
Sent: 10 February 2005 17:03
To: Chris Boulton; [email-masked]
Subject: RE: [mediactrl] Going forward with media server control -
resend

Chris,

-----Original Message-----
From: Chris Boulton [mailto:[email-masked]] 
Sent: Thursday, February 10, 2005 6:30 PM
To: Even, Roni; [email-masked]
Subject: RE: [mediactrl] Going forward with media server control -
resend

Some comments in-line.

-----Original Message-----
From: Even, Roni [mailto:[email-masked]] 
Sent: 10 February 2005 15:33
To: Chris Boulton; [email-masked]
Subject: RE: [mediactrl] Going forward with media server control -
resend

Chris,

Chris.

[snipped]