Subject: [mediactrl] RE: [XCON] Media Server Control

From: "MARJOU Xavier RD-MAPS-LAN" <[email-masked]>
Date: Thu, 14 Jul 2005 23:19:51 +0100 (BST)

<FONT face=Arial 
color=#0000ff size=2>Hi,
<FONT face=Arial 
color=#0000ff size=2> 
<SPAN 
class=322375621-14072005>I think that having again another new 
protocol complicates things at the AS side and delays hopes to quickly 
have interoperable ASs and MSs (e.g. needs for MSCS 
stacks, for new APIs in AS, for new testing tools, 
...).
<SPAN 
class=322375621-14072005><FONT face=Arial color=#0000ff 
size=2> 
<FONT face=Arial 
color=#0000ff size=2>What is the blocking point when conveying 
XML commands in SIP messages (as done in MSCML and 
MSML)?
<FONT face=Arial 
color=#0000ff size=2> 
<FONT face=Arial 
color=#0000ff size=2>Best Regards,
Xavier

From: [email-masked] 
[mailto:[email-masked]] On Behalf Of Chris BoultonSent: 
vendredi 1 juillet 2005 11:41To: [email-masked]: 
[XCON] Media Server Control

<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">All,
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial"> 
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">            
Just a short mail to make you aware of a new draft that has been submitted to 
the internet draft archives.  It is a first attempt at defining a framework 
using SIP for media server control.  The draft can be found at <A 
href="http://www.ietf.org/internet-drafts/draft-boulton-media-server-control-00.txt">http://www.ietf.org/internet-drafts/draft-boulton-media-server-control-00.txt.  
All input is greatly appreciated.
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial"> 
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Please note that this draft is not 
submitted as part of the XCON Working Group so please do NOT provide comments on 
the XCON mailing list.  A dedicated mailing list has been set up to discuss 
this topic.  I have included the details at the end of the 
mail.
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial"> 
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Best Regards,
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial"> 
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Chris.
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial"> 
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial"> 
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">------------------------------------------------------------------------------------------------------------------
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial"> 
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Instructions:-
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial"> 
<FONT 
face=Arial size=2><SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">-<SPAN 
lang=EN-GB 
style="FONT-SIZE: 7pt">          
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">generate a mail to <A 
href="mailto:[email-masked]">[email-masked]
<FONT 
face=Arial size=2><SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">-<SPAN 
lang=EN-GB 
style="FONT-SIZE: 7pt">          
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">place text ‘subscribe mediactrl’ in 
the body of the message (plain text)
<FONT 
face=Arial size=2><SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">-<SPAN 
lang=EN-GB 
style="FONT-SIZE: 7pt">          
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Follow remaining on-screen 
instructions to confirm list subscription
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial"> 
<SPAN lang=EN-GB 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">All subsequent mails need to be sent 
to <A 
href="mailto:[email-masked]">[email-masked]
<SPAN 
style="FONT-WEIGHT: bold; FONT-SIZE: 10pt; COLOR: navy; FONT-STYLE: italic; FONT-FAMILY: Arial"> 
<SPAN 
style="FONT-SIZE: 10pt; FONT-FAMILY: Arial"> <FONT 
face=Verdana size=1 colour="#cccccc">Information contained in this e-mail and 
any attachments are intended for the use of the addressee only, and may contain 
confidential information of Ubiquity Software Corporation. All unauthorized use, 
disclosure or distribution is strictly prohibited.  If you are not the 
addressee, please notify the sender immediately and destroy all copies of this 
email.  Unless otherwise expressly agreed in writing signed by an officer 
of Ubiquity Software Corporation, nothing in this communication shall be deemed 
to be legally binding. Thank-you

---

From: Tim Melanchuk <[email-masked]>
Date: Thu, 14 Jul 2005 23:43:55 +0100 (BST)

hi xavier,
the primary issue is the use of sip info which the ietf does not
like to be used as a general purpose transport (although it
frequently is). sip info has been debated many times on different
ietf lists, with different proposals about how to overcome the
issues. for example, jonathan rosenberg wrote a draft on
"info considered harmful" and dean willis wrote a draft on
"info packages". both drafts are expired but you can probably
find them on line somewhere.
the goal of the mscs draft is to suggest an alternative
transport mechanism to sip info that leverages standardized
mechanisms (e.g. comedia). another possibility is to define
a new sip method. eric burger mentions this is a draft he
has recently released. both drafts stem from conversations
between chris, eric, and myself on media server models and
transport protocols. we thought that it would be beneficial
to bring our discussions to a wider audience to provoke
greater discussion of possible solutions and the issues.
cheers,
timm
MARJOU Xavier RD-MAPS-LAN wrote:
Hi,
 
I think that having again another new protocol complicates things at the 
AS side and delays hopes to quickly have interoperable ASs and MSs (e.g. 
needs for MSCS stacks, for new APIs in AS, for new testing tools, ...).
 
What is the blocking point when conveying XML commands in SIP 
messages (as done in MSCML and MSML)?
 
Best Regards,
Xavier

------------------------------------------------------------------------
*From:* [email-masked] [mailto:[email-masked]] *On Behalf 
Of *Chris Boulton
*Sent:* vendredi 1 juillet 2005 11:41
*To:* [email-masked]
*Subject:* [XCON] Media Server Control

All,

            Just a short mail to make you aware of a new draft that has 
been submitted to the internet draft archives.  It is a first attempt at 
defining a framework using SIP for media server control.  The draft can 
be found at 
http://www.ietf.org/internet-drafts/draft-boulton-media-server-control-00.txt.  
All input is greatly appreciated.

Please note that this draft is not submitted as part of the XCON Working 
Group so please do NOT provide comments on the XCON mailing list.  A 
dedicated mailing list has been set up to discuss this topic.  I have 
included the details at the end of the mail.

Best Regards,

Chris.

------------------------------------------------------------------------------------------------------------------

Instructions:-

-          generate a mail to [email-masked] 
<mailto:[email-masked]>

-          place text ‘subscribe mediactrl’ in the body of the message 
(plain text)

-          Follow remaining on-screen instructions to confirm list 
subscription

All subsequent mails need to be sent to 
[email-masked] 
<mailto:[email-masked]>

*//* 

Information contained in this e-mail and any attachments are intended 
for the use of the addressee only, and may contain confidential 
information of Ubiquity Software Corporation. All unauthorized use, 
disclosure or distribution is strictly prohibited.  If you are not the 
addressee, please notify the sender immediately and destroy all copies 
of this email.  Unless otherwise expressly agreed in writing signed by 
an officer of Ubiquity Software Corporation, nothing in this 
communication shall be deemed to be legally binding. Thank-you
--------------------------
Ubiquity Software does not control or endorse the content, messages or information found in this mail list and it specifically disclaims any liability with regard to these communications.
Ubiquity Software reserves the right the restrict access to any communications in violation of the Terms and Conditions of Use for this website or as otherwise deemed improper.