Subject: [mediactrl] reprompting capability for MSCML

From: "David Cromwell" <[email-masked]>
Date: Thu, 13 Apr 2006 19:04:45 +0100

<span
style='font-size:10.0pt'>I propose adding a reprompting capability to MSCML to
extend the existing MSCML single prompt/single collect model.  Reprompting
provides the ability to prompt and collect information from a user with a
single logical operation/command that includes reprompts if necessary.   Reprompting
provides the developer with application level access to IVR functionality.  
It is consistent with the MSCML philosophy of defining "constructs and
primitives that are meaningful at the application level to ensure that
programmers are not distracted by unnecessary complexity".

<span
style='font-size:10.0pt'> 

<span
style='font-size:10.0pt'>The following elements would be added:

<span
style='font-size:10.0pt'> 

<span
style='font-size:10.0pt'><initialprompt>           //
initial prompt of a <playcollect> or <playrecord>      

<span
style='font-size:10.0pt'><reprompt>                 //
played if the initial collection attempt fails, and if neither the
<nodigitsprompt> or <nospeechprompt>

<span
style='font-size:10.0pt'>                                    //
has been specified

<span
style='font-size:10.0pt'><nodigitsprompt>       //
played if the user does not enter digits after the initial or subsequent
prompts of a <playcollect>

<span
style='font-size:10.0pt'><nospeechprompt>     //
played if the user does not speak after the initial or subsequent prompts of a
<playrecord>

<span
style='font-size:10.0pt'><successann>             //
played if the operation is successful

<span
style='font-size:10.0pt'><failureann>               //
played if the operation fails after maxattempts has been exceeded

<span
style='font-size:10.0pt'> 

<span
style='font-size:10.0pt'><nodigitsprompt> is a child of
<playcollect>.  

<span
style='font-size:10.0pt'><nospeechprompt> is a child of
<playrecord>.

<span
style='font-size:10.0pt'><initialprompt>, <repompt>,
<successann>, and <failureann> are children of <playcollect>
and <playrecord>

<span
style='font-size:10.0pt'> 

<span
style='font-size:10.0pt'>A new attribute, maxattempts, is added to the <playcollect>
and <playrecord>, elements to specify the maximum number of attempts the
user is given to enter the requested data.  The default for this attribute
is "1".  Another attribute, numattempts, to report the number of
times the user attempted to enter the requested data, is added to the
<response> element.

<span style='font-size:
10.0pt;font-family:Arial'> 

<span style='font-size:
10.0pt;font-family:Arial'>Regards,

<span style='font-size:
10.0pt;font-family:Arial'>David

<span lang=FR
style='font-size:10.0pt;font-family:Arial'>-- 

<span lang=FR
style='font-size:10.0pt;font-family:Arial'>[email-masked] 
AudioCodes, Inc.
633 Davis Drive, Suite 300 
Durham, NC 27713 

<font size=2 color=black
face="Lucida Sans Unicode">

---

From: "David Cromwell" <[email-masked]>
Date: Thu, 13 Apr 2006 19:10:31 +0100

<span style='font-size:
10.0pt;font-family:Arial'>Please note that all the prompt elements are optional. 
 This allows the Application Server to use a single prompt/single collect
model if desired.

<span style='font-size:

<span style='font-size:

<span style='font-size:

<span lang=FR

<span lang=FR

<font size=2 color=black
face=Tahoma>-----Original
Message-----
From: David Cromwell 
Sent: Thursday,
 April 13, 2006<span
style='font-family:Tahoma;color:windowtext'> <font
 color=black face=Tahoma>2:07
 PM<span style='font-family:Tahoma;
color:windowtext'>
To:
[email-masked]'
Subject: reprompting capability
for MSCML

<font size=2 color=black

<font size=2 color=black
face="Lucida Sans Unicode">I propose adding a
reprompting capability to MSCML to extend the existing MSCML single
prompt/single collect model.  Reprompting provides the ability to prompt
and collect information from a user with a single logical operation/command
that includes reprompts if necessary.   Reprompting provides the
developer with application level access to IVR functionality.   It is
consistent with the MSCML philosophy of defining "constructs and
primitives that are meaningful at the application level to ensure that
programmers are not distracted by unnecessary complexity".

<font size=2 color=black

<font size=2 color=black
face="Lucida Sans Unicode">The following
elements would be added:

<font size=2 color=black

<font size=2 color=black
face="Lucida Sans Unicode"><initialprompt>          
// initial prompt of a <playcollect> or <playrecord> 

<font size=2 color=black
face="Lucida Sans Unicode"><reprompt>                
// played if the initial collection attempt fails, and if neither the
<nodigitsprompt> or <nospeechprompt>

<font size=2 color=black
// has been specified

<font size=2 color=black
face="Lucida Sans Unicode"><nodigitsprompt>      
// played if the user does not enter digits after the initial or subsequent
prompts of a <playcollect>

<font size=2 color=black
face="Lucida Sans Unicode"><nospeechprompt>    
// played if the user does not speak after the initial or subsequent prompts of
a <playrecord>

<font size=2 color=black
face="Lucida Sans Unicode"><successann>            
// played if the operation is successful

<font size=2 color=black
face="Lucida Sans Unicode"><failureann>              
// played if the operation fails after maxattempts has been exceeded

<font size=2 color=black

<font size=2 color=black
face="Lucida Sans Unicode"><nodigitsprompt>
is a child of <playcollect>.  

<font size=2 color=black
face="Lucida Sans Unicode"><nospeechprompt>
is a child of <playrecord>.

<font size=2 color=black
face="Lucida Sans Unicode"><initialprompt>,
<repompt>, <successann>, and <failureann> are children of
<playcollect> and <playrecord>

<font size=2 color=black

<font size=2 color=black
face="Lucida Sans Unicode">A new attribute,
maxattempts, is added to the <playcollect> and <playrecord>,
elements to specify the maximum number of attempts the user is given to enter
the requested data.  The default for this attribute is
"1".  Another attribute, numattempts, to report the number of
times the user attempted to enter the requested data, is added to the
<response> element.

<font size=2 color=black
face=Arial> 

<font size=2 color=black
face=Arial>Regards,

<font size=2 color=black
face=Arial>David

<font size=2 color=black
face=Arial>-- 

<font size=2 color=black
face=Arial>[email-masked]

AudioCodes, Inc.

<font size=2 color=black