Subject: RE: [MEDIACTRL] Packages

From: "Chris Boulton" <[email-masked]>
Date: Mon, 16 Apr 2007 16:37:09 +0100

Isn't a version number that really is just an opaque token that gets
combined with another opaque token (the package name) more complex than
just an opaque token?

[Chris Boulton] Its different :-) - not sure it's more complex.  As Tim
pointed out it really just supplies some additional visual semantics for
someone debugging + a very loose coupling for packages.  I'm not going
to lose sleep either way.

Chris.

Information contained in this e-mail and any attachments are intended for the use of the addressee only, and may contain confidential information of Ubiquity Software Corporation. All unauthorized use, disclosure or distribution is strictly prohibited.  If you are not the addressee, please notify the sender immediately and destroy all copies of this email. Ubiquity Software Corporation plc, a company registered under the laws of England and Wales, Registration 2719723, registered offices at Eastern Business Park, Building 3, Wern Fawr Lane, St. Mellons, Cardiff CF3 5EA, Wales, United Kingdom.

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "Adnan Saleem" <[email-masked]>
Date: Mon, 16 Apr 2007 10:27:59 -0700

The version number is currently only used along with the package
name by the package drafts. The version information may need to be 
*within* the XML generated by the AS and XML generated by the MS. If
the XML did not contain version number information, then AS and MS
would both need to rely *exclusively* on the negotiated package token 
(name+ver) for parsing and validation. This may be ok, but I think it
would be better to make the version number explicit in the XML for
any given package schema.

This certainly needs more discussion within the group, since it has 
not been discussed as yet and I don't think the current sample 
packages define the version within the schemas.

Adnan

-----Original Message-----
From: Chris Boulton [mailto:[email-masked]] 
Sent: April 16, 2007 8:37 AM
To: Eric Burger; [email-masked]
Cc: [email-masked]
Subject: RE: [MEDIACTRL] Packages

Isn't a version number that really is just an opaque token that gets
combined with another opaque token (the package name) more complex than just
an opaque token?

[Chris Boulton] Its different :-) - not sure it's more complex.  As Tim
pointed out it really just supplies some additional visual semantics for
someone debugging + a very loose coupling for packages.  I'm not going to
lose sleep either way.

Chris.

Information contained in this e-mail and any attachments are intended for
the use of the addressee only, and may contain confidential information of
Ubiquity Software Corporation. All unauthorized use, disclosure or
distribution is strictly prohibited.  If you are not the addressee, please
notify the sender immediately and destroy all copies of this email. Ubiquity
Software Corporation plc, a company registered under the laws of England and
Wales, Registration 2719723, registered offices at Eastern Business Park,
Building 3, Wern Fawr Lane, St. Mellons, Cardiff CF3 5EA, Wales, United
Kingdom.

---

From: "Tim Melanchuk" <[email-masked]>
Date: Mon, 16 Apr 2007 14:33:26 -0700

the only reason i can see to have an explicit version within the
xml is to allow the option for the packages to be used outside
the control framework. i'm not sure that is one of our goals.
is there any other reason you are thinking of?

---

From: "Adnan Saleem" <[email-masked]>
Date: Mon, 16 Apr 2007 15:55:21 -0700

For the same reason that many XML languages
define the version within. Ie. payload identifies
the version number within rather than the control
or transport that negotiated and carried it.

________________________________

From: Tim Melanchuk [mailto:[email-masked]] 
Sent: April 16, 2007 2:33 PM
To: Adnan Saleem
Cc: [email-masked]
Subject: Re: [MEDIACTRL] Packages

	The version number is currently only used along with the package
	name by the package drafts. The version information may need to be
	*within* the XML generated by the AS and XML generated by the MS. If
	the XML did not contain version number information, then AS and MS 
	would both need to rely *exclusively* on the negotiated package
token
	(name+ver) for parsing and validation. This may be ok, but I think
it
	would be better to make the version number explicit in the XML for
	any given package schema.

---

From: "Adnan Saleem" <[email-masked]>
Date: Mon, 16 Apr 2007 15:59:27 -0700

Just to clarify further, I'm not suggesting that
the control framework should not identify version
numbers for discovery and/or negotiation purpose. I'm
ok with that. I'm just saying that the payload XML
should identify the version within it as well for
the reasons that I mentioned earlier.

-----Original Message-----
From: Adnan Saleem [mailto:[email-masked]] 
Sent: April 16, 2007 3:55 PM
To: 'Tim Melanchuk'
Cc: [email-masked]
Subject: RE: [MEDIACTRL] Packages

For the same reason that many XML languages define the version within. Ie.
payload identifies the version number within rather than the control or
transport that negotiated and carried it.

---

From: "Tim Melanchuk" <[email-masked]>
Date: Tue, 17 Apr 2007 06:59:09 -0700

i think that you're agreeing with me here. you are assuming that
the xml can be separated from the control framework and messages
and hence, needs a version number itself. is this a goal we want
to pursue?