Subject: RE: [MEDIACTRL] MS capabilities

From: "Chris Boulton" <[email-masked]>
Date: Thu, 5 Apr 2007 10:52:48 +0100

Now this to me means that SIP at least must parse the SDP, and any
errors in the SDP syntax would be reported in a 4xx message from the AS,
rather than forwarding broken SDP to the MS and letting that report the
error.

[Chris Boulton] While I am agreeing with everything you say - the
reality is that this is not the majority case.  I will use a JSR 116/289
compliant SIP Servlet container as an example.  SDP is just an opaque
object that CAN be retrieved/parsed/messed about with when creating a
B2BUA application.  The majority of B2UA's implemented would do exactly
what you suggest and simply forward the request (not bothering to parse
SDP) and let the poor old MS do all the hard work and report the
syntactical error.  This is a trivial B2BUA operation.

Chris.

Information contained in this e-mail and any attachments are intended for the use of the addressee only, and may contain confidential information of Ubiquity Software Corporation. All unauthorized use, disclosure or distribution is strictly prohibited.  If you are not the addressee, please notify the sender immediately and destroy all copies of this email. Ubiquity Software Corporation plc, a company registered under the laws of England and Wales, Registration 2719723, registered offices at Eastern Business Park, Building 3, Wern Fawr Lane, St. Mellons, Cardiff CF3 5EA, Wales, United Kingdom.

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: Eric Burger <[email-masked]>
Date: Thu, 05 Apr 2007 07:41:47 -0400

I agree with Chris here.  My reading of 3261 does NOT put the burden of
*parsing* SDP on the AS, only accepting it.

On 4/5/07 5:52 AM, "Chris Boulton" <[email-masked]> wrote:

> Information contained in this e-mail and any attachments are intended for the
> use of the addressee only, and may contain confidential information of
> Ubiquity Software Corporation. All unauthorized use, disclosure or
> distribution is strictly prohibited.  If you are not the addressee, please
> notify the sender immediately and destroy all copies of this email. Ubiquity
> Software Corporation plc, a company registered under the laws of England and
> Wales, Registration 2719723, registered offices at Eastern Business Park,
> Building 3, Wern Fawr Lane, St. Mellons, Cardiff CF3 5EA, Wales, United
> Kingdom.
> 
> 

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

---

From: "Tim Melanchuk" <[email-masked]>
Date: Thu, 5 Apr 2007 08:05:03 -0700

to summarize what chris,eric, et.al. are saying, it is that common AS
implementations
can avoid parsing the sdp, and hence we should have as a design goal, to
*optimize*
the protocol for this common case (no SDP parsing required), while still
*allowing*,
implementations that want/need SDP access, to do so.

this seems very sensible to me. and it aligns with rfc3725 (3pcc) Flow 1,
which is
specifically recommended when talking to automata such as media servers
since
it "requires no manipulation of the SDP by the controller (AS)".

cheers,
timm

---

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Fri, 13 Apr 2007 12:29:40 +0200

In which case they are surely they are not complying with the UA part of
RFC 3261, and therefore formally, they are broken implementations as far
as RFC 3261 is concerned.

Keith 

> -----Original Message-----
> From: Chris Boulton [mailto:[email-masked]] 
> Sent: Thursday, April 05, 2007 10:53 AM
> To: Drage, Keith (Keith); Eric Burger; 
> [email-masked]
> Cc: [email-masked]
> Subject: RE: [MEDIACTRL] MS capabilities
> 
> 
> Now this to me means that SIP at least must parse the SDP, 
> and any errors in the SDP syntax would be reported in a 4xx 
> message from the AS, rather than forwarding broken SDP to the 
> MS and letting that report the error.
> 
> [Chris Boulton] While I am agreeing with everything you say - 
> the reality is that this is not the majority case.  I will 
> use a JSR 116/289 compliant SIP Servlet container as an 
> example.  SDP is just an opaque object that CAN be 
> retrieved/parsed/messed about with when creating a B2BUA 
> application.  The majority of B2UA's implemented would do 
> exactly what you suggest and simply forward the request (not 
> bothering to parse
> SDP) and let the poor old MS do all the hard work and report 
> the syntactical error.  This is a trivial B2BUA operation.
> 
> Chris.
> 
> 
> 
> 
> Information contained in this e-mail and any attachments are 
> intended for the use of the addressee only, and may contain 
> confidential information of Ubiquity Software Corporation. 
> All unauthorized use, disclosure or distribution is strictly 
> prohibited.  If you are not the addressee, please notify the 
> sender immediately and destroy all copies of this email. 
> Ubiquity Software Corporation plc, a company registered under 
> the laws of England and Wales, Registration 2719723, 
> registered offices at Eastern Business Park, Building 3, Wern 
> Fawr Lane, St. Mellons, Cardiff CF3 5EA, Wales, United Kingdom.
> 
>