Subject: Re: [MEDIACTRL] MS capabilities

From: "Eric Burger" <[email-masked]>
Date: Wed, 4 Apr 2007 07:26:47 -0700

Absolutely. Remember, we are not advocating "AS MUST NOT parse SDP." We are saying "AS is NOT REQUIRED to parse SDP." This is a case where the negative of the statement does not mean only the opposite is true. 

--
Sent from my wireless e-mail device. Sorry if terse.  We all need lemonade: see <http://www.standardstrack.com/ietf/lemonade> for what lemonade is.

-----Original Message-----
From: [email-masked] <[email-masked]>
To: Eric Burger
CC: [email-masked] <[email-masked]>
Sent: Wed Apr 04 04:59:35 2007
Subject: Re: [MEDIACTRL] MS capabilities

> The AS needs to understand SDP *IF AND ONLY IF* it forwards non-SIP, non-SDP
> calls.  However, for SIP calls (which is what most of us care about), the AS
> *DOES NOT NEED* to understand SDP.
>

What if I have the following case? An endpoint sends a SIP INVITE with
a SDP containing media1 and media2. If one MS is dedicated to media of
type media1, and another MS is dedicated to media of type media2, the
AS needs to understand SDP, doesn't it?

Xavier

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "Even, Roni" <[email-masked]>
Date: Wed, 4 Apr 2007 21:40:35 +0300

Eric,
This text decision will affect how we can match between the media streams in the SIP dialog (SDP) with the AS/MS protocol.

Roni

> From: Eric Burger [mailto:[email-masked]]
> Sent: Wednesday, April 04, 2007 5:27 PM
> To: [email-masked]
> Cc: [email-masked]
> Absolutely. Remember, we are not advocating "AS MUST NOT parse SDP." We
> are saying "AS is NOT REQUIRED to parse SDP." This is a case where the
> negative of the statement does not mean only the opposite is true.
> 
> --
> Sent from my wireless e-mail device. Sorry if terse.  We all need
> lemonade: see <http://www.standardstrack.com/ietf/lemonade> for what
> lemonade is.
> 
> Notice:  This email message, together with any attachments, may contain
> information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
> entities,  that may be confidential,  proprietary,  copyrighted  and/or
> legally privileged, and is intended solely for the use of the individual
> or entity named in this message. If you are not the intended recipient,
> and have received this message in error, please immediately return this by
> email and then delete it.
>

---

From: Eric Burger <[email-masked]>
Date: Wed, 04 Apr 2007 16:18:32 -0400

Right  that is why the thread has not been shut down.

Thoughts from the list?

On 4/4/07 2:40 PM, "Even, Roni" <[email-masked]> wrote:

> Eric,
> This text decision will affect how we can match between the media streams in
> the SIP dialog (SDP) with the AS/MS protocol.
> 
> Roni
>

---

From: <[email-masked]>
Date: Thu, 5 Apr 2007 12:30:28 +0300

[Reposting, sorry if you receive multiple copies.]

Hi all,
I think whether the AS should or should not parse SDP is not a
requirement we can (or need to) set, but rather a design goal. Good
system design and implementation allows the SDP to be passed intact, if
that indeed is possible for a given application usage of Media Control
protocol.

Best regards,
Simo Veikkolainen

>From: ext Eric Burger [mailto:[email-masked]] 
>Sent: 04.04.2007 23:19
>To: Roni Even
>Cc: [email-masked]
>Right - that is why the thread has not been shut down.
>
>Thoughts from the list?
>
>
>> This text decision will affect how we can match between the media 
>> streams in the SIP dialog (SDP) with the AS/MS protocol.
>> 
>> Roni
>> 
>>> Absolutely. Remember, we are not advocating "AS MUST NOT 
>parse SDP." 
>>> We are saying "AS is NOT REQUIRED to parse SDP." This is a 
>case where 
>>> the negative of the statement does not mean only the 
>opposite is true.
>>> 
>>> --
>>>> The AS needs to understand SDP *IF AND ONLY IF* it 
>forwards non-SIP,
>>> non-SDP
>>>> calls.  However, for SIP calls (which is what most of us care 
>>>> about),
>>> the AS
>>> What if I have the following case? An endpoint sends a SIP INVITE 
>>> with a SDP containing media1 and media2. If one MS is dedicated to 
>>> media of type media1, and another MS is dedicated to media of type 
>>> media2, the AS needs to understand SDP, doesn't it?
>>> 
>>> Xavier
>>> 
>>> Notice:  This email message, together with any attachments, may 
>>> contain information  of  BEA Systems,  Inc.,  its 
>subsidiaries  and  
>>> affiliated entities,  that may be confidential,  proprietary,  
>>> copyrighted  and/or legally privileged, and is intended solely for 
>>> the use of the individual or entity named in this message. 
>If you are 
>>> not the intended recipient, and have received this message 
>in error, 
>>> please immediately return this by email and then delete it.
>>> 
>Notice:  This email message, together with any attachments, 
>may contain information  of  BEA Systems,  Inc.,  its 
>subsidiaries  and  affiliated entities,  that may be 
>confidential,  proprietary,  copyrighted  and/or legally 
>privileged, and is intended solely for the use of the 
>individual or entity named in this message. If you are not the 
>intended recipient, and have received this message in error, 
>please immediately return this by email and then delete it.
>

---

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Thu, 5 Apr 2007 11:43:37 +0200

I have a bit of difficulty here. Any AS is likely to be some sort of translation function between two protocols, e.g. SIP and whatever we are running to the MS. As such, the AS is implementing a SIP UA. RFC 3261 states:

   The Session Description Protocol (SDP) (RFC 2327 [1]) MUST be
   supported by all user agents as a means to describe sessions, and its
   usage for constructing offers and answers MUST follow the procedures
   defined in [13].

Now this to me means that SIP at least must parse the SDP, and any errors in the SDP syntax would be reported in a 4xx message from the AS, rather than forwarding broken SDP to the MS and letting that report the error.

I am sure other protocols using SDP have similar requirements in their specifications.

So while I agree that the decision on which codec to use and so on will be left to the MS, I cannot within the current protocol specifications see that it can be allowed to be entirely transparent.

Regards

Keith

> Sent: Wednesday, April 04, 2007 3:27 PM
> parse SDP." We are saying "AS is NOT REQUIRED to parse SDP." 
> This is a case where the negative of the statement does not 
> mean only the opposite is true. 
> 
> --
> Sent from my wireless e-mail device. Sorry if terse.  We all 
> need lemonade: see 
> <http://www.standardstrack.com/ietf/lemonade> for what lemonade is.
> 
> > The AS needs to understand SDP *IF AND ONLY IF* it forwards 
> non-SIP, 
> > non-SDP calls.  However, for SIP calls (which is what most 
> of us care 
> > about), the AS *DOES NOT NEED* to understand SDP.
> >
> 
> What if I have the following case? An endpoint sends a SIP 
> INVITE with a SDP containing media1 and media2. If one MS is 
> dedicated to media of type media1, and another MS is 
> dedicated to media of type media2, the AS needs to understand 
> SDP, doesn't it?
> 
> Xavier
> 
> individual or entity named in this message. If you are not 
> the intended recipient, and have received this message in 
> error, please immediately return this by email and then delete it.
>

---

From: "Geir Arne Sandbakken" <[email-masked]>
Date: Mon, 9 Apr 2007 21:22:04 +0200

Correlating media lines with control messages in AS/MS enables the AS to
do multimedia control.  I think this should be in scope of our work, but
should probably not put mandatory requirements on the AS to do so.

A proposal for a requirement to the AS/MS protocol:

"It shall be possible to correlate control messages with media lines.
If no correlation value is given, the control message shall apply to the
first media line in the SDP."

This should not put any requirements on the AS to understand the SDP,
but the protocol will support some use cases I believe will be important
for more than 1% of the users.  

Geir Arne

> Sent: 04 April 2007 22:19
> To: Roni Even
> Cc: [email-masked]
> streams in
non-SIP,
about),
> >> What if I have the following case? An endpoint sends a SIP INVITE
with
> >> Notice:  This email message, together with any attachments, may
contain
> >> and have received this message in error, please immediately return
this
> by
contain

---

From: "Even, Roni" <[email-masked]>
Date: Tue, 10 Apr 2007 12:16:59 +0300

Hi,
I do not think that 
"If no correlation value is given, the control message shall apply to
the first media line in the SDP"
Will work, what is the first line, is it the first line in the offer
what if it was rejected in the answer, how will the AS know
Roni

> From: Geir Arne Sandbakken [mailto:[email-masked]]
> Sent: Monday, April 09, 2007 10:22 PM
> To: Eric Burger; Even, Roni
> Cc: [email-masked]
> Subject: RE: [MEDIACTRL] MS capabilities
> 
> > >> are saying "AS is NOT REQUIRED to parse SDP." This is a case
where
> the
> > >> a SDP containing media1 and media2. If one MS is dedicated to
media
> of
> this by

---

From: "Geir Arne Sandbakken" <[email-masked]>
Date: Tue, 10 Apr 2007 17:46:55 +0200

Sorry, but the requirement was badly phrased and contained a possible
solution.  

The MS should map the control messages as it pleases if the AS hasn't
already done it.

Geir Arne

> From: Even, Roni [mailto:[email-masked]]
> Sent: 10 April 2007 11:17
> To: Geir Arne Sandbakken; Eric Burger
> Cc: [email-masked]
> > Correlating media lines with control messages in AS/MS enables the
AS
> to
need
> > > >> What if I have the following case? An endpoint sends a SIP
INVITE
> > > >> type media1, and another MS is dedicated to media of type
media2,