Subject: [MEDIACTRL] Packages

From: Eric Burger <[email-masked]>
Date: Sun, 08 Apr 2007 17:17:45 -0400

<chair-hat off>
The whole package concept is pretty big.  Are we going to have, for example,
versioning?  What happens if a requested version doesn't match?  What if the
requested version is "less than" the supported version?  What is the
definition of "less than"?

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "Tim Melanchuk" <[email-masked]>
Date: Mon, 9 Apr 2007 12:47:14 -0700

in my mind, there are definitely sets of distinct capabilities
corresponding to the PDUs of the 3rd charter deliverable.
the question more becomes one of whether these capabilities
should be expressed in a modular fashion, such as packages,
or not.

once that is decided, we can then answer questions
about if and how package versioning would be done.

several advantages of packages are:
1) they easily allow media servers with differing capabilities to be
    deployed
2) new capabilities can be standardized without requiring revision
    to a deployed protocol

i'd prefer to focus on the different pros/cons of packages in
general, before working through the solution to a specific
issue. versioning only becomes important if we have packages,
and if we think those packages are going to evolve enough to
warrant versioning rather than simply defining a new package.

cheers,
timm

On 4/8/07, Eric Burger < [email-masked]> wrote:
> Notice:  This email message, together with any attachments, may contain
> information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
> entities,  that may be confidential,  proprietary,  copyrighted  and/or
> legally privileged, and is intended solely for the use of the individual or
> entity named in this message. If you are not the intended recipient, and
> have received this message in error, please immediately return this by email
> and then delete it.
>