Subject: RE: [MEDIACTRL] MS capabilities

From: "Chris Boulton" <[email-masked]>
Date: Tue, 10 Apr 2007 10:10:09 +0100

This is in-line with the current Control Framework draft.

Chris.

-----Original Message-----
From: Geir Arne Sandbakken [mailto:[email-masked]] 
Sent: 09 April 2007 20:22
To: Eric Burger; Roni Even
Cc: [email-masked]
Subject: RE: [MEDIACTRL] MS capabilities

Correlating media lines with control messages in AS/MS enables the AS to
do multimedia control.  I think this should be in scope of our work, but
should probably not put mandatory requirements on the AS to do so.

A proposal for a requirement to the AS/MS protocol:

"It shall be possible to correlate control messages with media lines.
If no correlation value is given, the control message shall apply to the
first media line in the SDP."

This should not put any requirements on the AS to understand the SDP,
but the protocol will support some use cases I believe will be important
for more than 1% of the users.  

Geir Arne

> -----Original Message-----
> From: Eric Burger [mailto:[email-masked]]
> Sent: 04 April 2007 22:19
> To: Roni Even
> Cc: [email-masked]
> Subject: Re: [MEDIACTRL] MS capabilities
> 
> Right - that is why the thread has not been shut down.
> 
> Thoughts from the list?
> 
> 
> On 4/4/07 2:40 PM, "Even, Roni" <[email-masked]> wrote:
> 
> > Eric,
> > This text decision will affect how we can match between the media
> streams in
> > the SIP dialog (SDP) with the AS/MS protocol.
> >
> > Roni
> >
> >> -----Original Message-----
> >> From: Eric Burger [mailto:[email-masked]]
> >> Sent: Wednesday, April 04, 2007 5:27 PM
> >> To: [email-masked]
> >> Cc: [email-masked]
> >> Subject: Re: [MEDIACTRL] MS capabilities
> >>
> >> Absolutely. Remember, we are not advocating "AS MUST NOT parse
SDP." We
> >> are saying "AS is NOT REQUIRED to parse SDP." This is a case where
the
> >> negative of the statement does not mean only the opposite is true.
> >>
> >> --
> >> Sent from my wireless e-mail device. Sorry if terse.  We all need
> >> lemonade: see <http://www.standardstrack.com/ietf/lemonade> for
what
> >> lemonade is.
> >>
> >> -----Original Message-----
> >> From: [email-masked] <[email-masked]>
> >> To: Eric Burger
> >> CC: [email-masked] <[email-masked]>
> >> Sent: Wed Apr 04 04:59:35 2007
> >> Subject: Re: [MEDIACTRL] MS capabilities
> >>
> >>> The AS needs to understand SDP *IF AND ONLY IF* it forwards
non-SIP,
> >> non-SDP
> >>> calls.  However, for SIP calls (which is what most of us care
about),
> >> the AS
> >>> *DOES NOT NEED* to understand SDP.
> >>>
> >>
> >> What if I have the following case? An endpoint sends a SIP INVITE
with
> >> a SDP containing media1 and media2. If one MS is dedicated to media
of
> >> type media1, and another MS is dedicated to media of type media2,
the
> >> AS needs to understand SDP, doesn't it?
> >>
> >> Xavier
> >>
> >> Notice:  This email message, together with any attachments, may
contain
> >> information  of  BEA Systems,  Inc.,  its subsidiaries  and
affiliated
> >> entities,  that may be confidential,  proprietary,  copyrighted
and/or
> >> legally privileged, and is intended solely for the use of the
> individual
> >> or entity named in this message. If you are not the intended
recipient,
> >> and have received this message in error, please immediately return
this
> by
> >> email and then delete it.
> >>
> >> _______________________________________________
> >> MEDIACTRL mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/mediactrl
> >> Supplemental Web Site:
> >> http://www.standardstrack.com/ietf/mediactrl
> >
> 
> 
> 
> Notice:  This email message, together with any attachments, may
contain
> information  of  BEA Systems,  Inc.,  its subsidiaries  and
affiliated
> entities,  that may be confidential,  proprietary,  copyrighted
and/or
> legally privileged, and is intended solely for the use of the
individual
> or entity named in this message. If you are not the intended
recipient,
> and have received this message in error, please immediately return
this by
> email and then delete it.
> 
> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

Information contained in this e-mail and any attachments are intended for the use of the addressee only, and may contain confidential information of Ubiquity Software Corporation. All unauthorized use, disclosure or distribution is strictly prohibited.  If you are not the addressee, please notify the sender immediately and destroy all copies of this email. Ubiquity Software Corporation plc, a company registered under the laws of England and Wales, Registration 2719723, registered offices at Eastern Business Park, Building 3, Wern Fawr Lane, St. Mellons, Cardiff CF3 5EA, Wales, United Kingdom.

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "Chris Boulton" <[email-masked]>
Date: Tue, 10 Apr 2007 10:27:14 +0100

Hi,
I do not think that 
"If no correlation value is given, the control message shall apply to
the first media line in the SDP"
Will work, what is the first line, is it the first line in the offer
what if it was rejected in the answer, how will the AS know
Roni

[Chris Boulton] Sorry - I missed that (should really stop scanning :-).
I agree with Roni.  The Control message should really then apply to the
whole SDP - which might mean that some assumptions have to be made about
applicability.  At the end of the day, if you want to avoid such
assumptions you should be more specific.  I think the current version of
the Control draft recommends using Media Label etc etc unless you know
(and will know throughout the session) that only one media line will
exist.

Chris.

---

From: "Alan Bergmin" <[email-masked]>
Date: Fri, 13 Apr 2007 17:50:07 +0200

> What is the use case for the B2BUA?

There may be another use-case:
I want my AS, when receiving a call (i.e. INVITE) from A to B,
- to relay the call to a MS to play a basic announcement
- when the announcement is finished, to relay the call to B

I can't find a way to perform this call-control transfer operation
with a proxy behavior
(i.e. only B2BUA AS solution for this use-case?)