Subject: Re: [MEDIACTRL] RFC 4117 Vs MCCF for Transcoding serviceinvocation

From: "Rai, Shambhu" <[email-masked]>
Date: Tue, 4 Mar 2008 23:52:54 +0530

Hi lorenzo,

Thanks for the response.

I agree, MS can setup the transcoding with a request from 3PCC using SIP/SDP. You do not necessarily need any media control package for the same. But, media server needs to be told clearly which two call legs need to be joined in the transcoding? I am more worried about what mechanism AS can use to convey this information.
1. Use Conference package over Media control channel
2. Use RFC 4117 defined flows to setup transcoding
3. Anything else?

I know some of the existing MS vendors use protocols like MGCP to move two call legs (endpoints) in the same context. Has Any one any experience on transcoding setup on MS using SIP 3PCC AS?

Regards,
Shambhu
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, March 04, 2008 6:19 PM
To: Rai, Shambhu
Cc: [email-masked]
Subject: Re: [MEDIACTRL] RFC 4117 Vs MCCF for Transcoding serviceinvocation

Hi Rai,

from my understanding, the MS takes care of transcoding automatically.  
Control packages are only interfaces to the primitive functionality  
the MS itself provides with.However, the conferencing control package  
is currently needed to put two UACs in contact: if transcoding between  
them is needed (according to the previous 3PCC the AS had between them  
and the MS), the MS does that. Same for an announcement to play to a  
UAC, for instance: if the source is to be transcoded to a format the  
receiving UAC understands, the MS takes care of that.

I'm not sure I addressed your concern.

Lorenzo

Quoting "Rai, Shambhu" <[email-masked]>:

> HI,
>
> I am not sure, if my message reached the list.. Can some one comment on
> my questions on Transcoding service using media control channel
> framework in the mail below?
>
> Regards,
> Shambhu
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Rai, Shambhu
> Sent: Monday, March 03, 2008 2:55 PM
> To: [email-masked]
> Subject: [MEDIACTRL] FW: RFC 4117: Sip signaling for Transcoding
> serviceinvocation
>
> Hi Guys,
>
> I am new to this list. So, please excuse me if I am raising already
> discussed questions.
>
> 1. I am looking at the signaling model options for Transcoding service
> invocation on media server. Is there a package defined in the
> "mediactrl" framework for invoking the transcoding service on media
> server or one has to support conference packages to support the
> transcoding?
>
> 2. RFC 4117 proposes framework/call flows to invoke the transcoding
> service on Media server from a 3PCC AS. What is the MediaCtrl group's
> position on the same?
>
> Regards,
> Shambhu
>
>
>
> -----Original Message-----
> From: Rai, Shambhu
> Sent: Thursday, February 28, 2008 10:23 AM
> To: [email-masked];
> [email-masked]'; [email-masked]'
> Subject: RFC 4117: Sip signaling for Transcoding service invocation
>
> HI All,
>
> Is anyone aware of any Media server / MRF / Transcoder using 3PCC
> control mechanism described in RFC 4117 for invoking a transcoding
> service?
>
> I am evaluating the Signaling model to invoke transcoding service on
> MRF. I can think of following options.
>
> 1. RFC 4117 based 3PCC transcoding service invocation:
>         In this case AS setup only one Dialog (with SDP of A and
> B)towards MRF requesting the transcoding service.
>
> 2. 3PCC AS Use an identifier like a conference identifier to move both
> parties in the same context.
>     I am wondering, If setting up transcoding as two party conference
> will be a good idea?  As there will be need to distinguish transcoder
> service from the conferencing service. Like A party doing hold unhold
> etc, These scenarios needs to be handled differently for transcoding
> from conference.
>
> It will be good to know industry accepted mechanism for the same. Any
> inputs are welcome.
>
> Regards,
> Shambhu
>
> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl
>
> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl
>

-- 
Lorenzo Miniero, Junior Researcher
Dipartimento di Informatica e Sistemistica
Università degli Studi di Napoli "Federico II"
Via Claudio 21 -- 80125 Napoli (Italy)
Phone: +390817683821 - Fax: +390817683816
Email: [email-masked]

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "Steve Buko" <[email-masked]>
Date: Tue, 4 Mar 2008 13:37:18 -0500

The <join> defined in draft-boulton-conference-control-package can be used to connect endpoints.
It can connect endpoints to conferences, endpoints to endpoints, or conferences to conferences.

In your case below, it would be connecting two separate endpoints ("connections").

My experience with this scenario has been that the MS can use "smart transcoding".  Nothing in the <join> will define if transcoding is required (although that might be something to think about).  However the MS terminated both calls and knows if transcoding is required based on the media that was negotiated.

Steve

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On
|Behalf Of Rai, Shambhu
|Sent: Tuesday, March 04, 2008 1:23 PM
|To: [email-masked]
|Cc: [email-masked]
|Subject: Re: [MEDIACTRL] RFC 4117 Vs MCCF for Transcoding serviceinvocation
|
|Hi lorenzo,
|
|Thanks for the response.
|
|I agree, MS can setup the transcoding with a request from 3PCC using
|SIP/SDP. You do not necessarily need any media control package for the
|same. But, media server needs to be told clearly which two call legs need
|to be joined in the transcoding? I am more worried about what mechanism AS
|can use to convey this information.
|1. Use Conference package over Media control channel
|2. Use RFC 4117 defined flows to setup transcoding
|3. Anything else?
|
|I know some of the existing MS vendors use protocols like MGCP to move two
|call legs (endpoints) in the same context. Has Any one any experience on
|transcoding setup on MS using SIP 3PCC AS?
|
|Regards,
|Shambhu
|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]]
|Sent: Tuesday, March 04, 2008 6:19 PM
|To: Rai, Shambhu
|Cc: [email-masked]
|Subject: Re: [MEDIACTRL] RFC 4117 Vs MCCF for Transcoding serviceinvocation
|
|Hi Rai,
|
|from my understanding, the MS takes care of transcoding automatically.
|Control packages are only interfaces to the primitive functionality
|the MS itself provides with.However, the conferencing control package
|is currently needed to put two UACs in contact: if transcoding between
|them is needed (according to the previous 3PCC the AS had between them
|and the MS), the MS does that. Same for an announcement to play to a
|UAC, for instance: if the source is to be transcoded to a format the
|receiving UAC understands, the MS takes care of that.
|
|I'm not sure I addressed your concern.
|
|Lorenzo
|
|
|Quoting "Rai, Shambhu" <[email-masked]>:
|
|> HI,
|>
|> I am not sure, if my message reached the list.. Can some one comment on
|> my questions on Transcoding service using media control channel
|> framework in the mail below?
|>
|> Regards,
|> Shambhu
|> -----Original Message-----
|> From: [email-masked] [mailto:[email-masked]] On
|> Behalf Of Rai, Shambhu
|> Sent: Monday, March 03, 2008 2:55 PM
|> To: [email-masked]
|> Subject: [MEDIACTRL] FW: RFC 4117: Sip signaling for Transcoding
|> serviceinvocation
|>
|> Hi Guys,
|>
|> I am new to this list. So, please excuse me if I am raising already
|> discussed questions.
|>
|> 1. I am looking at the signaling model options for Transcoding service
|> invocation on media server. Is there a package defined in the
|> "mediactrl" framework for invoking the transcoding service on media
|> server or one has to support conference packages to support the
|> transcoding?
|>
|> 2. RFC 4117 proposes framework/call flows to invoke the transcoding
|> service on Media server from a 3PCC AS. What is the MediaCtrl group's
|> position on the same?
|>
|> Regards,
|> Shambhu
|>
|>
|>
|> -----Original Message-----
|> From: Rai, Shambhu
|> Sent: Thursday, February 28, 2008 10:23 AM
|> To: [email-masked];
|> [email-masked]'; [email-masked]'
|> Subject: RFC 4117: Sip signaling for Transcoding service invocation
|>
|> HI All,
|>
|> Is anyone aware of any Media server / MRF / Transcoder using 3PCC
|> control mechanism described in RFC 4117 for invoking a transcoding
|> service?
|>
|> I am evaluating the Signaling model to invoke transcoding service on
|> MRF. I can think of following options.
|>
|> 1. RFC 4117 based 3PCC transcoding service invocation:
|>         In this case AS setup only one Dialog (with SDP of A and
|> B)towards MRF requesting the transcoding service.
|>
|> 2. 3PCC AS Use an identifier like a conference identifier to move both
|> parties in the same context.
|>     I am wondering, If setting up transcoding as two party conference
|> will be a good idea?  As there will be need to distinguish transcoder
|> service from the conferencing service. Like A party doing hold unhold
|> etc, These scenarios needs to be handled differently for transcoding
|> from conference.
|>
|> It will be good to know industry accepted mechanism for the same. Any
|> inputs are welcome.
|>
|> Regards,
|> Shambhu
|>
|> _______________________________________________
|> MEDIACTRL mailing list
|> [email-masked]
|> https://www.ietf.org/mailman/listinfo/mediactrl
|> Supplemental Web Site:
|> http://www.standardstrack.com/ietf/mediactrl
|>
|> _______________________________________________
|> MEDIACTRL mailing list
|> [email-masked]
|> https://www.ietf.org/mailman/listinfo/mediactrl
|> Supplemental Web Site:
|> http://www.standardstrack.com/ietf/mediactrl
|>
|
|
|
|--
|Lorenzo Miniero, Junior Researcher
|Dipartimento di Informatica e Sistemistica
|Università degli Studi di Napoli "Federico II"
|Via Claudio 21 -- 80125 Napoli (Italy)
|Phone: +390817683821 - Fax: +390817683816
|Email: [email-masked]
|
|_______________________________________________
|MEDIACTRL mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/mediactrl
|Supplemental Web Site:
|http://www.standardstrack.com/ietf/mediactrl
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "Eric Burger" <[email-masked]>
Date: Wed, 5 Mar 2008 13:59:50 -0800

In terms of 4117, you simply invite two legs to a 4240 session with the same conf= URI.  Each leg gets its SDP negotiated separately.  The MS transcodes "by magic" from the AS' point of view. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Steve Buko
Sent: Tuesday, March 04, 2008 1:37 PM
To: Rai, Shambhu; [email-masked]
Cc: [email-masked]
Subject: Re: [MEDIACTRL] RFC 4117 Vs MCCF for Transcoding serviceinvocation

Steve

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On 
|Behalf Of Rai, Shambhu
|Sent: Tuesday, March 04, 2008 1:23 PM
|To: [email-masked]
|Cc: [email-masked]
|Subject: Re: [MEDIACTRL] RFC 4117 Vs MCCF for Transcoding 
|serviceinvocation
|
|Hi lorenzo,
|
|Thanks for the response.
|
|I agree, MS can setup the transcoding with a request from 3PCC using 
|SIP/SDP. You do not necessarily need any media control package for the 
|same. But, media server needs to be told clearly which two call legs 
|need to be joined in the transcoding? I am more worried about what 
|mechanism AS can use to convey this information.
|1. Use Conference package over Media control channel 2. Use RFC 4117 
|defined flows to setup transcoding 3. Anything else?
|
|I know some of the existing MS vendors use protocols like MGCP to move 
|two call legs (endpoints) in the same context. Has Any one any 
|experience on transcoding setup on MS using SIP 3PCC AS?
|
|Regards,
|Shambhu
|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]]
|Sent: Tuesday, March 04, 2008 6:19 PM
|To: Rai, Shambhu
|Cc: [email-masked]
|Subject: Re: [MEDIACTRL] RFC 4117 Vs MCCF for Transcoding 
|serviceinvocation
|
|Hi Rai,
|
|from my understanding, the MS takes care of transcoding automatically.
|Control packages are only interfaces to the primitive functionality the 
|MS itself provides with.However, the conferencing control package is 
|currently needed to put two UACs in contact: if transcoding between 
|them is needed (according to the previous 3PCC the AS had between them 
|and the MS), the MS does that. Same for an announcement to play to a 
|UAC, for instance: if the source is to be transcoded to a format the 
|receiving UAC understands, the MS takes care of that.
|
|I'm not sure I addressed your concern.
|
|Lorenzo
|
|
|Quoting "Rai, Shambhu" <[email-masked]>:
|
|> HI,
|>
|> I am not sure, if my message reached the list.. Can some one comment 
|> on my questions on Transcoding service using media control channel 
|> framework in the mail below?
|>
|> Regards,
|> Shambhu
|> -----Original Message-----
|> From: [email-masked] [mailto:[email-masked]] 
|> On Behalf Of Rai, Shambhu
|> Sent: Monday, March 03, 2008 2:55 PM
|> To: [email-masked]
|> Subject: [MEDIACTRL] FW: RFC 4117: Sip signaling for Transcoding 
|> serviceinvocation
|>
|> Hi Guys,
|>
|> I am new to this list. So, please excuse me if I am raising already 
|> discussed questions.
|>
|> 1. I am looking at the signaling model options for Transcoding 
|> service invocation on media server. Is there a package defined in the 
|> "mediactrl" framework for invoking the transcoding service on media 
|> server or one has to support conference packages to support the 
|> transcoding?
|>
|> 2. RFC 4117 proposes framework/call flows to invoke the transcoding 
|> service on Media server from a 3PCC AS. What is the MediaCtrl group's 
|> position on the same?
|>
|> Regards,
|> Shambhu
|>
|>
|>
|> -----Original Message-----
|> From: Rai, Shambhu
|> Sent: Thursday, February 28, 2008 10:23 AM
|> To: [email-masked];
|> [email-masked]'; [email-masked]'
|> Subject: RFC 4117: Sip signaling for Transcoding service invocation
|>
|> HI All,
|>
|> Is anyone aware of any Media server / MRF / Transcoder using 3PCC 
|> control mechanism described in RFC 4117 for invoking a transcoding 
|> service?
|>
|> I am evaluating the Signaling model to invoke transcoding service on 
|> MRF. I can think of following options.
|>
|> 1. RFC 4117 based 3PCC transcoding service invocation:
|>         In this case AS setup only one Dialog (with SDP of A and 
|> B)towards MRF requesting the transcoding service.
|>
|> 2. 3PCC AS Use an identifier like a conference identifier to move 
|> both parties in the same context.
|>     I am wondering, If setting up transcoding as two party conference 
|> will be a good idea?  As there will be need to distinguish transcoder 
|> service from the conferencing service. Like A party doing hold unhold 
|> etc, These scenarios needs to be handled differently for transcoding 
|> from conference.
|>
|> It will be good to know industry accepted mechanism for the same. Any 
|> inputs are welcome.
|>
|> Regards,
|> Shambhu
|>
|> _______________________________________________
|> MEDIACTRL mailing list
|> [email-masked]
|> https://www.ietf.org/mailman/listinfo/mediactrl
|> Supplemental Web Site:
|> http://www.standardstrack.com/ietf/mediactrl
|>
|> _______________________________________________
|> MEDIACTRL mailing list
|> [email-masked]
|> https://www.ietf.org/mailman/listinfo/mediactrl
|> Supplemental Web Site:
|> http://www.standardstrack.com/ietf/mediactrl
|>
|
|
|
|--
|Lorenzo Miniero, Junior Researcher
|Dipartimento di Informatica e Sistemistica Università degli Studi di 
|Napoli "Federico II"
|Via Claudio 21 -- 80125 Napoli (Italy)
|Phone: +390817683821 - Fax: +390817683816
|Email: [email-masked]
|
|_______________________________________________
|MEDIACTRL mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/mediactrl
|Supplemental Web Site:
|http://www.standardstrack.com/ietf/mediactrl
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl