Subject: [MEDIACTRL] Questions concerning mediactrl/msc-ivr (vxml params mapping, service identification, dialog interruption)

From: "Jean-Francois Bertrand" <[email-masked]>
Date: Thu, 30 Oct 2008 10:47:10 -0400

We are working on implementing draft-ietf-mediactrl-sip-control-framework-05 and draft-ietf-mediactrl-ivr-control-package-01 in our media server and have some questions:

-Section 4.2.6/4.2.7 of draft-ietf-mediactrl-ivr-control-package-01 defines parameters that can be provided for external dialog languages. How should the parameters provided via <params> be mapped in VoiceXML?

-What should be the user portion of the SIP request-URI for control and media dialogs?  For example, draft-ietf-mediactrl-vxml-02 specifies that "dialog" should be used as the user portion of the SIP request-URI to access VoiceXML media service.

-What happens when media dialog gets a SIP bye while dialog is executing?

thanks
Jean-François Bertrand, ing.
Sr. Software Designer
BroadSoft, Inc.
Montreal, Qc, Canada

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "McGlashan, Scott" <[email-masked]>
Date: Fri, 31 Oct 2008 12:23:12 +0000

Hi Jean-Francois,

Good to hear about your implementation - please keep us posted of any spec isssues you find which we need to fix.

- <params> in VoiceXML. You could follow the example in 6.3 and use "session.connection.ccxml.values", as used by CCXML. Let me know if you would prefer the spec to define a non-ccxml data access point. VoiceXML 2.0/2.1 doesn't define a general data access point, something that should be fixed in VoiceXML 3.0.

- User portion of request URIs are not standardized in this framework, so you can use whatever. If your MS is only for dialogs then 'dialog' would be ok, but if it also supports mixers, then 'dialog' is a bit misleading.

- media dialog behavior with SIP BYE

See description of <dialogexit> in 4.2.5.1, where we use the status code '2' to indicate the connection/conference associated with an active dialog has terminated.  Eg.

<mscivr version="1.0" xmlns="urn:ietf:params:xml:ns:msc-ivr">
 <event dialogid="d6"/>
  <dialogexit status="2">
   <collectinfo dtmf="1234"  termmode="stopped"/>
  </dialogexit>
 </event>
</mscivr>

So you can return dtmf and/or recordings (or <params> from Vxml) received before the connection was dropped.

Let me know if you need more info or have further questions.

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jean-Francois Bertrand
Sent: Thursday, October 30, 2008 15:47
To: [email-masked]
Subject: [MEDIACTRL] Questions concerning mediactrl/msc-ivr (vxml params mapping, service identification, dialog interruption)

thanks

---

From: "Stephane Bastien" <[email-masked]>
Date: Fri, 31 Oct 2008 09:15:38 -0400

Hi,

Yes, it would be nice as part of
draft-ietf-mediactrl-ivr-control-package to define all session variables
that should be presented to a VoiceXML script. Draft-ietf-mediactrl-vxml
makes a very good at it - how much could you reuse?

Thanks,

Stephan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of McGlashan, Scott
Sent: 31 octobre 2008 08:23
To: Jean-Francois Bertrand; [email-masked]
Subject: Re: [MEDIACTRL] Questions concerning mediactrl/msc-ivr
(vxmlparams mapping, service identification, dialog interruption)

(...)

- <params> in VoiceXML. You could follow the example in 6.3 and use
"session.connection.ccxml.values", as used by CCXML. Let me know if you
would prefer the spec to define a non-ccxml data access point. VoiceXML
2.0/2.1 doesn't define a general data access point, something that
should be fixed in VoiceXML 3.0.