Subject: [MEDIACTRL] MRB-PUB-9

From: Chris Boulton <[email-masked]>
Date: Mon, 08 Jun 2009 21:19:21 +0100

MediaCtrl-ID: MRB-PUB-9

Interface Name: Publishing

Property Name: Variable Announcements

Description:

Supplies the supported substitution variables for variable 
announcements, including digits, dates, costs, etc. The details are 
conveyed in a list showing the substitution variable and its associated 
variable type.

Type: List of strings

Example:

Date - mdy/ymd/dmy

Please provide comments on this interface property and let us know if it 
triggers any thoughts on additional information that could be included 
in the interface. This information will be used as the basis for text in 
the next version of the draft.

---

From: "McGlashan, Scott" <[email-masked]>
Date: Tue, 9 Jun 2009 09:07:30 +0000

This comment also applies to PUB-8 (announcement duration), PUB-7 (announcement formats). 

These features are specific to package functionality and packages provide audit functionality which reports on their capabilities and well as their current MS utilization (active IVR dialogs, active conferences, etc). What is the value of duplicating information in the MRB interface which is also available through package auditing (or vice versa)? I'm concerned that the MRB publication interface is a partial duplication of package audit functionality. If we really do need to expose this information through the MRB interface (I'm not sure if we do), then shouldn't we systematically map all package audit information? 

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Chris Boulton
Sent: Monday, June 08, 2009 22:19
To: [email-masked]
Subject: [MEDIACTRL] MRB-PUB-9

MediaCtrl-ID: MRB-PUB-9

Description:

Supplies the supported substitution variables for variable announcements, including digits, dates, costs, etc. The details are conveyed in a list showing the substitution variable and its associated variable type.

Type: List of strings

Example:

Date - mdy/ymd/dmy

Please provide comments on this interface property and let us know if it triggers any thoughts on additional information that could be included in the interface. This information will be used as the basis for text in the next version of the draft.
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: Lorenzo Miniero <[email-masked]>
Date: Tue, 9 Jun 2009 11:21:07 +0200

On Tue, 9 Jun 2009 09:07:30 +0000

> These features are specific to package functionality and packages provide audit functionality which reports on their capabilities and well as their current MS utilization (active IVR dialogs, activ…

You're right, Scott, in fact it's one of the things Chris and I discussed these days. Anyway we chose to discuss each element separately to check which functionality people in the ML really cared about.

About the need or not to expose this info in the MRB as well, my guess is that we do need this info (or a subset of it), considering that when an AS contacts an MRB, it may not be aware yet of any MS at all to query for the provided functionality.

L.

-- 
Lorenzo Miniero <[email-masked]>

---

From: Chris Boulton <[email-masked]>
Date: Tue, 09 Jun 2009 21:17:29 +0100

> About the need or not to expose this info in the MRB as well, my guess is that we do need this info (or a subset of it), considering that when an AS contacts an MRB, it may not be aware yet of any…
[Chris] Yes - we did talk about this and realise that this list is 
currently preliminary (for both additions/amendments and subtractions).  
It is true that large deployments will not have a permanent connection 
to an MS from an AS.  It might be policy that an AS disconnects after a 
period of time OR it might be that an AS has not used that MS before 
(new to the network).  So it is the MRBs role to assess the situation 
and supply appropriate information.  It is also true to say that an MRB 
plays a logical role that is making decisions on behalf of the AS and 
therefore needs all of the appropriate information - which might result 
in some duplication.