Subject: [MEDIACTRL] Media Control Channel Framework - Case Sensitivity

From: Chris Boulton <[email-masked]>
Date: Thu, 18 Jun 2009 16:57:57 +0100

Hi All,

As a result of feedback from our AD (Robert Sparks) we need to make a 
couple of changes to the Media Channel Control framework before we can 
proceed.  The following was called out:

The spec doesn't seem to cover comparison of the header field
       names and values it defines - is it case-sensitive or
       case-insensitive?

I would suggest the following:

Unless otherwise stated in the definition of a particular header field, 
field values, parameter names, and parameter values are case in-sensitive.

Are we happy with this?  Especially those who are implementing?

I would suggest the following exceptions - transaction-ID that appears 
in request/responses.

Any others?

Please let me know what you think.

Chris.

---

From: Stéphane Bastien <[email-masked]>
Date: Thu, 18 Jun 2009 11:34:59 -0700

connectionids should be case sensitive.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Chris Boulton
Sent: 18 juin 2009 11:58
To: [email-masked]
Subject: [MEDIACTRL] Media Control Channel Framework - Case Sensitivity

Hi All,

Any others?

Chris.

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: Chris Boulton <[email-masked]>
Date: Thu, 18 Jun 2009 20:02:12 +0100

Agreed.

Thanks Stéphane.  Anyone got any others?

Chris.

---

From: Jean-Francois Bertrand <[email-masked]>
Date: Thu, 18 Jun 2009 12:46:51 -0700

conferenceids should also be case sensitive.   

All other ids should be case in-sensitive, it'll make parsing easier.
/JF
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Chris Boulton [[email-masked]]
Sent: Thursday, June 18, 2009 3:02 PM
To: Stéphane Bastien
Cc: [email-masked]
Subject: Re: [MEDIACTRL] Media Control Channel Framework - Case Sensitivity

Agreed.

Chris.