Subject: [MEDIACTRL] Language Tags for Error Comments (was ... error in examples in section 4.2.3)

From: Eric Burger <[email-masked]>
Date: Thu, 1 Jul 2010 10:26:52 -0400

An AD wants to know: Will users ever see this text?  If we call it opaque, anyone mind if we do specify a language tag anyway?  My guess is no one will ever specify a tag with the string, but it does mean that MEDIACTRL clients should not barf is someday a server does specify a language tag.

Thoughts?

On Jun 15, 2010, at 7:26 AM, Eric Burger wrote:

> Does it need to be in local language? Does it need to always be readable? Does it need to be interpreted by a human? Does it need to be interpreted by a machine?
> 
> I would offer the answers are "No, No, Probably, Never", which means the comment should be opaque, 7-bit ASCII text.
> 
> Anyone think otherwise?
> 
> 
> On Jun 15, 2010, at 5:34 AM, RahulSrivastava 71616 wrote:
> 
>> Mostly this is required for writing logs and debugging.
>> Required for checking call failures and proving to somebody why it failed after days of usgae :-)
>> 
>> Regards,
>> Rahul
>> 
>> 
>> ******************************************************************************************
>> This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained here in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this email in error, please notify the sender by phone or email immediately and delete it!
>> *****************************************************************************************
>> 
>> ----- Original Message -----
>> From: Eric Burger <[email-masked]>
>> Date: Tuesday, June 15, 2010 10:42 am
>> Subject: Re: [MEDIACTRL] draft-ietf-mediactrl-mixer-control-package-11 error	in examples in section 4.2.3
>> To: [email-masked]
>> 
>>> More fundamental question: Why do we have reason text at all?
>>> 
>>> One of the DISCUSSes from the ADs is that if we have human-
>>> readable text, it has to have a language indicator.
>>> 
>>> If the Reason Comment is not human readable, then we do not need it.
>>> 
>>> What would be the opinion of the WG to drop reason / comment text 
>>> everywhere? Or, to keep with HTTP, to have fixed reason strings? 
>>> Or, to keep with XML, we just say that the string gets interpreted 
>>> in whatever locale the XML gets interpreted?
>>> 
>>> On Jun 10, 2010, at 11:29 AM, McGlashan, Scott wrote:
>>> 
>>>> thanks - I'll fix them.
>>>> 
>>>> Scott
>>>> 
>>>> On 4 Jun 2010, at 19:04, Stéphane Bastien wrote:
>>>> 
>>>> Hi,
>>>> 
>>>> In draft-ietf-mediactrl-mixer-control-package-11, there are 
>>> errors in the examples in section 4.2.3 <response>.
>>>> 
>>>> The examples are:
>>>> 
>>>> <response code="200">
>>>>  <reason>Success</reason>
>>>> </response>
>>>> 
>>>> 
>>>> <response code="403">
>>>> 
>>>>  <reason>Conf already exists</reason>
>>>> 
>>>> </response>
>>>> 
>>>> 
>>>> But I believe they should show:
>>>> 
>>>> 
>>>> <response status="200" reason="conference created" />
>>>> 
>>>> 
>>>> 
>>>> <response status="405" reason="Conference already exists" />
>>>> 
>>>> 
>>>> 
>>>> 
>>>> Regards,
>>>> 
>>>> Stéphane
>>>> 
>>>> <ATT00001..txt>
>>>> 
>>>> _______________________________________________
>>>> MEDIACTRL mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/mediactrl
>>>> Supplemental Web Site:
>>>> http://www.standardstrack.com/ietf/mediactrl
>>> 
>>> _______________________________________________
>>> MEDIACTRL mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/mediactrl
>>> Supplemental Web Site:
>>> http://www.standardstrack.com/ietf/mediactrl
>>> 
> 
> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl

---

From: Eric Burger <[email-masked]>
Date: Mon, 19 Jul 2010 17:14:30 -0400

Speaking as myself, users will not ever see this text, so it can be opaque and without language tags.  However, we need INPUT from the WG to close this.

---

From: Stéphane Bastien <[email-masked]>
Date: Mon, 19 Jul 2010 18:37:24 -0700

Agreed. I believe the text will be used by system operators and developers to track down problems.

---

From: Lorenzo Miniero <[email-masked]>
Date: Tue, 20 Jul 2010 07:34:14 +0200

I agree as well.

L.

On Mon, 19 Jul 2010 18:37:24 -0700

-- 
Lorenzo Miniero <[email-masked]>