Subject: [MEDIACTRL] Does a Control Package name include the version number

From: Chris Boulton <[email-masked]>
Date: Wed, 07 Jul 2010 20:47:55 +0100

Hi All,

As part of our IESG review the following has been identified:

Section 8.1

states:

The package name MUST also register a

version number for the package which is separated with a '/' symbol

e.g. package_name/1.0.

This could be taken to mean that (1) "package_name/1.0" is the complete

package name or (2) "package_name" is the mere package name and "1.0" is

the package version number. The ABNF appears to imply (1) because it says:

Packages = "Packages:" SP package-name *(COMMA package-name)

package-name = alpha-num-token

alpha-num-token = ALPHANUM 3*31alpha-num-tokent-char

alpha-num-tokent-char = ALPHANUM / "." / "-" / "+" / "%" / "=" / "/"

This appears to allow "/" in the "mere package name". If so, how will

software parse the complete package name to determine the package

version number? Will it parse the complete package name from the end and

split the name at the first "/" character it finds? Can the version

number include a "/" character? The ABNF does not appear to disallow that.

What do we want to do with version?  I would suggest that we soften the 
MUST requirement.

Chris.

-- 
Chris Boulton
CTO & Co-founder
NS-Technologies <http://www.ns-technologies.com>
m: +44.7876.476681

---

From: Eric Burger <[email-masked]>
Date: Mon, 19 Jul 2010 17:18:11 -0400

I say (as an individual) "Nay, nay": Packages do whatever they want.  Backwards compatibility is a nice fairy tale, but not anything we really care about.  I offer packages are arbitrary, opaque names. If they *happen* to end with /1.0 or /9.2993, great.  However, I would offer the protocol should not care or impose any semantics about what the /mumble.foo means.

On Jul 7, 2010, at 3:47 PM, Chris Boulton wrote:

> What do we want to do with version?  I would suggest that we soften the MUST requirement.
> 
> Chris.
> 
> 
> -- 
> Chris Boulton
> CTO & Co-founder
> NS-Technologies
> m: +44.7876.476681
> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl

---

From: RahulSrivastava 71616 <[email-masked]>
Date: Tue, 20 Jul 2010 09:51:51 +0500

Agreed.
But care should be take not to use package name doesn't become a tunnel where all properiety information can be passed.

Regards,
Rahul

******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained here in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this email in error, please notify the sender by phone or email immediately and delete it!
 *****************************************************************************************

----- Original Message -----
From: Eric Burger <[email-masked]>
Date: Tuesday, July 20, 2010 2:48 am
Subject: Re: [MEDIACTRL] Does a Control Package name include the version	number
To: Boulton Chris <[email-masked]>
Cc: Saint-Andre Peter <[email-masked]>, [email-masked]

> I say (as an individual) "Nay, nay": Packages do whatever they 
> want.  Backwards compatibility is a nice fairy tale, but not 
> anything we really care about.  I offer packages are arbitrary, 
> opaque names. If they *happen* to end with /1.0 or /9.2993, great. 
> However, I would offer the protocol should not care or impose any 
> semantics about what the /mumble.foo means.
> 
> > This could be taken to mean that (1) "package_name/1.0" is the 
> complete> package name or (2) "package_name" is the mere package 
> name and "1.0" is
> > This appears to allow "/" in the "mere package name". If so, how 
> will> software parse the complete package name to determine the 
> package> version number? Will it parse the complete package name 
> from the end and

---

From: Lorenzo Miniero <[email-masked]>
Date: Tue, 20 Jul 2010 07:36:18 +0200

Backwards compatiility is a nice fairy tale, but there are cases when a versioning may actually work (e.g., if a 1.1 only has additions to a 1.0 and no modification). Is it ok if we just say that the /mumble.foo may or may not appear, but if it doesn't it implies 1.0? This looks safer to me.

L.

On Mon, 19 Jul 2010 17:18:11 -0400

-- 
Lorenzo Miniero <[email-masked]>