Subject: [MEDIACTRL] ISSUE 1 - IVR Package - HTTP/HTTPS mandatory

From: "McGlashan, Scott" <[email-masked]>
Date: Tue, 24 Aug 2010 14:59:39 +0000

Hi All,

As part of our IESG review of the IVR package the following issue has been identified:

1) In Section 4:

   The MS MUST
   support one or more schemes using communication protocols suitable
   for fetching resources (e.g.  HTTP).

I don't think this is good enough for interoperability. You should specify a
mandatory to implement protocol for fetching resources.
I suggest you mandate
use of HTTP and HTTPS. (The latter is important for providing data
confidentiality)

The same issue is relevant in section 4.3.1.4 - a mandatory to implement
protocol for recording data.

Are we happy to mandate the use of HTTP and HTTPS in the context of fetching dialog documents and resources as well as recordings?
This seems a reasonable change to us but would affect implementations which don't already support these protocols. Let us know if you have any objections to this change.

thanks

Scott

---

From: Lorenzo Miniero <[email-masked]>
Date: Thu, 26 Aug 2010 11:50:13 +0200

I think mandating HTTP/HTTPS is definitely ok: my guess is everyone will support AT LEAST those two, so it's safe to add this.

L.

On Tue, 24 Aug 2010 14:59:39 +0000
"McGlashan, Scott" <[email-masked]> wrote:

> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl
> 

-- 
Lorenzo Miniero <[email-masked]>

---

From: Victor Paulsamy <[email-masked]>
Date: Thu, 26 Aug 2010 13:20:01 -0700

Is it mandatory to support both or either?

--victor

On Tue, Aug 24, 2010 at 7:59 AM, McGlashan, Scott <[email-masked]>wrote:

> Are we happy to mandate the use of HTTP and HTTPS in the context of
> fetching dialog documents and resources as well as recordings?
> This seems a reasonable change to us but would affect implementations which
> don't already support these protocols. Let us know if you have any
> objections to this change.
>
> thanks
>
> Scott