Subject: Re: [MEDIACTRL] MRB Publish interface suggestion

From: Chris Boulton <[email-masked]>
Date: Thu, 19 May 2011 15:12:50 +0100

Gary - this seems reasonable to me.  Unless anyone objects I will look 
at weaving into the text and submit a new version (which will also 
include some final edits).  Any thoughts?  Shout.

On 13/04/2011 11:33, MUNSON, GARY A (ATTSI) wrote:
> Thanks for posting mrb-08.
>
> I have one modification to suggest for the Publish interface.
>
> Currently the Publish subscription element has a 'frequency' child
> element that says how often the MRB wants to receive notifications from
> an MS on status of its resources.
>
> I find myself wondering whether a notification interval range min and
> max might be more useful than frequency. I.e., so that the MRB would
> tell the MS that the interval duration from the last notification to the
> next notification should be no more than X seconds and no less than Y
> seconds.
>
> That way the MS could optionally be allowed to decide, within
> constraints, how often to send notifications to MRB. So, for example,
> when things are working normally the MS might send updates every 30
> minutes, but if all of a sudden its real time consumption gets clobbered
> because of some system emergency audit running and the effective number
> of idle ports is seriously diminished, it can send a next event
> notification much sooner.
>
> Specifying max/min values instead of a single frequency adds a tiny bit
> of complexity to the Publish interface but could have a significant
> benefit. And one could still specify a single frequency by setting min
> and max to the same value.
>
> BR,
>
> Gary
>
> Gary Munson
> AT&T
> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl
>

-- 
Chris Boulton
CTO & Co-founder
NS-Technologies <http://www.ns-technologies.com>
m: +44.7876.476681

---

From: Lorenzo Miniero <[email-masked]>
Date: Mon, 23 May 2011 11:43:53 +0200

I'm ok with it as well, it sounds like a reasonable improvement which wouldn't add any additional or unrequired complexity to an implementation.

L.

On Thu, 19 May 2011 15:12:50 +0100

-- 
Lorenzo Miniero, COB

Meetecho s.r.l.
Web Conferencing and Collaboration Tools
http://www.meetecho.com