Subject: Re: V16 review - Editorial comments

From: Nancy-M Greene <[email-masked]>
Date: Fri, 24 Mar 2000 11:40:47 -0500

Hi Christian, thanks for your comments. My comments are below. The goal as
always, is to change the spec only if necessary.

Nancy
--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

> ----------
> From:         Christian Groves[SMTP:[email-masked]]
> Sent:         Wednesday, March 22, 2000 10:29 PM
> To:   [email-masked]
> Subject:      Re: V16 review - Editorial comments
>
> G'Day Nancy,
>
> Please see my comments marked [CHG].
>
> Cheers, Christian
>
> Nancy-M Greene wrote:
> >
> > Brian, John,
> > I believe each of the following is an editorial change to V16. You
> > have both seen most of these already, and commented on them - I am
> > posting them to the megaco list this time, with the proposed
> > resolutions. Please comment!
> >
> > 1- Section 7.1.1 Specifying Parameters
> > Issue: para. starting with "Unspecified mandatory parameters
> > (i.e. mandatory parameters not specified in a descriptor) result
> > in the command responder retaining the previous value for that
> > parameter."
> >
> > Comment: It seems that this section applies only to mandatory fields
> > in
> > Local and Remote descriptors (see section 7.1.8). For example, when
> > a mandatory parameter is unspecified in the Local descriptor,
> > then it retains the value it already has. But, a mandatory parameter
> > in a ServiceChange HAS to be there I would think. For example, the
> > ServiceChangeMethod descriptor is mandatory, and must
> > always be present.
> >
> > Proposal: Preface the quoted sentence in 7.1.1 with "For Local and
> > Remote Descriptors, unspecified mandatory parameters (i.e. mandatory
> > parameters not specified in a descriptor) result in the ...."
> >
> > 2- Section 7.1.6 Stream Descriptor
> > Issue: last sentence of first para, "A stream is deleted by
> > setting empty Local and Remote descriptors for the stream with
> > ReserveGroup and ReserveValue in LocalControl set to "false" on
> > all terminations in the context that previously supported that
> > stream."
> >
> > Comment: We don't have false or true in the ABNF, only "ON/OFF". The
> > text uses both true/false, and on/off.
> >
> > Proposal: Make no changes to the text. Just add this comment:
> > "ON = true, and OFF = false" to the ABNF.
> [CHG] OK
>
> >
> > 3- Section 7.1.7 LocalControl Descriptor - ReserveGroup/ReserveValue
> > Issue: There is no explanation as to what ReserveValue and
> > ReserveGroup mean.
> >
> > Proposal: Add text something like the following:
> > "In order to state that one session description is to be selected
> > out of a list, ReserveGroup is set to "false". If resources for all
> > session descriptions are to be reserved, ReserveGroup is set
> > to "true". In order to state that a parameter with a list of values,
> > e.g. multiple rtp payload types, requires one value is to be
> > selected from the list, ReserveValue is set to "false". If resources
> > for all values are to be reserved, ReserveValue is set to "true".
> > In other words, overspecifying by giving a list of values can happen
> > independently at the session description level and at the parameter
> > level. "
> [CHG] I don't think this is necessary. The text currently states: "The
> boolean-valued Reserve properties, ReserveValue and ReserveGroup" and
> then it follows in the next 2 paragraphs about what to do. The terms
> value and groups are used in other sections. This isn't an error at best
> its something for a possible implementors guide.
>
[Nancy] You are right, there is some text there. If necessary, some of our
text can be added for clarification - I will leave it up to the editors.

> >
> > 4- Section 7.1.9 Events Descriptor - eventDM
> > Issue: eventDM is not mentioned in this section while it is part of
> > the
> > eventsDescriptor syntax.
> >
> > Proposal: Add this sentence:
> > "If a digit map is required in the EventsDescriptor, EventDM is used
> > to carry either the name or the value of the digit map. See
> > section 7.1.14."
> >
> > 5- Section 7.1.11 Signals Descriptor
> > Issue: setting of the signal list type
> >
> > Proposal: Add the following to section 7.1.11:
> > * on/off in signal list
> >     -> it must be the last element, and signal list type must be
> > on/off
> > * timeout in signal list (and NO on/off signals in the list)
> >      -> signal list type must be timeout
> > * only brief signals in signal list
> >     -> signal list type defaults to brief.
>
> [CHG] Isn't this in the determined draft? 2nd paragraph after list.
>
[Nancy] Yes it is there in the 2nd paragraph after the list. Our proposal is
to clarify that paragraph. If people understand it as it is written, then we
don't need to add our text.

> >
> > 6- Section 7.1.12 Audit Descriptor, and also auditItem in the ABNF
> > Issue: the last entry in the table is "EventBuffer". auditItem in the
> > ABNF
> > does not qualify it either which is incorrect.
> >
> > Proposal: Change "EventBuffer" to "EventBuffer Descriptor" in both
> > section 7.1.12
> > and in the ABNF.
> >
> > 7- Section 7.1.13 ServiceChangeDescriptor
> > Issue: Extension is not part of the enumeration
> >
> > Comment: Is ServiceChangeDescriptor supposed to be extendable or not?
> > The ABNF still has an extension parameter in it.
> [CHG] I don't like the extension parameter but we do have it. See 7.2.8
> no.7 in the list. And the text in 7.2.8 "The optional Extension
> parameter may contain any value whose meaning is mutually understood by
> the MG and MGC."
>
> >
> > 8- Section 7.1.18 Topology Descriptor
> > Issue: para starting with "(T1,T2, bothway) means that ....
> > loopbacks are created by setting the TerminationMode."
> >
> > Comment: We don't have TerminationMode any more.
> >
> > Proposal: change it to read:
> > "...loopbacks are created by setting the StreamMode property to
> > LoopBack
> > in the LocalControlDescriptor."
> [CHG] Perhaps we can just delete the text after the ";"? StreamMode =
> Loopback is in 7.1.7
>
[Nancy] your proposal is fine.

> >
> > 9- 7.2.5 Audit Value
> > Issue "W-" and "O-"
> > Comment: Text does not describe that wildcarded response
> > is qualified by "W-". Also, no  text explaining that
> > optional commands are qualified by "O-".
> >
> > Proposal: in section  7.2.5, add the following:
> > "The wildcard response option (see section 6.2.2) is particularly
> > useful
> > to limit the size of a n audit value command which uses a wildcard
> > terminationId. In ASN.1 encoding (Annex A), the flag "wildcardReturn"
> > is set on a command, and in ABNF (Annex B), the command is qualified
> > by the "W-" option."
>
> [CHG] Sect 6.2.2 already covers much of this. I don't see a need to
> repeat the information in 7.2.5. 6.2.2 even recommends that this is
> useful for audit.
>
[Nancy] All right, the first sentence can go. BUT, we need the text that
explains O- and W-, and the corresponding ASN.1 terms "wildcardReturn" and
"optional".

> >
> > Also, in section 8, add the following:
> > "In ASN.1 encoding, the flag "optional" is set on a command, and in
> > the
> > ABNF, the command is qualified with the "O-" option."
> >
> > 10- Section 7.2.6 AuditCapabilities
> > Issue: AuditCapability API
> >
> > Comment: same as in 9-Section 7.2.5
> >
> > Proposal: Add same sentences as above, to this section.
> >
> [CHG] See my comment on 7.2.5
>
> > 11- Section 7.2.6 AuditCapabilities - DigitMap and Packages
> > Issue: DigitMap and Packages in the ABNF
> >
> > Comment: The ABNF allows DigitMap and Packages
> > in the return of AuditCapability. The text says no. Need to
> > add a comment in the ABNF that explains this.
> >
> > Proposal: Add the following comment to the ABNF:
> > "DigitMap and Packages are not permitted to be part of
> > AuditCapabilities"
> >
> > 12- ANNEX B: signalListParm
> > Issue: signalListParm = signalRequest
> >
> > Comment: This is redundant.
> >
> > Proposal: in the ABNF, signalRequest should replace
> > signalListParm in signalList.
> >
> > 13- ANNEX B:digitMapValue
> > Issue: digitMapDescriptor = DigitMapToken EQUAL digitMapName
> > ( LBRKT digitMapValue RBRKT )
> >
> > Comment: error with the round brackets
> >
> > Proposal: it should be
> > digitMapDescriptor = DigitMapToken EQUAL digitMapName
> > [ LBRKT digitMapValue RBRKT ]
> >
> > 14- ANNEX B: version token
> > Issue: VersionToken is missing in the ABNF.
> >
> > Proposal: Add VersionToken = ("Version" / "V")
> >
> > Nancy & Abdallah
> >
> >
> --------------------------------------------------------------------------
> >
> > Nancy M. Greene
> > Internet & Service Provider Networks, Nortel Networks
> > T:514-271-7221 (internal:ESN853-1077) E:[email-masked]
>

---

From: Chip Sharp <[email-masked]>
Date: Fri, 24 Mar 2000 12:50:29 -0800

At 08:35 PM 3/20/00 -0600, Nancy-M Greene wrote:
...snip...
>Issue: the last entry in the table is "EventBuffer". auditItem in the ABNF
>Proposal: Change "EventBuffer" to "EventBuffer Descriptor" in both section
>7.1.12
>and in the ABNF.

Nit.  I don't think there should be a space between "EventBuffer" and
"Descriptor."
...snip...

http://www.netaid.org
-------------------------------------------------------------------------
Chip Sharp                 CTO Consulting Engineering
Cisco Systems
Reality - Love it or Leave it.
------------------------------------------------------------------------