Subject: Re: Event handling questions

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 8 Mar 2000 23:16:08 -0500

I think there is no way an MGC is going to switch event buffering on and off
depending on what happens - either it will be set on and left, or set off
and
left.  If it is on, there needs to be a way to clear the buffer.  If it is
off,
you never have the problem.

I'd be okay in separating the controls (having two separate properties), but
at
this late date, it may not be worth it.  I'll let Tom pass judgment on that.

Brian

> -----Original Message-----
> From: Flemming Andreasen [mailto:[email-masked]]
> Sent: Wednesday, March 08, 2000 10:37 AM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: Re: Event handling questions
>
>
>
>
> "Rosen, Brian" wrote:
>
> > It seems to me that a particular MGC will either keep
> EventBufferControl on
> > or off.
> > There has to be a way to clear the buffer.  Turning it from
> on to off seems
> > to be
> > an appropriate way to do that.
>
> You can argue either way, which is why I've always argued
> this should have been
> two instead of one parameter. In the absence of that the
> question then becomes
> whether you should always drop the events or not. The safe
> approach which
> satisfies all scenarios is not to drop them which actually
> has the effect of
> clearing the buffer as well since the MG is fully allowed to empty the
> eventbuffer in a single Notify message when EventBufferControl is off.
> Consequently I say they should not be dropped.
>
>
> >
> >
> > Brian
> >
> > > -----Original Message-----
> > > From: Flemming Andreasen [mailto:[email-masked]]
> > > Sent: Tuesday, March 07, 2000 11:04 AM
> > > To: [email-masked]
> > > Subject: Re: Event handling questions
> > >
> > >
> > > Tom-PT Taylor wrote:
> > >
> > > >
> > > >
> > > > Replies below.
> > > >
> > > >      -----Original Message-----
> > > >      From:   Flemming Andreasen [SMTP:[email-masked]]
> > > >      Sent:   Tuesday, March 07, 2000 10:03 AM
> > > >      To:     [email-masked]
> > > >      Subject:        Event handling questions
> > > >
> > > >      A couple of questions on the event handling (7.1.9):
> > > >
> > > >      1. It is specified that "When the MG receives a
> command with a
> > > >      new
> > > >      EventsDescriptor, one or more events may have been
> buffered in
> > > >      the
> > > >      EventBuffer in the MG. The value of EventBufferControl then
> > > >      determines
> > > >      how the MG treats such buffered events."
> > > >
> > > >      I assume that the "the value of EventBufferControl"
> > > refers to the
> > > >      value
> > > >      in the new command (if supplied), not the old, correct ?
> > > >      [[TomT]]
> > > >      That is correct.
> > > >
> > > >      2. It is specified that "If the MG receives a command
> > > instructing
> > > >      it to
> > > >      set the value of EventBufferControl to Off, all
> events in the
> > > >      EventBuffer SHALL be discarded."
> > > >
> > > >      This seems rather strange to me as you will be
> dropping events
> > > >      for no
> > > >      apparent reason. Can somebody please explain the
> > > rationale behind
> > > >      this ?
> > > >
> > > >      [[TomT]]  If the MGC turns EventBufferControl off, it
> > > must have a
> > > >      reason for doing so.  The same reason presumably
> extends to the
> > > >      treatment of events already in the buffer.
> > > >
> > > I don't follow. How does that justify throwing away the
> > > events that were
> > > already buffered ? The only thing you are changing is the way
> > > you report
> > > events. For example consider the case where the set of
> events to be
> > > detected in the two commands are exactly the same but the
> > > EventBufferControl differs.
> > >
> > >
> > >
> > > >
> > > >      Thanks
> > > >
> > > >              Flemming
> > > >
> > > >      --
> > > >      Flemming Andreasen
> > > >      Cisco Systems
> > > >
> > > --
> > > Flemming Andreasen
> > > Cisco Systems
> > >
>
> --
> Flemming Andreasen
> Cisco Systems
>
>

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 9 Mar 2000 08:18:09 -0500

"Rosen, Brian" wrote:

> left.  If it is on, there needs to be a way to clear the buffer.

Send a single Notify.

> If it is

Look, although my preferences are probably well known here, I specifically did
not ask for a protocal design change. I have simply reviewed the specification
of the current design and noted a problem as well as offered a simple editorial
in nature  change to address it.

-- Flemming

--
Flemming Andreasen
Cisco Systems