Subject: Re: DTMF detection

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 28 Mar 2000 19:15:17 -0500

I'm inclined to declare this issue out of scope of Megaco, as it
only deals with what happens in the media stream and has nothing
to do with the control of the streams or the connections.  I
personally think that you would NOT substitute comfort noise in any
conditions.

Determining support of an RTP payload capability in the MG is possible
with the standard Megaco audit capabilities mechanism.  How two
MGCs determine whether the opposite MG can do it is an interMGC
protocol issue, and clearly out of scope of Megaco.

Brian

> -----Original Message-----
> From: Yu Zhu [mailto:[email-masked]]
> Sent: Tuesday, March 28, 2000 1:05 PM
> To: [email-masked]
> Subject: DTMF detection
>
>
> Hi there,
>
> The MG shall support detecting and passing DTMF signals to
> the peer gateway. The
> MG can use various methods in order to transport DTMF depending on its
> configuration and instructions by the MGC.
> The three different types of mechanisms for transport of DTMF are :
> 1). To the MGC through the standard MEGACO DTMF package
> 2)  In-band in the RTP stream and
> 3) Out-of-band through a special payload type in the RTP
> stream (per the
> Internet-draft "RTP Payload for DTMF Digits, Telephony Tones
> and Telephony
> Signals")
>
> In case of sending the DTMF trough the MGC and also when
> sending it with special
> RTP payloads as defined in the latest IETF draft , Should the
> DTMF be extracted
> from the media stream and replaced with comfort noise ? If
> someone chooses to
> use the special RTP packets and extracts DTMF out of media
> stream, how is it
> determined that the other end supports the same mechanism ?
>
> Regards,
> -- Yu Zhu
>

---

From: Stephen Terrill <[email-masked]>
Date: Wed, 29 Mar 2000 09:37:38 +0200

Hi,

I support Brian in this as it is also very dependant on the media stream as well (e.g. the DTMF in PCM Codec speach for the STM bearer will require different handling that the RTP stream(s)).

Regards,

..//Steve