Subject: Re: new proposed TIPHON work items

From: Peter Blatherwick <[email-masked]>
Date: Tue, 28 Mar 2000 04:37:32 -0500

Tom, list:

I would personally not want to see more than one interoperability focus, at
least initially.  It would add overhead and could lead to contentions and
confusion on what is actually correct from the multiple bodies.  I don't
care much which one -- whatever seems to meet the needs best -- but lets
pick one only.  IF bodies such as TIPHON wish to have an interoperability
conformance statement, test suite or whatever, it should be identical for
all such bodies irrespective of what forum the actual interop testing occurs
in.  Publishing a conformance statement or test suite might be a valuable
output of the WG, after initial interop testing, but we're not ready yet
IMO.

I would also would like to make sure that especially the very first interop
events are pretty closed door.  The last thing we need is a pile of
marketing and press getting in the way of engineering.  There seems to be
general agreement on this at least from those I have spoken to here so far.

My $0.02 (which the Ozzies in the crowd have pointed out is subject to round
off here ;-)

-- Peter

> -----Original Message-----
> From: Taylor, Tom-PT [CAR:B904:EXCH]
> Sent: Monday, March 27, 2000 12:41 AM
> To:   [email-masked]
> Subject:      FW: new proposed TIPHON work items
>
> Megaco followers may have an interest in this one, considering the recent
> discussions on interoperability testing.  Is this a valid work item, is it
> premature, is it a necessary step?  Comments?
>
> > -----Original Message-----
> > From: Schink Helmut [SMTP:[email-masked]]
> > Sent: Thursday, March 23, 2000 7:40 AM
> > To:   [email-masked]
> > Cc:   'TIPHON_PMC'
> > Subject:      new proposed TIPHON work items
> >
> > A series of new work items have been proposed at the TIPHON#17 meeting:
> > TIPHON has not made any determination as yet. The following titles have
> > submitted:
> >
> [[TomT]]  ...
> >  11.Protocol Implementation Conformance Statement (PICS) proforma for
> the
> > support of physically decomposed multimedia gateway; Support of ITU-T
> > recommendation H.248
> >
> > more details can be found at: <<new_WIs_for_approval.htm>>
> >
> > Best regards
> >
> > Helmut Schink
> >
> >
> --------------------------------------------------------------------------
> > --
> > ------------
> > Dr. Helmut Schink
> > Siemens AG
> > Information and Communication Networks
> > Advanced Network Standards
> > phone: +49 89 722 44523
> > mobile: +49 172 8146471
> > mailto:[email-masked]
> > http://intranet.icn.siemens.de/marketing/cs21/index.html (intranet use
> > only)
> > http://www.siemens.de (publically accessible)
> >  <<new_WIs_for_approval.htm>>
>  << File: new_WIs_for_approval.htm >>

---

From: "Drage, Keith" <[email-masked]>
Date: Wed, 29 Mar 2000 10:10:52 +0100

There seems to be a misconception in the last couple of messages on this
thread as to what a PICS proforma is. This is defined in ISO 9646 and is a
formal restatement of all the options within the underlying protocol
standard, with check boxes that the implementor can tick. The proforma is
filled in by the implementor to become a PICS.

As such a PICS proforma can be created as soon as the underlying protocol
text exists, it does not need to wait for an implementation. It also does
not need to wait for the specification of either applications or packages,
as those will be dealt with in separate documentation.

While a completed PICS may provided a means of identifying whether two
implementations of a standard will interoperate, i.e. in identifying whether
compatible options have been selected, it is not in itself a test document.
It may provide a means of specifying the input parameters for test case
selection in a test document.

If you want to know more about PICS proformas, apart from referring to ISO
9646, I suggest also a reading of ETSI EG 201 058 - freely available from
the ETSI web site.

ETSI TIPHON is apparently interested in providing conformance test
documentation in the future, and ETSI has a well established reputation for
such work on other protocols. Conformance testing connects the
implementation to a tester, which then runs a test script, and excercises
the implementation according to the requirements of the underlying protocol
specification. It assesses whether those requirements have been implemented.
It does not prove that an implementation will interwork with another
implementation. For an overview of required documentation for conformance
testing, I suggest reading ETSI ETS 300 406. Conformance testing is capable
of assessing both normal behaviour and exceptional behaviour (e.g. error
recovery).

Interoperability testing only tests whether one implementation will
interwork with another implementation. As such, it only provides a means of
assessing the normal behaviour, unless some sort of exceptional behaviour is
introduced into the operation of the peer implementation.

As such, interoperability testing and conformance testing are complementary.

The capability of providing either form of tests without specified
applications and packages depends on the available points of control within
the implementation. For conformance testing, these are specified in the ATS
(abstract test suite), and therefore do not need to be understood at the
time of writing the TSS&TP (test suite structure and test purpose).

Keith Drage

> ---------------------------------------------------------------
> Keith Drage ([email-masked])
> Siemens Communications Limited,
> Technology Drive, Beeston, Nottingham NG9 1LA, UK
> Tel: +44 115 943 4991   Fax: +44 115 943 4992
> ---------------------------------------------------------------
> Internet communications are not secure and therefore Siemens
> Communications Limited does not accept legal responsibility for the
> contents of this message. Any views or opinions presented are solely
> those of the author and do not necessarily represent those of Siemens
> Communications Limited unless otherwise specifically stated.
>

> From: Christian Groves [mailto:[email-masked]]
> Sent: Wednesday, March 29, 2000 2:24 AM
> Subject: Re: FW: new proposed TIPHON work items
>
>
> G'Day Tom,
>
> I think going for the Tiphon PICS is a bit premature for a
> first interop
> test. Some people may not be interested in Tiphon GWs (I'm thinking of
> you Pete :-)).
> I'm sure this will come up in discussions in Adelaide.
>
> Cheers, Christian
>
> > Tom-PT Taylor wrote:
> >
> > >  11.Protocol Implementation Conformance Statement (PICS) proforma
> > for the
> >                  New Work Items proposed at TIPHON#17
> >
> > These WIs are now submitted to your approval*, please send your
> > comments to the TIPHON mailing list
> > To check the details of individual Work Items click on the "details
> > and Download" links on this page or download the work item sheets
> > here.
> > (*)The approval process will end on the 21st of April 2000
> >
> >               IDENTIFICATION                 TITLE
>          STATUS
> >
> >  1   Deliverable Type: TR               Requirements for
> Current Status: 0
> >      Ref. DTR/TIPHON-01006              the IP Transport
> Next Status:
> >      Technical Body: TIPHON WG1         Plane            TB
> adoption of WI (21-04-2000)
> >      Details and Download
> (approval on mailing list)
> >
> >  2   Deliverable Type: MI               Project Method
> Current Status: 0
> >      Ref. MI/TIPHON-01007               Definition
> Next Status:
> >      Technical Body: TIPHON WG1                          TB
> adoption of WI (21-04-2000)
> >      Details and Download
> (approval on mailing list)
> >
> >  3   Deliverable Type: TR               Requirements
> Current Status: 0
> >      Ref. DTR/TIPHON-01008              Definition
> Next Status:
> >      Technical Body: TIPHON WG1         Study;           TB
> adoption of WI (21-04-2000)
> >      Details and Download               Scope and
> (approval on mailing list)
> >                                         requirements for
> >                                         a simple call;
> >
> >  4   Deliverable Type: TS               Release 3;
> Current Status: 0
> >      Ref. DTS/TIPHON-01009              Scope and
> Next Status:
> >      Technical Body: TIPHON WG1         requirements for TB
> adoption of WI (21-04-2000)
> >      Details and Download               a simple call
> (approval on mailing list)
> >
> >  5   Deliverable Type: TS               Release 3;
> Current Status: 0
> >      Ref. DTS/TIPHON-01010              Scope and
> Next Status:
> >      Technical Body: TIPHON WG1         requirements for TB
> adoption of WI (21-04-2000)
> >      Details and Download               QoS management
> (approval on mailing list)
> >                                         in TIPHON
> >                                         systems
> >
> >  6   Deliverable Type: TS               Release 3;
> Current Status: 0
> >      Ref. DTS/TIPHON-01011              Requirements for
> Next Status:
> >      Technical Body: TIPHON WG1         Alarm Reporting  TB
> adoption of WI (21-04-2000)
> >      Details and Download               in TIPHON
> (approval on mailing list)
> >                                         systems
> >
> >  7   Deliverable Type: TS               Protocol
> Current Status: 0
> >      Ref. DTS/TIPHON-03016              Framework
> Next Status:
> >      Technical Body: TIPHON WG3                          TB
> adoption of WI (21-04-2000)
> >      Details and Download
> (approval on mailing list)
> >
> >  8   Doc. Nb. TS 101 329-2 Ver. 2.0.0   End to End
> Current Status: 0
> >      Ref. RTS/TIPHON-05012              Quality of
> Next Status:
> >      Technical Body: TIPHON WG5         Service in       TB
> adoption of WI (21-04-2000)
> >      Details and Download               TIPHON Systems
> (approval on mailing list)
> >                                         Definition of
> >                                         Quality of
> >                                         Service (QoS)
> >                                         Classes
> >
> >  9   Doc. Nb. TS 101 329-6 Ver. 2.0.0   End to End
> Current Status: 0
> >      Ref. RTS/TIPHON-05013              Quality of
> Next Status:
> >      Technical Body: TIPHON WG5         Service in       TB
> adoption of WI (21-04-2000)
> >      Details and Download               TIPHON Systems
> (approval on mailing list)
> >                                         Actual
> >                                         measurements of
> >                                         network and
> >                                         terminal
> >                                         characteristics
> >                                         and performance
> >                                         parameters in
> >                                         TIPHON networks
> >                                         and their
> >                                         influence on
> >                                         voice quality
> >
> >  10  Deliverable Type: TS               Conformance Test
> Current Status: 0
> >      Ref. DTS/TIPHON-06016              Specifications
> Next Status:
> >      Technical Body: TIPHON WG6         for the support  TB
> adoption of WI (21-04-2000)
> >      Details and Download               of packet based
> (approval on mailing list)
> >                                         multimedia
> >                                         communications
> >                                         systems;
> >                                         H225.0 Test
> >                                         Suite Structure
> >                                         and Test
> >                                         Purposes
> >                                         (TSS&TP) for
> >                                         Terminal,
> >                                         Gatekeeper and
> >                                         Gateway
> >
> >  11  Deliverable Type: TS               Protocol
> Current Status: 0
> >      Ref. DTS/TIPHON-06017              Implementation
> Next Status:
> >      Technical Body: TIPHON WG6         Conformance      TB
> adoption of WI (21-04-2000)
> >      Details and Download               Statement (PICS)
> (approval on mailing list)
> >                                         proforma for the
> >                                         support of
> >                                         physically
> >                                         decomposed
> >                                         multimedia
> >                                         gateway;
> >                                         Support of ITU-T
> >                                         recommendation
> >                                         H.248
>