Subject: FWD: Information request! (Billing Package?)

From: Mart Nurmet <[email-masked]>
Date: Wed, 1 Mar 2000 15:02:29 -0600

Mart Nurmet wrote:

> More correspondence on billing.  -Mart
>
> Nathan Nelson wrote:
>
> > The point that was being asked is not specific to MEGACO, but more general to a
> decomposed architectures.
> >
> > The current formats that are used to bill PSTN traffic are based on AMA BAF or a
> > carrier/vendor defined CDR.  Inet believes there is a need to build a standard
> > format for a Transaction over IP record that allows for elements and
> > parameters to be recorded.
> >
> > Some of the key components of this record could be:
> >
> >     A Tracking field to tie multiple records from multiple platforms together
> >     Time Stamps
> >     Usage Stamps
> >     Originating Information (PSTN Number, IP address, email address.....)
> >     Terminating Information (PSTN Number, IP address, email address....)
> >     Terminating Port/ Media Gateway
> >     Originating Port/Media Gateway
> >     Amount of bandwidth used
> >     Types of Applications used
> >     Premiums associated with Applications
> >     Application Information (Application server IP addresses)
> >     Intermediate network usage
> >
> > One of the basic issues with a decomposed architecture from an accounting aspect
> > is that multiple devices are involved in call set, routing, application usage,
> > signaling, and finally termination.  It would be nice to see IETF support a
> > group that looks at accountability and billing, or at least provide a basic
> > model to build such records.
> >
> > Thx,
> > Nate Nelson
> > Inet
> >
> > "Rosen, Brian" wrote:
> >
> > > Interesting, I assumed everything EXCEPT a gateway throws CDRs.
> > > Assuming a decomposed gateway, the GW feeds statistics to a Call Agent
> > > (which would be a SIP UA among other things) that throws CDRs.
> > >
> > > The billing system collates all the CDRs.
> > >
> > > The spec required is, of course, the format of the CDR and the way they
> > > are transported.  You could claim that a "transaction log" is a form of
> > > CDR I suppose.
> > >
> > > I'd certainly agree that SIP itself doesn't have any "billing package".
> > > A UA and a server might, but that is independent of the protocol.  Billing
> > > might very well impact some things in SIP.
> > >
> > > Brian
> > >
> > > > -----Original Message-----
> > > > From: Dean Willis [mailto:[email-masked]]
> > > > Sent: Tuesday, February 29, 2000 2:41 PM
> > > > To: Mart Nurmet; [email-masked]
> > > > Subject: RE: Information request! (Billing Package?)
> > > >
> > > >
> > > > What would a billing package look like? I've never really understood the
> > > > concept, and it might be useful to talk about it some more.
> > > >
> > > > Here's how some implementors are doing it:
> > > >
> > > > 1) Gateways throw CDRs using RADIUS or something similar.
> > > > This feeds into rating, reporting, and billing systems,
> > > >
> > > > 2) SIP servers record transaction logs. These may feed into rating and
> > > > billing systems, and probably feed into reporting systems.
> > > >
> > > > 3) QoS PEP and PDPs log resource usages. These feed upstream as well.
> > > >
> > > > 4) Other systems, like profile managers, report usage.
> > > >
> > > > 5) Rating, reporting, and billing systems sift thru the vast amounts of
> > > > information coming at them and make useful things happen.
> > > >
> > > > All of these things use other protocols and systems -- they aren't SIP
> > > > specific. They do rely on SIP functions like authentication
> > > > -- that is, the goal of achieving billing functions has driven some
> > > > requirements into the design of SIP. However, other than driving some
> > requirements
> > > > to SIP, such efforts are generally considered to be outside the scope of
> > > > the SIP WG.
> > > >
> > > > Are you perhaps proposing to add functionality to SIP to simplify or enhance
> >
> > > > reporting capabilities or to simplify the task of driving downstream billing
> >
> > > > systems?
> > > >
> > > > --
> > > > Dena
> > > > > -----Original Message-----
> > > > > From: [email-masked]
> > > > > [mailto:[email-masked]]On Behalf Of
> > > > Mart Nurmet
> > > > > Sent: Monday, February 28, 2000 2:24 PM
> > > > > To: [email-masked]
> > > > > Subject: Information request! (Billing Package?)
> > > > >
> > > > >
> > > > > I am looking for information if there has been any work
> > > > done to generate a
> > > > > billing package for SIP.  From my look at the available
> > > > > information there does
> > > > > not seem to be any.  Is that the case or am I missing something?
> > > > >
> > > > > Thank you,
> > > > > -Mart
> > > > >
> > > > >
> > > >
> > > >

---

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 1 Mar 2000 15:20:25 -0600

I know of at least two standards in this area already (TIPHON OSP and H.323
Annex G), aside from the abortive VON MOU effort.  Do we really need another
one?

> From: Mart Nurmet [SMTP:[email-masked]]
> Sent: Wednesday, March 01, 2000 4:02 PM
> To:   [email-masked]
> Subject:      FWD: Information request! (Billing Package?)
>
> Mart Nurmet wrote:
>