Subject: V16 Review - auditing unnamed digit maps

From: Nancy-M Greene <[email-masked]>
Date: Thu, 23 Mar 2000 11:54:37 -0600

Here is an issue with auditing unnamed digit maps that has come up in
our review of section 7.2.5 AuditValue:

7.2.5 AuditValue and the unnamed digit map
Issue: in section 7.2.5 Audit Value, it mentions that DigitMapDescriptor
can be audited and returns either the name or value. This should be
more specific. A dumb MG may send name all the time while the MGC
is interested in the value. We need to allow explicit request of name, value

or both, especially to be sure to get something useful back when auditing
for unnamed digit maps.

Proposal:
1) we can give unnamed digit maps a name: "UNNAMED" .

2) Make the default meaning of the AuditValue command with respect to
digit maps be to request reporting of names without values (and "unnamed"
+ value for every unnamed digit map).

3) to request reporting of names and values (unnamed use the name
"UNNAMED") - introduce the token "A-" for "all" on the AuditValue command.
Need something similar in the ASN.1

Comments?

Nancy
Abdallah

--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 23 Mar 2000 13:02:04 -0500

I am in favor of auditValue always returning names and values, with
the unnamed digitmap called "UNNAMED"

I don't see great utility in an audit that just returns names.

I don't like introducing "A-"

This seems to be the simplest way to fix the real problem.

Brian

-----Original Message-----
From: Nancy-M Greene [mailto:[email-masked]]
Sent: Thursday, March 23, 2000 12:55 PM
To: [email-masked]
Subject: V16 Review - auditing unnamed digit maps

Proposal:

Comments?

Nancy
Abdallah