Subject: Re: Event handling questions

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 7 Mar 2000 10:47:40 -0500

Replies below.

> -----Original Message-----
> From: Flemming Andreasen [SMTP:[email-masked]]
> Sent: Tuesday, March 07, 2000 10:03 AM
> To:   [email-masked]
> Subject:      Event handling questions
>
> A couple of questions on the event handling (7.1.9):
>
> 1. It is specified that "When the MG receives a command with a new
> EventsDescriptor, one or more events may have been buffered in the
> EventBuffer in the MG. The value of EventBufferControl then determines
> how the MG treats such buffered events."
>
> I assume that the "the value of EventBufferControl" refers to the value
> in the new command (if supplied), not the old, correct ?
        [[TomT]]
        That is correct.

> 2. It is specified that "If the MG receives a command instructing it to
> set the value of EventBufferControl to Off, all events in the
> EventBuffer SHALL be discarded."
>
> This seems rather strange to me as you will be dropping events for no
> apparent reason. Can somebody please explain the rationale behind this ?
>
        [[TomT]]  If the MGC turns EventBufferControl off, it must have a
reason for doing so.  The same reason presumably extends to the treatment of
events already in the buffer.

> Thanks
>         Flemming
> --
> Flemming Andreasen
> Cisco Systems

---

From: Flemming Andreasen <[email-masked]>
Date: Tue, 7 Mar 2000 11:04:16 -0500

Tom-PT Taylor wrote:

>      reason for doing so.  The same reason presumably extends to the
>      treatment of events already in the buffer.
>
I don't follow. How does that justify throwing away the events that were
already buffered ? The only thing you are changing is the way you report
events. For example consider the case where the set of events to be
detected in the two commands are exactly the same but the
EventBufferControl differs.

--
Flemming Andreasen
Cisco Systems