Subject: Re: Questions About MEGACO/H.248 Version 16

From: Xiuping Qiu <[email-masked]>
Date: Tue, 7 Mar 2000 21:19:54 +0800

Hi, Tom-PT Taylor ,list

Still question on stream.

May StreamDescriptor describe streams between terminations in a same context?

If so, I think there are at least 2 streams within  a termination.
One stream  flows to the exterior of the context ,
the other flows to other termination,
In the figure below,  termination T1 has 2 streams : S1 and S3.
And termination T2 has S2 and S4.
S1 flows to the exterior of the context, S3 flows to other termination.

I wonder the relationships of S1,S2,S3,S4 if T1 and T2 are connected.
such as which are specified by StreamID , the equal relationship , which
equals to which then the streams aare connected, and so on.

                 +------------------------------------+
                 | Context                            |
                 |                                    |
            S1   |     +----+  S3    S4  +----+       |  S2
           ----------- |    |------*---- |    |-------------
                 |     | T1 |            | T2 |       |
                 |     +----+            +----+       |
                 |                                    |
                 +------------------------------------+

>> 2. In 7.1.6 Stream Descriptor
>>
>> " StreamIDs are of local significance between MGC and MG and they are
>> assigned by the MGC.  Within a context, StreamID is a means by which to
>> indicate which media flows are interconnected:  streams with the same
>> StreamID are connected  "
>>
>> I am wondering whether StreamID will conflict  with Topology.
>>
>> Let's  suppose there are 2 Terminations ( T1 and T2)  in a context . There
>> is one stream on the 2 Terminations each but the StreamIDs are different.
>> So  the media flows are not interconnected. But if the Topology Descriptor
>> of the Context is
>> Bothway", What will happen?
>        [[TomT]]
>        Topology is sort of a global property -- it defines
>inter-termination connectivity regardless of the details of which streams
>are flowing.  Streams add a level of detail within that framework: A may
>talk to B in general, but B doesn't happen to support the video that A is
>prepared to provide.  One could conceive of making topology stream-specific,
>but I don't think there's a real requirement for that level of control.
>

Regards,
Xiuping Qiu
_______________________________________________

Xiuping Qiu
Huawei Technologies Co., Ltd.
Mail to:   [email-masked]
Tel    :   +86 755 654 4482
Visit  :   http://www.huawei.com.cn
_______________________________________________

---

From: Christian Groves <[email-masked]>
Date: Fri, 10 Mar 2000 02:18:02 +0100

G'Day Xiuping,

A streamDescriptor doesn't describe streams between terminations.

Cheers, Christian