Subject: V16 review - Notify and error descriptor

From: Nancy-M Greene <[email-masked]>
Date: Thu, 23 Mar 2000 12:54:53 -0500

Here is an issue with auditing unnamed digit maps that has come up in 
our review of section 7.2.7 Notify and the related ABNF: 

Section 7.2.7 Notify in ABNF
Issue: NotifyRequest = NotifyToken EQUAL TerminationID 
           LBRKT observedEventsDescriptor  [ COMMA 
           errorDescriptor ] RBRKT 

Comment: NotifyRequest used to read: 
NotifyRequest = NotifyToken EQUAL TerminationID 
        LBRKT ( observedEventsDescriptor / errorDescriptor ) RBRKT 

It was changed because you can get more than one event per Notify, only 
the last of which could have an error. A cleaner way to do this would be to 
reserve RequestID of 0 for asynchronous errors which occur independently 
of particular transactions or event requests and then move errorDescriptor 
to the observedEventsDescriptor. So it would look like this:

NotifyRequest = NotifyToken EQUAL TerminationID 
    LBRKT observedEventsDescriptor RBRKT 

observedEventsDescriptor = ...parameters 
observedEventParameter = eventsStream/ eventOther / errorDescriptor 

Any comments? 

Nancy 
Abdallah 
--------------------------------------------------------------------------
Nancy M. Greene 
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 23 Mar 2000 13:21:46 -0500

Although I see some value in the proposal, I think the current
ABNF is okay, and propose to leave it as it is.

Brian

-----Original Message-----
From: Nancy-M Greene [mailto:[email-masked]]
Sent: Thursday, March 23, 2000 12:55 PM
To: [email-masked]
Subject: V16 review - Notify and error descriptor

Any comments?

Nancy
Abdallah