Subject: Re: API for Text/Binary encoding & Reply IP address

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 9 Aug 2000 08:54:54 -0400

There are some differences that the "user" of the stack would
have to deal with that are mostly a consequence of the differences
in the way things are named.  TerminationIds are the obvious one.
I think it's possible for an MGC to deal with the differences,
if the stack keeps the symbol table, and the interface uses handles.
The stack would have to have "matching" mechanisms.  While I think this
is possible, I haven't implemented it (not planning on binary
implementations around here at the moment).  An MG that attempted
to do both would be somewhat harder, I think.

The text on mIds and the section 9 text needs some improvement.
Basically, I think it's the case that the response usually goes to
where the mId says it should go.  The section 9 text refers to
cases where the controlling MGC is changing.  The idea is that the
response goes back to the "old" MGC.  Any new requests (a new Notify
perhaps) would go to the mId.

Brian

> -----Original Message-----
> From: Bentov, Kohava [mailto:[email-masked]]
> Sent: Wednesday, August 09, 2000 8:09 AM
> To: [email-masked]
> Subject: API for Text/Binary encoding & Reply IP address
>
>
> Hi all,
>
>    Please, help me to understand the following two issues:
>
>    1. The Binary and the Text encoding differ in some of the
> definitions.
> Thus, the User
>        of  the 'Megaco Stack' should know the message format
> of each message
> it sends. At first
>        we thought that this information is relevant just to
> the Stack itself
> and it is hidden from the user
>        (MGC or MG). But now, if some of the definitions are
> not the same
> (for example,  TerminationID),
>        the API procedures (between the User and the 'Megaco
> Stack') in some
> cases will be doubled: one for
>        the Text format and one for the Binary.
>        The user has to use the right API procedures according to the
> encoding format. .
>        Am I right ?????
>
>     2. In section 9 the following is written:
>          ' ...but responses must always be sent back to the
> address which
> was the source of the
>          corresponding request.'.
>          My question is:
>              To which IP address should  I send the response:
> the address
> mentioned in the mId field
>               in the header of the message, or, to the Source
> Address of
> message (from the TCP or
>               UDP layer)?
>               Should I check the correlation between these
> two addresses?
>
>    Thanks in advance,
>       Bentov Kohava
>       S/W Development
>       Nortel SBU
>      Telrad Networks
>      Email:[email-masked]
>

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 9 Aug 2000 09:33:51 -0400

"Rosen, Brian" wrote:

> where the mId says it should go.

No. The response always goes back to the source (address). It's by far the
simplest for relibale transmission when you have to deal with clustering
and failover.

> The section 9 text refers to

Right, however that should always be the case.

-- Flemming

--
Flemming Andreasen                Phone: +1 732 452 1667
Cisco Systems                     Fax:   +1 240 359 5839