Subject: Re: TerminationID

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 2 Aug 2000 10:01:26 -0400

I'm not clear what problem you refer to.
A TerminationID in binary encoding is a bit string
A TerminationID in text encoding is a character string
The lengths are, of course, different.

Does that answer the question?

Brian

> -----Original Message-----
> From: Prozan, Rakefet [mailto:[email-masked]]
> Sent: Wednesday, August 02, 2000 8:16 AM
> To: [email-masked]
> Subject: TerminationID
>
>
> Hi all,
>
> In A.1 "Coding of wildcards" it is written that:"Termination
> IDs consist
> of at most
> 64 bits". ASN.1 definition of Termination ID supports this,
> but in ABNF
> the definition of Termination ID
> is:
>    TerminationID  = "ROOT" / pathNAME / "$" / "*"  .
>
> The problem is that pathNAME can consist of 64 CHARS. Can someone
> clarify this problem?
>
> many thanks in advance,
>
> --
> Rakefet Prozan,
> Team Manager, S/W Development
> Nortel SBU
> Telrad Networks
> ESN 828-3043   Email:[email-masked]
>
>
>                                        """
>                                      -(o o)-
> +---------------------------------oOO--(_)--OOo--------------+
>
>                                .oooO         Oooo.
> -------------------------------(   )---------(   )------------
>                                 \ (           ) /
>                                  \_)         (_/
>
> Have fun !!!
>

---

From: "Bentov, Kohava" <[email-masked]>
Date: Wed, 9 Aug 2000 14:08:43 +0200

Hi all,

   Please, help me to understand the following two issues:

   1. The Binary and the Text encoding differ in some of the definitions.
Thus, the User
       of  the 'Megaco Stack' should know the message format of each message
it sends. At first
       we thought that this information is relevant just to the Stack itself
and it is hidden from the user
       (MGC or MG). But now, if some of the definitions are not the same
(for example,  TerminationID),
       the API procedures (between the User and the 'Megaco Stack') in some
cases will be doubled: one for
       the Text format and one for the Binary.
       The user has to use the right API procedures according to the
encoding format. .
       Am I right ?????

    2. In section 9 the following is written:
         ' ...but responses must always be sent back to the address which
was the source of the
         corresponding request.'.
         My question is:
             To which IP address should  I send the response: the address
mentioned in the mId field
              in the header of the message, or, to the Source Address of
message (from the TCP or
              UDP layer)?
              Should I check the correlation between these two addresses?

   Thanks in advance,
      Bentov Kohava
      S/W Development
      Nortel SBU
     Telrad Networks
     Email:[email-masked]