Subject: Package descriptor for ROOT.

From: Madhu Babu <[email-masked]>
Date: Tue, 1 Aug 2000 17:56:23 +0530

MGC if intends to "audit" packages supported by MG on ROOT, does
the response from MG indicates the packages supported on ROOT
termination or "UNION" of packages supported on different
terminations in MG?
-Madhubabu

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 1 Aug 2000 09:42:22 -0400

Audit of packages on Root returns all packages implemented on
the union of all termination -- it is the way you find out
what possible packages the MG implements.  Possibly additional
words needed.

Brian

> -----Original Message-----
> From: Madhu Babu [mailto:[email-masked]]
> Sent: Tuesday, August 01, 2000 8:26 AM
> To: [email-masked]
> Subject: Package descriptor for ROOT.
>
>

---

From: Madhu Babu <[email-masked]>
Date: Tue, 1 Aug 2000 19:18:50 +0530

If Audit on ROOT returns all packages, how can MGC know that out of these which
are actually valid for
ROOT termination. This means that there is no mechanism to audit packages
actually realized by ROOT
and MGC assumes that based on the agreed profile. I don't see any benefit in
getting a union of all packageIDs
because the MGC has to anyhow audit the termination types to find which of these
are implemented on physical
and which on ephemeral
I suggest that we should include the termination name schema auditing mechanism
first introduced in v14 in base
root package to audit the capabilities of termination type.

"Rosen, Brian" <[email-masked]> on 08/01/2000 07:12:22 PM

Please respond to "Rosen, Brian" <[email-masked]>

To:   [email-masked]
cc:    (bcc: Madhu B Babu/HSS)

Subject:  Re: Package descriptor for ROOT.

Brian

---

From: Madhu Babu <[email-masked]>
Date: Thu, 3 Aug 2000 15:11:05 +0530

Packages descriptor specifies the list of packages realized by a given
termination.  But if UNION of packages are used is it logical to say that
packages like RTP,etc are realized by ROOT termination. And the association of
packages for a given termination in no way is known by recieving a list of
packages from MG. Do you mean to say that a RTP stream can be created on ROOT
termination ??
-Madhubabu

Christian Groves <[email-masked]> on 08/02/2000 06:58:34 PM

Please respond to Christian Groves <[email-masked]>

G'Day all,

I would have thought that as the "root termination" is not really a
physical termination but relates to the MG as a whole that it would also
support all the packages in a MG. ie. if you added a package to a
termination you'd add it to the root termination. So I still support
Brian's response. In effect you would get the union.

Cheers, Christian

Flemming Andreasen wrote:
>
>
>
> Tom-PT Taylor wrote:
>
> >
> >
> > The resolution of this question in the past (e.g. in Oslo) was that
> > an audit of packages on ROOT only reveals those packages supported
> > by the ROOT termination.
>
> Contrary to Brian's response, that was my expectation as well, not
> least considering the following text in Section 6.2.5 (root
> termination):
>
> "* an AuditValue return - to examine the values of properties and
> statistics implemented on root"
>
>
> -- Flemming
>
>
> >
>
> > As far as I am concerned, the ultimate answer to the "auditing of
> > ephemerals" question will be to define packages with ROOT
> > termination properties which indicate the capability of the MG to
> > support specific types of termination.  These package properties
> > could include naming patterns, interface identifiers (e.g. IPv4 or
> > IPv6 addresses), and relevanr resource limits.  Since I believe
> > this, perhaps I should be the one to draw up first drafts of the
> > packages I have in mind.
> >
> >      From:  Madhu Babu [SMTP:[email-masked]]
> --
> Flemming Andreasen                Phone: +1 732 452 1667
> Cisco Systems                     Fax:   +1 240 359 5839
>