Subject: Clarification on Endpoint Identifier in RQNT

From: Arun Kumar S <[email-masked]>
Date: Mon, 7 Aug 2000 13:04:18 +0530

Hi,

        I wanted a clarification on the endpoint identifier naming conventions for
        the RQNT message.

        To quote from rfc2705,

        "EndpointId is the name for the endpoint in the gateway where
        NotificationRequest executes, as defined in section 2.1.1."

        The rfc does not specify the whether the endpoint id can be under-specified
        using the "any of" or "all" wildcard naming convention.
        - Is it possible for the endpoint id to be under-specified?
        - If so, can both the wild-cards (any of / all) be used within the endpoint
id
          of RQNT?

Regards,
___________________________________________________
Arun Kumar S
ishoni Networks (India) Pvt Ltd (http://www.ishoni.com)
...Broadband for everyone
email: [email-masked]
Phone: +91-80-2292125 (Work)
Fax: +91-80-2995545 (Work)

---

From: Flemming Andreasen <[email-masked]>
Date: Mon, 7 Aug 2000 14:18:15 -0400

>         - If so, can both the wild-cards (any of / all) be used within the endpoint

The "all of" wildcard can definitely be used. It makes little sense to use the "any of"
wildcard here, however the spec is unfortunately silent on this. If you are developing
a gw, I would encourage you to accept requests using "any of" wildcards, but if you are
developing a Call Agent I would strongly discourage such use (the 2705 update may in
fact disallow it).

For future reference, you might want to send MGCP questions to "[email-masked]"
instead.

Regards.

        Flemming

--
Flemming Andreasen                Phone: +1 732 452 1667
Cisco Systems                     Fax:   +1 240 359 5839

---

From: Nitin Kumar <[email-masked]>
Date: Mon, 7 Aug 2000 15:44:16 -0500

I think MGCP should strictly disallow "any of" wildcard in RQNT, because on
what basis MG can decode "any of" wildcarded RQNT. In that case MG has no
other option but to decode "any of" wildcard as "all of" to be on safer
side.

For NotificationRequest we should have similar clarity as we have for
EndPointConfiguration request.

See following extract from MGCP rfc2705...

"EndpointId is the name for the endpoint in the gateway where
   EndpointConfiguration executes, as defined in section 2.1.1.  The
   "any of" wildcard convention shall not be used.  If the "all of"
   wildcard convention is used, the command applies to all the endpoint
   whose name matches the wildcard."

Regards

nitin

 -----Original Message-----
From:   [email-masked]
[mailto:[email-masked]]  On Behalf Of Flemming
Andreasen
Sent:   Monday, August 07, 2000 1:18 PM
To:     [email-masked]
Cc:     [email-masked]; [email-masked]
Subject:        [MGCP]: Re: Clarification on Endpoint Identifier in RQNT

>         - If so, can both the wild-cards (any of / all) be used within the
endpoint

The "all of" wildcard can definitely be used. It makes little sense to use
the "any of"
wildcard here, however the spec is unfortunately silent on this. If you are
developing
a gw, I would encourage you to accept requests using "any of" wildcards, but
if you are
developing a Call Agent I would strongly discourage such use (the 2705
update may in
fact disallow it).

For future reference, you might want to send MGCP questions to
"[email-masked]"
instead.

Regards.

        Flemming

---

From: Flemming Andreasen <[email-masked]>
Date: Mon, 7 Aug 2000 16:52:04 -0400

Nitin Kumar wrote:

> I think MGCP should strictly disallow "any of" wildcard in RQNT,

I agree that would be very reasonable, however it's not spec'ed that way in 2705
currently.

> because on

That you certainly should *not* do.

>    whose name matches the wildcard."

Right - we should add that to the 2705 update unless somebody thinks otherwise.

-- Flemming