Subject: Re: Supplying only a port on a ServiceChangeAddress

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 29 Aug 2000 18:37:32 -0400

I think the issue is that you can have the same MGC have multiple
IP addresses.  You accept the association, but change the address.
Say, a pool of servers appearing to be one MGC.

Brian

> -----Original Message-----
> From: Flemming Andreasen [mailto:[email-masked]]
> Sent: Tuesday, August 29, 2000 6:38 PM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: Re: Supplying only a port on a ServiceChangeAddress
>
>
>
>
> "Rosen, Brian" wrote:
>
> > Suppose all you want to specify in a ServiceChangeAddress
> is a port number
> > that is, the IP address doesn't change, but the port does.
> >
> > The ABNF sez:
> > serviceChangeAddress = ServiceChangeAddressToken EQUAL VALUE
> >
> > This is because it could be IP, ATM, FR, MPLS....
> >
> > The example shows just a port number.
>
> Actually, I thought that's all that would be allowed in the
> case of IP. If
> not, how can it be within the "context of the association
> currently being
> negotiated", and how would it then relate to ServiceChangeMgcId ?
>
> -- Flemming
>
> >
> >
> > Should that be legal?  Should you have to specify the IP address
> > as x.x.x.x:p?
> >
> > Brian
>
> --
> Flemming Andreasen
> Cisco Systems
>
>

---

From: Flemming Andreasen <[email-masked]>
Date: Tue, 29 Aug 2000 19:36:46 -0400

> Say, a pool of servers appearing to be one MGC.

I'm not sure I fully understand what an association is then. What's the
difference/relationship between the association address and the
ServiceChangeMgcId (which may itself contain an address or indirectly
refer to a number of addresses through DNS) ?

-- Flemming

--
Flemming Andreasen
Cisco Systems