Subject: Re: Statistics when you delete a stream

From: Kushanava Laha <[email-masked]>
Date: Thu, 31 Aug 2000 17:43:33 +0530

G'day Brian, Christian
     I second Christian's opinion. However Brian's last sentence deserves
some more clarification.

>>"You can always get the statistics by specifying Audit of
>> Statistics on the deletion of the stream."

     I assume the intention was that "by specifying Audit of statistics
you shall get the cumulative statistics for all streams on the termination,
irrespective of whether they had been deleted recently or in the past along
with those that are still alive".

regards,
Kushanava Laha

---------------------- Forwarded by Kushanava Laha/HSS on 08/31/2000 05:39 PM
---------------------------

Christian Groves <[email-masked]> on 08/31/2000 06:07:05 AM

Please respond to Christian Groves <[email-masked]>

To:   [email-masked]
cc:    (bcc: Kushanava Laha/HSS)

Subject:  Re: Statistics when you delete a stream

G'Day Brian,

Your interpretation seems correct to me and consistent with what's in
the protocol today.

Cheers, Christian

"Rosen, Brian" wrote:
>
> The way the protocol is defined now, if you were to create a stream
> on a termination, run some media, delete the stream, and then
> re-establish the stream (maybe to another IP address), you would
> not get statistics automatically on the delete of the stream.
> As defined now, statistics are only generated automatically when
> a Subtract is done on the termination.
>
> Do list members think that this behavior is correct?  Or should
> statistics be generated if a stream is deleted?
>
> I personally think the current spec is correct, because the
> statistics are kept on the TERMINATION and not the STREAM.
> You can always get the statistics by specifying Audit of
> Statistics on the deletion of the stream.
>
> Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 31 Aug 2000 15:47:48 -0400

Yep, that's what I meant.

Brian

-----Original Message-----
From: Kushanava Laha
To: [email-masked]
Sent: 8/31/00 8:13 AM
Subject: Re: Statistics when you delete a stream

G'day Brian, Christian
     I second Christian's opinion. However Brian's last sentence
deserves
some more clarification.

     I assume the intention was that "by specifying Audit of statistics
you shall get the cumulative statistics for all streams on the
termination,
irrespective of whether they had been deleted recently or in the past
along
with those that are still alive".

regards,
Kushanava Laha

---------------------- Forwarded by Kushanava Laha/HSS on 08/31/2000
05:39 PM
---------------------------

Christian Groves <[email-masked]> on 08/31/2000 06:07:05
AM

G'Day Brian,

Cheers, Christian