Subject: transactionResponseAck ?

From: "Bentov, Kohava" <[email-masked]>
Date: Tue, 22 Aug 2000 13:31:13 +0200

Hi all,

    In Appendix A (the call flow Example), there are no transactionResponseAck  messages between the MGC  
    and its MGs. 
    Is the transactionResponseAck optional ?

    In section B.2 (ABNF specification) the following is written:

---------------------------------------
    transactionList = 1*( transactionRequest / transactionReply / 
                                 transactionPending / transactionResponseAck )
  ;Use of response acks is dependent on underlying transport

---------------------------------------

    Regarding the remark: 
                     Does it mean that we'll use transactionResponseAck when the transport layer 
                     is UDP and we'll not send/receive transactionResponseAck when the transport layer is TCP ?

                     If not, what does it mean ?

  Thanks in advance,
       Bentov Kohava
       S/W Development
       Telrad Networks
        E-mail:  [email-masked]

---

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 22 Aug 2000 14:12:35 -0400

TransactionResponseAck is used only with UDP/ALF.  See Annex D.1.

-----Original Message-----
From: Bentov, Kohava [Partner:LOD:Telrad]
Sent: Tuesday, August 22, 2000 7:31 AM
To: [email-masked]
Subject: transactionResponseAck ?

Hi all,

    In Appendix A (the call flow Example), there are no
transactionResponseAck  messages between the MGC
    and its MGs.
    Is the transactionResponseAck optional ?

---------------------------------------
    transactionList = 1*( transactionRequest / transactionReply /
                                 transactionPending / transactionResponseAck
)
  ;Use of response acks is dependent on underlying transport

    Regarding the remark:
                     Does it mean that we'll use transactionResponseAck when
the transport layer
                     is UDP and we'll not send/receive
transactionResponseAck when the transport layer is TCP ?

  Thanks in advance,
       Bentov Kohava
       S/W Development
       Telrad Networks
        E-mail:  [email-masked] <mailto:Email:
[email-masked]>

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 22 Aug 2000 20:28:24 -0400

transactionResponseAck would be used if the transport required it.  For
example, UDP would need it.
A reliable transport, such as TCP, would not require it.

I'd suggest that, as with most IETF protocols, all implementations should
accept transactionResponseAck
regardless of what transport is used.  Thus be conservative in what you
send, liberal in what you accept.

Brian

-----Original Message-----
From: Bentov, Kohava [mailto:[email-masked]]
Sent: Tuesday, August 22, 2000 7:31 AM
To: [email-masked]
Subject: transactionResponseAck ?

Hi all,

    Regarding the remark:

  Thanks in advance,
       Bentov Kohava
       S/W Development
       Telrad Networks