Subject: About mixing and topology

From: Junyoung Heo <[email-masked]>
Date: Fri, 4 Aug 2000 14:19:02 +0900

I have just read megaco draft documnet.
I will use megaco as protocol between MC and MP.

I choose megaco because its topology property.
But, I can't find how to describe topology to enable mixing among terminations' data.

How can I make it?

Regards,

Junyoung Heo
2000/08/04
KOREA

---

From: "Rosen, Brian" <[email-masked]>
Date: Sat, 5 Aug 2000 18:06:51 -0400

At "star" connection is "everyone hears everyone else", so the
default topology illustrates that connection; T1 hears T2 and T3,
T2 hears T1 and T3, T3 hears T1 and T2.

If your video mixer has an equivalent function, then the topology
descriptor will be perfect for your application.  If the mixer
has some other behavior (say, quadrants, with four inputs sent to
all parties identically), the current text does not define how
you would use Topology.

Brian
-----Original Message-----
From: Junyoung Heo
To: [email-masked]
Sent: 8/4/00 11:06 PM
Subject: Re: About mixing and topology

Thanks for answer, but I need more help.

draft-ietf-megaco-merged-01.txt page 39
shows when no topology descriptor.
      T1
   /      \
T2 ---- T3
Can I think it is a star topology?

Finally, I need "everyone SEEs ANYone else".
 So, I want to control whose video is mixed.
 How to use [T1, T2, association] form for my purpose?

Sorry for my ugly english. I'm poor at writing English. --;;

Best regards.

----- Original Message -----
From: "Rosen, Brian" <[email-masked]>
To: "'Junyoung Heo'" <[email-masked]>;
<[email-masked]>
Sent: Friday, August 04, 2000 10:49 PM
Subject: RE: About mixing and topology

> I cannot completely understand your question.
>
> The text describes how you use TOPOLOGY to control a device that uses
> a "star" topology mixer.  So I think the text is clear on how you
enable
> mixing among terminations data when the mixer is a "everyone hears
everyone
> else"
> type of mix.
>
> What the text is not clear on is how you use topology when the mixer
is
> not a "star".  That is a known limitation, which was agreed to be
deferred
> to
> a later edition.
>
> Brian
>
>
> -----Original Message-----
> From: Junyoung Heo [mailto:[email-masked]]
> Sent: Friday, August 04, 2000 1:19 AM
> To: [email-masked]
> Subject: About mixing and topology
>
>