Subject: Re: Media without Stream

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 29 Aug 2000 19:21:32 -0500

This is the optimized syntax for single stream (e.g. voice-only) operation.
It has been there ever since we invented streams, since one of the
constraints on handling of multimedia was that it not discommode
straightforward VoIP operation.

> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Tuesday, August 29, 2000 7:46 PM
> To: [email-masked]
> Subject: Media without Stream
>
>
> It may come as a surprise to some of you, as it did to me, that you
> can say:
>
> Media=termId{Local....
>
> you don't have to say
> Media=termId{Stream=1{Local...
>
> ABNF clearly allows this.  We have an MGC implementation that
> did this,
> and an MG that got confused.
>
> Brian
>

---

From: Christian Groves <[email-masked]>
Date: Thu, 31 Aug 2000 11:30:09 +1100

Yes, I agree Tom I thought it was covered in 7.1.4:
As a convenience a LocalControl, Local, or Remote descriptor may be
included in the Media Descriptor without an enclosing Stream
descriptor.  In this case, the StreamID is assumed to be 1.

Cheers, Christian