Subject: Re: Is Media required on the Physical Termination/Default value f or M ODE

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 29 Aug 2000 16:30:27 -0400

Okay, so what would you expect to happen if you audited media of
the physical termination.  Even if there was no default, it should
be one of the legal states.

Now, suppose it's in an acceptable state, should you have to send
a media descriptor?

What the folks who implemented the MG requiring the media descriptor
say is that "there is no mode, you haven't set it".  I can't deal
with that, because audit has to return a value.  So it has to be
something, and the MGC should be able to leave it, right?

Now, I said I think MGCs should always send media!

Brian

> -----Original Message-----
> From: Michael Thomas [mailto:[email-masked]]
> Sent: Tuesday, August 29, 2000 4:25 PM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: Is Media required on the Physical
> Termination/Default value for
> M ODE
>
>
>
> My general take has been that the MGC shouldn't
> assume much about the MG. If it wants the MG to
> do something, it should tell it. If it doesn't
> know the MG's state, it should audit it.
> Therefore, I think I disagree with the spec
> requiring some set of semantics for underspecified
> commands. What's the gain?
>
>               Mike
>
> Rosen, Brian writes:
>  > Another issue from the event:
>  >
>  > Is it REQUIRED that the MGC send a media descriptor to a PHYSICAL
>  > termination in order to get media to flow?
>  >
>  > There are two questions actually:
>  > 1) Is there a default state of MODE (text is silent)
>  > 2) Should the MG demand a media descriptor before allowing
> media flow?
>  >
>  > I believe:
>  > 1) The default for MODE is SendRecieve
>  > 2) MGCs should always send a media descriptor, with at least a MODE
>  > setting
>  > 3) MGs should not depend on 2)
>  >
>  > Brian
>  >
>

---

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 29 Aug 2000 16:00:42 -0500

I tend to agree with Mike.  Moreover, painful as it may be in the case of
digital circuit terminations to see all that duplication of information in
both Local and Remote, we should be sticking codec specifications into those
descriptors when TDM is involved.

I've just been looking at temptation in this regard while designing packages
for NAS operation.  One of the required packages conveys signalled bearer
capability to the TDM circuit termination.  I think that has to go into
Local and Remote, which means I need a TDM update for SDP.  I can use the
ATMSDP document as a starting point, but TDM should be a lot simpler.

> From: Michael Thomas [mailto:[email-masked]]
> To: [email-masked]

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 29 Aug 2000 17:07:21 -0400

That's an acceptable default, which almost forces the MGC to set it to
something
else in order to get media to flow.

Brian

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Tuesday, August 29, 2000 4:57 PM
To: Rosen, Brian; [email-masked]
Subject: RE: Is Media required on the Physical Termination/Default value f
or M ODE

Sorry, Brian, the natural default is "inactive".  It does seem that we
failed to specify the defaults in 7.1.7, even though section 6.2.4 promises
that we would.

> From: Rosen, Brian [ mailto:[email-masked]
<mailto:[email-masked]> ]
> Sent: Tuesday, August 29, 2000 4:30 PM
> Subject: Re: Is Media required on the Physical
> Termination/Default value
> f or M ODE
>
>
> > From: Michael Thomas [ mailto:[email-masked] <mailto:[email-masked]> ]