Subject: Re: DTMF Events

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 30 Aug 2000 12:17:55 -0500

That wasn't really clear.  I meant to add that if the digit map is active
but it hasn't completed, individual digits are absorbed and not reported.

> -----Original Message-----
> From: Taylor, Tom-PT [NORSE:B901:EXCH]
> Sent: Wednesday, August 30, 2000 1:05 PM
> To: [email-masked]
> Subject: Re: DTMF Events
>
>
> To be clear on this, EITHER you get a digit map completion
> event (if a digit
> map was active and it completed) OR you get the individual digit event
> (otherwise).
>
> > -----Original Message-----
> > From: Rosen, Brian [mailto:[email-masked]]
> > Sent: Wednesday, August 30, 2000 12:55 PM
> > To: [email-masked]
> > Subject: DTMF Events
> >
> >
> > The wording in Section E.6.2, DTMF detect is ambiguous and has
> > led to an incompatibility.  The intention of the section on DTMF
> > digits was that a set of events was defined, d0-d9, da-df,...
> > Each of these events can be used in an event descriptor.  The
> > events have no parameters.  When detected, these events trigger
> > a notify.  So if d0 is mentioned in an event descriptor,
> > and no digitMap is mentioned, and DTMF0 is detected, the event
> > d0 is notified, with no parameters.
> >
> > One implementer assumed that when you set the d0... event,
> > you still got the digitmap completion event notify, with a one digit
> > string.  This is not the intention.
> >
> >
> > Brian
> >
>

---

From: Christian Groves <[email-masked]>
Date: Thu, 31 Aug 2000 11:31:31 +1100

G'Day Tom and Brian,

Do you have some proposed text for the Implementor's Guide?

Cheers, Christian