Subject: Re: MG and DiffServ

From: S KA N <[email-masked]>
Date: Mon, 14 Aug 2000 09:38:57 -0700

Hi Mike,

Thanks for your reply. I have the following point.

If a VoIP vendor implements all the functionality
required by ICF, then it will be possible to have
close integration of the VoIP devices with the IP
network. Take an example of MPLS itself. Here if
the MG device itself has MPLS functionality builtin,
the granualarity in policy enforcement (FEC
implementation) will be more.

Any comment?

>>>SKAN<<<

> You really need to sort out roles and
> responsibilities before you can answer
> these questions.
>
> In the general case you have to make a distinction
> between the VoIP service
> provider and IP network operator.  Of course they
> may be one and the same
> but this assumption will not provide a general
> solution.
>
> The MG is a service provider function, it is linked
> to IP telephony or some
> other application - as such it is likely to be owned
> by the IP telephony
> service provider.  The IP transport network on the
> other hand is likely to
> be general purpose and will be carrying traffic of
> different types and from
> different sources.
>
> So where do Diff Serv and RSVP/IntServ fit in?  I
> would submit that these
> are part of the IP transport network, are
> application independent, and under
> the control of the IP network operator.
> So in the general case they are really nothing to do
> with the MG which is
> the territory of the IP telephony service provider.
>
> Between the MG and the IP network must be some form
> of border element which
> is owned by the IP network operator.  This is the
> device that will terminate
> RSVP or Diff Serv as far as the network operator is
> concerned.  This device
> will also provide policy enforcement ON BEHALF OF
> THE NETWORK OPERATOR.   In
> the TIPHON architecture this device is called an
> interconnect Function
> (ICF).
>
> RSVP or Diff Serv could of course be extended beyond
> the domain of the IP
> Network Operator.  This must be by service level
> agreements, however, and
> these must address issues of  security,
> policy enforcement and network addressing.  TIPHON
> has chosen to regard the
> situation of end to end homogeneity as a special
> case.  The general case is
> where the transport domain mechanisms terminate at
> the ICFs on the boundary
> of the IP network operators domain of control.  This
> model allows end to end
> QoS solutions where the media pass through IP
> domians with different QoS
> mechanisms, policies and address spaces (NATs may be
> part of the ICFs).
>
> So Diff Serv and other mechanisms could terminate in
> the MG but this would
> require agreements between the network operator and
> service provider.
> Policy Enforcement, NAT and security would also need
> to be covered by such
> agreements if a network operator was to pass these
> roles on to a third
> party.
>
>
> Mike Buckley
> +44-1457-877718 (T)
> +44-1457-877721 (F)
> [email-masked]
>
>
> ----- Original Message -----
> From: "S KA N" <[email-masked]>
> To: <[email-masked]>
> Sent: Saturday, August 12, 2000 9:02 PM
> Subject: Re: MG and DiffServ
>
>
> Hi All,
>
> > >Can you think of any relation between the MG and
> > >DiffServ?
> > >
> > >If a privately managed IP network is DiffServ
> > >compliant and suppose if the same network
> > >is going to be used for VoIP purposes also. Don't
> > >we require the MGs to be DiffServ compliant?
> >
> > Most MG's are already diffserv or TOS compliant.
> In
> > any case you can't require a vendor to build
> > something unless you plan to give them a lot of
> > money.
>
> I am still in the same loop. Let me go one more
> level
> down this time. How would I consider an MG to be
> QoS (e.g. diffserv, mpls, rsvp) compliant? Is it
> not possible that first make the MG w/o QoS support
> and then later at the time of selling it to a
> customer
> put a QoS compliant layer-3 device such as an MPLS
> router with diffserv, etc, with it. In this case,
> would
> it still be considered QoS compliant?
>
> Request you to comment on this.
>
> >>>SKAN<<<
>
>
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Mail - Free email you can access from
> anywhere!
> http://mail.yahoo.com/
>
>

__________________________________________________
Do You Yahoo!?
Yahoo! Mail – Free email you can access from anywhere!
http://mail.yahoo.com/

---

From: Mike Buckley <[email-masked]>
Date: Mon, 14 Aug 2000 18:16:10 +0100

Hi Skan,

The key issue as I see it is who owns the ICF and who is enforcing the
policies.  I would think that generally the ICF that implements MPLS and
policy enforcement will be owned by the operator of the IP network not the
VoIP service provider.  In this situation it would be outside the MG which
is a service provider function.

Mike

Mike Buckley
+44-1457-877718 (T)
+44-1457-877721 (F)
[email-masked]

----- Original Message -----
From: "S KA N" <[email-masked]>
To: "Mike Buckley" <[email-masked]>; "S KA N" <[email-masked]>;
<[email-masked]>
Sent: Monday, August 14, 2000 5:38 PM
Subject: Re: MG and DiffServ

> Yahoo! Mail - Free email you can access from anywhere!
> http://mail.yahoo.com/
>