Subject: Re: Is Media required on the Physical Termination/Default value f or M ODE

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 29 Aug 2000 16:57:18 -0400

Sorry, Brian, the natural default is "inactive".  It does seem that we
failed to specify the defaults in 7.1.7, even though section 6.2.4 promises
that we would.

> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Tuesday, August 29, 2000 4:30 PM
> To: [email-masked]
> Subject: Re: Is Media required on the Physical
> Termination/Default value
> f or M ODE
>
>
> Okay, so what would you expect to happen if you audited media of
> the physical termination.  Even if there was no default, it should
> be one of the legal states.
>
> Now, suppose it's in an acceptable state, should you have to send
> a media descriptor?
>
> What the folks who implemented the MG requiring the media descriptor
> say is that "there is no mode, you haven't set it".  I can't deal
> with that, because audit has to return a value.  So it has to be
> something, and the MGC should be able to leave it, right?
>
> Now, I said I think MGCs should always send media!
>
> Brian
>
>
>
> > -----Original Message-----
> > From: Michael Thomas [mailto:[email-masked]]
> > Sent: Tuesday, August 29, 2000 4:25 PM
> > To: Rosen, Brian
> > Cc: [email-masked]
> > Subject: Is Media required on the Physical
> > Termination/Default value for
> > M ODE
> >
> >
> >
> > My general take has been that the MGC shouldn't
> > assume much about the MG. If it wants the MG to
> > do something, it should tell it. If it doesn't
> > know the MG's state, it should audit it.
> > Therefore, I think I disagree with the spec
> > requiring some set of semantics for underspecified
> > commands. What's the gain?
> >
> >               Mike
> >
> > Rosen, Brian writes:
> >  > Another issue from the event:
> >  >
> >  > Is it REQUIRED that the MGC send a media descriptor to a PHYSICAL
> >  > termination in order to get media to flow?
> >  >
> >  > There are two questions actually:
> >  > 1) Is there a default state of MODE (text is silent)
> >  > 2) Should the MG demand a media descriptor before allowing
> > media flow?
> >  >
> >  > I believe:
> >  > 1) The default for MODE is SendRecieve
> >  > 2) MGCs should always send a media descriptor, with at
> least a MODE
> >  > setting
> >  > 3) MGs should not depend on 2)
> >  >
> >  > Brian
> >  >
> >
>

---

From: Christian Groves <[email-masked]>
Date: Thu, 31 Aug 2000 11:19:25 +1100

G'Day all,

I would have thought that the default was inactive for a termination and
that the stream mode would be off unless otherwise provisioned in the
MG. If a MGC wanted media to flows then it could set the mode to
send/receive when it did the ADD. I think its important to let the MGC
decide when it wants the cut through to occur on terminations ie. s/r on
both terminations.

Cheers, Christian