Subject: Re: Supplying only a port on a ServiceChangeAddress

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 29 Aug 2000 18:51:45 -0400

I have some sympathy with this sentiment.
I'm not too happy with VALUE as an address, even if I
understand it.

Other opinions?

Brian

> -----Original Message-----
> From: Naren Tulpule [mailto:[email-masked]]
> Sent: Tuesday, August 29, 2000 6:41 PM
> To: Rosen, Brian; [email-masked]
> Subject: RE: Supplying only a port on a ServiceChangeAddress
>
>
> Hi Brian, List,
>   people had posed this question (what the format of
> ServiceChangeAddress
> should be) earlier on the list. The answer you gave was
> "The address has to make sense in the domain of the transport
> mechanism. I'm
> not too fond of overspecifying this kind of thing, because it requires
> changes when you allow additional transports."
> I agree with this, upto a point. (e.g. in the case you
> mention below, "port
> number only" should be allowed because it does make sense).
>
> In ABNF ServiceChangeAddress  is specified as VALUE (=
> 1*(Safe character) /
> quotedString). This is useless unless you have enough
> contextual information
> to contact the new address. Flemming's response quotes the
> text ("in the
> context of the current association being negotiated") but
> that can mean
> several things. Why should the parser assume IP transport,
> for example, and
> interprete the number as a port number?
>
> Instead, can we make ServiceChangeAddress  = MID and allow
> port number in
> MID (along with any new transports that may come up). Or it
> can be "MID or
> port number" if you don't want to extend MID. I think it's
> better to extend
> the ABNF for ServiceChangeAddress  later as and when new
> transports are
> added; rather than make it so generalized right now that you
> can't even
> parse it without having additional information about the
> transport from
> somewhere outside the parser.
>
> -- Naren.
> Narendra C. Tulpule    SMTS, Trillium Digital Systems
> Ph: +1-310-442-9222              Fax: +1-310-442-1162
> 12100 Wilshire Bl #1800         Los Angeles, CA 90025
>
>
> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Tuesday, August 29, 2000 3:04 PM
> To: [email-masked]
> Subject: Supplying only a port on a ServiceChangeAddress
>
>
> Suppose all you want to specify in a ServiceChangeAddress is
> a port number
> that is, the IP address doesn't change, but the port does.
>
> The ABNF sez:
> serviceChangeAddress = ServiceChangeAddressToken EQUAL VALUE
>
> This is because it could be IP, ATM, FR, MPLS....
>
> The example shows just a port number.
>
> Should that be legal?  Should you have to specify the IP address
> as x.x.x.x:p?
>
> Brian
>

---

From: Flemming Andreasen <[email-masked]>
Date: Tue, 29 Aug 2000 19:42:44 -0400

> I'm not too happy with VALUE as an address, even if I

I agree. As part of that change, may I suggest we get rid of any duality
between ServiceChangeAddress and ServiceChangeMgcId as well.

-- Flemming

--
Flemming Andreasen
Cisco Systems