Subject: Query on the port numbers used

From: [email-masked]
Date: Fri, 4 Aug 2000 09:53:42 +0530

Hello,
     Section 9 of draft-ietf-megaco-merged-01.txt specifies that port
number 2944 should be the default port used for text encoding and 2945
should be default port for binary-encoding. It later says that these port
numbers may be changed using the ServiceChangeAddress.

     On specifying different port numbers, do we have to maintain
the same strategy of having different port numbers for text-encoding and
binary-encoding or can the same port be used for both text and binary
encoding. MGC shall identify whether to decode the text encoded data or
binary encoded data based on the local+remote port and IP address pair.

                                   Regards,
                                   R. Ezhirpavai

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 4 Aug 2000 09:45:26 -0400

When the MG contacts the MGC, it will encode the message in one way.
It will send a message, encoded in that way, to the correct port.
The MGC would then know what encoding the MG wanted to use.
If it wanted to move the association to a different port, it would
do so with the reply.  The encoding would be what the MG started with.

Thus there is no need to have different text/binary port numbers in
ServiceChange.

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, August 04, 2000 12:24 AM
> To: [email-masked]
> Subject: Query on the port numbers used
>
>
> Hello,