Subject: Re: About creating contextID and terimnationID

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 28 Aug 2000 13:24:18 -0400

No, the MG creates Contexts, and their IDs, as well as all TerminationIds
(both
physical and ephemeral).  It is not possible for the MGC to create
contextIds or
terminationIds.
 
Brian

-----Original Message-----
From: Junyoung Heo [mailto:[email-masked]]
Sent: Monday, August 28, 2000 4:48 AM
To: [email-masked]
Subject: About creating contextID and terimnationID

Hi.
 
It can be allowed that MGC creates contextID/terminationID 
and sends ADD command with them(new IDs) to MG.
 
I'm sorry, if similiar question is already answered.
 
Thanks for reading.
 
==============================
허준영(Junyoung Heo)
R&D center of NadaTel Co.,Ltd. Korea
Tel : +82-2-596-3941
Fax : +82-2-596-3626
Email : [email-masked] <mailto:[email-masked]>

---

From: John Segers <[email-masked]>
Date: Wed, 30 Aug 2000 14:26:07 +0200

Brian,

It just so happens that I looked at section 7.2.1 (Add) and found the
following text:

> The TerminationID specifies the termination to be added to the Context.
> The Termination is either created, or taken from the null Context.
> For an existing Termination, the TerminationID would be specific.
> For a Termination that does not yet exist, the TerminationID is
> specified as CHOOSE  in the command. The new TerminationID will be
> returned.

This text is not particularly clear, but seems to say that specific
physical Terminations are designated in Add commands, while CHOOSE must
be used for ephemerals.

In my opinion we shouldn't have this restriction in the protocol: in
some situations you may want to have the MG select a termination
(outgoing circuit within a trunk), in some you have to specify the
termination (access GW with subscriber lines).

It may make sense to have profiles impose such restrictions.

Cheers,

John

Brian Rosen wrote:
> No, the MG creates Contexts, and their IDs, as well as all TerminationIds (both
> physical and ephemeral).  It is not possible for the MGC to create contextIds or
> terminationIds.
>
> Brian

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 303
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954