Subject: megaco NAS package

From: Ravi Subramaniam <[email-masked]>
Date: Mon, 7 Aug 2000 11:55:09 -0400

Hello Tom...
    I have a prelimnary nas package which I build on top of the existing one,
    please take a look at it. I am working on making it IETF compliant
    right now, so alignments etc. may be off.
Thanks ...
Ravi Subramaniam
IOS-Wan Connectivity Products
Cisco Systems

---

From: ³s«Û©v <[email-masked]>
Date: Wed, 9 Aug 2000 15:59:26 +0800

There is an example call flow in Annex A of MEGACO protocol. I traced the
call flow. Here I have one issue in step 3 of the section A.1.1. The Step 3
of Section A.1.1 is copied in following:

3. The MGC programs a Termination in the NULL context. The terminationId is
A4444, the streamId is 1, the requestId in the Events descriptor is 2222.
The   mId is the identifier of the sender of this message, in this case, it
is the IP address and port [123.123.123.4]:55555. Mode for this stream is
set to SendReceive. "al" is the analog line supervision package.
MGC to MG1:
MEGACO/1 [123.123.123.4]:55555
Transaction = 9999 {
    Context = - {
        Modify = A4444 {
            Media { Stream = 1

                     LocalControl {
                         Mode = SendReceive,
                         ds0/gain=2,  ; in dB,
                         ds0/ec=G165
                     },
                     Local {
v=0
c=IN IP4 $
m=audio $ RTP/AVP 0
a=fmtp:PCMU VAD=X-NNVAD ; special voice activity
                        ; detection algorithm
                     }
                 }
            },
            Events = 2222 {al/of}
        }
    }
}

My Issue is:
    Termination A444 is an analog line termination. Why does it has the
Local Descriptor which describe the IP termination properties such "c=IN IP4
$", "m= audio $ RTP/AVP 0"....?