Subject: Re: Repeated Modify

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 29 Aug 2000 18:35:37 -0400

This would be a new transactionId, but the same command.

I conclude that we agree on what happens - you execute the command,
which may not cause any state change on the MG.

Brian

> -----Original Message-----
> From: Flemming Andreasen [mailto:[email-masked]]
> Sent: Tuesday, August 29, 2000 6:28 PM
> To: [email-masked]
> Subject: Re: Repeated Modify
>
>
> I'm not sure I understand this question. If you resend a command with
> the same transaction-id, etc. it's a duplicate that will
> (hopefully) not
> get executed again. If you send a command with another transaction-id
> than previously, it's a new command and it will be carried
> out as such.
> That may or may not lead to a change on the MG.
>
>
>
> "Rosen, Brian" wrote:
>
> > If you repeat a modify, what happens?
> >
> > I'd think that other than subtract or add, it's a NOP.
> > Add/Subtract is an error.
> >
> > The specific command set MODE to the same value it was.
> > Might unnecessarily consume cycles, but should be legal
> > right?
>
> Sure, however it's a new command with a NOP result.
>
> -- Flemming
>
> >
> >
> > Brian
>
> --
> Flemming Andreasen
> Cisco Systems
>

---

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 29 Aug 2000 20:10:18 -0400

Seems reasonable to me.

> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Tuesday, August 29, 2000 5:56 PM
> Subject: Repeated Modify

---

From: Michael P DiGioia <[email-masked]>
Date: Tue, 29 Aug 2000 20:14:33 -0400

Brian,

>>If you repeat a modify, what happens?

This is implementation specific! I.e., Should not be specified as one
or the other. In addition, if the MG is designed to execute all
commands, someone should first check and see if any one command can
cause a problem (i.e., do something more than NOP as with ADD). How will
any one MG know apriori that it should skip any one command?

/mpd