Subject: Re: Case Sensitivity

From: Peter Blatherwick <[email-masked]>
Date: Tue, 29 Aug 2000 15:34:54 -0500

Brian, all:

Your description below is as I remember it being decided.  To me this does
not constitute change, just an editorial mishap.  At what stage did the text
go missing (just a curio)?

-- Peter

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Tuesday, August 29, 2000 11:56
To: [email-masked]
Subject: Re: Case Sensitivity

To be really careful:
        SDP is defined case sensitive, and we aren't changing that
        quoted strings are case sensitive
So, what we are really saying is that symbols are case insensitive
Symbols include protocol tokens, terminationIds, package names,
events and signals names, property names, statistics names
and enumerated values.

Brian

> -----Original Message-----
> From: Rosen, Brian
> Sent: Tuesday, August 29, 2000 11:29 AM
> To: [email-masked]
> Subject: Case Sensitivity
>
>
> There is confusion on whether text encoding is case sensitive or not.
> Several of us remember language about this, but there is none now.
>
> I believe, and the sentiment of the room (interop test room),
> is that everything, language tokens, terminationIds, package
> names/events/signals/parameters... is NOT case sensitive.
>
> Any objections?
>
> Brian
>

---

From: John Segers <[email-masked]>
Date: Wed, 30 Aug 2000 14:49:33 +0200

All,

The text disappeared, because at the very beginning of Annex B there is
a reference to RFC 2234, and RFC 2234 says:

> The TerminationID specifies the termination to be added to the Context.  The Termination is either created, or taken from the null Context.  For an existing Termination, the TerminationID would be specific.  For a Termination that does not yet exist, the TerminationID is specified as CHOOSE  in the command. The new TerminationID will be returned.

>    ABNF permits specifying literal text string directly, enclosed in
>    quotation-marks.  Hence:
>
>         command     =  "command string"
>
>    Literal text strings are interpreted as a concatenated set of
>    printable characters.
>
>         NOTE:     ABNF strings are case-insensitive and
>                   the character set for these strings is us-ascii.
>
>    Hence:
>
>         rulename = "abc"
>
>    and:
>
>         rulename = "aBc"
>
>    will match "abc", "Abc", "aBc", "abC", "ABc", "aBC", "AbC" and "ABC".
>
>                 To specify a rule which IS case SENSITIVE,
>                    specify the characters individually.
>
>    For example:
>
>         rulename    =  %d97 %d98 %d99
>
>    or
>
>         rulename    =  %d97.98.99
>
>
>
>
>
> Crocker & Overell           Standards Track                     [Page 4]
>
> RFC 2234             ABNF for Syntax Specifications        November 1997
>
>
>    will match only the string which comprises only lowercased
>    characters, abc.

So the syntax of megaco is really case-insensitive, even quoted strings!

Cheers,

John

> Peter Blatherwick wrote:
>
> Brian, all:
>
> Your description below is as I remember it being decided.  To me this
> does not constitute change, just an editorial mishap.  At what stage
> did the text go missing (just a curio)?
>
> -- Peter
>

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 303
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954