Subject: Re: Calling Line Identification

From: "Davidson, Dan" <[email-masked]>
Date: Sun, 6 Aug 2000 11:18:13 +0200

Lets keep in mind that caller ID, caller Name and other similar features can
be received
also during an active call: the SCWID service - Spontaneous Call Wait ID.

Cheers,
Dan

> Well, It's not easy to tell what is "reasonable" and what is not... The
same
> issue could be raised for <draft-ietf-megaco-h248k-00.txt> where the
Generic
> Announcement package supports both fixed and variable announcements.

> Anyway, if we want to define more atomic packages for this new case, we
> first need to figure out which capabilities have a real impact on MG
> implementations and derive the number of packages from that. My feeling is
> that the MG does not need to be aware of the type of information which is
> actually sent to the terminal. The MGC shall provide a complete
> "presentation layer" frame, including the message type and lengh
indicators.
> The MG does not need to check that the message type is known and that the
> parameters are valid for that message. What matters for the MG is the type
> of transmission (on-hook/off-hook) and possibly the presence/absence of
> ringing after the data transmission. Therefore I assume that we could go
for
> three service-independent packages only.

> The first package "on-hook transmission associated with ringing" would be
> used to support Calling Line ID but also Calling Name ID or anything that
> needs to be displayed when a call is presented.

>Bruno,

> -----Message d'origine-----
> De: Rosen, Brian [mailto:[email-masked]]
> Date: vendredi 4 ao?t 2000 16:34
> ?: [email-masked]
> Objet: Re: Calling Line Identification
>
>
> My concern here is that when you implement a package, you
> implement all of
> it,
> and the extended capabilities you propose may be beyond what
> a reasonable
> implementation
> of a simple CLID capability may provide.  I could see a set
> of packages each
> extending
> from the previous which could have capabilities you describe.
>
> Brian
>
> > -----Original Message-----
> > From: CHATRAS Bruno FTRD/DAC/ISS
> > [mailto:[email-masked]]
> > Sent: Friday, August 04, 2000 10:24 AM
> > To: Rosen, Brian
> > Cc: [email-masked]'
> > Subject: RE: Calling Line Identification
> >
> >
> > Hi,
> >
> > I think that we need a more generic package that can support the
> > transmission of dipaly information over an analog line.
> >
> > I see a need to support:
> >
> > a) On-hook transmission associated with ringing (Calling Line
> > ID, Calling
> > Name ID, ...)
> >
> > b) On-hook transmission not associated with ringing (e.g.;
> > notification
> > services for message waiting indication)
> >
> > c) Off-hook transmission (calling Line ID presentation during
> > call waiting,
> > text-based advice of charge, ...)
> >
> > In all cases, there shall be no restrictions on the type of
> > message (and
> > parameters) to be sent over the analog line.
> >
> > I know that someone from Telcordia has presented a
> > contribution on that
> > topic to the ITU SG16 meeting in February'2000. The meeting reports
> > indicates that the proposal was reasonnable but that more
> > work was required.
> > I don't know what happened after that.
> >
> > I also attach for your information an alternative package
> > description I
> > drafted a few days ago. I'll not be able to work on it during
> > the cmming
> > weeks (holiday !). However, if someone wants to...
> >
> >
> >
> > > -----Message d'origine-----
> > > De: Rosen, Brian [mailto:[email-masked]]
> > > Date: vendredi 4 ao?t 2000 15:50
> > > ?: [email-masked]
> > > Objet: Re: Calling Line Identification
> > >
> > >
> > > Need a package.
> > >
> > > Any volunteers?
> > >
> > > Brian
> > >
> > > > -----Original Message-----
> > > > From: Rajendra Patil [mailto:[email-masked]]
> > > > Sent: Friday, August 04, 2000 7:57 AM
> > > > To: [email-masked]
> > > > Subject: Calling Line Identification
> > > >
> > > >
> > > > Hi,
> > > >
> > > >  How MEGACOsupports  CLID display for residential gateway ?
> > > >
> > > > Thanks/
> > > > Rajendra
> > > >
> > >
> >
> >
>

---

From: Michael Brown <[email-masked]>
Date: Mon, 7 Aug 2000 18:41:47 -0400

Actually, there is a proposed package which will address pretty much the whole
gamut of services related to display during alerting (either onhook or offhook).

Please see the Enhanced Alerting Package in the document at:

 http://www.ietf.org/internet-drafts/draft-brown-supplpkgs-00.txt

Michael Brown