Subject: Re: MG and DiffServ

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 2 Aug 2000 20:34:40 -0500

There's a difference between an operator's RFP requiring that their MGs
support DiffServ and a protocol dependency on such support.  Megaco has no
such dependency.

> -----Original Message-----
> From: S KA N [SMTP:[email-masked]]
> Sent: Wednesday, August 02, 2000 3:26 PM
> To:   [email-masked]
> Subject:      MG and DiffServ
>
> Hi,
>
> Can you think of any relation between the MG and
> DiffServ?
>
> If a privately managed IP network is DiffServ
> compliant and suppose if the same network
> is going to be used for VoIP purposes also. Don't
> we require the MGs to be DiffServ compliant?
>
> Any help/comment would be appreciated.
>
> ...SKAN
>
> __________________________________________________
> Do You Yahoo!?
> Kick off your party with Yahoo! Invites.
> http://invites.yahoo.com/

---

From: Thomas LEVY <[email-masked]>
Date: Thu, 3 Aug 2000 15:09:50 +0200

Hi all,

I am not quiet so definitive about that.
It depends, what you mean with :"MGs support Diffserv".
If you imagine a MG being able to handle a context wich modifies the QoS (i.e
for Diffserv : to have output stream with packets having different DSCP than
packets from input stream), you should rather express such a thing with Megaco
(why not in the Stream Descriptor).
I may also refer to Section 5.5 QoS/CoS from "Media Gateway Control Protocol
Architecture and Requirements" document, it states that: "The protocol must
support a means to change QoS during a connection...".
So I believe that Megaco will have to consider this point.

Any comments,

Thomas LEVY,

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 3 Aug 2000 14:24:11 -0400

Nevertheless, having the ability to specify which diffserv codepoint an MG
should use for a given media stream is fairly useful.

-- Flemming

--
Flemming Andreasen                Phone: +1 732 452 1667
Cisco Systems                     Fax:   +1 240 359 5839