Subject: Audit & Events

From: Isabelle Cnudde <[email-masked]>
Date: Thu, 12 Oct 2000 08:47:46 -0700

Hi,

Could someone explain me what are the difference between all the
*event* descriptors? and what should be returned to the commands
AuditCapabilities and AuditValue?
Here is my understanding and open points:

EventsDescriptor
----------------
. AuditCapabilities
Return the list of possible events on the Termination together with
the list of all possible values for the EventsDescriptor Parameters.
. AuditValue
What should be returned?

ObservedEventsDescriptor
------------------------
. AuditCapabilities
Return the names of active events on the termination.
What is an "active event"?
Is that a list of events that has to be observed on a termination?
. AuditValue
Returns a list of events in the EventBuffer.
Is that a list of events that has been observed on a termination?

EventBufferDescriptor
---------------------
. AuditCapabilities
The appropriate descriptors, with the possible values for the
Termination are returned from AuditCapabilities.
What should be returned?
. AuditValue
Return content of the EventBufferDescriptor = all events that has been
observed?
Then, what's the difference with the ObservedEventsDescriptor?

Thanks for any clarification on the topic!
Isabelle

---

From: Isabelle Cnudde <[email-masked]>
Date: Wed, 18 Oct 2000 15:21:42 -0700

Hi,

I sent last week some questions about the meaning of the differents
*event* descriptors, but I didn't receive any answers yet :(
Does this mean that this is unclear for most of us?! :)

I would really appreciate some clarification on the topic.
Isabelle