Subject: Subtract from MG to MGC?

From: Isabelle Cnudde <[email-masked]>
Date: Tue, 3 Oct 2000 16:44:25 -0700

Hi,

When resources associated to a connection is lost, shall the MG send a
Subtract command to the MGC to inform the connection is released? like
it is the case with MGCP and the DeleteConnection command?
Or is a ServiceChange with method=forced is enough?

Thanks for your help!
Isabelle

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 4 Oct 2000 11:13:57 -0400

Depends on what the "resource" is, but in general, I'd prefer to see
the MG's behavior for a "loss of service" type event to be
ServiceChange.  If there was some sort of less catastrophic event,
then maybe a Notify would be appropriate, but if a Subtract is
warranted, then I think a ServiceChange is warranted.

Note that IF POSSIBLE, the MG should NOT use "forced", as the MGC
may be able to take the call down more gracefully than the MG can.

Brian

> -----Original Message-----
> From: Michael Brown [mailto:[email-masked]]
> Sent: Wednesday, October 04, 2000 10:57 AM
> To: [email-masked]
> Subject: Re: Subtract from MG to MGC?
>
>
> I think that a better approach than ServiceChange would be
> for the MG to
> report an event indicating the loss of resources. The event
> in the Base
> Generic package could be used or if there is a specific event
> defined  in a
> package for the specific termination involved in the
> connection then that
> could be used. This would be the trigger for the MGC to send
> the SUBRACT (s)
> as needed to clean up the context or perhaps retry on setting up the
> connection ... up to the MGC as to what to do.
>
> Mike
>
> "Rosen, Brian" wrote:
>
> > Subtract cannot be sent from the MG to the MGC.
> > ServiceChange is the appropriate command.
> > The MGC should then send Subtract.
> >
> > Brian
> >
> > > -----Original Message-----
> > > From: Isabelle Cnudde [mailto:[email-masked]]
> > > Sent: Tuesday, October 03, 2000 7:44 PM
> > > To: [email-masked]
> > > Subject: Subtract from MG to MGC?
> > >
> > >
> > > Hi,
> > >