Subject: mId field in the Message header

From: "Bentov, Kohava" <[email-masked]>
Date: Tue, 3 Oct 2000 08:34:30 +0200

Hi,

  1.  Can we assume that each MG will use a unique mId in its message header when it 
       sends messages to the same MGC ?  
       If yes, is there a mistake in the example (section A.1.1) ?
============================  
1. An MG registers with an MGC using the ServiceChange command:

MG1 to MGC:

MEGACO/1 [124.124.124.222]

-----------------

4. The MG1 accepts the Modify with this reply:

MG1 to MGC:

MEGACO/1 [124.124.124.222]:55555

============================  

  2.  Is it obvious that the mId of a virtual MG will always consist of IP address + Port ? 
  
  3.  Is it possible that the mId in one message will be in a domainAddress format and in 
       another message (from the same source) it will be in an mtpAddress format ? 
  
  I ask these questions because we need unique mIds for managing 
the transaction database.  

Best regards,
    Kohava Bentov 
    Telrad Networks
    E-mail: [email-masked]
    Tel: (972)-8-9134353

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 3 Oct 2000 08:04:47 -0400

1. Yes, an MG uses a unique mId in it's header.
Unique means there is no duplicate from another MG

2. The mId could be address, address+port, FQDN, NSAP,
or something else, as long as it's unique

3. On formats, I'll fall on the usual dictum - senders should be
strict in the mId and always send the same thing.  Receivers
should be tolerant in what they accept.  The example was with
or without port; the sender should have been consistent,
the receiver should tolerate either.

Brian

-----Original Message-----
From: Bentov, Kohava [mailto:[email-masked]]
Sent: Tuesday, October 03, 2000 2:35 AM
To: [email-masked]
Subject: mId field in the Message header

Hi,

  1.  Can we assume that each MG will use a unique mId in its message header
when it

  2.  Is it obvious that the mId of a virtual MG will always consist of IP
address + Port ?

  3.  Is it possible that the mId in one message will be in a domainAddress
format and in
       another message (from the same source) it will be in an mtpAddress
format ?

Best regards,
    Kohava Bentov
    Telrad Networks