Subject: Re: ABNF for topologyDescriptor

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 20 Oct 2000 07:59:41 -0400

I don't like this addition, as it breaks "current" implementations.
Maybe:

topologyDescriptor   = TopologyToken topologyTriple |
                   ( LBRKT topologyTriple *(COMMA topologyTriple) RBRKT )
topologyTriple = LBRKT terminationA COMMA terminationB COMMA
                  topologyDirection RBRKT

> -----Original Message-----
> From: John Segers [mailto:[email-masked]]
> Sent: Friday, October 20, 2000 5:42 AM
> To: [email-masked]
> Subject: Re: ABNF for topologyDescriptor
>
>
> Christian,
>
> If we are making a change here, I propose that we delimit the
> triples by
> parentheses or brackets.  Something like
>
> topologyDescriptor   = TopologyToken LBRKT topologyTriple
>                    *(COMMA topologyTriple) RBRKT
> topologyTriple = LBRKT terminationA COMMA terminationB COMMA
>                   topologyDirection RBRKT
>
> Cheers,
>
> John
>
> > Date:         Wed, 18 Oct 2000 11:52:32 +1100
> > Reply-To:     Christian Groves <[email-masked]>
> > Sender:       "Media Gateway Control (megaco)"
> >               <[email-masked]>
> > From:         Christian Groves <[email-masked]>
> > Subject:      Re: ABNF for topologyDescriptor
> > X-To:         "Rosen, Brian" <[email-masked]>
> > Content-Type: text/plain; charset=iso-8859-1
> >
> > G'Day All,
> >
> > The update I have made is:
> > 6.10 Topology Triples in ABNF
> >
> > Description:    In the ABNF (Annex B), the term
> TopologyDescriptor allows
> > the specification of only one triple.  The ASN.1 permits a
> sequence of
> > such triples.
> > [Begin Correction]
> > B.2 ABNF Specification
> > ...
> > topologyDescriptor   = TopologyToken LBRKT topologyTriple
> >                   *(COMMA topologyTriple) RBRKT
> > topologyTriple = terminationA COMMA terminationB COMMA
> topologyDirection
> >                   RBRKT
> >
> > [End Correction]
> >
> > Cheers, Christian
>
> --
> John Segers                                  email: [email-masked]
> Lucent Technologies                                        Room HE 303
> Dept. Forward Looking Work                      phone: +31 35 687 4724
> P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954
>

---

From: John Segers <[email-masked]>
Date: Sat, 21 Oct 2000 16:04:38 +0200

Brian,

As I see it, the proposal for adding commas requires modification to the
existing parsers as well.  So I figured that we might as well make it
nice.  But it's no big deal to me.

Cheers,

John