Subject: Audit of digit map.

From: Madhu Babu <[email-masked]>
Date: Mon, 16 Oct 2000 15:53:07 +0530

Digit map with name "abc" is defined on a given termination T1. If the digit map
is active and MGC overwrites the definition of "abc", its mentioned in protocol
that this new definition will be applied only after deactivation of the digit
map.
If at this momment MGC audits the termination with digit map token, which
definition of the digit map "abc" is sent in response. The one that is active or
the
one that will be applied after digit map deactivation?
-Madhubabu

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 17 Oct 2000 08:09:20 -0400

The active one.

Brian

> -----Original Message-----
> From: Madhu Babu [mailto:[email-masked]]
> Sent: Monday, October 16, 2000 6:23 AM
> To: [email-masked]
> Subject: Audit of digit map.
>
>

---

From: Dave Sclarsky <[email-masked]>
Date: Tue, 24 Oct 2000 12:16:19 -0400

If audit value for DigitMap returns the active one,
is there any way for the MGC to audit the new one?

Wouldn't an audit value on the EventDescriptor return
the 'active' DigitMap?

DaveS.

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Tuesday, October 17, 2000 8:09 AM
To: [email-masked]
Subject: Re: Audit of digit map.

The active one.

Brian

---

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 24 Oct 2000 13:41:17 -0400

This seems to be one of those cases where the specification isn't clear, so
we have a choice.  It's absolutely clear to me that the AuditValue of
EventsDescriptor should return the active DigitMap.  It seems reasonable to
me that AuditValue of DigitMapDescriptor should return the new digitMap.  In
each case, the most recent setting of the descriptor is being returned.

> From: Dave Sclarsky [mailto:[email-masked]]
> Sent: Tuesday, October 24, 2000 12:16 PM

---

From: Dave Sclarsky <[email-masked]>
Date: Tue, 24 Oct 2000 17:25:56 -0400

I agree with your conclusion, but it raises another question!

How should an MG code the eventDM in response to an AuditValue of
EventsDescriptor, since eventDM allows either name OR value,
but not both?
Returning the name could be a problem, since auditing for the name's
value might not be reliable (assuming that auditing DigitMapDescriptor
would give you the 'new' value).
Returning the value could be wrong if the MGC expects to see the name
(i.e. it used the name in the activating EventsDescriptor)!

DaveS.

---

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 25 Oct 2000 10:17:53 -0400

I would think the safest thing is always to return the value.

> Sent: Tuesday, October 24, 2000 5:26 PM