Subject: Digit map completion event and other events.

From: Madhu Babu <[email-masked]>
Date: Mon, 16 Oct 2000 15:50:19 +0530

In section 7.1.14.7 its mentioned that  "While the digit map
is activated, detection is enabled for all
 events defined in the package containing the
specified digit map    completion event"
and "the events in the package containing the specified
digit map  completion event other than the
completion event itself are not       individually
notified".

In next section 7.1.14.8 if item identifier is wildcard, then its mentioned that
"Regardless of whether a digit map is activated,
if the package also contains the digit events
themselves, this form of event specification
will cause the    individual events to be
reported to the MGC as they are detected"

These two sections seems to be in conflict with each other. what
should be the MG behaviour.

-Madhubabu

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 17 Oct 2000 08:07:28 -0400

I don't understand the problem.

If you just have a digitmap, you don't get NOTIFYied of individual
events.  If you enable them, you do get the NOTIFYs, and they are
used by a digitMap, if enabled.  So there are two independent consumers
of DTMF digits, they can be enabled separately, or together, MGC choice.

Brian

> -----Original Message-----
> From: Madhu Babu [mailto:[email-masked]]
> Sent: Monday, October 16, 2000 6:20 AM
> To: [email-masked]
> Subject: Digit map completion event and other events.
>
>

---

From: John Segers <[email-masked]>
Date: Sat, 21 Oct 2000 16:18:36 +0200

Hi,

I agree that Brian's viewpoint is valid, but Madhu has a point: section
7.1.14.7 does say that while a digit map is active, the individual digit
events are not reported.

In my mind there are two things that we can do:
- change 7.14.1.7 to be more specific
- drop the clause from 7.1.14.8 that says that individual events are
notified if they are included in the events descriptor as well (i.e.
together with the digit map completion event).

Before making a choice, can anyone think of a scenario where you want
individual digits to be notified, *and* processed through a digit map at
the same time?

Cheers,

John

> Date:         Tue, 17 Oct 2000 08:07:28 -0400
> Reply-To:     "Rosen, Brian" <[email-masked]>
> Sender:       "Media Gateway Control (megaco)"
>               <[email-masked]>
> From:         "Rosen, Brian" <[email-masked]>
> Subject:      Re: Digit map completion event and other events.
> X-To:         "[email-masked]" <[email-masked]>
> Content-Type: text/plain; charset="iso-8859-1"
>

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 303
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954

---

From: CHATRAS Bruno FTRD/DAC/ISS <[email-masked]>
Date: Wed, 25 Oct 2000 09:19:40 +0200

> -----Message d'origine-----
> De : John Segers [mailto:[email-masked]]
> Envoyé : mercredi 25 octobre 2000 08:54
> À : [email-masked]
> Objet : Re: Digit map completion event and other events.
> 
> 
> Bruno,
> 
> If an IP is involved, couldn't it perform both functions (so the MG is
> not involved in collecting the called number at all)?

John,

Yes, this is one possible option. However it has some impact on the
dimensioning of the IP (number of incoming trunks and DTMF receivers).
Moreover, there is a risk that the first digit is dialled before the
connection to the external IP is actually switched-through. This is
generally considered unacceptable for emergency calls. One solution could be
to have the IP playing the dial tone (instead of the MG). However some
studies have shown that if the dial tone were not immediately available, a
large number of people would go on-hook or would start dialling anyway.

> 
> Cheers,
> 
> John
> 
> CHATRAS Bruno FTRD/DAC/ISS wrote:
> > 
> > John,
> > 
> > >
> > > Bruno,
> > >
> > > I wonder how the example that you give works.  In 
> particular, if the
> > > user speaks, does the MGC then learn the dialed number from
> > > the external IP?
> > 
> > Yes, you need a direct control interface between the MGC and the IP
> > (possibly tunnelled through the MG), which is outside the 
> scope of MEGACO.
> > 
> > > This looks awkward to me.
> > >
> > > An architecture where the MGC activates the digit map on 
> a Termination
> > > on the MG, and receives the digit string from that MG, whether it
> > > collected DTMF or used an external device to process user
> > > speech, seems
> > > preferrable to me.  The MGC then doesn't have to instruct two
> > > devices if
> > > it wants to get one dialled number.
> > 
> > I agree that this is a better target architecture. However 
> not all MGs will
> > be able to do that, while some Call Servers (MGC)(e.g; 
> those whose software
> > is derived from an existing PSTN switch) have already the 
> sort of control
> > interface I mentioned above. Another difficulty for the MG 
> is that the
> > selection of the external device may depend on the calling 
> party number.
> > 
> > >
> > > Cheers,
> > >
> > > John
> > >
> > > CHATRAS Bruno FTRD/DAC/ISS wrote:
> > > >
> > > > Hi,
> > > >
> > > > A scenario where you want individual digits to be notified,
> > > *and* processed
> > > > through a digit map at the same time might be a Voice
> > > Activated Dialling
> > > > service where the calling party can either dial or speak.
> > > >
> > > > When the calling party goes off-hook, the MGC creates a
> > > context with two
> > > > terminations. The first termination models the access to
> > > the calling line;
> > > > while the second termination models the access to an
> > > external Intelligent
> > > > Peripheral (with voice recognition capabilities). If the
> > > user prefers to
> > > > dial rather than speak, it might be useful for the MGC to
> > > be aware of this
> > > > decision as soon as possible, in order to release the
> > > external peripheral.
> > > > Reporting the first dialled digit as an individual event
> > > would make this
> > > > easy. In parallel, this digit and the subsequent digits
> > > would still need to
> > > > be processed through a digit map according to the dialling
> > > plan in force.
> > > >
> > > > > -----Message d'origine-----
> > > > > De : John Segers [mailto:[email-masked]]
> > > > > Envoyé : samedi 21 octobre 2000 16:19
> > > > > À : [email-masked]
> > > > > Objet : Re: Digit map completion event and other events.
> > > > >
> > > > >
> > > > > Hi,
> > > > >
> > > > > > > In next section 7.1.14.8 if item identifier is 
> wildcard, then
> > > > > > > its mentioned that