Subject: Re: Additional MTP3 formats

From: "Tulpule, Naren" <[email-masked]>
Date: Wed, 25 Oct 2000 09:40:53 -0700

So... what is the fix?
MTPAddress = MTPToken LBRKT 4*6(HEXDIG) RBRKT ?
(I hope the octetString doesn't mean 2/3 raw octets!)

-- Naren.
These views and opinions are mine alone, not those of Intel    (yet ;-)
Narendra C. Tulpule SMTS, Trillium (an Intel company)
Ph: +1-310-442-9222              Fax: +1-310-442-1162
12100 Wilshire Bl #1800         Los Angeles, CA 90025

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Tuesday, October 24, 2000 8:21 PM
To: [email-masked]
Subject: Additional MTP3 formats

G'Day all,

It was noted previously on the list that the MTP MID needed to be
updated to allow for American and Japanese variants.

Below is a proposed change for the implementors' guide.

For the ASN.1 change:
From:

mtpAddress                              OCTET STRING(SIZE(2)),
 -- Addressing structure of mtpAddress:
 --        15                0
 --        |  PC        | NI |
 --          14 bits    2 bits

to:

mtpAddress                              OCTET STRING,
 -- Addressing structure of mtpAddress:
 --        15                0
 --        |  PC        | NI |
 --         24-14 bits    2 bits
 -- NOTE: 14 bits is defined for international use.
 -- Two national options exist where the point code is 16 or 24 bits.

For the ABNF change:

From:
; An mtp address is two octets long
mtpAddress           = MTPToken LBRKT octetString RBRKT

to:
; Addressing structure of mtpAddress:
;        15                0
;        |  PC        | NI |
;         24-14 bits    2 bits
; NOTE: 14 bits is defined for international use.
; Two national options exist where the point code is 16 or 24 bits.
mtpAddress           = MTPToken LBRKT octetString RBRKT

Is this OK?

Cheers, Christian

---

From: Christian Groves <[email-masked]>
Date: Thu, 26 Oct 2000 14:23:01 +1100

G'Day Naren,

I think your proposal is better. I was just going to add a comment about
formatting the octet string into HEX digits.

The text I put in the implementors' guide is:
8.15 MTP addressing for non ITU variants

Description:    The MTP MID needed to be updated to allow for American and
Japanese variants as it only currently allows ITU defined MTP addresses
to be used.
Reference:      From: Christian Groves [mailto:[email-masked]]
Sent: Tuesday, October 24, 2000 8:21 PM
To: [email-masked]
Subject: Additional MTP3 formats
 [Begin Correction]
Section A.2 ASN.1 Syntax

MId ::= CHOICE
{
        ip4Address                              IP4Address,
        ip6Address                              IP6Address,
        domainName                      DomainName,
        deviceName                      PathName,
mtpAddress                              OCTET STRING(SIZE(2)),
 -- Addressing structure of mtpAddress:
 --       15                 0
 --        |  PC        | NI |
 --        24 - 14 bits    2 bits
 -- Note: 14 bits is defined for international use.
 -- Two national options exist where the point code is 16 or 24 bits.
 -- To octet align the mtpAddress the MSBs shall be encoded as 0s.
      ...
}
Section B.2 ABNF Syntax
…
; Addressing structure of mtpAddress:
; 25 - 15            0
;    |  PC        | NI |
;    24 - 14 bits    2 bits
; Note: 14 bits is defined for international use.
; Two national options exist where the point code is 16 or 24 bits.
; To octet align the mtpAddress the MSBs shall be encoded as 0s.
; An octet shall be represented by 2 hex digits.
; An mtp address is two octets long
mtpAddress           = MTPToken LBRKT 4*6(HEXDIG)octetString RBRKT

[End Correction]

Christian