Subject: Re: Mixing Requests and Replies

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 31 Oct 2000 10:37:04 -0500

The point being made here is that sometimes the address to which you must
send requests (as set by ServiceChange) will differ from the address from
which requests originated at the peer.  In that case you have to send
requests and replies in separate messages because they are going to
different places.

> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Tuesday, October 31, 2000 9:32 AM
> To: [email-masked]
> Subject: Mixing Requests and Replies
>
>
> Section 7.2.8 contains the following text:
>    .... At the same
>    time, as indicated in section 9, transaction replies and pending
>    indications must be sent to the address from which the
> corresponding
>    requests originated.  This must be done even if it implies extra
>    messaging because commands and responses cannot be packed together.
>    The TimeStamp parameter shall be sent with a registration command
>    and its response.
>
> Notice the phrase "commands and responses cannot be packed together"
> What does that mean?  You most certainly could put a request for
> one transaction in the same message you put a reply for another
> transaction, right?
>
> Brian
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 31 Oct 2000 10:57:01 -0500

Probably need some text clarifications.

More grist for the implementer's guide mill.

Brian

> From: John Segers [mailto:[email-masked]]
> Sent: Tuesday, October 31, 2000 10:40 AM
> Subject: Re: Mixing Requests and Replies
>
>
> Brian,
>
> The intention of this text is to say that
> - if an MG has an outstanding transaction (still a response to send),
> - it receives a ServiceChange redirecting it to another MGC (handoff),
> - and it wants to initiate a transaction request,
> then the response and the request cannot be packed together, but
> separate messages are required: response to the old MGC,
> request to the
> new MGC.
>
> The confusing bit to me is that this text occurs in a paragraph on
> registration and handoff isn't mentioned in that paragraph.
>
> Cheers,
>
> John
>
> "Rosen, Brian" wrote:
> >
> --
> John Segers                                  email: [email-masked]
> Lucent Technologies                                        Room HE 303
> Dept. Forward Looking Work                      phone: +31 35 687 4724
> P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954
>