Subject: Re: Subtract from MG to MGC?

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 4 Oct 2000 08:50:22 -0400

Subtract cannot be sent from the MG to the MGC.
ServiceChange is the appropriate command.
The MGC should then send Subtract.

Brian

> -----Original Message-----
> From: Isabelle Cnudde [mailto:[email-masked]]
> Sent: Tuesday, October 03, 2000 7:44 PM
> To: [email-masked]
> Subject: Subtract from MG to MGC?
>
>
> Hi,
>
> When resources associated to a connection is lost, shall the MG send a
> Subtract command to the MGC to inform the connection is released? like
> it is the case with MGCP and the DeleteConnection command?
> Or is a ServiceChange with method=forced is enough?
>
> Thanks for your help!
> Isabelle
>

---

From: Michael Brown <[email-masked]>
Date: Wed, 4 Oct 2000 10:57:04 -0400

I think that a better approach than ServiceChange would be for the MG to
report an event indicating the loss of resources. The event in the Base
Generic package could be used or if there is a specific event defined  in a
package for the specific termination involved in the connection then that
could be used. This would be the trigger for the MGC to send the SUBRACT (s)
as needed to clean up the context or perhaps retry on setting up the
connection ... up to the MGC as to what to do.

Mike