Subject: Re: ABNF for topologyDescriptor

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 17 Oct 2000 08:03:36 -0400

> Hi list,
>   in the implementor's guide (B.2), topology descriptor is given as
> topologyDescriptor   = TopologyToken LBRKT *(terminationA COMMA
>                          terminationB COMMA topologyDirection) RBRKT
> What's the seperator between topologyDirection and
> terminationA? How about
> COMMA if we haven't agreed on one?
Right, took me a while.  The problem occurs when you have more than one
topology setting in the descriptor.

So the ABNF could be:
topologyDescriptor   = TopologyToken LBRKT topologyTriple
                               *(COMMA topologyTriple) RBRKT
topologyTriple = terminationA COMMA terminationB COMMA topologyDirection

Or we can just disallow more than one setting per descriptor

Implementor's Guide Note please Christian

---

From: Christian Groves <[email-masked]>
Date: Wed, 18 Oct 2000 11:52:32 +1100

G'Day All,

The update I have made is:
6.10 Topology Triples in ABNF

Description:    In the ABNF (Annex B), the term TopologyDescriptor allows
the specification of only one triple.  The ASN.1 permits a sequence of
such triples.
 [Begin Correction]
B.2 ABNF Specification
…
topologyDescriptor   = TopologyToken LBRKT topologyTriple
*(COMMA topologyTriple) RBRKT
topologyTriple = terminationA COMMA terminationB COMMA topologyDirection
RBRKT

[End Correction]

Cheers, Christian