Subject: Re: a$ TermName in SUBTRACT

From: Tom-PT Taylor <[email-masked]>
Date: Mon, 30 Oct 2000 12:03:49 -0600

I would side with Brian on this one.  In fact, I can think of some uses for
the a$ construct.

> -----Original Message-----
> From: John Segers [mailto:[email-masked]]
> Sent: Monday, October 30, 2000 9:40 AM
> To: [email-masked]
> Subject: Re: a$ TermName in SUBTRACT
>
>
> Brian, Chanchal
>
> The way I always interpreted the current text "The use of
> CHOOSE in the
> TerminationID is an error [...]" is that a$ is an error: the CHOOSE
> character occurs in the TerminationID.  In my opinion no clarification
> is needed.
>
> Cheers,
>
> John
>
> "Rosen, Brian" wrote:
> >
> > No, I think if the MGC wants to play Russian Roulette with
> > termination IDs, we should let him!  Seriously, I don't think
> > it's particularly useful, but I don't see why we have to
> > prohibit it.  I'm not even sure why we have to prohibit
> > straight CHOOSE by the same reasoning, but I don't want to modify
> > the text now.
> >
> > Please note that a$ could refer to a physical termination, not
> > just an ephemeral.
> >
> > Brian
> >
> > > -----Original Message-----
> > > From: Chanchal Hassija [mailto:[email-masked]]
> > > Sent: Monday, October 30, 2000 1:12 AM
> > > To: [email-masked]
> > > Subject: a$ TermName in SUBTRACT
> > >
> > >
> > > Hello All,
> > >
> > > For Subtract command-- the protocol says -- " Use of CHOOSE
> > > in TerminationID is
> > > an error as the Subtract command may only be used on existing
> > > Terminations" as
> > > given in 7.2.3
> > >
> > > This seems to imply that TermID = $ which refers to ephemeral
> > > Terminations
> > > (which don't yet exist) is disallowed for Subtract command.
> > > But TermID=a$ can be
> > > used to Subtract any matching termination (a1, a2 etc) from
> > > the context
> > > specified.
> > >
> > > But this does not make much sense as MGC should be specific
> > > in which Termination
> > > it wants to remove in case all the terminations in the
> > > context match a$.
> > >
> > > Do we agree on the statement that "Both $ as well as a$ are
> > > invalid TermIDs for
> > > Subtract". If Yes, we need a note somewhere in the
> > > implementor's guide.
> > >
> > > Thanks
> > > Chanchal....
> > >
>
> --
> John Segers                                  email: [email-masked]
> Lucent Technologies                                        Room HE 303
> Dept. Forward Looking Work                      phone: +31 35 687 4724
> P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954
>

---

From: John Segers <[email-masked]>
Date: Tue, 31 Oct 2000 08:48:47 +0100

All,

If the majority thinks that we need this feature, then we have to change
the text.  The current text clearly does not allow TerminationID a$ for
a Subtract.

I don't see a reason to allow the use CHOOSE in the TerminationID of a
Subtract command myself.  All it does is allow the MGC to have the MG
flip a coin instead of flipping the coin itself before sending the
command.

Cheers,

John