Subject: Re: Topology

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 26 Oct 2000 09:30:02 -0400

All I can say is that the intention was to make topology specifications
cumulative over the life of the context, as Chanchal explains.  Do we need a
note in the Implementor's Guide?

> -----Original Message-----
> From: Paul Hollis [mailto:[email-masked]]
> Sent: Sunday, October 22, 2000 7:57 PM
> To: [email-masked]
> Subject: Re: Topology
>
>
> Hi,
>
> the point I was trying to make is that if you send down
> (T1,Tx,isolate) in one
> transaction, and then in a later transaction you send down
> (T1,Ty,isolate),
> according to the rule:
>
> "The default association when a termination is not mentioned
> in the Topology
> descriptor is bothway (if T3 is added to a context with T1
> and T2 with topology
> (T3,T1,oneway) it will be connected bothway to T2)."
>
> this would imply that T1 and Tx would now be bothway again as
> it was not
> specifically mentioned in the descriptor.
>
> Regards Paul.
>
>
> [email-masked] wrote:
>
> > Hello Paul,
> >
> > The topology is with respect to a context and hence is not
> a command level
> > descriptor.......................So during the life-time of a
> > context......whatever topologies come in various actions
> get applied to the
> > context..............one after the other........If at any
> point of time you
> > refer to a term T1 in a command, then the following
> statements explain ---
> >
> > *) If at any point of time in the life of the context, you
> referred to term T1
> > as (T1,Tx, isolate) (which shall be stored in your topology
> descriptor) , then
> > T1 and Tx are isolated for this command also......(if T1
> did not get subtracted
> > after the topology settings because that would flush the
> topology for T1)
> >
> > *) If at no point of time you referred to the pair
> (T1,Ty,..), then T1,Ty is
> > bothways for this command..............
> >
> > But remember, you have to flush the topology descriptor for
> T1, if T1 gets
> > subtracted from the context...................
> >
> > Njoy
> > Chanchal...........
> >
> > Paul Hollis <[email-masked]> on 10/19/2000 04:17:51 PM
> >
> > To:   Chanchal Hassija/HSS@HSS
> > cc:   [email-masked]
> >
> > Subject:  Re: Topology
> >
> > Hi Chanchal,
> >
> > thanks for the reply. However, if you take each step as
> being done in one
> > command
> > at a time, then step 2 would isolate T1 and T2, which is
> OK. However, once step
> > 3
> > is issued in the command with only (T3, T2, oneway)
> specified in the command,
> > then
> > according to the rule quoted below any other association
> not mentioned in the
> > command is set to bothway.
> >
> > In other words you would  need to specify (T1, T2 isolate)
> and (T3, T2, oneway)
> > in
> > the one command to achieve what is shown.
> >
> > Does this make sense or am I on the wrong track.
> >
> > Regards Paul.
> >
> > Chanchal Hassija wrote:
> >
> > > Hello Paul,
> > >
> > > My reply is embedded and prefixed with Chan>
> > >
> > > I have a quick question about the topology description in H.248.
> > >
> > > The wording in the Topology Descriptor chapter says:
> > >
> > > "The default association when a termination is not
> mentioned in the Topology
> > > descriptor is bothway (if T3 is added to a context with
> T1 and T2 with
> > topology
> > > (T3,T1,oneway) it will be connected bothway to T2)."
> > >
> > > but in the example in the diagrams, at step 3 we apply
> the topology "T3, T2,
> > > oneway". I would assume that if we apply the above rule,
> then there should be
> > a
> > > bothway connection between T1 and T2.
> > >
> > > Chan> You need to read all the steps in sequence. Hence
> the two-way connection
> > > between T1 and T2 in step 1) was broken in step 2) by the
> command....
> > > (T1,T2,Isolate).....Hence it is not there in step 3)
> > >
> > > Njoy....
> > > Chanchal........
>

---

From: Paul Hollis <[email-masked]>
Date: Fri, 27 Oct 2000 16:05:42 +1100

Hi,

I guess it wouldn't hurt to have a note clarifying the intention to make it less
ambiguous.

Regards Paul.