Subject: Re: Missing/ Empty Audit Descriptor

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 26 Oct 2000 09:37:25 -0400

You are certainly right in your observation.  The statement in 7.1.15 has
been there from the beginning -- it was inherited from MGCP.  When we added
the statement in 7.1.1, we forgot about 7.1.15.  Having an exception for the
Subtract command isn't pretty, but I think it is practical.

So the Implementor's Guide has to note the exception in section 7.1.1.

> -----Original Message-----
> From: Kapil Nayar [mailto:[email-masked]]
> Sent: Thursday, October 19, 2000 4:09 AM
> To: [email-masked]
> Subject: Missing/ Empty Audit Descriptor
>
>
> Hi
>
> The protocol document mentions:
>
> 7.1.1 Specifying Parameters
> ...
> "A missing Audit descriptor is equivalent to an empty Audit
> Descriptor."
>
> and also
>
> 7.1.15 Statistics Descriptor
> ...
> "By default, statistics are reported when the Termination is
> Subtracted from the
> Context.  This behavior can be overridden by including an
> empty AuditDescriptor
> in the Subtract command."
>
> Now, if Subtract command doesnot have an AuditDescriptor it
> would mean that
> there is an empty audit descriptor and no statistics would be
> reported. And, if
> the MGC needs termination statistics, it must send
> AuditDescriptor with
> Statistics token in the Subtract command. But this seems to change the
> definition of "By default".
>
> Please clarify whether the above is correct.
>
> -Kapil Nayar
> Hughes Software Systems
>

---

From: Christian Groves <[email-masked]>
Date: Fri, 27 Oct 2000 17:00:09 +1100

G'Day Tom,

OK. I propose the following:
8.16 Audit Descriptor and Subtract and Statistics

Description:    The protocol document mentions:
7.1.1 Specifying Parameters
...
"A missing Audit descriptor is equivalent to an empty Audit Descriptor."
and also
7.1.15 Statistics Descriptor
...
"By default, statistics are reported when the Termination is Subtracted
from the Context.  This behavior can be overridden by including an empty
AuditDescriptor in the Subtract command."
 According to this text, if Subtract command doesnot have an
AuditDescriptor it would mean that there is an empty audit descriptor
and no statistics would be reported. And, if the MGC needs termination
statistics, it must send AuditDescriptor with Statistics token in the
Subtract command. But this seems to change the definition of "By
default".
Reference:      Subject: Re: Missing/ Empty Audit Descriptor
Date: Thu, 26 Oct 2000 09:37:25 -0400
From:  Tom-PT Taylor <[email-masked]>
To:  [email-masked]
 [Begin Correction]
Section 7.1.1 Specifying Parameters
…
If a required descriptor other than the Audit descriptor is unspecified
(i.e., entirely absent) from a command, the previous values set in that
descriptor for that termination, if any, are retained.  In commands
other than Subtract, aA missing Audit descriptor is equivalent to an
empty Audit Descriptor.  The behavior of the MG with respect to
unspecified parameters within a descriptor varies with the descriptor
concerened, as indicated in succeeding sections.  Whenever a parameter
is underspecified or overspecified, the descriptor containing the value
chosen by the responder is included as output from the command.

[End Correction]

Agreeable?

Cheers, Christian