Subject: Binary encoding; Command type parameter

From: Rita Sharma <[email-masked]>
Date: Sat, 21 Oct 2000 16:09:27 GMT

Folks,

I have joined the list recently so excuse my lack of knowledge for this
question.

I am working with binary encoding and I could not find a place where a
command request specify the type of command (Add/subtract/ etc).

For example, the following three definitions do not specify the name of
command.

CommandRequest ::= SEQUENCE
   {
        command                 Command,
        optional                NULL OPTIONAL,
        wildcardReturn          NULL OPTIONAL,
        ...
   }

   Command ::= CHOICE
   {
        addReq                  AmmRequest,
        moveReq                 AmmRequest,
        modReq                  AmmRequest,
        -- Add, Move, Modify requests have the same parameters
        subtractReq             SubtractRequest,
        auditCapRequest         AuditRequest,
        auditValueRequest       AuditRequest,
        notifyReq               NotifyRequest,
        serviceChangeReq        ServiceChangeRequest,
        ...
   }

AmmRequest ::= SEQUENCE
   {
        terminationID           TerminationIDList,
        descriptors             SEQUENCE OF     AmmDescriptor,
        -- At most one descriptor of each type (see AmmDescriptor)
        -- allowed in the sequence.
        ...
   }

<<<<<<<<<<<<<<<<<<<
thanks

/Vivek
_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at
http://profiles.msn.com.

---

From: John Segers <[email-masked]>
Date: Mon, 23 Oct 2000 11:04:46 +0200

Vivek/Rita,

The encoding of a CHOICE construct contains information about the field
that was chosen, not just the value (in this case AmmRequest).

Cheers,

John

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 303
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954