Subject: M3UA Common Message Header

From: Peter Grant <[email-masked]>
Date: Wed, 11 Oct 2000 17:06:13 +0100

Dear All,

I have a query regarding the latest version (4) of M3UA. There is a
discrepancy between the definition of the Message Length in the Common
Message Header.

Version 3 describes the Message Length as being:

        Message Length: 32-bits (unsigned integer)

                The Message Length defines the length of the message in octets, not
                including the header.

However, Version 4 describe the Message Length thus:

        Message Length: 32-bits (unsigned integer)

                The Message Length defines the length of the message in octets,
                including the header.

Is it just a typing error, or has the definition of the Message Length
actually changed?

Having recently written decode for the entire protocol (just before the
latest version came out) I would appreciate it if you could confirm my fears
that my decode is now slightly wrong.

Peter Grant
Software Engineer,
Test Tools Division,
Telesoft Technologies Ltd.

Phone:  +44 (0)1258 480880
Direct: +44 (0)1258 486574
email:  [email-masked]
www:    www.telesoft-technologies.com

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 11 Oct 2000 13:40:24 -0400

Wong email list!  You wanted [email-masked],
not [email-masked]

> -----Original Message-----
> From: Peter Grant [mailto:[email-masked]]
> Sent: Wednesday, October 11, 2000 12:06 PM
> To: [email-masked]
> Subject: M3UA Common Message Header
>
>
> Dear All,
>