Subject: Re: Add with wildcard termination ID

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 9 Oct 2000 15:58:23 -0400

First of all, an Add only can add one termination per command,
so Add=abc* would only add abcd.  Pressing on, if, for
example, abcd was already in a context, then the
error would be in $ context, and would indicate no terminations
matched, I suppose.

We might want to think about whether outofservice really causes
a no terminations matched situation.  On the one hand, adding
an out of service termination makes no sense.  On the other hand
auditing one does.  So does the matching logic work differently
for Audit than it does for Add?  I would think it shouldn't,
thus we have a quandry.

Brian

-----Original Message-----
From: Sachin Mittal [mailto:[email-masked]]
Sent: Monday, October 09, 2000 4:13 AM
To: [email-masked]
Subject: Add with wildcard termination ID

Suppose there are two terminations in MG named "abcd" and "abce"
and MGC sends an ADD as
CtxID=$ ADD TermID=abc*
Now MG is able to create a Context and successfully ADD "abcd" in it, but
ADDing of "abce" fails (say because of "abce" being "outofservice")

What ContextID will be used in the response for the termination "abce":
1. $
2. The allocated ContextID for "abcd"

Sachin

---

From: Kevin Boyle <[email-masked]>
Date: Mon, 9 Oct 2000 16:30:03 -0400

It seems to me that if you can only add one termination per command, then
use of the ALL (*) wildcard is not allowed for Add.  CHOOSE ($), however,
would be acceptable.  There are other commands where these kinds of
restrictions are already expressed, so why not add one for Add in the
Implementer's Guide?

It would also seem to me that if a termination is OOS, then adding it is not
allowed.  Once again, somthing for the Implementer's Guide?

Kevin

---

From: Paul Hollis <[email-masked]>
Date: Tue, 10 Oct 2000 13:23:39 +1100

G'day Brian,

I would have thought that you could ADD more than one termination based on the
sentence that follows the ADD command in H248:

"If the wildcard matches more than one TerminationID, all possible matches are
attempted, with results reported for each one. "

Regards Paul.

---

From: Chuong Nguyen <[email-masked]>
Date: Tue, 10 Oct 2000 13:26:24 -0500

Section 7.2.1 there is the following statement:

"Add SHALL NOT be used on a Termination with a serviceState of "OutofService"."

So I assume that MG should return an error on this ADD.

Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****