Subject: Re: Statistics

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 19 Oct 2000 10:19:38 -0400

Oh cool.  I don't think we have ever talked about this,
stream specific statistics!  Hmmmmm.

So we would want to add (an optional) StreamId to Statistics Descriptor
                Statistics=1{rtp/pr=....
and you might get more than one Statistics descriptor in the reply.

Wow.  This is a real bug in the protocol I think!

Brian

> -----Original Message-----
> From: Madhu Babu [mailto:[email-masked]]
> Sent: Thursday, October 19, 2000 9:51 AM
> To: [email-masked]
> Subject: Statistics
>
>
> Section E.12.4 states that statistics like
> jitter, packet loss,etc are described on an
> RTP stream. If only one RTP stream is
> present on a termination its straitforward
> to send statistics. But if multiple streams
> are created on a termination How this
> reporting is done?
>
> -Madhubabu
>

---

From: Christian Groves <[email-masked]>
Date: Fri, 20 Oct 2000 10:22:58 +1100

This has been something thats been around for a long time and I thought
people were pretty aware of this. I don't think its a bug per se as you
can handle it formatting your statistics in a certain way. Certainly in
v2 it would be nice to allow statistics on streams. Its a fairly big
change to me for an implementors' guide.

Cheers, Christian