Subject: Re: Statistics

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 20 Oct 2000 07:51:25 -0400

Well we don't "format statistics" in a certain way to, say,
allow you to differentiate # of packets sent for video from
# of packets sent for audio.

Seems to me it needs to be addressed somehow.

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Thursday, October 19, 2000 7:23 PM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: Re: Statistics
>
>
> This has been something thats been around for a long time and
> I thought
> people were pretty aware of this. I don't think its a bug per
> se as you
> can handle it formatting your statistics in a certain way.
> Certainly in
> v2 it would be nice to allow statistics on streams. Its a fairly big
> change to me for an implementors' guide.
>
> Cheers, Christian
>
> "Rosen, Brian" wrote:
> >
> > Oh cool.  I don't think we have ever talked about this,
> > stream specific statistics!  Hmmmmm.
> >
> > So we would want to add (an optional) StreamId to
> Statistics Descriptor
> >                 Statistics=1{rtp/pr=....
> > and you might get more than one Statistics descriptor in the reply.
> >
> > Wow.  This is a real bug in the protocol I think!
> >
> > Brian
> >
> > > -----Original Message-----
> > > From: Madhu Babu [mailto:[email-masked]]
> > > Sent: Thursday, October 19, 2000 9:51 AM
> > > To: [email-masked]
> > > Subject: Statistics
> > >
> > >
> > > Section E.12.4 states that statistics like
> > > jitter, packet loss,etc are described on an
> > > RTP stream. If only one RTP stream is
> > > present on a termination its straitforward
> > > to send statistics. But if multiple streams
> > > are created on a termination How this
> > > reporting is done?
> > >
> > > -Madhubabu
> > >
>
>

---

From: Christian Groves <[email-masked]>
Date: Mon, 23 Oct 2000 11:29:06 +1100

G'Day Brian,

There's no reason that you can't. You could have a statistic on a
termination for : No. Audio PAckets received, another for Number video
packets received, another for Total packets received.

I do see the case why we want it per stream. I was questioning the place
to document it. Implementors guide or v2? If other people speak up I
don't mind adding it the Implementors' guide.

Cheers, Christian