Subject: Re: Last Call On NAS Package

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 25 Oct 2000 14:05:47 -0400

The bearer capability package is on my "to do" list.  I think there are only
two properties required: Information Transfer Capability (speech,
unrestricted digital, etc.) and transfer rate/bandwidth.  (Correct me if I'm
wrong.)  The package would apply to the circuit termination.  The MG (don't
personalize the NAS termination too much) would take account of these
properties on the circuit side when formulating its authentication request.

The modem descriptor would also be set on the circuit side, but only if
modem type was indicated in incoming signalling to the MGC.  Otherwise
normal autosensing procedures would apply.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, October 25, 2000 1:03 PM
> To: [email-masked]
> Subject: Re: Last Call On NAS Package
>
>
> All,
>
> Just one point I could use some clarification on. This may or
> may not impact the draft...
>
> The NAS termination, when being added to a context for
> inbound call, needs to know at least called and calling
> number (if available) and the port type/bearer capability
> (required for authentication request).
> The NAS package provides the called/calling number.
> Where does the NAS termination derive the port type from?
>
> The draft states in section 6.5:
> <<
> It will typically add the bearer capability properties (described in a
> separate document) to the circuit termination based on call
> signalling.
> >>
> What document is being referred to?
> This would imply that the NAS termination has to peek at the
> properties of the circuit termination that has been (or will
> be) added to it's context?
>
> What about Modem Descriptor? Would this be specified for the
> circuit termination or the NAS termination or both?
>
> Thanks for clarifying,
> Marc.
>
>
>
> >There have been no comments on draft-ietf-megaco-naspkg-01.txt.  I am
> >therefore submitting it to WG Last Call, expiring Nov. 8/00.
>  I think our
> >intention is that this be a Standards Track item, so speak up if you
> >disagree.
> >
> >Tom Taylor
>

---

From: Ilya Akramovich <[email-masked]>
Date: Wed, 25 Oct 2000 18:15:21 -0700

Tom,

I'm afraid that those two may not be enough.

I would also strongly recommend that User Information Layer 1 Protocol
and User Rate be included in order to account for V.110, WORM-ARQ and
PHS/PIAFS calls.

Of course, those can always be added as vendor extensions, but I would
give my 2 cents for their inclusion into a standartized package
because of the wide use of the protocols in the NAS world.

Ilya
--
Ilya Akramovich                    Tel: +1 (510) 747-2926
Sr. Software Engineer              mailto:[email-masked]
Lucent/InterNetworking Systems     http://www.lucent.com/ins