Subject: Additional MTP3 formats

From: Christian Groves <[email-masked]>
Date: Wed, 25 Oct 2000 14:20:49 +1100

G'Day all,

It was noted previously on the list that the MTP MID needed to be
updated to allow for American and Japanese variants.

Below is a proposed change for the implementors' guide.

For the ASN.1 change:
From:

mtpAddress                              OCTET STRING(SIZE(2)),
 -- Addressing structure of mtpAddress:
 --        15                0
 --        |  PC        | NI |
 --          14 bits    2 bits

to:

mtpAddress                              OCTET STRING,
 -- Addressing structure of mtpAddress:
 --        15                0
 --        |  PC        | NI |
 --         24-14 bits    2 bits
 -- NOTE: 14 bits is defined for international use.
 -- Two national options exist where the point code is 16 or 24 bits.

For the ABNF change:

From:
; An mtp address is two octets long
mtpAddress           = MTPToken LBRKT octetString RBRKT

to:
; Addressing structure of mtpAddress:
;        15                0
;        |  PC        | NI |
;         24-14 bits    2 bits
; NOTE: 14 bits is defined for international use.
; Two national options exist where the point code is 16 or 24 bits.
mtpAddress           = MTPToken LBRKT octetString RBRKT

Is this OK?

Cheers, Christian

---

From: John Segers <[email-masked]>
Date: Wed, 25 Oct 2000 11:32:09 +0200

Christian,

You'd have to leave out the '15' below.  Also, it should be specified
how the PC+NI is aligned in the string of octets if their total size is
not an integral multiple of 8 bits.

Cheers,

John

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 303
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954