Subject: Re: ROOT termination

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 13 Oct 2000 07:52:29 -0400

The MG uses ServiceChange to register with an MGC
The MGC audits the MG.

Note that if this is the initial registration for the MG (the MG booted),
then there is no relevant state - the MGC programs the state it wants.
The audits are to discover capability.

If the registration is due to a failover, then the MGC does have to
audit state, but the audit commands are sufficient.

There is a hole, which I'm supposed to have an I-D out on. The hole
is - how does the MGC know how to construct a finite number of
audit requests if it doesn't know the "naming pattern" of the terminations
in the MG.  The current answer is - provisioning.

The I-D I owe is a package that defines a property the MGC can read
which describes the naming pattern.

Brian

> -----Original Message-----
> From: SRD Tian YaMin [mailto:[email-masked]]
> Sent: Thursday, October 12, 2000 9:27 PM
> To: [email-masked]
> Subject: Re: ROOT termination
>
>
> So, how the MG do a registration?
> How to set the default service state initially?
>
> >Actually, no.  You need not do a ServiceChange of every termination
> >(interesting idea however!) after Registration.  The ServiceChange
> >of service state is a CHANGE of service state, not the initial one.
> >
> >Brian
> >
> >> -----Original Message-----
> >> From: SRD Tian YaMin [mailto:[email-masked]]
> >> Sent: Thursday, October 12, 2000 4:06 AM
> >> To: [email-masked]
> >> Subject: ROOT termination
> >>
> >>
> >> Hello, I need someone to verify my understandings:
> >> When an unknown MG first registers to a MGC, in principle ,
> >> it must register
> >>
> >> each termination with a ServiceChange to make the MGC be
> >> aware of their
> >> existence,
> >> But to reduce the network traffic, wildcard TerminationId is
> >> necessary, and
> >> the wildcards must be
> >> carefully constructed to let the MGC know the exact
> >> termination set on the
> >> MG, and it is not  right to
> >> use Root termination in this case.
> >> Am I right? Thanks a lot if somebody can help me.
> >>
> >> Best regards
>

---

From: Thomas LEVY <[email-masked]>
Date: Fri, 13 Oct 2000 14:34:31 +0200

I don't quiet understand the problem.
I guess you talk about permanent Termination.
Why wouldn't be possible for the MGC to Audit with wildcard in order to have
all the TerminationID from the MG?
Is it a too heavy procedure?

Thomas,