Subject: Re: Signal on Root - Re: heart beat message in the megaco protoco l

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 25 Oct 2000 10:22:26 -0400

I'd rather that signals kept what little semantic meaning they still have.
In any event, given that you really want to specify a destination and a
frequency, I would think the sensible approach would be to define a property
rather than a signal.

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Tuesday, October 24, 2000 11:31 PM
> To: [email-masked]
> Subject: Signal on Root - Re: heart beat message in the
> megaco protocol
>
>
> G'Day,
>
> I think Brian has given an alternative when you need to send the heart
> beat between an MGC and MG but not the case where you need the MG to
> send a heartbeat to other devices in a network. To me a signal on the
> root termination of a MG seems to be a good idea. ie.
> Term=root,Signal=heartbeat. The MG would then use the appropriate
> mechanism for it.
>
> Properties, Events, statistics are valid for Root. The text says that
> signals are not valid for root but can any one give a concrete reason
> why this is so?
>
> Cheers, Christian
>
> "Rosen, Brian" wrote:
> >
> > You can construct a NOP ServiceChange sent from MG to MGC.  You can
> > even send an empty NOTIFY I think.  Ping is not a really
> good heartbeat.
> >
> > Brian
> >
> > > -----Original Message-----
> > > From: Susumu YAMAMOTO [mailto:[email-masked]]
> > > Sent: Tuesday, October 17, 2000 2:01 AM
> > > To: [email-masked]
> > > Subject: Re: heart beat message in the megaco protocol
> > >
> > >
> > > Hi all,
> > >
> > > Please let me correct, if I am wrong.
> > >
> > > I think heart beat messages are sent rather from MG than from
> > > MGC, because
> > > in the case of fault of network or MGC only MG can trigger
> > > the failover
> > > operation
> > > to change the MGC and restore the service.
> > >
> > > I would find some mechanism outside of the H248 for heart
> > > beat message from MG,
> > > it may be Ping or something.
> > > (MGC can audit as heart beat messages as below, but there is
> > > no mechanism for
> > >   MG to send in the H.248.)
> > >
> > > ... and any other implementation is there ?
> > >
> > >
> > > >In my current implementation, I am using audits as a means
> > > of acheiving
> > > >heart beats.  The MGC audits the gateways periodically
> > > requesting connection
> > > >ids.  This way, the MGC can also say if it is out of
> > > sequence perhaps, with
> > > >the MG (say, the MG returns a connection id, and the MGC
> > > does not have one
> > > >for that endpoint).
> > > >
> > > >----- Original Message -----
> > > >From: "Christian Groves" <[email-masked]>
> > > >To: <[email-masked]>
> > > >Sent: Sunday, October 15, 2000 10:45 PM
> > > >Subject: Re: heart beat message in the megaco protocol
> > > >
> > > >
> > > > > Hello Susumu San,
> > > > >
> > > > > Currently there is no mechanism for this in H.248. I
> > > thought one way to
> > > > > achieve this would be to send a signal on the Root
> > > Termination of the MG
> > > > > that would be an on/off signal which would generate a
> > > heartbeart message
> > > > > periodically. But unfortunately we can't a signal
> (events are OK
> > > > > though)on the root termination. This may be something we
> > > want to change.
> > > > >
> > > > > I guess you could always provision some mechanism outside
> > > of H.248 also.
> > > > >
> > > > > Cheers, Christian
> > > > >
> > > > > Susumu YAMAMOTO wrote:
> > > > > >
> > > > > > Hi all,
> > > > > >
> > > > > > Is there a heart beat message from MG to MGC in the megaco
> > > > > > protocol?
> > > > > >
> > > > > > If not, how do you think about a heart beat message?
> > > > > >
> > > > > > I think MG always should be able to detect a
> failure of MGC and
> > > > > > restore the service by failover method, because the case of
> > > > > > restart of MGC, MGC may lost which MG is now in service and
> > > > > > cannot send a handoff message properly.
> > > > > >
> > > > > > Thanks in advance,
> > > > > > -*-*-*
> > > > > > YAMAMOTO SUSUMU
> > > > > > Mega-media Network Systems Project
> > > > > > NTT Network Service Systems Laboratories
> > > > > > mailto: [email-masked]
> > > > > > TEL:+81 422 59 2744  FAX:+81 422 37 7467
> > >
> > > -*-*-*
> > > SUSUMU YAMAMOTO
> > > Mega-media Network Systems Project
> > > NTT Network Service Systems Laboratories
> > > mailto: [email-masked]
> > > TEL:+81 422 59 2744  FAX:+81 422 37 7467
> > >
>

---

From: Hsien-Chuen Yu <[email-masked]>
Date: Wed, 25 Oct 2000 12:43:30 -0500

About a year ago, there were some discussions on how to model (or not
to model) a physical interface (e.g., Ethernet interface, ATM OC3c, etc.)
in H.248. A physical interface may have many ephemeral terminations created
on it. In some application, the MGC may need to specify a specific physical
interface on which to create an ephemeral termination. Without the notion
of physical interface, how can this be done? Also when the physical interface
goes down, how does the MG notify the MGC of all the ephemeral terminations
on this interface and not to use this interface to create any new ephemeral
terminations?

Thanks,

Hsien Yu

---

From: Christian Groves <[email-masked]>
Date: Fri, 27 Oct 2000 16:39:40 +1100

G'Day Tom,

Isn't the semantic meaning of signals to send something that is not
directly related to the user plane? And if multiple parameters are
needed for this isn't a signal the best?

A signal could have a frequency parameter, destination and a heart beat
isn't really a user plane function.

But heart beat aside. Why did we limit the root termination from having
a signal?

Cheers, Christian