Subject: Error code for Max no Term in a context exceeded

From: Christian Groves <[email-masked]>
Date: Fri, 20 Oct 2000 11:30:49 +1100

G'Day all,

I had a question of:
In H.248, what Error code should be used to indicate
that a context already has the max number of terminations
in it?

e.g. MG supports a max of 2 terminations per context;
MGC performs an ADD{C1, (T3)} to context C1 which already
has T1 and T2 in it.

I couldn't find a appropriate error code. The closest would be
"Insufficient Resources" but I'm not sure it really covers this case.

As such I propose either an addition to H.248 Annex L or the
implementors' guide with something  like the following text:

Error Code #: 434  Name: Max number of Terminations in a Context
exceeded.
Definition: The MGC has requested that a termination be added or moved
to a context that already contains a maximum number of termination.
Package: -

Cheers, Christian

---

From: John Segers <[email-masked]>
Date: Fri, 20 Oct 2000 11:59:16 +0200

Hi Christian,

Your proposal to add an error code sounds reasonable.

Cheers,

John

> Date:         Fri, 20 Oct 2000 11:30:49 +1100
> Reply-To:     Christian Groves <[email-masked]>
> Sender:       "Media Gateway Control (megaco)"
>               <[email-masked]>
> From:         Christian Groves <[email-masked]>
> Subject:      Error code for Max no Term in a context exceeded
> Content-Type: text/plain; charset=us-ascii
>
> G'Day all,
>
> I had a question of:

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 303
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 20 Oct 2000 07:52:56 -0400

I'd support the additional error message.

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Thursday, October 19, 2000 8:31 PM
> To: [email-masked]