Subject: Action Reply

From: Sankar Raman <[email-masked]>
Date: Tue, 31 Oct 2000 11:18:56 -0500

Referring to the standard:

ActionReply ::= SEQUENCE
{
 contextId ContextID,
 errorDescriptor ErrorDescriptor OPTIONAL,
 contextReply ContextRequest OPTIONAL,
 commandReply SEQUENCE OF CommandReply
}

Under what circumstances we could have both ErrorDescriptor
and SEQ of CommandReply? Why is not ErrorDescriptor Vs
SEQ of CommandReply a CHOICE ?

Thanks

Sankar Raman
Lucent Technologies

---

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 31 Oct 2000 12:02:02 -0600

Commands are executed until the first one fails.  It may therefore be quite
typical to get a series of command results terminated by an errorDescriptor.

> -----Original Message-----
> From: Sankar Raman [mailto:[email-masked]]
> Sent: Tuesday, October 31, 2000 11:19 AM
> To: [email-masked]
> Subject: Action Reply
>
>

---

From: "Tulpule, Naren" <[email-masked]>
Date: Tue, 31 Oct 2000 15:13:07 -0800

Hi Tom, list,
  Please comment.
  ABNF says

transactionReply = ReplyToken EQUAL TransactionID LBRKT [ImmAckRequiredToken
COMMA]
                                ( errorDescriptor / actionReplyList ) RBRKT
actionReplyList  = actionReply *(COMMA actionReply )
actionReply      = CtxToken EQUAL ContextID LBRKT ( errorDescriptor /
commandReply )                                                   RBRKT
commandReply     = (( contextProperties [COMMA commandReplyList] ) /
commandReplyList )
commandReplyList = commandReplys *(COMMA commandReplys )
commandReplys    = (serviceChangeReply / auditReply / ammsReply /
notifyReply )

So there is no option to have a sequence such as
commandReplys1, commandReplys2, commandReplys3, errorDescriptor.
We have to enclose the errorDescriptor in a seperate actionReply.
Same thing has to be done for ASN.1 encoding (two seperate "actionReply"s
for one actionRequest, one with commandReply sequence and one with
errorDescriptor).
When will you see an errorDescriptor FOLLOWED by a sequence of commandReply
(as ASN.1 apparently allows)? I can't think of a situation.

-- Naren.
These views and opinions are mine alone, not those of Intel    (yet ;-)
Narendra C. Tulpule SMTS, Trillium (an Intel company)
Ph: +1-310-442-9222              Fax: +1-310-442-1162
12100 Wilshire Bl #1800         Los Angeles, CA 90025