Subject: Missing/ Empty Audit Descriptor

From: Kapil Nayar <[email-masked]>
Date: Thu, 19 Oct 2000 13:39:06 +0530

Hi

The protocol document mentions:

7.1.1 Specifying Parameters
...
"A missing Audit descriptor is equivalent to an empty Audit Descriptor."

and also

7.1.15 Statistics Descriptor
...
"By default, statistics are reported when the Termination is Subtracted from the
Context.  This behavior can be overridden by including an empty AuditDescriptor
in the Subtract command."

Now, if Subtract command doesnot have an AuditDescriptor it would mean that
there is an empty audit descriptor and no statistics would be reported. And, if
the MGC needs termination statistics, it must send AuditDescriptor with
Statistics token in the Subtract command. But this seems to change the
definition of "By default".

Please clarify whether the above is correct.

-Kapil Nayar
Hughes Software Systems

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 19 Oct 2000 09:24:49 -0400

A subtract command without Audit causes statistics to be sent
A subtract command with an empty Audit causes statistics to be suppressed
Any other command without an Audit results in no Audit information sent
Any other command with an empty Audit results in no Audit information sent

Perhaps 7.1.1 should have a note referencing 7.1.15 like
"A missing Audit descriptor is equivalent to an empty
   Audit Descriptor (but see section 7.1.15)"

Brian

> -----Original Message-----
> From: Kapil Nayar [mailto:[email-masked]]
> Sent: Thursday, October 19, 2000 4:09 AM
> To: [email-masked]
> Subject: Missing/ Empty Audit Descriptor
>
>
> Hi
>

---

From: Alan Whitton <[email-masked]>
Date: Fri, 27 Oct 2000 06:57:23 -0400

Christian,

OK for the neophytes out there like me, you are proposing that if statistics
are NOT asked for in the subtract, they will NOT be sent, correct? (thus no
statistics is the default behavior)?

I am not commenting I'm just making sure I'm getting this straight.

Cheers,
Alan

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Friday, October 27, 2000 2:00 AM
To: [email-masked]
Subject: Re: Missing/ Empty Audit Descriptor

G'Day Tom,

OK. I propose the following:
8.16 Audit Descriptor and Subtract and Statistics

Description:    The protocol document mentions:
7.1.1 Specifying Parameters
...
"A missing Audit descriptor is equivalent to an empty Audit Descriptor."
and also
7.1.15 Statistics Descriptor
...
"By default, statistics are reported when the Termination is Subtracted
from the Context.  This behavior can be overridden by including an empty
AuditDescriptor in the Subtract command."
 According to this text, if Subtract command doesnot have an
AuditDescriptor it would mean that there is an empty audit descriptor
and no statistics would be reported. And, if the MGC needs termination
statistics, it must send AuditDescriptor with Statistics token in the
Subtract command. But this seems to change the definition of "By
default".
Reference:      Subject: Re: Missing/ Empty Audit Descriptor
Date: Thu, 26 Oct 2000 09:37:25 -0400
From:  Tom-PT Taylor <[email-masked]>
To:  [email-masked]
 [Begin Correction]
Section 7.1.1 Specifying Parameters
...
If a required descriptor other than the Audit descriptor is unspecified
(i.e., entirely absent) from a command, the previous values set in that
descriptor for that termination, if any, are retained.  In commands
other than Subtract, aA missing Audit descriptor is equivalent to an
empty Audit Descriptor.  The behavior of the MG with respect to
unspecified parameters within a descriptor varies with the descriptor
concerened, as indicated in succeeding sections.  Whenever a parameter
is underspecified or overspecified, the descriptor containing the value
chosen by the responder is included as output from the command.

[End Correction]

Agreeable?

Cheers, Christian

Tom-PT Taylor wrote:
>
> You are certainly right in your observation.  The statement in 7.1.15 has
> been there from the beginning -- it was inherited from MGCP.  When we
added
> the statement in 7.1.1, we forgot about 7.1.15.  Having an exception for
the
> Subtract command isn't pretty, but I think it is practical.
>
> So the Implementor's Guide has to note the exception in section 7.1.1.
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 27 Oct 2000 08:08:21 -0400

I hope he didn't mean that.  I didn't read it that way.  The corrected text
to 7.1.1
carves out an exception for Subtract on the missing Audit = empty Audit
rule.
The text from 7.1.15 remains, which states statistics are sent on Subtract
unless
an explicit empty Audit is specified.

Brian

-----Original Message-----
From: Alan Whitton [mailto:[email-masked]]
Sent: Friday, October 27, 2000 6:57 AM
To: [email-masked]
Subject: Re: Missing/ Empty Audit Descriptor

Christian,

Cheers,
Alan

-----Original Message-----
From: Christian Groves [ mailto:[email-masked]
<mailto:[email-masked]> ]
Sent: Friday, October 27, 2000 2:00 AM
To: [email-masked]
Subject: Re: Missing/ Empty Audit Descriptor

G'Day Tom,

[End Correction]

Agreeable?

Cheers, Christian

added
the
> > From: Kapil Nayar [ mailto:[email-masked]
<mailto:[email-masked]> ]