Subject: Selection of Termination

From: Hemant Agrawal <[email-masked]>
Date: Mon, 16 Oct 2000 18:38:56 +0530

Hi Tom, Brian & list,
                   w.r.t  a old mails of your for choosing termination on
the basis on Local or Remote Descriptor
" you mentioned
 (1) If the MGC provides too little information in an Add command for the MG
to select the bearer type for that termination, the MG must reject the
command with [appropriate error].  In practice, this means either that the
terminationID in the command provides the necessary information, or else
that at least one instance of a Local or Remote descriptor must be present,
containing a c= line with a specified nettype (or the Annex C equivalent)."

Is the following command  a valid one? what should be the response of this
command? As clear from this command, it is asking for selecting a
termination? And the SDP desc is having two different types of Network AAL2
and AAL5. Should MG select the termination on first SDP desc.

In a command ADD = ${
                            Media{ Stream= 1 {
                                           LocalControl {
                                                    Mode = SendReceive,
                                                    ReservedGroup = ON,
                                                    ReservedValue = ON
                                           },
                                           Local{
                  v=0
                  c =ATM    NSAP  $
                  m= audio $   AAL2/ITU  8
                  .
                  .
                  v = 0
                  c =ATM    NSAP  $
                  m= audio $   AAL5/ITU 0
                  .
                  .
                                      }}} }

As this command gives two choices in the SDP descriptor, either AAL2 type of
AAL1 type termination.  While processing the media descriptor, the value of
RG an RV are ON. that means for both the descriptor, MG has to  reserve the
resources, Is it meaningful to reserve the resources for second sdp desc, If
MG have already chosen the termination of type AAL2.

Please comment!

Thanks!
Hemant Agrawal

__________________________________________________
Hemant Agrawal
GlobeSpan Inc.
Email: [email-masked]
Web: www.globespan.net
Tel: +91 575 4544028 x 121

---

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 26 Oct 2000 08:53:22 -0400

As I see it, the double reservation is an acceptable mode of protocol
behaviour.  What you are really questioning is whether it makes sense for
the MGC to ask for something like this.

> -----Original Message-----
> From: Hemant Agrawal [mailto:[email-masked]]
> Sent: Monday, October 16, 2000 9:09 AM
> To: [email-masked]
> Subject: Selection of Termination
>
>
> Hi Tom, Brian & list,
>                                                     Mode =
> SendReceive,