Subject: Re: heart beat message in the megaco protocol

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 17 Oct 2000 08:19:18 -0400

This sounds like an expensive heartbeat unless the gateway is small.
I'd use something else.

Brian

> -----Original Message-----
> From: Manish Rao [mailto:[email-masked]]
> Sent: Monday, October 16, 2000 12:25 PM
> To: [email-masked]
> Subject: Re: heart beat message in the megaco protocol
>
>
> In my current implementation, I am using audits as a means of
> acheiving
> heart beats.  The MGC audits the gateways periodically
> requesting connection
> ids.  This way, the MGC can also say if it is out of sequence
> perhaps, with
> the MG (say, the MG returns a connection id, and the MGC does
> not have one
> for that endpoint).
>
> ----- Original Message -----
> From: "Christian Groves" <[email-masked]>
> To: <[email-masked]>
> Sent: Sunday, October 15, 2000 10:45 PM
> Subject: Re: heart beat message in the megaco protocol
>
>
> > Hello Susumu San,
> >
> > Currently there is no mechanism for this in H.248. I
> thought one way to
> > achieve this would be to send a signal on the Root
> Termination of the MG
> > that would be an on/off signal which would generate a
> heartbeart message
> > periodically. But unfortunately we can't a signal (events are OK
> > though)on the root termination. This may be something we
> want to change.
> >
> > I guess you could always provision some mechanism outside
> of H.248 also.
> >
> > Cheers, Christian
> >
> > Susumu YAMAMOTO wrote:
> > >
> > > Hi all,
> > >
> > > Is there a heart beat message from MG to MGC in the megaco
> > > protocol?
> > >
> > > If not, how do you think about a heart beat message?
> > >
> > > I think MG always should be able to detect a failure of MGC and
> > > restore the service by failover method, because the case of
> > > restart of MGC, MGC may lost which MG is now in service and
> > > cannot send a handoff message properly.
> > >
> > > Thanks in advance,
> > > -*-*-*
> > > YAMAMOTO SUSUMU
> > > Mega-media Network Systems Project
> > > NTT Network Service Systems Laboratories
> > > mailto: [email-masked]
> > > TEL:+81 422 59 2744  FAX:+81 422 37 7467
>

---

From: Manish Rao <[email-masked]>
Date: Tue, 17 Oct 2000 09:32:54 -0700

Well, the MGC only sends the heart beat audits out when it hasnt heard from
the gateway over a specified period of time.  This is usually when all ports
on the gateway are idle (in which case it really is not that expensive as no
voice/H.248 traffic is going on), or all ports have active calls or are
performing operations which do not need communication with the MGC for a
long duration--the specified period (in which case I still dont think its
that expensive).  As for the gateway, I really dont have a heart beat from
the MG to the MGC.  When a message needs to be delivered from the MG to the
MGC--I have a UDP implementation by the way--and my number of retransmits
has reached 1/2 MAX_RETRANSMITS, I begin to inquire about alternate MGCs
(from the primary MGC), so that as soon as MAX_RETRANSMITS has been reached,
the message is immediately transfered over to the alternate MG.  This has
seemed to work, and the result is that you have at most one or 2 calls that
are delayed because of the retransmits.  What I do need to implement is for
the primary MGC to detect that any one of the MGCs has failed, and then
contact that MGs associated with the failed MGC to be transfered over to a
new MGC.  Well, this is my implementation, and any comments would be
appreciated.  Hope this helps,

Manish Rao
Software Engineer
Cirilium Corporation
[email-masked]

---

From: Paddu Melanahalli <[email-masked]>
Date: Tue, 17 Oct 2000 09:48:09 -0700

What in the case of megaco supporting ip-redundant configuration?
In my opinion, sooner we detect the ip connectivity failures better
we can service & improve call failure rates.

I think we need to run a sort of heartbeat all the times
at the provisioned intervals.
~Paddu

--
                Enthusiasm
You can do anything... if you have Enthusiasm.
Enthusiasm is the yeast makes your hopes rise to the stars.
Enthusiasm is the sparkle in your eyes.
Enthusiasm   with it there is accomplishment,
                       without it there are only alibis
                                     --- Henry Ford's motto
________________________________________________________

Paddu Melanahalli,  Cisco Systems, NSSU
Voice:(408)525 5236 Fax: (408)527 1568  Pgr:(408)788 8275
Email: [email-masked]
________________________________________________________