Subject: Question about Megaco AuditValue Command

From: Hai Nguyen <[email-masked]>
Date: Fri, 27 Oct 2000 16:11:23 -0500

Hi all,
I have a question about the Megaco AuditValue Command.
My understanding from reading the Megaco specs is that an MGC can audit an
MG by sending an AuditRequest
transaction including an AuditValueToken to MG. Then, MG will send back an
AuditAccept transaction,
putting results in an auditReturnParameter. Is that right?

What if MG wants to audit status of some resources in MGC? Can MG send an
AuditRequest
transaction to MGC?

Do you know where I can find some examples about Megaco Audit commands? The
current specs has examples for other commands such as Add or Modify, but it
does not
include any examples for audit.

Your info is very much appreciated.

Regards,

Hai Nguyen

> Samsung Telecommunications America, Inc.
> 1130 E. Arapaho Road
> Richardson, Texas 75081
> Office 972-761-7703  Fax 972-761-7799
> E-Mail: [email-masked]
>
>
>
>
>
>
>
>
>
>
>
>
>
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 27 Oct 2000 17:35:07 -0400

Yes you have it right.
A request might look like:
Context=1122{AuditValue=termA{Audit{Packages}}}
and the reply might look like
Context=1122{AuditValue=termA{Packages{aaa,bbb,ccc}}}

The MG cannot audit resources of the MGC.  The way the protocol
works, the MG is relatively dumb, and the MGC is relatively smart,
and the MG can't ask the MGC for much other than ServiceChange.

Brian

> -----Original Message-----
> From: Hai Nguyen [mailto:[email-masked]]
> Sent: Friday, October 27, 2000 5:11 PM
> To: [email-masked]
> Subject: Question about Megaco AuditValue Command
>
>
> Hi all,