Subject: Local control descriptor

From: "Tulpule, Naren" <[email-masked]>
Date: Thu, 19 Oct 2000 11:41:58 -0700

Hi list,
  can the local control descriptor have more than one property parm? If yes,
what is the meaning of "at-most-once per item" in the production for
localParm?

-- Naren.
These views and opinions are mine alone, not those of Intel    (yet ;-)
Narendra C. Tulpule SMTS, Trillium (an Intel company)
Ph: +1-310-442-9222              Fax: +1-310-442-1162
12100 Wilshire Bl #1800         Los Angeles, CA 90025

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 19 Oct 2000 15:14:00 -0400

> can the local control descriptor have more than one
> property parm?
Yes

> what is the meaning of "at-most-once per item" in the production for
It means that any one parameter can only occur once in the descriptor.

Brian

---

From: "Tulpule, Naren" <[email-masked]>
Date: Thu, 19 Oct 2000 12:22:48 -0700

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]

Yes

Brian

[[NAREN]]
But ABNF doesn't fix the order of localParm components. So if I understood
your response correctly, we can have only one stream mode, only one reserved
value mode, only one reserved group mode but multiple property parameters
(each with a different pkgdName), something like
localControl { a/b = 1, c/d = 2, mode = sendonly, e/f = 3, reservedGroup =
OFF, g/h > 4, ... }
Is that right?

-- Naren.

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 19 Oct 2000 15:40:04 -0400

> [[NAREN]]
> But ABNF doesn't fix the order of localParm components. So if
Yes, order is NOT restricted

> I understood
> value mode, only one reserved group mode
yes

> but multiple
> property parameters
Well, close.  There is no restriction that you have different
pkgdNames, so you can set a/a1, a/a2 and a/a3 in the same localControl
descriptor, for example.

What you can't do is set a/a2 more than once in the same descriptor.

Brian