Subject: Re: wildcarded termination in Move

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 19 Oct 2000 10:02:42 -0400

Woops, sorry, didn't pay close enough attention.  Your example has TWO
RTP streams and no physical terminations.  Unusual, but legal.

Well, I'm stuck.  I can think of stupid things to do, but nothing
that looks useful.  Maybe a change is warranted.  

Need other opinions on allowing Context=${Move=...

Brian

> -----Original Message-----
> From: CHAPRON Jean-Emmanuel FTRD/DAC/ISS
> [mailto:[email-masked]]
> Sent: Thursday, October 19, 2000 9:45 AM
> To: [email-masked]
> Subject: Re: wildcarded termination in Move
> 
> 
> I don't understand your solution: T1 is an ephemeral 
> Termination: its TermID
> is not provisionned in the MG. As soon as T1 is subtracted from C1, it
> disappears, and its TermID too. How can the MGC re-use this 
> TermID to add it
> to a new Context?
> Can the MGC set the TermID of an ephemeral Termination when 
> it creates it? 
> 
> 
>                ```
>               (o o)
> ----------oOO--(_)-OOo--------------
> Jean-Emmanuel CHAPRON
> FRANCE TELECOM R&D
> DAC/ACE
> 38-40 rue du général Leclerc
> 92794 Issy-les-Moulineaux Cedex 9 - France
> Tel: +33 1 45 29 64 50
> -------------------------------------
> 
> 
> 
> > -----Message d'origine-----
> > De : Rosen, Brian [mailto:[email-masked]]
> > Envoyé : jeudi 19 octobre 2000 15:34
> > À : 'CHAPRON Jean-Emmanuel FTRD/DAC/ISS';
> > [email-masked]
> > Objet : RE: wildcarded termination in Move
> > 
> > 
> > I may be finessing the answer but
> >    Context=1{Subtract=T1....
> >    Context=${Add=T1...
> > gets you an equivalent
> > 
> > Brian
> > 
> > > -----Original Message-----
> > > From: CHAPRON Jean-Emmanuel FTRD/DAC/ISS
> > > [mailto:[email-masked]]
> > > Sent: Thursday, October 19, 2000 5:02 AM
> > > To: [email-masked]
> > > Subject: Re: wildcarded termination in Move
> > > 
> > > 
> > > Hello Brian, all
> > > 
> > > If things are left as they are, it seems that the case 
> > > described below is
> > > simply impossible:
> > > 
> > > (1)
> > >              | 
> > +-------------------------------------------------+  | 
> > >              | |Context C1                                  
> >      |  | 
> > >              | |  +-------------+                
> > +-------------+ |  | 
> > >              | |  | (Term. T1)  |   +-----+      | (Term. 
> > T2)  | |  | 
> > >            <-+--->| RTP Stream  |---|  *  |------| RTP Stream 
> > >  |<---+-> 
> > >              | |  +-------------+   +-----+      
> > +-------------+ |  | 
> > >              | 
> > +-------------------------------------------------+  | 
> > > (2)
> > > 
> > >              | 
> > +-------------------------------------------------+  | 
> > >              | |Context C1                                  
> >      |  | 
> > >              | |  +-------------+                             
> > >        |  | 
> > >              | |  | (Term. T1)  |   +-----+                 
> >      |  | 
> > >            <-+--->| RTP Stream  |---|  *  |                 
> >      |  |
> > >              | |  +-------------+   +-----+                 
> >      |  | 
> > >              | 
> > +-------------------------------------------------+  | 
> > >              | 
> > +-------------------------------------------------+  | 
> > >              | |Context C2                                  
> >      |  | 
> > >              | |                                 
> > +-------------+ |  | 
> > >              | |                    +-----+      | (Term. 
> > T2)  | |  | 
> > >              | |                    |  *  |------| RTP Stream 
> > >  |<---+-> 
> > >              | |                    +-----+      
> > +-------------+ |  | 
> > >              | 
> > +-------------------------------------------------+  | 
> > > 
> > > 
> > > C2 didn't exist in (1). How to go from (1) to (2)?
> > > - We can't use a MOVE $ (too bad..)
> > > - we can't  use Context = $ {Add = T2} because T2 is in a 
> > > non-NULL context
> > > - we can't use "Subtract/Add" because we have only RTP 
> > > Terminations we don't
> > > want to remove.
> > > 
> > > This is not a textbook case, as far as this case may occur 
> > if the Call
> > > Server/MGC is connected to the IN and receives, for 
> > instance, an INAP
> > > "SplitLeg" message requiring such an handling of connections.
> > > 
> > > Regards,
> > > 
> > > 
> > >                ```
> > >               (o o)
> > > ----------oOO--(_)-OOo--------------
> > > Jean-Emmanuel CHAPRON
> > > FRANCE TELECOM R&D
> > > DAC/ACE
> > > 38-40 rue du général Leclerc
> > > 92794 Issy-les-Moulineaux Cedex 9 - France
> > > Tel: +33 1 45 29 64 50
> > > -------------------------------------
> > > 
> > > 
> > > 
> > > > -----Message d'origine-----
> > > > De : Rosen, Brian [mailto:[email-masked]]
> > > > Envoyé : mercredi 18 octobre 2000 15:01
> > > > À : [email-masked]
> > > > Objet : Re: wildcarded termination in Move
> > > > 
> > > > 
> > > > Ya, that's one of the reasons it's probably there - separating
> > > > functions of Move and Add.
> > > > 
> > > > Probably best to leave things as they are.
> > > > 
> > > > Brian
> > > > 
> > > > > -----Original Message-----
> > > > > From: [email-masked] [mailto:[email-masked]]
> > > > > Sent: Wednesday, October 18, 2000 8:29 AM
> > > > > To: Rosen, Brian
> > > > > Cc: [email-masked]
> > > > > Subject: Re: wildcarded termination in Move
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > Hi
> > > > >
> > > > > If you remove this restriction then why you need Move, i will
> > > > > always use Add to
> > > > > either:
> > > > > 1. Add a termination to a context from null context
> > > > > 2. Move (read it as Add) a termination to a context from a
> > > > > non-NULL context.
> > > > >
> > > > > -Kapil Nayar
> > > > > Hughes Software Systems
> > > > >
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > "Rosen, Brian" <[email-masked]> on 10/18/2000 
> > 05:31:06 PM
> > > > >
> > > > > Please respond to "Rosen, Brian" <[email-masked]>
> > > > >
> > > > > To:   [email-masked]
> > > > > cc:    (bcc: Kapil Nayar/HSS)
> > > > >
> > > > > Subject:  Re: wildcarded termination in Move
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > Only Add can create a new context:
> > > > >   "In general, an Add command is used to add Terminations 
> > > > to Contexts.
> > > > >    If the MGC does not specify an existing Context to 
> which the
> > > > >    Termination is to be added, the MG creates a new 
> Context.  "
> > > > >
> > > > > A way to do the consultation hold is to create the new 
> > > context with
> > > > > C and move A to that Context.
> > > > >
> > > > > I'll note that I was a little surprised to read:
> > > > > "The Termination is either created, or taken from the 
> > > null Context"
> > > > > (although I may have wrote it!), since this prohibits 
> an Add of
> > > > > a termination already in another context.  I'm not sure why we
> > > > > prohibit that.  I do think there is little practical 
> > difficulty in
> > > > > keeping that restriction.  If we did relax that 
> restriction, you
> > > > > could do Context=${Add=A{....
> > > > >
> > > > > Brian
> > > > >
> > > > > > -----Original Message-----
> > > > > > From: Chanchal Hassija [mailto:[email-masked]]
> > > > > > Sent: Wednesday, October 18, 2000 12:40 AM
> > > > > > To: [email-masked]
> > > > > > Subject: Re: wildcarded termination in Move
> > > > > >
> > > > > >
> > > > > > Hi Brian,
> > > > > >
> > > > > > If you mean to say that Move with ContextID = $ is
> > > > > > nonsensical --- I beg to
> > > > > > differ......
> > > > > >
> > > > > > Consider a simple call scenario -- A is talking to 
> B..... and
> > > > > > now A wants to put
> > > > > > B on hold and call up C......The simplest way to do 
> it as per
> > > > > > my understanding
> > > > > > would be -- MGC shall tell MG to Move A to a new context
> > > > > > (Move - ContextID=$ and
> > > > > > TermID = A) where it shall talk to C, and once it is done,
> > > > > > move it back to the
> > > > > > context where it was talking to B......
> > > > > >
> > > > > > What is your opinion about this....
> > > > > >
> > > > > > Thanks
> > > > > > Chanchal....
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > "Rosen, Brian" <[email-masked]> on 10/17/2000 
> > > 05:57:41 PM
> > > > > >
> > > > > > Please respond to "Rosen, Brian" <[email-masked]>
> > > > > >
> > > > > > To:   [email-masked]
> > > > > > cc:    (bcc: Chanchal Hassija/HSS)
> > > > > >
> > > > > > Subject:  Re: wildcarded termination in Move
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > > If there are three terminations in an MG
> > > > > > > abcd
> > > > > > > abce
> > > > > > > xyz.
> > > > > > > Say abcd  is in Context ID = 1 and both abce and xyz is in
> > > > > > > NULL Context.
> > > > > > > If MGC says Move with ContextID = $ and 
> termination as abc*,
> > > > > > > what should the
> > > > > > > MG do
> > > > > > First of all, I think this is illegal, or at least 
> > nonsensical.
> > > > > > You CAN'T create a new contextId with CHOOSE.
> > > > > > So if it is legal, you are asking for Russian 
> Roulette - pick
> > > > > > a context where the resulting command would be legal, 
> > and do it.
> > > > > > If there is more than one, then it's random which one
> > > > > >
> > > > > > > 1. Consider abce while resolving wildcarded abc* -
> > > > > > >  Move is valid for abcd (it's in non-NULL context) and 
> > > > invalid for
> > > > > > > abce (move is not allowed to move from and to a 
> > NULL Context)
> > > > > > abcd is valid, abce is not valid
> > > > > >
> > > > > > > 2. Don't consider terminations in NULL Context 
> for resolving
> > > > > > > wildcard since
> > > > > > > the basic idea is not to Move to or from NULL Context.
> > > > > > This is correct
> > > > > >
> > > > > > >
> > > > > > > The first option has an impact on further commands in the
> > > > > > > transaction since a
> > > > > > > failure
> > > > > > > with one command can cause the side effect of 
> other commands
> > > > > > > being not executed.
> > > > > > True, but in general if the MGC was foolish enough 
> to do this,
> > > > > > it deserves what it gets.
> > > > > >
> > > > > > Brian
> > > > > >
> > > > >
> > > > >
> > > > >
> > > > >
> > > > >
> > > > >
> > > > 
> > > 
> > 
>

---

From: Christian Groves <[email-masked]>
Date: Fri, 20 Oct 2000 11:01:43 +1100

G'Day all,

I'm really confused now, taking sentences out of context (pardon the
pun) can add a little confusion.

The MOVE command chapter in H248 doesn't not prohibit moving a
termination to Context "?". It mentions target Context ID.

The Context chapter says:
"In general, an Add command is used to add Terminations to Contexts."
and the sentence after:
"If the MGC does not specify an existing Context to which the
Termination is to be added, the MG creates a new Context.talks about
that if Context "?" is specified then a context ID is provided."

The "In general" statement cited below is in the sentence about a
termination "?" and an ADD command.

The "If the MG...." statements talks about Context "?".

MOVE Context "?", ta seems to me to be a fundamental part of what we
defined and I don't see where this is disallowed. To clarify things at
most you could put a CR linefeed after the in general sentence above.

Cheers, Christian