Subject: DigitMap range definition ambiguity?

From: Dave Sclarsky <[email-masked]>
Date: Thu, 26 Oct 2000 14:39:47 -0400

Hi List,

Reference:
digitLetter = *((DIGIT "-" DIGIT ) / digitMapLetter)

Is this definition ambiguous?  I couldn't find any text
in the document that explicitly defines "-", or provides
rules about the relative values of the two DIGITs.
For example, is [2-0] legal?

I think that the intent is probably clear, but that maybe
it deserves some clarification (implementor's guide?)

============================
Dave Sclarsky
System Architect, Access Technology
S-Link Corporation
520 Fellowship Road, Suite C-304
Mt. Laurel, NJ 08054
[email-masked]
voice:856.642.9229x231 fax:856.642.0252
www.ss7-link.com

---

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 26 Oct 2000 18:29:08 -0400

Right, no text.  One of those things so familiar you forget to document it.
Anyway, since it means "all digits in this range", ordering doesn't matter.

> -----Original Message-----
> From: Dave Sclarsky [mailto:[email-masked]]
> Sent: Thursday, October 26, 2000 2:40 PM
> To: [email-masked]
> Subject: DigitMap range definition ambiguity?
>
>
> Hi List,
>
> Reference:

---

From: Dave Sclarsky <[email-masked]>
Date: Thu, 26 Oct 2000 18:39:16 -0400

So [2-0] is the same as [0-2]?

---

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 26 Oct 2000 19:07:07 -0400

Yes.  It says: "match any of 0, 1, or 2".

> From: Dave Sclarsky [mailto:[email-masked]]
> Sent: Thursday, October 26, 2000 6:39 PM
> To: Taylor, Tom-PT [NORSE:B901:EXCH];
> [email-masked]
> Subject: RE: DigitMap range definition ambiguity?
>
>