Subject: Re: Notify command generation.

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 17 Oct 2000 08:13:40 -0400

This is a suggestion for MG implementation.  Perhaps some rewording
would be helpful.  The intent is to suggest that the MG not send
a Notify if it has already sent one, but it has not gotten a reply.
A single transaction with multiple Notifies, even on the same
termination, is okay.  The reason is that with UDP transport, out of
order Notifies could cause the MGC to get confused.

Brian

> -----Original Message-----
> From: Madhu Babu [mailto:[email-masked]]
> Sent: Monday, October 16, 2000 8:32 AM
> To: [email-masked]
> Subject: Notify command generation.
>
>
> In section 9.1 its mentioned that "On a given Termination,
> there should normally be at most one
> outstanding Notify command at any time."
>
>
> Is this a suggestion for an MG implementation?
> When MGC enabled multiple events then why to restrict multiple
> notify generations in case multiple events are reported (with a
> very small time difference)?
>
> -Madhubabu
>

---

From: Christian Groves <[email-masked]>
Date: Wed, 18 Oct 2000 07:23:13 +1100

G'Day Brian,

I agree that this is a little misleading as there may be many events
present. Perhaps in the Implementor's Guide we should just strike the
sentence? The UDP problem of un-ordered response is described elsewhere.

Cheers, Christian