Subject: Differences between ABNF and ASN.1 specifications

From: Terry L Anderson <[email-masked]>
Date: Tue, 31 Oct 2000 13:41:21 -0500

I notice two differences between the ABNF and ASN.1 specifications and I
am wondering if these are intentional or errors.

1. In ASN.1
AmmRequest {
    terminationID    TerminationIDList,
    etc.
while in ABNF
ammRequest contains TerminationID rather than TerminationIDList

TerminationID in both cases can contain wildcards and so be effectively
a list, but the ASN.1 would allow a list of specific ids while the ABNF
would not.  Is this intentional?

2. earlier today Sankar Raman asked about ActionReply.  In the ASN.1
ActionReply contains
commandReply    SEQUENCE OF CommandReply
which is required and a
contextReply which is optional
while in the ABNF
an ActionReply that contained an errorDescriptor cannot contain either a
contextProperties or a commandReplyList

Is this intentional? Perhaps since SEQUENCE OF can be of zero length so
not really contain a CommandReply, but there is still the minor
difference that the ASN.1 permits a contextProperties and a commandReply
while the ASN.1 does not.

--
------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Pager:800.759.8352 pin 1704572   [email-masked]
Lucent Technologies/ Voice Over IP Access Networks/ Applications Grp
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Troy Cauble <[email-masked]>
Date: Tue, 31 Oct 2000 13:51:58 -0500

> would not.  Is this intentional?

See the second "NOTE" at the beginning of
section A.2.  Most of the TerminationIDLists
in the ASN.1 encoding are lists of one.

(Why is that?)

-troy