Subject: Re: Modify the service state property

From: Madhu Babu <[email-masked]>
Date: Thu, 19 Oct 2000 19:04:41 +0530

I believe that the ServiceState values
outofservice and inservice are not
settable directly my MGC and only indicate
the current state that can be modified
using SerivceChange. This seems to make
ServiceState property as "read-only" type for
these two values. But then what about "test" value ?

-Madhubabu

"Rosen, Brian" <[email-masked]> on 10/19/2000 07:04:09 PM

To:   Madhu B Babu/HSS@HSS, [email-masked]
cc:

Subject:  RE: Modify the service state property

I'd say yes, but I'd recommend not doing it that way.

Brian

> -----Original Message-----
> From: Madhu Babu [mailto:[email-masked]]
> Sent: Thursday, October 19, 2000 7:01 AM
> To: [email-masked]
> Subject: Modify the service state property
>
>
> Is the changing of ServiceState of a termination
> directly from inservice to outofservice and
> vice-versa allowed in say a Modify?
>
> Is this equivalent in functional operation to a ServiceChange
> on that termination?
>
> -Madhubabu
>

---

From: Christian Groves <[email-masked]>
Date: Fri, 20 Oct 2000 10:30:31 +1100

I'll agree with Brian on service state. I believe that the MGC can
manipulate the state in the Termination State Descriptor. I don't see
any compelling reason to now make it read only.

Cheers, Christian