Subject: Re: continuity test

From: Alan Whitton <[email-masked]>
Date: Wed, 25 Oct 2000 12:42:46 -0400

On Mon, 16 Oct 2000 11:52:57 +0300, Shlomo Kabaz ECItelecom
<[email-masked]> wrote:

>Hello all !
>
>Are  the  tones in the continuity test  permanent or  do they change ?
>
>Thanks , Shlomo .

Shlomo,

Have a look at GR 317 in section 3.1.1.3 it explains COT in all of it's
archane (sp?) and nasty glory!

The question you ask is many fold depending on whether you are doing only a
standard loopback or whether your gateway has to do TONING.... yikes!

Cheers,
Alan

---

From: Al Varney <[email-masked]>
Date: Wed, 25 Oct 2000 16:25:49 -0500

>archane (sp?) and nasty glory!

   Assuming you are talking about an SS7 ISUP continuity test (and I don't believe H.248 is explicitly limited to that -- Q.931 also supports a loopback test), a preferred reference is Q.724 (TUP), Section 7 (digital circuits) and Section 8 (for 2-wire speech circuits).  The ITU-T Q.764 ISUP procedures reference Q.724 for this test.  The US/Canadian reference is Committee T1 standard ANSI T1.113.  If you have GR-317 from Telcordia, it does do a little better job of describing the procedure (IMHO), but it limits operation to the "single report" method.

>standard loopback or whether your gateway has to do TONING.... yikes!

   In the digital case (Section 7 of Q.724), the node doing "standard loopback" (node receiving the continuity request) is only expected to echo back any received PCM octets.  It does not, and should not, care if the transmitting end is sending the recommended tone nor do any detection of whether tone was received and for how long it might persist.  The success/failure determination is made ONLY by the transmitting node.  A side effect of using other that the standard tone is that dual seizure situations (glare) can report failures, so standard tone are recommended.

   A common error in many past implementations was to stop the loop-back based on detection of tone or expiration of a 2-second timer at the loop-back end -- the loop-back should persist until the transmitting end determines test success/failure or the guard timer (T1) expires.

   In the analog case (Section 8 of Q.724), standard tones must be used, since each end both detects and sends (different) tones.  But the requesting node still determines success/failure/tone duration for the test.

Al Varney - Lucent Technologies  +1 630 224-7493    [email-masked]