Subject: Stopping a signal of type on/off

From: Sachin Mittal <[email-masked]>
Date: Wed, 1 Nov 2000 16:05:36 +0530

Section E.10.3 defines ct/rsp as type on/off and the procedure of section E.10.5
says
"When the MGC wants the MG to respond to a continuity test it sends a command to
MG
containing a signals descriptor with ct/rsp ......"
and for stopping it says "The MGC determines when to remove the rsp signal...."

But how to remove a signal of type on/off:
1. By sending a signal descriptor NOT containing the signal.
2. By sending a signal descriptor containing the signal.

Moreover, if an on/off type signal is active and an event occurs,
is the signal stopped (Keepactive not specified)?

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 1 Nov 2000 07:46:09 -0500

> 2. By sending a signal descriptor containing the signal.
Choice 1
   "A new SignalsDescriptor replaces any existing SignalsDescriptor.
   Any signals applied to the Termination not in the replacement
   descriptor shall be stopped, and new signals are applied, except as
   follows."
> is the signal stopped (Keepactive not specified)?
Yes

Brian

---

From: Alan Whitton <[email-masked]>
Date: Wed, 1 Nov 2000 14:50:05 -0500

Greetings,

I am keenly interested in this one. How exactly would the message flow look
like?

Let me have a hack first, and we'll do this as part of an ADD (just to be
different):

From Controller TO Gateway --->
Transation = TransactionID1 {
  Context= $ {
    Add = TDMTermID {
      Termstate
        {
         TDMC/ec = off
        }
    },
    EVENTS = eventID1
        { CT/CMP },
    SIGNALS = {CT/CT}
  }
}

From Gateway to Controller <---
Reply = TransactionID1
{
  Context = ContextID {
    Add=TDMTermID
  }
}

Thus our happy loopback COT test is now in place, and running on TDM
connection TDMTermID, correct?

Now the gateway wants to tell the controller that the test was passed
correctly, so we have:
From Gateway to Controller <---
Transaction = TransactionID5 {
  Context = ContextID {
    Notify = TDMTermID
      { ObservedEvents = eventID1
         { CT/CMP {RES = 1} }
      }
  }
}

From Controller to Gateway --->
Reply = TransationID5{ Context = ContextID { Notify = TDMTermID }}

Correct? Thus the Controller "knows" that the test has completed correctly.
If the controller is simply now either doing a MODIFY to this context
to "continue" the call, or a SUBTRACT to end the call, does it need to do
anything to STOP the toning? I don't think so.

Comments?

Cheers,
Alan Whitton