Subject: Basic Question on Audit

From: Kris Albert <[email-masked]>
Date: Mon, 27 Nov 2000 02:47:44 -0800

Hi all,
     In case of Add command, In general the MG applies the desciptor present in the command to the termination after adding it into context.
       The audit descriptor if present in  Add command should be processed.
   1. As it comes in the descriptor order.
   2. Before adding the termination into the context.
   3. After adding the termination into context and after applying all other descriptors.

Please tell me which option is valid.

Thanks,
Kris

Get FREE Email/Voicemail with 15MB at Lycos Communications at http://comm.lycos.com

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 27 Nov 2000 09:45:16 -0500

I believe that specific behavior is undefined (there is no
implied order of descriptor processing).  I would, if I were
implementing an MG, do it in descriptor order, which I believe
would be AFTER the actual Add was done.

On the other hand, I wouldn't expect this behavior if I was
implementing an MGC, and thus would do the audit either before,
or after the Add, depending on what I wanted.

Brian

> -----Original Message-----
> From: Kris Albert [mailto:[email-masked]]
> Sent: Monday, November 27, 2000 5:48 AM
> To: [email-masked]
> Subject: Basic Question on Audit
>
>
> Hi all,
>      In case of Add command, In general the MG applies the
> desciptor present in the command to the termination after
> adding it into context.

---

From: Tom Taylor <[email-masked]>
Date: Wed, 29 Nov 2000 15:09:34 -0500

>would be AFTER the actual Add was done.

[PTT] Actually, section 7.2 says that descriptors are processed in the order they are encountered.