Subject: Re: Signal lists

From: Kris Albert <[email-masked]>
Date: Wed, 1 Nov 2000 22:27:23 -0800

Hi Christian,
     I have few questions on your explanation.

> [CHG] I guess you can view this is several ways. The KeepActive on ALL
> signals certainly makes sense when you don't want any interruption. But
> is it erroneous to specify Keepactive on different signals? Certainly
> weird behaviour but you may want the initial part of a message to play
> irrespective of what event happens and you don't care about the rest of
> the signal. I would say that the Keepactive pertains to a moment in time
> in the playback of a message.
> ie. Signal list  = (s1ka, s2, s3, s4ka)
> If you receive an event when S1KA is playing the whole list plays.
> If you receive an event when S2 is playing the whole list stops.

I am not able to understand your example here.
It is specified in MEGACO that " Normally, recognition of an event shall cause any active signals to stop. When KeepActive is specified in the event, the MG shall not interrupt any signals active on the Termination on which the event is detected."

how does the 'KeepActive' status of signals matter here. Only KeepActive Flag associated with Event Defination should be considered. Otherwise Event Defination should have a embedded Signal Descriptor.

I will appriciate if you please further explain your example w.r.t.  the arrival of new signal descriptor with the same Signal list.

Always,
Kris

Get FREE Email/Voicemail with 15MB at Lycos Communications at http://comm.lycos.com

---

From: "Taylor, Tom-PT" <[email-masked]>
Date: Thu, 2 Nov 2000 07:35:07 -0500

Signals can also have a KeepActive flag.

> -----Original Message-----
> From: Kris Albert [mailto:[email-masked]]
> Sent: Thursday, November 02, 2000 1:27 AM
> To: [email-masked]
> Subject: Re: Signal lists
>
>
> Hi Christian,
> It is specified in MEGACO that " Normally, recognition of an
> event shall cause any active signals to stop. When KeepActive
> is specified in the event, the MG shall not interrupt any
> signals active on the Termination on which the event is detected."
>
> how does the 'KeepActive' status of signals matter here. Only
> KeepActive Flag associated with Event Defination should be
> considered. Otherwise Event Defination should have a embedded
> Signal Descriptor.
>
> I will appriciate if you please further explain your example
> w.r.t.  the arrival of new signal descriptor with the same
> Signal list.
>
>
> Always,
> Kris
>
>
>

---

From: Kris Albert <[email-masked]>
Date: Thu, 2 Nov 2000 04:57:08 -0800

-----
> Signals can also have a KeepActive flag.

That's true, but my question is different, I want to ask whether on the detection of event, do we process  only the KeepActive flag associated with Events, or do we also consider the KeepActive flag associated with the active Signals.

thanks
Kris

---

From: "Taylor, Tom-PT" <[email-masked]>
Date: Thu, 2 Nov 2000 08:06:13 -0500

You process both.  The obvious algorithm is:
 1) Check for event flag.  If there is one, leave signals playing.
 2) Otherwise check flag for each signal and keep playing or terminate as
indicated.

> From: Kris Albert [mailto:[email-masked]]
> Sent: Thursday, November 02, 2000 7:57 AM
> To: Taylor, Tom-PT [NORSE:B901:EXCH]
> Cc: [email-masked]
> That's true, but my question is different, I want to ask
> whether on the detection of event, do we process  only the
> KeepActive flag associated with Events, or do we also
> consider the KeepActive flag associated with the active Signals.
>
> thanks
> Kris
>
> >

---

From: Sandeep Gautam <[email-masked]>
Date: Thu, 2 Nov 2000 19:10:14 +0530

Hi,
The keepactive flag that comes in the signals descriptor is not remebered. The
fact whether the currently playing signal arrived with a keepcative flag or not
is immaterial for subsequent processing.

According to text

Signals present in the replacement descriptor and    containing the KeepActive
flagshall be continued if they are    currently playing and have not already
completed.  If a replacement    signal descriptor contains a signal that is not
currently playing    and contains the KeepActive flag, that signal SHALL be
ignored

Thus the scope of keepactive flag is limited to the signal descriptor processing
of the descriptor in which it arrived.

When subsequently an event is detected the stopping of the signal( which may
have arrived with a keepactive flag) is solely governed by the keepactive flag
associated with the event that is detected. Thus point no. 2 is invalid. If the
KA of event detected is not set then the MG should stop application of all
active signals.

Is this understanding correct?
Regards,
Sandy G

---

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 2 Nov 2000 10:23:39 -0500

I stand corrected and apologize for my carelessness.  You're right.  So the
only thing that determines whether the signal list keeps playing is the
keepActive setting (or embedded SignalsDescriptor) in the event itself.

> From: Sandeep Gautam [mailto:[email-masked]]
> Sent: Thursday, November 02, 2000 8:40 AM

---

From: Sandeep Gautam <[email-masked]>
Date: Thu, 2 Nov 2000 21:18:16 +0530

I think the question on which there can be confusion is what happens when the
embedded signals descriptor( invoked by event detection) contains the currently
active signal with the KA flag set?
If the processing of embedded descriptor is supposed to happen after the action
for event detection has been taken ; then If the event 's KA is not set we
should stop the signal.
But if the processing of embedded signals descriptor is done simultaneously( or
lets say before event detection processing) , then if the KA for any of the
active signal  is set in the embedded signals descriptor ( i.e. embedded signal
descriptor carries an active signal with KA set), then we should also take this
in account . In other words stop signals using  signals descriptor invocation
logic rather than event detection logic.

Any views?

Regards,
Sandy G

---

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 2 Nov 2000 10:08:47 -0600

I would favour the second interpretation -- that the fate of active signals
depends on what is in the embedded SignalsDescriptor.  Not sure this is a
real argument, but syntactically the embedded SD is an alternative to the
event KeepActive flag.

> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, November 02, 2000 10:48 AM
> Cc: [email-masked]
> Subject: RE: Signal lists
>
>
>
>

---

From: Sandeep Gautam <[email-masked]>
Date: Thu, 2 Nov 2000 22:03:43 +0530

Actually this makes sense because there is no need( and use) to  have KA flags
set in an embedded signals descriptor if the event does not have KA set.

So is there consensus that an embedded signals descriptor means KA of detcted
event should be assumed to be set. and thus KAs in embedded signals descriptor
honored? ( In case none of the active signals are in the embedded signals
descriptor with KA set then the stopping/starting of signals will be equivalent
to stopping all the signals due to event detection( with Ka not set) and then
processing the embedded descriptor)

---

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 2 Nov 2000 11:26:30 -0600

Sorry, that's not what I meant to imply.

> Sent: Thursday, November 02, 2000 11:34 AM

[PTT] I would expect the opposite: that you need to specify the intent of
the individual terms of the embedded signals descriptor when it is present.

---

From: Kris Albert <[email-masked]>
Date: Thu, 2 Nov 2000 20:02:22 -0800

I will appreciate if you can give me a example for the case

 when MG is playing a signal list    = (s1ka, s2, s3, s4ka)
and MG receives a replacement signal descriptor with same signal list,
what will the processing
 1) when S1KA is playing currently
 2) when S2 is playing currently
How the keepActive status will work on the case of signal list.?

thanks
Kris

--

On Thu, 2 Nov 2000 10:23:39

---

From: "Taylor, Tom-PT" <[email-masked]>
Date: Mon, 20 Nov 2000 15:45:47 -0500

[More old business.]
As per other messages in this thread:
  -- if the new descriptor arrives while s2 or s3 is playing, playout of the
list is halted
  -- if the new descriptor arrives while s1 or s4 is playing, playout of the
list continues.

> Sent: Thursday, November 02, 2000 11:02 PM
> To: [email-masked]; Taylor, Tom-PT
> [NORSE:B901:EXCH]