Subject: Re: Differences between ABNF and ASN.1 specifications

From: John Segers <[email-masked]>
Date: Wed, 1 Nov 2000 10:11:35 +0100

Tom,

I added the TerminationIDList construct _in my capacity as editor_.  The
original request came from other parties, with an eye towards future
extensions.

The construct is used in at least one place in the ASN.1, in
AuditResult.  The corresponding ABNF rule uses a list of terminationIDs
as well.

Finally, I fail to see how ABNF is more flexibile than ASN.1 for this
particular issue.  If there ever is a need to allow multiple
TerminationIDs on a command (e.g. Add = T1, T2, T3 { ... }), then the
ASN.1 syntax is in place, the ABNF has to be modified, right?

Cheers,

John

Tom-PT Taylor wrote:
>
> John Segers added the terminationIdList construct with an eye to the
> possible future, simply because ASN.1 is less flexible than ABNF.
>
> > -----Original Message-----
> > From: Troy Cauble [mailto:[email-masked]]
> > Sent: Tuesday, October 31, 2000 1:52 PM
> > To: [email-masked]
> > Subject: Re: Differences between ABNF and ASN.1 specifications
> >
> >
> > Terry L Anderson wrote:
> > >
> > > I notice two differences between the ABNF and ASN.1
> > specifications and I
> > > am wondering if these are intentional or errors.
> > >
> > > 1. In ASN.1
> > > AmmRequest {
> > >     terminationID    TerminationIDList,
> > >     etc.
> > > while in ABNF
> > > ammRequest contains TerminationID rather than TerminationIDList
> > >
> > > TerminationID in both cases can contain wildcards and so be
> > effectively
> > > a list, but the ASN.1 would allow a list of specific ids
> > while the ABNF
> > > would not.  Is this intentional?
> > >
> >
> > See the second "NOTE" at the beginning of
> > section A.2.  Most of the TerminationIDLists
> > in the ASN.1 encoding are lists of one.
> >
> > (Why is that?)
> >
> > -troy
> >

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 303
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954

---

From: Terry L Anderson <[email-masked]>
Date: Wed, 1 Nov 2000 10:08:52 -0500

> AuditResult.  The corresponding ABNF rule uses a list of terminationIDs

Yes, both ASN.1 and ABNF has the construct terminationIDList
but my point was that the construct AmmRequest in ASN.1 uses this as the
type of terminationID while
ABNF ammRequest uses only TerminationID (NOT terminationIDList).

Of course as pointed out the NOTE at the beginning of A.2 makes the two
essentially equivalent except for details of encoding.

--
------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Pager:800.759.8352 pin 1704572   [email-masked]
Lucent Technologies/ Voice Over IP Access Networks/ Applications Grp
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla