Subject: Re: Multiple Adds In One Transaction and Errors

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 3 Nov 2000 14:18:03 -0500

Commands are atomic, execute in order, and errors stop processing,
therefore, your response will be
Reply=1001 {Context=5599 {Add=TDM1/1 {Error{......}}}}
The contextId was a bit worrisome.  It could have been $,
and the context won't exist, but I think you will in fact get
the ContextId the MG would have used.

Is the latter more grist for the Implementer's Guide?

Brian

> -----Original Message-----
> From: Alan Whitton [mailto:[email-masked]]
> Sent: Friday, November 03, 2000 1:42 PM
> To: [email-masked]
> Subject: Multiple Adds In One Transaction and Errors
>
>
> Greetings,
>
> A simple question (I think). If I create a transaction which
> consists of
> two ADD commands, something like:
>
> MEGACO/1 [198.1.2.3]:55555
> Transaction=1001 {
>   Context = $ {
>     ADD = TDM1/1 {
>       blah... blah.. blah...
>     }
>     ADD = $ {
>       yatta... yatta... yatta...
>     }
>   }
> }
>
> And the Gateway has issues with these ADDs, what happens if
> BOTH the adds
> fail? What would the reply look like, and how would the
> Controller figure
> out which error goes with which ADD?
>
> Sounds easy, don't it?
>
> Cheers,
> Alan Whitton
>

---

From: Christian Groves <[email-masked]>
Date: Tue, 7 Nov 2000 22:48:15 +1100

G'Day Brian,

Wouldn't you just get back a "?" for the context ID? No termination is
added so there can't be a context.

Cheers, Christian