Subject: Announcement Package, noc

From: Matsuda <[email-masked]>
Date: Fri, 17 Nov 2000 15:33:37 +0900

Dear,

I have a question about the use of "number of cycles" parameter
in announcements (Generic Announcement Package, Annex K).

I need to indicate playing an announcement endlessly
from MGC to MG, because a telephone user need to listen the announcement
endlessly until on-hook (until the MGC indicates the MG "Signals{}").
What value of "number of cycles" can we use in the case of playing
an announcement endlessly ? Can we use "0" value for "number of cycles"
("number of cycles"=0) in the case of playing an announcement endlessly ?

I hope to specify a value of "number of cycles" for unlimited number
of cycles (endless playing) in Annex K.

Takao Matsuda
NTT Network Service Systems Laboratories

---

From: Christian Groves <[email-masked]>
Date: Sun, 19 Nov 2000 03:44:25 +1100

Hello Takao San,

Yes you can use "0" for the number of cycles. Since the August there has
been text that says:

Number of cycles
ParameterID:  noc (0x0002)
type: integer.

Values: any
          0 is used to represent an announcement
        that continuously plays or loops. (OO)
Default: provisioned per announcement in the MG.

Regards, Christian