Subject: Re: ServiceChangeMethod Failover

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 6 Nov 2000 14:04:54 -0500

Replies and Pendings ALWAYS go back from whence they came, no exceptions.

We do need to make this clear in the text.

Brian

> -----Original Message-----
> From: Terry L Anderson [mailto:[email-masked]]
> Sent: Monday, November 06, 2000 11:08 AM
> To: [email-masked]
> Subject: ServiceChangeMethod Failover
>
>
> The use of ServiceChangeMethod = Failover and the procedures behind it
> are not totally clear in 7.2.8.  The paragraph describing the use of
> ServiceChangeAddress indicate that new transaction requests go to the
> new address but replies and pending indications continue to go to the
> "address from which the corresponding request originated."
>
> The next paragraph discussing ServiceChangeMgcId (which I believe is
> used with Handoff) does NOT make clear whether a similar
> distinction is
> made between new transactions and replies and pending indictions or
> whether all messages go to the new MGC.  The text merely says "the new
> MGC that will take over from the current MGC." It is not clear what
> "take over" means.  The issue is the procedures behind a
> handoff: is it
> gradual (ServiceChange with Handoff is sent but the MGC must
> wait around
> for replies and pending indications before it can go out of
> service) or
> abrupt (ServiceChange can be sent and then immediately MGC
> can go out of
> service and the new MGC handle all subsequent activity).
>
> I think that text should be more specific about the
> procedures relating
> to Handoff.
>
> --
> ------------------------------------------------------------
> Terry L Anderson              mailto:[email-masked]
> Tel:908.582.7013   Fax:908.582.6729
> Pager:800.759.8352 pin 1704572   [email-masked]
> Lucent Technologies/ Voice Over IP Access Networks/ Applications Grp
> Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
> http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla
>
>

---

From: Terry L Anderson <[email-masked]>
Date: Mon, 6 Nov 2000 14:30:50 -0500

Thanks for the clarification.  Just to be clear then, to take an MGC out of
service using Handoff, one must send the ServiceChange with Handoff, then
send modifies with EventsDescriptor to cancel any event lists and wait for
all replies before shutting down.   Then the new MGC must send modifies with
EventsDescriptor to reinitiate any event lists still desired.  Is this
correct.