Subject: REPOST: conflicting IDs in NAS packages

From: "Tulpule, Naren" <[email-masked]>
Date: Fri, 17 Nov 2000 14:06:08 -0800

>  -----Original Message-----
> Sent: Wednesday, November 15, 2000 6:52 PM
>
> Hi,
>   apologies if this has already been pointed out.
> In http://www.ietf.org/internet-drafts/draft-ietf-megaco-naspkg-01.txt the
> 'nasin' package extends 'nas' package. Yet they have identical property
> IDs (for clgstat and sessid resp, both = 0x0001), event IDs (authres =
> nasfail = 1) etc. Has this been resolved? If so, where can I find the
> draft?
> Also, what's the name of the NAS root package? 'nasroot'? I assume it
> doesn't extend any other package?
>
> -- Naren.
> These views and opinions are mine alone, not those of Intel    (yet ;-)
> Narendra C. Tulpule SMTS, Trillium (an Intel company)
> Ph: +1-310-442-9222              Fax: +1-310-442-1162
> 12100 Wilshire Bl #1800         Los Angeles, CA 90025
>

---

From: "Taylor, Tom-PT" <[email-masked]>
Date: Mon, 20 Nov 2000 19:14:08 -0500

Yes, I hadn't thought things through.  Since the extension package
incorporates the properties, signals, etc. of the base package, it has to be
able to refer to them unambiguously.  This means the binary values for the
items in the extension have to start above those in the base package.  I
have to fix this and (sorry to say) draft Annex M.

Good catch.

> From: Tulpule, Naren [mailto:[email-masked]]
> Sent: Friday, November 17, 2000 5:06 PM
> To: [email-masked]
> Subject: REPOST: conflicting IDs in NAS packages
>
>
> > In
> http://www.ietf.org/internet-drafts/draft-ietf-megaco-naspkg-0
> 1.txt the