Subject: Alternatives in SDP

From: Dan Elbert <[email-masked]>
Date: Tue, 14 Nov 2000 16:36:15 -0500

"the following exceptions to the syntax
   of RFC 2327 are allowed:
   . the "s=", "t=" and "o=" lines are optional,
   . the use of CHOOSE is allowed in place of a single parameter value,
     and
   . the use of alternatives is allowed in place of a single parameter
     value."

Can anyone clarify what is meant by "alternatives in place of a single
parameter value" ?

Thanks

Dan Elbert
RADVISION

---

From: "Taylor, Tom-PT" <[email-masked]>
Date: Fri, 17 Nov 2000 16:21:51 -0600

I meant the alternativeValue production on which the definition of parmValue
depends, but you definitely have a point -- whatever we intended, it's not
spelled out in the grammar.

-----Original Message-----
From: Dan Elbert [mailto:[email-masked]]
Sent: Friday, November 17, 2000 2:59 PM
To: MEGACO@STANDARDS. NORTELNETWORKS. COM; Taylor, Tom-PT [NORSE:B901:EXCH]
Subject: RE: Alternatives in SDP

What production ?

Is not clear. LocalDescriptor and RemoteDescriptor in the ABNF are defined
as octetString.

Then it says in the protocol that in the text encoding SDP is used, but
allows exceptions to the syntax
of RFC 2327 which are not well defined.

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Friday, November 17, 2000 2:19 PM
To: [email-masked] <mailto:[email-masked]> ;
[email-masked]
<mailto:[email-masked]>
Subject: RE: Alternatives in SDP

Look at the name of the production in the ABNF.  It covers ranges and lists
of values.

> -----Original Message-----
> From: Dan Elbert [ mailto:[email-masked]
<mailto:[email-masked]> ]
> Sent: Tuesday, November 14, 2000 4:36 PM
> To: [email-masked]
<mailto:[email-masked]>
> Subject: Alternatives in SDP
>
>