Subject: Re: Statistics

From: "Taylor, Tom-PT" <[email-masked]>
Date: Mon, 20 Nov 2000 12:31:58 -0600

[Old mail, issue still open.]
Agreed that we have a bug, but I'm not sure it matters in practice.  The
typical usage of RTP terminations will, I suspect, mean just one stream per
termination.  Without that assumption, it appears that the text of the
package description contradicts the syntax of the statistics descriptor.
One way to solve it is to specify in the I-G that each statistic is to be
reported as a series of "pkgdName EQUAL VALUE" entries, one per stream (with
pkgdName repeated), in increasing order of stream number active on the
termination.  This respects the existing syntax but gives us a workaround
until we need a more permanent solution.

> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Thursday, October 19, 2000 10:20 AM
> To: [email-masked]
> Subject: Re: Statistics
>
>
> Oh cool.  I don't think we have ever talked about this,
> stream specific statistics!  Hmmmmm.
>
> So we would want to add (an optional) StreamId to Statistics
> Descriptor
>                 Statistics=1{rtp/pr=....
> and you might get more than one Statistics descriptor in the reply.
>
> Wow.  This is a real bug in the protocol I think!
>
> Brian
>
>
> > -----Original Message-----
> > From: Madhu Babu [mailto:[email-masked]]
> > Sent: Thursday, October 19, 2000 9:51 AM
> > To: [email-masked]
> > Subject: Statistics
> >
> >
> > Section E.12.4 states that statistics like
> > jitter, packet loss,etc are described on an
> > RTP stream. If only one RTP stream is
> > present on a termination its straitforward
> > to send statistics. But if multiple streams
> > are created on a termination How this
> > reporting is done?
> >
> > -Madhubabu
> >
>

---

From: Christian Groves <[email-masked]>
Date: Wed, 22 Nov 2000 04:37:05 +1100

What fix do you propose for the ASN1?

Cheers, Christian