Subject: Multiple SDP "blocks"

From: Troy Cauble <[email-masked]>
Date: Mon, 20 Nov 2000 13:11:28 -0500

In the call flow example, Appendix A.1.2 of the 6/00 ITU document,
item 12 shows the following:

                     Local {
   v=0
   c=IN IP4 $
   m=audio $ RTP/AVP 4
   a=ptime:30
   v=0
   c=IN IP4 $
   m=audio $ RTP/AVP 0
                     }

and states:
   "NOTE - The MGC its preferred parameter values as a series of sdp
    blocks in Local.  The MGC fills in the Local Descriptor in the Reply."

Is this really the way we want to present choices to the MGC?

SDP already has mechanisms to support multiple suggested parameter
values.  For example, this is valid, and equivalent to the intent
above:

   v=0
   c=IN IP4 $
   m=audio $ RTP/AVP 4 0
   a=ptime:30

SDP also has mechanisms to specify multiple media streams per session.
So unless we really need to specify multiple SESSIONS, I don't see
a need for multiple "blocks" delimited by v=0 lines.

-troy

---

From: "Cromwell, David [NCRTP:B933:EXCHANGE]" <[email-masked]>
Date: Tue, 21 Nov 2000 16:06:38 -0500

Troy,

My guess is that the problem was that you couldn't associate a separate
packetization with each payload type.

David
--
[email-masked]                   Nortel Networks Cable
Telephony Solutions, Inc.
Tel:   919-991-8870  (esn 351)                     35 Davis Dr
Fax:  919-991-4088                                    RTP, NC 27709

> -----Original Message-----
> From: Troy Cauble [SMTP:[email-masked]]
> Sent: Monday, November 20, 2000 1:11 PM
> To:   [email-masked]
> Subject:      Multiple SDP "blocks"
>