Subject: Re: IP header

From: Prashant Jain <[email-masked]>
Date: Fri, 5 Jan 2001 10:46:24 +0530

Hi James, Brian,
As per my understanding, the socket implementation allows you to BIND your
application process using a macro IN_ADDR_ANY.  This may lead to the unknown
situation to the application regarding the IP address used by the operating
system for that TCP/IP connection with the remote application in the case of
multi-homed host.
And one would have a problem in preparing the AH Header while sending out the
packets as you have mentioned.

This solution here should be to use a specific interface, i.e. a specific local
IP address  (through configuration) for that particular MEGACO connection with
the peer over TCP/IP. This shall also be valid in the case SCTP as transport.

Please comment.

Regards,
Prashant Jain

James Adragna <[email-masked]> on 01/04/2001 10:14:37 PM

Please respond to James Adragna <[email-masked]>

To:   [email-masked]
cc:    (bcc: Prashant Jain/HSS)

Subject:  Re: IP header

sorry, i meant the case where you don't have IPSEC
and must use the interim AH header. you need to prepend
the message with the source IP, destination IP, and
destination port when you do the calculation, but you
won't know which of your IP addresses the message will
go out on.

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Wednesday, January 03, 2001 5:13 PM
To: [email-masked]
Subject: Re: IP header

You need the source IP address.

Some IPSEC implementations handle this correctly, some don't.

Brian

> -----Original Message-----
> From: James Adragna [mailto:[email-masked]]
> Sent: Wednesday, January 03, 2001 1:58 PM
> To: [email-masked]
> Subject: IP header
>
>
> Hello
>
> How does a multihomed device create the IP header
> required for the AH calculation? The header needs
> the source IP address, but this may not be known
> at the time of the calculation.

---

From: Qiaobing Xie <[email-masked]>
Date: Tue, 23 Jan 2001 13:05:29 -0600

To my knowledge, correctly handling multi-homed endpoints is an
identified issue being actively addressed by IPSEC people. I've also
heard that we should see some I-drafts providing solutions very soon.

regards,
-Qiaobing