Subject: Wording for wildcard TerminationIds

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 12 Jan 2001 08:20:19 -0500

For the implementor's Guide:

In Annex A, the text reads:
> "The use of wildcards ALL and CHOOSE is allowed in the protocol. This
> allows a MGC to partially specify Termination IDs and let the MG choose
> from the values that conform to the partial specification. "
The text implies MGs can't wildcard.  This is incorrect, IMO.  For example,
an MG could use ALL in ServiceChange.

Brian

---

From: [email-masked]
Date: Fri, 12 Jan 2001 20:30:27 +0530

Hello,
     A similar statement is defined in the Service Change method Graceful, which
states:

   "1) Graceful - indicates that the specified Terminations will be taken
      out of service after the specified ServiceChangeDelay; established
      connections are not yet affected, but the Media Gateway Controller
      should refrain from establishing new connections and should
      attempt to gracefully tear down existing connections on the
      Termination(s) affected by the serviceChange command. The MG
      should set termination serviceState at the expiry of
      ServiceChangeDelay or the removal of the termination from an
      active context (whichever is first), to "out of service"."

Does this implicitly imply that the service change with graceful method can only
be sent from MG to MGC?
                                         Regards,
                                         R. Ezhirpavai

"Rosen, Brian" <[email-masked]> on 01/12/2001 06:50:19 PM

Please respond to "Rosen, Brian" <[email-masked]>

To:   [email-masked]
cc:    (bcc: R Ezhirpavai/HSS)

Subject:  Wording for wildcard TerminationIds

Brian

---

From: Tom Taylor <[email-masked]>
Date: Wed, 31 Jan 2001 13:36:08 -0500

I think if you're talking about individual terminations it's reasonable to limit use of "Graceful" to the MG, since the behavioural
constraints are on the MGC.  The latter doesn't need to know if it is going to put a termination out of service gracefully: once it has
marked it out of service, it will naturally avoid using it for live traffic.  And if it's the MGC that is going out of service, the Handoff
method should be adequate.