Subject: Re: Zero not allowed

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 12 Jan 2001 15:08:01 -0500

I don't think we thought about it.
For SDP, it doesn't matter.  Beyond that, who knows.
I suppose it would be better if it allowed zero.

Brian

> -----Original Message-----
> From: Paul Long [mailto:[email-masked]]
> Sent: Sunday, December 31, 2000 12:30 PM
> To: [email-masked]
> Subject: Zero not allowed
>
>
> I noticed that an octet of zero is not allowed in the ABNF
> octetString. Was
> this intentional?
>
> Paul Long
> ipDialog, Inc.
>

---

From: Paul Long <[email-masked]>
Date: Fri, 12 Jan 2001 15:33:17 -0600

Brian,

The low end of the range of acceptable characters for octetString
suspiciously starts with %01 rather than %00.

   octetString          = *(nonEscapeChar)
   nonEscapeChar        = ( "\}" / %x01-7C / %x7E-FF )

Since octetString is only referenced in mtpAddress, localDescriptor, and
remoteDescriptor, maybe it doesn't matter if an octet of zero is excluded. I
was just wondering why it was left out. Sounds like there was no reason.

Paul

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Rosen, Brian
Sent: Friday, January 12, 2001 2:08 PM
To: [email-masked]
Subject: Re: Zero not allowed

Brian

---

From: Christian Groves <[email-masked]>
Date: Mon, 15 Jan 2001 16:45:03 +1100

G'Day Brian and Paul,

It doesn't sound like people care very much for this change? Do you want
something added to the implementors' guide.

Cheers, Christian

---

From: Paul Long <[email-masked]>
Date: Mon, 15 Jan 2001 11:03:39 -0600

Christian,

Actually, I was just wondering what the rationale was for not allowing a
zero octet. Assuming that this was not intended and was simply an oversight,
how about this for the IG?

1.x Zero in octetString

Description:     Zero is unintentionally disallowed in octetString via the
nonEscapeChar construct.
Reference:      Subject:      Zero not allowed
Date:         Sun, 31 Dec 2000 11:30:07 -0600
Reply-To: [email-masked]
From: Paul Long <[email-masked]>
Organization: ipDIalog, Inc.
To: [email-masked]
[Begin Correction]
    nonEscapeChar        = ( "\}" / %x00-7C / %x7E-FF )
[End Correction]

If zero should truly _not_ be allowed, we should explain why.

BTW, I suppose we do run the risk of breaking implementations because some
vendors may have implemented an octetString as a good old fashion
null-delimited string which will no longer be possible if "null," or a zero
octet, is allowed.

Paul Long
ipDialog, Inc.

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Christian
Groves
Sent: Sunday, January 14, 2001 11:45 PM
To: [email-masked]
Subject: Re: Zero not allowed

G'Day Brian and Paul,

Cheers, Christian

---

From: Christian Groves <[email-masked]>
Date: Tue, 16 Jan 2001 11:54:31 +1100

G'Day Paul,

OK I don't see a problem adding this.

Cheers, Christian