Subject: Error response to a CHOOSE

From: Terry L Anderson <[email-masked]>
Date: Mon, 8 Jan 2001 11:44:48 -0500

What does one use as the value of ContextID or TerminationID in the
error reply when CHOOSE was used in the request and the item cannot be
created?

1. For example,
Context = $ {
    Add = some-Physical-TermID,
    Add = $
}

Now let's say that the context could not be created due to some resource
limitation (max number of contexts exceeded).  The reply should be:
Context = $ { Error = 412 {"No ContextIDs Available"}}

My question is, is this correct - should CHOOSE be used in the reply for
such an error, though CHOOSE should never be in a normal reply?

2. Now let's say that the context CAN be created but the ephemeral
terminationID cannot.  Now the reply should be:
Context = 1234 {
    Add = some-Physical-TermID,
    Add = $ { Error = 432 {"Out of TerminationIDs or No TerminationID
available"}}
}

Again is it correct to use CHOOSE in this error reply though it is not
in other replies?

My point, if this is correct, is that MGC must be prepared to see CHOOSE
in replies although they should appear only with Error.
--
------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Pager:800.759.8352 pin 1704572   [email-masked]
Lucent Technologies/ Voice Over IP Access Networks/ Applications Grp
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 8 Jan 2001 11:47:41 -0500

Yes, an error encountered with CHOOSE implies a return with CHOOSE.

Brian

> -----Original Message-----
> From: Terry L Anderson [mailto:[email-masked]]
> Sent: Monday, January 08, 2001 11:45 AM
> To: [email-masked]
> Subject: Error response to a CHOOSE
>
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 9 Jan 2001 07:51:42 -0500

Yes it would.

Brian

> From: Ian Leighton [mailto:[email-masked]]
> Sent: Monday, January 08, 2001 4:16 PM
> Subject: Re: Error response to a CHOOSE
>
>
> Would this also apply to transactions which have a
> context ID encoded as "ALL"? For example
>
> Transaction = ??? {
>   Context = * {
>     AuditValue = some-Non-Existent-Physical-TermID
>   }
> }
>
> Regards
> Ian Leighton
>
> > "Taylor, Tom-PT [NORSE:B901:EXCH]" wrote:
> >
> > The basic problem is that we need a syntactic placeholder.
> CHOOSE is
> > as good as any if people are prepared to accept it.
> >
> > > Subject: [MEGACO] Error response to a CHOOSE
> > >
> > >
> > > error reply when CHOOSE was used in the request and the
> item cannot
> > be
> > > created?
> > >
> > > 1. For example,
> > > Context = $ {