Subject: Re: ServiceChange Graceful

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 16 Jan 2001 09:27:22 -0500

I don't understand why network delay is an issue.  You send the
command, you wait for the reply and then start the timer.  The
other side receives the command, sends the reply and knows it
has AT LEAST the delay time to complete, as the network delay has
to be greater than zero.

Of course we are agreeing that it should start when the command is
sent.

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Monday, January 15, 2001 1:24 AM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: Re: ServiceChange Graceful
>
>
> G'Day Brian,
>
> On the first point I agree and on the second it can't be when
> the reply
> is received because the MG doesn't know the network delay from when it
> sends the message to the time it arrives at the MGC.
>
> Christian
>
> "Rosen, Brian" wrote:
> >
> > Someone asked me if it was legal to send a forced ServiceChange if,
> > following
> > timeout of the delay of a graceful ServiceChange, there
> were still contexts
> > up.
> > I think yes, it's possible, implementation decision.
> >
> > Related to that, a nit:
> > Is the time specified in the ServiceChangeDelay relative to
> when the command
> > is
> > sent, or the reply is received?
> >
> > I say, when the command is sent.
> >
> > Brian
>

---

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 30 Jan 2001 21:40:08 -0500

I agree with you.

> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Friday, January 12, 2001 8:26 AM
> To: [email-masked]
> Subject: [MEGACO] ServiceChange Graceful
>
>
> timeout of the delay of a graceful ServiceChange, there were
> still contexts
> up.