Subject: SignalType ?

From: Troy Cauble <[email-masked]>
Date: Mon, 15 Jan 2001 09:56:44 -0500

What is the purpose of SignalType?
The type is already known from the package info.
It can only cause a mismatch error.

-troy

---

From: Christian Groves <[email-masked]>
Date: Tue, 16 Jan 2001 13:35:09 +1100

G'Day Troy,

The signal type allows the MGC to override the default behaviour
specified in a package.
ie. A package specifies signal A to be brief. A brief signal is played
once. However the MGC wants to continue playing this signal so the MGC
sets the type to on/off to keep the signal playing.

Christian

---

From: Troy Cauble <[email-masked]>
Date: Tue, 16 Jan 2001 11:56:07 -0500

> > It can only cause a mismatch error.

This raises a lot of questions.

Do implementations have to support this for all tones?
Does a package define when this is supported?

If an implementation receives such a request and they
can't support it what do they do, play the tone as
defined in the package, or return an error?

Can I change time-out or on/off tones to brief?
What does that mean?  (How brief?)

If I change a tone to time-out, when does it time-out?

Does "sigDuration" affect time-out, on/off, and brief
tones the same way?  If I'm using "sigDuration" is
"signalType" superfluous?

-troy