Subject: Re: SignalType ?

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 16 Jan 2001 09:56:58 -0500

The package specifies a default.  It can be overridden.

Brian

> -----Original Message-----
> From: Troy Cauble [mailto:[email-masked]]
> Sent: Monday, January 15, 2001 9:57 AM
> To: [email-masked]
> Subject: SignalType ?
>
>
> What is the purpose of SignalType?
> The type is already known from the package info.
> It can only cause a mismatch error.
>
> -troy
>

---

From: Sandeep Gautam <[email-masked]>
Date: Mon, 22 Jan 2001 10:48:58 +0530

G'Day Christian,

When will the notify completion for a brief type signal be generated?

In the example given below, 150 ms duration and signal type brief means that one
instance of the signal will be played followed by 50 ms of silence. Is the
signal completion to be generated after 150 ms or after 100 ms( when the signal
has actually stopped)?

Thanx and regards,
Sandy G

Christian Groves <[email-masked]> on 22/01/2001 06:27:12

Please respond to Christian Groves <[email-masked]>

To:   [email-masked]
cc:    (bcc: Sandeep Gautam/HSS)

Subject:  Re: SignalType ?

G'Day Troy,

Please see my answers below marked CHG.

Cheers, Christian

Troy Cauble wrote:
>
> Christian Groves wrote:
> >
> > Hello Troy,
> >
> > The different between duration & OO, TO, BR is that duration gives times
> > and OO, TO, BR give essentially a number of times that something will
> > play.
> >
> > ie. S1 is a signal that plays a cadence for 100ms
> > {Duration 50ms, Signal Type = Br}  would play half the signal
> > {Duration 150ms, Signal Type = Br} would play one instance of the signal
> > and 50ms of silence.
> > {Duration 150ms, Signal Type = TO} would play one and a half instances
> > of the signal.
> > {Signal Type = OO} would keep playing instances of the signal.
> >
> > The H.248 is different to MGCP. We had alot of disucssion what br, to &
> > oo meant during the development of the protocol.
> >
>
> Christian,
>
> Thanks, this does clarify some things. The different
> SignalType values do make a difference in your 150ms
> examples.  But that's a funny way to specify silence!

[CHG] Yes it is a funny way. Its a function of the protocol but I don't
expect that you'd use it that way.

>
> Is it correct then, that the ONLY behavioral difference
> between signals that are defined as Brief or Timeout
> in their package definitions, is their behavior when
> asked to play longer than their default duration with
> no explicit SignalType specification?
[CHG] Yes.

>
>         { Duration 150ms }      ; Note: No SignalType
>
> Also, is it correct that all three signal types are
> suitable for notifyCompletion?
[CHG] Yes I believe so. All signals have a finite period of time and the
MGC might like to be notified once the signals plays successfully.

---

From: Sachin Mittal <[email-masked]>
Date: Tue, 23 Jan 2001 11:14:09 +0530

Hello Christian,

"Further more the interpretation of:
o Brief is play once (ie stop of its own accord)
o Timeout is play the cadences cycle multiple times until the timeout
value. (lasts for a specific period of time)
o ON/OFF is keep playing the cadence cycles. (lasts until turned off)"

Is what i mean by the example and the summary afterwards.
Is this NOT the intension in MEGACO? Is this explaination the
MGCP way? If yes, then what is the MEGACO way explaination?

Sachin
Hughes Software Systems

Christian Groves <[email-masked]> on 01/23/2001 10:45:27 AM

To:   [email-masked]
cc:    (bcc: Sachin Mittal/HSS)

Hello Sachin,

I know that signals in the case of tones are typically made up
of cadences. My interpretation I don't believe mixes duration and
cadence.

Further more the interpretation of:
o Brief is play once (ie stop of its own accord)
o Timeout is play the cadences cycle multiple times until the timeout
value. (lasts for a specific period of time)
o ON/OFF is keep playing the cadence cycles. (lasts until turned off)

The signal type is not the same as MGCP. We struggled with this
difference at end of 1999, start 2000.

Cheers, Christian

[email-masked] wrote:
>
> G'Day Christian,
> Your interpretation is mixing the duration with cadence whereas they are two
> seperate properties of
> the same entity, the signal:
> 1. The duration specifies the total time the cadence cycle is in progress. If
> the cadence cycle is less
> than the duration, the cadence cycle is repeated till the duration expires.
Also
> if the cadence cycle
> is more than the duration then the full cadence cycle can't be completed.
> For eg.
> If the cadence cycle is 100ms - on, 50ms - off, 50ms - on, 50ms - off
> then if
> a) duration of signal is 550ms the signal will play as
> 100 - on, 50 - off, 50 - on, 50 - off, (one cycle complete but signal duration
> has not expired), 100 - on,
> 50 - off, 50 - on, 50 - off, 50 - on (note that the 100 ms will not play for
> full time as toatl is now 550ms)
> b) duration of signal is 200 ms
> 100 - on, 50 - off, 50 - on
>
> The idea of BR, TO, OO just defines the durations and they have nothing to do
> with cadence.
> BR - means small duration
> TO - means perceptable duration (say ring, dial tone etc.)
> OO - NO DURATION (YOU CAN JUST KEEP ON PLAYING TILL IT IS TURNED OFF)
>
> Regards
> Sachin
> Hughes Software Systems
>
> Christian Groves <[email-masked]> on 01/22/2001 06:27:12 AM
>
> cc:    (bcc: Sachin Mittal/HSS)
>