Subject: Re: mediaParm/streamParm question

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 10 Jan 2001 17:20:44 -0500

It's a matter of definition.

You can indeed have more than one streamDescriptor, for example, but they
would
have to have different streamIds.

You can have more than one streamParm, but you can't have more than one
localDescriptor.

Brian

> -----Original Message-----
> From: Troy Cauble [mailto:[email-masked]]
> Sent: Wednesday, January 10, 2001 1:48 PM
> To: [email-masked]
> Subject: mediaParm/streamParm question
>
>
> I believe the "at-most-once" comment above the mediaParm construct
> should not apply to streamParm or streamDescriptor.  Can someone
> confirm this?
>
>
>    mediaDescriptor = MediaToken LBRKT mediaParm *(COMMA mediaParm)
>                         RBRKT
>
>    ; at-most-once per item
>    ; and either streamParm or streamDescriptor but not both
>    mediaParm            = (streamParm / streamDescriptor /
>                            terminationStateDescriptor)
>
>    ; at-most-once
>    streamParm           = ( localDescriptor / remoteDescriptor /
>                            localControlDescriptor )
>
>
> The corresponding ASN.1 contstruct allows a SEQUENCE of
> StreamDescriptors
> or a single StreamParms, which contains 3 optional descriptors (local,
> remote, and localControl).
>
> -troy
>

---

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 30 Jan 2001 21:25:41 -0500

In short, the comment, like so many similar ones, is imprecise.  You have to
figure out what is really meant from the text.

> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Wednesday, January 10, 2001 5:21 PM
> Subject: Re: [MEGACO] mediaParm/streamParm question
>
>