Subject: Re: SignalType ?

From: "Marcello Pantaleo (EED)" <[email-masked]>
Date: Wed, 17 Jan 2001 18:47:05 +0100

Hi Troy,
please see my comments below [MP].

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Tuesday, January 16, 2001 5:56 PM
To: [email-masked]
Subject: Re: SignalType ?

Christian Groves wrote:
>
> G'Day Troy,
>
> The signal type allows the MGC to override the default behaviour
> specified in a package.
> ie. A package specifies signal A to be brief. A brief signal is played
> once. However the MGC wants to continue playing this signal so the MGC
> sets the type to on/off to keep the signal playing.
>
> Christian
>
> Troy Cauble wrote:
> >
> > What is the purpose of SignalType?
> > The type is already known from the package info.
> > It can only cause a mismatch error.
> >
> > -troy

This raises a lot of questions.

Do implementations have to support this for all tones?
[MP] I suppose yes
Does a package define when this is supported?
[MP] No
If an implementation receives such a request and they
can't support it what do they do, play the tone as
defined in the package, or return an error?

Can I change time-out or on/off tones to brief?
What does that mean?  (How brief?)
[MP]Yes. The signal duration should be provided
If I change a tone to time-out, when does it time-out?
[MP]Yes. The signal duration should be provided
Does "sigDuration" affect time-out, on/off, and brief
tones the same way? [MP] Only time-out and brief
If I'm using "sigDuration" is
"signalType" superfluous? [MP]No

-troy

---

From: Troy Cauble <[email-masked]>
Date: Wed, 17 Jan 2001 14:09:06 -0500

> defined in the package, or return an error?

??

> [MP]Yes. The signal duration should be provided

If the duration is not provided, what is the behavior?

> [MP]Yes. The signal duration should be provide

If the duration is not provided, what is the behavior?

> "signalType" superfluous? [MP]No

Then what is the behavior when the following is received?
        { Duration=3000, SignalType=OnOff }

And what is the difference between
        { Duration=3000, SignalType=TimeOut }
        { Duration=3000, SignalType=Brief }

I think that these two are the same.  MGCP distinguished
between brief and timeout for the purposes of notifyCompletion,
but this isn't really stated in H.248.

Therefore I can't see the point in the SignalType,
other than SignalType=OnOff (with no Duration),
which could be represented with Duration=0 or some
other special value.  This would remove the bad
combination errors outlined above that are not
disallowed in the syntax.

Also, I fail to see the difference in specifying
a signal as brief or timeout when I'm defining it
in a package.  All the behaviors seem to be the same.

-troy