Subject: Re: Command prefixes

From: Christian Groves <[email-masked]>
Date: Mon, 15 Jan 2001 16:57:48 +1100

G'Day Paul,

Yes you are correct.

Cheers, Christian

Paul Long wrote:
>
> Does "O-" indicate an optional and "W-" a wildcarded command? I can't see
> where they could mean anything else, but I also didn't see this defined
> anywhere.
>
> Paul Long
> ipDialog, Inc.

---

From: Paul Long <[email-masked]>
Date: Mon, 15 Jan 2001 11:37:33 -0600

Christian,

Hey, thanks for the reply. I can't help it if I gotta ask the stupid
questions. :-) That's the only way I know how to learn. If this caused me
pause, perhaps it wouldn't hurt to make this clearer. How about this entry
for the IG?

1.x Command prefixes

Description:     Although they might be deduced, the meanings of the "O-"
and "W-" command prefixes are not explained.
Reference:      Subject:      Command prefixes
Date:         Sun, 31 Dec 2000 13:18:04 -0600
Reply-To: [email-masked]
From: Paul Long <[email-masked]>
Organization: ipDialog, Inc.
To: [email-masked]
[Begin Correction]
   ; "O-" indicates an optional command
   commandRequestList= ["O-"] commandRequest *(COMMA ["O-"]
   commandRequest)
[End Correction]
[Begin Correction]
   ; "W-" indicates a wildcarded command
   subtractRequest      =  ["W-"] SubtractToken EQUAL TerminationID
                           [ LBRKT auditDescriptor RBRKT]

   auditRequest         = ["W-"] (AuditValueToken / AuditCapToken )
                        EQUAL TerminationID LBRKT auditDescriptor RBRKT
[End Correction]

Paul Long
ipDialog, Inc.

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Christian
Groves
Sent: Sunday, January 14, 2001 11:58 PM
To: [email-masked]
Subject: Re: Command prefixes

G'Day Paul,

Yes you are correct.

Cheers, Christian

---

From: Christian Groves <[email-masked]>
Date: Tue, 16 Jan 2001 12:04:52 +1100

G'Day Paul,

No problems about the question I realise there's stuff in Megaco that
some people knoow stuff is there but its not written down. In the
approved implementors' guide W- has been shifted to commandRequestList
so I moved the W- comment to there. Also W- is a wildcarded command
response which is slightly different to wildcarded command. I'll add the
following:

 [Begin Correction]

...
; "O-" indicates an optional command
; "W-" indicates an wildcarded response to a command
commandRequestList= ["O-"] commandRequest *(COMMA ["O-"]commandRequest)
...
[End Correction]

Cheers, Christian