Subject: Re: ToneGen...CPTGen

From: Sandeep Gautam <[email-masked]>
Date: Mon, 15 Jan 2001 14:12:34 +0530

What would be the behaviour in case of tonedet/std(toneid=*) ? remeber that tone
id * is defined in the tonedet package. Will it be similarly lead to an error
generation?

The exaple is same as below, with tonedet and CPT det substituted.

Is the consensus that tonegen/antyhting and tonedet/anything doesnt make sense
and hence will never be used between the MG and MGC?

Thanx.
Regards,
Sandy G

Christian Groves <[email-masked]> on 15/01/2001 09:28:54

Please respond to Christian Groves <[email-masked]>

To:   [email-masked]
cc:    (bcc: Sandeep Gautam/HSS)

Subject:  Re: ToneGen...CPTGen

G'Day Chan,

If the MGC applies tonegen/playtone(toneid=dial tone) then you should
get an error. The MGC has to use CPTGEN package if it wants to play
toneid= dial tone.

Cheers, Christian

Chanchal Hassija wrote:
>
> Hello All,
>
> CPTGen package extends ToneGen package.
>
> If MGC applies a signal - tonegen/playtone(toneid=dial tone), and the
> termination has ToneGen as well as CPT gen loaded, should the MG invoke
> CPTGEN/playtone{ toneid=dial tone}. Is this not invalid since ToneId=DialTone
is
> not a valid parameter for the Base-Package and hence MGC can't refer to what
is
> valid in extended package only, by using BasePackageId.
>
> Thanks for your time
>
> Chan....

---

From: Christian Groves <[email-masked]>
Date: Tue, 16 Jan 2001 10:58:40 +1100

G'Day Sandy,

The Tonedet package makes explicit mention that "*" can be used in the
detection case.

Christian