Subject: Re: Event descriptors with ALL eventID in extended packages.

From: Kapil Nayar <[email-masked]>
Date: Sat, 13 Jan 2001 10:39:54 +0530

Hi Chris

Considering this specific case:
std, etd and ltd are part of a package which is "intended to be extended".

Do you mean to say that events descriptor with tonedet/* only would
cause MG to notify tonedet/std, tonedet/etd and tonedet/ltd ?
In that case, what would be the values of event parameters (tone ids)
for the above events, since the tone ids are supposed to be defined
by the packages extending tonedet (dd etc.).

-Kapil Nayar
Hughes Software Systems

Christian Groves <[email-masked]> on 01/12/2001 10:55:36 AM

Please respond to Christian Groves <[email-masked]>

To:   [email-masked]
cc:    (bcc: Kapil Nayar/HSS)

Subject:  Re: Event descriptors with ALL eventID in extended packages.

G'Day Dave,

The MG will notify dd/d0 to dd/do. std, etd and ltd are part of
different packages.

Cheers, Christian

Dave Sclarsky wrote:
>
> Hi,
>
> Per 7.1.9:
>   "The ALL wildcard may be used for the EventID,
>    indicating that all events from the specified
>    package have to be detected."
>
> Does this mean that an events descriptor that has
> dd/* causes an MG to notify dd/std{tid=d0}, dd/d0
> and dd/etd{tid=d0}, and possibly dd/ltd{tid=d0}?
>
> Thanks,
>
> ============================
> Dave Sclarsky
> System Architect, Access Technology
> S-Link Corporation
> 520 Fellowship Road, Suite C-304
> Mt. Laurel, NJ 08054
> [email-masked]
> voice:856.642.9229x231 fax:856.642.0252
> www.ss7-link.com

---

From: Christian Groves <[email-masked]>
Date: Mon, 15 Jan 2001 14:28:24 +1100

G'Day Kapil,

Woops it looks like I answered this too quickly. Marcello is correct in
pointing out the inheritence. If you do dd/* you will get all the events
in the dd package and any events in packages that it extended. This
follows the rules for naming in herited packages.

Cheers, Christian

G'Day Christian,

std, etd and ltd are part of tonedet and dd
extends tonedet. So I thought those events
would have notified as well.

Cheers,
Marcello