Subject: Re: Wildcard in ContextId

From: Sachin Mittal <[email-masked]>
Date: Tue, 23 Jan 2001 09:23:32 +0530

If the basic philosophy of  "context parsing to be done independently of the
command parsing" is applied strictly to the example being discussed or that
given by Mike
below the ContextId = * gives me all contexts that exist and thus the reply
should contain all
context IDs.

"Your example would be better expressed as two actions with
one command each rather than one action with two commands"
Yes I agree to that it should be two actions, but then we need to specify
somewhere
in implementors' guide that MG should not depend on this but MGC should set it
right
(give two actions rather than one)

Sachin

"Rosen, Brian" <[email-masked]> on 01/19/2001 06:28:03 PM

To:   Sachin Mittal/HSS@HSS, [email-masked]
cc:

Subject:  RE: Wildcard in ContextId

I think this makes implementations more difficult for no significant
gain.  What you would need to do is to do all the matching for all the
commands,
rather than process one command at a time.  I'm already reluctant to require
that context=* is evaluated on the first command, since the basic mechanism
was supposed to allow the context parsing to be done independently of the
command parsing.  Your example would be better expressed as two actions with
one command each rather than one action with two commands.

Brian

> -----Original Message-----
> From: Sachin Mittal [mailto:[email-masked]]
> Sent: Thursday, January 18, 2001 11:54 PM
> To: [email-masked]
> Subject: Re: Wildcard in ContextId
>
>
> If we remove the complication of W- from the example
> >     Context = * {
> >         W-Audit = * { ... }
> >         Subtract = T1
> >     }
> and change it to
> >     Context = * {
> >         Subtract = T2,
> >         Subtract = T1
> >     }
> where T2 is in ContextID=2 and T1 is in ContextID=1 (say)
> the choice of response #2 is incorrect. It doesn't make sense
> to tell MGC that in Context =2 the subtract of T1 has failed.
> The general
> idea "Context=* matches Contexts with
> terminationIDs that match the FIRST action terminationId"
> becomes invalid for this very common case where MGC doesn't
> know the Contexts
> in which T1 , T2 exists but wants to subtract them wherever
> they exist.
>
> Sachin
> Hughes Software Systems
>
>
>
>
>
> "Rosen, Brian" <[email-masked]> on 01/17/2001 12:11:37 AM
>
> Please respond to "Rosen, Brian" <[email-masked]>
>
> To:   [email-masked]
> cc:    (bcc: Sachin Mittal/HSS)
>
> Subject:  Re: Wildcard in ContextId
>
>
>
>
> I think Context=* gets you multiple replies.
> I think processing of Context=* occurs before consideration
> of terminationIds given the current text.
>
> I like your example.  I'd choose #2 as the correct response.
>
> We could consider trying to make it better, slightly,
> by specifying that Context=* matches Contexts with
> terminationIDs that match the FIRST action terminationId.
> Then you clearly would get errors in your example, but
> the common case would work better.
>
> Brian
>
> > -----Original Message-----
> > From: Mike Broome [mailto:[email-masked]]
> > Sent: Tuesday, January 16, 2001 12:47 PM
> > To: Rosen, Brian
> > Cc: [email-masked]
> > Subject: Re: Wildcard in ContextId
> >
> >
> > I'm not sure what the syntax "Context-W=*" means.  (That's might be
> > your point:  it is not valid syntax.)
> >
> > When using Context=* and W- on a command, should the reply be
> > one action
> > or multiple actions?  Section 7.3 of the Implementors' Guide defines
> > this scenario as returning one action with Context=* in the
> reply.  Is
> > this still the case?  Or are you saying that Context=* in a request
> > should always be expanded into multiple replies?
> >
> > What happens for a more complicated action like the following:
> >
> >     Context = * {
> >         W-Audit = * { ... }
> >         Subtract = T1
> >     }
> >
> > This is a somewhat ambiguous command for an MGC to send, but
> > how should
> > it be handled?  Section 7.3 of the Implementors' Guide only has an
> > example for a single W- command in an action.  I see three
> > possibilities
> > here:
> >
> > 1. Send back an error because the termination specifier
> doesn't match
> > between the two commands (ALL and specific).
> >
> > 2. Expand the Context=* and send back multiple replies,
> with an error
> > descriptor for the Subtract command in all the replies except the
> > Context that contains T1.
> >
> > 3. Internally, split the action into multiple actions with
> > the commands
> > grouped based on the termination specifier and W-.  For the
> example I
> > gave, we'd end up with two actions:
> >
> >     Context = * {
> >         W-Audit = * { ... }
> >     }
> >
> >     Context = * {
> >         Subtract = T1
> >     }
> >
> > Any comments?
> >
> > Thanks,
> > Mike
> >
> > On Fri, Jan 12, 2001 at 03:54:43PM -0500, Rosen, Brian wrote:
> > > You can't say Context-W=*, or anything equivalent.
> > >
> > > Therefore, when you use Context=*, you are going to get back
> > > more than one action, and there is no way to indicate that
> > > you only wanted one action.
> > >
> > > It is valid to use Context=* when you use W-.
> > >
> > > If the command has an error, you could get back Context=*,
> > > so I don't think I've contradicted the Error response to CHOOSE.
> > >
> > > Brian
> > >
> > > > -----Original Message-----
> > > > From: Mike Broome [mailto:[email-masked]]
> > > > Sent: Friday, January 12, 2001 3:19 PM
> > > > To: [email-masked]
> > > > Subject: Re: Wildcard in ContextId
> > > >
> > > >
> > > > Brian,
> > > >
> > > > When you say "wildcard response" do you mean there is no
> > way to get a
> > > > reply that contains "Context = *" or do you mean that it is
> > > > not valid to
> > > > use "W-" (the wildcard response indicator) on any of the
> > > > commands in an
> > > > action where the ContextID is wildcarded?
> > > >
> > > > The first interpretation is at odds with the recent
> > discussion in the
> > > > thread "Error response to a CHOOSE".  (It also would make the
> > > > change in
> > > > 6.21 in the IG that adds support for returning ALL as the
> > > > ContextID for
> > > > a transaction no longer needed, right?)
> > > >
> > > > The second interpretation would make an action like the
> > following --
> > > > with both ContextID and TerminationID wildcarded and a W- on
> > > > the command
> > > > -- invalid:
> > > >
> > > >     Context = * {
> > > >         W-Audit = * { ... }
> > > >     }
> > > >
> > > > If the above action IS valid, would the Reply have
> > "Context = *" or
> > > > would there be a separate action reply for every context?  My
> > > > preference
> > > > would be to have "Context = *" indicating the ContextID is a
> > > > don't care
> > > > (similar to what was discussed in the "Error response
> to a CHOOSE"
> > > > thread).
> > > >
> > > > Thanks,
> > > > Mike
> > > >
> > > >
> > > > On Fri, Jan 12, 2001 at 08:21:58AM -0500, Rosen, Brian wrote:
> > > > > Wildcards are allowed in ContextId.  There is no way to get a
> > > > > wildcard response if you use a wildcard ContextId.
> > > > > We should probably point that out somewhere.
> > > > >
> > > > > Brian
> > > >
> >
>

---

From: Chuong Nguyen <[email-masked]>
Date: Thu, 25 Jan 2001 15:31:37 -0600

Hi All,

The following from MG to MGC:

Context = - {[W-] ServiceChange = a/b/c/d* {Method=Forced}}

where a/b/c/d* represents a T1.

What should the ContextId be in the Request "-" or "*"?

What should the reply be?

1)  Context = - {ServiceChange = a/b/c/d*}

2)  Context = * {ServiceChange = a/b/c/d*}

3) Context = - {ServiceChange= a/b/c/d1},              channel 1 of T1 that is in
the NULL context
     Context = 100 {ServiceChange = a/b/c/d2},         channel 2 of T1 that is in
context 100.

    so on for each channel since they are in different Context

Should or does ContextID have any significant w/ServiceChange from MG?

Thanks
Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****