Subject: Re: Wildcard in ContextId

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 16 Jan 2001 13:41:37 -0500

I think Context=* gets you multiple replies.
I think processing of Context=* occurs before consideration
of terminationIds given the current text.

I like your example.  I'd choose #2 as the correct response.

We could consider trying to make it better, slightly,
by specifying that Context=* matches Contexts with
terminationIDs that match the FIRST action terminationId.
Then you clearly would get errors in your example, but
the common case would work better.

Brian

> -----Original Message-----
> From: Mike Broome [mailto:[email-masked]]
> Sent: Tuesday, January 16, 2001 12:47 PM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: Re: Wildcard in ContextId
>
>
> I'm not sure what the syntax "Context-W=*" means.  (That's might be
> your point:  it is not valid syntax.)
>
> When using Context=* and W- on a command, should the reply be
> one action
> or multiple actions?  Section 7.3 of the Implementors' Guide defines
> this scenario as returning one action with Context=* in the reply.  Is
> this still the case?  Or are you saying that Context=* in a request
> should always be expanded into multiple replies?
>
> What happens for a more complicated action like the following:
>
>     Context = * {
>         W-Audit = * { ... }
>         Subtract = T1
>     }
>
> This is a somewhat ambiguous command for an MGC to send, but
> how should
> it be handled?  Section 7.3 of the Implementors' Guide only has an
> example for a single W- command in an action.  I see three
> possibilities
> here:
>
> 1. Send back an error because the termination specifier doesn't match
> between the two commands (ALL and specific).
>
> 2. Expand the Context=* and send back multiple replies, with an error
> descriptor for the Subtract command in all the replies except the
> Context that contains T1.
>
> 3. Internally, split the action into multiple actions with
> the commands
> grouped based on the termination specifier and W-.  For the example I
> gave, we'd end up with two actions:
>
>     Context = * {
>         W-Audit = * { ... }
>     }
>
>     Context = * {
>         Subtract = T1
>     }
>
> Any comments?
>
> Thanks,
> Mike
>
> On Fri, Jan 12, 2001 at 03:54:43PM -0500, Rosen, Brian wrote:
> > You can't say Context-W=*, or anything equivalent.
> >
> > Therefore, when you use Context=*, you are going to get back
> > more than one action, and there is no way to indicate that
> > you only wanted one action.
> >
> > It is valid to use Context=* when you use W-.
> >
> > If the command has an error, you could get back Context=*,
> > so I don't think I've contradicted the Error response to CHOOSE.
> >
> > Brian
> >
> > > -----Original Message-----
> > > From: Mike Broome [mailto:[email-masked]]
> > > Sent: Friday, January 12, 2001 3:19 PM
> > > To: [email-masked]
> > > Subject: Re: Wildcard in ContextId
> > >
> > >
> > > Brian,
> > >
> > > When you say "wildcard response" do you mean there is no
> way to get a
> > > reply that contains "Context = *" or do you mean that it is
> > > not valid to
> > > use "W-" (the wildcard response indicator) on any of the
> > > commands in an
> > > action where the ContextID is wildcarded?
> > >
> > > The first interpretation is at odds with the recent
> discussion in the
> > > thread "Error response to a CHOOSE".  (It also would make the
> > > change in
> > > 6.21 in the IG that adds support for returning ALL as the
> > > ContextID for
> > > a transaction no longer needed, right?)
> > >
> > > The second interpretation would make an action like the
> following --
> > > with both ContextID and TerminationID wildcarded and a W- on
> > > the command
> > > -- invalid:
> > >
> > >     Context = * {
> > >         W-Audit = * { ... }
> > >     }
> > >
> > > If the above action IS valid, would the Reply have
> "Context = *" or
> > > would there be a separate action reply for every context?  My
> > > preference
> > > would be to have "Context = *" indicating the ContextID is a
> > > don't care
> > > (similar to what was discussed in the "Error response to a CHOOSE"
> > > thread).
> > >
> > > Thanks,
> > > Mike
> > >
> > >
> > > On Fri, Jan 12, 2001 at 08:21:58AM -0500, Rosen, Brian wrote:
> > > > Wildcards are allowed in ContextId.  There is no way to get a
> > > > wildcard response if you use a wildcard ContextId.
> > > > We should probably point that out somewhere.
> > > >
> > > > Brian
> > >
>

---

From: Madhu Babu Brahmanapally <[email-masked]>
Date: Tue, 16 Jan 2001 17:37:06 -0500

If MGC generates a wildcard command ("W-"),the prime intention is to
generate a single/minimum number of responses from MG. In Mike's example, If
command is wildcard (I mean "W-") and ContextID is * and TerminationId
partial wildcard. Instead of wildcard contextID WHY NOT multiple wildcard
response one for each Context/action??
Best Regards.
Madhubabu

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Rosen, Brian
Sent: Tuesday, January 16, 2001 1:42 PM
To: [email-masked]
Subject: Re: Wildcard in ContextId

Brian