Subject: Re: physical vs. ephemeral terminations

From: Tom Taylor <[email-masked]>
Date: Wed, 31 Jan 2001 08:54:23 -0500

My remarks below.

On Tue, 30 Jan 2001 17:30:40 -0500, Troy Cauble <[email-masked]> wrote:

>Hi all,
>
>It seems that the protocol goes out of it's way to not
>distinguish between physical an ephemeral terminations.

[PTT]
That is absolutely true, and is a major reason for the divergence between Megaco and MGCP.  The latter varies its syntax
depending on the sort of connection being made, and the consensus was for a model that was transport independent.

>
>What is the error returned if an MG is asked to do something
>it doesn't support (or doesn't even make sense) on that type
>of termination?
>        If it's asked to detect hook flash on an ephemeral
>        termination?

[PTT]
440 Unsupported or unknown package

>        If it's asked to apply Local or Remote Descriptors
>        to a physical termination?

[PTT]
Not an error, though the I-D describing SDP naming conventions (SDP nettype, addrtype) for TDM circuits has to be written.  You
need the descriptors to describe the codec (as Madhue has pointed out) and the bearer capability.

>
>This seems to indicate a whole class of syntactically correct,
>but nonsensical combinations.

[PTT]
Error code 440 covers a lot of it.

>
>I'm pretty sure that SDP Local and Remote descriptors are
>intended strictly for ephemeral terminations.  But I'm less
>sure about Annex C Local and Remote descriptor content.  Opinions?

[PTT]
See above.

>
>Also, it seems that given a termination id of CHOOSE, an MG must
>traverse descriptors looking for clues that indicate whether it
>should CHOOSE an ephemeral or physical termination.  Correct?
>What if there is no forcing hint?

[PTT]
I gave my own answer to that a while ago.  Basically the termination is treated as an empty software container waiting to be filled
with detail.

>
>        A termination id schema must clearly distinguish between
>        physical and ephemeral so the MGC knows how to pick a
>        termination associated with some physical attribute
>        (such as "POTS line 7"), yes?

[PTT]
It has been pointed out that there is no necessary association between termination type and name, even if the latter is based on a
physical schema (e.g. shelf/slot).  It might be possible to insert various card types (ATM, TDM, ethernet) into the same slot.  For
this reason I'll be withdrawing the naming schema property in my proposed NAS package in favour of Brian Rosen's more general
package (see separate message).

>        So the MG must pick between physical and ephemeral given
>        a CHOOSE.
>
>        A residential gateway might assume that CHOOSE implies
>        ephemeral, since random physical choices have little use.
>        A trunking gateway might be different though.

[PTT]
You are probably right for the residential gateway -- the only counter-example I can think of is the unlikely situation of such a
gateway serving a multi-line hunt group.  I'll take personal responsibility for the existence of the CHOOSE option in the first place,
back when we were negotiating IPDC.  At that time I had trunk groups in mind.

>
>How useful is termination id ALL, if many operations don't make
>sense on both classes of terminations?

[PTT]
ALL is more useful for maintenance-related or auditing operations.

>-troy

---

From: Troy Cauble <[email-masked]>
Date: Wed, 31 Jan 2001 19:53:11 -0500

> need the descriptors to describe the codec (as Madhue has pointed out) and the bearer capability.

Tom,

Well, it's an error for a POTS line.  What's the error code for that?
(Don't say 440; we're not talking about packages here.)

> Error code 440 covers a lot of it.

But not all :(

> I gave my own answer to that a while ago.  Basically the termination is treated as an empty software container waiting to be filled

This makes for nice viewgraphs, but difficult implementations :(

> physical schema (e.g. shelf/slot). It might be possible to insert various card types (ATM, TDM, ethernet) into the same slot.

I guess you're saying that the schema doesn't have to
explicity distinguish between termination types, as
long as the MGC and MG both know the mapping.  Correct?

So a schema could be simply integers 1-1000, and the MGC just
knows that the POTS line to my house is 37, while 36
and 38 are to be used for RTP streams?

Thanks,
-troy

---

From: Troy Cauble <[email-masked]>
Date: Wed, 31 Jan 2001 20:02:34 -0500

> > 440 Unsupported or unknown package

Also, this sounds like an error for a package the MG
doesn't support at all, not one it doesn't support on
that termination type.

-troy