Subject: Re: Error Descriptor Problems

From: Christian Groves <[email-masked]>
Date: Mon, 15 Jan 2001 16:17:00 +1100

G'Day Rakefet and Brian,

For one I don't think its an implementors item as the current syntax
does not prevent you from returning only the error descriptor. The
procedural text in the protocol supports this so I don't think you need
an explicit change to the syntax to enforce this.

Cheers, Christian

"Rosen, Brian" wrote:
>
> 1. Your suggestion is probably correct.  Perhaps a Implementor's Guide item.
>
> 2. No, you would see something like:
> Context=5555{Add=term1, Modify=term2, error=442....
>
> Brian
>
> -----Original Message-----
> From: Prozan, Rakefet [LOD:Telrad:SMTPPART]
> To: [email-masked]
> Sent: 12/19/00 3:48 AM
> Subject: Error Descriptor Problems
>
> Hi all,
>
> I have 2 questions regarding the errorDescriptor:
>
> 1) It is written in rfc3015.txt (page 61):
>
>   " The TransactionReply includes
>    the return values for the Commands that were executed successfully,
>    and the Command and error descriptor for any Command that failed."
>
>    So, I understand that if a command failed ,the reply will include the
>  command token ,the TerminationID & the errorDescriptor.
>
>   For instance, if there is an illegal parameter in one of the
>   descriptors of an Add command, the reply  will look like:
>
>   Add=55555{Error=455{Parameter illegal in this Descriptor}}.
>
>   But on the other hand,the following definitions allow sending of
>   other descriptors in the same command with the errorDescriptor:
>
> ammsReply            = (AddToken / MoveToken / ModifyToken /
>                            SubtractToken ) EQUAL TerminationID [ LBRKT
>                            terminationAudit RBRKT ]
>
> terminationAudit     = auditReturnParameter *(COMMA
>                         auditReturnParameter)
>
> auditReturnParameter = (mediaDescriptor / modemDescriptor /
>                            muxDescriptor / eventsDescriptor /
>                            signalsDescriptor / digitMapDescriptor /
>                      observedEventsDescriptor / eventBufferDescriptor /
>                            statisticsDescriptor / packagesDescriptor /
>                             errorDescriptor / auditItem )
>
> Shouldn't it be:
>
> terminationAudit     = (auditReturnParameter *(COMMA
>                         auditReturnParameter))/errorDescriptor   ????
>
> Please,correct me if I'm wrong...
>
> 2)In "8.2.2 TransactionReply",  it is written:
>
>    "If the end of a command cannot be reliably determined it will return
>    442 Syntax Error in Command as the reply to the last action it can
>    parse."
>
>     I understand from this text that in case that there were
>     a few commands in the commandRequestList & only one of
> them is erroneous, the Transaction Reply will include this context
> twice:
>   The first one with reply to the correct commands & the second one with
>    error descriptor instead of the erroneous command.
>
>   Am I right?
>
> Many thanks in advance,
> --
> Rakefet Prozan,
> Team Manager, S/W Development
> ATS SBU
> Telrad Networks
> ESN 828-3043   Email:[email-masked]
>
>                                        """
>                                      -(o o)-
> +---------------------------------oOO--(_)--OOo--------------+
>
>                                .oooO         Oooo.
> -------------------------------(   )---------(   )------------
>                                 \ (           ) /
>                                  \_)         (_/
>
> Have fun !!!

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 16 Jan 2001 09:29:44 -0500

I think of it as an Implementor's Guide (i.e., please notice that...) item,
rather than a bug.

Brian

> From: Christian Groves [mailto:[email-masked]]
> Sent: Monday, January 15, 2001 12:17 AM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: Re: Error Descriptor Problems
>
>
> G'Day Rakefet and Brian,
>