Subject: Persistent events

From: Nurit Shenhar <[email-masked]>
Date: Mon, 15 Jan 2001 11:10:51 +0200

Hi list

Do we have something like the persistent events in the MGCP to catch
off-hook event that occured before the termination got an events descriptor?

Best regards

Nurit Shenhar
AudioCodes Ltd.
Direct: +972-3-539-4155
Tel:     +972-3-539-4000
Fax:    +972-3-539-4040
email:  [email-masked]

web:    <http://www.audiocodes.com>

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 16 Jan 2001 09:56:11 -0500

No.

When we changed the event mechanism to not return state to that specified in
null context,
we introduced the possibility of lost events.  You must explicitly specify
an event descriptor
in a modify following the subtract.  Depending on how you implement it,
there could be a small
window of uncertainty, since commands are executed in order, and the
subtract would
be executed before the modify.  There is the “edge” vs. “state” nature of
events, which we
discussed, but doesn’t seem to have made it into the text.  That discussion
was whether the
change in state was the event, or the state itself.  For the former, you
don’t get a notify if the
thing the event is triggered by is at the triggered state when the Events
Descriptor is
processed, and in the latter you do.  As I recall, we decided on edge, and
one of the reasons
I thought that was appropriate was the return-to-state-in-null nature of
Subtract.  Generally,
you don’t want extra Notifies.  As it stands, with the hole, we probably
want to make it state,
and put up with extra events.  That would address the hole.

Of course as this is not specified, we have some problems we should address.

Brian

> -----Original Message-----
> From: Nurit Shenhar [mailto:[email-masked]]
> Sent: Monday, January 15, 2001 4:11 AM
> To: [email-masked]
> Subject: Persistent events
> 
> 
> Hi list
>