Subject: Re: Zero not allowed

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 16 Jan 2001 09:33:59 -0500

Well, maybe something along the lines of
"The octet zero is not among the permitted characters in octet string,
which is used in the ABNF for local and remote descriptors.  As the current
definition of these descriptors is limited to SDP, and a zero octet would
not
be a legal character in SDP, this is not a concern."

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Monday, January 15, 2001 12:45 AM
> To: [email-masked]
> Subject: Re: Zero not allowed
>
>
> G'Day Brian and Paul,
>
> It doesn't sound like people care very much for this change?
> Do you want
> something added to the implementors' guide.
>
> Cheers, Christian
>
> Paul Long wrote:
> >
> > Brian,
> >
> > The low end of the range of acceptable characters for octetString
> > suspiciously starts with %01 rather than %00.
> >
> >    octetString          = *(nonEscapeChar)
> >    nonEscapeChar        = ( "\}" / %x01-7C / %x7E-FF )
> >
> > Since octetString is only referenced in mtpAddress,
> localDescriptor, and
> > remoteDescriptor, maybe it doesn't matter if an octet of
> zero is excluded. I
> > was just wondering why it was left out. Sounds like there
> was no reason.
> >
> > Paul
> >
> > -----Original Message-----
> > From: Media Gateway Control (megaco)
> > [mailto:[email-masked]]On Behalf Of
> Rosen, Brian
> > Sent: Friday, January 12, 2001 2:08 PM
> > To: [email-masked]
> > Subject: Re: Zero not allowed
> >
> > I don't think we thought about it.
> > For SDP, it doesn't matter.  Beyond that, who knows.
> > I suppose it would be better if it allowed zero.
> >
> > Brian
> >
> > > -----Original Message-----
> > > From: Paul Long [mailto:[email-masked]]
> > > Sent: Sunday, December 31, 2000 12:30 PM
> > > To: [email-masked]
> > > Subject: Zero not allowed
> > >
> > >
> > > I noticed that an octet of zero is not allowed in the ABNF
> > > octetString. Was
> > > this intentional?
> > >
> > > Paul Long
> > > ipDialog, Inc.
>

---

From: Troy Cauble <[email-masked]>
Date: Tue, 16 Jan 2001 11:26:03 -0500

Yes.  Please don't add the zero.

SDP is limited to "the ISO 10646 character set in
UTF-8 encoding".

Based on that the range of characters for "octetString"
should probably be narrowed, not widened.

I think the problem is that the name "octetString" is
misleading and implies that a full range of octet values
needs to be supported.

I'm especially worried about adding '0' because that
terminates a character string and may cause implementation
issues.

-troy

---

From: Paul Long <[email-masked]>
Date: Tue, 16 Jan 2001 11:13:30 -0600

Troy,

Okay, I see. I was assuming that octetString was something like an ASN.1
OCTET STRING, which allows all octet values. Technically speaking, however,
the NUL character (hex 00) is present in both ASCII and UTF-8, regardless of
whether implementations use it as a string delimiter. Moreover, hex values,
FE and FF, are invalid for UTF-8 yet allowed in octetString. Whatever... At
least I understand the issues a lot better now.

Paul Long
ipDialog, Inc.

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Troy Cauble
Sent: Tuesday, January 16, 2001 10:26 AM
To: [email-masked]
Subject: Re: Zero not allowed

-troy