Subject: Re: ABNF syntax error of LocalControlDescriptor and TerminationS tateDescriptor

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 4 Jan 2001 21:13:25 -0500

Yes, you are correct.

> -----Original Message-----
> From: Richie Wu [mailto:[email-masked]]
> Sent: Friday, November 17, 2000 1:32 AM
> To: [email-masked]
> Subject: ABNF syntax error of LocalControlDescriptor and
> TerminationStateDescriptor
>
>
> Hello every body,
>
> I found there are inconsistent between ASN.1 and ABNF
> syntax of Local Control Descriptor as well as
> Termination State Descriptor.
>
> According to the ASN.1 syntax the property parameter
> is SEQQUENCE, it can be only one as per the ABNF
> syntax.  So I think there is an editorial error. We
> can add a comment "at-most-once per item, except for
> propertyParm" to solve this issue.  Please refer to
> the following (comments between square brackets):
>
> LocalControlDescriptor ::= SEQUENCE
>    {
>         streamMode      StreamMode OPTIONAL,
>         reserveValue    BOOLEAN,
>         reserveGroup    BOOLEAN,
>         propertyParms   SEQUENCE OF PropertyParm,
>         ...
>    }
>
> localControlDescriptor = LocalControlToken LBRKT
> localParm
>                             *(COMMA localParm) RBRKT
>
>    ; at-most-once per item
>    ; [except for propertyParm]
>    localParm            = ( streamMode / propertyParm
> /
>    reservedValueMode
>         / reservedGroupMode )
>
>
> TerminationStateDescriptor ::= SEQUENCE
>    {
>         propertyParms           SEQUENCE OF
> PropertyParm,
>         eventBufferControl      EventBufferControl
> OPTIONAL,
>         serviceState            ServiceState OPTIONAL,
>
>         ...
>    }
>
> terminationStateDescriptor = TerminationStateToken
> LBRKT
>                terminationStateParm *( COMMA
> terminationStateParm )
>    RBRKT
>
>    ; at-most-once per item
>    ; [except for propertyParm]
>    terminationStateParm =(propertyParm / serviceStates
> /
>    eventBufferControl )
>
>
> Regards,
>
> Richie Wu
>
>
> =====
> Huawei Technologies India Private Limited
>
> Unit 10, 2nd Floor, Innovator Block
> International Tech Park, Whitefield Main Road
> Bangalore 560 066, India
> TEL: 0091-80-841 0061/0753/0755
> FAX: 0091-80-841 0063
>
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Calendar - Get organized for the holidays!
> http://calendar.yahoo.com/
>

---

From: Christian Groves <[email-masked]>
Date: Mon, 15 Jan 2001 17:08:09 +1100

G'Day Tom and Richie,

I have made the following addition to the proposed Implementors' guide
updates:

1.8 ABNF syntax error of Local Control Descriptor and Termination State
Descriptor

Description:    According to the ASN.1 syntax the property parameter is
SEQUENCE, it can be only one as per the ABNF syntax.  So I think there
is an editorial error. We can add a comment "at-most-once per item,
except for propertyParm" to solve this issue.
Reference:      Subject:  RE: ABNF syntax error of LocalControlDescriptor and
TerminationStateDescriptor
Date: Thu, 4 Jan 2001 21:13:25 -0500
From: "Tom-PT Taylor" <[email-masked]>
To: Richie Wu <[email-masked]>, [email-masked]

 [Begin Correction]
…

localControlDescriptor = LocalControlToken LBRKT localParm
                         *(COMMA localParm) RBRKT

; at-most-once per item except for propertyParm
localParm            = ( streamMode / propertyParm / reservedValueMode
     / reservedGroupMode )
…
terminationStateDescriptor = TerminationStateToken LBRKT
            terminationStateParm *( COMMA terminationStateParm ) RBRKT

; at-most-once per item except for propertyParm
terminationStateParm =(propertyParm / serviceStates / eventBufferControl
)

…

 [End Correction]

Comments.

Cheers, Christian