Subject: Re: SignalType ?

From: "Marcello Pantaleo (EED)" <[email-masked]>
Date: Thu, 18 Jan 2001 09:15:04 +0100

Hi Troy,
please see my answer [MP] below.
/Marcello
-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Wednesday, January 17, 2001 8:09 PM
To: Marcello Pantaleo (EED)
Cc: [email-masked]
Subject: Re: SignalType ?

"Marcello Pantaleo (EED)" wrote:
>
> From: Troy Cauble [mailto:[email-masked]]
>
> Christian Groves wrote:
> >
> > G'Day Troy,
> >
> > The signal type allows the MGC to override the default behaviour
> > specified in a package.
> > ie. A package specifies signal A to be brief. A brief signal is played
> > once. However the MGC wants to continue playing this signal so the MGC
> > sets the type to on/off to keep the signal playing.
> >
> > Christian
> >
> > Troy Cauble wrote:
> > >
> > > What is the purpose of SignalType?
> > > The type is already known from the package info.
> > > It can only cause a mismatch error.
> > >
> > > -troy
>
> This raises a lot of questions.
>
> Do implementations have to support this for all tones?
> [MP] I suppose yes
> Does a package define when this is supported?
> [MP] No
> If an implementation receives such a request and they
> can't support it what do they do, play the tone as
> defined in the package, or return an error?

??

> Can I change time-out or on/off tones to brief?
> What does that mean?  (How brief?)
> [MP]Yes. The signal duration should be provided

If the duration is not provided, what is the behavior?

> If I change a tone to time-out, when does it time-out?
> [MP]Yes. The signal duration should be provide

If the duration is not provided, what is the behavior?

> Does "sigDuration" affect time-out, on/off, and brief
> tones the same way? [MP] Only time-out and brief
> If I'm using "sigDuration" is
> "signalType" superfluous? [MP]No

Then what is the behavior when the following is received?
        { Duration=3000, SignalType=OnOff }

[MP] H.248 (Section 7.1.11)states that "...If durationis specified
     for an on?off signal, it SHALL be ignored"

And what is the difference between
        { Duration=3000, SignalType=TimeOut }
        { Duration=3000, SignalType=Brief }
[MP] The difference is that with TimeOut you allow the MGC to turn
     the signal off too.

I think that these two are the same.  MGCP distinguished
between brief and timeout for the purposes of notifyCompletion,
but this isn't really stated in H.248.

Therefore I can't see the point in the SignalType,
other than SignalType=OnOff (with no Duration),
which could be represented with Duration=0 or some
other special value.  This would remove the bad
combination errors outlined above that are not
disallowed in the syntax.

Also, I fail to see the difference in specifying
a signal as brief or timeout when I'm defining it
in a package.  All the behaviors seem to be the same.

-troy

---

From: Christian Groves <[email-masked]>
Date: Fri, 19 Jan 2001 15:19:54 +1100

Hello Troy,

The different between duration & OO, TO, BR is that duration gives times
and OO, TO, BR give essentially a number of times that something will
play.

ie. S1 is a signal that plays a cadence for 100ms
{Duration 50ms, Signal Type = Br}  would play half the signal
{Duration 150ms, Signal Type = Br} would play one instance of the signal
and 50ms of silence.
{Duration 150ms, Signal Type = TO} would play one and a half instances
of the signal.
{Signal Type = OO} would keep playing instances of the signal.

The H.248 is different to MGCP. We had alot of disucssion what br, to &
oo meant during the development of the protocol.

Cheers, Christian

---

From: Troy Cauble <[email-masked]>
Date: Fri, 19 Jan 2001 12:46:16 -0500

> oo meant during the development of the protocol.

Christian,

Thanks, this does clarify some things. The different
SignalType values do make a difference in your 150ms
examples.  But that's a funny way to specify silence!

Is it correct then, that the ONLY behavioral difference
between signals that are defined as Brief or Timeout
in their package definitions, is their behavior when
asked to play longer than their default duration with
no explicit SignalType specification?

        { Duration 150ms }      ; Note: No SignalType

Also, is it correct that all three signal types are
suitable for notifyCompletion?

-troy

---

From: Christian Groves <[email-masked]>
Date: Mon, 22 Jan 2001 11:57:12 +1100

G'Day Troy,

Please see my answers below marked CHG.

Cheers, Christian

> examples.  But that's a funny way to specify silence!

[CHG] Yes it is a funny way. Its a function of the protocol but I don't
expect that you'd use it that way.

> no explicit SignalType specification?
[CHG] Yes.

> suitable for notifyCompletion?
[CHG] Yes I believe so. All signals have a finite period of time and the
MGC might like to be notified once the signals plays successfully.