Subject: Re: ToneGen...CPTGen

From: Christian Groves <[email-masked]>
Date: Mon, 15 Jan 2001 14:58:54 +1100

G'Day Chan,

If the MGC applies tonegen/playtone(toneid=dial tone) then you should
get an error. The MGC has to use CPTGEN package if it wants to play
toneid= dial tone.

Cheers, Christian

Chanchal Hassija wrote:
>
> Hello All,
>
> CPTGen package extends ToneGen package.
>
> If MGC applies a signal - tonegen/playtone(toneid=dial tone), and the
> termination has ToneGen as well as CPT gen loaded, should the MG invoke
> CPTGEN/playtone{ toneid=dial tone}. Is this not invalid since ToneId=DialTone is
> not a valid parameter for the Base-Package and hence MGC can't refer to what is
> valid in extended package only, by using BasePackageId.
>
> Thanks for your time
>
> Chan....

---

From: Madhubabu Brahmanapally <[email-masked]>
Date: Mon, 15 Jan 2001 16:27:33 -0500

Hi Christian, all,
The CPTGEN package extends the tonegen package. why at MG, if
tonegen/playtone(toneid=dial tone) is sent from MGC an error is occurred??
The values taken by toneid are said to be defined in packages extending  the
tonegen package. Hence toneid=dial tone is a valid parameter. The MGC can
either use the above method or can directly apply the dial tone by
specifying cg/dt. This is only another way of doing it. Infact all the
values for the toneid are said be defined in the packages that extends the
Tonegen pkg. Correct me if iam wrong!

Best regards.
Madhubabu

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Christian
Groves
Sent: Sunday, January 14, 2001 10:59 PM
To: [email-masked]
Subject: Re: ToneGen...CPTGen

G'Day Chan,

Cheers, Christian