Subject: ROOT not in ALL

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 20 Feb 2001 13:56:50 -0500

Where does it say that ROOT is not in ALL?

It should, I can't find it.

Brian

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Tue, 20 Feb 2001 14:24:42 -0500

A common understanding on the list but not documented. 

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Rosen, Brian
Sent: Tuesday, February 20, 2001 1:57 PM
To: [email-masked]'
Subject: ROOT not in ALL

Brian

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 20 Feb 2001 15:49:07 -0500

In section 8.1.2, there is mention that the "special" NULL context is
not matched by ALL.  By extension, you could then make the case that the
"special" ROOT termination is not matched by ALL. Besides, having ROOT
in ALL breaks all the wildcarded commands.  This sounds like fodder for
the Implementor's Guide.

Kevin