Subject: Re: ContextId List

From: David Dykhuizen <[email-masked]>
Date: Tue, 20 Feb 2001 15:11:54 -0600 (CST)

Afternoon:

First according to the Implementor's Guide (Chapter 7.1 "Returning a Context ID
List") we see the following wording:

"The list of Context Ids should be returned by using multiple Action Replys,
each containing a context from the list."

Second would question the outgoing request - according to the ABNF:

auditDescriptor = AuditToken LBRKT [ auditItem *(COMMA auditItem) ] RBRKT

at a minimum we need to have the empty list.  Then, according to the text within 
Chapter 7.2.5:

... Specifying an empty Audit Descriptor results in only the TerminationID(s)
being returned ...

Hence according to our existing ABNF syntax:

Context=* {
  AuditValue=ROOT {
    Audit {}
  }
}

results in:

Context=2000 {
  AuditValue=Context {t1, t2}
}
Context=3000 {
  AuditValue=Context {t3}
}
Context=4000 {
  AuditValue=Context {t4, t5, t6}
}
...

/David

==> 
==> Suppose you audit Root with ContextID = ALL.
==> You are supposed to get a list of ContextIds.
==> 
==> There is text that explains this in the Implementor's Guide,
==> but what, exactly, should you get?
==> 
==> You presumably say
==> Context=* {AuditValue=ROOT {Audit}}
==> 
==> What do you get back?
==> 
==> Context=1
==> Context=2
==> ...
==> 
==> 
==> or 
==> 
==> Context=1 {AuditValue=ROOT }
==> Context=2 {AuditValue=ROOT }
==> 
==> The problem with the latter is that the ABNF does not allow
==> a null Audit return.  I think it should.
==> 
==> Brian
==>

---

From: Chuong Nguyen <[email-masked]>
Date: Tue, 20 Feb 2001 15:46:59 -0600

Ok this clear my question on how contextTerminationAudit is used.
But I think the intend was for terminationId=ALL as indicated in Section 7.2.5 and
not
terminationId=ROOT.

And I think we have established that terminationId=ROOT <> terminationId=ALL.

Originally I was only interested in ContextId=ALL and terminationId=ALL and it was
missing from Section 7.2.5 AuditValue table.

I didn't care for the ContextId=ALL and terminationId=ROOT which I did not find
very useful.
From MGC, what would it do w/a list of ContextIds w/o any other info?
If one wants to remove all contexts, one has only to specify contextId=ALL.

What an MGC wants to know is for a particular in-use termination which context is
it in
so MGC can do a Subtract w/terminationId=ALL and specify a specific contextId.

So do we need contextId=ALL and terminationId=ROOT to return just a list of
contextIds?

Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Tue, 20 Feb 2001 18:31:55 -0500

I agree that the syntax doesn't allow any commands without termination
Identifiers. But this seems to be a special case where we use one
TerminationId in the request and receive different TerminationIDs in the
response. This was earlier possible only with the wildcards.

Best Regards.
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of David Dykhuizen
Sent: Tuesday, February 20, 2001 4:12 PM
To: [email-masked]
Subject: Re: ContextId List

Afternoon:

First according to the Implementor's Guide (Chapter 7.1 "Returning a Context
ID
List") we see the following wording:

at a minimum we need to have the empty list.  Then, according to the text
within
Chapter 7.2.5:

... Specifying an empty Audit Descriptor results in only the
TerminationID(s)
being returned ...

Context=* {
  AuditValue=ROOT {
    Audit {}
  }
}

results in:

Context=2000 {

/David

==>