Subject: Re: MG provisioning

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 5 Feb 2001 09:13:54 -0500

I agree with Tom, but also point out that there is no way for the
MGC to really know about this.  In theory it could infer it if it
audited the terminations in null, but since there is no explicit
mechanism, you are talking about something completely proprietary,
and it could be implemented so that if the termination was put in
a context, and then returned to null, it went to a different state.

Bottom line, I would say, is DON'T DO THIS!

Brian

> -----Original Message-----
> From: Tom Taylor [mailto:[email-masked]]
> Sent: Friday, February 02, 2001 7:14 PM
> To: [email-masked]
> Subject: Re: MG provisioning
>
>
> Yes, that is possible.  Whenever the termination returned to
> the null context
> the provisioned descriptor would apply until overridden by
> the MGC.  You would
> have to be careful not to get unexpected results (e.g.
> off-hook reported because
> the subscriber had not yet gone on-hook).  On a philosophical
> note, MGC
> designers might feel uneasy about having events enabled
> without explicit MGC
> control.
>
> Mario Monteiro wrote:
> >
> > The spec mentions that digitmaps can be provisioned at the MG. Can
> > EventDescriptors also be provisioned at the MG?
>

---

From: Christian Groves <[email-masked]>
Date: Tue, 6 Feb 2001 17:18:20 +1100

Its not proprietory, as Tom mentioned the provisioned descriptor would
apply. Its legal to do in the protocol you can audit a termination in
NULL so the MGC can find out what the MG has done. If people want to do
this notwithstanding Tom's philosophical note then who are we to police?

Christian