Subject: Re: Re. Send a syntax error

From: Nurit Shenhar <[email-masked]>
Date: Mon, 5 Feb 2001 13:51:51 +0200

If you do this, you will only get the same reply again from the
re-transmission mechanism.

-----Original Message-----
From: Richie Wu [mailto:[email-masked]]
Sent: Monday, February 05, 2001 1:41 PM
To: Nurit Shenhar
Cc: [email-masked]
Subject: Re. Send a syntax error

We can discard this response, and resend the
transaction again.

Regards,

Richie

=====
Huawei Technologies India Private Limited

Unit 10, 2nd Floor, Innovator Block
International Tech Park, Whitefield Main Road
Bangalore 560 066, India
TEL: 0091-80-841 0061/0753/0755
FAX: 0091-80-841 0063

__________________________________________________
Get personalized email addresses from Yahoo! Mail - only $35
a year!  http://personal.mail.yahoo.com/

---

From: Madhu Babu Brahmanapally <[email-masked]>
Date: Mon, 5 Feb 2001 10:22:34 -0500

hi Shenkar,list

If the transaction response sent is always the same, and is reply is
syntactically incorrect, there can be two cases
1) The responding entity encoded it incorrect
2) The receiving entity couldn't decode what the other entity has generated.
In case 1)THis is a implementation problem which we need not discuss these
on the list.
and for case 2) The responding entity is speaking in a language not
understood by transaction request generator (might be because of
incompatible capabilities). There should be a way to report to some entity
which is outside the scope of MEGACO which takes care of these inabilities.

Best Regards.

Madhubabu

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Nurit Shenhar
Sent: Monday, February 05, 2001 6:52 AM
To: [email-masked]
Subject: Re: Re. Send a syntax error

-----Original Message-----
From: Richie Wu [mailto:[email-masked]]
Sent: Monday, February 05, 2001 1:41 PM
To: Nurit Shenhar
Cc: [email-masked]
Subject: Re. Send a syntax error

Regards,

Richie

=====

---

From: Tom Taylor <[email-masked]>
Date: Mon, 5 Feb 2001 11:19:35 -0500

Agreed.  However, we deliberately excluded error responses to transaction
responses because they could set up response loops.  The MGC has to take some
sort of reasonable action when confronted with a response error, ranging from
limtied retransmission to closing down the association.