Subject: Missing EmbedSig in ABNF?

From: Lee Newman <[email-masked]>
Date: Mon, 5 Feb 2001 14:05:00 -0500

It seems to me that embedSig is missing as a choice from the eventParameter
rule in the ABNF for Megaco.  The ASN.1 allows you to specify a Signals
Descriptor in a RequestedEvent yet the ABNF does not.

Did I miss something?

Thanks.
Lee Newman, S-LiNK Corporation
7 Clarke Drive
Cranbury, NJ 08512
(609) 655-3111, xt. 309                    http://www.ss7-link.com

---

From: Tom Taylor <[email-masked]>
Date: Mon, 5 Feb 2001 14:34:03 -0500

No, the discrepancy in structure between the ASN.1 (which did it right in the
first place) and the ABNF (which I redrafted from something different) is my
fault, but the outcome is the same.  The two specifications wind up with the
same contents in the end.  Note the intermediate production EmbedWithSig in the
ABNF, which lets you get where you want.  And embedSig is there in the rule for
an embedded Events Descriptor.

---

From: Madhu Babu Brahmanapally <[email-masked]>
Date: Mon, 5 Feb 2001 14:46:00 -0500

hi lee,

I think the "embedWithSig" does the same as you say!!!
"embedSig" is used for the "secondEventParameter".

Best Regards.
Madhubabu

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Lee Newman
Sent: Monday, February 05, 2001 2:05 PM
To: [email-masked]
Subject: Missing EmbedSig in ABNF?

Did I miss something?

Thanks.