Subject: Re: Error Code Changes In Draft Annex L

From: "Griffeth, Nancy D (Nancy)" <[email-masked]>
Date: Tue, 6 Feb 2001 15:27:04 -0500

Tom,

Thanks for the clarifications of error codes; some of them are quite
cryptic.  If it's not too much trouble, we could use further clarification.

In Section 13.2 of the H.248 standard, it says:

"2.     A complete description of the conditions under which the error is
detected shall be included in a publicly available document.  The
description shall be sufficiently clear to differentiate the error from all
other existing error codes. "

Where would we find such a document?

Nancy Griffeth

> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Monday, February 05, 2001 12:50 PM
> To: [email-masked]
> Subject: Error Code Changes In Draft Annex L
>
>
> Draft H.248 Annex L can be found at
> ftp://standards.nortelnetworks.com/megaco/docs/Current/ITU-SG16/
>
> The editor (Christian Groves) has proposed changes to IANA
> registration for
> Megaco/H.248 error codes as follows:
>
> 400: change from "Bad Request" to "Syntax error in message"
>
> 403: Add the word "request", so description reads "Syntax error in
> transaction request"
>
> 441: Add the phrase "or local", so the description reads:
> "Missing Remote or
> Local Descriptor"
>
> 443: Add the phrase "Unsupported or", so the description
> reads "Unsupported
> or unknown command"
>
> 500: change from "Internal Gateway Error" to "Internal
> software Failure in
> MG"
>
> 505: change from "Command Received before Restart Response"
> to "Transaction
> Request Received before a ServiceChange"
>
> 520: change from "Media Gateway does not have a digit map" to
> "Digit Map
> undefined in the MG"
>
> 529: change from "Internal hardware failure" to "Internal
> hardware failure
> in MG"
>
> Moreover, the following additional codes are proposed:
> 434 - Max number of Terminations in a Context exceeded
> 457 - Missing parameter in signal or event
>
> Does anyone have concerns with any of these proposed changes?
>
> Tom Taylor
> Multimedia Control and Applications Standards
> Ph.  +1 613 736 0961
> Cell +1 613 290 0844
> [email-masked]
>

---

From: Christian Groves <[email-masked]>
Date: Wed, 7 Feb 2001 10:23:47 +1100

G'Day Nancy,

The document is H.248 Annex L. Hopefully in June is will be fully
approved at the SG16 meeting. I guess it will also be published as an
Informational RFC.

Cheers, Christian