Subject: RE: Does the First Line of SDP need a newline

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 21 Feb 2001 11:34:51 -0500

The issue, I believe, is the definition of SDP vs the definition of Megaco.
SDP is defined as not allowing whitespace before the "v="
So , which definition controls, the Megaco one, or the SDP one?
 
Brian
 
 -----Original Message-----
From: David Stonehouse [mailto:[email-masked]]
Sent: Wednesday, February 21, 2001 11:02 AM
To: [email-masked]'
Subject: RE: Does the First Line of SDP need a newline

Both of these are okay, because of the definition of LBRKT in the ABNF: 

localDescriptor = LocalToken LBRKT octetString RBRKT 
LBRKT  = LWSP %7B LWSP 

LWSP essentially means "optional white space", including the possiblity (not
necessity) of a carriage return for readability.  I see no reason to enforce
readibility at this point in the message.

Dave 

-----Original Message----- 
From: Rosen, Brian [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Wednesday, February 21, 2001 10:18 AM 
To: [email-masked]' 
Subject: Does the First Line of SDP need a newline 

Is this legal? 

        Add=termA { Media { Local {v=0 
m=.... 

or does is HAVE to be 
           Add=termA { Media { Local { 
v=0 
m=... 

Inquiring minds want to know!!! 

Brian

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 21 Feb 2001 21:06:45 -0500

I would say that SDP, not allowing whitespace before the "v=" does not
actually begin until you hit the "v=".  Up to that point, the message
is under the Megaco parsing constraints.  After that, until the end
of the SDP, the message is under the SDP parsing constraints.

Kevin

"Rosen, Brian" wrote:

The
issue, I believe, is the definition of SDP vs the definition of Megaco.SDP
is defined as not allowing whitespace before the "v="So
, which definition controls, the Megaco one, or the SDP one?Brian-----Original
Message-----

Sent: Wednesday, February
21, 2001 11:02 AM

To: [email-masked]'

Subject: RE: Does the First
Line of SDP need a newline

Both
of these are okay, because of the definition of LBRKT in the ABNF:

LBRKT  = LWSP %7B LWSP

LWSP essentially means "optional white space", including
the possiblity (not necessity) of a carriage return for readability.
I see no reason to enforce readibility at this point in the message.

Dave

-----Original Message-----

From: Rosen, Brian [mailto:[email-masked]]

To: [email-masked]'

Is this legal?

Add=termA {
Media { Local {v=0

m=....

or does is HAVE to be

v=0

m=...

Brian