Subject: Re: physical vs. ephemeral terminations

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 1 Feb 2001 13:39:23 -0500

y'know, I saw that discussion, and never said anything because
I never knew where the idea came from that you can't audit
a non-existent ephemeral.  I believed you could, precisely for
the reason we are discussing.  I'm glad you are as confused as
I.  Maybe we can claim you can in the absence of language to
the contrary in the spec.

More specifically, I think that if you do:
Context=-{W-AuditCapabilities=foo/*{Audit{Packages}}}}
you should get a meaningful response.

Brian

> -----Original Message-----
> From: Tom Taylor [mailto:[email-masked]]
> Sent: Thursday, February 01, 2001 12:31 PM
> To: [email-masked]
> Subject: Re: physical vs. ephemeral terminations
>
>
> In saying what I did about audits, I was quoted consensus
> doctrine (with
> which I do not personally agree) that you cannot audit capabilities of
> terminations which have not yet been instantiated.  I just
> tried to find
> any mention of this restriction in H.248 and failed.  Brian,
> do you know
> where it is, or is my memory of the position incorrect?
>
> Troy Cauble wrote:
> >
> > > Tom-PT Taylor wrote:
> > >
> > > Hi.
> > >
> > > > -----Original Message-----
> > > > From: Troy Cauble [mailto:[email-masked]]
> > > > Sent: Wednesday, January 31, 2001 7:53 PM
> > > > To: Taylor, Tom-PT [NORSE:B901:EXCH]
> > > > Cc: [email-masked]
> > > > Subject: Re: physical vs. ephemeral terminations
> > > >
> > > >
> > > >
> > > > Tom Taylor wrote:
> > > >
> > > > > >What is the error returned if an MG is asked to do something
> > > > > >it doesn't support (or doesn't even make sense) on that type
> > > > > >of termination?
> > > > > >        If it's asked to detect hook flash on an ephemeral
> > > > > >        termination?
> > > > >
> > > > > [PTT]
> > > > > 440 Unsupported or unknown package
> > > > >
> > > > > >        If it's asked to apply Local or Remote Descriptors
> > > > > >        to a physical termination?
> > > > >
> > > > > [PTT]
> > > > > Not an error, though the I-D describing SDP naming
> > > > conventions (SDP nettype, addrtype) for TDM circuits has to
> > > > be written.  You
> > > > > need the descriptors to describe the codec (as Madhue has
> > > > pointed out) and the bearer capability.
> > > >
> > > > Tom,
> > > >
> > > > Well, it's an error for a POTS line.  What's the error
> code for that?
> > > > (Don't say 440; we're not talking about packages here.)
> > >
> > > [PTT]
> > > Even for an analogue line you need SDP saying that it is
> carrying an audio
> > > stream.
> >
> > Really?!  What does that SDP look like?
> >
> > I thought you identified the codec, etc. in the ephemeral RTP
> > termination and added that and the analogue line termination
> > to the same context, a la #12 in Appendix A.
> >
> > > > I guess you're saying that the schema doesn't have to
> > > > explicity distinguish between termination types, as
> > > > long as the MGC and MG both know the mapping.  Correct?
> > > >
> > > > So a schema could be simply integers 1-1000, and the MGC just
> > > > knows that the POTS line to my house is 37, while 36
> > > > and 38 are to be used for RTP streams?
> > > [PTT]
> > > Don't forget audits, at least for physical terminations.
> There is a missing
> > > link for ephemerals: they can't be named or audited until
> they exist.  I
> > > think the answer has to be in defining container
> terminations representing
> > > the physical interfaces, as I mentioned yesterday.  I
> think I'll have a go at
> > > the necessary package definition today.
> >
> > "can't be named until they exist"
> >
> > OK. Let's see if I've got this right...
> >
> > Physical terminations always "exist", they just move to and from
> > the null context.
> > Ephemeral terminations are created and destroyed.
> >
> > Does CHOOSE mean "choose among the existing" or "choose
> > among the entire schema".  I guess it means the latter
> > otherwise we couldn't create an ephemeral with Add/CHOOSE.
> >
> > So by "can't be named", do you mean by the MGC?  As in the
> > MGC can't say "Add termination RTP/8" for ephemerals even
> > though it knows the schema and knows that it's not in use
> > (doesn't "exist")?
> > So the MGC *MUST* use Add/CHOOSE for ephemerals?
> >
> > Thanks,
> > -troy
>

---

From: Madhu Babu Brahmanapally <[email-masked]>
Date: Thu, 1 Feb 2001 20:05:31 -0500

Hi Brian,list,
How can MG/MGC responds on terminations that are not existing. Ephemeral
terminations are created and destroyed by Add and Subtract commands.
Commands to Ephemeral terminations always should be addressed with valid
Context Identifiers. I'm confused how MGC can Audit on terminations that
doesn't exist (Irrespective of the naming schema)? Am I missing anything
here!!

Best Regards.
Madhubabu

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Rosen, Brian
Sent: Thursday, February 01, 2001 1:39 PM
To: [email-masked]
Subject: Re: physical vs. ephemeral terminations

Brian

---

From: Troy Cauble <[email-masked]>
Date: Fri, 2 Feb 2001 13:12:50 -0500

Well, "exist", "create", and "destroy" are just words here.
It seems that some people may be interpretting them differently.

Frankly, if there is an addressing scheme for all terminations,
I think the exist/create/destroy concepts just confuse things,
especially when they're only applied to some termination types.

It's not at all clear (to me) that an MGC can't say

        Add = ephemeral/1 { ... }

if it knows the schema and knows ephemeral/1 is not in use
(doesn't "exist").

-troy