Subject: RE: Does the First Line of SDP need a newline

From: "David Stonehouse" <[email-masked]>
Date: Wed, 21 Feb 2001 11:01:34 -0500

Both of these are okay, because of the definition of LBRKT in the ABNF:

localDescriptor = LocalToken LBRKT octetString RBRKT
LBRKT  = LWSP %7B LWSP

LWSP essentially means "optional white space", including the possiblity (not
necessity) of a carriage return for readability.  I see no reason to enforce
readibility at this point in the message.

Dave

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Wednesday, February 21, 2001 10:18 AM
To: [email-masked]'
Subject: Does the First Line of SDP need a newline

Is this legal?

        Add=termA { Media { Local {v=0
m=....

or does is HAVE to be
	   Add=termA { Media { Local {
v=0
m=...

Inquiring minds want to know!!!

Brian

---

From: Chuong Nguyen <[email-masked]>
Date: Wed, 21 Feb 2001 11:32:58 -0600

We were intepreting this as, you can have as many white space after the
"{" but
SDP still start on a new line due to the SDP spec.

Let's not mix the 2 things where we go back and forth about not using
SDP.

Chuong

David Stonehouse wrote:

> LWSP essentially means "optional white space", including the
> possiblity (not necessity) of a carriage return for readability.  I
> see no reason to enforce readibility at this point in the message.
>
> Dave
>

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****