Subject: RE: Optional Property value

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 28 Feb 2001 09:04:53 -0500

AuditCapability of Media returns the possible VALUES of the
properties, not merely a list of those properties, so I don't
think this is correct.

Brian

> -----Original Message-----
> From: Madhu Babu Brahmanapally [mailto:[email-masked]]
> Sent: Tuesday, February 27, 2001 5:04 PM
> To: 'megaco'
> Subject: Optional Property value
> 
> 
> HI all,
> The Audit Capability command can return the properties that 
> are implemented
> on the termination. Similar to the statistics descriptor the 
> property value
> should be optional thus allowing MG to return only the list 
> of properties
> that are support on the termination. The grammar now has
> 
> 
> propertyParm         = pkgdName parmValue
> 
> this needs to be modified to
> 
> propertyParm         = pkgdName [ parmValue ].
> 
> Best Regards.
> Madhubabu
>

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Wed, 28 Feb 2001 09:25:13 -0500

HI Brian,list,
The Section 6.2.5 mentions only that "an AuditCapability is used to
determine what properties of root are implemented". It was not explicit
whether the possible values are also returned or not. So, this to true for
any descriptor also. Ex. The event descriptor in Audit capability not only
lists the events but also the parameters and the possible values of it.

Best Regards.
Madhubabu

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Wednesday, February 28, 2001 9:05 AM
To: 'Madhu Babu Brahmanapally'; 'megaco'
Subject: RE: Optional Property value

Brian