Subject: RE: Does the First Line of SDP need a newline

From: Lee Newman <[email-masked]>
Date: Wed, 21 Feb 2001 14:42:39 -0500

The 'v' is the first character of the SDP string.  Anything preceeding that
is irrelevan to an SDP parser.  The SDP RFC does not indicate that the first
character of an SDP is a newline.

This being the case ,I still believe that either string is allowed.

Lee

-----Original Message-----
From: Chuong Nguyen
To: megaco
Sent: 2/21/01 12:32 PM
Subject: Re: Does the First Line of SDP need a newline

We were intepreting this as, you can have as many white space after the
"{" but 
SDP still start on a new line due to the SDP spec. 

Let's not mix the 2 things where we go back and forth about not using
SDP. 

Chuong 

David Stonehouse wrote: 

Both of these are okay, because of the definition of LBRKT in the ABNF: 

localDescriptor = LocalToken LBRKT octetString RBRKT 
LBRKT  = LWSP %7B LWSP 

LWSP essentially means "optional white space", including the possiblity
(not necessity) of a carriage return for readability.  I see no reason
to enforce readibility at this point in the message. 

Dave 

-----Original Message----- 
From: Rosen, Brian [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Wednesday, February 21, 2001 10:18 AM 
To: [email-masked]' 
Subject: Does the First Line of SDP need a newline 

Is this legal? 

        Add=termA { Media { Local {v=0 
m=.... 

or does is HAVE to be 
           Add=termA { Media { Local { 
v=0 
m=... 

Inquiring minds want to know!!! 

Brian

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Chuong Nguyen <[email-masked]>
Date: Wed, 21 Feb 2001 15:40:22 -0600

Yes, I remember now.  The first line after the "{" should not be an issue.
From Brian's original question both should be allowed.

It is each line (or in SDP terminology - record) that needs to end w/a CRLF or
a newline.

From SDP spec.

"The sequence
   CRLF (0x0d0a) is used to end a record, although parsers should be
   tolerant and also accept records terminated with a single newline
   character. "

From SDP spec Appendix A:  SDP Grammer

   proto-version =       "v=" 1*DIGIT CRLF
                         ;this memo describes version 0

   origin-field =        "o=" username space
                         sess-id space sess-version space
                         nettype space addrtype space
                         addr CRLF

   session-name-field =  "s=" text CRLF

   information-field =   ["i=" text CRLF]

   uri-field =           ["u=" uri CRLF]

   email-fields =        *("e=" email-address CRLF)