Subject: Event Descriptor

From: Albert Frankovich <[email-masked]>
Date: Fri, 2 Feb 2001 17:05:45 -0600

Hello,

Can a single event descriptor be specified to detect and
handle the following:
First, detect and report off-hook.
After off-hook is detected be able to issue dial tone and collect digits

using a provisioned digit map.  Maybe this can be done using an embedded

descriptor.

Thanks,
Al

---

From: Tom Taylor <[email-masked]>
Date: Fri, 2 Feb 2001 19:25:32 -0500

The embedded event descriptor is precisely how this would be done.

---

From: Madhu Babu Brahmanapally <[email-masked]>
Date: Fri, 2 Feb 2001 19:49:45 -0500

hi Albert,
As Tom suggested this can be done by using the embedded event and signal
descriptors. According to the protocol only a single event descriptor will
be sent from MGC and only one event descriptor can be there at MG. I think
your interpretation of "single event descriptor" is event descriptor with
single event. Is that what you need?? The call flow document will be useful
for illustrating many of the protocol features (ex. One like this scenario).

Best Regards.
Madhubabu

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Albert
Frankovich
Sent: Friday, February 02, 2001 6:06 PM
To: [email-masked]
Subject: Event Descriptor

Hello,

descriptor.

Thanks,
Al

---

From: Albert Frankovich <[email-masked]>
Date: Mon, 5 Feb 2001 12:59:53 -0600

Tom,

Thanks for the quick reply to my first question.

I have another question related to embedded descriptors.
White embedded descriptor the spec says,
"Notification may be deferred if the event is absorbed into the current
dial string of an active digit map" (section 7.1.14).

Therefore it is not clear if the off-hook is reported when an embedded
event specifying the use of a digit map on off-hook exists
or if the notification to the MGC only occurs after the dialed digits
are collected.

Al

---

From: Madhu Babu Brahmanapally <[email-masked]>
Date: Mon, 5 Feb 2001 14:40:49 -0500

hi Albert,
I think you are talking of an example like this.

  MEGACO/1 [123.123.123.4]:55555
   Transaction = 10001 {
       Context = - {
           Modify = A4444 {
               Events = 2223 {
                   al/of { Embed { signals {cg/dt}, Events= dd/ce {Digit
Map=Dialplan0}} }
               }
                }
           }

The digit map becomes active after the off-hook event is detected. Off-hook
event is reported to MGC.
The dial tone is applied and simultaneously detection starts for digits with
dial pattern Dialplan0.
After the DialPlan0 is matched, all the collected digits are reported as
"ds"(digit string)parameter value to MGC with the event as dd/ce.

Best Regards.
Madhubabu

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Albert
Frankovich
Sent: Monday, February 05, 2001 2:00 PM
To: [email-masked]
Subject: Re: Event Descriptor

Tom,

Al