Subject: Re: physical vs. ephemeral terminations

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 1 Feb 2001 08:54:54 -0500

Hi.

> -----Original Message-----
> From: Troy Cauble [mailto:[email-masked]]
> Sent: Wednesday, January 31, 2001 7:53 PM
> To: Taylor, Tom-PT [NORSE:B901:EXCH]
> Cc: [email-masked]
> Subject: Re: physical vs. ephemeral terminations
>
>
>
> Tom Taylor wrote:
>
> > >What is the error returned if an MG is asked to do something
> > >it doesn't support (or doesn't even make sense) on that type
> > >of termination?
> > >        If it's asked to detect hook flash on an ephemeral
> > >        termination?
> >
> > [PTT]
> > 440 Unsupported or unknown package
> >
> > >        If it's asked to apply Local or Remote Descriptors
> > >        to a physical termination?
> >
> > [PTT]
> > Not an error, though the I-D describing SDP naming
> conventions (SDP nettype, addrtype) for TDM circuits has to
> be written.  You
> > need the descriptors to describe the codec (as Madhue has
> pointed out) and the bearer capability.
>
> Tom,
>
> Well, it's an error for a POTS line.  What's the error code for that?
> (Don't say 440; we're not talking about packages here.)

[PTT]
Even for an analogue line you need SDP saying that it is carrying an audio
stream.

>
> >
> > >
> > >This seems to indicate a whole class of syntactically correct,
> > >but nonsensical combinations.
> >
> > [PTT]
> > Error code 440 covers a lot of it.
>
> But not all :(
>
>
> > >Also, it seems that given a termination id of CHOOSE, an MG must
> > >traverse descriptors looking for clues that indicate whether it
> > >should CHOOSE an ephemeral or physical termination.  Correct?
> > >What if there is no forcing hint?
> >
> > [PTT]
> > I gave my own answer to that a while ago.  Basically the
> termination is treated as an empty software container waiting
> to be filled
> > with detail.
>
> This makes for nice viewgraphs, but difficult implementations :(

[PTT]
True.  You end up with a copntainer object with a bunch of pointers to the
real content.

>
>
> >
> > >
> > >        A termination id schema must clearly distinguish between
> > >        physical and ephemeral so the MGC knows how to pick a
> > >        termination associated with some physical attribute
> > >        (such as "POTS line 7"), yes?
> >
> > [PTT]
> > It has been pointed out that there is no necessary
> association between termination type and name, even if the
> latter is based on a
> > physical schema (e.g. shelf/slot). It might be possible to
> insert various card types (ATM, TDM, ethernet) into the same slot.
>
> I guess you're saying that the schema doesn't have to
> explicity distinguish between termination types, as
> long as the MGC and MG both know the mapping.  Correct?
>
> So a schema could be simply integers 1-1000, and the MGC just
> knows that the POTS line to my house is 37, while 36
> and 38 are to be used for RTP streams?
[PTT]
Don't forget audits, at least for physical terminations.  There is a missing
link for ephemerals: they can't be named or audited until they exist.  I
think the answer has to be in defining container terminations representing
the physical interfaces, as I mentioned yesterday.  I think I'll have a go
at the necessary package definition today.

> Thanks,
> -troy

---

From: Troy Cauble <[email-masked]>
Date: Thu, 1 Feb 2001 11:26:37 -0500

> Tom-PT Taylor wrote:

Really?!  What does that SDP look like?

I thought you identified the codec, etc. in the ephemeral RTP
termination and added that and the analogue line termination
to the same context, a la #12 in Appendix A.

> the physical interfaces, as I mentioned yesterday.  I think I'll have a go at
> the necessary package definition today.

"can't be named until they exist"

OK. Let's see if I've got this right...

Physical terminations always "exist", they just move to and from
the null context.
Ephemeral terminations are created and destroyed.

Does CHOOSE mean "choose among the existing" or "choose
among the entire schema".  I guess it means the latter
otherwise we couldn't create an ephemeral with Add/CHOOSE.

So by "can't be named", do you mean by the MGC?  As in the
MGC can't say "Add termination RTP/8" for ephemerals even
though it knows the schema and knows that it's not in use
(doesn't "exist")?
So the MGC *MUST* use Add/CHOOSE for ephemerals?

Thanks,
-troy

---

From: Tom Taylor <[email-masked]>
Date: Thu, 1 Feb 2001 12:31:23 -0500

In saying what I did about audits, I was quoted consensus doctrine (with
which I do not personally agree) that you cannot audit capabilities of
terminations which have not yet been instantiated.  I just tried to find
any mention of this restriction in H.248 and failed.  Brian, do you know
where it is, or is my memory of the position incorrect?