Subject: No Statistics

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 21 Feb 2001 09:28:12 -0500

Suppose you have a physical termination that implements the 
analog line package. It happens that that package does not 
define any statistics.

What do you get on Subtract?  Your options are:
	An Empty Statistics Descriptor
	No Statistics Descriptor

Wait, before you answer, consider:
If you specifically Audit Statistics of such a termination,
what do you get? (one of the above two, or an error??)

Remember that if you send an empty Audit on a Subtract,
you get no Statistics!

Now, I don't feel strongly about this, but I would say,
if there are no statistics to report, you don't get
a descriptor on Subtract.  If you Audit Statistics on
a termination with no statistics to offer, you get
an empty Statistics Descriptor.

Brian

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Wed, 21 Feb 2001 11:03:16 -0500

Hi Brian,list,

The Network Package is one package that can be implemented irrespective of
the type of termination. The physical termination even if they support
analog line supervision package can support the Network Package. The
Duration, Octets sent and Octets received can be made applicable to these
terminations also. Infact the Megaco protocol draft 0.1 even addressed this
issue of calculating Octets sent/received depending upon the transfer rate
on physical terminations. At least duration can be one useful statistic that
can be expected on physical terminations that supports analog line package.

Best Regards.
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Rosen, Brian
Sent: Wednesday, February 21, 2001 9:28 AM
To: [email-masked]'
Subject: No Statistics

Brian

---

From: Chuong Nguyen <[email-masked]>
Date: Wed, 21 Feb 2001 16:51:04 -0600

I am going to have to vote for "No Statistic Descriptor"

1) The request is  Subtract = terminationId
     There is no audit descriptor to start w/.
      So the argument about Audit Statistics does not apply here.
     Now if we had started w/that one has to always use AuditDescriptor
w/StatisticsDescrp
     to get the statistics on Subtract instead of statistics is returned
by default for Subtract,
     then one would have to return an empty StatisticsDescrip to be
consistent w/the
     use of AuditDescrip in Audit Statistics.

2) There is no point in return an empty Statistics Descriptor to
indicate that there is
     no statistics.  The less stuffs to parse the better.

3) One might question how does one really know that there was no
Statistics or
     there was an error.  If there was an error, one would have gotten
an ErrorDescriptor.

4) Ok That is how I got it implemented.

Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****