Subject: Properties

From: "Randy Younts" <[email-masked]>
Date: Tue, 27 Feb 2001 09:57:32 -0500

Can properties have their values changed in the reply to a command?  In
section 6.2.4, it states, "In some cases, descriptors are returned as output
from a command."  It sounds like property negotiation.  The following
message flow was suggested to me.  I am under the impression that property
values can only be read by auditing for them.  Which is correct.

MEGACO/1 [47.174.64.80]:2944
Transaction=11 {
 Context=- {
     Modify=TP2 {
         Media {
             LocalControl {
                 mta/mtapt = 1
                 mta/cfg   = lp
} } } } }

MEGACO/1 [47.140.7.191]:2427
Reply=11 {
 Context=- {
     Modify=TP2 {
         Media {
             LocalControl {
                 mta/mtapt = 1
                 mta/splitCap = NSFS
                 mta/monCap   = No
} } } } }

   Two roads diverged in a wood, and I-
   I took the one less traveled by,
   And that has made all the difference.
                         -Robert Frost
--------------------------------------------
 
W. Randy Younts      GWC Protocols
NORTEL NETWORKS      Dept. 3Z90
35 Davis Dr.         Voice: (919) 991-2014
RTP, NC  27709       ESN: 351-2014

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Tue, 27 Feb 2001 12:29:03 -0500

Propertieshi Randy,
According to section 7.1.5 the MG can select one value of the property when
multiple are specified, or selects its own value of property when CHOOSE
wildcard is used. If the property value specified is range or greater
than/less than, the MG then have to use those values specified by MGC. But
if alternative values are specified or CHOOSE wildcard is used MG has to
specify the value and to be sent in response. Of course there are values
that are read only like the number of terminations in contexts, max number
of contexts, etc.

Best Regards.
Madhubabu
  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Randy Younts
  Sent: Tuesday, February 27, 2001 9:58 AM
  To: Megaco (E-mail)
  Subject: Properties

  Transaction=11

   Context=-

       Modify=TP2

           Media

               LocalControl

                   mta/mtapt = 1
                   mta/cfg   = lp
  } } } } }

  Reply=11

   Context=-

       Modify=TP2

           Media

               LocalControl

                   mta/mtapt = 1
                   mta/splitCap = NSFS
                   mta/monCap   = No
  } } } } }