Subject: RE: ContextId List

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 20 Feb 2001 15:47:06 -0500

Yes I want a list of active contexts, nothing else
 
The text is Section 7.1 of the currently approved Implementor's Guide
dated 13-17 November.
 
I would not want to modify Context Audit to return ContextIds, although I
agree
this would work.
 
I've never really understood context audits, so I never replied to the
question
you raised.  Perhaps Christian could answer.
 
Brian

-----Original Message-----
From: Chuong Nguyen [mailto:[email-masked]]
Sent: Tuesday, February 20, 2001 2:56 PM
To: megaco
Subject: Re: ContextId List

First what is the intend of this - to find all active contexts on the
gateway (ROOT=gateway) 
but doesn't want to know anything else? 

Where is this text in the Implementor's Guide and what version of the
Implementor's Guide 
are you referring to? 

We already have the precedent of 
contextTerminationAudit = EQUAL CtxToken (terminationIDList/ LBRKT
errorDescriptor 
RBRKT) 

which I have asked several time how does one format the request that will
give this exact 
reply where one wants to know just the terminationIdList in the context. 

So can we have 

contextAudit = EQUAL CtxToken(contextIDList ....... which will give a more
compact 
reply that the options you suggested below: 

Chuong 

"Rosen, Brian" wrote: 

Suppose you audit Root with ContextID = ALL. 
You are supposed to get a list of ContextIds. 

There is text that explains this in the Implementor's Guide, 
but what, exactly, should you get? 

You presumably say 
Context=* {AuditValue=ROOT {Audit}} 

What do you get back? 

Context=1 
Context=2 
... 

or 

Context=1 {AuditValue=ROOT } 
Context=2 {AuditValue=ROOT } 

The problem with the latter is that the ABNF does not allow 
a null Audit return.  I think it should. 

Brian

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Dave Sclarsky <[email-masked]>
Date: Wed, 21 Feb 2001 01:14:56 -0500

I believe that the intent of the spec is to be able to get a 'list of
context IDs'.  Abbreviated from 7.2.5:

+-----------+---------------+------------------------+
| ContextID | TerminationID | Information Obtained   |
+-----------+---------------+------------------------+
| All       | Root          | List of all ContextIds |
+-----------+---------------+------------------------+

The problem is that the encoding (ABNF at least) doesn't allow this.  I
think that a clean solution would be to add 'contextIDList' to the grammar,
modeled after terminationIDList.  Then the definition of auditReply could be
changed to allow contextIDList in addition to contextTerminationAudit and
auditOther.

The text that David pointed out in 7.2.5 would also probably need to change
for this special case, to say somthing like:

... Specifying an empty Audit Descriptor results in only the TerminationID
being returned, except when the audit reply only contains a list of context
IDs ...

Is this reasonable?

Dave Sclarsky
S-Link Corporation.

-----Original Message-----
From: Madhu Babu Brahmanapally
To: 'David Dykhuizen'; [email-masked]
Sent: 2/20/01 6:31 PM
Subject: RE: ContextId List

I agree that the syntax doesn't allow any commands without termination
Identifiers. But this seems to be a special case where we use one
TerminationId in the request and receive different TerminationIDs in the
response. This was earlier possible only with the wildcards.

Best Regards.
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of David Dykhuizen
Sent: Tuesday, February 20, 2001 4:12 PM
To: [email-masked]
Subject: Re: ContextId List

Afternoon:

First according to the Implementor's Guide (Chapter 7.1 "Returning a
Context
ID
List") we see the following wording:

"The list of Context Ids should be returned by using multiple Action
Replys,
each containing a context from the list."

Second would question the outgoing request - according to the ABNF:

auditDescriptor = AuditToken LBRKT [ auditItem *(COMMA auditItem) ]
RBRKT

at a minimum we need to have the empty list.  Then, according to the
text
within
Chapter 7.2.5:

... Specifying an empty Audit Descriptor results in only the
TerminationID(s)
being returned ...

Hence according to our existing ABNF syntax:

Context=* {
  AuditValue=ROOT {
    Audit {}
  }
}

results in:

Context=2000 {
  AuditValue=Context {t1, t2}
}
Context=3000 {
  AuditValue=Context {t3}
}
Context=4000 {
  AuditValue=Context {t4, t5, t6}
}
...

/David

==>
==> Suppose you audit Root with ContextID = ALL.
==> You are supposed to get a list of ContextIds.
==>
==> There is text that explains this in the Implementor's Guide,
==> but what, exactly, should you get?
==>
==> You presumably say
==> Context=* {AuditValue=ROOT {Audit}}
==>
==> What do you get back?
==>
==> Context=1
==> Context=2
==> ...
==>
==>
==> or
==>
==> Context=1 {AuditValue=ROOT }
==> Context=2 {AuditValue=ROOT }
==>
==> The problem with the latter is that the ABNF does not allow
==> a null Audit return.  I think it should.
==>
==> Brian
==>