Subject: Audit of Termination State ONLY

From: Alan Whitton <[email-masked]>
Date: Tue, 6 Feb 2001 10:36:34 -0500

Greetings,

Is it possible to create a "tight" audit of the "state" of a termination
ONLY.

So far I have an audit (of a physical set of DS0s) that would look like:

Megaco/1 [ kilroy ]
Transaction = 4096 {
  Context = - {
    AuditValue = TDM_Connect_1* {
      Audit {media}         // Looking for state of each DS0
    }
  }
}

but I assume I would get back a list that matches the wildcard with the
following "baggage":

Reply = 4096 {
  Context = - {
    AuditValue = TDM_Connect_1_2 {
      Media {
        TerminationState { ServiceStates = InService,
           Buffer = OFF },
         Stream = 1 {
           LocalControl { Mode = SendReceive,
                       nt/jit=40 },
            Local {
   v=0
   c=IN IP4 127.0.0.1
   m=audio 1111 RTP/AVP  4
   a=ptime:30
      }
etc., etc., etc.,

All I really want is the ServiceStates of the termination ONLY. Is it
possible to ONLY audit that?

Cheers,
Alan Whitton
Nortel Networks Inc.,

---

From: Madhu Babu Brahmanapally <[email-masked]>
Date: Tue, 6 Feb 2001 11:28:24 -0500

hi Alan,
I think the Audit mechanism is defined only at the level of descriptor and
not to the level the parameters in each of the descriptor. I agree that in
your case it ends to be useful to have parameter wise auditing. but this
unnecessarily increase the  complexity of MG/MGC implementation, leading to
many combinations of parameters in Audit.
Best Regards.
Madhubabu

-----Original Message-----
From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Alan Whitton
Sent: Tuesday, February 06, 2001 10:37 AM
To: [email-masked]
Subject: Audit of Termination State ONLY

Greetings,

Megaco/1 [ kilroy ]
Transaction = 4096 {
  Context = - {

Reply = 4096 {
  Context = - {

Cheers,
Alan Whitton
Nortel Networks Inc.,

---

From: Christian Groves <[email-masked]>
Date: Wed, 7 Feb 2001 10:21:40 +1100

G'Day Alan,

Not in H.248v1 in H.248v2 this will be possible. This functionality was
accepted in the Aug 2000 SG16 meeting. I'm currently drafting up
text/ASN1/ABNF that explains how this is done.

Cheers, Christian