Subject: Re: The use of LWSP around EQUAL, LBRKT, RBRKT, COMMA

From: "Paul Long" <[email-masked]>
Date: Sat, 24 Feb 2001 15:04:06 -0500

Chuong,

What you propose is redundant. LWSP is defined as _zero_ or more (not one or more) occurences of WSP, COMMENT, or EOL. Therefore the EQUAL token, for example, can already have the value of just, "=", without any surrounding whitespace, comments, or EOLs.

Paul Long
ipDialog, Inc.

---------- Original Message ----------------------------------
From: Chuong Nguyen <[email-masked]>
Date: Sat, 24 Feb 2001 11:34:30 -0600

<snip>
>Maybe they should be defined as shown below.
>The same way that token name is defined w/long and short names.
>This shouldn't impact anyone parser.
>
> EQUAL                = (LWSP %x3D LWSP          /            "=")
>   LBRKT                = (LWSP %x7B LWSP           /             "{")
>   RBRKT                = (LWSP %x7D LWSP           /             "}")
>   COMMA                = (LWSP %x2C LWSP       /              ",")
>
>
>
>Chuong

---

From: Chuong Nguyen <[email-masked]>
Date: Sat, 24 Feb 2001 14:32:53 -0600

Now looking at how * is used in the ABNF.  I see.

Thanks

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: "Paul Long" <[email-masked]>
Date: Mon, 26 Feb 2001 14:49:49 -0600

I come from the H.323 world where the ASN.1 message syntax is inherently
extensible, thus providing a valuable mechanism for compatibility between
different versions of the protocol. This same mechanism is also available in
the Megaco binary encoding, but how is this handled in the Megaco ABNF text
encoding? Specifically, what should I do as an implementor to assure that my
v1 MG will be forward compatible with, for example, a v2 MGC? Or is version
compatibility even a goal in Megaco (MG/MGC deployment will be homogeneous
with repect to version)? IOW, will the ABNF syntax ever change? If so, how
can my ABNF parser distinguish between an extension to the syntax and a true
encoding error?

Paul Long
ipDialog, Inc.