Subject: ContextId List

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 20 Feb 2001 13:55:52 -0500

Suppose you audit Root with ContextID = ALL.
You are supposed to get a list of ContextIds.

There is text that explains this in the Implementor's Guide,
but what, exactly, should you get?

You presumably say
Context=* {AuditValue=ROOT {Audit}}

What do you get back?

Context=1
Context=2
...

or 

Context=1 {AuditValue=ROOT }
Context=2 {AuditValue=ROOT }

The problem with the latter is that the ABNF does not allow
a null Audit return.  I think it should.

Brian

---

From: Chuong Nguyen <[email-masked]>
Date: Tue, 20 Feb 2001 13:56:14 -0600

First what is the intend of this - to find all active contexts on the
gateway (ROOT=gateway)
but doesn't want to know anything else?

Where is this text in the Implementor's Guide and what version of the
Implementor's Guide
are you referring to?

We already have the precedent of
contextTerminationAudit = EQUAL CtxToken (terminationIDList/ LBRKT
errorDescriptor
RBRKT)

which I have asked several time how does one format the request that
will give this exact
reply where one wants to know just the terminationIdList in the context.

So can we have

contextAudit = EQUAL CtxToken(contextIDList ....... which will give a
more compact
reply that the options you suggested below:

Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****