Subject: RE: Does the First Line of SDP need a newline

From: Lee Newman <[email-masked]>
Date: Wed, 21 Feb 2001 11:10:32 -0500

The first line is just as legal as the second.  What argument is made
against the first?

Lee

-----Original Message-----
From: Rosen, Brian
To: [email-masked]'
Sent: 2/21/01 10:18 AM
Subject: Does the First Line of SDP need a newline

Is this legal?

        Add=termA { Media { Local {v=0
m=....

or does is HAVE to be
	   Add=termA { Media { Local {
v=0
m=...

Inquiring minds want to know!!!

Brian

---

From: "Duraisamy, Kandaprabhu (Kandaprabhu)** CTR **" <[email-masked]>
Date: Wed, 21 Feb 2001 11:36:08 -0500

Both are legal.You can use a Whitespace character or not(personal
perferences)

-Prabhu

---

From: "David Stonehouse" <[email-masked]>
Date: Wed, 21 Feb 2001 12:14:26 -0500

The Megaco parser must match the LBRKT completely (including LWSP) before
moving on to processing the OctetString.  That means that because LWSP
precedes the octetString, the first character of the OctetString is
restricted from matching any variant of LWSP.  For this reason, the SDP
"parser" shouldn't be seeing an initial newline character.
 
Dave

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Wednesday, February 21, 2001 11:35 AM
To: Stonehouse, David [NC1:GW10:EXCH]; [email-masked]'
Subject: RE: Does the First Line of SDP need a newline

The issue, I believe, is the definition of SDP vs the definition of Megaco.
SDP is defined as not allowing whitespace before the "v="
So , which definition controls, the Megaco one, or the SDP one?
 
Brian
 
 -----Original Message-----
From: David Stonehouse [mailto:[email-masked]]
Sent: Wednesday, February 21, 2001 11:02 AM
To: [email-masked]'
Subject: RE: Does the First Line of SDP need a newline

Both of these are okay, because of the definition of LBRKT in the ABNF: 

localDescriptor = LocalToken LBRKT octetString RBRKT 
LBRKT  = LWSP %7B LWSP 

LWSP essentially means "optional white space", including the possiblity (not
necessity) of a carriage return for readability.  I see no reason to enforce
readibility at this point in the message.

Dave 

-----Original Message----- 
From: Rosen, Brian [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Wednesday, February 21, 2001 10:18 AM 
To: [email-masked]' 
Subject: Does the First Line of SDP need a newline 

Is this legal? 

or does is HAVE to be 

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 21 Feb 2001 13:17:36 -0500

I think we have consensus that the SDP spec requires no whitespace,
but David Stonehouse points out that it's the Megaco part that has
trailing whitespace after the LBRKT, so, in theory, the SDP parser
would not see the whitespace.  
 
Tom Taylor, you might want to make this call, but I think that we ought to
say,
allowed, but discouraged, ie don't send it, but accept it.
 
Brian

-----Original Message-----
From: Chuong Nguyen [mailto:[email-masked]]
Sent: Wednesday, February 21, 2001 12:31 PM
To: megaco
Subject: Re: Does the First Line of SDP need a newline

We do the same thing too. 
We checked last year and it is in the SDP spec. 

Sophia Scoggins wrote: 

We use a third-party SDP parser which requires SDP starting at a new line.
Is 
it specified in SDP spec? 

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Lee Newman <[email-masked]>
Date: Wed, 21 Feb 2001 14:44:04 -0500

The 'v' is the first character of the SDP string.  Anything preceeding
that is irrelevan to an SDP parser.  The SDP RFC does not indicate that
the first character of an SDP is a newline.

This being the case ,I still believe that either string is allowed.

Lee

-----Original Message-----
From: Chuong Nguyen
To: megaco
Sent: 2/21/01 12:32 PM
Subject: Re: Does the First Line of SDP need a newline

We were intepreting this as, you can have as many white space after the
"{" but 
SDP still start on a new line due to the SDP spec. 

Let's not mix the 2 things where we go back and forth about not using
SDP. 

Chuong 

David Stonehouse wrote: 

LWSP essentially means "optional white space", including the possiblity
(not necessity) of a carriage return for readability.  I see no reason
to enforce readibility at this point in the message. 

Dave 

-----Original Message----- 

Is this legal? 

or does is HAVE to be 

Brian

--

---

From: "Tulpule, Naren" <[email-masked]>
Date: Fri, 23 Feb 2001 13:06:22 -0800

Hi guys,
   please be kind to parser writers. Since LBRKT includes LWSP which
includes a newline, you're asking them to choose a REDUCE over a SHIFT. Also
RFC 2327 doesn't say v= has to be preceded by a newline.
  And while we are on the subject of SDP changes, Rajesh Kumar et al have
specified the changes for ATM support in SDP. But Megaco group hasn't
explicitly specified what changes we made (except on the mailing list). E.g.
where to use $'s for choose, ranges etc etc. So writing an SDP parser with
Megaco requirements is still kind of ill-defined. 

-- Naren. 
These views and opinions are mine alone, not those of Intel    (yet ;-) 
Narendra C. Tulpule SMTS, Trillium (an Intel company) 
Ph: +1-310-442-9222              Fax: +1-310-442-1162 
12100 Wilshire Bl #1800         Los Angeles, CA 90025 

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Wednesday, February 21, 2001 10:18 AM
To: 'Chuong Nguyen'; megaco
Subject: RE: Does the First Line of SDP need a newline

 
Brian

-----Original Message-----
From: Chuong Nguyen [mailto:[email-masked]]
Sent: Wednesday, February 21, 2001 12:31 PM
To: megaco
Subject: Re: Does the First Line of SDP need a newline

Sophia Scoggins wrote: 

--

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 23 Feb 2001 16:37:09 -0500

I guess I'm a little confused on both points
 
Are you advocating that the newline before v= is required, or not required?
I interpret what
you are saying is that newline being included in whitespace, the Megaco
parser will stop at
the "v" and the SDP starts there, so newline is NOT required before v=.
 
I have put out a draft of the ATM Package for Megaco, which, despite the
controversy over
the special context, I will submit to the IETF I-D editor today.   I believe
that Rajesh's work
uses CHOOSE the way Megaco does.  I don't rememeber range issues in the
atmsdp stuff.
What would you have use do in Megaco exactly?
 
Brian

-----Original Message-----
From: Tulpule, Naren [mailto:[email-masked]]
Sent: Friday, February 23, 2001 4:06 PM
To: megaco
Subject: RE: Does the First Line of SDP need a newline

Hi guys,

-- Naren. 

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Wednesday, February 21, 2001 10:18 AM
To: 'Chuong Nguyen'; megaco
Subject: RE: Does the First Line of SDP need a newline

 
Brian

-----Original Message-----
From: Chuong Nguyen [mailto:[email-masked]]
Sent: Wednesday, February 21, 2001 12:31 PM
To: megaco
Subject: Re: Does the First Line of SDP need a newline

Sophia Scoggins wrote: 

--

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 26 Feb 2001 05:50:46 -0500

I'd say we should try to keep as closely as possible to SDP.  As someone
suggested already, it's probably time we wrote a detailed grammar of SDP
within Megaco/H.248.

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Wednesday, February 21, 2001 11:35 AM
To: Stonehouse, David [NC1:GW10:EXCH]; [email-masked]'
Subject: RE: Does the First Line of SDP need a newline

Brian
 
 -----Original Message-----
From: David Stonehouse [mailto:[email-masked]]
Sent: Wednesday, February 21, 2001 11:02 AM
To: [email-masked]'
Subject: RE: Does the First Line of SDP need a newline

Dave 

-----Original Message----- 

Is this legal? 

or does is HAVE to be 

Brian