Subject: RE: SDP on Physical Terminations

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 20 Feb 2001 13:50:01 -0500

Is this a valid example to start with?  
Well, the SDP isn't valid, but the example is 

Let's look at it from a different angle. 

The Reply in the Appendix did not return w/the c= and m= lines to indicate
what 
Port # and IP address were chosen as asked by MGC in the request.  

Right, that is one of the problems I raised, use of CHOOSE, with no reply.

CHOOSE is inappropriate here,  but there are no right values for address and
port 

What kind of termination is A4444 - DS0 or an RTP termination?  

It's an analog line, not an RTP port
 
The example indicated that it is an analog line. 
So the question is can an analog line have RTP data on flowing across it?  

No

Does it mean that if I pick up my analog line phone, I will hear RTP data
flow?  

No 

How does an analog line have Port# and IP address?   

It doesn't, and that is a problem  

So if one wants to use SDP for TDM termination should the media be
considered non-RTP media?  

Yes

If yes, how does the following paragraph from SDP RFC 2327 apply? 

"   o Formats for non-RTP media should be registered as MIME content 
     types as described in Appendix B.  For example, the LBL whiteboard 
     application might be registered as MIME content-type application/wb 
     with encoding considerations specifying that it operates over UDP, 
     with no appropriate file format.  In SDP this would then be 
     expressed using a combination of the "media" field and the "fmt" 
     field, as follows:"  

That's basically my suggestion (there is probably an existing MIME content
type
or we can create one. 

What was the intend of the following in the first place? 
  " a=fmtp:PCMU VAD=X-NNVAD ; special voice activity 
                           ; detection algorithm " 

To detect something on the analog side or RTP side? 

Analog side

If on the analog side, should a package be defined to look for it and return
an event to MGC?  

No, if SDP controls it, that is what we want to use 

Either what is the MG supposed to do if it detect this special voice
activity? 
Send an notify for event detect to MGC or go do some special processing?  

I don't really know.   

Chuong 

"Rosen, Brian" wrote: 

Okay, I've been looking at this one for a while, and never said 
anything, and now, at the Interop Event, it's a real problem. 

I draw your attention to the example in Appendix A: 
   MGC to MG1: 
   MEGACO/1 [123.123.123.4]:55555 
   Transaction = 9999 { 
       Context = - { 
           Modify = A4444 { 
               Media { Stream = 1 { 
                        LocalControl { 
                            Mode = SendReceive, 
                            tdmc/gain=2,  ; in dB, 
                            tdmc/ec=on 
                        }, 
                        Local { 
   v=0 
   c=IN IP4 $ 
   m=audio $ RTP/AVP 0 
   a=fmtp:PCMU VAD=X-NNVAD ; special voice activity 
                           ; detection algorithm 

The problem is the SDP on the Physical Termination. 
There are valid reasons why you should allow SDP on physical terminations. 
The example shows one, setting the VAD bit. 

The problem is the c and the a lines.  The physical termination is 
not an IP flow, and is not using RTP.  Yet, SDP requires an a and m line, 
just an a line is not a valid SDP.  Worse, the SDP is using "CHOOSE" 
for the addresses, and there is no reply with the answers. 

We need to do something.  All I can think of is to register some 
new network/protocol combinations like: 
c=X 
m=audio 0 X 

Another, less extreme suggestion would be most welcome. 

Brian

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 22 Feb 2001 05:17:12 -0500

I've been working on a TDM extension for SDP for a couple of months.  I
still hope to have one ready for Friday, though I'm probably dreaming.

> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Tuesday, February 20, 2001 11:36 AM
> To: [email-masked]'
> Subject: SDP on Physical Terminations
> 
>