Subject: MG Inpending Failure

From: [email-masked]
Date: Sun, 8 Apr 2001 13:48:07 +0530

As per Annex L, the meaning of "MG Impending Failure" as  Service Change Reason
is given as follows:

"MG IMPENDING FAILURE"
"Indicates that the entity indicated with the TerminationID
will go to the ServiceState "Out-of-service" and is unable to handle
new traffic for the receiving MGC."

With the above definition in mind, consider that a MG sends a Service Change
command with method as "Forced"
and reason as "MG IMPENDING FAILURE" to its controlling MGC.

Now when the Service Change response is received from MGC, what should be the
behavior of Media Gateway.

Should MG wait for the MGC for cleaning up of all the non-null contexts through
Subtract command, however, new commands except
Subtract should be rejected and hence when all the contexts get cleared, it
should stop communicating with the MGC ??

Or should MG  stop communicating with the MGC as soon as the desired Service
Change command is delivered and at the same time
should MG clean all the existing contexts of its own??

Please clarify.

Thanks,
Prashant Jain

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 9 Apr 2001 09:07:46 -0400

If you are "forcing" root, that is, the entire MG, I think you cannot 
assume any additional commands will be accepted (although you do send
the reply).  "Forced" to a set of terminations on the other hand, implies
a partial failure, and Subtract commands are appropriate.

I would assume you are free to return an error to any other command
on terminations that are forced out of service.

Brian

I believe that  
> should stop communicating with the MGC ?
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 11 Apr 2001 16:18:03 -0400

The choices depend on the situation.  If the MG is healthy enough to wait
for the MGC to do cleanup, it should probably use method "Graceful" rather
than "Forced".  If not, the nature of the outage determines whether the MG
hangs on to its states or does a clean restart.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Sunday, April 08, 2001 4:18 AM
> To: [email-masked]
> Subject: MG Inpending Failure
> 
> 
> 
>