Subject: RE: ServiceChange from an unregistered gateway

From: "Kaul, Bharat" <[email-masked]>
Date: Thu, 12 Apr 2001 10:42:30 -0700

Randy,

  The MGs register with MGCs using ServiceChange with TerminationId as ROOT
and method as restart. If MG sends any other command before it registers
with MGC, MGC will drop it.

- Bharat

-----Original Message-----
From: Randy Younts [mailto:[email-masked]]
Sent: Thursday, April 12, 2001 10:33 AM
To: megaco
Subject: ServiceChange from an unregistered gateway

What should the MGC's response be to a ServiceChane received from an
unknown, unregistered MG?

1) Should the MG be registered and responded to by the MGC as if it had
originally been registered.

2) Should the MGC quietly ignore the mesages from this unregistered MG?

or

3) Should the MGC respond with an error messag?

Randy

--
   Two roads diverged in a wood, and I-
   I took the one less traveled by,
   And that has made all the difference.
                         -Robert Frost
---------------------------------------------

W. Randy Younts      GWC Protocols
NORTEL NETWORKS      Dept. 3Z90
35 Davis Dr.         Voice: (919) 991-2014
RTP, NC  27709       ESN: 351-2014

---

From: David Dykhuizen <[email-masked]>
Date: Thu, 12 Apr 2001 14:29:11 -0500 (CDT)

Hello Madhubabu:

As stated by you:

==> The protocol today, doesn't say what to do when messages are received 
==> from non-provisioned MGs/MGCs.

Hence, it is safe to assume that a MGC may either:

1.) neatly (silently) discard that (ServiceChange) message

or

2.) Respond with error code # 402 "Unauthorized" (See Annex L)
    Description: The command is not executed due to the originator of
                 a command is not authorised to execute that command 
                 for the termination(s) affected by it.

Depending on what is read into the standard.

Later,
/David

-----Original Message-----

==> From [email-masked] Thu Apr 12 14:12 CDT 2001
==> From: "Madhu Babu Brahmanapally" <[email-masked]>
==> To: "'Randy Younts'" <[email-masked]>,
==>         "'megaco'" <[email-masked]>
==> Subject: RE: ServiceChange from an unregistered gateway
==> Date: Thu, 12 Apr 2001 15:09:02 -0400
==> MIME-Version: 1.0
==> Content-Transfer-Encoding: 7bit
==> X-Priority: 3 (Normal)
==> X-MSMail-Priority: Normal
==> X-Mailer: Microsoft Outlook CWS, Build 9.0.2416 (9.0.2911.0)
==> Importance: Normal
==> X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4133.2400
==> Sender: [email-masked]
==> 
==> 
==> Hi Randy,
==> What do you mean by "unknown MG"? If am correct then according to you
==> "unknown MG" is that MG which is not  provisioned at the MGC. If yes, then
==> the MGC should neatly discard that message. The protocol today, doesn't say
==> what to do when messages are received from non-provisioned MGs/MGCs.
==> 
==> Regards
==> Madhubabu
==> 
==> 
==> -----Original Message-----
==> From: [email-masked]
==> [mailto:[email-masked]]On Behalf Of Randy Younts
==> Sent: Thursday, April 12, 2001 1:33 PM
==> To: megaco
==> Subject: ServiceChange from an unregistered gateway
==> 
==> 
==> What should the MGC's response be to a ServiceChane received from an
==> unknown, unregistered MG?
==> 
==> 1) Should the MG be registered and responded to by the MGC as if it had
==> originally been registered.
==> 
==> 2) Should the MGC quietly ignore the mesages from this unregistered MG?
==> 
==> or
==> 
==> 3) Should the MGC respond with an error messag?
==> 
==> Randy
==> 
==> --
==>    Two roads diverged in a wood, and I-
==>    I took the one less traveled by,
==>    And that has made all the difference.
==>                          -Robert Frost
==> ---------------------------------------------
==> 
==> W. Randy Younts      GWC Protocols
==> NORTEL NETWORKS      Dept. 3Z90
==> 35 Davis Dr.         Voice: (919) 991-2014
==> RTP, NC  27709       ESN: 351-2014
==> 
==> 
==>