Subject: RE: Wherefore out thou Error Descriptor?

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 24 Apr 2001 08:42:40 -0400

You have them in the reverse of order of desirability.
It's not as obvious as I would like, but I think you
don't have a choice, there are rules:

If you can parse the transactionId and the ContextId,
then you should use the latter.

If you can parse the transactionId, but not the ContextId,
then you should use the middle one.

If you can't parse the transactionId, then you have to
use your first example.

Of course the specific error number would be different
for each of these, so if I take your example literally,
and use Error 400, bad request, you would use the
3rd form.   

Brian

> -----Original Message-----
> From: Paul Long [mailto:[email-masked]]
> Sent: Monday, April 23, 2001 5:11 PM
> To: [email-masked]
> Subject: Wherefore out thou Error Descriptor?
> 
> 
> What determines the level at which an error descriptor 
> appears in a reply
> (see below)? Should it just be obvious? :-) Is there ever a 
> choice as to
> where to place the error descriptor?
> 
> MEGACO/1 [123.123.123.4]
> Error = 400 { }
> 
>     or
> 
> MEGACO/1 [123.123.123.4]
> Reply = 9998 {
>     Error = 400 { } }
> 
>     or
> 
> MEGACO/1 [123.123.123.4]
> Reply = 9998 {
>     Context = - {
>         Error = 400 { } } }
> 
> Paul Long
> ipDialog, Inc.
>

---

From: Troy Cauble <[email-masked]>
Date: Tue, 24 Apr 2001 10:48:17 -0400

If these are "rules", they should be in a document.

-troy

---

From: "Paul Long" <[email-masked]>
Date: Tue, 24 Apr 2001 15:50:40 -0500

Brian,

Then, applying those rules, if the receiver parses a request without error,
it should never return the first two forms, correct? Or am I being too
literal? IOW, are there some error codes that are simply not appropriate for
some levels? I suppose so. I'll just have to review the list myself, huh?
:-) So I guess the more general rule is that an error descriptor should be
returned at the "lowest level" that is semantically appropriate for that
particular error and that is possible given any parsing problems with the
original request. I know that each of us should be able to understand at
which level an error descriptor should be returned, but it would be very
helpful if this information was agreed upon and present in the
RFC/Recommendation.

Oh, also, since the sender cannot know whether the receiver will encounter
an error parsing the request, it would be prudent for it to handle error
descriptors returned at any level, correct? That means there will probably
be some unavoidable ambiguity, though. Oh, well, I guess we should at least
make our best effort...

Paul Long
ipDialog, Inc.

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Tuesday, April 24, 2001 7:43 AM
To: 'Paul Long'; [email-masked]
Subject: RE: Wherefore out thou Error Descriptor?

Brian