Subject: RE: EventDescriptor in Subtract command

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 24 Apr 2001 13:28:12 -0400

Yah, I answered the question without looking at the syntax.
Note that it's no big deal to make two actions instead of one.
Very small overhead, and not worth dealing with.

The real overhead is that you have to set EVERY ONE of the
events back to what the MGC wants them to be in Null state;
there is no form of sticky state.  All events go back to
boot/configure state.

Brian

> -----Original Message-----
> From: Mario Monteiro [mailto:[email-masked]]
> Sent: Tuesday, April 24, 2001 11:59 AM
> To: [email-masked]
> Subject: Re: EventDescriptor in Subtract command
> 
> 
> Please ignore this question. There is no Eventdescriptor in 
> the Subtract
> command.
> 
> It would have been useful though in order to avoid sending  a Modify
> message after the Subtract.
> 
> Thanks - Mario
> 
> -------------------
> Mario Monteiro wrote:
> 
> > If an Eventdescriptor (monitor for on/off-hook, embedded 
> descriptor to
> > apply dail tone on off-hook and collect digits according to 
> a digitmap)
> > is sent in a Subtract message, will this descriptor be 
> applied to the
> > SCN after transitioning to the NULL context?
> >
> > Thanks - Mario
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 24 Apr 2001 13:25:14 -0400

No

The basic issue is that you would have to use the existing contextId.
So, you are saying, in this contextId, change the event descriptor
and Subtract.  After the command, that termination is no longer in 
the context you modified the events descriptor in, and that
events descriptor is trashed (the termination goes back to
boot/configured state).

Brian

> Sent: Tuesday, April 24, 2001 10:59 AM
> To: [email-masked]
> Subject: EventDescriptor in Subtract command
> 
> 
> If an Eventdescriptor (monitor for on/off-hook, embedded descriptor to
> apply dail tone on off-hook and collect digits according to a 
> digitmap)
> is sent in a Subtract message, will this descriptor be applied to the