Subject: RE: Control Association Problem

From: "Kaul, Bharat" <[email-masked]>
Date: Mon, 2 Apr 2001 15:19:25 -0700

So I propose we add following text to the implementors guide:
 
" For UDP as transport, the source transport address used by the MG for
sending ServiceChange with method as Restart for ROOT, shall be used by MGC
for subsequent communication with the MG. However, if MG specifies a
different transport address in ServiceChange Address parameter while
registering, this address must be used for subsequent communication from MGC
to MG".

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Sunday, April 01, 2001 8:04 AM
To: 'Kaul, Bharat'; [email-masked]'
Subject: RE: Control Association Problem

I think this makes sense.  It is consistent with the principle that you send
responses to the address from which the requests came.

> -----Original Message----- 
> From: Kaul, Bharat [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: Friday, March 30, 2001 9:37 PM 
> To: [email-masked]' 
> Subject: Control Association Problem 
> 
> 
> Hi List, 
> 
> Some more confusion/problem on MG-MGC control association and 
> potential 
> addition to Implementors guide. 
> 
> Assume that transport is UDP and MID filled in the header is 
> IPV4 Address + 
> Port and the transport address used for transmission of the message is 
> different from as specified in MID ? 
> 
> First, is it allowed/legal  ? 
> 
> If yes, then should the entity receiving (ENT-RCV) the 
> message assume that 
> the address information in MID is the transport address to be used for 
> subsequent communication with entity that sent the message 
> (ENT-TX) ? Or 
> should ENT-RCV use the transport address obtained from UDP on 
> receipt of the 
> message for subsequent communication ?" 
> 
> This is step one of the uncertainity. Here is step two :) 
> 
> Additionally, assume MG sent a ServiceChange with method as 
> Restart for the 
> Root Termination to the MGC and transport is UDP. The MID 
> filled by MG is 
> IPV4 + port, the transport address used for transmission is 
> different that 
> what is in MID and worse it fills a ServiceChange Address 
> with a different 
> transport address information. In such a case, which transport address 
> should the MGC use for subsequent communication with the MG. 
> 
> The protocol is silent on all these aspects and if above 
> holds, I do see 
> some inter-op issues here. 
> 
> If above indeed are issues, here is what I suggest: 
> 
> If MID is IPV4 address and the address is different from 
> source transport 
> address used for transmission, source transport address 
> should be used for 
> subsequent communication. 
> 
> In case of ServiceChange scenario message described above, 
> the ServiceChange 
> Address should take precedence. 
> 
> 
> Comments/Pats/BrickBats ? ;) 
> 
> - Bharat 
> 
> 
> -------------------------------------------------------------- 
> -------------- 
> -------------- 
> Bharat Kaul                          Trillium Digital Systems Inc. 
> mailto: [email-masked]    An Intel Company, 
> Phone: 310 481 5515             12100 Wilshire Blvd, #1800, 
> Fax    : 310 442 1162             Los Angeles, CA - 90025 
> http://www.trillium.com <http://www.trillium.com>  
> 
> 
>

---

From: Christian Groves <[email-masked]>
Date: Tue, 03 Apr 2001 11:41:38 +1000

Hello Bharat,

Exactly where to you want this added? Why is UDP only mentioned? Should
there be a transport independent rule?

Cheers, Christian

-------- Original Message --------
Subject: RE: Control Association Problem
   Date: Mon, 2 Apr 2001 15:19:25 -0700
   From: "Kaul, Bharat" <[email-masked]>
     To: "'Tom-PT Taylor'" <[email-masked]>,"Kaul,
         Bharat"<[email-masked]>,"[email-masked]'"
         <[email-masked]>

 So I propose we add following text to the implementors guide:" For UDP
as transport, the source transport address used by the MG for sending
ServiceChange with method as Restart for ROOT, shall be used by MGC for
subsequent communication with the MG. However, if MG specifies a
different transport address in ServiceChange Address parameter while
registering, this address must be used for subsequent communication from
MGC to MG".

     -----Original Message-----
     From: Tom-PT Taylor [mailto:[email-masked]]
     Sent: Sunday, April 01, 2001 8:04 AM
     To: 'Kaul, Bharat'; [email-masked]'
     Subject: RE: Control Association Problem

     I think this makes sense.  It is consistent with the principle
     that you send responses to the address from which the requests
     came.

     > From: Kaul, Bharat [mailto:[email-masked]]

     > http://www.trillium.com

---

From: "Kaul, Bharat" <[email-masked]>
Date: Mon, 2 Apr 2001 18:55:46 -0700

Hi Christian,

 For TCP this issue doesn't exist as TCP is connection oriented and both
ends use the same connection for communication. UDP is the area where this
issue arises as there is explicit understanding between two parties about
the transport address. 

I am not sure what you mean by "where should we add this". 

I suppose this is further clarification on establishing control association
while using UDP as transport. So it clarifies Annex D of H.248 and also
clarifies section 7.2.8 of H.248 (Refer to paragraph beginning with A
ServiceChange command specifying the "Root" for the terminationID and
ServiceChangeMethod equal to Restart is a registration command......).

So I guess in the implementors guide we can add a section "Control
Association Transport Address for UDP" and add the statement I proposed.

- Bharat

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Monday, April 02, 2001 6:42 PM
To: megaco ietf
Subject: RE: Control Association Problem

Hello Bharat,

Cheers, Christian

---

From: "Kaul, Bharat" <[email-masked]>
Date: Fri, 6 Apr 2001 12:12:20 -0700

Hi Christian/List,

  Am attaching the word document outlining the proposed changes for the
issue for review/approval by the list.

Please let me or Christian know if someone has any issues.

- Bharat

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Thursday, April 05, 2001 10:31 PM
To: Kaul, Bharat
Cc: megaco ietf
Subject: Re: Control Association Problem

Hello Bharat, all,

Could you please propose the exact text you want added to which H.248
section you want it added to. Perferably in the same format as I use in
the implementors guide eg.

x.xx <Descriptive Title>

Description: <A short description fault and change>
Reference: (Don't worry about this I take it from the email)

[Begin Correction]
Section x.x.x Title
...
<marked up text>
...
[End Correction]

This would help me save alot of time trying to formulate additions
changes to the Imp Guide.

Regards, Christian

"Kaul, Bharat" wrote:
> 
> OOOoops...error in sentence below..I meant for UDP there is "NO" explicit
> understanding between parties about the transport address.
> 
> Sent: Monday, April 02, 2001 6:56 PM
> To: 'Christian Groves'; megaco ietf