Subject: RE: Query on MegacoVsMgcp Doc

From: "Blatherwick, Peter" <[email-masked]>
Date: Wed, 25 Apr 2001 10:21:59 -0400

Just want to quickly remind people of the age of the comparison document referred to here.  It dates back to draft-04 of the Megaco/H.248 Protocol, Sep 99.  While its still largely correct, and quite useful, it should now be treated with some caution, and double-checked...  

-- Peter

-----Original Message-----
From: Sarika Gupta [mailto:[email-masked]]
Sent: April 25, 2001 01:53
To: [email-masked]
Subject: Query on MegacoVsMgcp Doc

Hi,
I have a query regarding one of the points of
differences between Megaco and MGCP in the 
ftp://standards.nortelnetworks.com/megaco/docs/Related/MegacoVsMGCPv1.pdf.
It is regarding "Handling of internal resources".
Under this point it is mentioned that the internal
resources such as DTMF Tone generator is treated as
separate termination. Now considering the scenario
that this resource is just another hardware chip for
generating tones within the same MG which contains the
terminations where the tones have to be actually
played, do we need to treat it as a separate
termination in Megaco or just the internal hardware
connectivity between the actual physical terminations
and this hardware would suffice.

Regards
sarika

____________________________________________________________
Do You Yahoo!?
Get your free @yahoo.co.uk address at http://mail.yahoo.co.uk
or your free @yahoo.ie address at http://mail.yahoo.ie

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 25 Apr 2001 11:08:46 -0400

It also dates back to the pre RFC2705bis dates which by nature means that it's not as comprehensive in its MGCP presentation as it could be.

A quick scan of the MGCP information in there revels that it's pretty accurate in what it presents though (which is more than can be said of the highly subjective and erroneous marketing junk often being referred to by some people on this list), except for the following two
items:

26 - Move Command
The MoveConnection command in RFC 2705 was merely a proposal which has been deleted from 2705bis.

28 - Resource Capability Auditing
This is actually supported in MGCP via the AuditEndpoint command where you can request an audit of Capabilites.

-- Flemming

--
Flemming Andreasen
Cisco Systems