Subject: RE: ServiceChange from an unregistered gateway

From: "Kaul, Bharat" <[email-masked]>
Date: Thu, 12 Apr 2001 15:47:12 -0700

Sending error code response seems like getting trapped into DOS kind of
thing. Someone with mean intentions keeps bombarding such messages and MGC
spends its energy responding. Although, sending error response may seem like
a nice thing to do, but I would think implementations typically should drop
it and not spend time on unauthorized messages.

-----Original Message-----
From: David Dykhuizen [mailto:[email-masked]]
Sent: Thursday, April 12, 2001 12:29 PM
To: [email-masked]; [email-masked]; [email-masked]
Subject: RE: ServiceChange from an unregistered gateway

Hello Madhubabu:

As stated by you:

==> The protocol today, doesn't say what to do when messages are received 
==> from non-provisioned MGs/MGCs.

Hence, it is safe to assume that a MGC may either:

1.) neatly (silently) discard that (ServiceChange) message

or

2.) Respond with error code # 402 "Unauthorized" (See Annex L)
    Description: The command is not executed due to the originator of
                 a command is not authorised to execute that command 
                 for the termination(s) affected by it.

==> 
==> What should the MGC's response be to a ServiceChane received from an
==> unknown, unregistered MG?
==> 
==> 1) Should the MG be registered and responded to by the MGC as if it had
==> originally been registered.
==> 
==> 2) Should the MGC quietly ignore the mesages from this unregistered MG?
==> 
==> or
==> 
==> 3) Should the MGC respond with an error messag?
==> 
==> Randy
==> 
==> --
==>    Two roads diverged in a wood, and I-
==>    I took the one less traveled by,
==>    And that has made all the difference.
==>                          -Robert Frost
==> ---------------------------------------------
==> 
==> W. Randy Younts      GWC Protocols
==> NORTEL NETWORKS      Dept. 3Z90
==> 35 Davis Dr.         Voice: (919) 991-2014
==> RTP, NC  27709       ESN: 351-2014
==> 
==> 
==>

---

From: "MEHUL SHAH" <[email-masked]>
Date: Fri, 13 Apr 2001 00:22:54 -0500

Sending NACK would be an good idea otherwise if it is discarded MG will be
retransmitting the same message again
and again until it times out.

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Kaul, Bharat
> Sent: Thursday, April 12, 2001 5:47 PM
> To: 'David Dykhuizen'; [email-masked]; [email-masked]