Subject: ServiceChange mandatory vs optional parameters

From: Chuong Nguyen <[email-masked]>
Date: Fri, 06 Apr 2001 09:39:59 -0500

Hi ALL,

7.2.8 ServiceChange

   The ServiceChangeDescriptor contains the following parameters as
   required:

   *  ServiceChangeMethod
   *  ServiceChangeReason
   *  ServiceChangeDelay
   *  ServiceChangeAddress
   *  ServiceChangeProfile
   *  ServiceChangeVersion
   *  ServiceChangeMgcId
   *  TimeStamp

The "as required" implies all the above parameters are optional.

But the description for each parameter indicated that only
ServiceChangeDelay,  ServiceChangeAddress, ServiceChangeProfile,
ServiceChangeVersion,
 ServiceChangeMgcId and TimeStamp are optional.

The ABNF also specified

serviceChangeParm    = (serviceChangeMethod / serviceChangeReason /
                          serviceChangeDelay / serviceChangeAddress /
                         serviceChangeProfile / extension / TimeStamp /
                          serviceChangeMgcId / serviceChangeVersion )

I agreed that for ServiceChangeReplyDescriptor the above can be
optional.

But for ServiceChangeRequest is it still true that all serviceChangeParm
are optional?

Can an MG send a ServiceChangeRequest w/o METHOD - for example a
ServiceChangeRequest
w/just serviceChangeAddress or TimeStamp?

Thanks
Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: "Marcello Pantaleo (EED)" <[email-masked]>
Date: Wed, 11 Apr 2001 16:16:29 +0200

Hi Chuong,
 
I think you're right. Also:
 
    in section 7.2.8 ServiceChangeMethod and ServiceChangeReason are not optional
    apparently in ASN.1 only ServiceChangeMethod is not optional
 
I guess an alignement is needed here.
 
Regards,
Marcello 

-----Original Message-----
From: Chuong Nguyen [mailto:[email-masked]]
Sent: Friday, April 06, 2001 4:40 PM
To: [email-masked]'
Subject: ServiceChange mandatory vs optional parameters

Hi ALL, 

7.2.8 ServiceChange 

   *  ServiceChangeMethod 
   *  ServiceChangeReason 
   *  ServiceChangeDelay 
   *  ServiceChangeAddress 
   *  ServiceChangeProfile 
   *  ServiceChangeVersion 
   *  ServiceChangeMgcId 
   *  TimeStamp 

But the description for each parameter indicated that only 
ServiceChangeDelay,  ServiceChangeAddress, ServiceChangeProfile, ServiceChangeVersion, 
 ServiceChangeMgcId and TimeStamp are optional. 

The ABNF also specified 

I agreed that for ServiceChangeReplyDescriptor the above can be optional. 

But for ServiceChangeRequest is it still true that all serviceChangeParm are optional? 

Can an MG send a ServiceChangeRequest w/o METHOD - for example a ServiceChangeRequest 
w/just serviceChangeAddress or TimeStamp? 

Thanks 
Chuong 

--