Subject: RE: NAT for Megaco.

From: "Tom-PT Taylor" <[email-masked]>
Date: Sun, 1 Apr 2001 11:05:54 -0400

Same as for SIP or anything else -- you need some solution to get the media
flows through, and that solution could vary from an application-level
gateway to administrative action.  We should probably rely on a general
solution rather than build something specific into Megaco.

> -----Original Message-----
> From: Madhu Babu Brahmanapally [mailto:[email-masked]]
> Sent: Saturday, March 31, 2001 2:20 PM
> To: megaco
> Subject: NAT for Megaco.
> 
> 
> Hi All,
> 
> What could be the impact of NAT on Megaco messages when SDP 
> specifies the IP
> address of ephemeral terminations???
> 
> Best Regards
> Madhubabu
> 
>

---

From: Scott Bradner <[email-masked]>
Date: Sun, 1 Apr 2001 11:49:45 -0400 (EDT)

> We should probably rely on a general 

watch what is happening in midcom

Scott

---

From: Matt Holdrege <[email-masked]>
Date: Mon, 02 Apr 2001 01:03:01 -0700

Forgetting MEGACO-controlled phones, the media doesn't matter.

The MGC must know the IP address realm that the MG is operating under. That 
has to be pre-provisioned or discovered from an entity that understands the 
MG's address realm. You might want to read the H.323 section of RFC 3027 as 
that will be somewhat similar to the MEGACO through NAT scenario.

At 08:05 AM 4/1/2001, Tom-PT Taylor wrote:

>Same as for SIP or anything else -- you need some solution to get the 
>media flows through, and that solution could vary from an 
>application-level gateway to administrative action.  We should probably 
>rely on a general solution rather than build something specific into Megaco.
>
> > From: Madhu Babu Brahmanapally 
> [<mailto:[email-masked]>mailto:[email-masked]]