Subject: some basic doubts

From: "Sasitharan R" <[email-masked]>
Date: Fri, 13 Apr 2001 11:46:01 +0530

Hi all,

   I'm new to this group. I have some basic doubts regarding MGCP and
MEGACO.
I have listed down my doubts as follows,

1) Is MEGACO is a super set of MGCP ?

2) If we implement MEGACO, then does it mean that our implementation will
implicitly support MGCP also ?

3) Is there any one to one mapping between the comands of MGCP and MEGACO ?

4) Is it possible to implement MGCP without SDP ?

5) What are the protocols/standards which we have to follow to implement
MEGACO?

6) From where we can get the latest standards/RFC's for both MGCP and MEGACO
?

7) In MEGACO, Media gateway informs Media gateway contorller about his
status ( like inservice), so that Media gateway
    controller will understand that Media gateway is UP. Now our doubt is in
MGCP how this is done?

8) Is it like only call control signals alone will go through Media gateway
controller or voice/data will also go through
   Media gateway controller ?

9) If we are going to implement Residential Media gateway, do we need to
bother about signalling concepts ? ( SS7) or it will
    be taken care by media gateway controller ?

10) In MGCP why ModifyConnection comand is needed while create connection
command is in progress ?

11) Is RTP/RTSP/RTCP is a must for MGCP or MEGACO?

12) Is there any freeware code for both MGCP and MEGACO ?

13) who will decide the number of end users connected with Media gateway? Is
in depend on Media gateway controller ?

      That's all for the time being. I may disturb you with few more doubts.

Regards and thanks,
         Sasi

---

From: "MEHUL SHAH" <[email-masked]>
Date: Fri, 13 Apr 2001 09:59:26 -0500

Answers are followed by mehul

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Sasitharan R
> Sent: Friday, April 13, 2001 1:16 AM
> To: [email-masked]
> Subject: some basic doubts
>
>
> Hi all,
>

Not Really. You might want to look at the conceptual model of
MGCP and MEGACO to unerstand the difference.

> implicitly support MGCP also ?

No

>
> 3) Is there any one to one mapping between the comands of
> MGCP and MEGACO?

Here is the mapping but not exact one.

RSIP MGCP command maps to ServiceChange MEGACO Command (RSIP is one way from
MG to MGC but ServiceChange is both way)

AUEP MGCP cmd maps to AuditCapability MEGACO command
AUCX MGCP cmd maps to AuditValue MEGACO command
CRCX MGCP cmd maps to Add MEGACO command
MDCX MGCP cmd maps to Modify MEGACO command
DLCX MGCP cmd maps to Substract MEGACO command
NTFY MGCP cmd maps to NTFY MEGACO command
RQNT MGCP cmd maps to Modify MEGACO command

> 4) Is it possible to implement MGCP without SDP ?

MGCP protocol refers SDP protocol for exchanging media
attributes. You can use any other protocol which allows to do so.

> 5) What are the protocols/standards which we have to follow

H.248 is the protocol manual.

> 6) From where we can get the latest standards/RFC's for both

http:/www.ietf.org/

>     controller will understand that Media gateway is UP. Now

Using RSIP message in MGCP.

>    Media gateway controller ?

Only call control signalling.

>     be taken care by media gateway controller ?

Your implementation should be generic.

> 10) In MGCP why ModifyConnection comand is needed while

After CRCX_ACK is received, ModifyConnection will be sent.

> 11) Is RTP/RTSP/RTCP is a must for MGCP or MEGACO?

Any other protocol which could replace RTP/RTSP/RTCP can do/

> 12) Is there any freeware code for both MGCP and MEGACO ?

Don't know about MEGACO but for MGCP yes. You have to search.

> in depend on Media gateway controller ?

Some gateways have 2 ports so only 2 end users.
Some gateways have 8 ports so 8 end users.
It depends on GW capacity.