Subject: RE: Annex G parameters question

From: "Blatherwick, Peter" <[email-masked]>
Date: Mon, 30 Apr 2001 15:23:34 -0400

Thanks for the sharp eyes Dan.  You may be right about that.  This definition could be a bit more formal, but hopefully the intent is clear enough.  Any opinions from the ABNF gurus out there, to make this more explicit, or is it good enough as is?  

Since this annex has been settled for some time, at most I think this would be a note in the Implementors' Guide.  Worthwhile?  

-- Peter

-----Original Message-----
From: Dan Elbert [mailto:[email-masked]]
Sent: April 27, 2001 14:43
To: [email-masked]'
Subject: Annex G parameters question

In Annex G, the syntax of the "Key List" property is defined as:
{{keyid,label,label_size},...}
I think this should be
"{{keyid,label,label_size},...}" 
because otherwise it violates the Megaco syntax.
The property is defined of type "String" but I think that there is no
specific requirement
to encode strings inside quotes.

Dan Elbert
RADVISION

---

From: Troy Cauble <[email-masked]>
Date: Mon, 30 Apr 2001 15:56:59 -0400

I've posted on this topic recently, including a proposed Addition.
See the thread titled 

Re: [FINAL;)] Re: encoding package values as ANBF VALUES

-troy