Subject: Re: Context Id in Service Change

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 04 Apr 2001 19:31:17 -0400

I would say that a Forced SC on Root for any reason ought to carry the
assumption that all contexts are cleared.  This is in line with the "boot
the MG" comment below, and allows the MGC to recover the MG with less
messaging when the MG comes back up (that is to say, the MGC won't have to
send the Context=*,Subtract=* message when the MG comes back in service).

This should go in the Implementor's Guide, given that "It's an
often-misunderstood thing."

Kevin

"Rosen, Brian" wrote:

> Yes, that is right.  It's an often-misunderstood thing.
> The MG NEVER takes a termination out of a context "involuntarily".
> It can have all kinds of errors, but the context stays
> around, and the termination stays in it until the MGC does
> the Subtract.
>
> The MG can do a ServiceChange on a termination in a context,
> even a Forced ServiceChange, but the termination (which would
> then be out-of-service) STAYS IN THE CONTEXT.
>
> Of course if you boot the MG, all bets (contexts) are off :)
>
> Brian
>
> > -----Original Message-----
> > From: Paul Rheaume [mailto:[email-masked]]
> > Sent: Friday, March 30, 2001 2:25 PM
> > To: Rosen, Brian
> > Cc: [email-masked]'
> > Subject: Re: Context Id in Service Change
> >
> >
> > Brian,
> >
> > One last clarification:
> >
> > My interpretation of the spec is that it is the responsibility of the
> > MGC to clean up contexts and terminations and that the MG shall never
> > remove any context or termination without the explicite
> > command to do so
> > from the MGC.
> >
> > Is this correct?
> >
> > Cheers,
> > Paul
> >
> > "Rosen, Brian" wrote:
> > >
> > > It's the MGC that should do that, yes.
> > > If the MG needed to take the terminations out of service,
> > > and they were in a context, and the MG had no way to
> > > tell the MGC what was about to happen, I suppose you would
> > > have to use the contextId(s) of the context the terminations
> > > were in to execute the ServiceChange.  The MGC would then
> > > have to send the Subtracts.
> > >
> > > Brian
> > >
> > > > -----Original Message-----
> > > > From: Paul Rheaume [mailto:[email-masked]]
> > > > Sent: Thursday, March 29, 2001 12:33 PM
> > > > To: Rosen, Brian
> > > > Subject: Re: Context Id in Service Change
> > > >
> > > >
> > > > Hi Brian,
> > > >
> > > > You seem to be saying that the MG should subtract
> > terminations from
> > > > their context when those terminations go out-of-service, but the
> > > > protocol clearly states that the MGC is responsible for
> > > > cleaning up the
> > > > contexts. So I think the subtract should come from the MGC.
> > > >
> > > > Am I understanding your statement correctly?
> > > >
> > > > Cheers,
> > > > Paul
> > > >
> > > > "Rosen, Brian" wrote:
> > > > >
> > > > > Technically correct.
> > > > >
> > > > > However, if you were taking terminations out of
> > service, it would
> > > > > be very wise to subtract them out of whatever terminations they
> > > > > were in first, then execute the service change to take them out
> > > > > of service.  It should be possible to do it in the other order,
> > > > > and it should be possible to leave them in a context, but
> > > > > I wouldn't recommend it!
> > > > >
> > > > > Brian
> > > > >
> > > > > > -----Original Message-----
> > > > > > From: Christer Holmberg
> > [mailto:[email-masked]]
> > > > > > Sent: Thursday, March 29, 2001 11:08 AM
> > > > > > To: [email-masked]
> > > > > > Cc: [email-masked]
> > > > > > Subject: Re: Context Id in Service Change
> > > > > >
> > > > > >
> > > > > >
> > > > > > Hi Revital,
> > > > > >
> > > > > > An MG can use any Context, depending on what is the
> > purpose of the
> > > > > > Service Change command.
> > > > > >
> > > > > > For example, if the MG sends ServiceChange to "register"
> > > > itself to the
> > > > > > MGC, the NULL Context will be used, but if the ServiceChange
> > > > > > is sent to
> > > > > > indicate that terminations have been taken out or service
> > > > (or put back
> > > > > > in service) you can use an ANY-wilcarded ContextId value
> > > > or a specific
> > > > > > ContextId value.
> > > > > >
> > > > > > Regards,
> > > > > >
> > > > > > Christer Holmberg
> > > > > > Ericsson Finland
> > > > > >
> > > > > >
> > > > > >
> > > > > > [email-masked] wrote:
> > > > > > >
> > > > > > > Hi List,
> > > > > > >
> > > > > > > Which Context should the MG use when generating Service
> > > > > > Change Command?
> > > > > > >
> > > > > > > Revital Malka
> > > > > > > Voice Over IP
> > > > > > > E.C.I NGTS
> > > > > > > Tel: 03-9287516
> > > > > > > Fax: 03-9287010
> > > > > >
> > > >
> >

---

From: Christian Groves <[email-masked]>
Date: Fri, 06 Apr 2001 11:44:38 +1000

I support Kevin's view that Forced SC on root should carry the
assumption that all contexts are cleared. If the MG has effectively been
rebooted then its alot of wasted messaging for the MGC to request a
subtract and then return termination not in context.
All other cases its up to the MGC to subtract the terminations.

How about the following for the implementors' Guide?

1.44 Clearing Contexts in ServiceChange

Description:	There is confusion as to the handling on subtraction of
terminations from a context when a ServiceChange with "forced"
indication is used. When a ServiceChange "forced" is issued on a
non-Root termination the MGC is responsible for subsequently subtracting
the termination from the applicable context. When a ServiceChange
"forced" is issued on the Root termination it is assumed that all
connection are lost on the MG and thus the MGC can consider that all the
terminations are subtracted. 

Reference:	Subject: Re: Context Id in Service Change
Date: Wed, 04 Apr 2001 19:31:17 -0400
From: "Kevin Boyle" <[email-masked]>
Organization: Nortel Networks
To: "Rosen, Brian" <[email-masked]>
CC: "'Paul Rheaume'" <[email-masked]>, "[email-masked]'"
<[email-masked]>
 [Begin Correction]
Section 7.2.8 ServiceChange
…
2) Forced - indicates that the specified Terminations were taken
abruptly out of service and any established connections associated with
them may be lost. For non-Root terminations the MGC is responsible for
cleaning up the context (if any) with which the failed termination is
associated.  At a minimum the termination shall be subtracted from the
context.  The termination serviceState should be "out of service". For
the root termination the MGC can assume that all connections are lost on
the MG and thus can consider that all the terminations have been
subtracted.

…
[End Correction]

Regards, Christian