Subject: RE: MEGACO conferencing and Global IP address

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 24 Apr 2001 08:59:00 -0400

To mix three users, you need to have all three streams in one place
so you can add them together.  There are two possibilities:
	There is a conference bridge, all three gateways connect to it
		in this case, each RGW has only a two termination context
		the conference bridge has a single 3 termination context
	One gateway acts as the bridge
		in this case, two of the RGWs have 2 termination contexts
		one RGW has a 3 termination context (its physical POTS
		port and two ephemeral ATM or IP/RTP terminations).

I assume you mean to implement the second possibility. 
Suppose each of these has a POTS port whose termId is P1
Suppose each of these creates RTP ports termId is RTP/1 or RTP/2
Suppose the address of RGW1 is 144.115.25.1
Suppose the address of RGW2 is 144.115.25.2
Suppose the address of RGW3 is 144.115.25.3

At RGW1 and RGW2, you send something like:
	Context=${Add=P1...
               ,Add=RTP/${Remote={...c=IN IP4 144.115.25.3..

At RGW3, you use
	Context=${Add=P1...
               ,Add=RTP/${Remote={...c=IN IP4 144.115.25.1..
               ,Add=RTP/${Remote={...c=IN IP4 144.115.25.2..

No global addresses at all, no pool, no NAT.

Brian

> -----Original Message-----
> From: Sasitharan R [mailto:[email-masked]]
> Sent: Tuesday, April 24, 2001 8:26 AM
> To: 'Rosen, Brian'
> Subject: MEGACO conferencing and Global IP address
> 
> 
> Hi,
> 
>    Thanks a lot for U R useful informations. I have few
> doubts regarding conferencing with respect to MEGACO.
> 
>  The conference is between three users.
> 
>  Each user is connected to different media gateways( MG) and all are
> connected to single media gateway controller(MGC)
> 
>   In this case we have to create totally six ephemeral  
> terminations, two
> per
> context. My question is do we need to have a global IP 
> address for each
> ephemeral
> termination ?
> 
>   Or it's upto the MG to have some kind of mapping like NAT ?
> 
>   Do we need to have a pool of global IP addresses for conference?
> 
> Regards,
>  sasi
> 
>

---

From: "Don Stanwyck" <[email-masked]>
Date: Tue, 24 Apr 2001 07:11:30 -0600

Brian:
   Would it not be more accurate to say that the conference bridge has an
N-termination context where N is greater than or equal to 3?  Many
conference bridges support 6-way, 8-way, or in the case of our equipment and
that of some of our competitors, very-many-leg (>100) conference.

Don

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Rosen, Brian
> Sent: Tuesday, April 24, 2001 6:59 AM
> To: [email-masked]'
> Cc: [email-masked]'
> Subject: RE: MEGACO conferencing and Global IP address
>
>