Subject: Reply about embed

From: "Yien-Chang Liao" <[email-masked]>
Date: Wed, 11 Apr 2001 09:30:23 +0800

Dear :
if MG receive a message from MGC
Events = 1111 {al/of {
            embed{
                signals{cg/dt},
                Events = 1112 {al/on}
            }
}}

Does MG need notify MGC when the first event(al/of) occur?
or only notify when second event occur?

thanks

Yien-Chang Liao 
CCL/ITRI

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 12 Apr 2001 11:45:33 -0400

This is up to the MGC.  If it re-uses RequestIDs, it could get confused in
some cases.  In this particular example, the first Notify might go missing,
in which case it is possible for the MGC to see the al/on event before it
sees the al/off.  The reused RequestID might confuse it.  (Of course, the
UDP section of the document advises against sending a second Notify before
the first has been acknowledged.)

> -----Original Message-----
> From: Yien-Chang Liao [mailto:[email-masked]]
> Sent: Wednesday, April 11, 2001 8:42 PM
> To: Rosen, Brian; megaco
> Subject: Re: Reply about embed
> 
> 
> In other case, if we use same event request ID(1111) :
> Events = 1111 {al/of {
>             embed{
>                 signals{cg/dt},
>                 Events = 1111{al/on}
>             }
> }}
> what will happend ? or we can't use same event request ID?
> 
> thanks.
> 
> Yien-Chang Liao 
> CCL/ITRI
> 
> ----- Original Message ----- 
> From: "Rosen, Brian" <[email-masked]>
> To: "'Yien-Chang Liao'" <[email-masked]>; <[email-masked]>
> Sent: Wednesday, April 11, 2001 8:11 PM
> Subject: RE: Reply about embed
> 
> 
> You get a Notify when the first event al/of occurs.
> You get another event when al/on occurs
> 
> Brian
> 
> > -----Original Message-----
> > From: Yien-Chang Liao [mailto:[email-masked]]
> > Sent: Tuesday, April 10, 2001 9:30 PM
> > To: [email-masked]
> > Subject: Reply about embed
> > 
> > 
> > Dear :

---

From: Dave Sclarsky <[email-masked]>
Date: Thu, 12 Apr 2001 12:21:54 -0400

Tom,
 
I agree that re-using RequestIDs is confusing, and shouldn't be recommended.
It is legal, though.
 
BTW, it wasn't the UDP section of the document that talked about
one-notifiy-at-a-time.  It was the transport section (9.1).  This paragraph
is deleted, per the approved IG (6.22).  I believe that the assumption is
that the MGC can order events based on the timestamp.
 
DaveS

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Thursday, April 12, 2001 11:46 AM
To: 'Yien-Chang Liao'; Rosen, Brian; megaco
Subject: RE: Reply about embed

> From: Yien-Chang Liao [ mailto:[email-masked] <mailto:[email-masked].
tw> ] 
> > From: Yien-Chang Liao [ mailto:[email-masked]
<mailto:[email-masked]> ]