Subject: Digit Map query.

From: [email-masked]
Date: Thu, 5 Apr 2001 20:21:21 +0530

Hello,
     I have the following questions in digit map:
1. Can MGC send a command to MG asking MG to detect for two events where both
have a corresponding digit map associated for the event detection?

     e.g.: Modify = termA {
          Events = 1 {
               a/b {DigitMap=DialPlan0}, c/d {DigitMap=DialPlan1}
          }

2. If the answer to the above question is yes, then does that mean that both the
digit maps are active?

3. Consider that digits received by MG is such that the DialPlan0 matches
completely.  Due to this the DigitMap for DialPlan0 would get deactivated.
Assuming there in no new event descriptor received for the same termination and
also there exists no embeded event descriptor. Hence the same event descriptor
would still be active.

Question here is would the DialPlan1 still be active or does the DialPlan0 match
result in DialPlan1 also getting deactivated.

                                         Regards,
                                         R. Ezhirpavai

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 10 Apr 2001 23:33:25 -0400

My answers below.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, April 05, 2001 10:51 AM
> To: [email-masked]
> Subject: Digit Map query.
> 
> 
> 
> 
> Hello,

[PTT]  Yes, I believe so.
> 2. If the answer to the above question is yes, then does that 

[PTT]  Yes.
> result in DialPlan1 also getting deactivated.

[PTT] DialPlan1 remains active.

---

From: [email-masked]
Date: Wed, 11 Apr 2001 16:15:12 +0530

Hello Tom, List,
     In the example given, consider that both package a and package c have
events for detection of digits 0 through 9. Consider that the DialPlan0 is x123
and DialPlan1 is x567.
     In this case, on detection of first digit, it shall be given to both the
digit maps as both are active. Consider the second digit as 1. In this case,
would the DialPlan1 get deactivated by sending a digit map completion event with
partial match or would MG need to know that it needs to keep only DialPlan0
active now and then later when the digit map completion event for event
corresponding to DialPlan0 is deactivated will the DialPlan1 get activated
again.

                                         Regards,
                                         R. Ezhirpavai

"Tom-PT Taylor" <[email-masked]> on 04/11/2001 09:03:25 AM

To:   R Ezhirpavai/HSS@HSS, [email-masked]
cc:

Subject:  RE: Digit Map query.

My answers below.

[PTT]  Yes, I believe so.

[PTT]  Yes.

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 11 Apr 2001 12:57:28 -0400

My interpretation is that DialPlan1 gets deactivated by sending a digit map
completion event with partial match.

> Sent: Wednesday, April 11, 2001 6:45 AM
> To: Taylor, Tom-PT [NORSE:B881:EXCH]
> Cc: [email-masked]

---

From: Dave Sclarsky <[email-masked]>
Date: Wed, 11 Apr 2001 14:29:50 -0400

Hi Tom,
 
I'm surprised that a termination needs to support more than one active digit
map.  I searched and searched, but couldn't find anything that disallows it!
Is it allowed intentionally?  I can't think of any reason why this might be
desirable.  In fact, it seems pretty confusing to have multiple "current
dial string"s on a termination.
 
Am I missing something?
 
DaveS.
S-Link Corporation

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Wednesday, April 11, 2001 12:57 PM
To: [email-masked]'
Cc: [email-masked]
Subject: RE: Digit Map query.

> From: [email-masked] [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> > From: [email-masked] [ mailto:[email-masked]
<mailto:[email-masked]> ]

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 11 Apr 2001 22:14:49 -0400

The only reason I can think of is so the precise pattern matched gets
identified by the reported event.  I remember a question about a year ago
relating to this. 

-----Original Message-----
From: Dave Sclarsky [mailto:[email-masked]]
Sent: Wednesday, April 11, 2001 2:30 PM
To: Taylor, Tom-PT [NORSE:B881:EXCH]; [email-masked]'
Cc: [email-masked]
Subject: RE: Digit Map query.

Hi Tom,

Am I missing something?
 
DaveS.
S-Link Corporation

---

From: Nurit Shenhar <[email-masked]>
Date: Thu, 12 Apr 2001 09:15:01 +0200

Dave and List
 
I am also surprised. Before this thread started, I was sure that DigitMap is
activated only as a parameter of a dd/ce event. Now I am trying to
understand how to activate two maps. Would we send something like 
   al/of{digitmap=DialP1}, dd/ce{DialP2}  ? (one of the events must be
dd/ce, otherwise the dial string is not sent)
It seems strange... And what happens if we want only two events to be
detected, and we want to activate three maps? would we put two of them as
parameters of the same event?
In any case, I suppose that two active digitmap are useful if we wish the
MGC to know the name of the digitmap that the dial string matched. If we put
DialP1 and DialP2 as two options in the same digitmap, the MGC would have to
find out what kind of a dial string was dialed. This could be solved if we
replaced the 'meth' parameter in the digitmap completion event by an index
of the matched option (0 - number of options), where -1 represents no match.
 
Nurit

-----Original Message-----
From: Dave Sclarsky [mailto:[email-masked]]
Sent: Wednesday, April 11, 2001 8:30 PM
To: 'Tom-PT Taylor'; [email-masked]'
Cc: [email-masked]
Subject: RE: Digit Map query.

Hi Tom,

Am I missing something?
 
DaveS.
S-Link Corporation

---

From: Dave Sclarsky <[email-masked]>
Date: Thu, 12 Apr 2001 10:55:31 -0400

Tom,
 
Doesn't that only work if the events are defined in different packages?  We
still can't do something like dd/ce{Digitmap=d1},dd/ce{Digitmap=d2}, can we?
And even if we could, the matched pattern still isn't identified by the
reported event.
 
Digit map syntax already allows 'alternative event sequences', which is
challenging enough!  I say, disallow multiple digitmaps in an event
descriptor, and if there is a desire for the MGC to know which pattern was
matched, let's enhance the observed events descriptor to indicate which
event sequence caused the notification.
 
DaveS.

-----Original Message-----
From: Dave Sclarsky [mailto:[email-masked]]
Sent: Wednesday, April 11, 2001 2:30 PM
To: Taylor, Tom-PT [NORSE:B881:EXCH]; [email-masked]'
Cc: [email-masked]
Subject: RE: Digit Map query.

Hi Tom,

Am I missing something?
 
DaveS.
S-Link Corporation

---

From: Dave Sclarsky <[email-masked]>
Date: Thu, 12 Apr 2001 11:23:41 -0400

Nurit,
 
I don't think you can say al/of{digitmap=DialP1}, because al/of does not
expect a digit map parameter.  In fact, the only event defined in RFC3015
that allows a digit map parameter is dd/ce.
 
The original example (a/b {DigitMap=DialPlan0}, c/d {DigitMap=DialPlan1})
actually uses a different package for each digit map activation.
Presumably, a/b and c/d are defined to be 'digit map completion events' (see
7.1.9 para 3).
 
DaveS.

-----Original Message-----
From: Nurit Shenhar [mailto:[email-masked]]
Sent: Thursday, April 12, 2001 3:15 AM
To: 'Dave Sclarsky'; 'Megaco (E-mail)
Subject: RE: Digit Map query.

Dave and List

Nurit

-----Original Message-----
From: Dave Sclarsky [mailto:[email-masked]]
Sent: Wednesday, April 11, 2001 8:30 PM
To: 'Tom-PT Taylor'; [email-masked]'
Cc: [email-masked]
Subject: RE: Digit Map query.

Hi Tom,

Am I missing something?
 
DaveS.
S-Link Corporation