Subject: RE: Reply about embed

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 11 Apr 2001 08:11:24 -0400

You get a Notify when the first event al/of occurs.
You get another event when al/on occurs

Brian

> -----Original Message-----
> From: Yien-Chang Liao [mailto:[email-masked]]
> Sent: Tuesday, April 10, 2001 9:30 PM
> To: [email-masked]
> Subject: Reply about embed
> 
> 
> Dear :
> if MG receive a message from MGC
> Events = 1111 {al/of {
>             embed{
>                 signals{cg/dt},
>                 Events = 1112 {al/on}
>             }
> }}
> 
> Does MG need notify MGC when the first event(al/of) occur?
> or only notify when second event occur?
> 
> thanks
> 
> Yien-Chang Liao 
> CCL/ITRI
> 
>

---

From: "Yien-Chang Liao" <[email-masked]>
Date: Thu, 12 Apr 2001 08:41:34 +0800

In other case, if we use same event request ID(1111) :
Events = 1111 {al/of {
            embed{
                signals{cg/dt},
                Events = 1111{al/on}
            }
}}
what will happend ? or we can't use same event request ID?

thanks.

Yien-Chang Liao 
CCL/ITRI

----- Original Message ----- 
From: "Rosen, Brian" <[email-masked]>
To: "'Yien-Chang Liao'" <[email-masked]>; <[email-masked]>
Sent: Wednesday, April 11, 2001 8:11 PM
Subject: RE: Reply about embed

Brian

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 12 Apr 2001 12:02:46 -0400

Hi Liao,
The Spec say that "The RequestIdentifier is used to correlate the request
with  the notifications that it may trigger." Since it is the MGC that
initiates these request Identifier, if it can correlate two different
notifies generated from the MG with the Same requestId, then it can go ahead
and use it. The RequestId is used only for the interpretation of the MGC.
The MG doesn't bother what the value is.  In your example its perfect to use
the same requestId "1111" both for event descriptor and embedded events
descriptor.

Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Yien-Chang Liao
Sent: Wednesday, April 11, 2001 8:42 PM
To: Rosen, Brian; [email-masked]
Subject: Re: Reply about embed

thanks.

Yien-Chang Liao
CCL/ITRI

----- Original Message -----
From: "Rosen, Brian" <[email-masked]>
To: "'Yien-Chang Liao'" <[email-masked]>; <[email-masked]>
Sent: Wednesday, April 11, 2001 8:11 PM
Subject: RE: Reply about embed

Brian