Subject: RE: Network Package

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 29 May 2001 17:16:18 -0400

If you implement any part of a package, you implement all of it.
If a package extends any part of a package, it extends all of it.
 
What is not required is that if you implement a package that extends
another package that you have to "expose" the underlying package.
This means that if you implement rtp you don't have to expose nt.
If you list nt as one of the packages in an audit, then you have to
implement nt/dur.  
 
Brian

-----Original Message-----
From: Madhu Babu Brahmanapally [mailto:[email-masked]]
Sent: Tuesday, May 29, 2001 5:15 PM
To: 'Chuong Nguyen'
Cc: [email-masked]
Subject: RE: Network Package

Hi chuong/all,
IMO if PackageB extends PackageA and if one of the statistic/property of
Package A is not valid for termination realizing packageB then there is no
reason why PackageB extends PackageA. Then PackageB shouldn't extend
PackageA (just only to reuse few properties/statistics) but should define
the same properties (Might be with different IDs) in packageB. 
 
I think the extension of packages is logical if the newly defined package
can inherit "all" the properties already defined in the base package and
also define new properties. 
 
In your example, I was in the impression that "OS" and "OR" can be
calculated as "The number of octet sent or received is equal to the duration
of the Termination, in seconds, multiplied by the sampling frequency,  8000
Hz.". (Of course this seems to be redundant info if the MGC is aware of the
sampling frequency). Isn't this the intention?????

-Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Chuong Nguyen
Sent: Tuesday, May 29, 2001 4:38 PM
To: [email-masked]
Subject: Network Package

Hi All 

Is it reasonable to assume that Network Package StatisticsID will never be
used directly? 
That is nt/dur, nt/os and nt/or will normally be rtp/dur, rtp/os and rtp/or
respectiviely 
since rtp package extends nt package. 

I know that it is agreed that if a termination realizes rtp package, it also
realizes nt package 
and either nt/.. or rtp/.. are valid packageName. 

But if we allow, nt/... instead of rtp/.., are we saying that if MGC
receives nt/.., it has to 
know whether it is for rtp or tmcd termination by the terminationID? 

Furthermore, since tdmc package extends nt package, do "octet sent" (OS) and
"octet 
received" (OR) really apply to tdm termination? 

Also what does it mean for a TDM termination to realize the "NT" package
properties 
of "Maximum Jitter Buffer"? 

So a more general question, if a termination realizes a packageB that
extends 
packageA and there are items in the packageA that does not make sense to 
the termination what should MG/MGC do. 

Take the above as an example and assuming that it does not make sense for
TDM 
termination to have "OS" and "OR", what should MG return for TDM termination

statistics if the termination realizes "TDMC" package? 
Just "duration". 

--- 
Said it is valid to have "OS" and "OR" for TDM. 
IF MGC does a Subtract=* on a specific context w/1 TDM and 1 RTP
termination, 
is it valid for MG to return nt/dur, nt/os and nt/or for the TDM termination
and RTP 
termination instead of tdmc/dur, ... vs rtp/dur ? 

Thanks 
Chuong 

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Troy Cauble <[email-masked]>
Date: Tue, 29 May 2001 17:26:22 -0400

> If a package extends any part of a package, it extends all of it.

What do you mean by this statement?

Package A might have Signals and Events.
Are you saying Package B can't extend A's Signals
but not A's Events?  It can't extend the values
for Signal A1, without extending the values for
Event A7 ??

-troy

---

From: Chuong Nguyen <[email-masked]>
Date: Tue, 29 May 2001 16:29:21 -0500

"Rosen, Brian" wrote:

> If you implement any part of a package, you implement all of it.If a
> package extends any part of a package, it extends all of it.

> What is not required is that if you implement a package that
> extendsanother package that you have to "expose" the underlying
> package.This means that if you implement rtp you don't have to expose
> nt.If you list nt as one of the packages in an audit, then you have
> toimplement nt/dur.

<cnn>  I don't quite follow here.
               You seem to imply that nt/dur and rtp/dur are 2 different
things.
               I thought both nt/dur and rtp/dur are the same thing
w/the same value.
              If MG exposed nt, what should it return for duration -
nt/dur or rtp/dur?

Do you know the intend of tdmc/os and tdmc/or?
I thought the same as Madhubabu about how they are calculated.

>      Hi chuong/all,IMO if PackageB extends PackageA and if one of
>      the statistic/property of Package A is not valid for
>      termination realizing packageB then there is no reason why
>      PackageB extends PackageA. Then PackageB shouldn't extend
>      PackageA (just only to reuse few properties/statistics) but
>      should define the same properties (Might be with different
>      IDs) in packageB. I think the extension of packages is
>      logical if the newly defined package can inherit "all" the
>      properties already defined in the base package and also
>      define new properties. In your example, I was in the
>      impression that "OS" and "OR" can be calculated as "The
>      number of octet sent or received is equal to the duration of
>      the Termination, in seconds, multiplied by the sampling
>      frequency,  8000 Hz.". (Of course this seems to be redundant
>      info if the MGC is aware of the sampling frequency). Isn't
>      this the intention?????-RegardsMadhubabu
>
>           Is it reasonable to assume that Network Package
>           StatisticsID will never be used directly?
>           That is nt/dur, nt/os and nt/or will normally be
>           rtp/dur, rtp/os and rtp/or respectiviely
>           I know that it is agreed that if a termination
>           realizes rtp package, it also realizes nt package
>           But if we allow, nt/... instead of rtp/.., are we
>           saying that if MGC receives nt/.., it has to
>           Furthermore, since tdmc package extends nt
>           package, do "octet sent" (OS) and "octet
>           Also what does it mean for a TDM termination to
>           realize the "NT" package properties
>           So a more general question, if a termination
>           realizes a packageB that extends
>           Take the above as an example and assuming that it
>           does not make sense for TDM
>           IF MGC does a Subtract=* on a specific context w/1
>           TDM and 1 RTP termination,
>           is it valid for MG to return nt/dur, nt/os and
>           nt/or for the TDM termination and RTP