Subject: RE: Error Code 505

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 9 May 2001 23:56:07 -0400

All we're talking about is response to a ServiceChange here -- not a
subsequent ServiceChange indicating a reversion to the previous state.  I
would suggest that 505 should apply only to ServiceChange on ROOT, not
because I have an immediate counter-example for the alternative, but because
it feels like it would be easy to construct a counter-example.

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Wednesday, May 09, 2001 10:22 PM
> To: Madhu Babu Brahmanapally
> Cc: [email-masked]
> Subject: Re: Error Code 505
> 
> 
> I'd say this is valid also for terminations than root. A servicechange
> can be applied to individual terminations and this error code is to
> guard trying to change termination characteristics before they have
> restarted.
> 
> Christian
> 
> Madhu Babu Brahmanapally wrote:
> > 
> > HI All,
> > 
> > The Error code 505 description is "Transaction Request 
> Received before a
> > ServiceChange Reply has been received", does the 
> ServiceChange reply here
> > mean the ServiceChange reply on ROOT termination? or is 
> this valid for other
> > terminations also. I think the intention is here is 
> ServiceChange for ROOT
> > termination. Comments??
> > 
> > Regards
> > Madhubabu
>

---

From: Christian Groves <[email-masked]>
Date: Thu, 10 May 2001 14:41:32 +1000

You lost me on the first sentence of your reply. Why can't ServiceChange
bring up a range of termination for the first time? I don't see any
overriding reason that this must only apply to ROOT. 

Christian

Tom-PT Taylor wrote:
> subsequent ServiceChange indicating a reversion to the previous
> state.  I would suggest that 505 should apply only to ServiceChange on
> ROOT, not because I have an immediate counter-example for the
> alternative, but because it feels like it would be easy to construct a
> counter-example.
>

---

From: Chuong Nguyen <[email-masked]>
Date: Thu, 10 May 2001 10:51:48 -0500

505 was only intended for Cold Start use and not subsequent ServiceChange?

Megaco Standard

Section 11.2 Cold Start

   It is possible that the reply to a ServiceChange with Restart will be
   lost, and a command will be received by the MG prior to the receipt
   of the ServiceChange response.  The MG shall issue error 505 -
   Command Received before Restart Response.

I believe this was the intend of 505 but Annex L wording for 505 sort of
broaden the scope
of 505.
The original intend was to let MGC knows that MG has not successfully
established
an association w/MGC so it can't honor any request from MGC.

I think AnnexL 505 description needs to be reworded to match the original
intend of 505
as quoted from Section 11.2 above.

Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****