Subject: RE: Use of ServiceChange from MGC to MG

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 18 May 2001 11:31:42 -0400

Hi.

> -----Original Message-----
> From: Dan Elbert [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 11:06 AM
> To: [email-masked]'
> Subject: Use of ServiceChange from MGC to MG
> 
> 
> Hi 
> 
> The Media Gateway Controller may indicate that Termination(s) 
> shall be taken
> out of or returned to service.
> 1. What is the meaning of the MGC taking down a termination ? 
> Does it means
> that the termination is substracted from any active context 
> and all signal
> are stopped and no events are detected ?

Yes

> 2. What methods are used for taking the MG down and up ? I'd 
> say Graceful
> and Restart. Is this OK ?

"Taking the MG down" to me means doing a ServiceChange on ROOT at the MG.
It's possible the MGC might do that to an MG, but most likely in that case
that it would be done under manual control (i.e. the network is set up such
that control of MGs is exercised through the MGC).  I don't see this as a
typical maintence arrangement.

> 3. Is this applicable also to the root termination ? I would 
> say no because
> if the root termination "goes down" then logically the MG may 
> not be able to
> receive any more MGC commands.

Upon recovery the MG would follow normal start-up procedures to establish a
new control association.

> Thanks,
> Dan Elbert
> RADVISION

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 18 May 2001 11:37:21 -0400

One thing I think is incorrect here is the "Subtracted from any active
contexts" part.  I believe we defined the protocol so that this NEVER
happens
as a side-effect.  The termination may actually be out of service, but both
the MG and the MGC have it in a context if it was when the termination was
taken out of service.
 
It is always incumbant on the MGC to do the subtract explicitly.
 
The ONLY exception to this is restart of the MG; all contexts are lost.
 
Brian

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Friday, May 18, 2001 11:32 AM
To: 'Dan Elbert'; [email-masked]'
Subject: RE: Use of ServiceChange from MGC to MG

Hi. 

> From: Dan Elbert [ mailto:[email-masked]
<mailto:[email-masked]> ] 

Yes

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 18 May 2001 11:56:51 -0400

I was thinking of what the colloquial expression "take down a termination"
might mean.  This expression is NOT defined in the protocol specification.
The precise answer to Dan's question 1 is that "taken out of service" means
that the ServiceState parameter in TerminationState is changed to "Out of
Service", with resulting constraints on what commands can be applied to it.
The phrase "taking down a termination" is not defined in the protocol, so
you have to ask whoever uses it what they mean.
 
 -----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, May 18, 2001 11:37 AM
To: Taylor, Tom-PT [NORSE:B881:EXCH]; 'Dan Elbert'; [email-masked]'
Subject: RE: Use of ServiceChange from MGC to MG

 
 
Brian

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Friday, May 18, 2001 11:32 AM
To: 'Dan Elbert'; [email-masked]'
Subject: RE: Use of ServiceChange from MGC to MG

Hi. 

Yes

---

From: Dan Elbert <[email-masked]>
Date: Fri, 18 May 2001 11:07:47 -0500

You are right, but then this is yet an additional case, and the question
would be what happen with a termination in an active context if the
ServiceState is set to "Out of Service" , does it stays in the context, do
the streams get disconnected, etc.
But my question refered to a termination receiving a ServiceChange from the
MGC with method "Forced" ( or "Graceful" ) which should be somehow
equivalent.
 
Dan

 
 -----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, May 18, 2001 11:37 AM
To: Taylor, Tom-PT [NORSE:B881:EXCH]; 'Dan Elbert'; [email-masked]'
Subject: RE: Use of ServiceChange from MGC to MG

 
Brian
-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Friday, May 18, 2001 11:32 AM
To: 'Dan Elbert'; [email-masked]'
Subject: RE: Use of ServiceChange from MGC to MG
Hi. 
Yes

---

From: Dan Elbert <[email-masked]>
Date: Fri, 18 May 2001 10:46:26 -0500

See below
 
-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, May 18, 2001 11:37 AM
To: 'Tom-PT Taylor'; 'Dan Elbert'; [email-masked]'
Subject: RE: Use of ServiceChange from MGC to MG

[Dan] So what is the meaning of making a termination in a context "out of
service" ? Does it gets disconnected from all the media streams ?

 
[Dan] So you agree that is possible for the MGC to take the "root"
termination down and up again .
 
Brian
-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Friday, May 18, 2001 11:32 AM
To: 'Dan Elbert'; [email-masked]'
Subject: RE: Use of ServiceChange from MGC to MG
Hi. 
Yes

---

From: [email-masked]
Date: Fri, 18 May 2001 22:43:04 +0530

Hello Brain,
     Since the MGC is the controller of the call, shouldn't the MGC explicitly
subtract the call from the context before taking the termination out of service?
In what scenarios would the MGC take the termination out of service and then
subtract it from the call explicitly.

     Taking it a bit further, if the MGC sends service change with "forced" on
ROOT termination, should the MG still wait for the contexts on all terminations
to be subtracted explicitly by the MGC before going down?

                                         Regards,
                                         R. Ezhirpavai

"Rosen, Brian" <[email-masked]> on 05/18/2001 09:07:21 PM

To:   "'Tom-PT Taylor'" <[email-masked]>, "'Dan Elbert'"
      <[email-masked]>, "[email-masked]'" <[email-masked]>
cc:    (bcc: R Ezhirpavai/HSS)

Brian

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Friday, May 18, 2001 11:32 AM
To: 'Dan Elbert'; [email-masked]'
Subject: RE: Use of ServiceChange from MGC to MG

Hi.

Yes

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 18 May 2001 14:16:48 -0400

This has been discussed before.  The consensus at that time was that
the MGC needed to be able to force terminations out of service
regardless of the context state.  I don't want to force an ordering - it's
better if the MGC goofs and sends the ServiceChange first to actually
take the termination out of service then to not take it out of service and
return an error.

Brian

> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 1:58 PM
> To: Rosen, Brian
> Cc: 'Tom-PT Taylor'; 'Dan Elbert'; [email-masked]'
>      Yes, I was mentioning about the order of operations. 
> IMHO, the protocol
> should enforce the MGC to subtract the termination from 
> context before putting
> it out of service. If the MGC sends the service change for putting the
> termination out of service, while the termination is in 
> context, MG should send
> back an error to the MGC, thus indicating to the MGC that the 
> termination is in
> context and any discripency between the MG and MGC may be resolved.
> 
>                                          Regards,
>                                          R. Ezhirpavai
> 
> 
> 
> 
> 
> "Rosen, Brian" <[email-masked]> on 05/18/2001 11:08:30 PM
> 
> To:   R Ezhirpavai/HSS@HSS
> cc:   "'Tom-PT Taylor'" <[email-masked]>, "'Dan Elbert'"
> I said that - the MGC does the Subtract explicitly; just
> taking the termination out of service DOES NOT implicitly do
> a Subtract.  If you are arguing about the order of operations,
> I would recommend the Subtract before the ServiceChange.
> 
> The usual drill for the MGC is first to subtract, then serviceChange
> forced.  There really isn't any reason for the MGC to use Graceful.
> 
> The usual drill for the MG is to send Graceful, the MGC responds
> with Subtract, then the MG makes the terminations out of
> service after the subtract or at the latest, after the timeout.
> 
> A forced Restart on Root should happen immediately.
> 
> Brian
> 
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Friday, May 18, 2001 1:13 PM
> > To: Rosen, Brian
> > Cc: 'Tom-PT Taylor'; 'Dan Elbert'; [email-masked]'

---

From: [email-masked]
Date: Sat, 19 May 2001 01:40:48 +0530

Hello,
     If the media flow is stopped on receiving the SC, then why should it remain
in context? What is achieved by keeping it in context, though call is not going
on?
If it is just for stats information, why can't we add stats descriptor in
service change reply and in this way the MG would reply positively for the SC
and at the same time delete the context too without an explict subtract command.

                                         Regards,
                                         R. Ezhirpavai

"Madhu Babu Brahmanapally" <[email-masked]> on 05/19/2001 12:47:49 AM

To:   R Ezhirpavai/HSS@HSS, "'Kevin Boyle'" <[email-masked]>
cc:   "'Rosen, Brian'" <[email-masked]>, "'Tom-PT Taylor'"
      <[email-masked]>, "'Dan Elbert'" <[email-masked]>,
      [email-masked]

HI Pavai,
The media flows also will stop when the ServiceChange is received by the MG
to put that termination out-of-service. Hence the question of the Endpoint
being in call is ruled-out. Second if the MGC is generating service change
for the termination that is in Active context, then it has to generate
Subtract also. If it doesn't there is a potential problem with the MGC
implementation.

Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Friday, May 18, 2001 2:46 PM
To: Kevin Boyle
Cc: Rosen, Brian; Tom-PT Taylor; 'Dan Elbert'; [email-masked]'
Subject: Re: Use of ServiceChange from MGC to MG

Hello,
     Consider that due to a discripency the MG still has the "termA" in
context
and the MGC assumes that the termA is in NULL context. In this case the MGC
would send service change with forced and would not send any subtract, but
MG is
still waiting for the call to terminate.

     By indicating that the MG should not remove it from context till it
receives a subtract, does it not imply that the MG should not stop the media
flow too?

                                         Regards,
                                         R. Ezhirpavai

"Kevin Boyle" <[email-masked]> on 05/18/2001 11:55:51 PM

To:   R Ezhirpavai/HSS@HSS
cc:   "Rosen, Brian" <[email-masked]>, "Tom-PT Taylor"
      <[email-masked]>, "'Dan Elbert'" <[email-masked]>,
      "[email-masked]'" <[email-masked]>

Subject:  Re: Use of ServiceChange from MGC to MG

Why?  What benefit is gained by setting this restriction?  Now, I would
agree
with
the idea that "out of service" also implies "inactive", thereby halting the
information flow on the streams.  However, I don't see any great problem
with
allowing the out of service Modify command to precede the Subtract.  The MG
is
supposed to leave terminations in context until explicitly subtracted, or
the MG
restarts.

Kevin

[email-masked] wrote:

> Hello Brain,
>      Yes, I was mentioning about the order of operations. IMHO, the
protocol
> should enforce the MGC to subtract the termination from context before
putting
> termination out of service, while the termination is in context, MG should
send
> back an error to the MGC, thus indicating to the MGC that the termination
is
in

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Sun, 20 May 2001 10:22:23 -0400

The MGC could use GRACEFUL if the termination is an outgoing trunk which a
craftsperson at the MGC has seized.  The idea would be to give time for any
existing call to terminate, while preventing additional calls from being
assigned to the trunk.

> Sent: Friday, May 18, 2001 1:39 PM
> To: [email-masked]'
> Cc: Taylor, Tom-PT [NORSE:B881:EXCH]; 'Dan Elbert'; [email-masked]'

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Sun, 20 May 2001 10:25:38 -0400

I think it is legitimate for the MGC to force an MG to do a restart, and the
logical way to do it is through the SC on ROOT.

> From: Madhu Babu Brahmanapally [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 2:22 PM
> To: 'Rosen, Brian'; rezhirpavai
> Cc: 'Dan Elbert'; megaco
> There is no mention of this "unregistration" from the MGC in 
> the protocol.
> The protocol only address ServiceChange with ROOT termination 
> ID as a means
> of MG registering with the MGC but not the other way round. I 
> was in the
> impression that it is possible according to the grammar but 
> nothing like
> "un-registration" exists. (I'm not sure whether every one has 
> the common
> understanding of this "un-registration")
> 
> Regards
> Madhubabu
> 
>

---

From: [email-masked]
Date: Mon, 21 May 2001 12:55:57 +0530

Hello Tom,
     Firstly can an MGC issue a SC with GRACEFUL?

If yes consider the actions at MG
- on receiving GRACEFUL with 0 delay for a non-ROOT termination: It needs to
wait for the call to get cleared, i.,e wait till it receives a SUBTRACT before
putting it OOS.
- on receiving FORCED for a non-ROOT termination: It still needs to wait for a
SUBTRACT, i.e wait for the call to get cleared gracefully.

Hence what is the difference between MG receiving a service change with graceful
or with forced?

                                              Regards,
                                              R. Ezhirpavai

"Tom-PT Taylor" <[email-masked]> on 05/20/2001 07:52:23 PM

To:   "'Rosen, Brian'" <[email-masked]>, R Ezhirpavai/HSS@HSS
cc:   "'Dan Elbert'" <[email-masked]>, "[email-masked]'"
      <[email-masked]>

---

From: [email-masked]
Date: Mon, 21 May 2001 19:21:39 +0530

Hello,
     IMO, MG definitely needs to know about the termination state. Consider MGC
sends an Add with a partial choose as trunk1/$. So the MG would be required to
choose a free SCN termination whose termination name startes with trunk1/. Thus
if MGC requires that trunk1/2 should never be put in a call, MGC can restrict it
by sending SC.

     But since MGC is the controller of the call, IMHO, MGC should be restricted
to send SC with forced once the active call is cleared.

                                         Regards,
                                         R. Ezhirpavai

"Madhu Babu Brahmanapally" <[email-masked]> on 05/21/2001 06:52:19 PM

To:   "'Tom-PT Taylor'" <[email-masked]>, R Ezhirpavai/HSS@HSS
cc:   "'Rosen, Brian'" <[email-masked]>, "'Dan Elbert'"
      <[email-masked]>, [email-masked]

RE: Use of ServiceChange from MGC to MGHI Tom/pavai,
The "graceful" method of SC doesn't convey additional information to
MG(except for the SC delay part of it). Tom mentioned "assign no new calls,
but wait to set the state", but it is the MGC that is aware of the calls not
MG. So what does it mean if MGC is indicating MG not to establish new
calls???

Regards
Madhubabu
  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Tom-PT Taylor
  Sent: Monday, May 21, 2001 6:36 AM
  To: [email-masked]'
  Cc: 'Rosen, Brian'; 'Dan Elbert'; [email-masked]'
  Subject: RE: Use of ServiceChange from MGC to MG

  You're right: the only difference would be if the MGC asked for GRACEFUL
with a non-zero time delay.  I suspect the appropriate action in that case
is unspecified -- have to check the documentation.  It would be nice if that
meant "assign no new calls, but wait to set the state".

  > Sent: Monday, May 21, 2001 3:26 AM
  > To: Taylor, Tom-PT [NORSE:B881:EXCH]
  > Cc: 'Rosen, Brian'; 'Dan Elbert'; [email-masked]'