Subject: RE: ABNF Question: digit maps embedded in events

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 30 May 2001 15:44:29 -0400

I usually defer to Tom on any digitMap questions. 
I can't tell you how many hours I (and several others
including Abdullah Rayhan) spent pouring over the
ABNF to ferret out such problems.

Yes, I agree, it should be 
digitMap={...
and not
digitMap{...

I think this qualifies as a typo and deserves an IG entry.
Tom, do you agree?

Brian

> -----Original Message-----
> From: Steven Weisz [mailto:[email-masked]]
> Sent: Wednesday, May 30, 2001 3:08 PM
> To: Megaco Mailing List (E-mail)
> Subject: ABNF Question: digit maps embedded in events
> 
> 
> Hi List,
> 
> I asked this question a few weeks ago and still have not 
> found an answer.
> Does anyone have an opinion?
> 
> It is a quick question concerning a digit map embedded in a 
> requested event.
> Specifically, if you look at the ABNF the embedded digit map 
> is defined as
> 
> eventDM = DigitMapToken (( EQUAL digitMapName ) / (LBRKT digitMapValue
> RBRKT))
> 
> and a digit map descriptor is defined as:
> 
> digitMapDescriptor = DigitMapToken EQUAL (( LBRKT 
> digitMapValue RBRKT ) / 
> 		         ( digitMapName [LBRKT digitMapValue RBRKT] ))
> 
> It obvious that they are very similar, as I believe was 
> intended but there
> is one thing that is bothering me in eventDM. That is it 
> seems to me that
> the EQUAL should be right after DigitMapToken as is the case in
> digitMapDescriptor. So we would instead have:
> 
> eventDM = DigitMapToken EQUAL (( digitMapName ) / (LBRKT digitMapValue
> RBRKT))
> 
> Does this make sense?
> 
> Thanks,
> 
> Steve
>

---

From: YouLing Sha <[email-masked]>
Date: Wed, 30 May 2001 16:10:43 -0400

By the way, does anyone know when the next version of Megaco is going to be available?

Regards,
YouLing Sha

-----Original Message-----
From:	Madhu Babu Brahmanapally [SMTP:[email-masked]]
Sent:	Wednesday, May 30, 2001 3:55 PM
To:	'Paul Long'; 'Megaco Mailing List (E-mail)'
Subject:	RE: ABNF Question: digit maps embedded in events

HI all,

But this a potential candidate for including in the next version of Megaco.
If not in IG might be some where else, so that we wont miss these.

Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Paul Long
Sent: Wednesday, May 30, 2001 3:35 PM
To: Megaco Mailing List (E-mail)
Subject: RE: ABNF Question: digit maps embedded in events

Well, if you're just looking for someone to reply... :-)

I hadn't noticed this difference before, but your recommendation makes
sense. However, it is too late to change now, so it's a moot point.

Paul Long
ipDialog, Inc.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Steven Weisz
Sent: Wednesday, May 30, 2001 2:08 PM
To: Megaco Mailing List (E-mail)
Subject: ABNF Question: digit maps embedded in events

Hi List,

I asked this question a few weeks ago and still have not found an answer.
Does anyone have an opinion?

It is a quick question concerning a digit map embedded in a requested event.
Specifically, if you look at the ABNF the embedded digit map is defined as

digitMapDescriptor = DigitMapToken EQUAL (( LBRKT digitMapValue RBRKT ) /
		         ( digitMapName [LBRKT digitMapValue RBRKT] ))

It obvious that they are very similar, as I believe was intended but there
is one thing that is bothering me in eventDM. That is it seems to me that
the EQUAL should be right after DigitMapToken as is the case in
digitMapDescriptor. So we would instead have:

Does this make sense?

Thanks,

Steve