Subject: RE: Use of ServiceChange from MGC to MG

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 18 May 2001 14:03:40 -0400

I think you can - it's an MGC invoked soft boot.

Brian

> -----Original Message-----
> From: Madhu Babu Brahmanapally [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 1:52 PM
> To: [email-masked]
> Cc: 'Dan Elbert'; [email-masked]
> Subject: RE: Use of ServiceChange from MGC to MG
> 
> 
> HI Pavai,
> I think second point address non-ROOT terminations. I don't 
> think the MGC
> can send ServiceChange on ROOT to either bring it down or up. 
> (Of course
> there is no restriction from the protocol that MGC cannot 
> send ServiceChange
> on ROOT...I think we may need some consensus on this from everyone).
> 
> Regards
> Madhubabu
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 12:55 PM
> To: Madhu Babu Brahmanapally
> Cc: 'Dan Elbert'; [email-masked]
> Subject: RE: Use of ServiceChange from MGC to MG
> 
> 
> 
> 
> Hello Madhu,
>      In the second point you have mentioned about the methods 
> for taking the
> MG
> down as "forced" and restart".  If the MG itself wants to 
> indicate about its
> going down, then it can either send "graceful" or "forced", 
> but if the MGC
> wants
> to bring down its association with the MG then it needs to 
> send service
> change
> on ROOT with "forced". "Restart" from MGC on ROOT termination 
> is not valid.
> In
> this case the MG needs to itself send service change to any 
> secondary MGC or
> to
> the same primary MGC (if secondary MGC are configured) after restart
> avalance
> timer.
> 
> 
>                                          Regards,
>                                          R. Ezhirpavai
> 
> 
> 
> 
> 
> "Madhu Babu Brahmanapally" <[email-masked]> on 
> 05/18/2001 09:05:16 PM
> 
> To:   "'Dan Elbert'" <[email-masked]>, [email-masked]
> cc:    (bcc: R Ezhirpavai/HSS)
> 
> Subject:  RE: Use of ServiceChange from MGC to MG
> 
> 
> 
> 
> HI Dan,
> Comments below [Madhu]
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Dan Elbert
> Sent: Friday, May 18, 2001 11:06 AM
> To: [email-masked]'
> Subject: Use of ServiceChange from MGC to MG
> 
> 
> Hi
> 
> The Media Gateway Controller may indicate that Termination(s) 
> shall be taken
> out of or returned to service.
> 
> 1. What is the meaning of the MGC taking down a termination ? 
> Does it means
> that the termination is substracted from any active context 
> and all signal
> are stopped and no events are detected ?
> [Madhu] IMO its similar to the situation where MG generates such
> servicechange.
> The signals to be stopped and no event detection.
> Will be useful in
> 1) Residential Gateway - Where the user profile is not 
> encouraging and the
> MGC doesn't
> want to entertain any messages generated from the MG for that 
> endpoint.
> 2) Trunking gateway - Remove some of the trunks from the 
> initial provisioned
> trunks.
> 
> 2. What methods are used for taking the MG down and up ? I'd 
> say Graceful
> and Restart. Is this OK ?
> [Madhu] I think Graceful is a mean by which MG can say to MGC 
> that this
> particular termination
> shouldn't be used for further calls. Graceful has no meaning when MGC
> generates this. I think the
> methods should be "forced" and "restart".
> 
> 3. Is this applicable also to the root termination ? I would 
> say no because
> if the root termination "goes down" then logically the MG may 
> not be able to
> receive any more MGC commands.
> [Madhu] Yes. Your argument is correct.
> 
> Thanks,
> 
> Dan Elbert
> RADVISION
> 
> 
> 
> 
>

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Fri, 18 May 2001 14:22:03 -0400

There is no mention of this "unregistration" from the MGC in the protocol.
The protocol only address ServiceChange with ROOT termination ID as a means
of MG registering with the MGC but not the other way round. I was in the
impression that it is possible according to the grammar but nothing like
"un-registration" exists. (I'm not sure whether every one has the common
understanding of this "un-registration")

Regards
Madhubabu

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, May 18, 2001 2:04 PM
To: 'Madhu Babu Brahmanapally'; [email-masked]
Cc: 'Dan Elbert'; [email-masked]
Subject: RE: Use of ServiceChange from MGC to MG

Brian