Subject: RE: Network Package

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 29 May 2001 17:47:04 -0400

Well rtp/dur and nt/dur are "the same thing" in the sense that the mean the
same
thing, but if you implement (expose) both packages, then they are "separate"
statistics.  Using Events is perhaps easier to understand.  Suppose Package
A
implements event E1, and package B extends Package A, and a given
implementation
exposes both A and B, such that an audit of termination T1 returns
Packages{..A,B..}
 
You can say Add=T1{Events=123{B/E1}}
or you can say
Add=T1{Events=123{A/T1}}
or even
Add=T1{Events=123{A/T1,B/T1}}
 
In the latter, detection of the event would result in a notify of both.
 
Returning to statistics, the value would be the same, but they are separate
statistics.
 
Brian

-----Original Message-----
From: Chuong Nguyen [mailto:[email-masked]]
Sent: Tuesday, May 29, 2001 5:29 PM
To: [email-masked]
Subject: Re: Network Package

"Rosen, Brian" wrote: 

If you implement any part of a package, you implement all of it.If a package
extends any part of a package, it extends all of it.

What is not required is that if you implement a package that extendsanother
package that you have to "expose" the underlying package.This means that if
you implement rtp you don't have to expose nt.If you list nt as one of the
packages in an audit, then you have toimplement nt/dur.

<cnn>  I don't quite follow here. 
               You seem to imply that nt/dur and rtp/dur are 2 different
things. 
               I thought both nt/dur and rtp/dur are the same thing w/the
same value. 
              If MG exposed nt, what should it return for duration - nt/dur
or rtp/dur? 

Do you know the intend of tdmc/os and tdmc/or? 
I thought the same as Madhubabu about how they are calculated. 

Brian 

-----Original Message----- 
From: Madhu Babu Brahmanapally [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Tuesday, May 29, 2001 5:15 PM 
To: 'Chuong Nguyen' 
Cc: [email-masked] 
Subject: RE: Network Package
Hi chuong/all,IMO if PackageB extends PackageA and if one of the
statistic/property of Package A is not valid for termination realizing
packageB then there is no reason why PackageB extends PackageA. Then
PackageB shouldn't extend PackageA (just only to reuse few
properties/statistics) but should define the same properties (Might be with
different IDs) in packageB. I think the extension of packages is logical if
the newly defined package can inherit "all" the properties already defined
in the base package and also define new properties. In your example, I was
in the impression that "OS" and "OR" can be calculated as "The number of
octet sent or received is equal to the duration of the Termination, in
seconds, multiplied by the sampling frequency,  8000 Hz.". (Of course this
seems to be redundant info if the MGC is aware of the sampling frequency).
Isn't this the intention?????-RegardsMadhubabu 

-----Original Message----- 
From: [email-masked] [
mailto:[email-masked]
<mailto:[email-masked]> ]On Behalf Of Chuong Nguyen 
Sent: Tuesday, May 29, 2001 4:38 PM 
To: [email-masked] 
Subject: Network Package
Hi All 

Is it reasonable to assume that Network Package StatisticsID will never be
used directly? 
That is nt/dur, nt/os and nt/or will normally be rtp/dur, rtp/os and rtp/or
respectiviely 
since rtp package extends nt package. 

I know that it is agreed that if a termination realizes rtp package, it also
realizes nt package 
and either nt/.. or rtp/.. are valid packageName. 

But if we allow, nt/... instead of rtp/.., are we saying that if MGC
receives nt/.., it has to 
know whether it is for rtp or tmcd termination by the terminationID? 

Furthermore, since tdmc package extends nt package, do "octet sent" (OS) and
"octet 
received" (OR) really apply to tdm termination? 

Also what does it mean for a TDM termination to realize the "NT" package
properties 
of "Maximum Jitter Buffer"? 

So a more general question, if a termination realizes a packageB that
extends 
packageA and there are items in the packageA that does not make sense to 
the termination what should MG/MGC do. 

Take the above as an example and assuming that it does not make sense for
TDM 
termination to have "OS" and "OR", what should MG return for TDM termination

statistics if the termination realizes "TDMC" package? 
Just "duration". 

--- 
Said it is valid to have "OS" and "OR" for TDM. 
IF MGC does a Subtract=* on a specific context w/1 TDM and 1 RTP
termination, 
is it valid for MG to return nt/dur, nt/os and nt/or for the TDM termination
and RTP 
termination instead of tdmc/dur, ... vs rtp/dur ? 

Thanks 
Chuong 

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Chuong Nguyen <[email-masked]>
Date: Tue, 29 May 2001 17:14:59 -0500

Ok.  I follow you now but ....

IS this clearly stated somewhere?
This could be a nightmare for MGC to receive the same statistics value
via 2 different
parameter.  Talk about the overhead of parsing these text strings.

Can someone answer the question what does it mean for tdmc package to
extend nt package property of "Maximum Jitter Buffer"?

Thanks
Chuong

"Rosen, Brian" wrote:

> Well rtp/dur and nt/dur are "the same thing" in the sense that the
> mean the samething, but if you implement (expose) both packages, then
> they are "separate"statistics.  Using Events is perhaps easier to
> understand.  Suppose Package Aimplements event E1, and package B
> extends Package A, and a given implementationexposes both A and B,
> such that an audit of termination T1 returns Packages{..A,B..}You can
> say Add=T1{Events=123{B/E1}}or you can sayAdd=T1{Events=123{A/T1}}or
> evenAdd=T1{Events=123{A/T1,B/T1}}In the latter, detection of the event
> would result in a notify of both.Returning to statistics, the value
> would be the same, but they are separatestatistics.Brian
>
>     > If you implement any part of a package, you implement all
>     > of it.If a package extends any part of a package, it
>     > extends all of it.
>
>     > What is not required is that if you implement a package
>     > that extendsanother package that you have to "expose" the
>     > underlying package.This means that if you implement rtp
>     > you don't have to expose nt.If you list nt as one of the
>                     You seem to imply that nt/dur and rtp/dur are
>      2 different things.
>                     I thought both nt/dur and rtp/dur are the
>      same thing w/the same value.
>                    If MG exposed nt, what should it return for
>      duration - nt/dur or rtp/dur?
>
>     >      From: Madhu Babu Brahmanapally
>     >      [mailto:[email-masked]]
>     >      Hi chuong/all,IMO if PackageB extends PackageA
>     >      and if one of the statistic/property of Package
>     >      A is not valid for termination realizing
>     >      packageB then there is no reason why PackageB
>     >      extends PackageA. Then PackageB shouldn't extend
>     >      PackageA (just only to reuse few
>     >      properties/statistics) but should define the
>     >      same properties (Might be with different IDs) in
>     >      packageB. I think the extension of packages is
>     >      logical if the newly defined package can inherit
>     >      "all" the properties already defined in the base
>     >      package and also define new properties. In your
>     >      example, I was in the impression that "OS" and
>     >      "OR" can be calculated as "The number of octet
>     >      sent or received is equal to the duration of the
>     >      Termination, in seconds, multiplied by the
>     >      sampling frequency,  8000 Hz.". (Of course this
>     >      seems to be redundant info if the MGC is aware
>     >      of the sampling frequency). Isn't this the
>     >      intention?????-RegardsMadhubabu
>     >
>     >           From:
>     >           [email-masked]
>     >           [mailto:[email-masked]]On
>     >           Behalf Of Chuong Nguyen
>     >           Is it reasonable to assume that
>     >           Network Package StatisticsID will
>     >           never be used directly?
>     >           I know that it is agreed that if a
>     >           termination realizes rtp package, it
>     >           also realizes nt package
>     >           Furthermore, since tdmc package
>     >           extends nt package, do "octet sent"
>     >           (OS) and "octet
>     >           Also what does it mean for a TDM
>     >           termination to realize the "NT"
>     >           package properties
>     >           Take the above as an example and
>     >           assuming that it does not make sense
>     >           for TDM
>     >           termination to have "OS" and "OR",
>     >           what should MG return for TDM
>     >           termination
>     >           IF MGC does a Subtract=* on a specific
>     >           context w/1 TDM and 1 RTP termination,
>     >
>     >           is it valid for MG to return nt/dur,
>     >           nt/os and nt/or for the TDM
>     >           termination and RTP

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Tue, 29 May 2001 19:19:15 -0400

Brian/All,

Sorry for wrong information in my earlier mail.... Error code "456 -
Parameter or Property appears twice in this Descriptor" is present for
avoiding multiple instances of properties/parameters. If A/T1 and B/T1 mean
the same doesn't this fall into the above error category.

Regards
Madhubabu
  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Rosen, Brian
  Sent: Tuesday, May 29, 2001 5:47 PM
  To: 'Chuong Nguyen'; [email-masked]
  Subject: RE: Network Package

  Well rtp/dur and nt/dur are "the same thing" in the sense that the mean
the same
  thing, but if you implement (expose) both packages, then they are
"separate"
  statistics.  Using Events is perhaps easier to understand.  Suppose
Package A
  implements event E1, and package B extends Package A, and a given
implementation
  exposes both A and B, such that an audit of termination T1 returns
Packages{..A,B..}

  Returning to statistics, the value would be the same, but they are
separate
  statistics.

  Brian
    -----Original Message-----
    From: Chuong Nguyen [mailto:[email-masked]]
    Sent: Tuesday, May 29, 2001 5:29 PM
    To: [email-masked]
    Subject: Re: Network Package

    "Rosen, Brian" wrote:
      If you implement any part of a package, you implement all of it.If a
package extends any part of a package, it extends all of it.
      What is not required is that if you implement a package that
extendsanother package that you have to "expose" the underlying package.This
means that if you implement rtp you don't have to expose nt.If you list nt
as one of the packages in an audit, then you have toimplement nt/dur.

    <cnn>  I don't quite follow here.
                   You seem to imply that nt/dur and rtp/dur are 2 different
things.
                   I thought both nt/dur and rtp/dur are the same thing
w/the same value.
                  If MG exposed nt, what should it return for duration -
nt/dur or rtp/dur?

      Brian
          -----Original Message-----
          From: [email-masked]
[mailto:[email-masked]]On Behalf Of Chuong Nguyen
          Sent: Tuesday, May 29, 2001 4:38 PM
          To: [email-masked]
          Subject: Network Package
          Hi All

          Is it reasonable to assume that Network Package StatisticsID will
never be used directly?
          That is nt/dur, nt/os and nt/or will normally be rtp/dur, rtp/os
and rtp/or respectiviely
          since rtp package extends nt package.

          I know that it is agreed that if a termination realizes rtp
package, it also realizes nt package
          and either nt/.. or rtp/.. are valid packageName.

          But if we allow, nt/... instead of rtp/.., are we saying that if
MGC receives nt/.., it has to
          know whether it is for rtp or tmcd termination by the
terminationID?

          Furthermore, since tdmc package extends nt package, do "octet
sent" (OS) and "octet
          received" (OR) really apply to tdm termination?

          Also what does it mean for a TDM termination to realize the "NT"
package properties
          of "Maximum Jitter Buffer"?

          So a more general question, if a termination realizes a packageB
that extends
          packageA and there are items in the packageA that does not make
sense to
          the termination what should MG/MGC do.

          Take the above as an example and assuming that it does not make
sense for TDM
          termination to have "OS" and "OR", what should MG return for TDM
termination
          statistics if the termination realizes "TDMC" package?
          Just "duration".

          ---
          Said it is valid to have "OS" and "OR" for TDM.
          IF MGC does a Subtract=* on a specific context w/1 TDM and 1 RTP
termination,
          is it valid for MG to return nt/dur, nt/os and nt/or for the TDM
termination and RTP
          termination instead of tdmc/dur, ... vs rtp/dur ?

          Thanks
          Chuong

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Tue, 29 May 2001 19:11:57 -0400

HI Brian/all,

In your example A/T1 and B/T1 actually mean to the MG for reporting of the
same event(I.e T1). But I think generating two notifies for this purpose is
unnecessary and doesn't carry any extra information. I think the reporting
should be either A/T1 or B/T1 as both mean the same. If they mean the same
why to provide redundant information to MGC???

Lets say a event descriptor has Events=123{A/a1, A/a1} (grammar allows this
and there is no statement restricting multiple occurrence of the same event)
does this leads to reporting of two Notifies from the MG?????? IMHO
reporting of single event is enough.

Related query: Is it valid to have multiple occurrence of the same signal/
event or properties in any of the descriptors ????

-Regards
Madhubabu
  -----Original Message-----

  Brian
    -----Original Message-----
    From: Chuong Nguyen [mailto:[email-masked]]
    Sent: Tuesday, May 29, 2001 5:29 PM
    To: [email-masked]
    Subject: Re: Network Package

    "Rosen, Brian" wrote:

      Brian
          -----Original Message-----

          ---

          Thanks
          Chuong