Subject: RE: multiple digitmaps

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 4 May 2001 09:42:15 -0400

This is one of those grey-area things.  Given that it would break an
implementation, I guess we should hold off.

-----Original Message-----
From: Dave Sclarsky [mailto:[email-masked]]
Sent: Thursday, May 03, 2001 3:58 PM
To: Taylor, Tom-PT [NORSE:B881:EXCH]; 'Troy Cauble'; MEGACO list
Subject: RE: multiple digitmaps

This will break [at least one :-( ] current implementations.  Are you
proposing to change this for v1, or could it wait till v2?
 
DaveS.

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Thursday, May 03, 2001 3:32 PM
To: 'Troy Cauble'; MEGACO list
Subject: RE: multiple digitmaps

You're right.  I think we intended this.  Does anyone object?   

> -----Original Message----- 
> From: Troy Cauble [ mailto:[email-masked] <mailto:[email-masked]> ] 
> Sent: Thursday, May 03, 2001 11:51 AM 
> To: MEGACO list 
> Subject: multiple digitmaps 
> 
> 
> 
> MEGACO/1 [12.12.12.12]:12345 
> Transaction = 1030 {Context = - {Modify = ROOT { 
>   DigitMap = Pin {(xxxx|xxxxxx)}, 
>   DigitMap = UserId {(xxxxxx)}, 
>   DigitMap = Dialplan0 {(0|00|911|1xxxxxxxxxx|Exx|[2-9]xxxxxx|9011x.)} 
> }}} 
> 
> 
> Multiple digitmaps in Add/Move/Modify parameters are 
> currently illegal based on comments in Annex A and B.  
> This seems pretty useful. 
> 
> 
> Proposal: 
> 
> In Annex B, rewrite the comment above the "ammParameter" spec as: 
>       ; at-most-once except for digitMapDescriptor. 
> 
> In Annex A, rewrite the comment in the "AmmRequest" spec as: 
>       -- At most one descriptor of each type (see AmmDescriptor) 
>       -- allowed in the sequence, except for DigitMapDescriptor. 
> 
> 
> -troy 
>

---

From: Troy Cauble <[email-masked]>
Date: Fri, 04 May 2001 10:16:30 -0400

Given the changes we see on this list every week, I'm
suprised at the pushback for a minor parsing change.
But I guess you have to have to draw a line somewhere.

The currently legal alternative is to wrap N DigitMapDescriptors 
in N Add/Move/Modifys.  Not a massive inconvenience, just 
a minor ugliness.  (So I hope the breakage you're worried 
about is just in your parsing, not your ability to hold 
more than one DigitMap.)

-troy

> This is one of those grey-area things.  Given that it would break an implementation, I guess we should hold off.
> 
>     This will break [at least one :-( ] current implementations.  Are you proposing to change this for v1, or could it wait till v2?
>      
>     DaveS.
> 
>         > From: Troy Cauble [mailto:[email-masked]]