Subject: RE: Use of CHOOSE as a TerminationID

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 17 May 2001 07:43:38 -0400

Certainly when the text you quote was drafted, people had ephemerals in
mind.  In theory if Local and Remote described a TDM circuit, the MG would
probably have to choose from amongst the TDM circuits it supported, but this
doesn't seem too useful unless all the circuits go to the same destination.

A CHOOSE is embedded in a partial name, of course, is a reasonable way to
ask the MG to choose from a specific set of terminations, whether that set
be provisioned or ephemeral.

> -----Original Message-----
> From: Preeti Sharma [mailto:[email-masked]]
> Sent: Wednesday, May 16, 2001 4:30 PM
> To: [email-masked]
> Subject: Use of CHOOSE as a TerminationID
> 
> 
> Hi All,
>     I have a very basic question:
> 
>     If CHOOSE ($)  is recieved as a TerminationID by the MG, 
> can the MG
> then assume that it
>     refers to an ephemeral termination. I tend to believe so 
> as the text
> in Section 7.2.1 says :
> 
>    "The Terminationis either created or taken from the null 
> Context. For
> an existing Termination,
>      the TerminationID would be specific. For a Termination that does
> not yet exist, the TerminationID
>      is specified as CHOOSE in the command."
> 
>      Also CHOOSE can be used for a TerminationID only in the ADD
> command.
> 
>      Hence I infer that CHOOSE implies an ephemeral Termination.
> 
>      Can someone please clarify this.
> 
>  Regards.
>  Preeti.
> 
> 
> 
>

---

From: Preeti Sharma <[email-masked]>
Date: Thu, 17 May 2001 09:31:44 -0400

Why would I use CHOOSE embedded in a partial name, wouldn't I use
WILDCARD instead ?
 Also I can use CHOOSE only for an ADD command.
 So would I say :
  1.   Add = xyz/* {
    or
 2.    Add =  xyz/$ {

 if say I want to choose a circuit from a trunk group "xyz".
 If the answer is 1. then WILDCARD works  like " choose from the
existing pool".
 CHOOSE would work more like "Create a new one".

 And since ephemeral terminations are the only ones being created and
destroyed CHOOSE
 should be used for them only.

 Preeti.

Tom-PT Taylor wrote:

>
>
> Certainly when the text you quote was drafted, people had ephemerals
> in mind.  In theory if Local and Remote described a TDM circuit, the
> MG would probably have to choose from amongst the TDM circuits it
> supported, but this doesn't seem too useful unless all the circuits go
> to the same destination.
>
> A CHOOSE is embedded in a partial name, of course, is a reasonable way
> to ask the MG to choose from a specific set of terminations, whether
> that set be provisioned or ephemeral.
>

---

From: Preeti Sharma <[email-masked]>
Date: Thu, 17 May 2001 09:56:26 -0400

In that case the text in Section 7.2.1 is in a way misleading.

---

From: Troy Cauble <[email-masked]>
Date: Thu, 17 May 2001 14:13:06 -0400

The text Preeti quoted has already been replaced in the IG;
the new text does not imply that CHOOSE implies ephemeral.

<rant>
I've always thought that this CHOOSE syntax leaves a lot
of room for error & causes more work than the "elegance"
is worth.  To support the protocol, an MG must handle CHOOSE 
and can not assume it means ephemeral (unless perhaps a profile 
says differently).

So the MG must DEDUCE the type of termination intended from clues
in the descriptors, with no guarantee there will be enough
clues to narrow it to one type!  Why don't we just have the 
MGC *TELL* the MG what TYPE of termination it wants instead 
of making the MG *DEDUCE* it?  

I understand that it's desired that the protocol be transport 
independent, but how is saying { Type=rtp } different from
setting a bunch of parameters that imply it?

I've asked this before and the answer is that the termination
can be an "empty container" and you won't know the TYPE until
it's filled to a certain point.

Well the MG has to return a NAME for the termination after the 
first CHOOSE reference.  And naming the termination will often
require mapping the type and sometimes more than that.  The schema 
itself might make the termination type obvious (RTP/1, TDM/2, etc.).  
Even if it's not obvious from the schema, the MGC has to know 
certain types of physical mappings (that A444 is the POTS line 
to my house).
</rant>

-troy

> A CHOOSE is embedded in a partial name, of course, is a reasonable way to ask
> the MG to choose from a specific set of terminations, whether that set be
> provisioned or ephemeral.
>