Subject: Clarification in RFC-3015 for domainAddress related to IPV6address

From: [email-masked]
Date: Tue, 22 May 2001 14:49:30 +0530

Hi all,
     I am attaching the part where I feel some ambiguity,

   domainAddress        = "[" (IPv4address / IPv6address) "]"
   ;RFC2373 contains the definition of IP6Addresses.
   IPv6address          = hexpart [ ":" IPv4address ]
   IPv4address          = V4hex DOT V4hex DOT V4hex DOT V4hex
   V4hex                = 1*3(DIGIT) ; "0".."225"
   ; this production, while occurring in RFC2373, is not referenced
   ; IPv6prefix         = hexpart SLASH 1*2DIGIT
   hexpart               = hexseq "::" [ hexseq ] / "::" [ hexseq ] / hexseq
   hexseq               = hex4 *( ":" hex4)
   hex4                 = 1*4HEXDIG

Can anyone tell me whether my interpretation is correct or not?

The expansion of hexpart    is           either    hexseq "::" [ hexseq ]
                              or         "::" [ hexseq ]
                              or         hexseq

If I am correct then the expansion of
IPV6address  leads to         hexpart [ ":" IPV4address ]
and if I choose the first choice of hexpart then I get
     IPV6address    =    hexseq :: [ hexseq ] [ ":" IPV4address ]
since the second hexseq is optional so if I omit it then I get
     IPV6address    =    hexseq :: [ ":" IPV4address ]
and now if get a ":" and an IPV4address, then I get
     IPV6address    =    hexseq ::: IPV4address

which means that an IPV6address can be of the above type,
is this ":::" allowed like this.
Please see if my interpretation is right,
if it is then is the above expansion allowed.

regards/
Amit Kalra

---

From: "Paul Long" <[email-masked]>
Date: Tue, 22 May 2001 10:31:19 -0500

Amit,

I believe you are correct. That idiom would be used when there are trailing
zeros in the IPv4 representation before an IPv6 representation. For example,
FFFF:::13.1.68.3 == FFFF:0:0:0:0:0:13.1.68.3 == FFFF:0:0:0:0:0:0D01:4403.
BTW, this syntax is nasty to parse. My lexer scans ahead and then nibbles
away at each end. :-)

Paul Long
ipDialog, Inc.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Tuesday, May 22, 2001 4:19 AM
To: [email-masked]
Subject: Clarification in RFC-3015 for domainAddress related to
IPV6address

Hi all,

regards/
Amit Kalra