Subject: order of responses.

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Wed, 9 May 2001 20:13:00 -0400

Hi All,
Is the following response valid?????
MGC--------->MG
   MEGACO/1 [216.33.33.61]: 27000
   Transaction = 1243 {
     Context = 2 {
       Modify = TermB {
         Signals { }}
       Modify = EphB {
          Media {
            LocalControl {
              Mode = sendrecv}
                   Remote {
   v=0
   c=IN IP4 192.168.0.160
   m=audio 50000 RTP/AVP 4
                   }
               } ; RTP profile for G723 is 4
           }
       }
     }
   }

and the response from MG-------->MGC is

   MEGACO/1 [207.176.47.89]: 26000
   Reply = 1243 {
      Context = 2 {Modify = TermB, Modify = EphB}
   }

In this example Modify TermB is first executed in the MG and then the Modify
for EphB. Is it valid that the MG after the command execution send response
first for EphB and then for TermB.

Regards
Madhubabu

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 9 May 2001 23:52:39 -0400

No, because commands must be executed in order of appearance, and creation
of the response can be considerted part of "execution".

> -----Original Message-----
> From: Madhu Babu Brahmanapally [mailto:[email-masked]]
> Sent: Wednesday, May 09, 2001 8:13 PM
> To: megaco
> Subject: order of responses.
> 
> 
> Hi All,
> --------------------------------------------------------------
> -----------
> This email server is running an evaluation copy of the 
> MailShield anti-
> spam software. Please contact your email administrator if you have any
> questions about this message. MailShield product info: 
www.mailshield.com