Subject: RE: Polls of MGC

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 18 May 2001 13:28:40 -0400

Right.  I just replied to another version of this and forgot the
point that Johnnies MGC will figure out that Dad's MGC is down,
and that can be fixed, but Dad's MG won't register with the
replacement MGC because it doesn't know (yet) to do so. 

See that message for options.  The package will work, I think,
pretty well (modulo the worry about signals).  So will the
profile defined no-op SC method, and declaring restart of an 
up termination to be a no-op.  It occurs to me that we could
make this more palateable by saying a gracefull restart of an
up termination with a time of -1 was defined to be a no-op.

Brian

> -----Original Message-----
> From: Dave Sclarsky [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 1:18 PM
> To: 'Rosen, Brian'; 'Troy Cauble'
> Cc: [email-masked]'; [email-masked]
> Subject: RE: Polls of MGC
> 
> 
> Brian,
> We cannot let the MGs wait until they need to send something 
> before learning
> that an MGC went down.  You could have a ResGW disconnected 
> from the network
> all night!  What if Johnny at college needs to call home at 
> 3am to bail him
> out of jail?  Dad's controlling MGC won't be able to make his 
> phone ring
> because Dad hasn't made a call since the MGC restarted!  I 
> guess if you're
> Johnny's dad this is a good thing :-)
> 
> DaveS.
> 
> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 11:22 AM
> To: 'Troy Cauble'
> Cc: [email-masked]'; [email-masked]
> Subject: RE: Polls of MGC
> 
> 
> Y'know, I've asked myself that.  I'm not sure I'd use it IFF
> the whole process of finding an MGC and getting back up was fast
> enough to not cause problems with subscribers.
> 
> My conclusion is that it COULD take a long time, and thus I think
> finding it out sooner is better.  I don't feel so strongly that
> I think we just GOTTA change the protocol.
> 
> Brian
> 
> > -----Original Message-----
> > From: Troy Cauble [mailto:[email-masked]]
> > Sent: Friday, May 18, 2001 11:15 AM
> > To: Rosen, Brian
> > Cc: [email-masked]'; [email-masked]
> > Subject: Re: Polls of MGC
> > 
> > 
> > "Rosen, Brian" wrote:
> > > 
> > > This discussion is not specifically detecting failure of the
> > > MGC by timeout of response to a message.  It has to do with
> > > detecting failure of the MGC when there is no message flow.
> > 
> > Brian,
> > 
> > I think the question is why do we *NEED* to detect failure
> > when there is no message flow?  Why not wait and detect it
> > when the MG tries to send something?  (From the MGs view,
> > nothing has failed yet!)
> > 
> > -troy
> > 
>

---

From: Troy Cauble <[email-masked]>
Date: Fri, 18 May 2001 15:03:14 -0400

> replacement MGC because it doesn't know (yet) to do so.

What doesn't the replacement MGC know?  Why doesn't it know it?
Let's make it remember!  Requiring the MG to register with the
new MGC is the problem.

-troy

Polling is bad.
The traffic it causes is bad.
The logic of using it to solve this problem is bad.
It is bad enough to make people look for other protocols.