Subject: RE: Error Code 505

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 10 May 2001 00:58:09 -0400

Let me put the opposite question: has anyone up to now thought that
terminations are only in service after a ServiceChange announcing their
presence?  I think I can see a possible use for such a convention with ATM,
but I don't see it applying to any other type of termination.

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Thursday, May 10, 2001 12:42 AM
> To: Taylor, Tom-PT [NORSE:B881:EXCH]
> Cc: Madhu Babu Brahmanapally; [email-masked]
> Subject: Re: Error Code 505
> 
> 
> You lost me on the first sentence of your reply. Why can't 
> ServiceChange
> bring up a range of termination for the first time? I don't see any
> overriding reason that this must only apply to ROOT. 
> 
> Christian
> 
> Tom-PT Taylor wrote:
> > 
> > All we're talking about is response to a ServiceChange here -- not a
> > subsequent ServiceChange indicating a reversion to the previous
> > state.  I would suggest that 505 should apply only to 
> ServiceChange on
> > ROOT, not because I have an immediate counter-example for the
> > alternative, but because it feels like it would be easy to 
> construct a
> > counter-example.
> > 
> > > -----Original Message-----
> > > From: Christian Groves [mailto:[email-masked]]
> > > Sent: Wednesday, May 09, 2001 10:22 PM
> > > To: Madhu Babu Brahmanapally
> > > Cc: [email-masked]
> > > Subject: Re: Error Code 505
> > >
> > >
> > > I'd say this is valid also for terminations than root. A
> > servicechange
> > > can be applied to individual terminations and this error 
> code is to
> > > guard trying to change termination characteristics before 
> they have
> > > restarted.
> > >
> > > Christian
> > >
> > > Madhu Babu Brahmanapally wrote:
> > > >
> > > > HI All,
> > > >
> > > > The Error code 505 description is "Transaction Request
> > > Received before a
> > > > ServiceChange Reply has been received", does the
> > > ServiceChange reply here
> > > > mean the ServiceChange reply on ROOT termination? or is
> > > this valid for other
> > > > terminations also. I think the intention is here is
> > > ServiceChange for ROOT
> > > > termination. Comments??
> > > >
> > > > Regards
> > > > Madhubabu
> > >
>

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 10 May 2001 09:42:02 -0400

RE: Error Code 505The Error code 521 (Termination is "service changeing") is
no more used. I think the error code Termination is "service Changeing"  and
'Command received before restart response' are functionally merged into the
'Transaction Request received before a service change reply has been
received'.

But if we map the two different scenarios into one error response, we may
not preserve the granular information of actual reason of failure.

Regards
Madhubabu

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 10 May 2001 09:47:09 -0400

RE: Error Code 505Hi Tom,
Why is this valid only for ATM? The general assumption is that as soon as
the ROOT ServiceChange is complete, all the terminations (irrespective of
type) provisioned at both MG and MGC are in-service. Unless followed by any
ServiceChange for those terminations whose state is out-of-service.

Regards
Madhubabu