Subject: multiple digitmaps

From: Troy Cauble <[email-masked]>
Date: Thu, 03 May 2001 11:50:32 -0400

MEGACO/1 [12.12.12.12]:12345
Transaction = 1030 {Context = - {Modify = ROOT {
  DigitMap = Pin {(xxxx|xxxxxx)},
  DigitMap = UserId {(xxxxxx)},
  DigitMap = Dialplan0 {(0|00|911|1xxxxxxxxxx|Exx|[2-9]xxxxxx|9011x.)}
}}}

Multiple digitmaps in Add/Move/Modify parameters are 
currently illegal based on comments in Annex A and B.  
This seems pretty useful.

Proposal:

In Annex B, rewrite the comment above the "ammParameter" spec as:
	; at-most-once except for digitMapDescriptor.

In Annex A, rewrite the comment in the "AmmRequest" spec as:
	-- At most one descriptor of each type (see AmmDescriptor)
	-- allowed in the sequence, except for DigitMapDescriptor.

-troy

---

From: Dave Sclarsky <[email-masked]>
Date: Thu, 3 May 2001 15:58:18 -0400

This will break [at least one :-( ] current implementations.  Are you
proposing to change this for v1, or could it wait till v2?
 
DaveS.

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Thursday, May 03, 2001 3:32 PM
To: 'Troy Cauble'; MEGACO list
Subject: RE: multiple digitmaps

You're right.  I think we intended this.  Does anyone object?   

> -----Original Message----- 
> From: Troy Cauble [ mailto:[email-masked] <mailto:[email-masked]> ] 
> Sent: Thursday, May 03, 2001 11:51 AM 
> To: MEGACO list 
> Subject: multiple digitmaps 
> 
> 
>

---

From: Dave Sclarsky <[email-masked]>
Date: Fri, 4 May 2001 11:39:42 -0400

Troy,

I guess we made certain assumptions in our design, for example, a "message"
could contain an unlimited number of transactions.  A transaction could
contain an unlimited number of actions.  An action could contain an
unlimited number of commands.  But a command can only contain at-most-one of
each descriptor.  So it isn't the parser that breaks, it's the internal
representation of a command.  We do support N modifies, each with 1
digitmapdescriptor.

I don't really like holding back progress for one implementation (even if
its mine!)...but I suspect that there are also others that will need at
least minor tweaks for this to work.  So, given the fact that the workaround
isn't all that bad, doesn't it seem reasonable to hold off until v2?

DaveS.

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Friday, May 04, 2001 10:17 AM
To: Tom-PT Taylor
Cc: 'Dave Sclarsky'; MEGACO list
Subject: Re: multiple digitmaps

Given the changes we see on this list every week, I'm
suprised at the pushback for a minor parsing change.
But I guess you have to have to draw a line somewhere.

The currently legal alternative is to wrap N DigitMapDescriptors 
in N Add/Move/Modifys.  Not a massive inconvenience, just 
a minor ugliness.  (So I hope the breakage you're worried 
about is just in your parsing, not your ability to hold 
more than one DigitMap.)

-troy

> This is one of those grey-area things.  Given that it would break an
implementation, I guess we should hold off.
>     From: Dave Sclarsky [mailto:[email-masked]]
>     Sent: Thursday, May 03, 2001 3:58 PM
>     To: Taylor, Tom-PT [NORSE:B881:EXCH]; 'Troy Cauble'; MEGACO list
>         > From: Troy Cauble [mailto:[email-masked]] 
>         >   DigitMap = Dialplan0
{(0|00|911|1xxxxxxxxxx|Exx|[2-9]xxxxxx|9011x.)}