Subject: RE: If resource of a termination is busy on a Non-Megaco call, wh at should MG do ?

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 18 May 2001 15:50:37 -0400

The protocol is not designed to cover such a case.  You can use
any error you would like, but unless an MGC has been designed to
deal with the concept that it is not a real client server arrangement
you are going to have trouble.  MGCs assume they are in complete
control of the terminations.

Probably what you want to do is define a package that 
adds an error, and possibly an event. Then you need to get the
MGC vendors to implement it.

A better idea is to make the GR-303 side a set of terminations
that the MGC controls.  Then the MGC can make "calls" between the
subscriber side and the GR-303 ports.  Also needs implementation
at the MGC, but you will probably find that.  You may actually want
the MG to appear to be two MGs, one that has the subscriber side
and one that has the GR-303 side.  You can easily shortcut the
network connections.  It also opens up nice possibilities of routing
calls from other MGs to the GR-303 ports.

Brian

> -----Original Message-----
> From: YouLing Sha [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 3:34 PM
> To: [email-masked]'
> Subject: If resource of a termination is busy on a Non-Megaco 
> call, what
> should MG do ?
> 
> 
> Hi,
> 
> If a residentail gateway has a group of subscribers 
> provisioned on the access side; 
> and on the network side, it has GR-303 to the PSTN and Megaco 
> to IP. The calls made 
> by the subscribers from the access side can be routed to PSTN 
> (using GR-303 not Megaco) 
> or IP (using Megaco) based on some pre-defined routing 
> creteria (say time based, 
> digit based, or resource based).  
> 
> In MEGACO environment. MGC is the master and MG behaves as a slave.
> Assuming the gateway has a subscriber (say A). Now if "A" is 
> busy with a GR-303 
> call to the PSTN (not going through the Megaco/MG on the gateway), 
> and the MGC being unaware of it, sends an incoming call 
> request to the gateway for "A", 
> then the call has to be rejected because A is actually busy. 
> 
> The questions are:
> 
> 1. What could be the error cause so that we could avoid any 
> audit triggering
> from the MGC. Because the audit correction might be termination out of
> service or hook status change?
> 2. Could we make the Termination Out of service temporarily 
> (during the
> period it's in a call with some other interface)  by sending a Service
> change to the MGC so that no incoming call request will come from MGC?
> 
> Your advise is highly appreciated.
> 
> Regards,
> YouLing Sha
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Sun, 20 May 2001 10:36:29 -0400

First observation: this mode of operation breaks the assumptions upon which
Megaco/H.248 is based: that each resource is controlled by only one virtual
MG.  In this case, the GR-303 connection is equivalent to a second virtual
MG competing with the one seen by the IP side MGC.

In this case, the best I could suggest is 503 Service Unavailable.  You
could also try 530 Temporary Network Failure.