Subject: How to get SPI

From: "Sarju Garg" <[email-masked]>
Date: Tue, 1 May 2001 16:06:26 +0530

Hi List,

My question is related to getting the SPI value in the Interim AH security Header. There are two ways:
1. Is there any fixed value to be used for SPI for Interim AH  or
2. The value is there in the SAD present in MGC and  need to be determined by MG while security association is created?

Which one is used normally in implementations? If 2 is the case, how (protocol messages) and when to create a security association?

TIA
Sarju

---

From: "Sarju Garg" <[email-masked]>
Date: Wed, 2 May 2001 16:20:33 +0530

Hi Chris, List,

Thanks Chris for the information. I did not find the procedure of exchanging SPI between two hosts. SPI is a constant and defined in SAD. So there is no calculation involved in it. I want to know the procedure at MG of obtaining the SPI value from MGC which will then be used for sending the first transaction (registration request) to MGC.

TIA
Sarju
  ----- Original Message ----- 
  From: Chris Rigano 
  To: 'Sarju Garg' 
  Sent: Wednesday, May 02, 2001 3:57 AM
  Subject: RE: How to get SPI

  Hi TIA,
   
  the IETF IPSEC AH and I believe ESP documents out line SPI calculation. I still don't understand the logic of duplicating IPSEC in Megaco.
   
  Best regards,
   
  Chris
    -----Original Message-----
    From: Sarju Garg [mailto:[email-masked]]
    Sent: Tuesday, May 01, 2001 6:36 AM
    To: 'megaco'
    Subject: How to get SPI

    Hi List,

    TIA
    Sarju