Subject: RE: Polls of MGC

From: Dave Sclarsky <[email-masked]>
Date: Fri, 18 May 2001 13:18:21 -0400

Brian,
We cannot let the MGs wait until they need to send something before learning
that an MGC went down.  You could have a ResGW disconnected from the network
all night!  What if Johnny at college needs to call home at 3am to bail him
out of jail?  Dad's controlling MGC won't be able to make his phone ring
because Dad hasn't made a call since the MGC restarted!  I guess if you're
Johnny's dad this is a good thing :-)

DaveS.

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, May 18, 2001 11:22 AM
To: 'Troy Cauble'
Cc: [email-masked]'; [email-masked]
Subject: RE: Polls of MGC

Y'know, I've asked myself that.  I'm not sure I'd use it IFF
the whole process of finding an MGC and getting back up was fast
enough to not cause problems with subscribers.

My conclusion is that it COULD take a long time, and thus I think
finding it out sooner is better.  I don't feel so strongly that
I think we just GOTTA change the protocol.

Brian

> -----Original Message-----
> From: Troy Cauble [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 11:15 AM
> To: Rosen, Brian
> Cc: [email-masked]'; [email-masked]
> Subject: Re: Polls of MGC
> 
> 
> "Rosen, Brian" wrote:
> > 
> > This discussion is not specifically detecting failure of the
> > MGC by timeout of response to a message.  It has to do with
> > detecting failure of the MGC when there is no message flow.
> 
> Brian,
> 
> I think the question is why do we *NEED* to detect failure
> when there is no message flow?  Why not wait and detect it
> when the MG tries to send something?  (From the MGs view,
> nothing has failed yet!)
> 
> -troy
>

---

From: Troy Cauble <[email-masked]>
Date: Fri, 18 May 2001 14:59:48 -0400

If the MGC doesn't have the capability to save *SOME* information 
about the ResGW, like the mapping between it's IP address and 
Johnie's Dad's phone number, it will never work.

Given the capability to save this information, what information
can't it save?  What doesn't it know when it reboots?  Just
the port number?  Why not keep it simple and make it know
that too?

-troy

Polling is bad.
The traffic it causes is bad.
The logic of using it to solve this problem is bad.
It is bad enough to make people look for other protocols.