Subject: Use of CHOOSE as a TerminationID

From: Preeti Sharma <[email-masked]>
Date: Wed, 16 May 2001 16:29:35 -0400

Hi All,
    I have a very basic question:

    If CHOOSE ($)  is recieved as a TerminationID by the MG, can the MG
then assume that it
    refers to an ephemeral termination. I tend to believe so as the text
in Section 7.2.1 says :

   "The Terminationis either created or taken from the null Context. For
an existing Termination,
     the TerminationID would be specific. For a Termination that does
not yet exist, the TerminationID
     is specified as CHOOSE in the command."

     Also CHOOSE can be used for a TerminationID only in the ADD
command.

     Hence I infer that CHOOSE implies an ephemeral Termination.

     Can someone please clarify this.

 Regards.
 Preeti.

---

From: "Raju" <[email-masked]>
Date: Wed, 16 May 2001 17:28:40 -0400

You should also 'qualify' the CHOOSE with some character, so that the
Gateway knows what type of Ephemeral it has to create,
like  R$ for RTP and N$ for NAS termination.

Although the type of ephemeral can be determined from the descriptors, to
avoid ambiguity and make it clear
it's better to (under)specify termination Ids with some prefix ( like 'R$'
or 'N$' ).

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Preeti Sharma
Sent: Wednesday, May 16, 2001 4:30 PM
To: [email-masked]
Subject: Use of CHOOSE as a TerminationID

Hi All,

 Regards.
 Preeti.