Subject: RE: "Does anybody really know what time it is?" :-)

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 2 May 2001 14:19:48 -0400

I intended that the MG continue to use it's 
own "notion" of time (starting from a fixed reference on
the initial ServiceChange) for the purposes of
Megaco.  I can use the MGC notion of time for any other
purpose it may need time for.

Brian

> -----Original Message-----
> From: Paul Long [mailto:[email-masked]]
> Sent: Wednesday, May 02, 2001 1:52 PM
> To: 'Megaco (E-mail)
> Subject: RE: "Does anybody really know what time it is?" :-)
> 
> 
> Brian,
> 
> As you say, the MG has already commited to a timebase via its 
> ServiceChange
> request by the time it receives the MGC's timestamp in the 
> ServiceChange
> reply. Therefore, for the MG to synch its own clock to the 
> MGC's clock, the
> MG would have to unregister and then re-register with the new, synched
> timestamp. That's certainly technically feasible and 
> compliant behavior but
> probably isn't a practical solution due to the added 
> bandwidth and delay.
> Plus, I don't see what this actually buys you. Woohoo, your 
> timestamps are
> synched! :-)
> 
> Paul Long
> ipDialog, Inc.
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Rosen, Brian
> Sent: Wednesday, May 02, 2001 6:59 AM
> To: 'Ami Amir'; Paul Long; 'Megaco (E-mail)
> Subject: RE: "Does anybody really know what time it is?" :-)
> 
> 
> I have two mobiles.  One gets time from the network (Qualcom, 
> CDMA/Sprint
> PCS)
> the other has a local notion of time (Motorola, GSM/VoiceStream).
> 
> If you want the device to use the MGC's notion of time, you can,
> use the reply of the ServiceChange to get it.
> 
> Doesn't solve the basic issue that the MG initiates the ServiceChange,
> and it sends it's notion of time, the MGC replies with it's notion of
> time.  I do think that, while you might want it to be different,
> it's okay, and the idea of using a fixed time (with the correct
> timezone) is acceptable.
> 
> Brian
>

---

From: "Paul Long" <[email-masked]>
Date: Wed, 2 May 2001 13:30:37 -0500

Brian,

Both the MG and MGC equally have their own notion of time. If we want the
MGC to maintain absolute UTC time so the MG can depend on it for, e.g.,
local time display, we need to state that in the standard. Currently,
neither timestamps are necessarily absolute.

Paul

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Wednesday, May 02, 2001 1:20 PM
To: 'Paul Long'; 'Megaco (E-mail)
Subject: RE: "Does anybody really know what time it is?" :-)

Brian