Subject: RE: SDP and ';' comments

From: "Tulpule, Naren" <[email-masked]>
Date: Thu, 17 May 2001 17:42:10 -0700

Megaco wankers :)
[NAREN] Hey now, it's not Friday evening yet, Troy :-)
Check out
http://standards.nortelnetworks.com/scripts/wa.exe?A2=ind0009&L=MEGACO&P=R25
962 point (3).
This has come up before.
(If the link doesn't work try "search archives" with "SDP comment")
So what if it's the last line of SDP - it still violates SDP syntax before
the all important newline. It's just a Bad Example.
We don't need the rule that you propose, because SDP last line (a= or
whichever) is ALWAYS supposed to end with newline.

<end of comments, Troy's original message below>

At least one of the messages in Appendix A
has SDP with an H.248 style comment:

                        Local { 
v=0 
c=IN IP4 $ 
m=audio $ RTP/AVP 0 
a=fmtp:PCMU VAD=X-NNVAD ; special voice activity  
                           ; detection algorithm 
                        } 

I assume we're not imposing these comments on SDP in general.
But in this example it's the last line of SDP and the comments 
could be part of RBRKT.

localDescriptor      = LocalToken LBRKT octetString RBRKT
RBRKT                = LWSP %x7D LWSP
LWSP                 = *( WSP / COMMENT / EOL )

But unless ';' is specifically not allowed in SDP (which I doubt),
allowing these comments will make it impossible to extract 
the SDP portion without fully parsing it.  I think it 
would be best if we could do that.

Could we say no comments between the braces?
Or no comments on the same lines as SDP?
Or no comments from the start of the SDP
to the RBRKT?

Maybe 

localDescriptor      = LocalToken LBRKT octetString RBRKT2
remoteDescriptor     = RemoteToken LBRKT octetString RBRKT2
RBRKT2               = LWSP2 %x7D LWSP
LWSP2                = *( WSP / EOL )

??

-troy

---

From: Christian Groves <[email-masked]>
Date: Fri, 18 May 2001 22:23:19 +1000

Dear Troy,

Please be aware that "wanker" is not a term of endearment in Australia
or most of Europe. Actually it may be a good way of addressing someone
if you don't want a very positive response.

Christian

---

From: Troy Cauble <[email-masked]>
Date: Fri, 18 May 2001 09:28:17 -0400

Good point!  SDP does require the newline!
-troy

---

From: Troy Cauble <[email-masked]>
Date: Fri, 18 May 2001 09:35:41 -0400

Yikes!  Sorry, all.  No offense intended.  
That's what I get for trying to crack wise.

I knew the origins were derogatory, but I thought it
was now in casual use.  I guess it just sounds "funny"
to us in the US, but it's still "fighting words" elsewhere.

Sorry again!
-troy