Subject: RE: Use of ServiceChange from MGC to MG

From: "Kaul, Bharat" <[email-masked]>
Date: Fri, 18 May 2001 14:20:03 -0700

Brian/List,

Basic Question ...Why does MGC need to send "Forced", "Graceful" to MG with
Termination as ROOT ?

Why is it bringing down the MG ? As you pointed out, I would think it is a
management interface issue.

And did any on these situation even arise at interop ? This is first time I
am hearing MGC can send these methods in SVC

- Bharat

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, May 18, 2001 11:24 AM
To: 'Madhu Babu Brahmanapally'; [email-masked]
Cc: 'Dan Elbert'; [email-masked]
Subject: RE: Use of ServiceChange from MGC to MG

Where do you get "unregistration"?

When sent from MG to MGC SC forced on Root means "I am going down" 
When sent from MGC to MG forced on Root means "go down"

And the corresponding Restart does the obvious thing.

There is an argument that this treads into management interface
territory.

Brian

> -----Original Message-----
> From: Madhu Babu Brahmanapally [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 2:22 PM
> To: 'Rosen, Brian'; [email-masked]
> Cc: 'Dan Elbert'; [email-masked]
> Subject: RE: Use of ServiceChange from MGC to MG
> 
> 
> There is no mention of this "unregistration" from the MGC in 
> the protocol.
> The protocol only address ServiceChange with ROOT termination 
> ID as a means
> of MG registering with the MGC but not the other way round. I 
> was in the
> impression that it is possible according to the grammar but 
> nothing like
> "un-registration" exists. (I'm not sure whether every one has 
> the common
> understanding of this "un-registration")
> 
> Regards
> Madhubabu
> 
> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 2:04 PM
> To: 'Madhu Babu Brahmanapally'; [email-masked]
> Cc: 'Dan Elbert'; [email-masked]
> Subject: RE: Use of ServiceChange from MGC to MG
> 
> 
> I think you can - it's an MGC invoked soft boot.
> 
> Brian
> 
> > -----Original Message-----
> > From: Madhu Babu Brahmanapally [mailto:[email-masked]]
> > Sent: Friday, May 18, 2001 1:52 PM
> > To: [email-masked]
> > Cc: 'Dan Elbert'; [email-masked]
> > Subject: RE: Use of ServiceChange from MGC to MG
> >
> >
> > HI Pavai,
> > I think second point address non-ROOT terminations. I don't
> > think the MGC
> > can send ServiceChange on ROOT to either bring it down or up.
> > (Of course
> > there is no restriction from the protocol that MGC cannot
> > send ServiceChange
> > on ROOT...I think we may need some consensus on this from everyone).
> >
> > Regards
> > Madhubabu
> >
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Friday, May 18, 2001 12:55 PM
> > To: Madhu Babu Brahmanapally
> > Cc: 'Dan Elbert'; [email-masked]
> > Subject: RE: Use of ServiceChange from MGC to MG
> >
> >
> >
> >
> > Hello Madhu,
> >      In the second point you have mentioned about the methods
> > for taking the
> > MG
> > down as "forced" and restart".  If the MG itself wants to
> > indicate about its
> > going down, then it can either send "graceful" or "forced",
> > but if the MGC
> > wants
> > to bring down its association with the MG then it needs to
> > send service
> > change
> > on ROOT with "forced". "Restart" from MGC on ROOT termination
> > is not valid.
> > In
> > this case the MG needs to itself send service change to any
> > secondary MGC or
> > to
> > the same primary MGC (if secondary MGC are configured) after restart
> > avalance
> > timer.
> >
> >
> >                                          Regards,
> >                                          R. Ezhirpavai
> >
> >
> >
> >
> >
> > "Madhu Babu Brahmanapally" <[email-masked]> on
> > 05/18/2001 09:05:16 PM
> >
> > To:   "'Dan Elbert'" <[email-masked]>, [email-masked]
> > cc:    (bcc: R Ezhirpavai/HSS)
> >
> > Subject:  RE: Use of ServiceChange from MGC to MG
> >
> >
> >
> >
> > HI Dan,
> > Comments below [Madhu]
> >
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Dan Elbert
> > Sent: Friday, May 18, 2001 11:06 AM
> > To: [email-masked]'
> > Subject: Use of ServiceChange from MGC to MG
> >
> >
> > Hi
> >
> > The Media Gateway Controller may indicate that Termination(s)
> > shall be taken
> > out of or returned to service.
> >
> > 1. What is the meaning of the MGC taking down a termination ?
> > Does it means
> > that the termination is substracted from any active context
> > and all signal
> > are stopped and no events are detected ?
> > [Madhu] IMO its similar to the situation where MG generates such
> > servicechange.
> > The signals to be stopped and no event detection.
> > Will be useful in
> > 1) Residential Gateway - Where the user profile is not
> > encouraging and the
> > MGC doesn't
> > want to entertain any messages generated from the MG for that
> > endpoint.
> > 2) Trunking gateway - Remove some of the trunks from the
> > initial provisioned
> > trunks.
> >
> > 2. What methods are used for taking the MG down and up ? I'd
> > say Graceful
> > and Restart. Is this OK ?
> > [Madhu] I think Graceful is a mean by which MG can say to MGC
> > that this
> > particular termination
> > shouldn't be used for further calls. Graceful has no 
> meaning when MGC
> > generates this. I think the
> > methods should be "forced" and "restart".
> >
> > 3. Is this applicable also to the root termination ? I would
> > say no because
> > if the root termination "goes down" then logically the MG may
> > not be able to
> > receive any more MGC commands.
> > [Madhu] Yes. Your argument is correct.
> >
> > Thanks,
> >
> > Dan Elbert
> > RADVISION
> >
> >
> >
> >
> >
>

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Fri, 18 May 2001 20:10:06 -0400

HI All,

I posted similar query earlier. Even if we assume that the MGC can generate
ServiceChange Forced on ROOT, IMO any further messages from the MGC should
not be responded by the MG because the MGC has broken the control
association. Then the MG has to reinitiate the "registration" process with
the SC Restart on ROOT. (IMO The SC Restart on ROOT from MGC will have to
discarded by the MG)

My argument is that if the MG's  SC Restart on ROOT establishes the control
association then the MGC's SC Forced on ROOT should be treated as breaking
this association. Of course nothing regarding to this is mentioned in the
protocol. The only cases that are addressed in the protocol regarding usage
of SC with ROOT is the MGC using the SC generation with Handoff methods.

I agree that the MGC should be able to break the control association
but...the protocol should say this somewhere describing the usage of Root
TerminationId with ServiceChange.

Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Kaul, Bharat
Sent: Friday, May 18, 2001 5:20 PM
To: [email-masked]
Subject: RE: Use of ServiceChange from MGC to MG

Brian/List,

- Bharat

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Friday, May 18, 2001 11:24 AM
To: 'Madhu Babu Brahmanapally'; [email-masked]
Cc: 'Dan Elbert'; [email-masked]
Subject: RE: Use of ServiceChange from MGC to MG

Brian