Subject: RE: Network Package

From: "Blatherwick, Peter" <[email-masked]>
Date: Tue, 29 May 2001 21:35:20 -0400

See below (and related responses to Madhubabu).   -- Peter

-----Original Message-----
From: Chuong Nguyen [mailto:[email-masked]]
Sent: May 29, 2001 18:15
To: [email-masked]
Subject: Re: Network Package

Ok.  I follow you now but .... 

IS this clearly stated somewhere? 
This could be a nightmare for MGC to receive the same statistics value via 2 different 
parameter.  Talk about the overhead of parsing these text strings. 

[PB]  I believe this logic was given in the Implementors' Guide.  If it remains unclear, please let us all know what needs to be clarified.   

[PB] Yes, there would be double the overhead, but that's not really different overhead from MGC asking for 2 sets of statistics from different sources.  

 Can someone answer the question what does it mean for tdmc package to 
extend nt package property of "Maximum Jitter Buffer"?  

[PB] My opinion, not as author of the tdmc Package,  is the property should simply always be 0.  There is no jitter buffer.  I agree this is not a very interesting value, so if the MGC is not interested it should not ask, and if its software is designed to handle the general case of any package extending from nt, it better be able to handle 0 as the answer.  

Thanks 
Chuong 

"Rosen, Brian" wrote: 

Well rtp/dur and nt/dur are "the same thing" in the sense that the mean the samething, but if you implement (expose) both packages, then they are "separate"statistics.  Using Events is perhaps easier to understand.  Suppose Package Aimplements event E1, and package B extends Package A, and a given implementationexposes both A and B, such that an audit of termination T1 returns Packages{..A,B..}You can say Add=T1{Events=123{B/E1}}or you can sayAdd=T1{Events=123{A/T1}}or evenAdd=T1{Events=123{A/T1,B/T1}}In the latter, detection of the event would result in a notify of both.Returning to statistics, the value would be the same, but they are separatestatistics.Brian 

-----Original Message----- 
From: Chuong Nguyen [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Tuesday, May 29, 2001 5:29 PM 
To: [email-masked] 
Subject: Re: Network Package
"Rosen, Brian" wrote: 

If you implement any part of a package, you implement all of it.If a package extends any part of a package, it extends all of it.

What is not required is that if you implement a package that extendsanother package that you have to "expose" the underlying package.This means that if you implement rtp you don't have to expose nt.If you list nt as one of the packages in an audit, then you have toimplement nt/dur.

<cnn>  I don't quite follow here. 
               You seem to imply that nt/dur and rtp/dur are 2 different things. 
               I thought both nt/dur and rtp/dur are the same thing w/the same value. 
              If MG exposed nt, what should it return for duration - nt/dur or rtp/dur? 

Do you know the intend of tdmc/os and tdmc/or? 
I thought the same as Madhubabu about how they are calculated. 

Brian 

-----Original Message----- 
From: Madhu Babu Brahmanapally [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Tuesday, May 29, 2001 5:15 PM 
To: 'Chuong Nguyen' 
Cc: [email-masked] 
Subject: RE: Network Package
Hi chuong/all,IMO if PackageB extends PackageA and if one of the statistic/property of Package A is not valid for termination realizing packageB then there is no reason why PackageB extends PackageA. Then PackageB shouldn't extend PackageA (just only to reuse few properties/statistics) but should define the same properties (Might be with different IDs) in packageB. I think the extension of packages is logical if the newly defined package can inherit "all" the properties already defined in the base package and also define new properties. In your example, I was in the impression that "OS" and "OR" can be calculated as "The number of octet sent or received is equal to the duration of the Termination, in seconds, multiplied by the sampling frequency,  8000 Hz.". (Of course this seems to be redundant info if the MGC is aware of the sampling frequency). Isn't this the intention?????-RegardsMadhubabu 

-----Original Message----- 
From: [email-masked] [ mailto:[email-masked] <mailto:[email-masked]> ]On Behalf Of Chuong Nguyen 
Sent: Tuesday, May 29, 2001 4:38 PM 
To: [email-masked] 
Subject: Network Package
Hi All 

Is it reasonable to assume that Network Package StatisticsID will never be used directly? 
That is nt/dur, nt/os and nt/or will normally be rtp/dur, rtp/os and rtp/or respectiviely 
since rtp package extends nt package. 

I know that it is agreed that if a termination realizes rtp package, it also realizes nt package 
and either nt/.. or rtp/.. are valid packageName. 

But if we allow, nt/... instead of rtp/.., are we saying that if MGC receives nt/.., it has to 
know whether it is for rtp or tmcd termination by the terminationID? 

Furthermore, since tdmc package extends nt package, do "octet sent" (OS) and "octet 
received" (OR) really apply to tdm termination? 

Also what does it mean for a TDM termination to realize the "NT" package properties 
of "Maximum Jitter Buffer"? 

So a more general question, if a termination realizes a packageB that extends 
packageA and there are items in the packageA that does not make sense to 
the termination what should MG/MGC do. 

Take the above as an example and assuming that it does not make sense for TDM 
termination to have "OS" and "OR", what should MG return for TDM termination 
statistics if the termination realizes "TDMC" package? 
Just "duration". 

--- 
Said it is valid to have "OS" and "OR" for TDM. 
IF MGC does a Subtract=* on a specific context w/1 TDM and 1 RTP termination, 
is it valid for MG to return nt/dur, nt/os and nt/or for the TDM termination and RTP 
termination instead of tdmc/dur, ... vs rtp/dur ? 

Thanks 
Chuong 

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Tue, 29 May 2001 21:47:34 -0400

Hi Peter/All,
I think the better place for the "Maximum Jitter Buffer" is the RTP package
instead of the NT package. 0 can be the value for TDM terminations but...if
its the same value... no extra information is conveyed to MGC. Only RTP
package realizing terminations should use them.

Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Blatherwick,
Peter
Sent: Tuesday, May 29, 2001 9:35 PM
To: 'Chuong Nguyen'; [email-masked]
Subject: RE: Network Package

-----Original Message-----
From: Chuong Nguyen [mailto:[email-masked]]
Sent: May 29, 2001 18:15
To: [email-masked]
Subject: Re: Network Package

IS this clearly stated somewhere?
This could be a nightmare for MGC to receive the same statistics value via 2
different
parameter.  Talk about the overhead of parsing these text strings.

[PB]  I believe this logic was given in the Implementors' Guide.  If it
remains unclear, please let us all know what needs to be clarified.

[PB] Yes, there would be double the overhead, but that's not really
different overhead from MGC asking for 2 sets of statistics from different
sources.

[PB] My opinion, not as author of the tdmc Package,  is the property should
simply always be 0.  There is no jitter buffer.  I agree this is not a very
interesting value, so if the MGC is not interested it should not ask, and if
its software is designed to handle the general case of any package extending
from nt, it better be able to handle 0 as the answer.

Thanks
Chuong

"Rosen, Brian" wrote:

Well rtp/dur and nt/dur are "the same thing" in the sense that the mean the
samething, but if you implement (expose) both packages, then they are
"separate"statistics.  Using Events is perhaps easier to understand.
Suppose Package Aimplements event E1, and package B extends Package A, and a
given implementationexposes both A and B, such that an audit of termination
T1 returns Packages{..A,B..}You can say Add=T1{Events=123{B/E1}}or you can
sayAdd=T1{Events=123{A/T1}}or evenAdd=T1{Events=123{A/T1,B/T1}}In the
latter, detection of the event would result in a notify of both.Returning to
statistics, the value would be the same, but they are
separatestatistics.Brian

-----Original Message-----
From: Chuong Nguyen [ mailto:[email-masked]
<mailto:[email-masked]> ]
Sent: Tuesday, May 29, 2001 5:29 PM
To: [email-masked]
Subject: Re: Network Package
"Rosen, Brian" wrote:

If you implement any part of a package, you implement all of it.If a package
extends any part of a package, it extends all of it.

What is not required is that if you implement a package that extendsanother
package that you have to "expose" the underlying package.This means that if
you implement rtp you don't have to expose nt.If you list nt as one of the
packages in an audit, then you have toimplement nt/dur.

<cnn>  I don't quite follow here.
               You seem to imply that nt/dur and rtp/dur are 2 different
things.
               I thought both nt/dur and rtp/dur are the same thing w/the
same value.
              If MG exposed nt, what should it return for duration - nt/dur
or rtp/dur?

Brian

-----Original Message-----
From: Madhu Babu Brahmanapally [ mailto:[email-masked]
<mailto:[email-masked]> ]
Sent: Tuesday, May 29, 2001 5:15 PM
To: 'Chuong Nguyen'
Cc: [email-masked]
Subject: RE: Network Package
Hi chuong/all,IMO if PackageB extends PackageA and if one of the
statistic/property of Package A is not valid for termination realizing
packageB then there is no reason why PackageB extends PackageA. Then
PackageB shouldn't extend PackageA (just only to reuse few
properties/statistics) but should define the same properties (Might be with
different IDs) in packageB. I think the extension of packages is logical if
the newly defined package can inherit "all" the properties already defined
in the base package and also define new properties. In your example, I was
in the impression that "OS" and "OR" can be calculated as "The number of
octet sent or received is equal to the duration of the Termination, in
seconds, multiplied by the sampling frequency,  8000 Hz.". (Of course this
seems to be redundant info if the MGC is aware of the sampling frequency).
Isn't this the intention?????-RegardsMadhubabu

-----Original Message-----
From: [email-masked]
 mailto:[email-masked]
<mailto:[email-masked]> ]On Behalf Of Chuong Nguyen
Sent: Tuesday, May 29, 2001 4:38 PM
To: [email-masked]
Subject: Network Package
Hi All

Is it reasonable to assume that Network Package StatisticsID will never be
used directly?
That is nt/dur, nt/os and nt/or will normally be rtp/dur, rtp/os and rtp/or
respectiviely
since rtp package extends nt package.

I know that it is agreed that if a termination realizes rtp package, it also
realizes nt package
and either nt/.. or rtp/.. are valid packageName.

But if we allow, nt/... instead of rtp/.., are we saying that if MGC
receives nt/.., it has to
know whether it is for rtp or tmcd termination by the terminationID?

Furthermore, since tdmc package extends nt package, do "octet sent" (OS) and
"octet
received" (OR) really apply to tdm termination?

Also what does it mean for a TDM termination to realize the "NT" package
properties
of "Maximum Jitter Buffer"?

So a more general question, if a termination realizes a packageB that
extends
packageA and there are items in the packageA that does not make sense to
the termination what should MG/MGC do.

Take the above as an example and assuming that it does not make sense for
TDM
termination to have "OS" and "OR", what should MG return for TDM termination
statistics if the termination realizes "TDMC" package?
Just "duration".

---
Said it is valid to have "OS" and "OR" for TDM.
IF MGC does a Subtract=* on a specific context w/1 TDM and 1 RTP
termination,
is it valid for MG to return nt/dur, nt/os and nt/or for the TDM termination
and RTP
termination instead of tdmc/dur, ... vs rtp/dur ?

Thanks
Chuong

--

--

--

---

From: Chuong Nguyen <[email-masked]>
Date: Wed, 30 May 2001 09:58:09 -0500

> [PB]  I believe this logic was given in the Implementors' Guide.  If it remains unclear, please let us all know what needs to be clarified.

<cnn>  Are you referring to the following in IGv6  Section 12.1?

When packages are extended, the properties, events, signals and statistics defined in the base package can be referred to using either the extended package name.  For example, if Package A defines event e1, and Package B extends Package A, then B/e1 is an event for a termination implementing Package B. By definition, the MG MUST also implement the base Package, but it optional to publish the base package as an allowed interface.  If it does publish A, then A would be reported on the Package Descriptor in AuditValue as well as B, and event A/e1 would be available on a termination.  If the MG does not publish A, then only B/e1 would be available.  If published through AuditValue, A/e1 and B/e1 are the same event.
For the purpose of improved interoperability and backward compatibility, the an MG MAY publish all Packages supported by its Terminations, including base Packages from which extended Packages are derived.  An exception to this is in cases where the base packages are expressly designed to be extended by others, not directly controlled, and may not have any function on their own or be nonsensical on their own, in which case the MG SHOULD NOT publish the base Packages.

<cnn>  I don't see anything remotely stating what we are discussing about statistics and
               event reporting.   Specifically that one can get duplicate statistics.

> [PB] Yes, there would be double the overhead, but that's not really different overhead from MGC asking for 2 sets of statistics from different sources.

<cnn>  I am using the case of Subtract Request which does not specify any parameter.
              Thus MG will reply w/all statistics in which case MGC will receive duplicate
              statistics.

> [PB] My opinion, not as author of the tdmc Package,  is the property should simply always be 0.  There is no jitter buffer.  I agree this is not a very interesting value, so if the MGC is not inter…

<cnn>  So in general if a package that extends another package and there is some parameters
               that might not apply, we do not flag it as an error but assume some default value
               and treat it as a nop?

              So does NT package qualify as a "base package" based on the definition of what
              a "base package" is as quoted above -

     An exception to this is in cases where the base packages are expressly designed to be extended by others, not directly controlled, and may not have any function on their own or be nonsensical on their own, in which case the MG SHOULD NOT publish the base Packages.

     Should something be added to each package to define whether it is a "base package"
     which meant that it can't be used on its own?

     NT package is one example to me since each termination that realizes this package must
     belong to some network type which should have its own network-type package (RTP,
     TDM, ATM, etc).