Subject: RE: Use of ServiceChange from MGC to MG

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 21 May 2001 06:36:04 -0400

You're right: the only difference would be if the MGC asked for GRACEFUL
with a non-zero time delay.  I suspect the appropriate action in that case
is unspecified -- have to check the documentation.  It would be nice if that
meant "assign no new calls, but wait to set the state".

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, May 21, 2001 3:26 AM
> To: Taylor, Tom-PT [NORSE:B881:EXCH]
> Cc: 'Rosen, Brian'; 'Dan Elbert'; [email-masked]'
> Subject: RE: Use of ServiceChange from MGC to MG
> 
> 
> 
> 
> Hello Tom,
>      Firstly can an MGC issue a SC with GRACEFUL?
> 
> If yes consider the actions at MG
> - on receiving GRACEFUL with 0 delay for a non-ROOT 
> termination: It needs to
> wait for the call to get cleared, i.,e wait till it receives 
> a SUBTRACT before
> putting it OOS.
> - on receiving FORCED for a non-ROOT termination: It still 
> needs to wait for a
> SUBTRACT, i.e wait for the call to get cleared gracefully.
> 
> Hence what is the difference between MG receiving a service 
> change with graceful
> or with forced?
> 
>                                               Regards,
>                                               R. Ezhirpavai
> 
> 
> 
> 
> 
> "Tom-PT Taylor" <[email-masked]> on 05/20/2001 07:52:23 PM
> 
> To:   "'Rosen, Brian'" <[email-masked]>, R Ezhirpavai/HSS@HSS
> cc:   "'Dan Elbert'" <[email-masked]>, "[email-masked]'"
>       <[email-masked]>
> 
> Subject:  RE: Use of ServiceChange from MGC to MG
> 
> 
> 
> 
> The MGC could use GRACEFUL if the termination is an outgoing 
> trunk which a
> craftsperson at the MGC has seized.  The idea would be to 
> give time for any
> existing call to terminate, while preventing additional calls 
> from being
> assigned to the trunk.
> 
> > -----Original Message-----
> > From: Rosen, Brian [mailto:[email-masked]]
> > Sent: Friday, May 18, 2001 1:39 PM
> > To: [email-masked]'
> > Cc: Taylor, Tom-PT [NORSE:B881:EXCH]; 'Dan Elbert'; 
> [email-masked]'
> > Subject: RE: Use of ServiceChange from MGC to MG
> >
> >
> > I said that - the MGC does the Subtract explicitly; just
> > taking the termination out of service DOES NOT implicitly do
> > a Subtract.  If you are arguing about the order of operations,
> > I would recommend the Subtract before the ServiceChange.
> >
> > The usual drill for the MGC is first to subtract, then serviceChange
> > forced.  There really isn't any reason for the MGC to use Graceful.
> >
> > The usual drill for the MG is to send Graceful, the MGC responds
> > with Subtract, then the MG makes the terminations out of
> > service after the subtract or at the latest, after the timeout.
> >
> > A forced Restart on Root should happen immediately.
> >
> > Brian
> >
> 
> 
> 
> 
> 
> 
>

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Mon, 21 May 2001 09:22:19 -0400

RE: Use of ServiceChange from MGC to MGHI Tom/pavai,
The "graceful" method of SC doesn't convey additional information to
MG(except for the SC delay part of it). Tom mentioned "assign no new calls,
but wait to set the state", but it is the MGC that is aware of the calls not
MG. So what does it mean if MGC is indicating MG not to establish new
calls???

Regards
Madhubabu
  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Tom-PT Taylor
  Sent: Monday, May 21, 2001 6:36 AM
  To: [email-masked]'
  Cc: 'Rosen, Brian'; 'Dan Elbert'; [email-masked]'
  Subject: RE: Use of ServiceChange from MGC to MG