Subject: RE: Version negotiation

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 29 May 2001 08:58:21 -0400

The situation is pretty complicated, and the action taken may
depend on a lot of things.  There are several strategies an MG
could use, including trying secondary MGCs.  One of the variables
is what profile the MGC offers; if it offers the correct profile,
but it's version of Megaco is earlier, and the MG can deal with
the older version, then it might stay with the MGC, or, it might 
try secondary MGCs looking for a better fit.  

As there is only one version, I'd defer any text changes until this
is a real problem.

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, May 29, 2001 6:59 AM
> To: [email-masked]
> Subject: Version negotiation
> 
> 
> 
> 
> 
> Hi Christian,
> 
> Since nobody replied back to my mail so should I assume that 
> in case the version
> negotiations fails with MGC, then MG should try with the 
> secondary MGCs. In this
> case we need to make change in the text of the protocol.
> 
> Regards
> Vivek Bansal
> 
> 
> ---------------------- Forwarded by Vivek Bansal/HSS on 
> 05/29/2001 04:19 PM
> ---------------------------
> 
> To:   [email-masked]
> cc:    (bcc: Sachin Sikri/HSS)
> 
> Subject:  Version negotiation
> 
> 
> 
> 
> 
> 
> 
> Hi
> 
> If the version negotiations fails at MG, then what should be 
> the recovery
> action. Protocols says close the netwrok connection and give 
> error to MGC in
> case of any transaction from MGC. But it does not specify 
> what should MG do
> after the failure. Should it try to contact the other 
> provisioned MGCs. or is it
> assumed that all the MGCs are configured with the same 
> version and MG will not
> be able to create association with them.
> 
> Please  clarify this.
> 
> Regards
> Vivek
> 
> 
> 
> 
> 
> 
>

---

From: Christian Groves <[email-masked]>
Date: Thu, 31 May 2001 00:21:05 +1000

I agree with Brian. This is something "possibly" for v2. We have the
negotiation mechanism that we require and as backward compatibility is
required you should never have the case where you can't agree on a
version. If you can't agree on a version the it really depends on your
network scenario. I think the best thing to do is notify O&M.

Cheers, Christian