Subject: RE: Use of ServiceChange from MGC to MG

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 18 May 2001 13:38:30 -0400

I said that - the MGC does the Subtract explicitly; just
taking the termination out of service DOES NOT implicitly do
a Subtract.  If you are arguing about the order of operations,
I would recommend the Subtract before the ServiceChange.

The usual drill for the MGC is first to subtract, then serviceChange
forced.  There really isn't any reason for the MGC to use Graceful.

The usual drill for the MG is to send Graceful, the MGC responds
with Subtract, then the MG makes the terminations out of
service after the subtract or at the latest, after the timeout.

A forced Restart on Root should happen immediately.

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 1:13 PM
> To: Rosen, Brian
> Cc: 'Tom-PT Taylor'; 'Dan Elbert'; [email-masked]'
> Subject: RE: Use of ServiceChange from MGC to MG
> 
> 
> 
> 
> Hello Brain,
>      Since the MGC is the controller of the call, shouldn't 
> the MGC explicitly
> subtract the call from the context before taking the 
> termination out of service?
> In what scenarios would the MGC take the termination out of 
> service and then
> subtract it from the call explicitly.
> 
>      Taking it a bit further, if the MGC sends service change 
> with "forced" on
> ROOT termination, should the MG still wait for the contexts 
> on all terminations
> to be subtracted explicitly by the MGC before going down?
> 
> 
>                                          Regards,
>                                          R. Ezhirpavai
> 
> 
> 
> 
> 
> "Rosen, Brian" <[email-masked]> on 05/18/2001 09:07:21 PM
> 
> To:   "'Tom-PT Taylor'" <[email-masked]>, "'Dan Elbert'"
>       <[email-masked]>, "[email-masked]'" <[email-masked]>
> cc:    (bcc: R Ezhirpavai/HSS)
> 
> Subject:  RE: Use of ServiceChange from MGC to MG
> 
> 
> 
> 
> One thing I think is incorrect here is the "Subtracted from any active
> contexts" part.  I believe we defined the protocol so that this NEVER
> happens
> as a side-effect.  The termination may actually be out of 
> service, but both
> the MG and the MGC have it in a context if it was when the 
> termination was
> taken out of service.
> 
> It is always incumbant on the MGC to do the subtract explicitly.
> 
> The ONLY exception to this is restart of the MG; all contexts 
> are lost.
> 
> Brian
> 
> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 11:32 AM
> To: 'Dan Elbert'; [email-masked]'
> Subject: RE: Use of ServiceChange from MGC to MG
> 
> 
> 
> Hi.
> 
> > -----Original Message-----
> > From: Dan Elbert [ mailto:[email-masked]
> <mailto:[email-masked]> ]
> > Sent: Friday, May 18, 2001 11:06 AM
> > To: [email-masked]'
> > Subject: Use of ServiceChange from MGC to MG
> >
> >
> > Hi
> >
> > The Media Gateway Controller may indicate that Termination(s)
> > shall be taken
> > out of or returned to service.
> > 1. What is the meaning of the MGC taking down a termination ?
> > Does it means
> > that the termination is substracted from any active context
> > and all signal
> > are stopped and no events are detected ?
> 
> Yes
> 
> > 2. What methods are used for taking the MG down and up ? I'd
> > say Graceful
> > and Restart. Is this OK ?
> 
> "Taking the MG down" to me means doing a ServiceChange on 
> ROOT at the MG.
> It's possible the MGC might do that to an MG, but most likely 
> in that case
> that it would be done under manual control (i.e. the network 
> is set up such
> that control of MGs is exercised through the MGC).  I don't 
> see this as a
> typical maintence arrangement.
> 
> > 3. Is this applicable also to the root termination ? I would
> > say no because
> > if the root termination "goes down" then logically the MG may
> > not be able to
> > receive any more MGC commands.
> 
> Upon recovery the MG would follow normal start-up procedures 
> to establish a
> new control association.
> 
> >
> > Thanks,
> >
> > Dan Elbert
> > RADVISION
> >
> 
> 
>

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Fri, 18 May 2001 14:04:25 -0400

HI Brian,
Do you mean that the MGC can send ServiceChange on ROOT with either
"Restart" or "Forced". I was in the impression that ROOT is some special
termination indicating the Whole MG and the MG uses it to registers itself
with the MGC. As you said "A forced Restart on Root should happen
immediately.", Is it your intention that the MG should initiate this
Restart???

Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Rosen, Brian
Sent: Friday, May 18, 2001 1:39 PM
To: [email-masked]'
Cc: 'Tom-PT Taylor'; 'Dan Elbert'; [email-masked]'
Subject: RE: Use of ServiceChange from MGC to MG

Brian