Subject: RE: IP Type of Service

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 8 May 2001 10:07:14 -0400

That makes sense.

-----Original Message-----
From: Madhu Babu Brahmanapally [mailto:[email-masked]]
Sent: Tuesday, May 08, 2001 10:08 AM
To: 'Rosen, Brian'; Taylor, Tom-PT [NORSE:B881:EXCH]; 'Chuong Nguyen';
megaco
Subject: RE: IP Type of Service

Hi All,
Another suggestion. Why cant the SDP be extended to incorporate a TOS
parameter/attribute so that all the protocols(SIP,Megaco,MGCP) that use SDP
need not define extra properties/parameter for supporting this. 
 
Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Rosen, Brian
Sent: Tuesday, May 08, 2001 9:24 AM
To: 'Madhu Babu Brahmanapally'; 'Tom-PT Taylor'; 'Chuong Nguyen';
[email-masked]
Subject: RE: IP Type of Service

I don't agree.  The TOS for a particular stream should be set on that
stream, not
on the MG as a whole.  For example, if I have a multimedia MG, I will want
to set
the priority of voice higher than video, and video higher than normal.  If I
implement a
Multilevel Pre-emption and Priority scheme, some calls will have higher
priority than
others.  The TOS/frame priority has to be per stream.
 
Brian

-----Original Message-----
From: Madhu Babu Brahmanapally [mailto:[email-masked]]
Sent: Tuesday, May 08, 2001 9:24 AM
To: 'Rosen, Brian'; 'Tom-PT Taylor'; 'Chuong Nguyen'; [email-masked]
Subject: RE: IP Type of Service

Hi All,
 
The default TOS type should be defined on the ROOT termination for the
default TOS used for all media packets generated from the MG. There should
be a method (might be through some property) of specifying stream level TOS
bits. 
 
I'm interested to work on RSVP. 
 
Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Rosen, Brian
Sent: Tuesday, May 08, 2001 8:10 AM
To: 'Tom-PT Taylor'; 'Chuong Nguyen'; [email-masked]'
Subject: RE: IP Type of Service

TOS should not be ignored at the edge router if the router is configured to
enable DiffServ.  
 
It would be pretty simple to create one package that had the appropriate
controls for
DiffServ and 802.1p.  RSVP needs it's own package because there is
messaging,
and you at least an event or two
 
The former could be an enumeration: QosMarking, that had values None, TOS
and
FramePriority, plus another integer, Value.  That would suffice I think,
although you
could conceivably get more clever with DiffServ.
 
Shall I write something up along those lines?  
 
RSVP takes some more work.  Any volunteers?
 
Brian

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Monday, May 07, 2001 9:15 PM
To: 'Chuong Nguyen'; [email-masked]'
Subject: RE: IP Type of Service

No such package has yet been defined.
 
Various QOS architectures can be imagined.  Each would give rise to its own
package, since the MGC-MG information flow would differ from one
architecture to the next.  One question: unless the MG is itself the edge
router, won't the ToS be ignored when the media packets reach the latter?

-----Original Message-----
From: Chuong Nguyen [mailto:[email-masked]]
Sent: Monday, May 07, 2001 5:14 PM
To: [email-masked]'
Subject: IP Type of Service

All 

In MGCP, MGC can specify IP Type of Service to the MG. 
Do we have an equivalent in Megaco? 

Is there or has anyone defined a package for IP Type of Service? 

Thanks 
Chuong 

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Chuong Nguyen <[email-masked]>
Date: Tue, 08 May 2001 09:33:51 -0500

Right now I don't have any preference w/package vs SDP extension.
Which is quicker to be considered as acceptable for Standardization?
Is there any difference in the IETF process vs ITU process?

But I am concern w/the concept of doing an AuditCapability to see what
package does
an MG support.  Said there was an SDP extension for ToS, how does an MGC
knows
that the MG supports ToS?

It looks like "Profile" would be more useful than AuditCapability on
package to find
MG capability.

Tom-PT Taylor wrote:

>      To: 'Rosen, Brian'; Taylor, Tom-PT [NORSE:B881:EXCH];
>      'Chuong Nguyen'; megaco
>      Hi All,Another suggestion. Why cant the SDP be extended to
>      incorporate a TOS parameter/attribute so that all the
>      protocols(SIP,Megaco,MGCP) that use SDP need not define
>      extra properties/parameter for supporting
>      this. RegardsMadhubabu
>
>           To: 'Madhu Babu Brahmanapally'; 'Tom-PT Taylor';
>           'Chuong Nguyen'; [email-masked]
>           I don't agree.  The TOS for a particular stream
>           should be set on that stream, noton the MG as a
>           whole.  For example, if I have a multimedia MG, I
>           will want to setthe priority of voice higher than
>           video, and video higher than normal.  If I
>           implement aMultilevel Pre-emption and Priority
>           scheme, some calls will have higher priority
>           thanothers.  The TOS/frame priority has to be per
>           stream.Brian
>
>                Hi All,The default TOS type should be
>                defined on the ROOT termination for the
>                default TOS used for all media packets
>                generated from the MG. There should be a
>                method (might be through some property)
>                of specifying stream level TOS bits. I'm
>                interested to work on
>                RSVP. RegardsMadhubabu
>
>                     TOS should not be ignored at
>                     the edge router if the router
>                     is configured toenable
>                     DiffServ. It would be pretty
>                     simple to create one package
>                     that had the appropriate
>                     controls forDiffServ and
>                     802.1p.  RSVP needs it's own
>                     package because there is
>                     messaging,and you at least an
>                     event or twoThe former could
>                     be an enumeration: QosMarking,
>                     that had values None, TOS
>                     andFramePriority, plus another
>                     integer, Value.  That would
>                     suffice I think, although
>                     youcould conceivably get more
>                     clever with DiffServ.Shall I
>                     write something up along those
>                     lines? RSVP takes some more
>                     work.  Any volunteers?Brian
>
>                          -----Original
>                          Message-----
>                          From: Tom-PT Taylor
>                          No such package has
>                          yet been
>                          defined.Various QOS
>                          architectures can be
>                          imagined.  Each
>                          would give rise to
>                          its own package,
>                          since the MGC-MG
>                          information flow
>                          would differ from
>                          one architecture to
>                          the next.  One
>                          question: unless the
>                          MG is itself the
>                          edge router, won't
>                          the ToS be ignored
>                          when the media
>                          packets reach the
>                          latter?
>                               ----Original
>                               Message-----
>                               From:
>                               Nguyen
>                               [mailto:[email-masked]]
>
>                               Sent:
>                               Monday,
>                               May 07,
>                               2001 5:14
>                               PM
>                               To:
>                               [email-masked]'
>
>                               Subject:
>                               IP Type of
>                               Service
>                               All
>
>                               In MGCP,
>                               MGC can
>                               specify IP
>                               Type of
>                               Service to
>                               the MG.
>                               Do we have
>                               an
>                               equivalent
>                               in Megaco?
>
>                               Is there
>                               or has
>                               anyone
>                               defined a
>                               package
>                               for IP
>                               Type of
>                               Service?
>
>                               Thanks
>                               Chuong
>
>                               --

---

From: "Krishna Gundamaraju" <[email-masked]>
Date: Tue, 8 May 2001 11:05:58 -0400

Assuming that the SDP is extended to specify the TOS value for a stream, what should a MG do if this parameter is missing in the SDP sent from MGC? I think the protocol should also specify what should happen if TOS info is missing in the SDP received. 

    If both of the above options are available(MEGACO means of specifying TOS and SDP way of specifying TOS), the protocol specified option should take precedence over the one specified in SDP, as done for mode parameter.

    So, as pointed by Madhu, I think we need

1). The capability to specify a default value of TOS for the MG (either as a property of the root termination or some other means).
2). The capability to specify the TOS value on per stream basis.

Regards
Krishna G

  ----- Original Message ----- 
  From: Tom-PT Taylor 
  To: 'Madhu Babu Brahmanapally' ; 'Rosen, Brian' ; 'Chuong Nguyen' ; megaco 
  Sent: Tuesday, May 08, 2001 10:07 AM
  Subject: RE: IP Type of Service

  That makes sense.
    -----Original Message-----
    From: Madhu Babu Brahmanapally [mailto:[email-masked]]
    Sent: Tuesday, May 08, 2001 10:08 AM
    To: 'Rosen, Brian'; Taylor, Tom-PT [NORSE:B881:EXCH]; 'Chuong Nguyen'; megaco
    Subject: RE: IP Type of Service

    Hi All,
    Another suggestion. Why cant the SDP be extended to incorporate a TOS parameter/attribute so that all the protocols(SIP,Megaco,MGCP) that use SDP need not define extra properties/parameter for supporting this. 
     
    Regards
    Madhubabu
      -----Original Message-----
      From: [email-masked] [mailto:[email-masked]]On Behalf Of Rosen, Brian
      Sent: Tuesday, May 08, 2001 9:24 AM
      To: 'Madhu Babu Brahmanapally'; 'Tom-PT Taylor'; 'Chuong Nguyen'; [email-masked]
      Subject: RE: IP Type of Service

      I don't agree.  The TOS for a particular stream should be set on that stream, not
      on the MG as a whole.  For example, if I have a multimedia MG, I will want to set
      the priority of voice higher than video, and video higher than normal.  If I implement a
      Multilevel Pre-emption and Priority scheme, some calls will have higher priority than
      others.  The TOS/frame priority has to be per stream.
       
      Brian
        -----Original Message-----
        From: Madhu Babu Brahmanapally [mailto:[email-masked]]
        Sent: Tuesday, May 08, 2001 9:24 AM
        To: 'Rosen, Brian'; 'Tom-PT Taylor'; 'Chuong Nguyen'; [email-masked]
        Subject: RE: IP Type of Service

        Hi All,
         
        The default TOS type should be defined on the ROOT termination for the default TOS used for all media packets generated from the MG. There should be a method (might be through some property) of specifying stream level TOS bits. 

        Regards
        Madhubabu
          -----Original Message-----
          From: [email-masked] [mailto:[email-masked]]On Behalf Of Rosen, Brian
          Sent: Tuesday, May 08, 2001 8:10 AM
          To: 'Tom-PT Taylor'; 'Chuong Nguyen'; [email-masked]'
          Subject: RE: IP Type of Service

          It would be pretty simple to create one package that had the appropriate controls for
          DiffServ and 802.1p.  RSVP needs it's own package because there is messaging,
          and you at least an event or two
           
          The former could be an enumeration: QosMarking, that had values None, TOS and
          FramePriority, plus another integer, Value.  That would suffice I think, although you
          could conceivably get more clever with DiffServ.

           
          Brian
            -----Original Message-----

            Various QOS architectures can be imagined.  Each would give rise to its own package, since the MGC-MG information flow would differ from one architecture to the next.  One question: unless the MG is itself the edge router, won't the ToS be ignored when the media packets reach the latter?
              -----Original Message-----

              All 

              Thanks 
              Chuong