Subject: RE: multiple digitmaps

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 3 May 2001 15:32:15 -0400

You're right.  I think we intended this.  Does anyone object?   

> -----Original Message-----
> From: Troy Cauble [mailto:[email-masked]]
> Sent: Thursday, May 03, 2001 11:51 AM
> To: MEGACO list
> Subject: multiple digitmaps
> 
> 
> 
> MEGACO/1 [12.12.12.12]:12345
> Transaction = 1030 {Context = - {Modify = ROOT {
>   DigitMap = Pin {(xxxx|xxxxxx)},
>   DigitMap = UserId {(xxxxxx)},
>   DigitMap = Dialplan0 {(0|00|911|1xxxxxxxxxx|Exx|[2-9]xxxxxx|9011x.)}
> }}}
> 
> 
> Multiple digitmaps in Add/Move/Modify parameters are 
> currently illegal based on comments in Annex A and B.  
> This seems pretty useful.
> 
> 
> Proposal:
> 
> In Annex B, rewrite the comment above the "ammParameter" spec as:
> 	; at-most-once except for digitMapDescriptor.
> 
> In Annex A, rewrite the comment in the "AmmRequest" spec as:
> 	-- At most one descriptor of each type (see AmmDescriptor)
> 	-- allowed in the sequence, except for DigitMapDescriptor.
> 
> 
> -troy
>

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 3 May 2001 16:02:42 -0400

RE: multiple digitmapsNeed to add text for this feature in section 7.1.14,
else its not known unless one looks into the grammar.

Regards
Madhubabu
  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Tom-PT Taylor
  Sent: Thursday, May 03, 2001 3:32 PM
  To: 'Troy Cauble'; MEGACO list
  Subject: RE: multiple digitmaps

  > Transaction = 1030 {Context = - {Modify = ROOT