Subject: RE: Polls of MGC

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 18 May 2001 15:33:33 -0400

Troy

Keepalives have never been considered very bad when they have the
appropriate controls.  I don't know what systems you have worked on, but
most of the reliable systems I know have keepalives.

In this case, we CAN make it one-sided - the MGC makes sure that it
has some minimum message rate to the MGs it controls, or we can
let the MG send a message if, after some time the MGC determines,
it hasn't seen a message from the MGC.  Either way works.  Either way
should NOT be a big burden.  Note that you also can implement both,
and by sending messages from the MGC faster than the interval you
set on the MG, you won't ever see any of the MG initiated messages,
until something goes wrong. Then you will see ONE message from each
MG, and then, in a pretty random, and pretty spaced out way (if you
have done the right thing with MG setup on the MGC), you should see
them all move over to another MGC.

I'm not up for changing something that isn't broken

Keepalives are good for reliability.

Brian

Brian

> -----Original Message-----
> From: Troy Cauble [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 3:24 PM
> To: Dave Sclarsky
> Cc: 'Rosen, Brian'; [email-masked]'; [email-masked]
> Subject: Re: Polls of MGC
> 
> 
> Dave Sclarsky wrote:
> > 
> > Troy,
> > 
> > It doesn't matter what the new (or restarted) MGC knows or 
> doesn't know.
> > Megaco defines that the control association between MG and 
> MGC is ALWAYS
> > initiated by the MG.  
> 
> Then this definition is the problem and should be revisited.
> 
> Polling is bad.
> 
> -troy
> 
> > Given that definition, Johnny's Dad's MG won't be
> > reachable by a new (or a restarted) MGC until the his MG notices the
> > failure.  We must define a way for it to know ASAP!
>

---

From: Troy Cauble <[email-masked]>
Date: Fri, 18 May 2001 16:06:36 -0400

> most of the reliable systems I know have keepalives.

Not considered "very" bad ?  Just a little bad? :)

> I'm not up for changing something that isn't broken

The words "poll" and "keepalive" do not exist in the
H.248 document or the IG.  You are changing something.

-troy