Subject: Re: RFC 3015 Errors

From: Christian Groves <[email-masked]>
Date: Mon, 07 May 2001 11:34:41 +1000

G'Day Brian,

Points 1 and 2 are already covered by the H.248/Megaco implementors'
Guide. With regards to point 3 these may be addressed in a future
RFC/recommendation currently the best think to look at would be H.225
(from memory) where this was copied from.

Cheers, Christian

"Brian C. Wiles" wrote:
> 
>    Forgive me if this has already been addressed because the list archive
> ends at February.  I've noticed that the ASN.1 description in RFC 3015 has
> at least a few missing lines and at least one ambiguity.
> 
>    1.)  The top line of the definition for the IP4Address on Page 84 is
> missing, but its contents are defined:
> 
>          Currently, it reads:
> 
> {
>    address         OCTET STRING (SIZE(4)),
>    portNumber      INTEGER(0..65535) OPTIONAL
> }
> 
>          I believe it should read:
> 
> IP4Address ::= SEQUENCE
> {
>    address         OCTET STRING (SIZE(4)),
>    portNumber      INTEGER(0..65535) OPTIONAL
> }
> 
>    2.)  The definition for ServiceChangeParm on Page 97 seems to be missing
> a "..." extension marker.
> 
>    3.)  The H221NonStandard structure on Page 98 contains a t35CountryCode1
> and t35CountryCode2 in addition to the t35Extension.  Isn't there supposed
> to be only one CountryCode byte plus the Extension?  If all 3 are intended,
> what should the values be for a company in the US (Country Code B500)?
> 
>    Shouldn't these be addressed in a future RFC to ensure manufacturers are
> compatible?  Or, am I completely off base here? :)  Thanks.
>          -Brian
> 
> ---
> Brian C. Wiles
> Chief Executive Officer
> StreamComm
> +1 (916) 501-4349
> http://www.streamcomm.com

---

From: Atanu Mondal <[email-masked]>
Date: Mon, 07 May 2001 10:24:40 +0530

Can anybody tell me where this H.248/Megaco Implementor's guide is available ?

Regards
Atanu

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Mon, 7 May 2001 08:59:25 -0400

Atanu,

ftp://standards.nortelnetworks.com/megaco/docs/Approved/
is the location from which I got the IG.
Regards
Madhubabu
  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Atanu Mondal
  Sent: Monday, May 07, 2001 12:55 AM
  To: Christian Groves; [email-masked]
  Subject: Re: RFC 3015 Errors

  Can anybody tell me where this H.248/Megaco Implementor's guide is
available ?
  Regards
  Atanu

  Christian Groves wrote:

    G'Day Brian,