Subject: RE: Error in transaction reply.

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 2 May 2001 11:41:40 -0400

There's a general principle, that there is no point in replying to an error
response pointing out the error because that could create an error loop.
All that is possible is to try to reset things to a known state or, if
things get too bad, discontinue the association.

-----Original Message-----
From: Titty Thomas [mailto:[email-masked]]
Sent: Wednesday, May 02, 2001 12:04 AM
To: megaco mail list
Subject: Error in transaction reply.

Hi all, 
  
    If there is an error in transaction reply, what will the receiver of the
reply do. How 

can he report back to the sender that the reply was an error. And what will
happen if 

the reply had some values chosen by the sender (eg. reply for a command with
$ ) and the 

value is in error. 

Regards, 

- Titty 

-- 

+------------------------------------------------------------------+

|Two roads diverged in a wood, and I took the one less traveled by,| 

|And that has made all the difference.                             |

+------------------------------------------------------------------+

---

From: Atanu Mondal <[email-masked]>
Date: Thu, 3 May 2001 09:51:09 +0530

Hello Rezhirpavai,
So how does it matter.. The MGC will again retransmit the transaction,
whereas the MG since it has stored the transaction id will simply discard
the message and send a reply to MGC...

Regards
Atanu

> ----------
> From: 	[email-masked][SMTP:[email-masked]]
> Sent: 	Thursday, May 03, 2001 9:20 AM
> To: 	Madhu Babu Brahmanapally
> Cc: 	[email-masked]; 'megaco mail list'
> Subject: 	RE: Error in transaction reply.
> 
> <<File: att1.htm>>
> 
> 
> Hello Madhu,
>      If the MGC assumes that the transaction response containing a parse
> error
> is a transaction reply with error, then this would lead to discrepancy
> between
> the states of MG and MGC. The MGC would assume that the MG has not
> processed the
> request whereas the MG would have processed the request and would have
> possibly
> changed the termination state.
> 
>                                          Regards,
>                                          R. Ezhirpavai
> 
> 
> 
> 
> 
> "Madhu Babu Brahmanapally" <[email-masked]> on 05/02/2001 07:09:47
> PM
> 
> To:   [email-masked], "'megaco mail list'" <[email-masked]>
> cc:    (bcc: R Ezhirpavai/HSS)
> 
> Subject:  RE: Error in transaction reply.
> 
> 
> 
> 
> Hi Titty,
> 
> In normal circumstances, even if the MGC retransmit its
> transaction-request
> the same transaction response is received from MG. IMO the MGC can treat
> the
> error transaction response as error response from MG.
> Regards
> Madhubabu
> 
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Titty Thomas
>       If there is an error in transaction reply, what will the receiver of
> the reply do. How
>   can he report back to the sender that the reply was an error. And what
> will happen if
> 
>   the reply had some values chosen by the sender (eg. reply for a command
> with $ ) and the
> 
>   value is in error.
> 
>   Regards,
> 
>   - Titty
> 
> 
> 
> --

---

From: [email-masked]
Date: Thu, 3 May 2001 09:52:54 +0530

Hello Atanu,
     On getting back a valid transaction reply, the MGC would stop the
retransmission timer irrespective of whether it contains an error descriptor or
not. Hence it cannot retransmit with the same transaction id. It can though
construct a new transaction request and send to MG again, but probably the new
response may again have a parse error.

                                         Regards,
                                         R. Ezhirpavai

Atanu Mondal <[email-masked]> on 05/03/2001 09:51:09 AM

To:   Madhu Babu Brahmanapally <[email-masked]>, R Ezhirpavai/HSS@HSS
cc:   [email-masked], "'megaco mail list'" <[email-masked]>

Hello Rezhirpavai,

Regards
Atanu

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 3 May 2001 09:18:17 -0400

I'm beginning to think that maybe we ought to do something about this.
 
First of all, every one of these discussions around syntax errors often
misses
a real important point
    There is basically no recovery possible for the error
This is because there is no way either end is going to change the SYNTAX
of the message it sends as a result of an error.  It's going to take the
offending
programmer to do that (20 lashes with a wet noodle please).  Your only
real recourse is:
    Don't do whatever caused that problem to happen, until the software is
fixed
 
Now, having said that, real systems often have problems and vendors need
a way to figure out what happened and even customers need a way to figure
out that something wrong happened so they at least have a shot at a
workaround.
 
The best solution I can come up with is a real change to the protocol, and
I'm not
at all wild about proposing something that actually changes things, but here
goes:
 
Send a TransactionAck (even if you are using a reliable transport) with an
error
message.
 
Of course, you could get a syntax error on a transactionAck!  I think we can
either ignore that possibility, or allow the Ack the other way.  I'd vote
the former.
 
Brian

-----Original Message-----
From: Titty Thomas [mailto:[email-masked]]
Sent: Wednesday, May 02, 2001 11:39 PM
To: [email-masked]
Cc: Madhu Babu Brahmanapally; [email-masked]; 'megaco mail list'
Subject: Re: Error in transaction reply.

Hi , 
  
    In this case one of the options can be to audit the MG and find out its
state. 

Regards, 
-- Titty 

[email-masked] wrote: 

Hello Madhu, 
the states of MG and MGC. The MGC would assume that the MG has not processed

                                         Regards, 
                                         R. Ezhirpavai 

"Madhu Babu Brahmanapally" <[email-masked]> on 05/02/2001 07:09:47 PM

Hi Titty, 

In normal circumstances, even if the MGC retransmit its transaction-request 
the same transaction response is received from MG. IMO the MGC can treat the

 -----Original Message----- 
From: [email-masked] 
[ mailto:[email-masked]
<mailto:[email-masked]> ]On Behalf Of Titty Thomas 
Sent: Wednesday, May 02, 2001 12:04 AM 
To: megaco mail list 
Subject: Error in transaction reply. 

  Hi all, 

  value is in error. 

  Regards, 

  - Titty 

  ------------------------------------------------------------------------ 
                  Name: att1.htm 
   att1.htm       Type: Hypertext Markup Language (text/html) 
              Encoding: base64 
           Description: Internet HTML

--