Subject: RE: Error Code 505

From: "Alf Heidermark (UAB)" <[email-masked]>
Date: Thu, 10 May 2001 16:45:36 +0200

Hello
 
If you look in the proposed Annex L you can find for different service change reason what the state of each concened terminastions is. 

-----Original Message-----
From: Krishna Gundamaraju [mailto:[email-masked]]
Sent: den 10 maj 2001 16:38
To: Tom-PT Taylor; 'Madhu Babu Brahmanapally'; 'Christian Groves'
Cc: megaco
Subject: Re: Error Code 505

Hi All,
 
    All along we were thinking that the ROOT ServiceChange implies that all the provisioned terminations are inservice. The Protocol should clearly state what is the correct behavior as otherwise there could be very serious interoperability issues.
 
Regards,
Krishna G

----- Original Message ----- 
From: Tom-PT Taylor <mailto:[email-masked]>  
To: 'Madhu  <mailto:[email-masked]> Babu Brahmanapally' ; 'Christian Groves' <mailto:[email-masked]>  
Cc: megaco <mailto:[email-masked]>  
Sent: Thursday, May 10, 2001 10:06 AM
Subject: RE: Error Code 505

Sorry, I took the usage with respect to ROOT as a given.  I and Christian (I believe) were talking about the hypothesis that after ROOT comes up, individual terminations are out of service until they, too, have been signalled in-service through a ServiceChange exchange.  As your message shows and mine was meant to point out, this is not the behaviour people are currently assuming.  Of course, maybe I misunderstood Christian in the first place.

-----Original Message----- 
From: Madhu Babu Brahmanapally [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Thursday, May 10, 2001 9:47 AM 
To: Taylor, Tom-PT [NORSE:B881:EXCH]; 'Christian Groves' 
Cc: megaco 
Subject: RE: Error Code 505 

Hi Tom, 
Why is this valid only for ATM? The general assumption is that as soon as the ROOT ServiceChange is complete, all the terminations (irrespective of type) provisioned at both MG and MGC are in-service. Unless followed by any ServiceChange for those terminations whose state is out-of-service.

Regards 
Madhubabu 
  
-----Original Message----- 
From: Tom-PT Taylor [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Thursday, May 10, 2001 12:58 AM 
To: 'Christian Groves' 
Cc: Madhu Babu Brahmanapally; [email-masked] 
Subject: RE: Error Code 505 

Let me put the opposite question: has anyone up to now thought that terminations are only in service after a ServiceChange announcing their presence?  I think I can see a possible use for such a convention with ATM, but I don't see it applying to any other type of termination.

> -----Original Message----- 
> From: Christian Groves [ mailto:[email-masked] <mailto:[email-masked]> ] 
> Sent: Thursday, May 10, 2001 12:42 AM 
> To: Taylor, Tom-PT [NORSE:B881:EXCH] 
> Cc: Madhu Babu Brahmanapally; [email-masked] 
> Subject: Re: Error Code 505 
> 
> 
> You lost me on the first sentence of your reply. Why can't 
> ServiceChange 
> bring up a range of termination for the first time? I don't see any 
> overriding reason that this must only apply to ROOT. 
> 
> Christian 
> 
> Tom-PT Taylor wrote: 
> > 
> > All we're talking about is response to a ServiceChange here -- not a 
> > subsequent ServiceChange indicating a reversion to the previous 
> > state.  I would suggest that 505 should apply only to 
> ServiceChange on 
> > ROOT, not because I have an immediate counter-example for the 
> > alternative, but because it feels like it would be easy to 
> construct a 
> > counter-example. 
> > 
> > > -----Original Message----- 
> > > From: Christian Groves [ mailto:[email-masked] <mailto:[email-masked]> ] 
> > > Sent: Wednesday, May 09, 2001 10:22 PM 
> > > To: Madhu Babu Brahmanapally 
> > > Cc: [email-masked] 
> > > Subject: Re: Error Code 505 
> > > 
> > > 
> > > I'd say this is valid also for terminations than root. A 
> > servicechange 
> > > can be applied to individual terminations and this error 
> code is to 
> > > guard trying to change termination characteristics before 
> they have 
> > > restarted. 
> > > 
> > > Christian 
> > > 
> > > Madhu Babu Brahmanapally wrote: 
> > > > 
> > > > HI All, 
> > > > 
> > > > The Error code 505 description is "Transaction Request 
> > > Received before a 
> > > > ServiceChange Reply has been received", does the 
> > > ServiceChange reply here 
> > > > mean the ServiceChange reply on ROOT termination? or is 
> > > this valid for other 
> > > > terminations also. I think the intention is here is 
> > > ServiceChange for ROOT 
> > > > termination. Comments?? 
> > > > 
> > > > Regards 
> > > > Madhubabu 
> > > 
>

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 10 May 2001 11:13:45 -0400

Hi All,
In the protocol, there should be a mention that if ServiceChange for ROOT is
received from MG, it is implied(or not implied) that all the terminations
that are provisioned at both MG and MGC  are inservice(or out-of-service).
"I think this particular statement is missing in the protocol."

IMHO the MG need not send further InService messages for each termination,
as the ROOT ServiceChange should imply this.  But for any new terminations
that are not provisioned the MG has to specifically send ServiceChange with
"in-service".

Regards
Madhubabu

-----Original Message-----
From: Alf Heidermark (UAB) [mailto:[email-masked]]
Sent: Thursday, May 10, 2001 10:46 AM
To: 'Krishna Gundamaraju'; Tom-PT Taylor; 'Madhu Babu Brahmanapally';
'Christian Groves'
Cc: megaco

Hello

If you look in the proposed Annex L you can find for different service
change reason what the state of each concened terminastions is.

-----Original Message-----
From: Krishna Gundamaraju [mailto:[email-masked]]
Sent: den 10 maj 2001 16:38
To: Tom-PT Taylor; 'Madhu Babu Brahmanapally'; 'Christian Groves'
Cc: megaco
Subject: Re: Error Code 505

Hi All,

    All along we were thinking that the ROOT ServiceChange implies that all
the provisioned terminations are inservice. The Protocol should clearly
state what is the correct behavior as otherwise there could be very serious
interoperability issues.

Regards,
Krishna G

----- Original Message -----
From: Tom-PT Taylor <mailto:[email-masked]>
To: 'Madhu  <mailto:[email-masked]> Babu Brahmanapally' ; 'Christian
Groves' <mailto:[email-masked]>
Cc: megaco <mailto:[email-masked]>
Sent: Thursday, May 10, 2001 10:06 AM
Subject: RE: Error Code 505

Sorry, I took the usage with respect to ROOT as a given.  I and Christian (I
believe) were talking about the hypothesis that after ROOT comes up,
individual terminations are out of service until they, too, have been
signalled in-service through a ServiceChange exchange.  As your message
shows and mine was meant to point out, this is not the behaviour people are
currently assuming.  Of course, maybe I misunderstood Christian in the first
place.

-----Original Message-----
From: Madhu Babu Brahmanapally [ mailto:[email-masked]
<mailto:[email-masked]> ]
Sent: Thursday, May 10, 2001 9:47 AM
To: Taylor, Tom-PT [NORSE:B881:EXCH]; 'Christian Groves'
Cc: megaco
Subject: RE: Error Code 505

Hi Tom,
Why is this valid only for ATM? The general assumption is that as soon as
the ROOT ServiceChange is complete, all the terminations (irrespective of
type) provisioned at both MG and MGC are in-service. Unless followed by any
ServiceChange for those terminations whose state is out-of-service.

Regards
Madhubabu

-----Original Message-----
From: Tom-PT Taylor [ mailto:[email-masked]
<mailto:[email-masked]> ]
Sent: Thursday, May 10, 2001 12:58 AM
To: 'Christian Groves'
Cc: Madhu Babu Brahmanapally; [email-masked]
Subject: RE: Error Code 505

Let me put the opposite question: has anyone up to now thought that
terminations are only in service after a ServiceChange announcing their
presence?  I think I can see a possible use for such a convention with ATM,
but I don't see it applying to any other type of termination.