Subject: Re: Use of ServiceChange from MGC to MG

From: [email-masked]
Date: Sat, 19 May 2001 00:15:42 +0530

Hello,
     Consider that due to a discripency the MG still has the "termA" in context
and the MGC assumes that the termA is in NULL context. In this case the MGC
would send service change with forced and would not send any subtract, but MG is
still waiting for the call to terminate.

     By indicating that the MG should not remove it from context till it
receives a subtract, does it not imply that the MG should not stop the media
flow too?

                                         Regards,
                                         R. Ezhirpavai

"Kevin Boyle" <[email-masked]> on 05/18/2001 11:55:51 PM

To:   R Ezhirpavai/HSS@HSS
cc:   "Rosen, Brian" <[email-masked]>, "Tom-PT Taylor"
      <[email-masked]>, "'Dan Elbert'" <[email-masked]>,
      "[email-masked]'" <[email-masked]>

Subject:  Re: Use of ServiceChange from MGC to MG

Why?  What benefit is gained by setting this restriction?  Now, I would agree
with
the idea that "out of service" also implies "inactive", thereby halting the
information flow on the streams.  However, I don't see any great problem with
allowing the out of service Modify command to precede the Subtract.  The MG is
supposed to leave terminations in context until explicitly subtracted, or the MG
restarts.

Kevin

[email-masked] wrote:

> Hello Brain,
>      Yes, I was mentioning about the order of operations. IMHO, the protocol
> should enforce the MGC to subtract the termination from context before putting
> it out of service. If the MGC sends the service change for putting the
> termination out of service, while the termination is in context, MG should
send
> back an error to the MGC, thus indicating to the MGC that the termination is
in
> context and any discripency between the MG and MGC may be resolved.
>
>                                          Regards,
>                                          R. Ezhirpavai
>
> "Rosen, Brian" <[email-masked]> on 05/18/2001 11:08:30 PM
>
> To:   R Ezhirpavai/HSS@HSS
> cc:   "'Tom-PT Taylor'" <[email-masked]>, "'Dan Elbert'"
>       <[email-masked]>, "[email-masked]'" <[email-masked]>
>
> Subject:  RE: Use of ServiceChange from MGC to MG
>
> I said that - the MGC does the Subtract explicitly; just
> taking the termination out of service DOES NOT implicitly do
> a Subtract.  If you are arguing about the order of operations,
> I would recommend the Subtract before the ServiceChange.
>
> The usual drill for the MGC is first to subtract, then serviceChange
> forced.  There really isn't any reason for the MGC to use Graceful.
>
> The usual drill for the MG is to send Graceful, the MGC responds
> with Subtract, then the MG makes the terminations out of
> service after the subtract or at the latest, after the timeout.
>
> A forced Restart on Root should happen immediately.
>
> Brian
>
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Friday, May 18, 2001 1:13 PM
> > To: Rosen, Brian
> > Cc: 'Tom-PT Taylor'; 'Dan Elbert'; [email-masked]'
> > Subject: RE: Use of ServiceChange from MGC to MG
> >
> >
> >
> >
> > Hello Brain,
> >      Since the MGC is the controller of the call, shouldn't
> > the MGC explicitly
> > subtract the call from the context before taking the
> > termination out of service?
> > In what scenarios would the MGC take the termination out of
> > service and then
> > subtract it from the call explicitly.
> >
> >      Taking it a bit further, if the MGC sends service change
> > with "forced" on
> > ROOT termination, should the MG still wait for the contexts
> > on all terminations
> > to be subtracted explicitly by the MGC before going down?
> >
> >
> >                                          Regards,
> >                                          R. Ezhirpavai
> >
> >
> >
> >
> >
> > "Rosen, Brian" <[email-masked]> on 05/18/2001 09:07:21 PM
> >
> > To:   "'Tom-PT Taylor'" <[email-masked]>, "'Dan Elbert'"
> >       <[email-masked]>, "[email-masked]'" <[email-masked]>
> > cc:    (bcc: R Ezhirpavai/HSS)
> >
> > Subject:  RE: Use of ServiceChange from MGC to MG
> >
> >
> >
> >
> > One thing I think is incorrect here is the "Subtracted from any active
> > contexts" part.  I believe we defined the protocol so that this NEVER
> > happens
> > as a side-effect.  The termination may actually be out of
> > service, but both
> > the MG and the MGC have it in a context if it was when the
> > termination was
> > taken out of service.
> >
> > It is always incumbant on the MGC to do the subtract explicitly.
> >
> > The ONLY exception to this is restart of the MG; all contexts
> > are lost.
> >
> > Brian
> >
> > -----Original Message-----
> > From: Tom-PT Taylor [mailto:[email-masked]]
> > Sent: Friday, May 18, 2001 11:32 AM
> > To: 'Dan Elbert'; [email-masked]'
> > Subject: RE: Use of ServiceChange from MGC to MG
> >
> >
> >
> > Hi.
> >
> > > -----Original Message-----
> > > From: Dan Elbert [ mailto:[email-masked]
> > <mailto:[email-masked]> ]
> > > Sent: Friday, May 18, 2001 11:06 AM
> > > To: [email-masked]'
> > > Subject: Use of ServiceChange from MGC to MG
> > >
> > >
> > > Hi
> > >
> > > The Media Gateway Controller may indicate that Termination(s)
> > > shall be taken
> > > out of or returned to service.
> > > 1. What is the meaning of the MGC taking down a termination ?
> > > Does it means
> > > that the termination is substracted from any active context
> > > and all signal
> > > are stopped and no events are detected ?
> >
> > Yes
> >
> > > 2. What methods are used for taking the MG down and up ? I'd
> > > say Graceful
> > > and Restart. Is this OK ?
> >
> > "Taking the MG down" to me means doing a ServiceChange on
> > ROOT at the MG.
> > It's possible the MGC might do that to an MG, but most likely
> > in that case
> > that it would be done under manual control (i.e. the network
> > is set up such
> > that control of MGs is exercised through the MGC).  I don't
> > see this as a
> > typical maintence arrangement.
> >
> > > 3. Is this applicable also to the root termination ? I would
> > > say no because
> > > if the root termination "goes down" then logically the MG may
> > > not be able to
> > > receive any more MGC commands.
> >
> > Upon recovery the MG would follow normal start-up procedures
> > to establish a
> > new control association.
> >
> > >
> > > Thanks,
> > >
> > > Dan Elbert
> > > RADVISION
> > >
> >
> >
> >

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Fri, 18 May 2001 15:17:49 -0400

HI Pavai,
The media flows also will stop when the ServiceChange is received by the MG
to put that termination out-of-service. Hence the question of the Endpoint
being in call is ruled-out. Second if the MGC is generating service change
for the termination that is in Active context, then it has to generate
Subtract also. If it doesn't there is a potential problem with the MGC
implementation.

Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Friday, May 18, 2001 2:46 PM
To: Kevin Boyle
Cc: Rosen, Brian; Tom-PT Taylor; 'Dan Elbert'; [email-masked]'
Subject: Re: Use of ServiceChange from MGC to MG

Hello,
     Consider that due to a discripency the MG still has the "termA" in
context
and the MGC assumes that the termA is in NULL context. In this case the MGC
would send service change with forced and would not send any subtract, but
MG is
still waiting for the call to terminate.

                                         Regards,
                                         R. Ezhirpavai

To:   R Ezhirpavai/HSS@HSS

Why?  What benefit is gained by setting this restriction?  Now, I would
agree
with
the idea that "out of service" also implies "inactive", thereby halting the
information flow on the streams.  However, I don't see any great problem
with
allowing the out of service Modify command to precede the Subtract.  The MG
is
supposed to leave terminations in context until explicitly subtracted, or
the MG
restarts.

Kevin

send
in