Subject: Notifications

From: Winter Johannes <[email-masked]>
Date: Thu, 10 May 2001 14:18:54 +0200

Hi List,

I have a short question about notifications sent from the MG to the MGC: 

The communication between MGC and MG is always realized by the exchange of
Transaction Request messages (sent by the MGC) and Transaction Reply
messages (sent by the MG).  The Transaction messages include the
corresponding Command Requests and Replys. 

Is this the same for notifications sent by the MG to the MGC? 
So, does the MG set up a Transaction request (including a NotifyRequest,
Annex A)  with a Transaction ID and receive a corresponding Transaction
reply (with a NotifyReply, optional an empty SEQUENCE) from the MGC? 

If this is true, should section 7.2.7 not changed to:

...
[TerminationID]
[,ErrorDescriptor]
	Notify (TerminationID,
		ObservedEventsDescriptor,
		[ErrorDescriptor])
...

regards

Johannes Winter
Siemens AG Austria

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 10 May 2001 09:54:06 -0400

Hi All,

When multiple commands are sent from MGC/MG, there can be error in any of
the commands. The return parameter shown in the command APIs (Section 7.2.1
to 7.2.8) doesn't have any error descriptor. I think [,ErrorDescriptor] can
be part of the descriptors listed as return parameters of each command.

Regards
Madhubabu
-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Winter Johannes
Sent: Thursday, May 10, 2001 8:19 AM
To: [email-masked]
Subject: Notifications

Hi List,

...
[TerminationID]
[,ErrorDescriptor]
	Notify (TerminationID,

regards

Johannes Winter
Siemens AG Austria

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 10 May 2001 10:22:31 -0400

I believe that there is a note in the IG that states that Error descriptors can
be returned where appropriate, but are not shown in the sample API.

Kevin

---

From: Christian Groves <[email-masked]>
Date: Fri, 11 May 2001 11:13:29 +1000

Hello, 

As Kevin pointed out. This is covered in the IG 6.33.

Christian