Subject: RE: IP Type of Service

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 8 May 2001 09:23:56 -0400

I don't agree.  The TOS for a particular stream should be set on that
stream, not
on the MG as a whole.  For example, if I have a multimedia MG, I will want
to set
the priority of voice higher than video, and video higher than normal.  If I
implement a
Multilevel Pre-emption and Priority scheme, some calls will have higher
priority than
others.  The TOS/frame priority has to be per stream.
 
Brian

-----Original Message-----
From: Madhu Babu Brahmanapally [mailto:[email-masked]]
Sent: Tuesday, May 08, 2001 9:24 AM
To: 'Rosen, Brian'; 'Tom-PT Taylor'; 'Chuong Nguyen'; [email-masked]
Subject: RE: IP Type of Service

Hi All,
 
The default TOS type should be defined on the ROOT termination for the
default TOS used for all media packets generated from the MG. There should
be a method (might be through some property) of specifying stream level TOS
bits. 
 
I'm interested to work on RSVP. 
 
Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Rosen, Brian
Sent: Tuesday, May 08, 2001 8:10 AM
To: 'Tom-PT Taylor'; 'Chuong Nguyen'; [email-masked]'
Subject: RE: IP Type of Service

TOS should not be ignored at the edge router if the router is configured to
enable DiffServ.  
 
It would be pretty simple to create one package that had the appropriate
controls for
DiffServ and 802.1p.  RSVP needs it's own package because there is
messaging,
and you at least an event or two
 
The former could be an enumeration: QosMarking, that had values None, TOS
and
FramePriority, plus another integer, Value.  That would suffice I think,
although you
could conceivably get more clever with DiffServ.
 
Shall I write something up along those lines?  
 
RSVP takes some more work.  Any volunteers?
 
Brian

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Monday, May 07, 2001 9:15 PM
To: 'Chuong Nguyen'; [email-masked]'
Subject: RE: IP Type of Service

No such package has yet been defined.
 
Various QOS architectures can be imagined.  Each would give rise to its own
package, since the MGC-MG information flow would differ from one
architecture to the next.  One question: unless the MG is itself the edge
router, won't the ToS be ignored when the media packets reach the latter?

-----Original Message-----
From: Chuong Nguyen [mailto:[email-masked]]
Sent: Monday, May 07, 2001 5:14 PM
To: [email-masked]'
Subject: IP Type of Service

All 

In MGCP, MGC can specify IP Type of Service to the MG. 
Do we have an equivalent in Megaco? 

Is there or has anyone defined a package for IP Type of Service? 

Thanks 
Chuong 

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Tue, 8 May 2001 10:01:58 -0400

Hi Brian,
I agree that there should be stream level TOS, I even mentioned that in my
mail. This needs to be sent from the MGC when that particular stream is
established. But if the TOS is having a constant value for every stream, its
an overhead to send it for each stream as and when it is created. The
default TOS defined on ROOT will be taken as the default value for all the
streams unless overwritten by the MGC while stream creation, thus defining
the gateway level TOS. The other alternative of the same is to have a
default value for the TOS defined in the LocalControlDescriptor, which
again defines the default TOS used across the system.  But this will remain
as the provisioned default, whose value cannot be changed by the MGC during
runtime, unless a property is defined on the ROOT.

Regards
Madhubabu
  -----Original Message-----
  To: 'Madhu Babu Brahmanapally'; 'Tom-PT Taylor'; 'Chuong Nguyen';
[email-masked]

  the priority of voice higher than video, and video higher than normal.  If
I implement a

  Brian
    -----Original Message-----
    From: Madhu Babu Brahmanapally [mailto:[email-masked]]
    Sent: Tuesday, May 08, 2001 9:24 AM
    To: 'Rosen, Brian'; 'Tom-PT Taylor'; 'Chuong Nguyen'; [email-masked]
    Subject: RE: IP Type of Service

    Hi All,

    Regards
    Madhubabu
      -----Original Message-----

      TOS should not be ignored at the edge router if the router is
configured to
      enable DiffServ.

      It would be pretty simple to create one package that had the
appropriate controls for
      DiffServ and 802.1p.  RSVP needs it's own package because there is
messaging,
      and you at least an event or two

      The former could be an enumeration: QosMarking, that had values None,
TOS and
      FramePriority, plus another integer, Value.  That would suffice I
think, although you
      could conceivably get more clever with DiffServ.

      Brian
        -----Original Message-----
        From: Tom-PT Taylor [mailto:[email-masked]]
        Sent: Monday, May 07, 2001 9:15 PM
        To: 'Chuong Nguyen'; [email-masked]'
        Subject: RE: IP Type of Service

        Various QOS architectures can be imagined.  Each would give rise to
its own package, since the MGC-MG information flow would differ from one
architecture to the next.  One question: unless the MG is itself the edge
router, won't the ToS be ignored when the media packets reach the latter?
          -----Original Message-----

          All

          Thanks
          Chuong

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Tue, 8 May 2001 10:08:04 -0400

Hi All,
Another suggestion. Why cant the SDP be extended to incorporate a TOS
parameter/attribute so that all the protocols(SIP,Megaco,MGCP) that use SDP
need not define extra properties/parameter for supporting this.

Regards
Madhubabu
  -----Original Message-----

  Brian
    -----Original Message-----
    From: Madhu Babu Brahmanapally [mailto:[email-masked]]
    Sent: Tuesday, May 08, 2001 9:24 AM
    To: 'Rosen, Brian'; 'Tom-PT Taylor'; 'Chuong Nguyen'; [email-masked]
    Subject: RE: IP Type of Service

    Hi All,

    Regards
    Madhubabu
      -----Original Message-----

      Brian

          -----Original Message-----

          All

          Thanks
          Chuong