Subject: RE: IP Type of Service

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 9 May 2001 23:41:22 -0400

However, any changes to SDP have to be done in the IETF, and since QOS
relates to media streams, it really has to be done in SDP as well as
anywhere else the ITU-T and other bodies see fit to put it.

-----Original Message-----
From: Brown, Michael [NC1:GW10:EXCH] 
Sent: Wednesday, May 09, 2001 4:47 PM
To: Petros N. Mouchtaris
Cc: megaco; SG16; Oskar vanDeventer
Subject: RE: IP Type of Service

There are at least four contributions to the upcoming Study Group 11 meeting
(May 14-May 25)related to this topic. If you have ITU TIES access, they are
under Delayed Contributions 207, 212, 214, and 215.
-----Original Message----- 
From: Christian Groves [mailto:[email-masked]] 
Sent: Wednesday, May 09, 2001 1:41 AM 
To: Petros N. Mouchtaris 
Cc: Rosen, Brian; megaco; SG16; Oskar vanDeventer 
Subject: Re: IP Type of Service 

I think that any work on QoS parameters should be aligned with the work 
occuring in ETSI Tiphon, ITU SG16, ITU SG11 etc. There's been a 
considerable amount of effort in trying to come up with common 
parameters for QoS. Any solution should tap into this. 
Cheers, Christian 
"Petros N. Mouchtaris" wrote: 
> 
> Brian, 
> 
> Actually there was a long discussion on this topic last year on the
mailing 
> list i.e. whether MGC should be able to signal an MG which TOS bit to use.

> The whole topic ended up being dropped. Check the archive for e-mails with

> title "MG and DiffServ". 
> 
> By the way, Flemming had volunteered to do some work but I assume it
didn't 
> have high enough priority. 
> 
> Excerpt from e-mail: 
> 
> "Tom-PT Taylor wrote: 
> 
>                     > You are correct that packages should be drawn up
(and/or SDP defined) to 
>                     > allow QOS parameter setting.  Volunteers? 
> 
>                     Sure - I can put a package proposal together. 
> 
>                     -- Flemming 
> 
> Petros 
> 
> "Rosen, Brian" <[email-masked]> on 05/08/2001 03:29:44 PM 
> 
> To:   "'Tom-PT Taylor'" <[email-masked]>, "'Madhu Babu 
>       Brahmanapally'" <[email-masked]>, "Rosen, Brian" 
>       <[email-masked]>, "'Chuong Nguyen'" 
>       <[email-masked]>, megaco <[email-masked]> 
> cc:    (bcc: Petros N. Mouchtaris/Telcordia) 
> Subject:  RE: IP Type of Service 
> 
> I'll look into this.  I agree. 
> 
> Brian 
> 
> -----Original Message----- 
> From: Tom-PT Taylor [mailto:[email-masked]] 
> Sent: Tuesday, May 08, 2001 10:07 AM 
> To: 'Madhu Babu Brahmanapally'; 'Rosen, Brian'; 'Chuong Nguyen'; megaco 
> Subject: RE: IP Type of Service 
> 
> That makes sense. 
> 
> -----Original Message----- 
> From: Madhu Babu Brahmanapally [mailto:[email-masked]] 
> Sent: Tuesday, May 08, 2001 10:08 AM 
> To: 'Rosen, Brian'; Taylor, Tom-PT [NORSE:B881:EXCH]; 'Chuong Nguyen'; 
> megaco 
> Subject: RE: IP Type of Service 
> 
> Hi All, 
> Another suggestion. Why cant the SDP be extended to incorporate a TOS 
> parameter/attribute so that all the protocols(SIP,Megaco,MGCP) that use
SDP 
> need not define extra properties/parameter for supporting this. 
> 
> Regards 
> Madhubabu 
> 
> -----Original Message----- 
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of Rosen, Brian 
> Sent: Tuesday, May 08, 2001 9:24 AM 
> To: 'Madhu Babu Brahmanapally'; 'Tom-PT Taylor'; 'Chuong Nguyen'; 
> [email-masked] 
> Subject: RE: IP Type of Service 
> 
> I don't agree.  The TOS for a particular stream should be set on that 
> stream, not 
> on the MG as a whole.  For example, if I have a multimedia MG, I will want

> to set 
> the priority of voice higher than video, and video higher than normal.  If

> I 
> implement a 
> Multilevel Pre-emption and Priority scheme, some calls will have higher 
> priority than 
> others.  The TOS/frame priority has to be per stream. 
> 
> Brian 
> 
> -----Original Message----- 
> From: Madhu Babu Brahmanapally [mailto:[email-masked]] 
> Sent: Tuesday, May 08, 2001 9:24 AM 
> To: 'Rosen, Brian'; 'Tom-PT Taylor'; 'Chuong Nguyen'; [email-masked] 
> Subject: RE: IP Type of Service 
> 
> Hi All, 
> 
> The default TOS type should be defined on the ROOT termination for the 
> default TOS used for all media packets generated from the MG. There should

> be a method (might be through some property) of specifying stream level
TOS 
> bits. 
> 
> I'm interested to work on RSVP. 
> 
> Regards 
> Madhubabu 
> 
> -----Original Message----- 
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of Rosen, Brian 
> Sent: Tuesday, May 08, 2001 8:10 AM 
> To: 'Tom-PT Taylor'; 'Chuong Nguyen'; [email-masked]' 
> Subject: RE: IP Type of Service 
> 
> TOS should not be ignored at the edge router if the router is configured
to 
> enable DiffServ. 
> 
> It would be pretty simple to create one package that had the appropriate 
> controls for 
> DiffServ and 802.1p.  RSVP needs it's own package because there is 
> messaging, 
> and you at least an event or two 
> 
> The former could be an enumeration: QosMarking, that had values None, TOS 
> and 
> FramePriority, plus another integer, Value.  That would suffice I think, 
> although you 
> could conceivably get more clever with DiffServ. 
> 
> Shall I write something up along those lines? 
> 
> RSVP takes some more work.  Any volunteers? 
> 
> Brian 
> 
> -----Original Message----- 
> From: Tom-PT Taylor [mailto:[email-masked]] 
> Sent: Monday, May 07, 2001 9:15 PM 
> To: 'Chuong Nguyen'; [email-masked]' 
> Subject: RE: IP Type of Service 
> 
> No such package has yet been defined. 
> 
> Various QOS architectures can be imagined.  Each would give rise to its
own 
> package, since the MGC-MG information flow would differ from one 
> architecture to the next.  One question: unless the MG is itself the edge 
> router, won't the ToS be ignored when the media packets reach the latter? 
> 
> -----Original Message----- 
> From: Chuong Nguyen [mailto:[email-masked]] 
> Sent: Monday, May 07, 2001 5:14 PM 
> To: [email-masked]' 
> Subject: IP Type of Service 
> 
> All 
> 
> In MGCP, MGC can specify IP Type of Service to the MG. 
> Do we have an equivalent in Megaco? 
> 
> Is there or has anyone defined a package for IP Type of Service? 
> 
> Thanks 
> Chuong 
> 
> -- 
> 
>   Alcatel USA, Inc             Internet: [email-masked] 
> 
>   1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613 
> 
>   **** The opinions expressed are not those of Alcatel USA, Inc **** 
> 
>   ------------------------------------------------------------------------

>                Name: att1.htm 
>    att1.htm    Type: Hypertext Markup Language (text/html) 
>            Encoding: base64

---

From: Paul Sijben <[email-masked]>
Date: Thu, 10 May 2001 09:22:02 +0200

I believe setting of ToS is very specific for the deployment of the gateway
initiating the call. I would be more in favour of a more generic QoS
description that can be used by the MG to determine which ToS value to set
using its local policies.

I suggested something like this in Pittsburgh but was shot down over the use
of the word "domain" or so and the contents of the request (generic QoS
description in SDP) seems to have been lost.

I'll be happy to try and write something like this up over the next few weeks.

Paul

> Tom-PT Taylor wrote:

-- 
Paul Sijben              Tel:+31 356874774 
Lucent Technologies      Message:+31 848702874			
Forward Looking Work     Fax: +31 208702874
Huizen, The Netherlands  http://voip.nl.lucent.com/~sijben (internal)