Subject: RE: Polls of MGC

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 18 May 2001 08:52:46 -0400

Christian

Everyone agrees that the way the MGC finds out if an MG is down is
to send a message and look for a response.  There are quite
a few messages an MGC could use.  I've suggested an audit.

Everyone also agrees that the way the MG finds out if the MGC is down
is to send a message and get a response.  It would presumably have
some timer that is reset by any message from the MGC.  If the timer
expired, it would send a message (a poll), and look for a reply.

There are two issues:
1. What message do you send?  MGs only send two messages, ServiceChange
and Notify.  The first series of messages on this thread talked about 
using SC as the message.  The issue is how to construct an SC
which does not change the MGCs notion of the MG state (ie behave
as a no-op).  The second set of messages talked about using Notify
as the poll

2. How fast do you poll? The MGC really ought to be able to control 
the frequency of polls, which would depend on how many MGs it was 
controlling.  For this reason, we have been talking about using Notify, 
with an interval parameter, which would be set by the MGC to control 
the polling.  Using SC, even if you could, there is no way for the
MGC to control the polling rate.

If the MGC is down, the MG can do the right thing, which is to contact
an alternate MGC for service.  

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 4:18 AM
> To: [email-masked]
> Subject: Re: Polls of MGC
> 
> 
> G'Day,
> 
> I'd really like to understand the network scenario for adding this
> polling.
> As I see it the MGC can determine that an MG is down. ie. It issues a
> command and gets no response. It can take the appropriate action.
> Likewise the MG can determine when the MGC is down in the same way.
> Except that if the MGC its connected to is down the MG can't do much.
> Remember the MGC is the Master and the MG is the slave.
> 
> I really don't see the benefit of the MG doing periodic 
> polling. It will
> find something is wrong when it tries to signal the MGC.
> 
> Without going to Servicechange methods, reasons etc. What's 
> the benefit?
> 
> Cheers, Christian
> 
>

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Fri, 18 May 2001 09:48:30 -0400

Hi Brian/list,
Even today without the Polling mechanism the MG can follow the MGC failure
procedures defined in Section 11.5. So, what is the additional gain by
sending another message to the MGC and then initiating the failure
procedures.

When this polling needs to be done??
1) When there is no activity between MG and MGC OR
2) When any command generated from MG is not acknowledged by the MGC with
any response?

Regards
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Rosen, Brian
Sent: Friday, May 18, 2001 8:53 AM
To: 'Christian Groves'; [email-masked]
Subject: RE: Polls of MGC

Christian

There are two issues:

Brian