Subject: RE: Notifies on a Termination / IG sect. 6.22

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 7 May 2001 09:11:40 -0400

Christian

Do you have notes about why the recommendation from the chapter?
I don't remember it.  Timestamps do let you order Notifies of course.
but I seem to recall that there is another problem, although I
can't dredge up the actual problem out of my leaky brain.

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Sunday, May 06, 2001 11:46 PM
> To: megaco ietf
> Subject: Notifies on a Termination / IG sect. 6.22
> 
> 
> G'Day all,
> 
> The IG chapter 6.22  removed the recommendation "On a given 
> Termination,
> there should normally be at most one outstanding Notify command at any
> time" from H.248 chapter 9.1. However the chapter states 
> "This document
> does not mandate that the underlying
> transport protocol guarantees the sequencing of transactions 
> sent to an
> entity.  This property tends to maximize the timeliness of 
> actions, but
> it has a few drawbacks. 
> For example:"
> 
> I can't remember the discussion around this. It seems to me that UDP
> will still have a problem with sequencing and this isn't covered
> anywhere in the document. Can someone explain why this isn't 
> a problem?
> 
> Otherwise i'll make an update to Annex D or 9.1 stating the exception
> for UDP transports.
> 
> Cheers, Christian
>

---

From: Christian Groves <[email-masked]>
Date: Tue, 08 May 2001 17:15:19 +1000

G'Day Brian,

I don't have any other notes apart from what's in the description field.
I do see it has desirable behaviour to be able to have multiple notifies
and I agree with the change. The only problem is with UDP and
unsequenced delivery. Ie. you get a digits in a series of notifies. You
definately want them in the right order. Even with timestamps how long
do you have to wait when you receive an event before you can be sure
that you don't get another event with an earlier timestamp? This will
lead to problems.

Cheers, Christian