Subject: how to pass the dialed string from one MG to another through MGC?

From: YouLing Sha <[email-masked]>
Date: Tue, 22 May 2001 10:55:58 -0400

Hi,

If two MGs controlled by the same MGC, MG1 is the Gateway at the subscriber side, and MG2 is the Gateway with the connectivity to the PSTN. If a subscriber tries to make an outgoing call to the PSTN, MG1 forwards the dialed string to the MGC. The MGC, based on the dial plan, knows that this is a PSTN call and route it to MG2. In this case, there's no SS7 involved. 
The question is that how the original dialed string can be passed from the MGC to MG2 ? Is there an appropriate package to support this kind of situation? 
Please advice. Thanks.

Regards,
YouLing Sha
CyberPath Inc.
(732) 463-7700 ext. 304
[email-masked]

---

From: "Michael Brown" <[email-masked]>
Date: Tue, 22 May 2001 11:50:20 -0400

The package(s) currently proposed are in :

Basic CAS packages

http://ietf.org/internet-drafts/draft-manyfolks-megaco-caspackage-00.txt

MF Tone Generation/Detection

http://ietf.org/internet-drafts/draft-bothwell-megaco-mftonepkgs-00.txt

These packages should be going to List Last Call soon. Comments are welcome.

Michael Brown

-----Original Message-----
From: YouLing Sha [mailto:[email-masked]]
Sent: Tuesday, May 22, 2001 10:56 AM
To: [email-masked]'
Cc: Youling Sha (E-mail)
Subject: how to pass the dialed string from one MG to another through
MGC?

Hi,

If two MGs controlled by the same MGC, MG1 is the Gateway at the subscriber
side, and MG2 is the Gateway with the connectivity to the PSTN. If a
subscriber tries to make an outgoing call to the PSTN, MG1 forwards the
dialed string to the MGC. The MGC, based on the dial plan, knows that this
is a PSTN call and route it to MG2. In this case, there's no SS7 involved. 
The question is that how the original dialed string can be passed from the
MGC to MG2 ? Is there an appropriate package to support this kind of
situation? 
Please advice. Thanks.

Regards,
YouLing Sha
CyberPath Inc.
(732) 463-7700 ext. 304
[email-masked]

---

From: YouLing Sha <[email-masked]>
Date: Tue, 22 May 2001 13:58:56 -0400

Hi Michael,

If using 'bcas', am I doing the right thing here? Some places I put "??" there. What should be the right IDs to use?
Thanks.

MG1 detects the digits dialed. A notify command is generated from MG1 to MGC. 
MG1 to MGC:
MEGACO/1 [11.22.33.44]: 12345
   Transaction = 2001 {
      Context = - {
          Notify = TermA {ObservedEvents =1111 {
            20010522T111111111:dd/ce {ds="5551212", Meth=??}}}
      }
   }

How the MGC passes the dialed string "5551212" to MG2 using the bcas or mfg package? Where the MG2 is the gateway to the PSTN.

MGC to MG2
MEGACO/1 [44.33.22.11]: 54321
   Transaction = 1002 {
      Context = - {
        Modify = Trunk1/line1 {
             Signals = { bcas/sz }
             Events = 1111 {bcas/?? Embed { signals {bcas/addr { ds = 5551212} }, Events=1112 { bcas/clear, bcas/ans}}} 
                                                     }
                     }

Regards,
YouLing Sha

-----Original Message-----
From:	Michael Brown [SMTP:[email-masked]]
Sent:	Tuesday, May 22, 2001 11:50 AM
To:	[email-masked]'
Subject:	RE: how to pass the dialed string from one MG to another through MGC?

Basic CAS packages

Michael Brown

-----Original Message-----
From: YouLing Sha [mailto:[email-masked]]
Sent: Tuesday, May 22, 2001 10:56 AM
To: [email-masked]'
Cc: Youling Sha (E-mail)
Subject: how to pass the dialed string from one MG to another through
MGC?

Hi,

Regards,
YouLing Sha
CyberPath Inc.
(732) 463-7700 ext. 304
[email-masked]

 << File: ATT00002.htm >>

---

From: "Michael Brown" <[email-masked]>
Date: Tue, 22 May 2001 14:57:54 -0400

Comments inline
-----Original Message-----
From: YouLing Sha [mailto:[email-masked]]
Sent: Tuesday, May 22, 2001 1:59 PM
To: Brown, Michael [NC1:GW10:EXCH]; [email-masked]'
Subject: RE: how to pass the dialed string from one MG to another
through MGC?

Hi Michael,

If using 'bcas', am I doing the right thing here? Some places I put "??"
there. What should be the right IDs to use?
Thanks.

MG1 detects the digits dialed. A notify command is generated from MG1 to
MGC. 
MG1 to MGC:
MEGACO/1 [11.22.33.44]: 12345
   Transaction = 2001 {
      Context = - {
          Notify = TermA {ObservedEvents =1111 {
            20010522T111111111:dd/ce {ds="5551212", Meth=??}}}
      }
   }

[MB] The method parameter would be as specified in the DTMF detection
package. It indicates the reason which triggered the completion of the digit
map that was specified in the request to collect digits. So the value used
depends on how your digit map is set up and there really isn't a "right"
answer.

How the MGC passes the dialed string "5551212" to MG2 using the bcas or mfg
package? Where the MG2 is the gateway to the PSTN.

MGC to MG2
MEGACO/1 [44.33.22.11]: 54321
   Transaction = 1002 {
      Context = - {
        Modify = Trunk1/line1 {
             Signals = { bcas/sz }
             Events = 1111 {bcas/?? Embed { signals {bcas/addr { ds =
5551212} }, Events=1112 { bcas/clear, bcas/ans}}} 
                                                     }
                     }

[MB] The event you would be looking for where you've put the "??" is Start
Dial (sd). This is the trigger to begin outpulsing. The text in the draft
describes the behavior associated with this event for different trunk types.

Regards,
YouLing Sha

-----Original Message-----
From:	Michael Brown [SMTP:[email-masked]]
Sent:	Tuesday, May 22, 2001 11:50 AM
To:	[email-masked]'
Subject:	RE: how to pass the dialed string from one MG to another
through MGC?

Basic CAS packages

Michael Brown

-----Original Message-----
From: YouLing Sha [mailto:[email-masked]]
Sent: Tuesday, May 22, 2001 10:56 AM
To: [email-masked]'
Cc: Youling Sha (E-mail)
Subject: how to pass the dialed string from one MG to another through
MGC?

Hi,

Regards,
YouLing Sha
CyberPath Inc.
(732) 463-7700 ext. 304
[email-masked]

 << File: ATT00002.htm >>