Subject: RE: TCP + RFC1006

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 4 May 2001 11:51:07 -0400

Worked for me:
ftp://ftp.isi.edu/in-notes/rfc1006.txt
<ftp://ftp.isi.edu/in-notes/rfc1006.txt> 
 
also known as STD35
 
RFCs are never "removed", they are all around.  They get superceded.
 
The part we care about (TPKT) wasn't touched by 2126.
 
You DON'T get an automatic upgrade when your reference changes.
 
Brian

-----Original Message-----
From: Chuong Nguyen [mailto:[email-masked]]
Sent: Friday, May 04, 2001 11:23 AM
To: [email-masked]'
Subject: TCP + RFC1006

Tom 

Can I get an understanding of how RFC works? 

Megaco RFC3015 specifies the use of TCP+RFC1006. 

If I go to the IETF.org and try to get RFC1006, it is not available any
more. 
(I was able to get it last year.) 

The IETF index page shows the following: 

1006 ISO transport services on top of the TCP: Version 3. M.T. Rose, 
     D.E. Cass. May-01-1987. (Format: TXT=31935 bytes) (Obsoletes RFC0983) 
     (Updated by RFC2126) (Also STD0035) (Status: STANDARD) 

2126 ISO Transport Service on top of TCP (ITOT). Y. Pouffary, A. 
     Young. March 1997. (Format: TXT=51032 bytes) (Updates RFC1006) 
     (Status: PROPOSED STANDARD) 

Now the questions are: 

1) Did RFC2126 supersed RFC1006? 
2) If yes, how does it affect Megaco RFC3015? 

3) Does Megaco implementation automatically go w/the latest RFC that
replaces RFC1006? 
  
4) If Megaco implementation has to stick w/RFC1006, how does one get a copy
of it? 

5) Is there an IETF understanding if an RFC (say RFCa) references another
RFC (say RFCb), 
     implementator of RFCa will have to always upgrade their implementation
if RFCb was 
     obsoleted by a newer RFC? 

     I see ITU H.248 also reference IETF RFC.  So what does ITU
understanding of how 
     obsolete RFC affect ITU implementation? 

Personally I think we ought to remove TCP from Megaco. 

Thanks 
Chuong 

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Chuong Nguyen <[email-masked]>
Date: Fri, 04 May 2001 11:10:13 -0500

Thanks

I couldn't get it from your link.
But I was able to get via STD35 via an internal archive.

I was trying to get it from http://www.ietf.org/rfc.html which just give
me a blank page.

"Rosen, Brian" wrote:

> Worked for me:ftp://ftp.isi.edu/in-notes/rfc1006.txtalso known as
> STD35RFCs are never "removed", they are all around.  They get
> superceded.The part we care about (TPKT) wasn't touched by 2126.You
> DON'T get an automatic upgrade when your reference changes.Brian
>
>      If I go to the IETF.org and try to get RFC1006, it is not
>      available any more.
>      3) Does Megaco implementation automatically go w/the latest
>      RFC that replaces RFC1006?
>
>      4) If Megaco implementation has to stick w/RFC1006, how does
>      one get a copy of it?
>
>      5) Is there an IETF understanding if an RFC (say RFCa)
>      references another RFC (say RFCb),
>           implementator of RFCa will have to always upgrade their
>      implementation if RFCb was
>           I see ITU H.248 also reference IETF RFC.  So what does
>      ITU understanding of how