Subject: RE: ABNF Question: digit maps embedded in events

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 30 May 2001 17:27:14 -0400

Yes, and I suspect I'm the guilty typist.

> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Wednesday, May 30, 2001 3:44 PM
> To: 'Steven Weisz'; Megaco Mailing List (E-mail)
> Cc: Taylor, Tom-PT [NORSE:B881:EXCH]
> Subject: RE: ABNF Question: digit maps embedded in events
> 
> 
> I usually defer to Tom on any digitMap questions. 
> I can't tell you how many hours I (and several others
> including Abdullah Rayhan) spent pouring over the
> ABNF to ferret out such problems.
> 
> Yes, I agree, it should be 
> digitMap={...
> and not
> digitMap{...
> 
> I think this qualifies as a typo and deserves an IG entry.
> Tom, do you agree?
> 
> Brian
> 
> > -----Original Message-----
> > From: Steven Weisz [mailto:[email-masked]]
> > Sent: Wednesday, May 30, 2001 3:08 PM
> > To: Megaco Mailing List (E-mail)
> > Subject: ABNF Question: digit maps embedded in events
> > 
> > 
> > Hi List,
> > 
> > I asked this question a few weeks ago and still have not 
> > found an answer.
> > Does anyone have an opinion?
> > 
> > It is a quick question concerning a digit map embedded in a 
> > requested event.
> > Specifically, if you look at the ABNF the embedded digit map 
> > is defined as
> > 
> > eventDM = DigitMapToken (( EQUAL digitMapName ) / (LBRKT 
> digitMapValue
> > RBRKT))
> > 
> > and a digit map descriptor is defined as:
> > 
> > digitMapDescriptor = DigitMapToken EQUAL (( LBRKT 
> > digitMapValue RBRKT ) / 
> > 		         ( digitMapName [LBRKT digitMapValue RBRKT] ))
> > 
> > It obvious that they are very similar, as I believe was 
> > intended but there
> > is one thing that is bothering me in eventDM. That is it 
> > seems to me that
> > the EQUAL should be right after DigitMapToken as is the case in
> > digitMapDescriptor. So we would instead have:
> > 
> > eventDM = DigitMapToken EQUAL (( digitMapName ) / (LBRKT 
> digitMapValue
> > RBRKT))
> > 
> > Does this make sense?
> > 
> > Thanks,
> > 
> > Steve
> > 
>

---

From: Christian Groves <[email-masked]>
Date: Fri, 01 Jun 2001 04:15:58 +1000

Just in time. I'll add it to the implementors' guide.

Christian