Subject: From whence they came?

From: "Paul Long" <[email-masked]>
Date: Thu, 10 May 2001 13:23:43 -0500

Item 6.85 got me thinking about the following passages in the spec.

7.2.8: "...replies and pending indications must be sent to the address from
which the corresponding requests originated."
9: "...responses ... must always be sent back to the address which was the
source of the corresponding request."

Are they referring to the source address in the IP header and source port in
the UDP and TCP headers, or are they referring to the mID in the message
header?

Paul Long
ipDialog, Inc.

---

From: "Kaul, Bharat" <[email-masked]>
Date: Thu, 10 May 2001 18:23:05 -0700

Yes Paul, that is the intention. 
 
Besides MID can syntactically be defined as domain name also. In that case,
you still need to send it to the source transport address. Conceptually, in
such a case MID again becomes a logical identifier only. So, there shouldn't
be any issues.
 
- Bharat

-----Original Message-----
From: Paul Long [mailto:[email-masked]]
Sent: Thursday, May 10, 2001 5:28 PM
To: megaco
Subject: RE: From whence they came?

Tom,
 
Hmmm... Taking a closer look at the spec, I see that the mID in the message
prolog is just used by the receiver as a logical identifier for the sender
and that, in particular, the IP-address forms just have syntactical
value--they are never used as IP addresses, per se. It looks like these mIDs
are only used when paired up with transaction identifiers to uniquely
identify transactions, scoped to the receiver. Is this correct? Scary
thought, but, as long as the sender takes care by using an IP address that
another sender will not use, it appears that the IP address in a message mID
doesn't have to have any relationship to the actual network interface of the
sender. Am I right?
 
Paul Long
ipDialog, Inc.

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Thursday, May 10, 2001 5:56 PM
To: 'Paul Long'; megaco
Subject: RE: From whence they came?

It's partly the difference between a physical and a logical unit in a
load-sharing architecture where the separate units have different addresses.
There's also the possibility that a single physical unit has multiple
network interfaces.  Using the address as received in the header is
important because it gives a beter chnace of the response getting back
through any intervening firewall.

-----Original Message-----
From: Paul Long [mailto:[email-masked]]
Sent: Thursday, May 10, 2001 5:40 PM
To: megaco
Subject: RE: From whence they came?

Tom,
 
Okay, then, and this may be a stupid question, but what is the difference
between "the peer in an association" and the source of a message? IOW, under
what circumstances might they be different? The reason I was confused was
probably because in H.323 the source of a message is of absolutely no
consequence.
 
Paul Long
ipDialog, Inc.

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 11 May 2001 08:43:14 -0400

Basically, yes.  It's probably better to use a domain name rather than an
address as an mID tag.

-----Original Message-----
From: Paul Long [mailto:[email-masked]]
Sent: Thursday, May 10, 2001 8:28 PM
To: megaco
Subject: RE: From whence they came?

Tom,

Paul Long
ipDialog, Inc.

-----Original Message-----
From: Paul Long [mailto:[email-masked]]
Sent: Thursday, May 10, 2001 5:40 PM
To: megaco
Subject: RE: From whence they came?

Tom,

Paul Long
ipDialog, Inc.

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 11 May 2001 12:26:37 -0400

It's a matter of historical development of our understanding of mID,
perhaps, but your example is correct.  There should be no comparison of
actual source with mID.  Your example could have arisen because of a
behind-the-scenes (invisible to the MGC) hot switchover from one MG to its
mate, or because a cluster of physical devices are sharing the load of one
control session, or because the host has multiple network interfaces or ...

> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, May 11, 2001 10:43 AM
> To: Taylor, Tom-PT [NORSE:B881:EXCH]
> Cc: 'Paul Long'; megaco
> Hello Tom,
>      Does that mean that from a host with IP1 as the IP 
> address, a Megaco
> message
> can be sent to the peer with an MId as IP2? Should the 
> receiving entity not
> compare the
> source IP address and the IP address in the message header 
> (assuming the mID is
> represented by IP address)?
> 
> Regards,
> Vivek
> 
> 
> 
> 
> 
> "Tom-PT Taylor" <[email-masked]> on 05/11/2001 06:13:14 PM
> 
> To:   "'Paul Long'" <[email-masked]>, megaco <[email-masked]>
> cc:    (bcc: Vivek Bansal/HSS)
>