Subject: RE: Polls of MGC

From: Dan Elbert <[email-masked]>
Date: Fri, 18 May 2001 10:25:01 -0500

The difference with MGCP is that in MGCP when the MGC comes up it know how
to contact the MGs ( they listen in a default or configured port) , but in
Megaco the MGC only knows the MG port after the MG connects to it. If the
MGC goes down normally this information can be saved, but if it fails and
this information is lost, in some situations there is no way for the MG and
MGC to connect to each other again.

Dan

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Friday, May 18, 2001 11:11 AM
To: Christian Groves
Cc: [email-masked]
Subject: Re: Polls of MGC

Christian Groves wrote:
>
> G'Day,
>
> I'd really like to understand the network scenario for adding this
> polling.
> As I see it the MGC can determine that an MG is down. ie. It issues a
> command and gets no response. It can take the appropriate action.
> Likewise the MG can determine when the MGC is down in the same way.
> Except that if the MGC its connected to is down the MG can't do much.
> Remember the MGC is the Master and the MG is the slave.

MGCP/NCS has a failover scheme involving multiple DNS entries.  Basically
if the MG can't reach the MGC after X tries, it checks the DNS entry for
another IP address and tries it.  (Actually it's fairly complicated with
attempt counts and timers, etc., but that's the idea.)

Any failover method needs to consider security.  It's not very good
if the MG accepts messages that say "I'm your MGC now" from anyone.

> I really don't see the benefit of the MG doing periodic polling. It will
> find something is wrong when it tries to signal the MGC.

I don't see the benefit either.  It'll find out when it tries to
communicate something. Before then, it didn't need to know. 
The MGC might come back online before the MG needs it. 

Picture 5000 MGs polling an MGC.  That's a lot of traffic. 
If the MGC is down for 5 minutes, 5000 MGs detect it and
switch over *somehow* to the backup MGC, then need to be
switched back to the original.  That's a lot of traffic too.
If you let the MGs handle the problem as needed, maybe only
a handful would have needed to.

> Without going to Servicechange methods, reasons etc. What's the benefit?
>
> Cheers, Christian

---

From: Troy Cauble <[email-masked]>
Date: Fri, 18 May 2001 12:01:45 -0400

Then that's the problem:)
Have the MGs use a default or configured port also.
Seriously, why not?

Polling is BAD.

-troy

(BTW, I wasn't really proposing that we use the MGCP/NCS
 DNS based mechanism.  I was just responding to Christian's
 comment that the "MG can't do much" when it detects failure.
 A quick peek at section 9 shows me the H.248 mechanism:
 "The MGC is provisioned with a name or address of a primary and
 zero or more secondary MGCs".)