Subject: RE: Use of CHOOSE as a TerminationID

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 17 May 2001 10:22:14 -0400

Because WILDCARD may get you multiple terminationIDs, and thus
result in inadvertent behavior, while CHOOSE gets you one.

If you have terminationIds xyx/1, xyz/2 and xyz3, then
Add=T*
results in xyx/1, xyz/2 and xyz3 all being added to the context.
Add=T$
results in one of xyx/1, xyz/2 and xyz3 (choice is up to the MG) 
being added.

Brian

> -----Original Message-----
> From: Preeti Sharma [mailto:[email-masked]]
> Sent: Thursday, May 17, 2001 9:32 AM
> To: Tom-PT Taylor
> Cc: 'Preeti Sharma'; [email-masked]
> Subject: Re: Use of CHOOSE as a TerminationID
> 
> 
> Why would I use CHOOSE embedded in a partial name, wouldn't I use
> WILDCARD instead ?
>  Also I can use CHOOSE only for an ADD command.
>  So would I say :
>   1.   Add = xyz/* {
>     or
>  2.    Add =  xyz/$ {
> 
>  if say I want to choose a circuit from a trunk group "xyz".
>  If the answer is 1. then WILDCARD works  like " choose from the
> existing pool".
>  CHOOSE would work more like "Create a new one".
> 
>  And since ephemeral terminations are the only ones being created and
> destroyed CHOOSE
>  should be used for them only.
> 
>  Preeti.
> 
> Tom-PT Taylor wrote:
> 
> >
> >
> > Certainly when the text you quote was drafted, people had ephemerals
> > in mind.  In theory if Local and Remote described a TDM circuit, the
> > MG would probably have to choose from amongst the TDM circuits it
> > supported, but this doesn't seem too useful unless all the 
> circuits go
> > to the same destination.
> >
> > A CHOOSE is embedded in a partial name, of course, is a 
> reasonable way
> > to ask the MG to choose from a specific set of terminations, whether
> > that set be provisioned or ephemeral.
> >
> > > -----Original Message-----
> > > From: Preeti Sharma [mailto:[email-masked]]
> > > Sent: Wednesday, May 16, 2001 4:30 PM
> > > To: [email-masked]
> > > Subject: Use of CHOOSE as a TerminationID
> > >
> > >
> > > Hi All,
> > >     I have a very basic question:
> > >
> > >     If CHOOSE ($)  is recieved as a TerminationID by the MG,
> > > can the MG
> > > then assume that it
> > >     refers to an ephemeral termination. I tend to believe so
> > > as the text
> > > in Section 7.2.1 says :
> > >
> > >    "The Terminationis either created or taken from the null
> > > Context. For
> > > an existing Termination,
> > >      the TerminationID would be specific. For a Termination that
> > does
> > > not yet exist, the TerminationID
> > >      is specified as CHOOSE in the command."
> > >
> > >      Also CHOOSE can be used for a TerminationID only in the ADD
> > > command.
> > >
> > >      Hence I infer that CHOOSE implies an ephemeral Termination.
> > >
> > >      Can someone please clarify this.
> > >
> > >  Regards.
> > >  Preeti.
> > >
> > >
> > >
> > >
>

---

From: Preeti Sharma <[email-masked]>
Date: Thu, 17 May 2001 09:47:25 -0400

Thanks, didn't think of that...
 Preeti.