Subject: RE: [Megaco] Megaco CAS

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 8 Jan 2002 10:06:40 -0500

Good point.  What did the authors have in mind?  If the type of outpulsing
is provsioned, the text should say so.

-----Original Message-----
From: PSK Chakravarthi [mailto:[email-masked]]
Sent: Tuesday, January 08, 2002 9:30 AM
To: [email-masked]
Subject: [Megaco] Megaco CAS

Hi List,
As per draft-manyfolks-megaco-caspackage-01.txt Section
6.4.5 
    Signal Name: Address 
    SignalID: addr (0x0005) 
    Description: Applies the address signals in the form of either 
          DTMF, dial-pulse or MF-tones on the trunk. The actual 
          frequency, cadence, duration and amplitude values for the 
          multi-frequency tones that convey the address information are 
          provisioned in the MG. 
    Signal Type: (BR) Brief 
    Duration: Provisioned 
    Additional Parameters:  
        Parameter Name: Digit String 
        ParameterID: ds (0x0001) 
        Description: The digit string that needs to be sent as address 
          signals. 
        Type: string of digits. 
        Possible Values: a sequence of the characters "0" through "9" 
          as well as "A" through "H" ("A" through "H" used for MF 
          signalling - refer to the symbols defined for the digit map 
          in the MF Tone Detection package). 
        Parameter Name: Address Delay 
        ParameterID: ad (0x0002) 
        Description: Specifies a timed delay that is applied prior to 
          signalling the address. The address delay is optional. If the 
          address delay parameter is not provided, the MG uses the 
          provisioned value by default.  
        Type: integer 
        Possible Values: 0 and up in milliseconds 

Question:
MGC can instruct gateway to out pulse digits either in DTMF or MF or dial
pulse.
How MGC can tell gateway about the mode of the digits is MF or DTMF or Dial
Pulse?

Thanks in advance.

Chak

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Tue, 8 Jan 2002 11:02:49 -0500

HI Tom,Chak,all,
The description of the "addr" it indicates that the "The actual frequency,
cadence, duration and amplitude values for the           multi-frequency
tones" is "provisioned" at the MG. Wont that be sufficient to say that the
type of outpulsing is "provisioned".

Regards
Madhubabu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Tom-PT Taylor
Sent: Tuesday, January 08, 2002 10:07 AM
To: 'PSK Chakravarthi'; [email-masked]
Subject: RE: [Megaco] Megaco CAS

-----Original Message-----
From: PSK Chakravarthi [mailto:[email-masked]]
Sent: Tuesday, January 08, 2002 9:30 AM
To: [email-masked]
Subject: [Megaco] Megaco CAS

Hi List,

Question:

Thanks in advance.

Chak

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Tue, 8 Jan 2002 11:02:49 -0500

HI Tom,Chak,all,

Regards
Madhubabu

-----Original Message-----
From: PSK Chakravarthi [mailto:[email-masked]]
Sent: Tuesday, January 08, 2002 9:30 AM
To: [email-masked]
Subject: [Megaco] Megaco CAS

Hi List,

Question:

Thanks in advance.

Chak

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Wed, 9 Jan 2002 12:41:30 +0530

Madhubabu,

I think it will not be sufficient.  If MG wishes to support outpulsing in more
than one mode (DTMF/MF), then how to instruct MG.  This is required for the MGs
which support both FGD MF and FGD DTMF.

regards,
Chak

----- Original Message -----
From: "Madhu Babu Brahmanapally" <[email-masked]>
To: "'Tom-PT Taylor'" <[email-masked]>; "'PSK Chakravarthi'"
<[email-masked]>; <[email-masked]>
Sent: Tuesday, January 08, 2002 9:32 PM
Subject: RE: [Megaco] Megaco CAS

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Wed, 9 Jan 2002 12:41:30 +0530

Madhubabu,

regards,
Chak

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Wed, 9 Jan 2002 12:56:05 +0530

Tom,

I think we can have another parameter as given below:

        Parameter Name: Address Type 
        ParameterID: at (0x0003) 
        Description: Specifies Type of address digits.  
        Type: enumeration 
        Possible Values: 
        "DTMF"  (0x0000)  DTMF Digits
        "MF"       (0x0001)  MF Digits
        "DP"        (0x0002)  Dial Pulse Digits

Thanks
Chak

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Wed, 9 Jan 2002 12:56:05 +0530

Tom,

Thanks
Chak

---

From: Al Varney <[email-masked]>
Date: Wed, 09 Jan 2002 10:48:09 -0600

Chak,
    At first, I thought the Description of "provisioned" frequency, 
cadence, etc. could be clarified as a per-trunk attribute (not per MG, as 
some might read it).  That is, MF trunks always used MF signaling, etc.  On 
further reflection, this is insufficient to emulate some forms of older 
signaling used in the USA.  For example, some circuits signal using Dial 
Pulse in a first stage, followed by MF in the second.  Also, it might be 
useful to force DTMF signaling over an MF trunk which is already connected 
on a call (although that goes beyond the function typically associated with 
the acronym "CAS").

    So I'm agreeing with you, with a small suggestion below:

>         "DP"        (0x0002)  Dial Pulse Digits

    It might be less confusing if the word "Type" was not used in the Name 
or Description, since it is part of the meta-language of MEGACO 
packages.  I used "Coding" below, but another word might be better.  Also, 
you offered no default text in the Description -- did you really want 
"Address Type" to be included in every use of "addr"?

      Alternative Name/ID/Description for consideration:
  Parameter Name: Address Coding
  ParameterID: ac (0x0003)
  Description: Specifies the coding of Digit String parameter
           in tones or DC pulses.  Address Coding is optional;
           if not provided, the MG uses the value provisioned
           as an attribute of the circuit associated with the
           signal.

    Would it be useful to mention an error case if Address Coding is not 
present and the "circuit" has no 'ac' value provisioned?  (For example, 
could CAS package be used to signal over an ephemeral?)

    On second thought, having 'ac' optional might be a mistake.  It forces 
the MGC to "know" the coding for every circuit.  (The 
provisioned-per-MG-circuit option allows the MGC to be ignorant of the 
coding.)  I think it unlikely that the MGC could be ignorant of MF vs. DTMF 
vs. DP for a given circuit, and provisioning in 2 places (MG and MGC) is 
just asking for an error.

Al Varney - [email-masked]

---

From: Al Varney <[email-masked]>
Date: Wed, 09 Jan 2002 10:48:09 -0600

Chak,

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Thu, 10 Jan 2002 13:47:25 +0530

Al Varney,

I think optional is OK.  Default coding type for a termination should be
provisioned in MG.  If MGC want to override, it can use optional parameter "ac".

Thanks
Chak

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Thu, 10 Jan 2002 13:47:25 +0530

Al Varney,

Thanks
Chak

---

From: "Anand N.S." <[email-masked]>
Date: Thu, 10 Jan 2002 15:11:21 +0530

Hi All ,
     How to implement
           a) Embedded Request
           b) Piggy Backing
           c) Softswitch failure
  in MGCP. RFC 2075

  Any one who has implemented these can share their ideas.
  Thanks.

---

From: "Anand N.S." <[email-masked]>
Date: Thu, 10 Jan 2002 15:11:21 +0530

Hi All ,
     How to implement
           a) Embedded Request
           b) Piggy Backing
           c) Softswitch failure
  in MGCP. RFC 2075

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Mon, 21 Jan 2002 14:16:31 +0100

Hi all,

When a MOVE command is received on a termination.
Do we have to accumulate the statistics or we can reset them
for the new context?

Thanks in advance
Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Mon, 21 Jan 2002 14:16:31 +0100

Hi all,

Thanks in advance
Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL