Subject: RE: [Megaco] Topology Descriptor

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 2 Jan 2002 14:28:01 -0500

It should be returned, because the original descriptor had wildcards and the
returned value should show how they were resolved.

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Saturday, December 29, 2001 6:43 AM
To: [email-masked]
Subject: [Megaco] Topology Descriptor

Hi,

When a context is created using two add comands and a topology descriptor,
will
the topology descriptor be returned in the reply.

regards
gokul

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 3 Jan 2002 09:17:14 -0500

I see your point: either the topology descriptor is returned, even if no
wildcards were present, or the topology doesn't get acknowledged.  There is
no half-way measure possible within the syntax such as just returning the
topology token.  So the answer is that if the MGC specifies a topology
descriptor, the MG returns a topology descriptor in the response.

Remembering that topology descriptors are cumulative over successive actions
affecting the same context, another question that comes to mind is whether
the MG returns the topology descriptor supplied by the MGC with wildcarded
terminationIDs resolved, or whether instead it should return a complete
description of the current topology of the context.  Bear in mind that in
H.248v2 we will be able to specify topology per stream, unless someone
strongly objects at the last moment.

Opinions?

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 6:57 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]
Subject: RE: [Megaco] Topology Descriptor

Hi,

will the same results be observed even if the topology descriptor is fully
specified.

gokul

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Saturday, December 29, 2001 6:43 AM
To: [email-masked]
Subject: [Megaco] Topology Descriptor

Hi,

regards
gokul

---

From: "Nurit Shenhar" <[email-masked]>
Date: Thu, 3 Jan 2002 17:04:16 +0200

Hi

If we want to know what the topology is, we can audit it. Example:

MEGACO/1 [10.2.1.228]:2944
Transaction = 1237 {
       Context = 1 {
          Topology{*, gws0c2, oneway},ca{tp}
}}

Even so, I don't think that the ALL wildcard should be resolved, as it
may cause a huge reply. Only the CHOOSE wildcard should be resolved in
the answer.

Nurit

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 4:17 PM
To: [email-masked]'; [email-masked]
Subject: RE: [Megaco] Topology Descriptor

I see your point: either the topology descriptor is returned, even if no
wildcards were present, or the topology doesn't get acknowledged.  There
is
no half-way measure possible within the syntax such as just returning
the
topology token.  So the answer is that if the MGC specifies a topology
descriptor, the MG returns a topology descriptor in the response.

Remembering that topology descriptors are cumulative over successive
actions
affecting the same context, another question that comes to mind is
whether
the MG returns the topology descriptor supplied by the MGC with
wildcarded
terminationIDs resolved, or whether instead it should return a complete
description of the current topology of the context.  Bear in mind that
in
H.248v2 we will be able to specify topology per stream, unless someone
strongly objects at the last moment.

Opinions?

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 6:57 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]
Subject: RE: [Megaco] Topology Descriptor

Hi,

will the same results be observed even if the topology descriptor is
fully
specified.

gokul

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Thursday, 3 January 2002 12:58 AM
To: [email-masked]'; [email-masked]
Subject: RE: [Megaco] Topology Descriptor

It should be returned, because the original descriptor had wildcards and
the
returned value should show how they were resolved.

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Saturday, December 29, 2001 6:43 AM
To: [email-masked]
Subject: [Megaco] Topology Descriptor

Hi,

When a context is created using two add comands and a topology
descriptor,
will
the topology descriptor be returned in the reply.

regards
gokul

---

From: "Nurit Shenhar" <[email-masked]>
Date: Thu, 3 Jan 2002 17:04:16 +0200

Hi

Nurit

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 4:17 PM
To: [email-masked]'; [email-masked]
Subject: RE: [Megaco] Topology Descriptor

Opinions?

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 6:57 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]
Subject: RE: [Megaco] Topology Descriptor

Hi,

gokul

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Saturday, December 29, 2001 6:43 AM
To: [email-masked]
Subject: [Megaco] Topology Descriptor

Hi,

regards
gokul

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 3 Jan 2002 09:17:14 -0500

Opinions?

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 6:57 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]
Subject: RE: [Megaco] Topology Descriptor

Hi,

gokul

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Saturday, December 29, 2001 6:43 AM
To: [email-masked]
Subject: [Megaco] Topology Descriptor

Hi,

regards
gokul

---

From: "Nurit Shenhar" <[email-masked]>
Date: Thu, 3 Jan 2002 17:26:09 +0200

Hi

Nurit

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 4:17 PM
To: [email-masked]'; [email-masked]
Subject: RE: [Megaco] Topology Descriptor

Opinions?

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 6:57 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]
Subject: RE: [Megaco] Topology Descriptor

Hi,

gokul

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Saturday, December 29, 2001 6:43 AM
To: [email-masked]
Subject: [Megaco] Topology Descriptor

Hi,

regards
gokul

---

From: "Nurit Shenhar" <[email-masked]>
Date: Thu, 3 Jan 2002 17:26:09 +0200

Hi

Nurit

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 4:17 PM
To: [email-masked]'; [email-masked]
Subject: RE: [Megaco] Topology Descriptor

Opinions?

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 6:57 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]
Subject: RE: [Megaco] Topology Descriptor

Hi,

gokul

-----Original Message-----
From: gokulc [mailto:[email-masked]]
Sent: Saturday, December 29, 2001 6:43 AM
To: [email-masked]
Subject: [Megaco] Topology Descriptor

Hi,

regards
gokul