Subject: RE: [Megaco] NotifyCompletion Question

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 17 Jan 2002 10:17:57 -0500

The error is in the Annex E text.  This material was a fairly late addition
(part of the enormous amount of work we did in the Feb'00 meeting in
Geneva), and an inconsistency crept in.  You are the first to spot it.  The
text should read:

Signal Completion 
      EventID: sc (0x0002) 
      Indicates termination of one or more signals for which the 
      notifyCompletion parameter was set to enable reporting of a
      completion event.  For further procedural description, see 
      sections 7.1.11, 7.1.17, and 7.2.7. 

-----Original Message-----
From: Carl Rutter [mailto:[email-masked]]
Sent: Thursday, January 17, 2002 10:04 AM
To: [email-masked]'
Subject: [Megaco] NotifyCompletion Question

For V1 the possible values of NotifyCompletion reason are:

notifyCompletion     = NotifyCompletionToken EQUAL (LBRKT 
          notificationReason *(COMMA notificationReason) RBRKT) 
    
   notificationReason   = ( TimeOutToken / InterruptByEventToken 
               / InterruptByNewSignalsDescrToken 
               / OtherReasonToken ) 

So when an MGC wants the MG to notify a completion of a Signal
the MGC would specify:

NC = TimeOut,IntByEvent etc (or whatever of the 4 they want to be notified
for)

Is this correct???

The reason I ask is later in the RFC there is this:
Signal Completion 
      EventID: sc (0x0002) 
      Indicates termination of one or more signals for which the 
      notifyCompletion parameter was set to "ON".  For further 
      procedural description, see sections 7.1.11, 7.1.17, and 7.2.7. 

Which seems to indicate that the NC really should be an ON or OFF value and
the 4 notificationReasons are really just return values.

Thanks,
Carl

Carl Rutter
Telica, Inc.
Building G, Suite 100
734 Forest Street
Marlboro, MA 01752
Email [email-masked]
Voice 508-480-0909 x8178
Fax 508-480-0922 
www.telica.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 17 Jan 2002 10:35:57 -0500

I agree.  I will add to IG.

--

------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 17 Jan 2002 10:35:57 -0500

--

---

From: "Chuong N. Nguyen" <[email-masked]>
Date: Sun, 20 Jan 2002 14:11:27 -0600

I am not sure we have addressed Carl's concern here.

What he is saying makes everything clear to me now and it makes better sense
than what is already
defined in the ABNF.
I didn't really understood how this NotifyCompletion really worked and I think
I had raised some questions on it before.

   signalRequest        = signalName [ LBRKT sigParameter
                          *(COMMA sigParameter) RBRKT ]

   sigParameter    = sigStream / sigSignalType / sigDuration / sigOther
                   / notifyCompletion / KeepActiveToken

   notifyCompletion     = NotifyCompletionToken EQUAL (LBRKT
                   notificationReason *(COMMA notificationReason) RBRKT

Because of the above ABNF, my intepretation is that MGC specifies to MG that it
needs to report
signal completion based on the reason(s) that MGC has specified.
If the signal completion was not due to one of the reasons specified by the MGC
then
don't report the signal completion.
When the signal completed and the reason matches one specified by MGC, MG
reports
the signal completion w/the reason.

Tom, I am not sure if your change to Event sc makes any difference here to the
actual implementation.

I think Carl is suggesting the following (correct me if I am wrong)

   notifyCompletion    = "ON/OFF"

This is a change in syntax which will break current implementation.

I am using notifyCompletionRequest because we still have to keep
notifyCompletion for
the reporting of the signal completion in the EventDescriptor.

Since this is a BIG syntax change, it can't be done in V1 or an update to IG.
For V2, it will still be a big problem due to backward compatibilty requirement.

Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: "Chuong N. Nguyen" <[email-masked]>
Date: Sun, 20 Jan 2002 14:11:27 -0600

Chuong