Subject: [Megaco] comment in v2

From: [email-masked]
Date: Fri, 11 Jan 2002 10:53:43 +0200

Hi Marcello,

On page 112 of Megaco v2 draft, auditItem has been extended to include
indAudterminationAudit which is defined as 

indAudterminationAudit   = indAudauditReturnParameter  
                                *(COMMA indAudauditReturnParameter)

now AuditDescriptor has been defined as containing multiple AuditItem
separated by COMMA, so when there are multiple AuditItem all separated
by COMMA , which further contain multiple indAudauditReturnParameter
each again separated by COMMA , then how can one tell which AuditItem
did the indAudauditReturnParameter belong to ? I think that from
functionality point of view it would NOT matter because at the end all
the AuditItems would be applied to one TerminationId regardless of which
AuditItem they were a part of.

But for clarity why not define indAudterminationAudit as
indAudterminationAudit   = LBRKT indAudauditReturnParameter  
                                *(COMMA indAudauditReturnParameter)
RBRKT

regards,
sunesh

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Marcello Pantaleo (EED)" <[email-masked]>
Date: Fri, 11 Jan 2002 18:05:41 +0100

Hi Sunesh,

I think that the current definition works fine. In my opinion it doesn't really matter which AuditItem the indAudauditReturnParameter belongs to.

For instance if you want to audit:
1)current value of events associated with the termination
2)Item2= signal Sig1,signal Sig2
 
you will have something like:

AV=TerminationId{AT{E,SG{PackageName/Sig1},SG{PackageName/Sig2}}}

Any other opinions?

Regards,
Marcello

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, January 11, 2002 9:54 AM
To: [email-masked]
Cc: [email-masked]
Subject: comment in v2

Hi Marcello,

regards,
sunesh

---

From: "Marcello Pantaleo (EED)" <[email-masked]>
Date: Fri, 11 Jan 2002 18:05:41 +0100

Hi Sunesh,

 

Any other opinions?

Regards,
Marcello

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, January 11, 2002 9:54 AM
To: [email-masked]
Cc: [email-masked]
Subject: comment in v2

Hi Marcello,

regards,
sunesh

---

From: [email-masked]
Date: Mon, 14 Jan 2002 10:10:26 +0200

Hi Marcello,

I agree that from functionality point of view this would absolutely
work, but from design point of view it looked a little odd. But I can
live with it. 
Also on page 113 :
indAudsignalList = SignalListToken EQUAL signalListId LBRKT  
                      indAudsignalListParm RBRKT

but indAudsignalListParm is not defined in the draft.

Regards,
sunesh

		-----Original Message-----
		From:	ext Marcello Pantaleo (EED)
[mailto:[email-masked]]
		Sent:	11. January 2002 19:06
		To:	Kumra Sunesh (NET/Helsinki)
		Cc:	[email-masked]
		Subject:	RE: comment in v2

		Hi Sunesh,

		I think that the current definition works fine. In my
opinion it doesn't really matter which AuditItem the
indAudauditReturnParameter belongs to.

		For instance if you want to audit:
		1)current value of events associated with the
termination
		2)Item2= signal Sig1,signal Sig2

		Any other opinions?

		Regards,
		Marcello

		-----Original Message-----
		From: [email-masked]
[mailto:[email-masked]]
		Sent: Friday, January 11, 2002 9:54 AM
		To: [email-masked]
		Cc: [email-masked]
		Subject: comment in v2

		Hi Marcello,

		On page 112 of Megaco v2 draft, auditItem has been
extended to include
		indAudterminationAudit which is defined as 

		indAudterminationAudit   = indAudauditReturnParameter  
		                                *(COMMA
indAudauditReturnParameter)

		now AuditDescriptor has been defined as containing
multiple AuditItem
		separated by COMMA, so when there are multiple AuditItem
all separated
		by COMMA , which further contain multiple
indAudauditReturnParameter
		each again separated by COMMA , then how can one tell
which AuditItem
		did the indAudauditReturnParameter belong to ? I think
that from
		functionality point of view it would NOT matter because
at the end all
		the AuditItems would be applied to one TerminationId
regardless of which
		AuditItem they were a part of.

		But for clarity why not define indAudterminationAudit as
		indAudterminationAudit   = LBRKT
indAudauditReturnParameter  
		                                *(COMMA
indAudauditReturnParameter)
		RBRKT

		regards,
		sunesh

---

From: [email-masked]
Date: Mon, 14 Jan 2002 10:10:26 +0200

Hi Marcello,

Regards,
sunesh

		-----Original Message-----

		Hi Sunesh,

		 

		Any other opinions?

		Regards,
		Marcello

		-----Original Message-----

		Hi Marcello,

		regards,
		sunesh

---

From: "Marcello Pantaleo (EED)" <[email-masked]>
Date: Mon, 14 Jan 2002 12:53:14 +0100

Hi Sunesh,

yes, you're right. indAudsignalListParm is not defined.

I think it should be:

indAudsignalListParm       = indAudsignalRequest

I'll fix it.

Regards,
Marcello
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, January 14, 2002 9:10 AM
To: [email-masked]
Cc: [email-masked]
Subject: RE: comment in v2

Hi Marcello,

Regards,
sunesh

		-----Original Message-----

		Hi Sunesh,

		 

		Any other opinions?

		Regards,
		Marcello

		-----Original Message-----

		Hi Marcello,

		regards,
		sunesh

---

From: "Marcello Pantaleo (EED)" <[email-masked]>
Date: Mon, 14 Jan 2002 12:53:14 +0100

Hi Sunesh,

I think it should be:

I'll fix it.

Regards,
Marcello
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, January 14, 2002 9:10 AM
To: [email-masked]
Cc: [email-masked]
Subject: RE: comment in v2

Hi Marcello,

Regards,
sunesh

		-----Original Message-----

		Hi Sunesh,

		 

		Any other opinions?

		Regards,
		Marcello

		-----Original Message-----

		Hi Marcello,

		regards,
		sunesh