Subject: RE: [Megaco] How does H.323 work with MGCP or Megaco?

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 2 Jan 2002 16:30:35 -0500

I should have waited to read your second message before reply.

To be absolutely clear: the MGC can use H.225.0 call signalling and H.245
between itself and a remote H.323 entity (which might be another MGC).  It
maps between that and Megaco's Local and Remote descriptors.

I have some sample call flows showing this sort of operation.  If I get a
moment, I'll purge them of proprietary content and post them to the Megaco
supplementary web site.

-----Original Message-----
From: Patrick Lam [mailto:[email-masked]]
Sent: Wednesday, January 02, 2002 4:21 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]; [email-masked]
Subject: Re: [Megaco] How does H.323 work with MGCP or Megaco?

Thanks a lot.

Can the MGC not use H.245 though?

What I am thinking is to setup the call using H.225, and use MGCP or Megaco
to
setup the RTP channel with the MG?  Does this make sense at all?  Is this
possible?

Thanks very much again,

Patrick.

Tom-PT Taylor wrote:

> Assuming the MG supports either MGCP or Megaco with text encoding, you end
> up having to do a translation between H.245 and SDP.  In the capability
> exchange phase, the MGC may use capabilities gleaned via an
AuditCapability
> request.  OpenLogicalChannel has to be mapped into the appropriate Local
> and/or Remote descriptor content.
>
> -----Original Message-----
> From: Patrick Lam [mailto:[email-masked]]
> Sent: Wednesday, January 02, 2002 3:03 PM
> To: [email-masked]; [email-masked]
> Subject: [Megaco] How does H.323 work with MGCP or Megaco?
>
> Hi:
>
> This might be a stupid question for most of you here, but I couldn't
> figured that out yet .....
>
> When I have an H.323 terminal calling to another, say Netmeeting, the
> H.245 procedures (OLC) set up the RTP channels between the 2 terminals.
>
> However, when H.323 is used in a MGC, the MGC employs MGCP or Megaco to
> setup the RTP channels in the MGs.  Is H.245 used in this case?  If so,
> how can I make the MGC know whether it needs to setup the RTP channel
> for the MG or the terminal?
>
> What is the difference, in terms of H.225 and H.245 procedures, when
> MGCP (or Megaco) is used and when it's not used?
>
> Thanks very much in advance,
>
> Patrick.
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Patrick Lam" <[email-masked]>
Date: Wed, 02 Jan 2002 13:45:39 -0800

I see ....

Thanks to all who answered this question in such a quick manner.

I really appreciate it.

Patrick.

---

From: "Patrick Lam" <[email-masked]>
Date: Wed, 02 Jan 2002 13:45:39 -0800

I see ....

I really appreciate it.

Patrick.

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Wed, 2 Jan 2002 16:45:34 -0500

HI Pat,
You can also refer to the Megaco call flow draft which has a scenario
explaining the MGC communication with H.323 endpoint.
http://www.ietf.org/internet-drafts/draft-madhu-megaco-callflows-00.txt
Hope this helps.

Regards
Madhubabu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Tom-PT Taylor
Sent: Wednesday, January 02, 2002 4:31 PM
To: 'Patrick Lam'
Cc: [email-masked]; [email-masked]
Subject: RE: [Megaco] How does H.323 work with MGCP or Megaco?

-----Original Message-----
From: Patrick Lam [mailto:[email-masked]]
Sent: Wednesday, January 02, 2002 4:21 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]; [email-masked]
Subject: Re: [Megaco] How does H.323 work with MGCP or Megaco?

Thanks a lot.

Thanks very much again,

Patrick.

AuditCapability

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Wed, 2 Jan 2002 16:45:34 -0500

HI Pat,

Regards
Madhubabu

-----Original Message-----
From: Patrick Lam [mailto:[email-masked]]
Sent: Wednesday, January 02, 2002 4:21 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]; [email-masked]
Subject: Re: [Megaco] How does H.323 work with MGCP or Megaco?

Thanks a lot.

Thanks very much again,

Patrick.

AuditCapability