Subject: RE: [Megaco] Doubt on package extension

From: "Blatherwick, Peter" <[email-masked]>
Date: Thu, 31 Jan 2002 10:49:04 -0500

Just to confirm Tom's interpretation is correct, and answer Usha's question.  

Since the parameter is not defined in the base package, must use the extended package to address it.  Also, since in this case the base class (tonegen) has no function of its own, just defines signals but no parameters, it is dubious to me an implementation should even expose it -- just expose the extended packages.  It is not "illegal" to expose the base package in cases such as this, just useless and confusing.  

I believe the IG text on this was made quite clear, hence v2 should now be also.  Have to admit, I have not specifically checked...

-- Peter Blatherwick

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: January 30, 2002 09:59
To: [email-masked]'; megaco
Subject: RE: [Megaco] Doubt on package extension

This doesn't feel right to me, and the cases are not exactly the same.  Here
we have a parameter value which is unknown in the base package.  Even though
toneGen is known there, the parameter value is not.  In my view this means
you have to address that value through the extension which defined it (or
extensions of that extension).

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, January 30, 2002 9:35 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; megaco
Subject: Re: [Megaco] Doubt on package extension

Is option A invalid for the reason that tonegen package is designed only for
extension,or does the rule apply to any base package ?
 
    Acc to  12.4 of AVD_2128  
---- For example, if Package A defines event e1, and Package B extends
Package A, then B/e1 is an event for a termination implementing Package B.
By definition, the MG MUST also implement the base Package, but it optional
to publish the base package as an allowed interface. If it does publish A,
then A would be reported on the Package Descriptor in AuditValue as well as
B, and event A/e1 would be available on a termination. If the MG does not
publish A, then only B/e1 would be available 
----
 
Going by the above , option A  is allowed if tonegen package is published . 
 
TIA,
usha
----- Original Message ----- 
From: Taylor, Tom-PT [CAR:B800:EXCH] 
To: 'Usha Iyer' ; [email-masked] 
Sent: Wednesday, January 30, 2002 7:37 PM
Subject: RE: [Megaco] Doubt on package extension

Assuming DTMFgen defines d0 as both a signal and a toneId, and similarly for
cw in callProgToneGen, then either B or C is valid.

-----Original Message-----
From: Usha Iyer [mailto:[email-masked]]
Sent: Wednesday, January 30, 2002 3:01 AM
To: [email-masked]
Subject: [Megaco] Doubt on package extension

Hi ,
 
DTMF Gen and Call ProgressToneGen pkg both extend tone gen package .  
So for a termination that supports ToneGen, DTMFGen and Call ProgToneGen Pkg
, suppose i want to play d0 follwed by call  waiting tone , which of the
foll apply . 
 
A - tonegen/playtone(toneid list= d0,cw ) 
B -dtmfgen/playtone(toneid list= d0 )  followed by
callprogtonegen/playtone(toneid list= cw )
C -dtmfgen/d0 followed by callprogtonegen/cw 

Reg
Usha

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Usha Iyer" <[email-masked]>
Date: Thu, 31 Jan 2002 22:34:37 +0530

Hi Peter/All,

    The IGAdditions doc does say that the ToneGen and ToneDet packages are designed for extension and not for direct control... however i was unable to locate the text that addresses my query .
I should have mentioned it but what i quoted was just an example. I'd just like to know whether it is illegal (not whether it is confusing) for the base package (if published) to refer to parameter values defined in the packages that extend it and not just for the specific example that i quoted 
( Acc. to Troy's mail , all the options that i quoted are allowed & you also say  that it is not illegal. )

TIA,
usha
   
  ----- Original Message ----- 
  From: Blatherwick, Peter 
  To: [email-masked]' ; megaco 
  Cc: 'Tom-PT Taylor' 
  Sent: Thursday, January 31, 2002 9:19 PM
  Subject: RE: [Megaco] Doubt on package extension

  -- Peter Blatherwick

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]
  Sent: Wednesday, January 30, 2002 9:35 AM
  To: Taylor, Tom-PT [CAR:B800:EXCH]; megaco
  Subject: Re: [Megaco] Doubt on package extension

      Acc to  12.4 of AVD_2128  

  TIA,
  usha

  -----Original Message-----
  From: Usha Iyer [mailto:[email-masked]]
  Sent: Wednesday, January 30, 2002 3:01 AM
  To: [email-masked]
  Subject: [Megaco] Doubt on package extension

  Hi ,

  Reg
  Usha

---

From: "Usha Iyer" <[email-masked]>
Date: Thu, 31 Jan 2002 22:34:37 +0530

Hi Peter/All,

TIA,
usha
   
  ----- Original Message ----- 
  From: Blatherwick, Peter 
  To: [email-masked]' ; megaco 
  Cc: 'Tom-PT Taylor' 
  Sent: Thursday, January 31, 2002 9:19 PM
  Subject: RE: [Megaco] Doubt on package extension

  -- Peter Blatherwick

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]
  Sent: Wednesday, January 30, 2002 9:35 AM
  To: Taylor, Tom-PT [CAR:B800:EXCH]; megaco
  Subject: Re: [Megaco] Doubt on package extension

      Acc to  12.4 of AVD_2128  

  TIA,
  usha

  -----Original Message-----
  From: Usha Iyer [mailto:[email-masked]]
  Sent: Wednesday, January 30, 2002 3:01 AM
  To: [email-masked]
  Subject: [Megaco] Doubt on package extension

  Hi ,

  Reg
  Usha