Subject: [Megaco] DOUBT ABUOT ACK

From: "sree gk" <[email-masked]>
Date: 18 Jan 2002 06:36:29 -0000

hi

   Every transaction request should be responded with ACK/REP/PEND. But in the example given in RFC, 
places where ACK is expected also reply is sent. Why is it happened here so -  or is that the correct sequence .. ?

sree 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 22 Jan 2002 13:19:37 -0500

ACK is used only when you have unreliable transport such as UDP, and is
needed to assure delivery of replies.  REP, of course, assures both that the
request has been delivered (a function that can also be performed by
reliable transport) and that the application has recognized and processed
it.  PEND can also be interpreted as functioning both at the transport and
the application level. 

-----Original Message-----
From: sree gk [mailto:[email-masked]]
Sent: Friday, January 18, 2002 1:36 AM
To: [email-masked]
Subject: [Megaco] DOUBT ABUOT ACK

hi

   Every transaction request should be responded with ACK/REP/PEND. But in
the example given in RFC, 
places where ACK is expected also reply is sent. Why is it happened here so
-  or is that the correct sequence .. ?

sree

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 22 Jan 2002 13:19:37 -0500

-----Original Message-----
From: sree gk [mailto:[email-masked]]
Sent: Friday, January 18, 2002 1:36 AM
To: [email-masked]
Subject: [Megaco] DOUBT ABUOT ACK

hi

sree