Subject: [Megaco] QRY about the failed command

From: "vidya g" <[email-masked]>
Date: 30 Jan 2002 09:37:23 -0000

Hi all

  In RFC, page number 61 it says that

 "  At the first failing Command in a Transaction, processing of the remaining Commands in that Transaction stops."

  This statement is some what confusing. What I understand is even if a non optional 
command fails in an action, the action will be cancelled and the next action will be taken 
for processing and the commands in that action will be processed.. is that right .. ?

vdy

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 31 Jan 2002 20:37:16 +0200

I have a question related to this.  Consider the following requirements:

1.	Commands within a Transaction are executed sequentially. (8).
2.	The descriptors SHALL be processed in the order in which they appear
(7.2).  Exception (7.1.14.1): It is permissible for a digit map completion
event within an Events Descriptor to refer by name to a DigitMap which is
defined by a DigitMap Descriptor within the same command, regardless of the
transmitted order of the respective descriptors.
3.	When the TerminationId of a  command is wildcarded, the effect shall
be as if the command was repeated with each of the TerminationIds matched.
(7.1.1).
4.	The order of attempts when multiple TerminationIDs match is not
specified. (7.2.1).

Now, suppose I have a wildcarded command with multiple descriptors.  Rules 1
and 3 seem to imply that I must process all descriptors for the first
termination before I process any descriptors for the second termination.  On
the other hand, rules 2 and 4 seem to allow bulk handling of a single
descriptor for all terminations simultaneously, before handling the next
descriptor in the same bulk fashion.  This facilitates efficient storage if,
for example, a digit map or requested event is specified for a wildcarded
termination.

Is either interpretation permitted?  The previous discussion in this thread
suggests that it is, because if an error occurs, the command should still be
completed for each matching termination, and it could be in either case.

Raphael Tryster

	-----Original Message-----
	From:	Terry L Anderson [SMTP:[email-masked]]
	Sent:	Thursday, 31 January, 2002 4:45 PM
	To:	Christian Groves
	Cc:	vidya g; [email-masked]
	Subject:	Re: [Megaco] QRY about the failed command

	You are right.  I (and Vidya G) should have read a little further.
I agree, no change is needed.

	Christian Groves wrote:

	> G'Day Terry,
	>
	> The behaviour already is mentioned in 8.0 the paragraph after "At
the
	> first failing Command...". States: "Commands may be marked as
"Optional"
	> which can override this behaviour -  if a command marked as
Optional
	> results in an error, subsequent commands in the Transaction will
be
	> executed.  If a command fails, the MG shall as far as possible
restore
	> the state that existed prior to the attempted execution of the
command
	> before continuing with command processing."
	>
	> Regards, Christian
	>
	> Terry L Anderson wrote:
	> >
	> > The statement (in 8.0) IS misleading but your understanding is
also incorrect.
	> >
	> > 8.2.2 (including changes from IG 6.36) make it clear that the
first non-optional command that fails ends processing of
	> > the entire Transaction (not just the action).
	> >
	> > Perhaps the exception indicated in 8.2.2 should also be
mentioned in 8.0.
	> >
	> > Do folks think this sentence should be corrected in IG?
	> >
	> > vidya g wrote:
	> >
	> > > Hi all
	> > >
	> > >  "  At the first failing Command in a Transaction, processing
of the remaining Commands in that Transaction stops."

	--

	------------------------------------------------------------
	Terry L Anderson              mailto:[email-masked]
	Tel:908.582.7013   Fax:908.582.6729
	Lucent Technologies/INS/Voice Over IP Access Networks
	Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
	http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

	*** eSafe scanned this email for malicious content ***
	*** IMPORTANT: Do not open attachments from unrecognized senders
*** << File: Card for Terry L Anderson >>

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 31 Jan 2002 20:37:16 +0200

Raphael Tryster

	-----Original Message-----
	From:	Terry L Anderson [SMTP:[email-masked]]
	Sent:	Thursday, 31 January, 2002 4:45 PM
	To:	Christian Groves
	Cc:	vidya g; [email-masked]
	Subject:	Re: [Megaco] QRY about the failed command

the
"Optional"
Optional
be
restore
command
also incorrect.
mentioned in 8.0.

	--

---

From: "Kevin Boyle"<[email-masked]>
Date: Thu, 31 Jan 2002 14:27:36 -0500

You should process the full command on each termination is turn, just as if
the terminations had been expressed individually in their own command.
Requirement 4 (by the numbering below) indicates that it is up to the MG to
figure which order the terms go in, if more than one matches the wildcard.
 
Kevin

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, January 31, 2002 1:37 PM
To: Terry L Anderson; Christian Groves
Cc: vidya g; [email-masked]
Subject: RE: [Megaco] QRY about the failed command

Raphael Tryster 

	BM__MailData-----Original Message----- 

	Christian Groves wrote: 

	> G'Day Terry, 
> 
> The behaviour already is mentioned in 8.0 the paragraph after "At the 
> first failing Command...". States: "Commands may be marked as "Optional" 
> which can override this behaviour -  if a command marked as Optional 
> results in an error, subsequent commands in the Transaction will be 
> executed.  If a command fails, the MG shall as far as possible restore 
> the state that existed prior to the attempted execution of the command 
> > The statement (in 8.0) IS misleading but your understanding is also
incorrect. 
> > 
> > 8.2.2 (including changes from IG 6.36) make it clear that the first
non-optional command that fails ends processing of

> > Perhaps the exception indicated in 8.2.2 should also be mentioned in
8.0. 
> > >  "  At the first failing Command in a Transaction, processing of the
remaining Commands in that Transaction stops."

> > > for processing and the commands in that action will be processed.. is
that right .. ? 
<https://www1.ietf.org/mailman/listinfo/megaco>  

	-- 

	------------------------------------------------------------ 
Terry L Anderson              mailto:[email-masked] <mailto:[email-masked]>

Tel:908.582.7013   Fax:908.582.6729 
Lucent Technologies/INS/Voice Over IP Access Networks 
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974 
http://its.lucent.com/~tla <http://its.lucent.com/~tla>  (Lucent internal)
http://www.gti.net/tla <http://www.gti.net/tla>  

	*** eSafe scanned this email for malicious content *** 
*** IMPORTANT: Do not open attachments from unrecognized senders  *** <<
File: Card for Terry L Anderson >>

---

From: "Kevin Boyle"<[email-masked]>
Date: Thu, 31 Jan 2002 14:27:36 -0500

Kevin

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, January 31, 2002 1:37 PM
To: Terry L Anderson; Christian Groves
Cc: vidya g; [email-masked]
Subject: RE: [Megaco] QRY about the failed command

Raphael Tryster 

incorrect. 

8.0. 

	--

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 31 Jan 2002 21:42:39 +0200

Hello Kevin,

Thanks for your quick reply.  What I gathered from the requirement I listed
as 4 is that the ordering of a wildcard is undefined.  Therefore, if an MG
is permitted to process the entire command for termination2 before the
entire command for termination 1, or the reverse, it should be OK to process
the two terminations in parallel, one descriptor at a time.  Thus, using
shorthand C for command and D for descriptor:

C1D1, C1D2, C2D1, C2D2 is OK.  Therefore, C1D1 may come first and C2D2 may
come last.
C2D1, C2D2, C1D1, C1D2 is OK.  Therefore, C2D1 may come before C1D2.

Then it stands to reason that the parallel execution sequence: C1D1, C2D1,
C1D2, C2D2 is also OK, because each bilateral temporal relationship in it
also exists in one of the sequences that we know are permitted.

Can you think of any bad behaviour that would result from following my line
of reasoning?

Raphael Tryster

	-----Original Message-----
	From:	Kevin Boyle [SMTP:[email-masked]]
	Sent:	Thursday, 31 January, 2002 9:28 PM
	To:	Raphael Tryster; Terry L Anderson; Christian Groves
	Cc:	vidya g; [email-masked]
	Subject:	RE: [Megaco] QRY about the failed command

	You should process the full command on each termination is turn,
just as if the terminations had been expressed individually in their own
command.  Requirement 4 (by the numbering below) indicates that it is up to
the MG to figure which order the terms go in, if more than one matches the
wildcard.
	 
	Kevin

		-----Original Message-----
		From: Raphael Tryster [mailto:[email-masked]]
		Sent: Thursday, January 31, 2002 1:37 PM
		To: Terry L Anderson; Christian Groves
		Cc: vidya g; [email-masked]
		Subject: RE: [Megaco] QRY about the failed command

		I have a question related to this.  Consider the following
requirements: 

		Now, suppose I have a wildcarded command with multiple
descriptors.  Rules 1 and 3 seem to imply that I must process all
descriptors for the first termination before I process any descriptors for
the second termination.  On the other hand, rules 2 and 4 seem to allow bulk
handling of a single descriptor for all terminations simultaneously, before
handling the next descriptor in the same bulk fashion.  This facilitates
efficient storage if, for example, a digit map or requested event is
specified for a wildcarded termination.

		Is either interpretation permitted?  The previous discussion
in this thread suggests that it is, because if an error occurs, the command
should still be completed for each matching termination, and it could be in
either case.

		Raphael Tryster 

		-----Original Message----- 
		From:   Terry L Anderson [SMTP:[email-masked]] 
		Sent:   Thursday, 31 January, 2002 4:45 PM 
		To:     Christian Groves 
		Cc:     vidya g; [email-masked] 
		Subject:        Re: [Megaco] QRY about the failed command 

		You are right.  I (and Vidya G) should have read a little
further.  I agree, no change is needed. 

		Christian Groves wrote: 

		> > The statement (in 8.0) IS misleading but your
understanding is also incorrect. 
		> > 
		> > 8.2.2 (including changes from IG 6.36) make it clear
that the first non-optional command that fails ends processing of

mentioned in 8.0. 
		> > >  "  At the first failing Command in a Transaction,
processing of the remaining Commands in that Transaction stops."

		> > > command fails in an action, the action will be
cancelled and the next action will be taken 

		-- 

		Terry L Anderson              mailto:[email-masked]
<mailto:[email-masked]>  
		Tel:908.582.7013   Fax:908.582.6729 
		Lucent Technologies/INS/Voice Over IP Access Networks 
		Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974 
		http://its.lucent.com/~tla <http://its.lucent.com/~tla>
(Lucent internal) http://www.gti.net/tla <http://www.gti.net/tla>  

		*** eSafe scanned this email for malicious content *** 
		*** IMPORTANT: Do not open attachments from unrecognized
senders  *** << File: Card for Terry L Anderson >>

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 31 Jan 2002 21:42:39 +0200

Hello Kevin,

Raphael Tryster

	-----Original Message-----
	From:	Kevin Boyle [SMTP:[email-masked]]
	Sent:	Thursday, 31 January, 2002 9:28 PM
	To:	Raphael Tryster; Terry L Anderson; Christian Groves
	Cc:	vidya g; [email-masked]
	Subject:	RE: [Megaco] QRY about the failed command

	Kevin

		-----Original Message-----
		From: Raphael Tryster [mailto:[email-masked]]
		Sent: Thursday, January 31, 2002 1:37 PM
		To: Terry L Anderson; Christian Groves
		Cc: vidya g; [email-masked]
		Subject: RE: [Megaco] QRY about the failed command

		Raphael Tryster 

		-----Original Message----- 
		From:   Terry L Anderson [SMTP:[email-masked]] 
		Sent:   Thursday, 31 January, 2002 4:45 PM 
		To:     Christian Groves 
		Cc:     vidya g; [email-masked] 
		Subject:        Re: [Megaco] QRY about the failed command 

mentioned in 8.0. 

		--

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 31 Jan 2002 15:21:46 -0500

I see some implementation trade-offs here, but no real protocol issues.

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, January 31, 2002 2:43 PM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] QRY about the failed command

Hello Kevin, 

Raphael Tryster 

Kevin 

	-----Original Message-----
From: Raphael Tryster [ mailto:[email-masked]
<mailto:[email-masked]> ]
Sent: Thursday, January 31, 2002 1:37 PM
To: Terry L Anderson; Christian Groves
Cc: vidya g; [email-masked]
Subject: RE: [Megaco] QRY about the failed command

	Now, suppose I have a wildcarded command with multiple descriptors.
Rules 1 and 3 seem to imply that I must process all descriptors for the
first termination before I process any descriptors for the second
termination.  On the other hand, rules 2 and 4 seem to allow bulk handling
of a single descriptor for all terminations simultaneously, before handling
the next descriptor in the same bulk fashion.  This facilitates efficient
storage if, for example, a digit map or requested event is specified for a
wildcarded termination.

	Is either interpretation permitted?  The previous discussion in this
thread suggests that it is, because if an error occurs, the command should
still be completed for each matching termination, and it could be in either
case.

	Raphael Tryster 

incorrect.

8.0.

	-- 

	------------------------------------------------------------
Terry L Anderson               <mailto:[email-masked]> mailto:[email-masked]
Tel:908.582.7013   Fax:908 Lucent Technologies/INS/Voice Over IP Access
Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
 <http://its.lucent.com/~tla> http://its.lucent.com/~tla (Lucent internal)
<http://www.gti.net/tla> http://www.gti.net/tla

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 31 Jan 2002 15:21:46 -0500

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]]
Sent: Thursday, January 31, 2002 2:43 PM
To: Boyle, Kevin [NCRTP:3Z30:EXCH]
Cc: [email-masked]
Subject: RE: [Megaco] QRY about the failed command

Hello Kevin, 

Raphael Tryster 

Kevin 

	-----Original Message-----

	Raphael Tryster 

incorrect.

8.0.

	--