Subject: RE: [Megaco] Doubt regarding immAckRequired field.

From: [email-masked]
Date: Thu, 3 Jan 2002 20:04:49 +0530

If this is the case, then we need update the same in the v2 draft.

Regards
Vivek

"Tom-PT Taylor" <[email-masked]> on 01/03/2002 01:06:02 AM

To:   Vivek Bansal/HSS@HSS, [email-masked]
cc:

Subject:  RE: [Megaco] Doubt regarding immAckRequired field.

The immAckRequired flag was introduced because without it a protocol glitch
was possible, so what you postulate is not a nice situation.  Anyway, to
answer your question, I would say that retransmission of the final response
(with exponential backoff) is necessary until an acknowledgement is
received.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Sunday, December 30, 2001 8:23 AM
To: [email-masked]
Subject: [Megaco] Doubt regarding immAckRequired field.

Hi

I have a doubt regarding immAckRequired field.

Section D.1.4 says

"An entity that sends a provisional response, SHALL include the
immAckRequired
field in the ensuing final response, indicating that an immediate
confirmation
is expected."

Now what would happen, if the entity receiving the final response with
immAckRequired field, does not send the immediate confirmation? In this case
do
we need to retransmit the response till we get the confirmation?

Please clarify.

Regards
Vivek

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Wed, 09 Jan 2002 13:57:43 +1100

G'Day Vivek,

What exactly do you propose to update in v2?

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Wed, 09 Jan 2002 13:57:43 +1100

G'Day Vivek,

Regards, Christian