Subject: RE: [Megaco] Inter-MGC Communication

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Thu, 3 Jan 2002 13:56:31 -0500

Hi, Kevin:
 
I beg to disagree with you here.
 
The decomposition of the GWs has been done to have other benefits as well. For example, MGCs from one vendor, while MGs from other vendors.
 
What do we expect in those situations? Do the service providers be forced to lock into proprietary solutions/implementations?
 
I understand the problems that MEGACO WG may not be chartered to address those issues. That does not mean we should NOT be worried about those issues. MEGACO WG has done its primary job and it is a very proud achievement (in standardizing the MEGACO protocol). As we move forward, we have to see how the industry can reap the benefits in implementing the large-scale networks in multi-vendor and multi-protocol environment using the MEGACO protocol.
 
Since the MEGACO protocol is standardized, now, we have the luxury to go for the next step: Interoperability in multiprotocol (SIP, H.323, BICC, ISUP) and multi-vendor environment using the MEGACO protocol. Not only that, it is also applicable for all transport networks (PSTN, IP, ATM, FR). I feel that MEGACO is providing a wonderful GLUE to solve these complex problems what could not even be imagined couples of years ago.
 
Best regards,
Radhika R. Roy
[email-masked]

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 1:12 PM
To: Roy, Radhika R, ALCTA; Rosen, Brian; asrar ashraf; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

As Brian stated, the translation is internal to a single entity (in this case, the MGC).  I don't see a problem here, just as I don't see a problem with different MGCs having different internal hardware.  Think "black box".  If the external interfaces are OK (H.248/Megaco on the one hand, and BICC or SIP or whatever on the other), then why worry about the translation?  If the translation is not correct, for whatever reason, then the vendor will surely figure that out and correct it, or their product will not sell!

Kevin 

-----Original Message----- 
From: Roy, Radhika R, ALCTA [ mailto:[email-masked]] 
Sent: Thursday, January 03, 2002 11:40 AM 
To: Rosen, Brian; asrar ashraf; [email-masked] 
Subject: RE: [Megaco] Inter-MGC Communication 

... 

I suspect there is not a single exact 
mapping. 

[RRR] This is the problem. Should people like to live with this? 

Brian 

> -----Original Message----- 
> From: Roy, Radhika R, ALCTA [ mailto:[email-masked]] 
> Sent: Thursday, January 03, 2002 10:27 AM 
> To: Rosen, Brian; asrar ashraf; [email-masked] 
> Subject: RE: [Megaco] Inter-MGC Communication 
> 
> 
> Hi, Brian: 
> 
> You are right. 
> 
> What could have been better if we could have a document, like 
> Madhubabu's call flows, how the mapping is done as Tom Taylor 
> has indicated. For example, the scenarios can be as follows: 
> 
>       MGC  <--- H.323 (H.225.0, H.245) ---> MGC 
>        ^                                                 ^ 
>        |                                                 | 
>      MEGACO/MGCP                              MEGACO/MGCP 
>        |                                                 | 
>        v                                                 v 
>       MG  <---------- RTP ---------------->  MG 
> 
> Now the appropriate mapping needs to be done between H.323 
> (H.225.0, H.245) and MEGACO (or MGCP). This part is missing 
> and no documentation is available. If this is done, people 
> could have interoperable implementations. 
> 
> Similarly, the scenarios can be created for SIP and BICC and, 
> mappings need to be done as follows: 
> 
> SIP/SDP <-> MEGACO (or MGCP) 
> BICC  <-> MEGACO (or MGCP) 
> 
> Best regards, 
> 
> Radhika R. Roy 
> [email-masked] 
> 
> -----Original Message----- 
> From: Rosen, Brian [ mailto:[email-masked]] 
> Sent: Thursday, January 03, 2002 9:25 AM 
> To: 'asrar ashraf'; [email-masked] 
> Subject: RE: [Megaco] Inter-MGC Communication 
> 
> 
> Neither RFC3015 nor Recommendation H.248 say anything about 
> interMGC communication.  It is out of scope of the protocol. 
> You can use anything you would like.  SIP/SIP-T works, but so 
> does BICC or even H.323. 
> 
> Brian 
> 
> > -----Original Message----- 
> > From: asrar ashraf [ mailto:[email-masked]] 
> > Sent: Thursday, January 03, 2002 2:18 AM 
> > To: [email-masked] 
> > Subject: [Megaco] Inter-MGC Communication 
> > 
> > 
> > Can Any one confirm that 
> > Only SIP or SIP-T is used for Inter-MGC Communication. 
> >  What about other options. 
> > Can any one guide If There are any callFlows available for Inte-MGC 
> > communication ... 
> > 
> >   regards 
> >  Asrar Ashraf 
> >  AvazNetworks 
> >  Islamabad, Pakistan 
> > 
> 
> _______________________________________________ 
> Megaco mailing list 
> [email-masked] 
> https://www1.ietf.org/mailman/listinfo/megaco 
> 

_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 08 Jan 2002 13:44:15 +1100

G'Day Roy,

There is some work ongoing in ITU SG11 to define mapping between BICC
1902.x and Q.1950 which is based on H.248.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Tue, 08 Jan 2002 13:44:15 +1100

G'Day Roy,

Regards, Christian