Subject: RE: [Megaco] Megaco Questions

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 16 Jan 2002 13:19:13 -0500

Hi and welcome.  Answers below.

-----Original Message-----
From: Balasubramanian Pitchandi [mailto:[email-masked]]
Sent: Wednesday, January 16, 2002 11:31 AM
To: [email-masked]
Subject: [Megaco] Megaco Questions

Hi All,

I am a newbie to the group.

I have a few questions about implementation of Megaco on the MG side.

1. Is it a mandatory requirement of Megaco for the MG to support "IP
Multicasting"?
[PTT] Megaco doesn't say anything about required media transports.

2. Can the MGs by-pass the MGC to make a direct call to another
endpoint?
[PTT] Not within the Megaco architecture.  Of course, that is a functional
architecture for the purpose of defining a protocol: how you choose to build
a product could be different.

3. Can the MGCs impose restrictions on MGs to support all the packages
that are supported by themselves?
[PTT] Yes.  The MGC can refuse the control association if it sees inadequate
package support from the MG.

4. What is the latest status of the Megaco MIB? I saw the latest draft
(draft-ietf-megaco-mib-02.txt) that was done in May 2001. Is there any
official word on when would it be RFC-ed?
[PTT]  I want to push ahead with it and have the WG finish it within a month
or so -- as soon as we get H.248v2 out the door.

Thanks in advance for your replies.

Regards
Bala
________________________
Bala Pitchandi
UTStarcom Inc.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Shambhu Dayal Rai <[email-masked]>
Date: Thu, 17 Jan 2002 10:17:41 +0530

Hi Tom,

I am not clear on your comment to the third point.

> package support from the MG

I had a impression MGC should support all the packages but MG needs to support only the packages which are of its use. for example a
gateway not dealing with ATM need not support ATM packages. May be, Packages supported for a MG can be provisioned on the MGC, then
MGC may check  the packages supported on the MG.

If its mandatery to support all the packages, Do we make mandatery to send all the packages supported  from MG in the initial
Service Change message, If not How can MGC refuse the control associan at this stage ?

Please clarify.
-Shambhu

-- 
-------------------------------------------------------------------
Shambhu Dayal Rai                              [email-masked] 
Infosys - India SQA Team              91-80-8520362 Ext. : 6561
-------------------------------------------------------------------

---

From: Shambhu Dayal Rai <[email-masked]>
Date: Thu, 17 Jan 2002 10:17:41 +0530

Hi Tom,

Please clarify.
-Shambhu