Subject: Re: [Megaco] Doubt regarding immAckRequired field.

From: [email-masked]
Date: Wed, 9 Jan 2002 14:16:48 +0530

Hi Christian

Regarding the Immediate ACK nothing has been mentioned in the protocol. I had
asked if the entity sending response sends the response with immAckRequired
field, and the entity receiving the response does not send back ACK, then what
should entity sending the response do. To handle this Tom had suggested that the
entity sending rerponse will retransmit the response till it gets the ACK of it.
And this solutions seems fine, otherwise the presence of immAckRequired field in
the message will not make any difference.

This is all that I wanted to be updated in V2.

Regards
Vivek

Christian Groves <[email-masked]> on 01/09/2002 08:27:43 AM

To:   Vivek Bansal/HSS@HSS
cc:   Tom-PT Taylor <[email-masked]>, [email-masked]

Subject:  Re: [Megaco] Doubt regarding immAckRequired field.

G'Day Vivek,

What exactly do you propose to update in v2?

Regards, Christian

[email-masked] wrote:
>
> If this is the case, then we need update the same in the v2 draft.
>
> Regards
> Vivek
>
> "Tom-PT Taylor" <[email-masked]> on 01/03/2002 01:06:02 AM
>
> To:   Vivek Bansal/HSS@HSS, [email-masked]
> cc:
>
> Subject:  RE: [Megaco] Doubt regarding immAckRequired field.
>
> The immAckRequired flag was introduced because without it a protocol glitch
> was possible, so what you postulate is not a nice situation.  Anyway, to
> answer your question, I would say that retransmission of the final response
> (with exponential backoff) is necessary until an acknowledgement is
> received.
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Sunday, December 30, 2001 8:23 AM
> To: [email-masked]
> Subject: [Megaco] Doubt regarding immAckRequired field.
>
> Hi
>
> I have a doubt regarding immAckRequired field.
>
> Section D.1.4 says
>
> "An entity that sends a provisional response, SHALL include the
> immAckRequired
> field in the ensuing final response, indicating that an immediate
> confirmation
> is expected."
>
> Now what would happen, if the entity receiving the final response with
> immAckRequired field, does not send the immediate confirmation? In this case
> do
> we need to retransmit the response till we get the confirmation?
>
> Please clarify.
>
> Regards
> Vivek
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 10 Jan 2002 11:03:42 +1100

G'Day Vivek,

I understood that its not mentioned what I was asking for was a wording
proposal to D.1.4 or whereever it is relevant to assist the IG and v2
editors.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Thu, 10 Jan 2002 11:03:42 +1100

G'Day Vivek,

Regards, Christian