Subject: RE: [Megaco] Doubt on package extension

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 30 Jan 2002 09:58:54 -0500

This doesn't feel right to me, and the cases are not exactly the same.  Here
we have a parameter value which is unknown in the base package.  Even though
toneGen is known there, the parameter value is not.  In my view this means
you have to address that value through the extension which defined it (or
extensions of that extension).

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, January 30, 2002 9:35 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; megaco
Subject: Re: [Megaco] Doubt on package extension

Is option A invalid for the reason that tonegen package is designed only for
extension,or does the rule apply to any base package ?
 
    Acc to  12.4 of AVD_2128  
---- For example, if Package A defines event e1, and Package B extends
Package A, then B/e1 is an event for a termination implementing Package B.
By definition, the MG MUST also implement the base Package, but it optional
to publish the base package as an allowed interface. If it does publish A,
then A would be reported on the Package Descriptor in AuditValue as well as
B, and event A/e1 would be available on a termination. If the MG does not
publish A, then only B/e1 would be available 
----
 
Going by the above , option A  is allowed if tonegen package is published . 
 
TIA,
usha
----- Original Message ----- 
From: Taylor, Tom-PT [CAR:B800:EXCH] 
To: 'Usha Iyer' ; [email-masked] 
Sent: Wednesday, January 30, 2002 7:37 PM
Subject: RE: [Megaco] Doubt on package extension

Assuming DTMFgen defines d0 as both a signal and a toneId, and similarly for
cw in callProgToneGen, then either B or C is valid.

-----Original Message-----
From: Usha Iyer [mailto:[email-masked]]
Sent: Wednesday, January 30, 2002 3:01 AM
To: [email-masked]
Subject: [Megaco] Doubt on package extension

Hi ,
 
DTMF Gen and Call ProgressToneGen pkg both extend tone gen package .  
So for a termination that supports ToneGen, DTMFGen and Call ProgToneGen Pkg
, suppose i want to play d0 follwed by call  waiting tone , which of the
foll apply . 
 
A - tonegen/playtone(toneid list= d0,cw ) 
B -dtmfgen/playtone(toneid list= d0 )  followed by
callprogtonegen/playtone(toneid list= cw )
C -dtmfgen/d0 followed by callprogtonegen/cw 

Reg
Usha

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Wed, 30 Jan 2002 16:44:57 -0500

We've been around on this subject before.  

Here are some notes I compiled for my own use.  Too bad
I didn't reference the specific mailing list messages
on which they're based.

Perhaps the language used will stimulate someone's memory.

/* NOTES:
 * Given packges A with event a1 and B with event b1 where B extends A:
 *
 *      A/a1, B/b1, & B/a1 are legal.
 *      A/b1 is not.
 *
 * Note that we search DOWN the extension chain from B to verify a1.
 *
 * Packages may also define new parameter VALUES for the packages they extend.
 * So if A/a1 has a parameter ap1, B may define a value bv1 making
 *
 *      A/a1 { ap1=bv1 } legal, and
 *      B/a1 { ap1=bv1 } legal.
 *
 * Note that we search UP the extension chain (tree) to verify v1!
 */

-troy

---

From: Troy Cauble <[email-masked]>
Date: Wed, 30 Jan 2002 16:44:57 -0500

/* NOTES:

-troy