Subject: RE: [Megaco] misleading ABNF comment on stream descriptor?

From: Raphael Tryster <[email-masked]>
Date: Wed, 23 Jan 2002 10:31:58 +0200

The previous posting came out garbled.

	Here is something from the archive which was never answered.  I
think the answer to Steven's question is that section 7.1.4 is right and the
comment in the ABNF is wrong, as the ASN.1 definition allows multiple stream
descriptors per media descriptor.  Will the comment in the ABNF be changed?

	Raphael Tryster 

	From: Steven Weisz <[email-masked]> 
	To: "Megaco Mailing List (E-mail)" <[email-masked]> 
	Subject: Clarification on Media Descriptor needed. 
	Date: Tue, 24 Apr 2001 13:32:09 -0400 
	MIME-Version: 1.0 
	X-Mailer: Internet Mail Service (5.5.2650.21) 
	Content-Type: text/plain; 
	        charset="iso-8859-1" 
	Sender: [email-masked] 
	Precedence: bulk 

	Hi List, 

	I need some clarification regarding the Media Descriptor.
Specifically in 
	section 7.1.4, paragraph 1 the protocol states: 

	  "The Media Descriptor specifies the parameters for all the media 
	   streams.  These parameters are structured into two descriptors, a

	   Termination State Descriptor, which specifies the properties of a

	   termination that are not stream dependent, and one or more Stream

	   Descriptors each of which describes a single media stream." 

	This states that a Media Descriptor has one or more Stream
Descriptors 
	associated with it. However, in the ABNF we have: 

	  "mediaDescriptor = MediaToken LBRKT mediaParm *(COMMA mediaParm) 
	                        RBRKT 

	   ; at-most-once per item 
	   ; and either streamParm or streamDescriptor but not both 
	   mediaParm            = (streamParm / streamDescriptor / 
	                           terminationStateDescriptor)" 

	Which to me seems to say that we have only one Stream Descriptor
associated 
	with it (as indicated by the comment "; at-most-once per item". 

	Am I interpreting the ABNF correctly? 

	thanks, 

	Steven Weisz

---

From: Troy Cauble <[email-masked]>
Date: Wed, 23 Jan 2002 10:38:35 -0500

I agree that the ABNF comment is incorrect.

It should be

        ; at-most-one terminationStateDescriptor
        ; and either streamParm(s) or streamDescriptor(s) but not both

-troy

> Raphael Tryster wrote:
>      Here is something from the archive which was never answered.  I think
>      the answer to Steven's question is that section 7.1.4 is right and the
>      comment in the ABNF is wrong, as the ASN sp; Will the comment in the
>      ABNF be changed?
> 
>      Raphael Tryster
> 
>      X-Mailer: Internet Mail Service (5.5 Content-Type: text/plain;
>              charset="iso-8859-1"
>      I need some clarification regarding the Media Descriptor. Specifically
>      in
>      This states that a Media Descriptor has one or more Stream Descriptors

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Troy Cauble <[email-masked]>
Date: Wed, 23 Jan 2002 10:38:35 -0500

It should be

-troy

---

From: Terry L Anderson <[email-masked]>
Date: Wed, 23 Jan 2002 12:38:24 -0500

I agree that Troy's statement is correct.  This was the intent of IG 6.75 but the
change did not completely fix the interpretation.  I believe Troy's is better.
Unless I hear an objection I will add this to the IG.

Isn't there also a problem with the comment above streamParm?
; at-most-once
shouldn't it be
;at-most-once per item
we need the possibility of all three Descriptors.

--

------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Terry L Anderson <[email-masked]>
Date: Wed, 23 Jan 2002 12:38:24 -0500

--