Subject: Re: [Megaco] Doubt on package extension

From: "Usha Iyer" <[email-masked]>
Date: Wed, 30 Jan 2002 20:04:31 +0530

Is option A invalid for the reason that tonegen package is designed only for extension,or does the rule apply to any base package ?

    Acc to  12.4 of AVD_2128  
---- For example, if Package A defines event e1, and Package B extends Package A, then B/e1 is an event for a termination implementing Package B. By definition, the MG MUST also implement the base Package, but it optional to publish the base package as an allowed interface. If it does publish A, then A would be reported on the Package Descriptor in AuditValue as well as B, and event A/e1 would be available on a termination. If the MG does not publish A, then only B/e1 would be available 
----

Going by the above , option A  is allowed if tonegen package is published . 

TIA,
usha
  ----- Original Message ----- 
  From: Taylor, Tom-PT [CAR:B800:EXCH] 
  To: 'Usha Iyer' ; [email-masked] 
  Sent: Wednesday, January 30, 2002 7:37 PM
  Subject: RE: [Megaco] Doubt on package extension

  Assuming DTMFgen defines d0 as both a signal and a toneId, and similarly for
  cw in callProgToneGen, then either B or C is valid.

  -----Original Message-----
  From: Usha Iyer [mailto:[email-masked]]
  Sent: Wednesday, January 30, 2002 3:01 AM
  To: [email-masked]
  Subject: [Megaco] Doubt on package extension

  Hi ,
   
  DTMF Gen and Call ProgressToneGen pkg both extend tone gen package .  
  So for a termination that supports ToneGen, DTMFGen and Call ProgToneGen Pkg
  , suppose i want to play d0 follwed by call  waiting tone , which of the
  foll apply . 
   
  A - tonegen/playtone(toneid list= d0,cw ) 
  B -dtmfgen/playtone(toneid list= d0 )  followed by
  callprogtonegen/playtone(toneid list= cw )
  C -dtmfgen/d0 followed by callprogtonegen/cw 

  Reg
  Usha

---

From: "Usha Iyer" <[email-masked]>
Date: Wed, 30 Jan 2002 20:04:31 +0530

Acc to  12.4 of AVD_2128  

TIA,
usha

  -----Original Message-----
  From: Usha Iyer [mailto:[email-masked]]
  Sent: Wednesday, January 30, 2002 3:01 AM
  To: [email-masked]
  Subject: [Megaco] Doubt on package extension

  Hi ,

  Reg
  Usha

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 30 Jan 2002 09:07:06 -0500

-----Original Message-----
From: Usha Iyer [mailto:[email-masked]]
Sent: Wednesday, January 30, 2002 3:01 AM
To: [email-masked]
Subject: [Megaco] Doubt on package extension

Hi ,

Reg
Usha

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco