Subject: [Megaco] QRY about the failed command

From: "vidya g" <[email-masked]>
Date: 30 Jan 2002 09:37:23 -0000

Hi all

  In RFC, page number 61 it says that

 "  At the first failing Command in a Transaction, processing of the remaining Commands in that Transaction stops."

  This statement is some what confusing. What I understand is even if a non optional 
command fails in an action, the action will be cancelled and the next action will be taken 
for processing and the commands in that action will be processed.. is that right .. ?

vdy

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Wed, 30 Jan 2002 10:46:39 -0500

The statement (in 8.0) IS misleading but your understanding is also incorrect.

8.2.2 (including changes from IG 6.36) make it clear that the first non-optional command that fails ends processing of
the entire Transaction (not just the action).

Perhaps the exception indicated in 8.2.2 should also be mentioned in 8.0.

Do folks think this sentence should be corrected in IG?

---

From: Terry L Anderson <[email-masked]>
Date: Wed, 30 Jan 2002 10:46:39 -0500

---

From: Christian Groves <[email-masked]>
Date: Thu, 31 Jan 2002 10:55:47 +1100

G'Day Terry,

The behaviour already is mentioned in 8.0 the paragraph after "At the
first failing Command...". States: "Commands may be marked as "Optional"
which can override this behaviour -  if a command marked as Optional
results in an error, subsequent commands in the Transaction will be
executed.  If a command fails, the MG shall as far as possible restore
the state that existed prior to the attempted execution of the command
before continuing with command processing."

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Thu, 31 Jan 2002 10:55:47 +1100

G'Day Terry,

Regards, Christian

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 31 Jan 2002 09:45:19 -0500

You are right.  I (and Vidya G) should have read a little further.  I agree, no change is needed.

--

------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 31 Jan 2002 09:45:19 -0500

--