Subject: [Megaco] RE: How the ServiceState of TermStateDescriptor in MediaDescripto r is used?

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 31 Jan 2002 22:44:54 -0500

One possibility is that the termination is one of a group, such that when
the MGC send down a request for an outgoing trunk, the MG chooses an
available member of that group (e.g. Add=groupname/${...).  Then setting a
particular trunk to out of service state ensures that the MG won't choose
it.

-----Original Message-----
From: Zhang, Yuyong [mailto:[email-masked]]
Sent: Thursday, January 31, 2002 5:48 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: How the ServiceState of TermStateDescriptor in MediaDescriptor is
used?

G'day, Tom, All
 
I am not very clear how the ServiceState in TermStateDescriptor is used.
 
If a MGC sends this ServiceState to MG, what the "Test", "Out of Service",
or "In Service" state means to a MG, what is the MG's behavior in receiving
such state? I just don't know in what situation, a MGC will sends this
ServiceState to MG.
 
If a MG wants to send termination state to the MGC, then the ServiceChange
with ServiceChangeDescriptor will do.
 
The only way I see the ServiceState to be used is when MG replys an AUDIT on
MediaDescriptor, MG sends the termination state on this.
 
Any thoughts on this?
 
Regards,
 
Yuyong

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 31 Jan 2002 22:44:54 -0500

-----Original Message-----
From: Zhang, Yuyong [mailto:[email-masked]]
Sent: Thursday, January 31, 2002 5:48 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: How the ServiceState of TermStateDescriptor in MediaDescriptor is
used?

G'day, Tom, All

 

Any thoughts on this?
 
Regards,
 
Yuyong