Subject: RE: [Megaco] one dount on RFC3015 as to the requirement on RFC280 5

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 2 Jan 2002 08:18:01 -0500

You audit the Media descriptor of all of the terminations
to determine which terminations are employing the
codec of interest.

Brian

> -----Original Message-----
> From: zhangzhong [mailto:[email-masked]]
> Sent: Friday, December 28, 2001 9:25 PM
> To: Rosen, Brian; 'Madhu Babu Brahmanapally'; 'Shashi Kumar'
> Cc: [email-masked]
> Subject: Re: [Megaco] one dount on RFC3015 as to the requirement on
> RFC2805
> 
> 
> Hi Brian,  All
> I agree with you on the concept of Audit capability and Audit 
> Value . But in present protocol , How can we get the 500 busy 
> through Audit value present defined, I can't find the 
> parameter or package defined the case. 
> 
> Regards
> Zhangzhong
> 
> ----- Original Message ----- 
> From: Rosen, Brian <[email-masked]>
> To: 'Madhu Babu Brahmanapally' <[email-masked]>; 
> 'Shashi Kumar' <[email-masked]>; 'zhangzhong' 
> <[email-masked]>
> Cc: <[email-masked]>
> Sent: Saturday, December 29, 2001 12:54 AM
> Subject: RE: [Megaco] one dount on RFC3015 as to the 
> requirement on RFC2805
> 
> 
> > Audit capabilities tells you what the capabilities of the system
> > are.  Audit Value tells you what is currently "in use".
> > In theory, the "1000 G.711 channel resource" comes from Audit
> > Capability, "500 busy" comes from Audit Value.
> > 
> > In general, the RFC is compliant with the requirements with one
> > notable exception: many gateways are implemented with DSPs or other
> > programmable resources. There is no good way to express capability
> > with such resources.
> > 
> > If you have 1000 fixed G.711 channels, Audit Capability will reveal
> > that.  If 500 channels are used, Audit Value will reveal that.
> > 
> > Brian
> > 
> > > -----Original Message-----
> > > From: Madhu Babu Brahmanapally [mailto:[email-masked]]
> > > Sent: Friday, December 28, 2001 9:44 AM
> > > To: 'Shashi Kumar'; 'zhangzhong'
> > > Cc: [email-masked]
> > > Subject: RE: [Megaco] one dount on RFC3015 as to the 
> requirement on
> > > RFC2805
> > > 
> > > 
> > > HI Shashi,All,
> > > Its true that Audit will help MGC to reconcile the 
> > > inconsistency. But for
> > > the specific scenario Zhang has pointed, How this resource 
> > > information is
> > > exchanged between the MG and the MGC. According to my 
> > > knowledge there is no
> > > parameter or anything as such to "quantitatively" identify 
> > > G711 or any such
> > > channel resource.
> > > Regards
> > > Madhubabu
> > > 
> > > -----Original Message-----
> > > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > > Shashi Kumar
> > > Sent: Thursday, December 27, 2001 11:55 PM
> > > To: zhangzhong
> > > Cc: [email-masked]
> > > Subject: Re: [Megaco] one dount on RFC3015 as to the 
> requirement on
> > > RFC2805
> > > 
> > > 
> > > we have provision to audit the MG resource, which 
> clearlty defined by
> > > Megaco/H.248. By means of Auduting the MG resources we can always
> > > "reconcile inconsistencies between the MGC and the MG"
> > > 
> > > thanks,
> > > shashi
> > > 
> > > 
> > > > zhangzhong wrote:
> > > >
> > > > Hi :
> > > > In the rfc 2805, there have a request to H.248:
> > > >         Provide a mechanism to discover the current available
> > > > resources
> > > >         in the MG, where resources are dynamically consumed by
> > > >         connections and the MGC cannot reasonably or 
> reliably track
> > > > the
> > > >         consumption of such resources. It should also 
> be possible to
> > > >         discover resources currently in use, in order 
> to reconcile
> > > >         inconsistencies between the MGC and the MG.
> > > >
> > > > This means MGC can know the resource consume in the MGW , 
> > > for example
> > > > , if There have 1000 G.711 channel resource , if 500 is 
> > > busy , How can
> > > > MGC know this through RFC3015?
> > > > If can't , The RFC3015 is inconsist with the RFC2805
> > > >
> > > > Thanks for the reply.
> > > > Regards
> > > > Zhangzhong
> > > 
> > > 
> > > _______________________________________________
> > > Megaco mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/megaco
> > >
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "zhangzhong" <[email-masked]>
Date: Fri, 4 Jan 2002 17:08:00 +0800

Hi Brian,
Yes , It can know the resource using, But if you can't binding all channel with Termination, How can you know the 
status of left? idle or failed? 
We can configure the Max number of channel and we can know the exact number of them is busy, but we can't know the status of spares . We can bind a termination with one channel, and put into NULL context, Only in this case, when one channel failed, MGW report the status to MGC .
But this method , I think , is not a standard way .
Why not define a explicit way to reach the aim?

Regards
Zhangzhong

---

From: "zhangzhong" <[email-masked]>
Date: Fri, 4 Jan 2002 17:08:00 +0800

Hi Brian,

Regards
Zhangzhong