Subject: [Megaco] Inter-MGC Communication

From: asrar ashraf <[email-masked]>
Date: Thu, 3 Jan 2002 12:18:25 +0500

Can Any one confirm that 
Only SIP or SIP-T is used for Inter-MGC Communication.
 What about other options.
Can any one guide If There are any callFlows available for Inte-MGC
communication ...

  regards
 Asrar Ashraf
 AvazNetworks
 Islamabad, Pakistan

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 3 Jan 2002 09:24:30 -0500

Neither RFC3015 nor Recommendation H.248 say anything about
interMGC communication.  It is out of scope of the protocol.
You can use anything you would like.  SIP/SIP-T works, but so
does BICC or even H.323.

Brian

> -----Original Message-----
> From: asrar ashraf [mailto:[email-masked]]
> Sent: Thursday, January 03, 2002 2:18 AM
> To: [email-masked]
> Subject: [Megaco] Inter-MGC Communication
> 
> 
> Can Any one confirm that

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 3 Jan 2002 09:24:30 -0500

Brian

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 3 Jan 2002 10:00:34 -0500

You can use any call signalling protocol you want for inter-MGC
communication.  Standardized protocols include BICC CS2 and H.323 as well as
SIP/SIP-T.

-----Original Message-----
From: asrar ashraf [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 2:18 AM
To: [email-masked]
Subject: [Megaco] Inter-MGC Communication

Can Any one confirm that 

  regards
 Asrar Ashraf
 AvazNetworks
 Islamabad, Pakistan

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 3 Jan 2002 10:00:34 -0500

-----Original Message-----
From: asrar ashraf [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 2:18 AM
To: [email-masked]
Subject: [Megaco] Inter-MGC Communication

Can Any one confirm that 

  regards
 Asrar Ashraf
 AvazNetworks
 Islamabad, Pakistan

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Thu, 3 Jan 2002 10:27:20 -0500

Hi, Brian:

You are right.

What could have been better if we could have a document, like Madhubabu's call flows, how the mapping is done as Tom Taylor has indicated. For example, the scenarios can be as follows:

	MGC  <--- H.323 (H.225.0, H.245) ---> MGC
	 ^						   ^
	 |						   |
     MEGACO/MGCP  				MEGACO/MGCP
	 |						   |
	 v						   v
	MG  <---------- RTP ---------------->  MG

Now the appropriate mapping needs to be done between H.323 (H.225.0, H.245) and MEGACO (or MGCP). This part is missing and no documentation is available. If this is done, people could have interoperable implementations.

Similarly, the scenarios can be created for SIP and BICC and, mappings need to be done as follows:

SIP/SDP <-> MEGACO (or MGCP)
BICC  <-> MEGACO (or MGCP)

Best regards,

Radhika R. Roy
[email-masked]

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 9:25 AM
To: 'asrar ashraf'; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

Brian

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Thu, 3 Jan 2002 10:27:20 -0500

Hi, Brian:

You are right.

Best regards,

Radhika R. Roy
[email-masked]

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 9:25 AM
To: 'asrar ashraf'; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 3 Jan 2002 10:40:15 -0500

As the method used to map H.232 into the appropriate Megaco
commands is solely within the domain of a single MGC, it is
not appropriate to standardize it, at least in the IETF.

ITU sometimes does this sort of thing, and it's always possible
to have an informational RFC that describes ONE WAY to do it,
but I think it's a very bad idea to specify that any particular
mapping is the RIGHT way.

The only important thing is that the MGC implementation
work on a wide variety of MGs, using standard Megaco/H248,
and that it interwork with a wide variety of H.323 devices
using standard H.323.  I suspect there is not a single exact
mapping.

Brian

> From: Roy, Radhika R, ALCTA [mailto:[email-masked]]
> Sent: Thursday, January 03, 2002 10:27 AM
> To: Rosen, Brian; asrar ashraf; [email-masked]
> What could have been better if we could have a document, like 
> Madhubabu's call flows, how the mapping is done as Tom Taylor 
> has indicated. For example, the scenarios can be as follows:
> 
> Now the appropriate mapping needs to be done between H.323 
> (H.225.0, H.245) and MEGACO (or MGCP). This part is missing 
> and no documentation is available. If this is done, people 
> could have interoperable implementations.
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 3 Jan 2002 10:40:15 -0500

Brian

---

From: [email-masked]
Date: Thu, 3 Jan 2002 17:46:10 +0200

Hi,

I think we are getting further out of scope. If some document as Radhika
suggested, it would be appropriate in other forums rather than megaco.

Regards,
Kishore

-----Original Message-----
From: ext Roy, Radhika R, ALCTA [mailto:[email-masked]]
Sent: 03. January 2002 17:27
To: Rosen, Brian; asrar ashraf; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

Hi, Brian:

You are right.

What could have been better if we could have a document, like Madhubabu's
call flows, how the mapping is done as Tom Taylor has indicated. For
example, the scenarios can be as follows:

Now the appropriate mapping needs to be done between H.323 (H.225.0, H.245)
and MEGACO (or MGCP). This part is missing and no documentation is
available. If this is done, people could have interoperable implementations.

Similarly, the scenarios can be created for SIP and BICC and, mappings need
to be done as follows:

Best regards,

Radhika R. Roy
[email-masked]

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 9:25 AM
To: 'asrar ashraf'; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

Brian

---

From: [email-masked]
Date: Thu, 3 Jan 2002 17:46:10 +0200

Hi,

Regards,
Kishore

-----Original Message-----
From: ext Roy, Radhika R, ALCTA [mailto:[email-masked]]
Sent: 03. January 2002 17:27
To: Rosen, Brian; asrar ashraf; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

Hi, Brian:

You are right.

Best regards,

Radhika R. Roy
[email-masked]

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 9:25 AM
To: 'asrar ashraf'; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

Brian

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Thu, 3 Jan 2002 11:39:51 -0500

...

I suspect there is not a single exact
mapping.

[RRR] This is the problem. Should people like to live with this?

Brian

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Thu, 3 Jan 2002 11:39:51 -0500

...

Brian

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Thu, 3 Jan 2002 11:44:34 -0500

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]
Sent: Thursday, January 03, 2002 10:46 AM
To: Roy, Radhika R, ALCTA; [email-masked]; [email-masked];
[email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

Hi,

[RRR] Yes, I agree. (Other forums will be a better place. Sometimes, people also do informational RFCs.)

Regards,
Kishore

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Thu, 3 Jan 2002 11:44:34 -0500

-----Original Message-----

Hi,

Regards,
Kishore

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 3 Jan 2002 13:12:09 -0500

As Brian stated, the translation is internal to a single entity (in this
case, the MGC).  I don't see a problem here, just as I don't see a problem
with different MGCs having different internal hardware.  Think "black box".
If the external interfaces are OK (H.248/Megaco on the one hand, and BICC or
SIP or whatever on the other), then why worry about the translation?  If the
translation is not correct, for whatever reason, then the vendor will surely
figure that out and correct it, or their product will not sell!

Kevin

-----Original Message-----
From: Roy, Radhika R, ALCTA [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 11:40 AM
To: Rosen, Brian; asrar ashraf; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

...

Brian

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 3 Jan 2002 13:12:09 -0500

Kevin

-----Original Message-----
From: Roy, Radhika R, ALCTA [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 11:40 AM
To: Rosen, Brian; asrar ashraf; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

...

Brian

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Thu, 3 Jan 2002 13:56:31 -0500

Hi, Kevin:
 
I beg to disagree with you here.
 
The decomposition of the GWs has been done to have other benefits as well. For example, MGCs from one vendor, while MGs from other vendors.
 
What do we expect in those situations? Do the service providers be forced to lock into proprietary solutions/implementations?
 
I understand the problems that MEGACO WG may not be chartered to address those issues. That does not mean we should NOT be worried about those issues. MEGACO WG has done its primary job and it is a very proud achievement (in standardizing the MEGACO protocol). As we move forward, we have to see how the industry can reap the benefits in implementing the large-scale networks in multi-vendor and multi-protocol environment using the MEGACO protocol.
 
Since the MEGACO protocol is standardized, now, we have the luxury to go for the next step: Interoperability in multiprotocol (SIP, H.323, BICC, ISUP) and multi-vendor environment using the MEGACO protocol. Not only that, it is also applicable for all transport networks (PSTN, IP, ATM, FR). I feel that MEGACO is providing a wonderful GLUE to solve these complex problems what could not even be imagined couples of years ago.
 
Best regards,
Radhika R. Roy
[email-masked]

-----Original Message-----
From: Kevin Boyle [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 1:12 PM
To: Roy, Radhika R, ALCTA; Rosen, Brian; asrar ashraf; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

As Brian stated, the translation is internal to a single entity (in this case, the MGC).  I don't see a problem here, just as I don't see a problem with different MGCs having different internal hardware.  Think "black box".  If the external interfaces are OK (H.248/Megaco on the one hand, and BICC or SIP or whatever on the other), then why worry about the translation?  If the translation is not correct, for whatever reason, then the vendor will surely figure that out and correct it, or their product will not sell!

Kevin 

-----Original Message----- 
From: Roy, Radhika R, ALCTA [ mailto:[email-masked]] 
Sent: Thursday, January 03, 2002 11:40 AM 
To: Rosen, Brian; asrar ashraf; [email-masked] 
Subject: RE: [Megaco] Inter-MGC Communication 

... 

Brian 

> From: Roy, Radhika R, ALCTA [ mailto:[email-masked]] 
> From: Rosen, Brian [ mailto:[email-masked]] 
> > From: asrar ashraf [ mailto:[email-masked]]

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Thu, 3 Jan 2002 14:52:11 -0500

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 2:36 PM
To: Roy, Radhika R, ALCTA; Kevin Boyle; asrar ashraf; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

You are missing the point.  An MGC that interworks H.323 to Megaco
should work with any MG from any vendor that supports the appropriate
packages for the type of termination supported.  No standardization is
required for that.  Such an MGC should be able to interwork with
any H.323 terminal or gateway.  

It's all local to the MGC.

[RRR] If everything is local to MGC and there is no dependency in sending the particular messages among the MGCs, there is no need for any additional work.

[RRR] However, there may be a dependency directly or indirectly in communications between the MGC and MG and vice versa based on what MGCs do among themselves using other protocols (e.g., H.323, SIP). For example, the implications of QOS and other attributes.

[RRR] The whole idea has been to go through all those scenarios for a given protocol, we can then find out what the end result is (may be to prove what you have said).

No standardization is required for that.

[RRR] It is not about standardization per se. The concern is more about interoperability.

Brian

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Thu, 3 Jan 2002 14:52:11 -0500

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 2:36 PM
To: Roy, Radhika R, ALCTA; Kevin Boyle; asrar ashraf; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 3 Jan 2002 14:35:36 -0500

any H.323 terminal or gateway.  No standardization is required for
that.

Brian

> Sent: Thursday, January 03, 2002 1:57 PM
> To: Kevin Boyle; Rosen, Brian; asrar ashraf; [email-masked]
> The decomposition of the GWs has been done to have other 
> benefits as well. For example, MGCs from one vendor, while 
> MGs from other vendors.
>  
> What do we expect in those situations? Do the service 
> providers be forced to lock into proprietary 
> solutions/implementations?
>  
> I understand the problems that MEGACO WG may not be chartered 
> to address those issues. That does not mean we should NOT be 
> worried about those issues. MEGACO WG has done its primary 
> job and it is a very proud achievement (in standardizing the 
> MEGACO protocol). As we move forward, we have to see how the 
> industry can reap the benefits in implementing the 
> large-scale networks in multi-vendor and multi-protocol 
> environment using the MEGACO protocol.
>  
> Since the MEGACO protocol is standardized, now, we have the 
> luxury to go for the next step: Interoperability in 
> multiprotocol (SIP, H.323, BICC, ISUP) and multi-vendor 
> environment using the MEGACO protocol. Not only that, it is 
> also applicable for all transport networks (PSTN, IP, ATM, 
> FR). I feel that MEGACO is providing a wonderful GLUE to 
> solve these complex problems what could not even be imagined 
> couples of years ago.
>  
> Best regards,
> Radhika R. Roy
> [email-masked]
> 
> As Brian stated, the translation is internal to a single 
> entity (in this case, the MGC).  I don't see a problem here, 
> just as I don't see a problem with different MGCs having 
> different internal hardware.  Think "black box".  If the 
> external interfaces are OK (H.248/Megaco on the one hand, and 
> BICC or SIP or whatever on the other), then why worry about 
> the translation?  If the translation is not correct, for 
> whatever reason, then the vendor will surely figure that out 
> and correct it, or their product will not sell!
> 
> Kevin 
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 3 Jan 2002 14:35:36 -0500

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 3 Jan 2002 17:01:59 -0500

> [RRR] However, there may be a dependency directly or 
> indirectly in communications between the MGC and MG and vice 
> versa based on what MGCs do among themselves using other 
> protocols (e.g., H.323, SIP). For example, the implications 
> of QOS and other attributes.

I don't think there is anything like it.  I believe there was a
concern raised about H.450 video events; they would be hard
to field at the MGC.  Because Megaco is master/slave, the MGC
tells the MG how to handle the QoS stuff.  I don't think there is
any problem with SIP or BICC.

Brian

> Sent: Thursday, January 03, 2002 2:52 PM
> To: Rosen, Brian; Kevin Boyle; asrar ashraf; [email-masked]
> [RRR] If everything is local to MGC and there is no 
> dependency in sending the particular messages among the MGCs, 
> there is no need for any additional work.
> 
> [RRR] However, there may be a dependency directly or 
> indirectly in communications between the MGC and MG and vice 
> versa based on what MGCs do among themselves using other 
> protocols (e.g., H.323, SIP). For example, the implications 
> of QOS and other attributes.
> 
> [RRR] The whole idea has been to go through all those 
> scenarios for a given protocol, we can then find out what the 
> end result is (may be to prove what you have said).
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 3 Jan 2002 17:01:59 -0500

Brian

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Thu, 3 Jan 2002 17:25:12 -0500

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 5:02 PM
To: Roy, Radhika R, ALCTA; Kevin Boyle; asrar ashraf; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

to field at the MGC.  

[RRR] It is nice to know someone did some analysis or testing. This is what is needed to come out for interoperable implementations. As long as we all agree that it works and interoperates, we are done. (Still it appears that there may be some issues.)

Because Megaco is master/slave, the MGC
tells the MG how to handle the QoS stuff. 

[RRR] I would suggest to look into some QOS contributions provided in MEGACO. It shows that there are some basic issues (e.g., policy) that need to be resolved for the base MEGACO protocol itself. Then the question comes whether we need to do anything extra when other protocols are used among the MGCs.

I don't think there is

[RRR] May be you are right. So, as I explained earlier, if we all agree that things are interoperable in multi-protocol and multi-vendor environment, then we are done. (Are we all sure about this?)

[RRR} Last of all, let me provide a pointer. For example, Madhubabu has provided a "MEGACO Call Flows" I-D. There is no new standardization works. However, it shows how things can be implemented and if we all agree with these procedures and it provides a baseline for interoperable implementations (should any questions arise). The same is true for the SIP Call Flows or SIP services example. (Why can we not do the same MEGACO for inter-MGC communications where SIP, H.323, etc. are used?)

Brian

---

From: "Roy, Radhika R, ALCTA" <[email-masked]>
Date: Thu, 3 Jan 2002 17:25:12 -0500

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Thursday, January 03, 2002 5:02 PM
To: Roy, Radhika R, ALCTA; Kevin Boyle; asrar ashraf; [email-masked]
Subject: RE: [Megaco] Inter-MGC Communication

I don't think there is

Brian