Subject: [Megaco] NotifyCompletion Question

From: Carl Rutter <[email-masked]>
Date: Thu, 17 Jan 2002 10:04:20 -0500

For V1 the possible values of NotifyCompletion reason are:

notifyCompletion     = NotifyCompletionToken EQUAL (LBRKT 
          notificationReason *(COMMA notificationReason) RBRKT) 
    
   notificationReason   = ( TimeOutToken / InterruptByEventToken 
               / InterruptByNewSignalsDescrToken 
               / OtherReasonToken ) 

So when an MGC wants the MG to notify a completion of a Signal
the MGC would specify:

NC = TimeOut,IntByEvent etc (or whatever of the 4 they want to be notified
for)

Is this correct???

The reason I ask is later in the RFC there is this:
Signal Completion 
      EventID: sc (0x0002) 
      Indicates termination of one or more signals for which the 
      notifyCompletion parameter was set to "ON".  For further 
      procedural description, see sections 7.1.11, 7.1.17, and 7.2.7. 

Which seems to indicate that the NC really should be an ON or OFF value and
the 4 notificationReasons are really just return values.

Thanks,
Carl

Carl Rutter
Telica, Inc.
Building G, Suite 100
734 Forest Street
Marlboro, MA 01752
Email [email-masked]
Voice 508-480-0909 x8178
Fax 508-480-0922 
www.telica.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 17 Jan 2002 10:17:57 -0500

The error is in the Annex E text.  This material was a fairly late addition
(part of the enormous amount of work we did in the Feb'00 meeting in
Geneva), and an inconsistency crept in.  You are the first to spot it.  The
text should read:

Signal Completion 
      EventID: sc (0x0002) 
      Indicates termination of one or more signals for which the 
      notifyCompletion parameter was set to enable reporting of a
      completion event.  For further procedural description, see 
      sections 7.1.11, 7.1.17, and 7.2.7. 

-----Original Message-----
From: Carl Rutter [mailto:[email-masked]]
Sent: Thursday, January 17, 2002 10:04 AM
To: [email-masked]'
Subject: [Megaco] NotifyCompletion Question

    

Is this correct???

Thanks,
Carl

Carl Rutter
Telica, Inc.
Building G, Suite 100
734 Forest Street
Marlboro, MA 01752
Email [email-masked]
Voice 508-480-0909 x8178
Fax 508-480-0922 
www.telica.com

---

From: Carl Rutter <[email-masked]>
Date: Mon, 21 Jan 2002 08:38:47 -0500

I was looking for clarification which Tom provided.
Annex E being the confusing statement which Tom rephrased.
I wasn't suggesting a change to V1 for notify Completion = "ON/OFF" 
although like yourself I see the merits of it as well.
 
Carl

-----Original Message-----
From: Chuong N. Nguyen [mailto:[email-masked]]
Sent: Sunday, January 20, 2002 3:11 PM
To: Terry L Anderson
Cc: Tom-PT Taylor; 'Carl Rutter'; [email-masked]'
Subject: Re: [Megaco] NotifyCompletion Question

I am not sure we have addressed Carl's concern here. 

What he is saying makes everything clear to me now and it makes better sense
than what is already 
defined in the ABNF. 
I didn't really understood how this NotifyCompletion really worked and I
think 
I had raised some questions on it before. 

   signalRequest        = signalName [ LBRKT sigParameter 
                          *(COMMA sigParameter) RBRKT ] 

   sigParameter    = sigStream / sigSignalType / sigDuration / sigOther 
                   / notifyCompletion / KeepActiveToken 

   notifyCompletion     = NotifyCompletionToken EQUAL (LBRKT 
                   notificationReason *(COMMA notificationReason) RBRKT 

Because of the above ABNF, my intepretation is that MGC specifies to MG that
it needs to report 
signal completion based on the reason(s) that MGC has specified. 
If the signal completion was not due to one of the reasons specified by the
MGC then 
don't report the signal completion. 
When the signal completed and the reason matches one specified by MGC, MG
reports 
the signal completion w/the reason. 

Tom, I am not sure if your change to Event sc makes any difference here to
the actual implementation. 

I think Carl is suggesting the following (correct me if I am wrong) 

   notifyCompletion    = "ON/OFF" 

This is a change in syntax which will break current implementation. 

I am using notifyCompletionRequest because we still have to keep
notifyCompletion for 
the reporting of the signal completion in the EventDescriptor. 

Since this is a BIG syntax change, it can't be done in V1 or an update to
IG. 
For V2, it will still be a big problem due to backward compatibilty
requirement. 

Chuong 

Terry L Anderson wrote: 

I agree.  I will add to IG. 

Tom-PT Taylor wrote: 

> From: Carl Rutter [ mailto:[email-masked] <mailto:[email-masked]>
] 

> the 4 notificationReasons are really just return values. 
<https://www1.ietf.org/mailman/listinfo/megaco>  
<https://www1.ietf.org/mailman/listinfo/megaco>  

-- 

------------------------------------------------------------ 
Terry L Anderson             mailto:[email-masked] <mailto:[email-masked]>  
Tel:908.582.7013   Fax:908.582.6729 
Lucent Technologies/INS/Voice Over IP Access Networks 
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974 
http://its.lucent.com/~tla <http://its.lucent.com/~tla>  (Lucent internal)
http://www.gti.net/tla <http://www.gti.net/tla> 

-- 

  Alcatel USA, Inc             Internet: [email-masked]

  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613

  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Carl Rutter <[email-masked]>
Date: Mon, 21 Jan 2002 08:38:47 -0500

Carl

-----Original Message-----
From: Chuong N. Nguyen [mailto:[email-masked]]
Sent: Sunday, January 20, 2002 3:11 PM
To: Terry L Anderson
Cc: Tom-PT Taylor; 'Carl Rutter'; [email-masked]'
Subject: Re: [Megaco] NotifyCompletion Question

Chuong 

Terry L Anderson wrote: 

] 

-- 

--