Subject: [Megaco] Routing

From: "gokulc" <[email-masked]>
Date: Sat, 5 Jan 2002 12:00:07 +0530

Hi,

I believe that routing is the responsibility of MGC, and MG plays no role in
routing.
In view of this I also believe that the wildcards(partial) used in the
selection of the terminations
is only to identify the terminations, and not for routing in the MG. That is
MG may not take routing
decisions on receipt of command like Add = $. MGC has figured out the
destination MG based on the
dialed digits and also the termination(or possible set of terminations in
the case of trunk group).

Is that valid?

gokul

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Shambhu Dayal Rai <[email-masked]>
Date: Sat, 05 Jan 2002 13:46:45 +0530

Hi gokul,

You are right, MGC takes the decision on which terminations to use on the MG based on the dial number and the routing information in
its database or other means. 

After the session is up, ofcourse routing of the data packets to the destination IP Address is done by MG, based on MG's routing
table. 

-Shambhu

-- 
-------------------------------------------------------------------
Shambhu Dayal Rai                              [email-masked] 
Infosys - India SQA Team              91-80-8520362 Ext. : 6561
-------------------------------------------------------------------

---

From: Shambhu Dayal Rai <[email-masked]>
Date: Sat, 05 Jan 2002 13:46:45 +0530

Hi gokul,

-Shambhu

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Fri, 04 Jan 2002 13:59:01 +0530

Hi Gokul,
	Here I assume, Routing you mean by is Call Routing.

> the case of trunk group).

To my knowledge what you believe is true.
You can visualise MG as a dedicated device for Media Transfer between
terminations that are grouped under the term 'context'. And does this
grouping and ungrouping of terminations with instructions received from
an intelligent guy called MGC using the protocol MEGACO. It's upto the
MGC to decide which terminations to interconnect(group) to accomplish
the call.

> gokul

Thanks,
Giri

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,
51, Jawaharlal Nehru Road 
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.

Phone Off : +91 44 233 4174 or +91 44 233 4181
Fax : +91 44 234 4256
e-mail : [email-masked] <mailto:[email-masked]>

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,
51, Jawaharlal Nehru Road 
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.

Phone Off : +91 44 233 4174 or +91 44 233 4181
Fax : +91 44 234 4256
e-mail : [email-masked] <mailto:[email-masked]>

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Fri, 04 Jan 2002 13:59:01 +0530

Hi Gokul,

Thanks,
Giri

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,