Subject: [Megaco] ****ERROR condition

From: "vidya g" <[email-masked]>
Date: 25 Jan 2002 04:44:55 -0000

hi 

    If an optional command is failed we can go ahead with processing with other commands according to RFC. But if one optional command fails, how do we specify it in the response..? Error descriptor is available only in the action level. we do not have error descriptor in command level. So if an optional command fails, we cannot specify error in the reply. But at the same time if we do not specify error condition, MGC will think that the command is success. How do we handle this situation.. ?

   # What for this Notify reply is used.. ?

regs
vdy 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Fri, 25 Jan 2002 08:39:06 -0500

There IS an errorDescriptor at in every command Reply (as long as the command name is parsed - the exception is being fixed.  See recent discussion about open issue #4: Doubt regarding sending Error in Transaction Reply).  For example, ammsReply contains terminationAudit which contains auditReturnParameter which can be errorDescriptor.

--

------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:908.582.7013   Fax:908.582.6729
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Terry L Anderson <[email-masked]>
Date: Fri, 25 Jan 2002 08:39:06 -0500

--