Subject: [Megaco] Annex E: RTP package Statistics Delay

From: "Chuong N. Nguyen" <[email-masked]>
Date: Fri, 05 Apr 2002 11:09:46 -0600

Delay
        StatisticID:delay (0x0008)

        Requests the current value of packet propagation delay
        expressed in timestamp units. Same as average latency.

Where is "average latency" defined in the Standard?

Is TimeStamp units the following?

   TimeStamp            = Date "T" Time ; per ISO 8601:1988
      ; Date = yyyymmdd
   Date                 = 8(DIGIT)
      ; Time = hhmmssss
   Time                 = 8(DIGIT)

Do we really intend for this to be timestamp units or just msec?

In the example

             Statistics { rtp/ps=1200,  ; packets sent
                          nt/os=62300, ; octets sent
                          rtp/pr=700, ; packets received
                          nt/or=45100, ; octets received
                          rtp/pl=0.2,  ; % packet loss
                          rtp/jit=20,
                          rtp/delay=40 } ; avg latency  //  Doesn't look
like timestamp at all.

Thanks
Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Terry L Anderson <[email-masked]>
Date: Mon, 08 Apr 2002 08:45:28 -0400

I think that this means RTP timestamp units rather than TimeStamp
strings.

"Chuong N. Nguyen" wrote:

>                           rtp/delay=40 } ; avg latency  //  Doesn't
> look like timestamp at all.
>
> Thanks
> Chuong
>
> --

--
-------------------------------------------------------
Terry L Anderson, DMTS                   [email-masked]
Lucent Technologies /INS/ Voice over IP Access Networks
Rm 2B-121,   600 Mountain Ave, Murray Hill, NJ 07974
Voice:908 582-7013  FAX:908 582-6226   Org:18E75000000
http://its.lucent.com/~tla  (Lucent internal)
http://www.gti.net/tla
-------------------------------------------------------

---

From: Terry L Anderson <[email-masked]>
Date: Mon, 08 Apr 2002 08:45:28 -0400

---

From: "Chuong N. Nguyen" <[email-masked]>
Date: Mon, 08 Apr 2002 08:17:32 -0500

What is RTP timestamp units and where can I get the official definition for
it?

Also in Annex C C.1 General Media Attributes

  +-------------------+------+-------------+---------------------------+
  | PropDelay         | 100E | Unsigned    | Propagation Delay:        |
  |                   |      | Integer     | 0..65535                  |
  +-------------------+------+-------------+---------------------------+
  | Maximum propagation delay in milliseconds for the bearer           |
  | connection between two  media gateways. The maximum delay will be  |
  | dependent on the bearer technology.                                |

So do they both mean the same thing so they should both have the same units
- msec?

Thanks
Chuong

---

From: "Chuong N. Nguyen" <[email-masked]>
Date: Mon, 08 Apr 2002 08:17:32 -0500

Thanks
Chuong

---

From: Terry L Anderson <[email-masked]>
Date: Mon, 08 Apr 2002 11:19:59 -0400

According to RFC 1889, the RTP timestamp interval varies with the
payload and is specified in the payload spec but is usually the sampling
interval, eg. 1/8000 sec for most audio codecs.  Note that latency can
be calculated from RTCP reports which use this same unit.

I assume that Annex C's PropDelay is the sender's estimate for a maximum
value of latency that should be encountered, but is given in millisec,
possibly to be independent of payload type(?).

"Chuong N. Nguyen" wrote:

>
> What is RTP timestamp units and where can I get the official
> definition for it?
>
> So do they both mean the same thing so they should both have the same
> units - msec?
>
> Thanks
> Chuong
>
>
>
> Terry L Anderson wrote:
>

--

------------------------------------------------------------
Terry L Anderson              mailto:[email-masked]
Tel:732.949.5628   Fax:732.949.7016
Lucent Technologies/INS/Voice Over IP Access Networks
Rm 2G-219A, 101 Crawfords Corner Rd, Holmdel, NJ 07733-3030
http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

---

From: Terry L Anderson <[email-masked]>
Date: Mon, 08 Apr 2002 11:19:59 -0400

--