Subject: [Megaco] use of EventBufferDescriptor

From: "ding" <[email-masked]>
Date: Wed, 10 Apr 2002 20:19:42 +0800

hi,

suppose MG receives a EventBufferDescriptor and a EventDescriptor at the same time, and MG's event buffer queue(FIFO queue) is empty. now if some user event is recognized in the EventBufferDescriptor(and not recognized in the EventDescriptor), should MG discard the user event or send it to the FIFO queue?

I think it should be discarded, am i right?

thanks.

---

From: "ding" <[email-masked]>
Date: Thu, 11 Apr 2002 09:07:18 +0800

hi Tom,

do u think I'm right or not?

thanks

Watson. Ding

----- Original Message ----- 
From: ding <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, April 10, 2002 9:04 PM
Subject: Re: [Megaco] use of EventBufferDescriptor

> my understanding is that 
> 
> when EventBufferControl is LockStep mode &&
>                   EventsDescriptor is not active &&
>                        event is found in EventBufferDescriptor
> 
> the mode to process user event equal to the mode in MGCP when
> 
> endpoint is in notification state &&
>                 QuarantineHandling is "process" and "step".
> 
> do you think so?
> 
> 
> 
> ----- Original Message ----- 
> From: Giri Rajasekhar Saladi <[email-masked]>
> To: ding <[email-masked]>
> Cc: <[email-masked]>
> Sent: Wednesday, April 10, 2002 6:18 PM
> Subject: Re: [Megaco] use of EventBufferDescriptor
> 
> 
> > Hi Ding,
> > My answer is inline.
> > 
> > > ding wrote:
> > > 
> > > hi,
> > > 
> > > suppose MG receives a EventBufferDescriptor and a EventDescriptor at the same
> > > time, and MG's event buffer queue(FIFO queue) is empty. now if some user event
> > 
> > We search for the event against EventBufferDescriptor only if EventBufferControl
> > is LockStep mode and EventsDescriptor is not active.
> > 
> > > is recognized in the EventBufferDescriptor(and not recognized in the
> > > EventDescriptor), should MG discard the user event or send it to the FIFO
> > > queue?
> > 
> > So, if EventBufferControl is LockStep mode &&
> >                  EventsDescriptor is not active &&
> >                       event is found in EventBufferDescriptor
> >     then
> >        send it to the FIFO queue.
> > 
> > > 
> > Regds.,
> > Giri
> > -- 
> > Giri Rajasekhar Saladi
> > HCL Technologies Ltd.,
> > 51, Jawaharlal Nehru Road 
> > Guindy Industrial Estate,
> > Ekkatuthangal,
> > Chennai - 600 097.
> > 
> > 
> > Phone Off : +91 44 233 4174 or +91 44 233 4181 Extn. 233
> > Fax : +91 44 234 4256
> > e-mail : [email-masked] <mailto:[email-masked]>
> > 
> > _______________________________________________
> > Megaco mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/megaco
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "ding" <[email-masked]>
Date: Thu, 11 Apr 2002 09:07:18 +0800

hi Tom,

thanks

Watson. Ding