Subject: [Megaco] Re: Unique ContextId and TerminationId?

From: Y Hu <[email-masked]>
Date: Thu, 4 Apr 2002 03:11:05 -0800 (PST)

Hi,

According to the spec, the ContextID is unique to
identify the action, but the context ID is assigned by
the MG. When the MGC sends a first action request to
the MG, it uses a null context ID. How can the MGC
maintain the action identification uniquely with the
null Context ID? How can the MGC match a reply action
to the original request action as the context ID has 
been changed (assigned by the MG)?

Also, the termination ID is provisioned at MG, does
the MGC has the knowledge of the termination IDs
before sending request, or does the MGC reply the MG
to assign the termination ID as well?

Thank you.

yh

__________________________________________________
Do You Yahoo!?
Yahoo! Tax Center - online filing with TurboTax
http://taxes.yahoo.com/

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 04 Apr 2002 09:13:16 -0500

MGC can Modify a termination using a NULL contextID.  NULL is not a
wildcard and MG does not choose a normal context id in this case.  The
termination is left in the NULL context.

Or MGC can Add a termination using a CHOOSE contextID.  In this case MG
generates a contextID that is unique to the MG and returns it in the
response.

The task of matching the response to the request is done by using the
transactionID (assigned by MGC) along with the fact that commands in a
transaction must be performed in order and the responses must follow the
same order.  Thus MGC can identify the command response that
corresponded to the command that used CHOOSE.

--
-------------------------------------------------------
Terry L Anderson, DMTS                   [email-masked]
Lucent Technologies /INS/ Voice over IP Access Networks
Rm 2B-121,   600 Mountain Ave, Murray Hill, NJ 07974
Voice:908 582-7013  FAX:908 582-6226   Org:18E75000000
http://its.lucent.com/~tla  (Lucent internal)
http://www.gti.net/tla
-------------------------------------------------------

---

From: Terry L Anderson <[email-masked]>
Date: Thu, 04 Apr 2002 09:13:16 -0500