Subject: [Megaco] Deleting termination from the Context

From: Anil Jangam <[email-masked]>
Date: Wed, 24 Apr 2002 12:10:09 +0530

Hi,

Is it possible to issue a 'Subtract' command to delete a Termination with
'Context' as a '*'.
I am looking at subtract command which essentially deletes a Termination
from the context, when I don't have the information about the context, in
which the Termination is present. Thus with 'Context' as '*', it would try
to find out the TerminastionId in all the contexts present and delete it. 

regds,
/anil.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Wed, 24 Apr 2002 16:33:22 +0530

Hi Anil

It is possible to send subtract command with context ALL and termination fully
specified.
In such a case if the specified termination is present in any non null context,
it will get subtracted otherwise an error will be returned

Regards
Shobhit

Anil Jangam <[email-masked]> on 04/24/2002 04:27:19 PM

To:   "[email-masked]'" <[email-masked]>,
      [email-masked]
cc:    (bcc: Shobhit Bansal/HSS)

Subject:  RE: [Megaco] Deleting termination from the Context

Hi Elango,

Apparently this is the case when it is required to delete all terminations
in all the context. Does it mean that I can specify a specific Termination
ID and try to delete it with the method you have mentioned? In my case, I
want to delete a *given termination only* and not all.

/anil.

> -----Original Message-----
> From: Elango K [mailto:[email-masked]]
> Sent: Wednesday, April 24, 2002 3:18 PM
> To: 'Anil Jangam'; [email-masked]
> Subject: RE: [Megaco] Deleting termination from the Context
>
>
> Hi Anil,
>
> Use of Subtract command with Context as '*' is permissible. This would
> delete all ephemeral terminations and return all physical
> terminations to
> null context.
>
> Hope this helps.
>
> Regards,
> Elango.
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Anil Jangam
> Sent: Wednesday, 24 April 2002 12:10 PM
> To: [email-masked]'
> Subject: [Megaco] Deleting termination from the Context
>
>
> Hi,
>
> **************************************************************
> *************
> This message is proprietary to Future Software Limited (FSL)
> and is intended solely for the use of the individual to whom it
> is addressed. It may contain  privileged or confidential information
> and should not be circulated or used for any purpose other than for
> what it is intended.
>
> If you have received this message in error, please notify the
> originator immediately. If you are not the intended recipient,
> you are notified that you are strictly prohibited from using,
> copying, altering, or disclosing the contents of this message.
> FSL accepts no responsibility for loss or damage arising from
> the use of the information transmitted by this email including
> damage from virus.
> **************************************************************
> *************
>

---

From: [email-masked]
Date: Wed, 24 Apr 2002 16:33:22 +0530

Hi Anil

Regards
Shobhit

Hi Elango,

/anil.

---

From: Anil Jangam <[email-masked]>
Date: Wed, 24 Apr 2002 16:27:19 +0530

Hi Elango,

/anil.

---

From: Anil Jangam <[email-masked]>
Date: Wed, 24 Apr 2002 16:27:19 +0530

Hi Elango,

/anil.

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 24 Apr 2002 08:55:36 -0400

Following the precedent set with the Audit commands, I think this should be
possible.

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]]
Sent: Wednesday, April 24, 2002 2:40 AM
To: [email-masked]'
Subject: [Megaco] Deleting termination from the Context

Hi,

regds,
/anil.

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 24 Apr 2002 08:55:36 -0400

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]]
Sent: Wednesday, April 24, 2002 2:40 AM
To: [email-masked]'
Subject: [Megaco] Deleting termination from the Context

Hi,

regds,
/anil.

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 24 Apr 2002 08:57:39 -0400

You're thinking of ContextId=*{Subtract=*{}}}.  Anil was asking about 
ContextId=*{Subtract=specific{}}}.

-----Original Message-----
From: Elango K [mailto:[email-masked]]
Sent: Wednesday, April 24, 2002 5:48 AM
To: 'Anil Jangam'; [email-masked]
Subject: RE: [Megaco] Deleting termination from the Context

Hi Anil,

Use of Subtract command with Context as '*' is permissible. This would
delete all ephemeral terminations and return all physical terminations to
null context.

Hope this helps.

Regards,
Elango.

-----Original Message-----

Hi,

regds,
/anil.

***************************************************************************

***************************************************************************

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 24 Apr 2002 08:57:39 -0400

-----Original Message-----
From: Elango K [mailto:[email-masked]]
Sent: Wednesday, April 24, 2002 5:48 AM
To: 'Anil Jangam'; [email-masked]
Subject: RE: [Megaco] Deleting termination from the Context

Hi Anil,

Hope this helps.

Regards,
Elango.

-----Original Message-----

Hi,

regds,
/anil.

---

From: "Nurit Shenhar" <[email-masked]>
Date: Mon, 29 Apr 2002 17:39:18 +0200

Hi
 
I have always thought that using the format of Context=* and termination=specific should be limited to the audit command. The MGC id supposed to have the picture at all times, and if there is a loss of synchronization, it should audit to get the current status. So how come that the MGC doesn't know the context's termination? And if the context is known, why using the ALL wildcard?
 
Nurit
 
-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Wednesday, April 24, 2002 2:56 PM
To: 'Anil Jangam'; [email-masked]'
Subject: RE: [Megaco] Deleting termination from the Context
 
Following the precedent set with the Audit commands, I think this should be possible. 
-----Original Message----- 
From: Anil Jangam [ mailto:[email-masked]] 
Sent: Wednesday, April 24, 2002 2:40 AM 
To: [email-masked]' 
Subject: [Megaco] Deleting termination from the Context 
 
Hi, 
Is it possible to issue a 'Subtract' command to delete a Termination with 'Context' as a '*'. 
I am looking at subtract command which essentially deletes a Termination 
from the context, when I don't have the information about the context, in which the Termination is present. Thus with 'Context' as '*', it would try to find out the TerminastionId in all the contexts present and delete it. regds, 
/anil. 
_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Nurit Shenhar" <[email-masked]>
Date: Mon, 29 Apr 2002 17:39:18 +0200

Hi

Nurit

-----Original Message----- 
From: Anil Jangam [ mailto:[email-masked]] 
Sent: Wednesday, April 24, 2002 2:40 AM 
To: [email-masked]' 
Subject: [Megaco] Deleting termination from the Context 
 
Hi,