Subject: [Megaco] ServiceChange for a single termination (Cold Start)

From: "Barcotti, Glauco" <[email-masked]>
Date: Tue, 16 Apr 2002 15:26:22 -0400

Hi,

	Assuming a Gateway with 2 terminations, one of them is OK and the other is Malfunctioning. How should I proceed if I want to bring just the working termination up (Cold Start)?

a) If a ServiceChange is issued for ROOT termination MGC will think that all terminations are up and, until another ServiceChange is issued taking the defective Termination out of service, a call could be attempted on that defective termination

b) If a ServiceChange is issued just for the working Termination The ability to redirect the gateway to another MGC will be lost (See quotation from spec below) 

"The return from ServiceChange is empty except when the Root terminationID is used.  In that case it includes the following parameters as required:"

Thanks,
Glauco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 17 Apr 2002 08:37:27 +0300

Hi,

> a) If a ServiceChange is issued for ROOT termination MGC will think that all terminations are up and, until another ServiceChange is issued taking the defective Termination out of service, a call c…

I don't agree. A ServiceChange for ROOT will indicate that the MG is up, not specific terminations. You would then have to send additonal ServiceChange commands, with Reason code 900, for each termination you want to put in-service.

Regards,

Christer Holmberg
Ericsson Finland

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 17 Apr 2002 08:37:27 +0300

Hi,

Regards,

Christer Holmberg
Ericsson Finland

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 17 Apr 2002 10:45:53 +0300

Hi,

>> >         Assuming a Gateway with 2 terminations, one of them is OK
>> and the other is Malfunctioning. How should I proceed if I want to
>> bring just the working termination up (Cold Start)?
>> >
>> > a) If a ServiceChange is issued for ROOT termination MGC will
>> think that all terminations are up and, until another ServiceChange
>> is issued taking the defective Termination out of service, a call
>> could be attempted on that defective termination
>>
>> I don't agree. A ServiceChange for ROOT will indicate that the MG is
>> up, not specific terminations. You would then have to send additonal
>> ServiceChange commands, with Reason code 900, for each termination
>> you want to put in-service.
>>
>
> I don't agree. I think that when the MG issues a Service Change
> Restart the MGC must assume that all terminations are by default up
> and running. So if you have a termination out of service you should
> only send one Service Change Forced for that termination.
> Imagine a MG with 1000 terminations, if you send a Service Change
> Restart for each one you can have avalanche problems. We can suppose
> that a termination out of service is going to
> happen in much less ocassions.

You don't have to send a SeriveChange for each termination. You can use
wildcards.

One possibility could be to specify different meaning of Warm- and Cold
boot also for the MG startup. If the MGC gets a
ServiceChange/Root/Warmboot we could assume that the terminations are
"in-service", but if we get a ServiceChange/Root/Coldboot the
terminations must be put "in-service" using separate ServiceChanges.
Just some thoughts...

Regards,

Christer Holmberg
Ericsson Finland

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 17 Apr 2002 10:45:53 +0300

Hi,

Regards,

Christer Holmberg
Ericsson Finland

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Wed, 17 Apr 2002 09:22:55 +0200

Hi,

See my comments interleaved

> I don't agree. A ServiceChange for ROOT will indicate that the MG is up, not specific terminations. You would then have to send additonal ServiceChange commands, with Reason code 900, for each term…

I don't agree. I think that when the MG issues a Service Change Restart the MGC must assume that all terminations are by default up and running. So if you have a termination out of service you should only send one Service Change Forced for that
termination.
Imagine a MG with 1000 terminations, if you send a Service Change Restart for each one you can have avalanche problems. We can suppose that a termination out of service is going to
happen in much less ocassions.

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Wed, 17 Apr 2002 09:22:55 +0200

Hi,

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL