Subject: re: Re: [Megaco] (no subject)

From: [email-masked]
Date: Thu, 18 Apr 2002 18:14:50 +0900

hi, Giri and list.

thanks Giri.

your answer is very right. 
but I asking not asking meaning of mode in the individual termination
but the effect of pair of modes in terminations in context whichs abstract
connection.
Topology in context assummed bothway.

In other words, my question can be rewritten this way with respect to real
application.

see below,
                MGC1                     MGC2
                  |                              |
LEX1 ------- MG1 ----------------------MG2-----LEX2
         (originating)           (terminating)

when servicing 1 on 1 voice call,
if needed to open onyway connection from LEX2 to LEX1,
(only lex2 can transfer its data over IP network to lex1)
Can we specify modes in localcontrol descriptor like below?
        In MG1,                                                            
   pstn term. :  send only/sendreceive
   ephemeral term. : recv only
       In MG2,
   pstn term. : recv only
   ephemeral term. : send only

thanks in advance.

Hi, 
Extract from the draft draft-ietf-megaco-h248v2-00.txt. 
Notice the word highlighted with ^^^^^^.
   "The allowed values for the mode property are send-only, receive- 
   only, send/receive, inactive and loop-back.  "Send" and "receive" 
   are with respect to the exterior of the context, so that, for 
						   ^^^^^^^^ 
   example, a stream set to mode=sendonly does not pass received media 
   into the context. The default value for the mode property is 
   "Iactive"."
So the mode talks about the media entering or leaving the context at this 
termination. 
send-only - Media is allowed to go outside of the context at this
termination 
but not inside. 
recv-only - Media is allowed to go inside of the context at this
termination but 
not outside.
See for Giri for my inline comments.
> [email-masked] wrote: 
> 
> hi, list 
> 
> 
> 
> I have some questions about mode in localcontrol descriptor. 
> could you please clear my head? 
> see following examples(let's assume this can be happened in Trunking
gateway 
> using IP Packet network) 
> 
>								  ctx1 
>						   -------------------------
- 
> pstn network --	 pstn term ---  eph term		 --- IP
network 
>						   -------------------------
- 
> 
> 
> 
>	 pstn term.		  ephemeral term. 
> ------------------------------------------------------------------------- 
>	   recv only		 recv only		    ---1) 
>	   recv only		 send only		   ---2) 
>	   recv only		 sendreceive	    ---3) 
>	   send only	    recv only		    ---4) 
>	   send only	    send only		   ---5) 
>	   send only	    sendreceive	    --6) 
>	   sendreceive	 recv only		    --7) 
>	   sendreceive	 send only		   --8) 
>	   sendreceive	 sendreceive	   --9) 
> 
> 
> follwoing the way of undestanding is correct? 
> 
> 1) means 
>    It can receive data from LEX, but can not transfer over IP to peer MG.
[Giri] Your first part of the understanding is true.
>    It can receive data from peer MG, but can not transfer to PSTN
network. 
[Giri] Stream Mode at pstn term = recv only, implies 
	   PSTN termination can only recieve media from LEX into the 
	   context. Nothing more than that. It doesn't say whether it 
	   can/can't transfer over IP to peer MG.
	   And similarly the Stream Mode at eph term = recv only, implies 
	   EPH termination can only receive media from peer MG into the 
	   context. Nothing more than that. It doesn't say whether it 
	   can/can't transfer to PSTN network.
Hope this clears your doubt. 
Thanks, 
Giri 
-- 
Giri Rajasekhar Saladi 
HCL Technologies Ltd., 
51, Jawaharlal Nehru Road 
Guindy Industrial Estate, 
Ekkatuthangal, 
Chennai - 600 097.

Phone Off : +91 44 233 4174 or +91 44 233 4181 Extn. 233 
Fax : +91 44 234 4256 
e-mail : [email-masked] <mailto:[email-masked]>

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Thu, 18 Apr 2002 14:56:58 +0530

Hi,
	Think, we can specify. But do we need to use "send-recieve" on the pstn
termination at MG1, when we want to only send data to LEX1. Any specific reason?
Regds.,
Giri

> send-only - Media is allowed to go outside of the context at this termination
> but not inside.
> recv-only - Media is allowed to go inside of the context at this termination
> but
> not outside.
> > see following examples(let's assume this can be happened in Trunking gateway
> 
> > using IP Packet network)
> >
> >                                                                 ctx1
> >                                                  --------------------------
> >                                                  --------------------------
> >
> >
> >
> >    It can receive data from peer MG, but can not transfer to PSTN network.
> >

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Thu, 18 Apr 2002 14:56:58 +0530

Hi,

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,