Subject: RE: [Megaco] Local/Remote descriptors and Permanent terminations

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 2 Apr 2002 16:24:56 -0500

I've had a message pointing out the existence of
draft-ietf-avt-rtp-cn-05.txt.  Specifying this payload type as well as G.711
would indicate the use of silence suppression implicitly.  That covers RTP
transport.  For ATM we have the a=silenceSupp attribute defined in RFC 3108.
Do we need anything for TDM?

-----Original Message-----
From: Carl Rutter [mailto:[email-masked]]
Sent: Tuesday, April 02, 2002 3:19 PM
To: 'Chuong N. Nguyen'
Cc: [email-masked]
Subject: RE: [Megaco] Local/Remote descriptors and Permanent terminations

Chuong,
 
There was several ideas bouncing around but I don't believe
there was any closure.  There is a hole for G711 since we can't use 
annexa or annexb.
Lifting the support in RFC 3108, section 5.6.3.2 and putting it into
the TDM Circuit Package would give us a lot of flexibility.
 
Here are the ideas I know of:
1)
Another option is to extend the TDM Circuit Package (which has been
previously discussed on the list). The TDM Cicruit Package
currently has Gain and Echo Control as its properties. So, it's logical
(IMO) for Silence Suppression to be part of the package as
well. In fact, it looks like an oversight that it was missed off in the
first place.
Regards,
Wayne Cutler
2)
Another possibility is to use payload 13 as defined in
draft-ietf-avt-rtp-cn-05.  E.g.: 
Media={Stream=1{ Local { 
v=0 
c=IN IP4 $ 
m=audio $ RTP/AVP 0 13 
}}}
David Barr 
3)
I'm starting to think that the answer may be to use the a=silenceSupp 
attribute defined in RFC 3108, section 5.6.3.2. 
Tom Taylor
 
Carl
-----Original Message-----
From: Chuong N. Nguyen [mailto:[email-masked]]
Sent: Tuesday, April 02, 2002 2:59 PM
Cc: [email-masked]
Subject: Re: [Megaco] Local/Remote descriptors and Permanent terminations

So what was that discussion about adding silence suppression to TDM package?

Do we use SDP TDM or TDM package or both? 
Or even worse combination of both within 1 command w/some parameters defined
by TDM package and 
some parameters defined by SDP TDM. 

Tom-PT Taylor wrote: 
As I noted earlier, you do need to specify the properties in the NAS case. 
The SDP TDM draft has certainly had time to ripen, and I will reissue it and

the NAS packages within the next week. 
-----Original Message----- 
From: Chuong N. Nguyen [mailto:[email-masked]] 
Sent: Tuesday, April 02, 2002 2:48 PM 
To: [email-masked] 
Subject: Re: [Megaco] Local/Remote descriptors and Permanent terminations 
  
I don't know about the sendrecv issue here. 
I don't know what you mean by SDP parameters are of no significance in case 
of phy. term. 
Tom wrote the SDP TDM draft which I wonder what is the status of this draft.

But I can't remember now whether it was intended to be used in local or 
localControl Descriptor. 
  
Madhu Babu Brahmanapally wrote: 
HI Rajesh/All, 
Not all parameters might be useful for the MG/MGC in case of physical 
terminations. The SDP parameters are of no significance in case of physical 
terminations (in normal scenario). Hence the mode was set to "sendrecv" 
without specifying the local/remote descriptor information. 
Regards 
Madhubabu 
-----Original Message----- 
From: [email-masked] [mailto:[email-masked]]On Behalf Of 
Rajesh N 
Sent: Tuesday, April 02, 2002 11:32 AM 
To: [email-masked] 
Subject: [Megaco] Local/Remote descriptors and Permanent terminations 
Hi, 
Sometime back there was a thread regarding usage of SendRecv mode for an 
ephemeral termination, when Remote Descriptor values are yet to be defined. 
And one of the choices for the MG in such a situation is to reply back with 
error 411, "missing remote or local descriptor". 
I would like to know, what is the significance of this problem w.r.to 
permanent terminations. The example call flow in the draft shows a Modify 
request for a permanent termination, from MGC to MG1, in which mode is set 
as SendRecv and  the Local descriptor values alone are being provided. 
Are local and remote descriptors relevant for physical terminations? If 
yes, where should I get the values from? 
Thanks 
Regards, 
Rajesh N 
_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco 
--- 
[This E-mail was scanned for viruses and is clean.] 
_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco 
-- 
  Alcatel USA, Inc             Internet: [email-masked] 
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613 
  **** The opinions expressed are not those of Alcatel USA, Inc **** 
 
-- 
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Chuong N. Nguyen" <[email-masked]>
Date: Tue, 02 Apr 2002 18:15:34 -0600

> Do we need anything for TDM?

What if someone wanted to make a TDM-TDM, hairpin call?
Would silenceSupp be used for such a call?
If yes, then what?

---

From: "Chuong N. Nguyen" <[email-masked]>
Date: Tue, 02 Apr 2002 18:15:34 -0600

---

From: "Carl Rutter" <[email-masked]>
Date: Tue, 2 Apr 2002 19:51:08 -0500

I can't think of an application where you'd want to do that.
Silence suppression really wouldn't make sense for a TDM-TDM
which is hairpined at the CO.  The DS0 is dedicated.
The advantage of Silent suppression it to limit the RTP traffic on the
IP side, which you wouldn't have in that case.

Maybe if you wanted to inject Comfort Noise instead of background
noice in the TDM-TDM call??

Carl
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Chuong N. Nguyen
  Sent: Tuesday, April 02, 2002 7:16 PM
  To: [email-masked]
  Subject: Re: [Megaco] Local/Remote descriptors and Permanent terminations

  Tom-PT Taylor wrote:
    I've had a message pointing out the existence of
    draft-ietf-avt-rtp-cn-05.txt.  Specifying this payload type as well as
G.711
    would indicate the use of silence suppression implicitly.  That covers
RTP
    transport.  For ATM we have the a=silenceSupp attribute defined in RFC
3108.
    Do we need anything for TDM?

---

From: "Carl Rutter" <[email-masked]>
Date: Tue, 2 Apr 2002 19:51:08 -0500

Carl
  -----Original Message-----

  Tom-PT Taylor wrote:

---

From: "Carl Rutter" <[email-masked]>
Date: Tue, 2 Apr 2002 20:35:54 -0500

You bring up a good point,
Is/Should Silient Suppression be tied to the TDM package or
SDP TDM, if in fact its really more applicable to the Ephemral side.
If no can think of a good reason then your right it would make more sense to
be in the SDP.
For now we could use 0 13 for G711 and long-term use the ATM approach for
SDP.
Trying to drive towards closure as we have a need to implement this.
Yea, the hairpinning would be in the MG Switch.
Comments?

Carl
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Chuong N. Nguyen
  Sent: Tuesday, April 02, 2002 8:05 PM
  Cc: [email-masked]
  Subject: Re: [Megaco] Local/Remote descriptors and Permanent terminations

  That is what  I initially thought silence suppression was about.
  But then I was told differently.
  It could be applied to TDM.
  If not, then why are we discussing adding silence suppresion to the TDM
package?

  By the way,  I thought TDM-TDM calls are being made at the Gwy too.
  Aren't you guys doing that now?

  Carl Rutter wrote:

    I can't think of an application where you'd want to do that. Silence
suppression really wouldn't make sense for a TDM-TDMwhich is hairpined at
the CO. The DS0 is dedicated. The advantage of Silent suppression it to
limit the RTP traffic on the IP side, which you wouldn't have in that
case.Maybe if you wanted to inject Comfort Noise instead of backgroundnoice
in the TDM-TDM call??Carl
      -----Original Message-----
      From: [email-masked] [mailto:[email-masked]]On Behalf Of
Chuong N. Nguyen
      Sent: Tuesday, April 02, 2002 7:16 PM
      To: [email-masked]
      Subject: Re: [Megaco] Local/Remote descriptors and Permanent
terminations
      Tom-PT Taylor wrote:
        I've had a message pointing out the existence of
        draft-ietf-avt-rtp-cn-05.txt.  Specifying this payload type as well
as G.711
        would indicate the use of silence suppression implicitly.  That
covers RTP
        transport.  For ATM we have the a=silenceSupp attribute defined in
RFC 3108.
        Do we need anything for TDM?

---

From: "Chuong N. Nguyen" <[email-masked]>
Date: Tue, 02 Apr 2002 19:05:01 -0600

If not, then why are we discussing adding silence suppresion to the
TDM package?

Carl Rutter wrote:

> suppression really wouldn't make sense for a TDM-TDMwhich is hairpined
> at the CO. The DS0 is dedicated. The advantage of Silent
> suppression it to limit the RTP traffic on the IP side, which you
> wouldn't have in that case.Maybe if you wanted to inject Comfort Noise
> instead of backgroundnoice in the TDM-TDM call??Carl
>
>      From: [email-masked] [mailto:[email-masked]]On
>      Behalf Of Chuong N. Nguyen

---

From: "Chuong N. Nguyen" <[email-masked]>
Date: Tue, 02 Apr 2002 19:05:01 -0600

---

From: "Carl Rutter" <[email-masked]>
Date: Tue, 2 Apr 2002 20:35:54 -0500

Carl
  -----Original Message-----

  Carl Rutter wrote: