Subject: [Megaco] use of EventBufferDescriptor

From: "ding" <[email-masked]>
Date: Wed, 10 Apr 2002 20:19:42 +0800

hi,

suppose MG receives a EventBufferDescriptor and a EventDescriptor at the same time, and MG's event buffer queue(FIFO queue) is empty. now if some user event is recognized in the EventBufferDescriptor(and not recognized in the EventDescriptor), should MG discard the user event or send it to the FIFO queue?

I think it should be discarded, am i right?

thanks.

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Wed, 10 Apr 2002 15:48:19 +0530

Hi Ding,
	My answer is inline.

> ding wrote:
> 
> hi,
> 
> suppose MG receives a EventBufferDescriptor and a EventDescriptor at the same
> time, and MG's event buffer queue(FIFO queue) is empty. now if some user event

We search for the event against EventBufferDescriptor only if EventBufferControl
is LockStep mode and EventsDescriptor is not active.

> is recognized in the EventBufferDescriptor(and not recognized in the
> EventDescriptor), should MG discard the user event or send it to the FIFO
> queue?

So, if EventBufferControl is LockStep mode &&
                 EventsDescriptor is not active &&
                      event is found in EventBufferDescriptor
    then
       send it to the FIFO queue.

> I think it should be discarded, am i right?

Regds.,
Giri

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,
51, Jawaharlal Nehru Road 
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.

Phone Off : +91 44 233 4174 or +91 44 233 4181 Extn. 233
Fax : +91 44 234 4256
e-mail : [email-masked] <mailto:[email-masked]>

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Wed, 10 Apr 2002 15:48:19 +0530

Hi Ding,
	My answer is inline.

Regds.,
Giri

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,

---

From: "ding" <[email-masked]>
Date: Wed, 10 Apr 2002 21:04:59 +0800

my understanding is that 

when EventBufferControl is LockStep mode &&
                  EventsDescriptor is not active &&
                       event is found in EventBufferDescriptor

the mode to process user event equal to the mode in MGCP when

endpoint is in notification state &&
                QuarantineHandling is "process" and "step".

do you think so?

---

From: "ding" <[email-masked]>
Date: Wed, 10 Apr 2002 21:04:59 +0800

my understanding is that 

do you think so?

---

From: "Watson Ding" <[email-masked]>
Date: Thu, 11 Apr 2002 14:40:25 +0800

when should MG set EventsDescriptor to be inactive?

after received a new EventBufferDescriptor && a new EventBufferControl  with the value LockStep 

or after send a notify command && and no new EventsDescriptor received?

---

From: "Watson Ding" <[email-masked]>
Date: Thu, 11 Apr 2002 14:40:25 +0800

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Thu, 11 Apr 2002 12:30:28 +0530

Hi Watson,
	The latter is true, MG sets the EventsDescriptor to
Inactive, when
1) EventBufferControl is LockStep &&
2) When MG Detected an event and Notified to MGC and yet to
   receive a new EventsDescriptor.

Becomes Active when MG recieves a new EventsDescriptor from
MGC.
Regds.,
Giri

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Thu, 11 Apr 2002 12:30:28 +0530

Hi Watson,

-- 

Giri Rajasekhar Saladi
HCL Technologies Ltd.,