Subject: [Megaco] About RGW PBX application

From: "SRD Wang JuLin" <[email-masked]>
Date: Tue, 30 Apr 2002 16:48:04 +0800

Hi,
 
Currently,we are take consideration of RGW (FXS type)PBX application.I have a question to consult:
Suppose that the caller located in one RGW firstly dial a number to connect to the PBX which are lined to another RGW. After call connected and establish rtp stream,the  PBX will send dialtone directly to the caller  indicating the caller  to dial the ext(callee's) number (callee lined to the PBX).So the caller can send the  ext number to Softswtich in Notify message.(use dtmf inband transfer is another case)But i wonder how can the Softswtich send the ext number to the callee side?Use dg package???
Pls clear my mind about it!
Thanks a lot! 

best  regards 
:-)Jerry Wang 
tel:(8621)58541240 ext 9615 
mailto:[email-masked] 
Shanghai Bell Co.LTD

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 30 Apr 2002 08:43:27 -0400

Why does the callee side need the ext number?  Normally it is up to the MGC
to translate between the called number and a terminationID representing the
called party in the destination RGW.

-----Original Message-----
From: SRD Wang JuLin [mailto:[email-masked]]
Sent: Tuesday, April 30, 2002 4:48 AM
To: An Leurs; Megaco (E-mail); MadhuBabu Brahmanapally (E-mail)
Cc: Albrecht Schwarz; Patrick Villarin; Van Opstal Jan
Subject: [Megaco] About RGW PBX application

Hi,
 
Currently,we are take consideration of RGW (FXS type)PBX application.I have
a question to consult:
Suppose that the caller located in one RGW firstly dial a number to connect
to the PBX which are lined to another RGW. After call connected and
establish rtp stream,the  PBX will send dialtone directly to the caller
indicating the caller  to dial the ext(callee's) number (callee lined to the
PBX).So the caller can send the  ext number to Softswtich in Notify
message.(use dtmf inband transfer is another case)But i wonder how can the
Softswtich send the ext number to the callee side?Use dg package???
Pls clear my mind about it!
Thanks a lot! 
 
best  regards 
JJerry Wang 

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 30 Apr 2002 08:43:27 -0400

-----Original Message-----
From: SRD Wang JuLin [mailto:[email-masked]]
Sent: Tuesday, April 30, 2002 4:48 AM
To: An Leurs; Megaco (E-mail); MadhuBabu Brahmanapally (E-mail)
Cc: Albrecht Schwarz; Patrick Villarin; Van Opstal Jan
Subject: [Megaco] About RGW PBX application

Hi,

best  regards 
JJerry Wang

---

From: Anil Jangam <[email-masked]>
Date: Tue, 30 Apr 2002 18:41:59 +0530

Hi PTT,

this is a typical scenario as follows.
Tel1 --> RGW1 --> Softswitch ---> RGW2 ---> PBX ---> Tel2.
In this case, the PBX is one of the endpoints configured on the RGW2, and
also would have been configured as one of the route in softswitch (I assume
that both the gateways are configured in the same softswitch). Now the call
is assumed to be established between the caller and the callee (in this set
up case, it is PBX), and then once the media is established, PBX would play
a file asking to dial the ext number. Once the PBX receives the digits, it
will send an alert to the ext inside its own network.

The question, here is in the context... how the dialed digits (after the
media is established) are being passed to the PBX. One method is to send the
inband DTMF, which has inherent problems of low frequency signal
transmission (I took the reference of the link:
http://www.cs.columbia.edu/sip/drafts/draft-sinnreich-sigdevctrl-00.txt see
6.2. DTMF Signaling Issues). 

In case of out of band digit transmission, the RGW1 can be programmed to
send NTFY (in case of MGCP) to the softswitch. But I couldn't find out how
the softswitch would inform it to the RGW2, and ultimately to the PBX.

/anil.

> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Tuesday, April 30, 2002 6:13 PM
> To: 'SRD Wang JuLin'; An Leurs; Megaco (E-mail); MadhuBabu 
> Brahmanapally
> (E-mail)
> Subject: RE: [Megaco] About RGW PBX application
> 
>

---

From: Anil Jangam <[email-masked]>
Date: Tue, 30 Apr 2002 18:41:59 +0530

Hi PTT,

/anil.

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 30 Apr 2002 09:22:55 -0400

Occasionally one encounters PBXs where DTMF signalling is used over the
trunks.  I would think it more common these days for the PBX to use PRI,
H.323, or SIP for call signalling.  That means that the linear diagram you
show below looks more like this (in the PRI case):

            Softswitch
            /     \  \
           /Megaco \  \Q.931/IUA/SCTP/IP
          /         \  \
     ----------   ----------
     |  MG1   |   |  MG2   |
     |        |   |        |
     ----------   ----------
         |            |  T1 or E1      --------
        Tel           -----------------|  PBX |
                                       --------

That rightmost line up to the Softswitch is a Sigtran connection carrying
the PRI signalling from the PBX.  The box containing MG2 also incorporates
Signalling Gateway (SG) functionality as defined by RFC 2719.

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]]
Sent: Tuesday, April 30, 2002 9:12 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; 'SRD Wang JuLin'; An Leurs; Megaco
(E-mail); MadhuBabu Brahmanapally (E-mail)
Cc: Albrecht Schwarz; Patrick Villarin; Van Opstal Jan
Subject: RE: [Megaco] About RGW PBX application

Hi PTT,

/anil.

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 30 Apr 2002 09:22:55 -0400

Softswitch
            /     \  \

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]]
Sent: Tuesday, April 30, 2002 9:12 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; 'SRD Wang JuLin'; An Leurs; Megaco

Hi PTT,

/anil.