Subject: [Megaco] about eventbuffer descriptor

From: "付 宏" <[email-masked]>
Date: Wed, 24 Apr 2002 08:40:30 +0800

All,
   In section 7.1.10 of megaco, there is a description about eventbuffer:
    'the Eventbuffer descriptor contains a list of events, with their 
parameters if any, that the MG is requested to detect and buffer when 
eventbufferControl equals LocaStep'
   from the descrition, I think it means the eventbuffer descriptor include 
many request event from MGC and the MG should detect the event by the 
eventbuffer descriptor if the eventbuffercontrol equals LockStep.Is it 
right?

Mark

_________________________________________________________________
免费下载 MSN Explorer：http://explorer.msn.com/lccn/intl.asp

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 23 Apr 2002 21:33:07 -0400

Yes.  When running in LockStep mode the MGC specifies both the Events
Descriptor and the EventBuffer descriptor, and either can contain multiple
events.  The Events Descriptor determines what events are reported, and the
EventBuffer Descriptor determines what events are saved for processing
against the next Events descriptor after an event notification has been
sent.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, April 23, 2002 8:41 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: about eventbuffer descriptor

All,

Mark

_________________________________________________________________
Ãâ·ÑÏÂÔØ MSN Explorer£ºhttp://explorer.msn.com/lccn/intl.asp

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 23 Apr 2002 21:33:07 -0400

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, April 23, 2002 8:41 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: about eventbuffer descriptor

All,

Mark

---

From: [email-masked]
Date: Wed, 24 Apr 2002 09:36:13 +0530

Hello Tom,
     According to a statement in the protocol, Events mentioned in event
descriptor remain active in MG till next event descriptor is received. (An
exception to this is the digit map event). Thus if an MGC wants that none of the
events being detetced at MG be lost, it can send all required events on that
termination in a single event descriptor and then get the events as and when
they are detected at MG without sending a second event descriptor. It can send
the next event descriptor only when subtract is sent. If this is a valid
sequence, then where and why would an MGC use event buffer descriptor and thus a
lockstep mode.

Regards,
- R. Ezhirpavai

"Tom-PT Taylor" <[email-masked]> on 04/24/2002 07:03:07 AM

To:   "'???'" <[email-masked]>
cc:   [email-masked] (bcc: R Ezhirpavai/HSS)

Subject:  [Megaco] RE: about eventbuffer descriptor

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, April 23, 2002 8:41 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: about eventbuffer descriptor

All,

Mark

_________________________________________________________________
???????? MSN Explorer??http://explorer.msn.com/lccn/intl.asp

---

From: [email-masked]
Date: Wed, 24 Apr 2002 09:36:13 +0530

Hello Tom,

Regards,
- R. Ezhirpavai

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, April 23, 2002 8:41 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: about eventbuffer descriptor

All,

Mark

---

From: "付 宏" <[email-masked]>
Date: Wed, 24 Apr 2002 16:21:19 +0800

When running in LockStep mode, If MG detected event which exist in 
EventBuffer, It should put the event in the EventBuffer，Is it right?
    If it is right, Then the EventBuffer include requested event and the 
observedevent, and how can i distinguish them?

Mark

>From: "Tom-PT Taylor"<[email-masked]>
>CC: [email-masked]
>Date: Tue, 23 Apr 2002 21:33:07 -0400
>

_________________________________________________________________
与联机的朋友进行交流，请使用 MSN Messenger: 
http://messenger.microsoft.com/cn

---

From: "付 宏" <[email-masked]>
Date: Wed, 24 Apr 2002 16:21:19 +0800

Mark

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 24 Apr 2002 08:01:22 -0400

Right after the statement you quote is this paragraph:

<quote>
If the value of the EventBufferControl property equals LockStep, following
detection of such an event, normal handling of events is suspended. Any
event which is subsequently detected and occurs in the EventBuffer
Descriptor is added to the end of the EventBuffer (a FIFO queue), along with
the time that it was detected.   The MG SHALL wait for a new
EventsDescriptor to be loaded.  A new EventsDescriptor can be loaded either
as the result of receiving a command with a new EventsDescriptor, or by
activating an embedded EventsDescriptor.
</quote>

Some people wanted Lockstep mode because it guarantees the correct sequence
of event notifications at the MGC if one is using UDP transport.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, April 24, 2002 12:06 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: '???'; [email-masked]
Subject: Re: [Megaco] RE: about eventbuffer descriptor

Hello Tom,
     According to a statement in the protocol, Events mentioned in event
descriptor remain active in MG till next event descriptor is received. (An
exception to this is the digit map event). Thus if an MGC wants that none of
the
events being detetced at MG be lost, it can send all required events on that
termination in a single event descriptor and then get the events as and when
they are detected at MG without sending a second event descriptor. It can
send
the next event descriptor only when subtract is sent. If this is a valid
sequence, then where and why would an MGC use event buffer descriptor and
thus a
lockstep mode.

Regards,
- R. Ezhirpavai

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, April 23, 2002 8:41 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: about eventbuffer descriptor

All,

Mark

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 24 Apr 2002 08:01:22 -0400

<quote>

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, April 24, 2002 12:06 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: '???'; [email-masked]
Subject: Re: [Megaco] RE: about eventbuffer descriptor

Hello Tom,

Regards,
- R. Ezhirpavai

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, April 23, 2002 8:41 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: about eventbuffer descriptor

All,

Mark

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 24 Apr 2002 08:08:07 -0400

You have to keep four different logical concepts separate in your mind.  The
first three are syntactic constructs used in the messaging between the MGC
and MG.  The fourth exists only in the MG.
  (1) the Events Descriptor, naming the events for which the MGC wants
notifications to be generated;
  (2) the EventBuffer DESCRIPTOR, naming the events the MGC wants buffered
during Lockstep mode while waiting for a new Events descriptor;
  (3) the ObservedEvents Descriptor, used in the Notify request to report
observed events to the MGC;
  (4) the EventBuffer, which, unlike the DESCRIPTORs listed above, is a
purely logical concept used to describe MG behaviour during event
processing.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, April 24, 2002 4:21 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: Re: [Megaco] RE: about eventbuffer descriptor

    When running in LockStep mode, If MG detected event which exist in 
EventBuffer, It should put the event in the EventBuffer��Is it right?
    If it is right, Then the EventBuffer include requested event and the 
observedevent, and how can i distinguish them?

Mark

>������� MSN Explorer��http://explorer.msn.com/lccn/intl.asp
>
>

_________________________________________________________________
�����������ѽ��н�������ʹ�� MSN Messenger: 
http://messenger.microsoft.com/cn

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 24 Apr 2002 08:08:07 -0400

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, April 24, 2002 4:21 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: Re: [Megaco] RE: about eventbuffer descriptor

Mark

---

From: "付 宏" <[email-masked]>
Date: Thu, 25 Apr 2002 08:29:09 +0800

Thanks, taylor.

>Subject: RE: [Megaco] RE: about eventbuffer descriptor
>Date: Wed, 24 Apr 2002 08:08:07 -0400
>

---

From: "付 宏" <[email-masked]>
Date: Thu, 25 Apr 2002 08:29:09 +0800

Thanks, taylor.