Subject: [Megaco] Conferencing in MEGACO

From: Fhuval Hittay <[email-masked]>
Date: Mon, 22 Apr 2002 13:05:35 +0400 (MSD)

Could anyone, please, clarify conferencing operations described in 
"draft-ietf-megaco-callflows-00.txt" ? In that document, "FlashHook" is the 
main button to form a conference, but how MGC could know, that "FlashHook" mean 
"form a conference", not a "call transfer" or something else?
 And if in a conference there are more than three participants, what is the 
main actions must perform every participant to enter the conference?
----
  http://www.rambler.ru

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Mon, 22 Apr 2002 20:49:44 +0530

Madhu,
     I beg to differ that MGC would not be aware of it in first hookflash.
According to the service requirement, a subscriber can have either "call
transfer" facility or "Three way calling" facility. Even in call transfer
service, the subscriber can bring the other two into conference after doing a
hookflash. Only difference is the action that follow subscriber going on-hook.
In one case the call is transfered and in other the call is released.

Regards,
- R. Ezhirpavai

"Madhu Babu Brahmanapally" <[email-masked]> on 04/22/2002 08:17:47 PM

To:   "'Fhuval Hittay'" <[email-masked]>, [email-masked]
cc:    (bcc: R Ezhirpavai/HSS)

Subject:  RE: [Megaco] Conferencing in MEGACO

hi Fhuval,
Its true that "flash hook" is the main button or trigger for both "call
transfer" and "conference". Infact there is no difference till party B
getting "connected" to party C. After that based on the User B action the
scenario changes. If the UserB goes onhook, the MGC connects party A and
Party C thus enabling the call transfer. If UserB does a "flash hook", the
MGC connects all the three parties. Even the MGC may not be aware whether
the first "flash hook" is for call transfer of conference.
Regards
Madhubabu.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Fhuval Hittay
Sent: Monday, April 22, 2002 5:06 AM
To: [email-masked]
Subject: [Megaco] Conferencing in MEGACO

main button to form a conference, but how MGC could know, that "FlashHook"
mean

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco
---
[This E-mail was scanned for viruses and is clean.]

---

From: "Mishra, Rajesh" <[email-masked]>
Date: Mon, 22 Apr 2002 19:06:52 -0400

Hello Fhuval!
   I do not see problem with the call flow, to further clarify let's take the following example:

A calls B and they are in session.

then B does Hook Flash

at this time (assuming B has subscribed to any of the flash based services) the voice path between A and B will be broken and 
B will be fed secondary dial tone. A is put on hold.

Please note that at this we do not attach any meaning to the flash (whether TWC or CT) at this time.

now B dials a new number (let's say C) and B and C are in conversation state.

Now B's flash has lot's of  different meaning depending on how services are implemented 

e.g. : 1. One can implement flash from B meaning conf among A, B & C typical north American style.
        2. Other options could be flash followed by digit 1 means  B talking to A and C is put on hold then Flash followed by digit 2 means B talking to C again and A is put on hold.  Flash followed by digit 3 mean conf.

Typically in north America conf is flash (as in case 1) and transfer is B goes on hook while talking to C in that case A is transferred to C.

So it really depends on how services are implemented.

regards,
Rajesh Mishra

-----Original Message-----
From: Madhu Babu Brahmanapally [mailto:[email-masked]]
Sent: Monday, April 22, 2002 10:48 AM
To: 'Fhuval Hittay'; [email-masked]
Subject: RE: [Megaco] Conferencing in MEGACO

hi Fhuval,

---

From: "Mishra, Rajesh" <[email-masked]>
Date: Mon, 22 Apr 2002 19:06:52 -0400

Hello Fhuval!

then B does Hook Flash

regards,
Rajesh Mishra

-----Original Message-----
From: Madhu Babu Brahmanapally [mailto:[email-masked]]
Sent: Monday, April 22, 2002 10:48 AM
To: 'Fhuval Hittay'; [email-masked]
Subject: RE: [Megaco] Conferencing in MEGACO

hi Fhuval,

---

From: [email-masked]
Date: Tue, 23 Apr 2002 09:30:07 +0530

Hello Madhu,
     By "Service Requirement" I mean the service specifications of these
services. It disallows both these services for single subscriber as the exchange
(MGC in our case) should know whether the subscriber wants to transfer the call
or clear the call when the subscriber invoking the conference disconnects the
call.

Regards,
- R. Ezhirpavai

"Madhu Babu Brahmanapally" <[email-masked]> on 04/23/2002 03:37:02 AM

To:   R Ezhirpavai/HSS@HSS
cc:   "'Fhuval Hittay'" <[email-masked]>, [email-masked]

HI Pavai,
What is this "service requirement" that disallows a user from having both
the call transfer and 3 way calling feature???
Regards
Madhubabu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, April 22, 2002 11:20 AM
To: Madhu Babu Brahmanapally
Cc: 'Fhuval Hittay'; [email-masked]
Subject: RE: [Megaco] Conferencing in MEGACO

Madhu,
     I beg to differ that MGC would not be aware of it in first hookflash.
According to the service requirement, a subscriber can have either "call
transfer" facility or "Three way calling" facility. Even in call transfer
service, the subscriber can bring the other two into conference after doing
a
hookflash. Only difference is the action that follow subscriber going
on-hook.
In one case the call is transfered and in other the call is released.

Regards,
- R. Ezhirpavai

hi Fhuval,

-----Original Message-----

---

---

From: [email-masked]
Date: Tue, 23 Apr 2002 09:30:07 +0530

Hello Madhu,

Regards,
- R. Ezhirpavai

To:   R Ezhirpavai/HSS@HSS

HI Pavai,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, April 22, 2002 11:20 AM
To: Madhu Babu Brahmanapally
Cc: 'Fhuval Hittay'; [email-masked]
Subject: RE: [Megaco] Conferencing in MEGACO

Madhu,

Regards,
- R. Ezhirpavai

hi Fhuval,

-----Original Message-----

---

---

From: asrar ashraf <[email-masked]>
Date: Thu, 25 Apr 2002 17:07:46 +0500

hello List!
  Is it protocol compliance requirement that Same sequence as specified in
Madhu-babu's draft, be followed for Creation/Modification of Ephemeral Terms
for 3-Way Calling(Conferencing) OR instead We can use any Sequence remaining
in Limits of Megaco.
  That is instead of
        1)	EphA-PhysA and EphB-PhysB Creation
        2)  At First Flash, EphA(Recv Only), EphC-PhysC Creation and Eph-B
(Modify Remote)
	  3)  At Second Flash,
		i) Fisrt EphD-PhyC creation and EphE-PhyA creation  and Then

		ii)Secondly EphF-PhyB Creation and EphA (Modify-SendRecv).
  Can We Do
	 1)	EphA-PhysA and EphB-PhysB Creation
       2)   At First Flash, not Do EphA(Recv Only), EphC-PhysC Creation and
instead of Eph-B (Modify Remote), Create EphF- 
            PhysB
	 3)   At Second Flash,
		i) Fisrt EphD-PhyC creation and EphE-PhyA creation  and no
need for EphA (Modify-SendRecv). 

Regards
Asrar

-----Original Message-----
[email-masked]
Sent: Tuesday, April 23, 2002 9:00 AM

Hello Madhu,
     By "Service Requirement" I mean the service specifications of these
services. It disallows both these services for single subscriber as the
exchange
(MGC in our case) should know whether the subscriber wants to transfer the
call
or clear the call when the subscriber invoking the conference disconnects
the
call.

Regards,
- R. Ezhirpavai

To:   R Ezhirpavai/HSS@HSS

HI Pavai,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, April 22, 2002 11:20 AM
To: Madhu Babu Brahmanapally
Cc: 'Fhuval Hittay'; [email-masked]
Subject: RE: [Megaco] Conferencing in MEGACO

Madhu,

Regards,
- R. Ezhirpavai

hi Fhuval,

-----Original Message-----

---

---

From: [email-masked]
Date: Thu, 25 Apr 2002 14:12:18 -0400

And in fact you wouldn't necessarily want to do it that way for large
conferences. The number of terminations per context and the number of media
streams connecting the participants both go up as the square of the number
of participants. That is, (n^2 + n)/2, for n participants. Of course one
could argue that voice activity detection would mitigate the need for a lot
of bandwidth, statistically speaking.

However, the call flows for conferencing do work well for completely
distributed conferencing with a small number of participants.

- Dave

David Franklin
Principal Software Engineer
NMS Communications
[email-masked]
tel. +1.508.271.1038

                      "Madhu Babu                                                            
                      Brahmanapally"           To:       "'asrar ashraf'"                    
                      <madhubabu@kenete         <[email-masked]>, <[email-masked]>      
                      c.com>                   cc:                                           
                      Sent by:                 Subject:  RE: [Megaco] Conferencing in MEGACO 
                      megaco-admin@ietf                                                      
                      .org                                                                   

                      04/25/02 01:34 PM                                                      

HI Asrar,All,
The call flow draft is to illustrate sample messages between MGC and MG for
different call scenarios. There is no requirement that the same sequence
need to be followed.

Regards
Madhubabu Brahmanapally.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
asrar ashraf
Sent: Thursday, April 25, 2002 8:08 AM
To: [email-masked]
Subject: RE: [Megaco] Conferencing in MEGACO

hello List!
  Is it protocol compliance requirement that Same sequence as specified in
Madhu-babu's draft, be followed for Creation/Modification of Ephemeral
Terms
for 3-Way Calling(Conferencing) OR instead We can use any Sequence
remaining
in Limits of Megaco.
  That is instead of
        1)  EphA-PhysA and EphB-PhysB Creation
        2)  At First Flash, EphA(Recv Only), EphC-PhysC Creation and Eph-B
(Modify Remote)
   3)  At Second Flash,
  i) Fisrt EphD-PhyC creation and EphE-PhyA creation  and Then

Regards
Asrar

-----Original Message-----

Hello Madhu,

Regards,
- R. Ezhirpavai

"Madhu Babu Brahmanapally" <[email-masked]> on 04/23/2002 03:37:02
AM

To:   R Ezhirpavai/HSS@HSS

HI Pavai,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, April 22, 2002 11:20 AM
To: Madhu Babu Brahmanapally
Cc: 'Fhuval Hittay'; [email-masked]
Subject: RE: [Megaco] Conferencing in MEGACO

Madhu,

Regards,
- R. Ezhirpavai

"Madhu Babu Brahmanapally" <[email-masked]> on 04/22/2002 08:17:47
PM

hi Fhuval,

-----Original Message-----

---

---

From: [email-masked]
Date: Thu, 25 Apr 2002 14:12:18 -0400

- Dave

David Franklin

                      "Madhu Babu                                                            

                      04/25/02 01:34 PM                                                      

HI Asrar,All,

Regards
Madhubabu Brahmanapally.

-----Original Message-----

hello List!

Regards
Asrar

-----Original Message-----

Hello Madhu,

Regards,
- R. Ezhirpavai

To:   R Ezhirpavai/HSS@HSS

HI Pavai,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, April 22, 2002 11:20 AM
To: Madhu Babu Brahmanapally
Cc: 'Fhuval Hittay'; [email-masked]
Subject: RE: [Megaco] Conferencing in MEGACO

Madhu,

Regards,
- R. Ezhirpavai

hi Fhuval,

-----Original Message-----

---