Subject: [Megaco] About mdeia negociation

From: "Jackson.liu" <[email-masked]>
Date: Mon, 22 Apr 2002 17:30:23 +0800

Dear Taylor:
   I have some questions about media negociation. Would you so kind to solve the problerms?
   For instance, before establishing RTP connection, media negociation should be done. MG1 suports PCMA ,and ptime = 20, 30, 40 can be choosed.At the same time MG1 supports G.723 ,and ptime = 20, 40 can be supported. MG2 suports PCMA ,and ptime = 30, 40 can be choosed.At the same time MG2 supports G.722 ,and ptime = 40 can be supported. How can MG2 get the media capability of MG1's RTP port.
Do you think the following procedure is right or not? Let's highlight at the SDP session:
Step1:
    MGC to MG1:
          Local{
                       v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP $
                    }
Step2:
    MG1 to MGC:
              Local{
                      v=0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 8
                      a=ptime:20
                      v=0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 8
                      a=ptime:30
                      v=0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 8
                      a=ptime:40
                      v=0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 4
                      a=ptime:30
                      v=0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 4
                      a=ptime:40
                     }
Step 3:
     MGC to MG2
                   Local{
                      v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP 8
                      a=ptime:20
                      v=0
                      c=IN IP4  $
                      m=audio $ RTP/AVP 8
                      a=ptime:30
                      v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP 8
                      a=ptime:40
                     v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP 4
                      a=ptime:30
                      v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP 4
                      a=ptime:40
                       }        
Step3:
    MG2 to MGC:
              Local{
                      v=0
                      c=IN IP4 209.110.59.34
                      m=audio 1050 RTP/AVP 8
                      a=ptime:30  
                       }      
Step 4 
     MGC to MG1:
              remote{
                      v=0
                      c=IN IP4 209.110.59.34
                      m=audio 1050 RTP/AVP 8
                      a=ptime:30  
                           }

    It seems so clumsy to negotiate media information in this way. Is there any other efficient method?

Best Regards

Jackson.liu

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Mon, 22 Apr 2002 15:52:46 -0400

Half of the clumsiness can be eliminated.  We require the MG to send
SDP-conformant Local and Remote descriptors to the MGC, so the latter can
pass them on unchanged when using SIP.  (But SIP puts a limit on the
information that can be exchanged which means the MGC has to do some editing
in any event.)  However, in the MGC to MG direction we can use ranges, for
one thing, so your third message from MGC to MG2 can be shortened to:

 Local{
                      v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP 8
                      a=ptime:[20:40]
                     v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP 4
                      a=ptime:[30:40]
                       } 

-----Original Message-----
From: Jackson.liu [mailto:[email-masked]]
Sent: Monday, April 22, 2002 5:30 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: About mdeia negociation

Dear Taylor:
   I have some questions about media negociation. Would you so kind to solve
the problerms?
   For instance, before establishing RTP connection, media negociation
should be done. MG1 suports PCMA ,and ptime = 20, 30, 40 can be choosed.At
the same time MG1 supports G.723 ,and ptime = 20, 40 can be supported. MG2
suports PCMA ,and ptime = 30, 40 can be choosed.At the same time MG2
supports G.722 ,and ptime = 40 can be supported. How can MG2 get the media
capability of MG1's RTP port.
Do you think the following procedure is right or not? Let's highlight at the
SDP session:
Step1:
    MGC to MG1:
          Local{
                       v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP $
                    }
Step2:
    MG1 to MGC:
              Local{
                      v=0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 8
                      a=ptime:20
                      v=0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 8
                      a=ptime:30
                      v=0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 8
                      a=ptime:40
                      v=0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 4
                      a=ptime:30
                      v=0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 4
                      a=ptime:40
                     }
Step 3:
     MGC to MG2
                   Local{
                      v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP 8
                      a=ptime:20
                      v=0
                      c=IN IP4  $
                      m=audio $ RTP/AVP 8
                      a=ptime:30
                      v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP 8
                      a=ptime:40
                     v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP 4
                      a=ptime:30
                      v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP 4
                      a=ptime:40
                       }        
Step3:
    MG2 to MGC:
              Local{
                      v=0
                      c=IN IP4 209.110.59.34
                      m=audio 1050 RTP/AVP 8
                      a=ptime:30  
                       }      
Step 4 
     MGC to MG1:
              remote{
                      v=0
                      c=IN IP4 209.110.59.34
                      m=audio 1050 RTP/AVP 8
                      a=ptime:30  
                           }

    It seems so clumsy to negotiate media information in this way. Is there
any other efficient method?

Best Regards

Jackson.liu

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Mon, 22 Apr 2002 15:52:46 -0400

Local{
                      v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP 8
                      a=ptime:[20:40]
                     v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP 4
                      a=ptime:[30:40]
                       } 

-----Original Message-----
From: Jackson.liu [mailto:[email-masked]]
Sent: Monday, April 22, 2002 5:30 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: [email-masked]
Subject: About mdeia negociation

Dear Taylor:

Best Regards

Jackson.liu

---

From: "SRD Wang JuLin" <[email-masked]>
Date: Tue, 23 Apr 2002 13:02:41 +0800

Hi,
I would prefer that MGC exchange the caller and callee 's codec info using local and remote media descriptor.Just as Ian Leighton had commented.
While anther way is that MGC hold the GWs' media info provisioned statically.So when net payload is heavy,it can specify the codec both slave  side supported.

best  regards
> :-)Jerry Wang
tel:(8621)58541240 ext 9615
mailto:[email-masked]
Shanghai Bell Co.LTD

-----Original Message-----
From: Ian Leighton [mailto:[email-masked]]
Sent: Monday, April 22, 2002 11:48 PM
To: Jackson.liu
Cc: [email-masked]
Subject: Re: [Megaco] About mdeia negociation

Hi Jackson

As an alternative the message from MGC to MG2 in step 3 could include a Local descriptor with $ in the c line <connection-address > field and $ in the <port> and <fmt> fields of the m line. Also the Local descriptor from MG1 could be encoded in the Remote descriptor to MG2. For example

     MGC to MG2
          Local{
                       v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP $
                    }
           Remote{
                      v=0
                      o=- blah blah blah
                      s=-
                      t=0 0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 8
                      a=ptime:20
                      v=0
                      o=- blah blah blah
                      s=-
                      t=0 0
                     c=IN IP4  209.110.59.33
                      m=audio 1000 RTP/AVP 8
                      a=ptime:30
                      v=0
                       o=- blah blah blah
                      s=-
                      t=0 0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 8
                      a=ptime:40
                     v=0
                       o=- blah blah blah
                      s=-
                      t=0 0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 4
                      a=ptime:30
                      v=0
                       o=- blah blah blah
                      s=-
                      t=0 0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 4
                      a=ptime:40
                       }

In other words the MGC requests MG2 to select its Local characteristics based one of the alternatives included in the Remote Descriptor.

Also note that I have added the o, t and s lines which should be included in SDP's sent from the MG.

Regards
Ian Leighton

---

From: "SRD Wang JuLin" <[email-masked]>
Date: Tue, 23 Apr 2002 13:02:41 +0800

Hi,

best  regards

-----Original Message-----
From: Ian Leighton [mailto:[email-masked]]
Sent: Monday, April 22, 2002 11:48 PM
To: Jackson.liu
Cc: [email-masked]
Subject: Re: [Megaco] About mdeia negociation

Hi Jackson

     MGC to MG2
          Local{
                       v=0
                      c=IN IP4 $
                      m=audio $ RTP/AVP $
                    }
           Remote{
                      v=0
                      o=- blah blah blah
                      s=-
                      t=0 0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 8
                      a=ptime:20
                      v=0
                      o=- blah blah blah
                      s=-
                      t=0 0
                     c=IN IP4  209.110.59.33
                      m=audio 1000 RTP/AVP 8
                      a=ptime:30
                      v=0
                       o=- blah blah blah
                      s=-
                      t=0 0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 8
                      a=ptime:40
                     v=0
                       o=- blah blah blah
                      s=-
                      t=0 0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 4
                      a=ptime:30
                      v=0
                       o=- blah blah blah
                      s=-
                      t=0 0
                      c=IN IP4 209.110.59.33
                      m=audio 1000 RTP/AVP 4
                      a=ptime:40
                       }

Regards
Ian Leighton