Subject: [Megaco] Audit & contextTerminationAudit??

From: Anil Jangam <[email-masked]>
Date: Wed, 24 Apr 2002 11:19:37 +0530

Hi,

1. How one should use/issue the 'Audit' command from the MGC persepective?
Is it necesary to 'Audit' the endpoint/gateway every time before a call
initiated? 

2. In the 'AuditValue' return parameter in the 'auditReply' what is the
'contextTerminationAudit' return option? Under what circumstances,  the
Audit command would return it and what are implications/effects of this
return on the actual call processing/control?

I am not able to understand the meaning of the 'contextTerminationAudit' and
couldn't proceed to change the call handling state machine.

Regds,
/anil.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 24 Apr 2002 08:53:05 -0400

Hi.  Answers marked with [PTT].

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]]
Sent: Wednesday, April 24, 2002 1:50 AM
To: [email-masked]'
Subject: [Megaco] Audit & contextTerminationAudit??

Hi,

[PTT]
In my opinion, audits should be used in two ways:
 - at startup of an association or after the MGC recognizes a discontinuity
or inconsistency, to (re)synchronize state between the MG and MGC
 - as a low-level continuously running background task, to assure state
consistency between the MG and MGC.

[PTT]
Look in section 7.2.5, paragraph beginning "EventBuffer returns the set of
events and associated parameter values ...", final three sentences.

Regds,
/anil.

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 24 Apr 2002 08:53:05 -0400

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]]
Sent: Wednesday, April 24, 2002 1:50 AM
To: [email-masked]'
Subject: [Megaco] Audit & contextTerminationAudit??

Hi,

[PTT]

[PTT]

Regds,
/anil.