Subject: Re: [MEGACO] what does list of signals mean?

From: Narine_Mossikyan <[email-masked]>
Date: Mon, 01 Apr 2002 10:47:11 +0400

It is indicated SigID=cg/rt in your sample, in this case cg signal's rt parameter
is simple. My question is if  I have SigID=pt/tl, where tl is tone id list, should
I enumerate tl's parameters too, or not? I mean will the syntax of SigID=pt/tl  be
correct if I will  not use  tl tone list parameters?

thanks for your advice
P.S. "sit" is not a parameter of "g" event. How could you explain the meaning of
g/sit you used in your sample?

Terry L Anderson wrote:

> An example would be
> End of a signal, say an ringtone
>     ObservedEvents = 2345 {20010329T11501000:g/sit{SigID=cg/rt, Meth=TO,
> SLID=NotInServiceAnnouncement}}
> If the signal had been part of a signal list, then the signal list ID is also
> returned as shown, otherwise it would be omitted.
>
> For example, if the signal was started by a signals descriptor like:
> Signals { SignalList = NotInServiceAnnouncement {
>     cg/sit {NotifyCompletion={TimeOut,IntByEvent,OtherReason}},
>     an/apf {an=NotInService, av=English, NotifyCompletion={TimeOut, IntByEvent,
> OtherReason}},
> }}
>
> End of the sit tone would be notified as above.
>
> Narine_Mossikyan wrote:
>
> > Hi ,
> > Thanks for your quick response.
> > I still don't  understand what does observedEventsDescriptor's last parameter
> > mean? Can you give me some examples of observedEventsDescriptor?
> > thanks a lot for your help
> >
> > Terry L Anderson wrote:
> >
> > > The original text was ambiguous and was recently amended to clarify this
> > > parameter.  The change first appeared in the Implementors Guide but was
> > > included in H.248v1 Corrigendum 1 and H.248v2 as consented in Geneva Feb
> > > 2002.  Here is the current text:
> > >
> > > ObservedEvents Descriptor parameters:
> > > Signal Identity
> > > ParameterID:  SigID (0x0001)
> > > This parameter identifies the signal which has terminated. For a signal
> > > that is contained in a signal list the signal list identity parameter
> > > should also be returned indicating the appropriate list.
> > > Type: Binary: octet (string), Text: string
> > > Possible values: a signal which has terminated.  A signal shall be
> > > identified using the pkgdName syntax without wildcarding.
> > >
> > > Narine_Mossikyan wrote:
> > >
> > > > Hi,
> > > > I found the list of signals on the page#139,  RFC 3015 Megaco Protocol
> > > > Version 1.0,  November 2000 , in Section Generic packages , E.1.2.
> > > > Events .
> > > > ObservedEvents Descriptor parameters:
> > > >         Signal Identity
> > > >         ParameterID:  SigID (0x0001)
> > > >         This parameter identifies the signals which have terminated.
> > > >         Type: list
> > > > My question is:
> > > > Should I implement  list of  signals as it is describe in the same RFC,
> > > > page #107 ?
> > > >         signalList           = SignalListToken EQUAL signalListId LBRKT
> > > >                           signalListParm *(COMMA signalListParm) RBRKT
> > > > or the list of signals in ObservedEvents has another meaning?
> > > > thanks for your help
> > > >
> > > > _______________________________________________
> > > > Megaco mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/megaco
> > >
> > > --
> > >
> > > ------------------------------------------------------------
> > > Terry L Anderson             mailto:[email-masked]
> > > Tel:732.949.5628   Fax:732.949.7016
> > > Lucent Technologies/INS/Voice Over IP Access Networks
> > > Rm 2G-219A, 101 Crawfords Corner Rd, Holmdel, NJ 07733-3030
> > > http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla
>
> --
>
> ------------------------------------------------------------
> Terry L Anderson             mailto:[email-masked]
> Tel:732.949.5628   Fax:732.949.7016
> Lucent Technologies/INS/Voice Over IP Access Networks
> Rm 2G-219A, 101 Crawfords Corner Rd, Holmdel, NJ 07733-3030
> http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Narine_Mossikyan <[email-masked]>
Date: Mon, 01 Apr 2002 10:47:11 +0400

thanks for your advice

---

From: Terry L Anderson <[email-masked]>
Date: Mon, 01 Apr 2002 09:54:11 -0500

> correct if I will  not use  tl tone list parameters?

We currently have a way to indicate the name of a signal that completed but not the
name of a parameter to that signal.  That would not seem to be a problem when only one
instance of a given signal is active (even if it has a parameter).  In your example, I
don't think there is a problem as a signal
    Signals{tonegen/pt{tl=2,4,6}}
has only one "signal".  That signal is a sequence of tones, but is one signal and so
completion will be notified only after the entire signal (all tones in sequence) are
complete).

But if more than one instance of a signal with varying parameter values are active
there is currently no way to indicate which completed.  That is, if the signal were:
    Signals{
    tonegen/pt{tl=1{Duration=1 } },
    tonegen/pt{tl=3{Duration=2 } }
    }    ; play 1 and 3 simultaneously
There would be no way to indicate in a notify which one completed.  Of course it would
be more usual to play single DTMF tones using the distinct events rather than
tonegen/pt.  If one played the above as
    Signals{
    dg/d1{Duration=1},
    dg/d3{Duration=2}
}
There would be no problem.  However, there may well be useful cases where more than
one instance of a given named signal (with distinct parameter values) is played
simultaneously.  Do folks think we need a way to notify which completed?

> g/sit you used in your sample?

I'm sorry, I mistyped.  I meant g/sc event in ObservedEvents.  I did use cg/sit
further down, but did not mean 'sit' in the ObservedEvents.

--
-------------------------------------------------------
Terry L Anderson, DMTS                   [email-masked]
Lucent Technologies /INS/ Voice over IP Access Networks
Rm 2B-121,   600 Mountain Ave, Murray Hill, NJ 07974
Voice:908 582-7013  FAX:908 582-6226   Org:18E75000000
http://its.lucent.com/~tla  (Lucent internal)
http://www.gti.net/tla
-------------------------------------------------------

---

From: Terry L Anderson <[email-masked]>
Date: Mon, 01 Apr 2002 09:54:11 -0500

---

From: Narine_Mossikyan <[email-masked]>
Date: Tue, 02 Apr 2002 11:27:27 +0400

Your samples were about Signals Descriptor. Can I say that SigID=tonegen/pt{t1=2,4,5} for
ObservedEvent is useful too?
I mean,
is the following ObservedEvent  syntactical correct?
    ObservedEvents = 2345 {20010329T11501000:g/sc{SigID=tonegen/pt{t1=2,4,5},    Meth=TO
}}
if not, could you give me a correct one?
thanks a lot

---

From: Narine_Mossikyan <[email-masked]>
Date: Tue, 02 Apr 2002 11:27:27 +0400

---

From: Terry L Anderson <[email-masked]>
Date: Tue, 02 Apr 2002 11:52:13 -0500

> if not, could you give me a correct one?

no.  tonegen/pt is the signal.  The parameter to sc only takes a signal.  It does not include
any parameters to that signal.  The syntax is specified for text encoding as pkgdName which (
PackageName SLASH ItemID ) The wildcard alternative is not allowed.
But the event would not be sent until the entire signal (all three digits in sequence) is
complete.

--

---

From: Terry L Anderson <[email-masked]>
Date: Tue, 02 Apr 2002 11:52:13 -0500

--