Subject: [Megaco] Silence Suppression Attribute

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 2 Apr 2002 16:10:41 -0500

The issue of how to signal silence suppression capability keeps coming up on
the Megaco list.  The situation is fairly complicated:
 - some codecs come with a pre-defined capability for silence suppression.
This capability can be invoked by the appropriate MIME type parameter as
defined in draft-ietf-avt-rtp-mime-06.txt.  That draft is specific to RTP
transport, arguably over UDP only.
 - other codecs like G.711 have no such parameter, yet silence suppression
is possible
 - RFC 3108 defined an a=silenceSupp attribute, but it applies to ATM
transport only.

How would people feel about allowing the a=silenceSupp parameter to be used
independently of the transport type?

Tom Taylor
[email-masked]
Ph. +1 613 736 0961 (ESN 396 1490)

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 3 Apr 2002 18:58:17 -0500

Is this a workable assumption?

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]]
Sent: Wednesday, April 03, 2002 6:56 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Dan Firac; [email-masked]
Subject: Re: [MMUSIC] Silence Suppression Attribute 

If you're using RTP, it's assumed that silence suppression is possible (and
since receivers have to cope with packet loss anyway, this doesn't add any
significant complexity). 

Colin

--> "Tom-PT Taylor" writes:
>The caller supports G.711 with voice activity detection and silence
>suppression and would like to make that offer.  There is no PCM parameter
>indicating this mode of operation.
>
>-----Original Message-----
>From: Colin Perkins [mailto:[email-masked]]
>Sent: Wednesday, April 03, 2002 6:23 PM
>To: Dan Firac
>Cc: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]
>Subject: Re: [MMUSIC] Silence Suppression Attribute 
>
>
>What would be the scenario where the new attribute is used? 
>Colin
>
>
>--> "Dan Firac" writes:
>>It's a very good ideea.
>>Anyway, why this attribute was defined for ATM transport type only?
>>Silence suppression, as you pointed below, is an attribute of a codec
>>and has nothing to do with transport.
>>
>>Dan Firac,
>>Software Engineer,
>>RedlineCommunications,
>>Romania.
>>
>>
>>
>>
>>----- Original Message -----
>>From: "Tom-PT Taylor" <[email-masked]>
>>To: <[email-masked]>; <[email-masked]>
>>Sent: Wednesday, April 03, 2002 12:10 AM
>>Subject: [MMUSIC] Silence Suppression Attribute
>>
>>
>>> The issue of how to signal silence suppression capability keeps coming
up
>>on
>>> mmusic mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/mmusic
>>
>>
>>mmusic mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/mmusic

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 3 Apr 2002 18:58:17 -0500

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]]
Sent: Wednesday, April 03, 2002 6:56 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Dan Firac; [email-masked]
Subject: Re: [MMUSIC] Silence Suppression Attribute 

Colin

up

---

From: Dan Elbert <[email-masked]>
Date: Thu, 04 Apr 2002 10:16:50 +0300

I think is a good idea
By the way, if an attribute is registred for use in SDP I don't think there
is a scope limitation, anybody can effectively use it.

Dan Elbert
RADVISION

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Wednesday, April 03, 2002 12:11 AM
To: [email-masked]; [email-masked]'
Subject: [Megaco] Silence Suppression Attribute

Tom Taylor

---

From: Dan Elbert <[email-masked]>
Date: Thu, 04 Apr 2002 10:16:50 +0300

I think is a good idea

Dan Elbert
RADVISION

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Wednesday, April 03, 2002 12:11 AM
To: [email-masked]; [email-masked]'
Subject: [Megaco] Silence Suppression Attribute

Tom Taylor

---

From: Carl Rutter <[email-masked]>
Date: Thu, 4 Apr 2002 08:51:09 -0500

Could you clarify what the assumtion is,
Is it,
That its OK to assume that any MG should be able to handle 
Silent Suppression?

Carl

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]]
Sent: Wednesday, April 03, 2002 6:56 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Dan Firac; [email-masked]
Subject: Re: [MMUSIC] Silence Suppression Attribute 

Colin

up

---

From: Carl Rutter <[email-masked]>
Date: Thu, 4 Apr 2002 08:51:09 -0500

Carl

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]]
Sent: Wednesday, April 03, 2002 6:56 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Dan Firac; [email-masked]
Subject: Re: [MMUSIC] Silence Suppression Attribute 

Colin

up

---

From: [email-masked]
Date: Thu, 4 Apr 2002 19:37:05 +0530

Hi
   I have a doubt in this assumption that a handling packet loss would have a
limit. I mean the MG (DSP) can handle the packet loss upto a certain extent only
and the silence period may be a long one. If the silence suppression is on and
the DSP is indicated so it will generate Comfort Noise, which it might not in
case of packet loss where it might try to replay/reconstruct the previous voice
frames.

Regards
Sarika

Carl Rutter <[email-masked]> on 04/04/2002 07:21:09 PM

To:   "'Tom-PT Taylor'" <[email-masked]>, "[email-masked]'"
      <[email-masked]>
cc:    (bcc: Sarika Gupta/HSS)

Subject:  RE: [Megaco] FW: [MMUSIC] Silence Suppression Attribute

Carl

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]]
Sent: Wednesday, April 03, 2002 6:56 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Dan Firac; [email-masked]
Subject: Re: [MMUSIC] Silence Suppression Attribute

Colin

up

---

From: [email-masked]
Date: Thu, 4 Apr 2002 19:37:05 +0530

Hi

Regards
Sarika

Carl

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]]
Sent: Wednesday, April 03, 2002 6:56 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Dan Firac; [email-masked]
Subject: Re: [MMUSIC] Silence Suppression Attribute

Colin

up

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 4 Apr 2002 10:34:23 -0500

That's right.  In fact, Stephen Casner made the point forcefully: the real
issue is how to turn off silence suppression (if there is a requirement).
Dan Firac has expressed such a requirement on the MMUSIC list.  We'll see
what comes of the discussion.

-----Original Message-----
From: Carl Rutter [mailto:[email-masked]]
Sent: Thursday, April 04, 2002 8:51 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]'
Subject: RE: [Megaco] FW: [MMUSIC] Silence Suppression Attribute

Carl

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]]
Sent: Wednesday, April 03, 2002 6:56 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Dan Firac; [email-masked]
Subject: Re: [MMUSIC] Silence Suppression Attribute 

Colin

up

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 4 Apr 2002 10:34:23 -0500

-----Original Message-----
From: Carl Rutter [mailto:[email-masked]]
Sent: Thursday, April 04, 2002 8:51 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]; [email-masked]'
Subject: RE: [Megaco] FW: [MMUSIC] Silence Suppression Attribute

Carl

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]]
Sent: Wednesday, April 03, 2002 6:56 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Dan Firac; [email-masked]
Subject: Re: [MMUSIC] Silence Suppression Attribute 

Colin

up

---

From: Carl Rutter <[email-masked]>
Date: Thu, 4 Apr 2002 11:07:48 -0500

I'll have to agree with Sarika on this
that from the DSPs perspective 
they are different cases as he stated.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, April 04, 2002 9:07 AM
To: Carl Rutter
Cc: 'Tom-PT Taylor'; [email-masked]'
Subject: RE: [Megaco] FW: [MMUSIC] Silence Suppression Attribute

Hi
   I have a doubt in this assumption that a handling packet loss would have
a
limit. I mean the MG (DSP) can handle the packet loss upto a certain extent
only
and the silence period may be a long one. If the silence suppression is on
and
the DSP is indicated so it will generate Comfort Noise, which it might not
in
case of packet loss where it might try to replay/reconstruct the previous
voice
frames.

Regards
Sarika

Carl

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]]
Sent: Wednesday, April 03, 2002 6:56 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Dan Firac; [email-masked]
Subject: Re: [MMUSIC] Silence Suppression Attribute

Colin

up

---

From: Carl Rutter <[email-masked]>
Date: Thu, 4 Apr 2002 11:07:48 -0500

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, April 04, 2002 9:07 AM
To: Carl Rutter
Cc: 'Tom-PT Taylor'; [email-masked]'
Subject: RE: [Megaco] FW: [MMUSIC] Silence Suppression Attribute

Hi

Regards
Sarika

Carl

-----Original Message-----
From: Colin Perkins [mailto:[email-masked]]
Sent: Wednesday, April 03, 2002 6:56 PM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: Dan Firac; [email-masked]
Subject: Re: [MMUSIC] Silence Suppression Attribute

Colin

up