Subject: [Megaco] Re: Unique ContextId and TerminationId?

From: Y Hu <[email-masked]>
Date: Thu, 4 Apr 2002 03:11:05 -0800 (PST)

Hi,

According to the spec, the ContextID is unique to
identify the action, but the context ID is assigned by
the MG. When the MGC sends a first action request to
the MG, it uses a null context ID. How can the MGC
maintain the action identification uniquely with the
null Context ID? How can the MGC match a reply action
to the original request action as the context ID has 
been changed (assigned by the MG)?

Also, the termination ID is provisioned at MG, does
the MGC has the knowledge of the termination IDs
before sending request, or does the MGC reply the MG
to assign the termination ID as well?

Thank you.

yh

__________________________________________________
Do You Yahoo!?
Yahoo! Tax Center - online filing with TurboTax
http://taxes.yahoo.com/

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Carl Rutter <[email-masked]>
Date: Thu, 4 Apr 2002 07:57:53 -0500

As far as the Termination ID its something
agreed upon(provisioned) between the MG & MGC.

AS far as the first question, usually the MGC will
use CHOOSE for the Context and the MG will create 
a unique one, if I understand your question correctly.

Carl
-----Original Message-----
From: Y Hu [mailto:[email-masked]]
Sent: Thursday, April 04, 2002 6:11 AM
To: [email-masked]
Subject: [Megaco] Re: Unique ContextId and TerminationId?

Hi,

Thank you.

yh

---

From: Carl Rutter <[email-masked]>
Date: Thu, 4 Apr 2002 07:57:53 -0500

Carl
-----Original Message-----
From: Y Hu [mailto:[email-masked]]
Sent: Thursday, April 04, 2002 6:11 AM
To: [email-masked]
Subject: [Megaco] Re: Unique ContextId and TerminationId?

Hi,

Thank you.

yh

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 4 Apr 2002 11:02:44 -0500

On your first point, the matching is done via the TransactionID.  The reply
to the transaction is matched against the request and the returned contextID
is picked up based on the position of the action in the response.

On your second point, the MGC has to be provisioned with at least some
knowledge of terminationIDs in the MG, so it knows how to handle calls
involving them and so it can route to them.

-----Original Message-----
From: Y Hu [mailto:[email-masked]]
Sent: Thursday, April 04, 2002 6:11 AM
To: [email-masked]
Subject: [Megaco] Re: Unique ContextId and TerminationId?

Hi,

Thank you.

yh

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 4 Apr 2002 11:02:44 -0500

-----Original Message-----
From: Y Hu [mailto:[email-masked]]
Sent: Thursday, April 04, 2002 6:11 AM
To: [email-masked]
Subject: [Megaco] Re: Unique ContextId and TerminationId?

Hi,

Thank you.

yh

---

From: Y Hu <[email-masked]>
Date: Thu, 4 Apr 2002 14:56:28 -0800 (PST)

Thanks Tom and Terry,

> On your second point, the MGC has to be provisioned 
> with at least some knowledge of terminationIDs in
the > MG, so it knows how to handle calls involving
them 
> and so it can route to them.

In other words, the termination ID is assigned by the
MGC actually, thus it maintains its uniqueness through
out the whole process unlike the context ID. Is that
correct?

Thank you.

At 11:02 AM 4/04/2002 -0500, Tom-PT Taylor wrote:
On your first point, the matching is done via the
TransactionID.  The reply
to the transaction is matched against the request and
the returned contextID
is picked up based on the position of the action in
the response.

On your second point, the MGC has to be provisioned
with at least some
knowledge of terminationIDs in the MG, so it knows how
to handle calls
involving them and so it can route to them.

---

From: Y Hu <[email-masked]>
Date: Thu, 4 Apr 2002 14:56:28 -0800 (PST)

Thanks Tom and Terry,

Thank you.

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 4 Apr 2002 18:38:32 -0500

We're talking physical terminations here, I assume.  I'll put it this way:
the MG is provisioned with the terminationIDs.  The MGC also knows the
terminationIDs, and can specify them in its requests.  If the terminations
concerned are lines, the MGC has to have a table matching up the line
terminationIDs with telephone numbers and all sorts of other information.
If the terminations are trunks, the MGC has to have (conceptually) a list of
which terminationIDs belong to which trunk groups.  I'm using the traffic
engineering definition of a trunk group here, as a set of circuits all
eligible to carry the same parcel of traffic.

-----Original Message-----
From: Y Hu [mailto:[email-masked]]
Sent: Thursday, April 04, 2002 5:56 PM
To: [email-masked]
Cc: Taylor, Tom-PT [CAR:B800:EXCH]
Subject: Re: Unique ContextId and TerminationId?

Thanks Tom and Terry,

Thank you.

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 4 Apr 2002 18:38:32 -0500

-----Original Message-----
From: Y Hu [mailto:[email-masked]]
Sent: Thursday, April 04, 2002 5:56 PM
To: [email-masked]
Cc: Taylor, Tom-PT [CAR:B800:EXCH]
Subject: Re: Unique ContextId and TerminationId?

Thanks Tom and Terry,

Thank you.