Subject: RE: [Megaco] ServiceChange for a single termination (Cold Start)

From: "Barcotti, Glauco" <[email-masked]>
Date: Wed, 17 Apr 2002 10:10:23 -0400

Hi,

>>         Assuming a Gateway with 2 terminations, one of >them is OK and the other is Malfunctioning. How should I >proceed if I want to bring just the working termination >up (Cold Start)?
>>
>> a) If a ServiceChange is issued for ROOT termination MGC will think that all terminations are up and, until another ServiceChange is issued taking the defective Termination out of service, a call could be attempted on that defective termination

>I don't agree. A ServiceChange for ROOT will indicate that the MG is up, not specific terminations. You would then have to send additonal ServiceChange commands, with Reason code 900, for each termination you want to put in-service.

The example in the spec (Appendix A) and the draft-madhu-megaco-callflows-00.txt tell me that when I address ROOT on a ServiceChange all terminations are addressed (One ServiceChange ROOT is sent and the terminations are available to use). Where did you find information about ServiceChange ROOT not bringing all terminations up? 

Thanks,
Glauco

>Regards,

>hrister Holmberg
>ricsson Finland

>
>
> b) If a ServiceChange is issued just for the working Termination The ability to redirect the gateway to another MGC will be lost (See quotation from spec below)
>
> "The return from ServiceChange is empty except when the Root terminationID is used.  In that case it includes the following parameters as required:"
>
> Thanks,
> Glauco
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 18 Apr 2002 08:53:15 +0300

Hi,

> The example in the spec (Appendix A) and the draft-madhu-megaco-callflows-00.txt tell me that when I address ROOT on a ServiceChange all terminations are addressed (One ServiceChange ROOT is sent a…

Assume my MG comes up, but for whatever reason I don't have TDM interface card X available, so those timeslots/terminations are not available. Now, to tell the MGC that there are two options:

1. I configure the MGC manually not to use those terminations.

2. The MGC will have to do Audit to find out which terminations are in servce.

Now, I don't like option 1.

And, when card X is put back into service, or I put a new card in my MG, there will have to be ServiceChanges for those terminations anyway, because I don't think we can assume the MGC to Audit the MG all the time.

Also, if I have a very big MG it may take different time before all interfaces are up. But, I still want to start using some interfaces, so I don't want to wait with the registration ServiceChange until all interfaces are up. But, again, the MGC would now have to start doing frequent Audits, to find out which interfaces are up, and
which are not, until it realizes all terminations are up.

Chapter 6.2.5 defines that the ROOT specify the whole MG, rather than specific terminations. My understanding is that it does NOT say that includes the terminations. Also, how would you define the difference between TerminationID=ROOT and TerminationID=ALL???

Also, IF ROOT would include all terminations, why am I not to send a Subtract with ContextID=ALL and TerminationID=ROOT???

Regards,

Christer Holmberg
Ericsson Finland

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 18 Apr 2002 08:53:15 +0300

Hi,

Regards,

Christer Holmberg
Ericsson Finland

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 18 Apr 2002 10:08:22 +0300

Hi,

>> Hi,
>>
>> > Hi,
>> >
>> > >>         Assuming a Gateway with 2 terminations, one of >them is
>> OK and the other is Malfunctioning. How should I >proceed if I want
>> to bring just the working termination >up (Cold Start)?
>> > >>
>> > >> a) If a ServiceChange is issued for ROOT termination MGC will
>> think that all terminations are up and, until another ServiceChange
>> is issued taking the defective Termination out of service, a call
>> could be attempted on that defective termination
>> >
>> > >I don't agree. A ServiceChange for ROOT will indicate that the MG
>> is up, not specific terminations. You would then have to send
>> additonal ServiceChange commands, with Reason code 900, for each
>> termination you want to put in-service.
>> >
>> > The example in the spec (Appendix A) and the
>> draft-madhu-megaco-callflows-00.txt tell me that when I address ROOT
>> on a ServiceChange all terminations are addressed (One ServiceChange
>> ROOT is sent and the terminations are available to use). Where did
>> you find information about ServiceChange ROOT not bringing all
>> terminations up?
>>
>> Assume my MG comes up, but for whatever reason I don't have TDM
>> interface card X available, so those timeslots/terminations are not
>> available. Now, to tell the MGC that there are two options:
>>
> There is a third option:
>     3. Assume all terminations are up. The MG will send SVC (Forced)
> only for those termination down (the ones on the card x)

Yes, but those terminations may be up in 10 seconds, which is a very
long time in a PSTN environment, so then it would have to send a new SVC
to put them back into service...

>> And, when card X is put back into service, or I put a new card in my
>> MG, there will have to be ServiceChanges for those terminations
>> anyway, because I don't think we can assume the MGC to Audit the MG
>> all the time.
>
>
>     The MGC does not need to audit anything it knows now what
> terminations are up (by default)

Are you sure? I may use my MGC with different MGs. Yes, the termination
naming has to be the same in both MGs, so that the MGC knows which
terminationID is associated with witch timeslot, trunk etc, but the
number of timeslots/interfaces may be different.

> and which ones down (due to the SVC(Forced) ).

Again, card X may come up within 10 seconds, card Y within 20 seconds
etc etc. How does it make all simpler by having to send SVC twice -
first to remote them, and 10 seconds later to put them back????

Regards,

Christer Holmberg
Ericsson Finland

>  If the card restores the service a SVGC (Restart) will be sent only
> for the terminations on the Card X. The process is simpler than
> sending a restart for all terminations in the system
>     on startup.
>
>>
>>
>> Also, if I have a very big MG it may take different time before all
>> interfaces are up. But, I still want to start using some interfaces,
>> so I don't want to wait with the registration ServiceChange until
>> all interfaces are up. But, again, the MGC would now have to start
>> doing frequent Audits, to find out which interfaces are up, and
>> Chapter 6.2.5 defines that the ROOT specify the whole MG, rather
>> than specific terminations. My understanding is that it does NOT say
>> that includes the terminations. Also, how would you define the
>> difference between TerminationID=ROOT and TerminationID=ALL???
>>
>> Also, IF ROOT would include all terminations, why am I not to send a
>> Subtract with ContextID=ALL and TerminationID=ROOT???
>>
>> Regards,
>>
>> Christer Holmberg
>> Ericsson Finland
>>
>> >
>> >
>> > Thanks,
>> > Glauco
>> >
>> > >Regards,
>> >
>> > >hrister Holmberg
>> > >ricsson Finland
>> >
>> > >
>> > >
>> > > b) If a ServiceChange is issued just for the working Termination
>> The ability to redirect the gateway to another MGC will be lost (See
>> quotation from spec below)
>> > >
>> > > "The return from ServiceChange is empty except when the Root
>> terminationID is used.  In that case it includes the following
>> parameters as required:"
>> > >
>> > > Thanks,
>> > > Glauco
>> > >
> Regards
> Fernando
> --
> Fernando Vallejo Lazaro
> Phone:  +34 91 330 8279
> SW  Wireline ASD-Madrid
>        ALCATEL

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 18 Apr 2002 10:08:22 +0300

Hi,

Regards,

Christer Holmberg
Ericsson Finland

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Thu, 18 Apr 2002 08:46:10 +0200

Hi,
See comments interleaved

There is a third option:

    3. Assume all terminations are up. The MG will send SVC (Forced) only for those termination down (the ones on the card x)

> And, when card X is put back into service, or I put a new card in my MG, there will have to be ServiceChanges for those terminations anyway, because I don't think we can assume the MGC to Audit the…

    The MGC does not need to audit anything it knows now what terminations are up (by default) and which ones down (due to the SVC(Forced) ).
    If the card restores the service a SVGC (Restart) will be sent only for the terminations on the Card X. The process is simpler than sending a restart for all terminations in the system
    on startup.

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL

---

From: Fernando Vallejo Lazaro <[email-masked]>
Date: Thu, 18 Apr 2002 08:46:10 +0200

Hi,
See comments interleaved

There is a third option:

Regards
Fernando

--
Fernando Vallejo Lazaro
Phone:  +34 91 330 8279
SW  Wireline ASD-Madrid
       ALCATEL