Subject: [Megaco] Disabling all Events

From: "Sudhir Kumar Appana" <[email-masked]>
Date: Wed, 10 Apr 2002 16:44:10 +0530

Hi,

Is MGC can send the following packet to disable all Events that were
previously
activated:

Transaction = 1 {
       Context = - {
           Modify = TermA {
               Events             ; just events token
        }
    }
}

Is the above packet is a valid. As far as syntax is considered, it is valid.

As far as I know, just Events token will be used by MG as a reply to
AuditValue Transaction if no Event(s) were activated.

Thanks,
Sudhir

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Dan Elbert <[email-masked]>
Date: Wed, 10 Apr 2002 15:52:34 +0300

You are right, sorry to confuse you.

Dan

-----Original Message-----
From: Sudhir Kumar Appana [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 3:36 PM
To: 'Dan Elbert'; [email-masked]
Cc: Sudhir (E-mail)
Subject: RE: [Megaco] Disabling all Events

Hi Dan,
According to ABNF Syntax,

eventsDescriptor     = EventsToken [ EQUAL RequestID LBRKT
                       requestedEvent *( COMMA requestedEvent ) RBRKT ]

So "Events {}" is not according to syntax.

But for signals, "Signals {}" is a valid.

Reply back.
Thanks,
Sudhir

-----Original Message-----
From: Dan Elbert [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 4:48 PM
To: [email-masked]'; [email-masked]'
Subject: RE: [Megaco] Disabling all Events

You are supposed to send empty event list

Transaction = 1 {
       Context = - {
           Modify = TermA {
               Events  {}           ; just events token
        }
    }
}

this will disable all event detection

Dan Elbert
RADVISION

-----Original Message-----
From: Sudhir Kumar Appana [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 2:14 PM
To: [email-masked]
Cc: Sudhir (E-mail)
Subject: [Megaco] Disabling all Events

Hi,

Transaction = 1 {
       Context = - {
           Modify = TermA {

Thanks,
Sudhir

---

From: Dan Elbert <[email-masked]>
Date: Wed, 10 Apr 2002 15:52:34 +0300

Dan

-----Original Message-----
From: Sudhir Kumar Appana [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 3:36 PM
To: 'Dan Elbert'; [email-masked]
Cc: Sudhir (E-mail)
Subject: RE: [Megaco] Disabling all Events

Hi Dan,

Reply back.
Thanks,
Sudhir

-----Original Message-----
From: Dan Elbert [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 4:48 PM
To: [email-masked]'; [email-masked]'
Subject: RE: [Megaco] Disabling all Events

Transaction = 1 {
       Context = - {
           Modify = TermA {

Dan Elbert
RADVISION

-----Original Message-----
From: Sudhir Kumar Appana [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 2:14 PM
To: [email-masked]
Cc: Sudhir (E-mail)
Subject: [Megaco] Disabling all Events

Hi,

Transaction = 1 {
       Context = - {
           Modify = TermA {

Thanks,
Sudhir

---

From: "Sudhir Kumar Appana" <[email-masked]>
Date: Wed, 10 Apr 2002 23:42:36 +0530

Tom,
Can you reply for this doubt.
Thanks,
Sudhir

-----Original Message-----
From: Sudhir Kumar Appana [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 4:44 PM
To: [email-masked]
Cc: Sudhir (E-mail)
Subject: Disabling all Events

Hi,

Transaction = 1 {
       Context = - {
           Modify = TermA {

Thanks,
Sudhir

---

From: "Sudhir Kumar Appana" <[email-masked]>
Date: Wed, 10 Apr 2002 23:42:36 +0530

Tom,

-----Original Message-----
From: Sudhir Kumar Appana [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 4:44 PM
To: [email-masked]
Cc: Sudhir (E-mail)
Subject: Disabling all Events

Hi,

Transaction = 1 {
       Context = - {
           Modify = TermA {

Thanks,
Sudhir

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 10 Apr 2002 18:30:12 -0400

I'm surprised no one has brought this up before, though I have the vaguest
memory of a discussion a couple of years ago in which I favoured this
syntax.  (Whether I did or not, it looks a bit irregular to me now.)  It
certainly appears that you are right, but perhaps it is an item for an
Implementor's Guide correction in the syntax to allow the empty braces.

-----Original Message-----
From: Sudhir Kumar Appana [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 2:13 PM
To: [email-masked]
Cc: Sudhir (E-mail)
Subject: [Megaco] FW: Disabling all Events

Tom,

-----Original Message-----
From: Sudhir Kumar Appana [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 4:44 PM
To: [email-masked]
Cc: Sudhir (E-mail)
Subject: Disabling all Events

Hi,

Transaction = 1 {
       Context = - {
           Modify = TermA {

Thanks,
Sudhir

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 11 Apr 2002 22:57:58 -0400

Yes, I remember now, and I'm guilty of not following through.  Brian Rosen
is the only one I remember responding.

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Thursday, April 11, 2002 3:20 PM
To: Terry L Anderson
Cc: [email-masked]
Subject: Re: [Megaco] FW: Disabling all Events

Terry L Anderson wrote:
> 
> This was discussed and the syntax was changed through the implementors
guide to
> this form rather than an empty {}.  The issue was avoiding the need for a
> RequestID when no real event is being specified.  The alternative would
have
> been
>     Events = 1234 {}
> But since there would be no event to tigger a notify it seems pointless to
> allocate the id.  Allowing
>     Event {}
> with no '=' would be too much of a deviation in form

Terry,

This reminds me...
Last June I pointed out that the change to which you are
referring (IG 6.79) broke the ABNF in a fairly serious way.

Here's an example.  The EventsToken below could be
one of two things.

MEGACO/1 [135.114.123.123]:1234
Reply = 5000 {
  Context = 1 {
    Add = t1 {
      Events    ; this could be an empty eventsDescriptor
                ; OR an auditItem
    }
  }
}

Last October, at your suggestion, I tried to revive the
thread, but no one responded.  Below I am attaching the 
last post on the subject.

-troy

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Thu, 11 Apr 2002 22:57:58 -0400

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]]
Sent: Thursday, April 11, 2002 3:20 PM
To: Terry L Anderson
Cc: [email-masked]
Subject: Re: [Megaco] FW: Disabling all Events

guide to
have

Terry,

This reminds me...

-troy