Subject: [Megaco] NOTIFICATION - medGwyInvalidControllerAddress

From: "Venkatesh A" <[email-masked]>
Date: Thu, 18 Apr 2002 12:34:02 +0530

Hi All,

This is regarding the NOTIFICATION medGwyInvalidControllerAddress in megaco
mib.  The draft says that this notfication has to be raised whenever a
message is received from a controller that did not match any one valid
controller IP address.  Here what is meant by "invalid controller" ???  Does
it mean to say the mgc should be present in the pre provisioned list with
mg?  In case of mg running on UDP, mg is not keeping the ip address of mgc
whom it is talking to.  It simply replies to the mgc from where the request
came.  So, when / how should this NOTIFICATION be raised?

Thanks
Venkatesh

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 18 Apr 2002 13:51:07 -0400

The MG should have a list of its primary MGC and secondary MGCs. Thus
identifying whether the request has been originated from the active
controller. Whether its TCP/UDP the MG need this information as, it has to
fall back to other MGCs in case of failure of its primary MGC.
Regards
Madhubabu Brahmanapally.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Venkatesh A
Sent: Thursday, April 18, 2002 3:04 AM
To: [email-masked]
Subject: [Megaco] NOTIFICATION - medGwyInvalidControllerAddress

Hi All,

Thanks
Venkatesh

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco
---
[This E-mail was scanned for viruses and is clean.]

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Thu, 18 Apr 2002 13:51:07 -0400

-----Original Message-----

Hi All,

Thanks
Venkatesh

---

From: "Balasubramanian Pitchandi" <[email-masked]>
Date: Thu, 18 Apr 2002 14:05:08 -0400

The MG is provisioned with a list of Media Gateway Controllers through
"medGwyGatewayControllerTable" and if the MG receives a message from any
other MGC than the one provisioned in the
"medGwyGatewayControllerTable", it would send this NOTIFICATION (Trap -
medGwyInvalidControllerAddress) to the NMS Manager.

Thanks
Bala

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Venkatesh A
Sent: Thursday, April 18, 2002 3:04 AM
To: [email-masked]
Subject: [Megaco] NOTIFICATION - medGwyInvalidControllerAddress

Hi All,

This is regarding the NOTIFICATION medGwyInvalidControllerAddress in
megaco mib.  The draft says that this notfication has to be raised
whenever a message is received from a controller that did not match any
one valid controller IP address.  Here what is meant by "invalid
controller" ???  Does it mean to say the mgc should be present in the
pre provisioned list with mg?  In case of mg running on UDP, mg is not
keeping the ip address of mgc whom it is talking to.  It simply replies
to the mgc from where the request came.  So, when / how should this
NOTIFICATION be raised?

Thanks
Venkatesh

---

From: "Balasubramanian Pitchandi" <[email-masked]>
Date: Thu, 18 Apr 2002 14:05:08 -0400

Thanks
Bala

-----Original Message-----

Hi All,

Thanks
Venkatesh

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Fri, 19 Apr 2002 14:25:55 +0530

Hi Bala/All,
	Are the list of provisioned MGCs and the list of active
MGCs same? I thought that the controller table corresponds to the
list of provisioned MGCs of all virtual MGs. And at any given point
of time, one(atmost) MGC of this list shall be active per virtual
MG. Such one active MGC per every virtual MG form the list of
active MGCs. Is my understanding correct?
Thanks & Regds.,
Giri

---

From: Giri Rajasekhar Saladi <[email-masked]>
Date: Fri, 19 Apr 2002 14:25:55 +0530

Hi Bala/All,

---

From: "Balasubramanian Pitchandi" <[email-masked]>
Date: Fri, 19 Apr 2002 12:27:43 -0400

The list of provisioned MGCs is a superset of list of active MGCs. In
other words, all provisioned MGCs need not be active at all the time.
And your understanding is correct about 'atmost one active MGC per
virtual MG' and they all combine to form the list of active MGCs.

The provisioned MGCs are created/maintained by the NMS to instruct the
MG to contact them in case they cannot communicate with the primary
(active) MGC.

Thanks
Bala

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Giri Rajasekhar Saladi
Sent: Friday, April 19, 2002 4:56 AM
To: Balasubramanian Pitchandi
Cc: [email-masked]
Subject: Re: [Megaco] NOTIFICATION - medGwyInvalidControllerAddress

Hi Bala/All,
	Are the list of provisioned MGCs and the list of active
MGCs same? I thought that the controller table corresponds to the list
of provisioned MGCs of all virtual MGs. And at any given point of time,
one(atmost) MGC of this list shall be active per virtual MG. Such one
active MGC per every virtual MG form the list of active MGCs. Is my
understanding correct? Thanks & Regds., Giri Balasubramanian Pitchandi

> "medGwyGatewayControllerTable" and if the MG receives a message from 
> any other MGC than the one provisioned in the 
> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Venkatesh A
> whenever a message is received from a controller that did not match 
> any one valid controller IP address.  Here what is meant by "invalid 

> keeping the ip address of mgc whom it is talking to.  It simply 
> replies to the mgc from where the request came.  So, when / how should

> this NOTIFICATION be raised?
> 
> Thanks
> Venkatesh
>

---

From: "Balasubramanian Pitchandi" <[email-masked]>
Date: Fri, 19 Apr 2002 12:27:43 -0400

Thanks
Bala

-----Original Message-----

Hi Bala/All,