Subject: Re: [Megaco] Problem with Dgitmap event

From: mukta vasudeva <[email-masked]>
Date: Tue, 14 Jan 2003 05:24:54 +0000 (GMT)

hi,
Thanks for your response. 
You are right about MG dumping the  event (as per processing requirements) ,if the events decriptor for that event is not there.But maybe i didnt frame my question right:
Q: If MG terminations  support R2 Package then, considering the given scenario,which eventof this Package would the MGC use for the notification of the last rejected event. Because the current dial string would be sent as notification for the R2Address Event.
Actually i cannot find any such event in the R2 Package which could be used for such a purpose.So does such an event exist in R2 Package through which a single collected digit could be sent back to the MGC? 
In any case your solution applies to the MG : if events descriptor is not there,dump the event.
regards ,
Mukta V.
 
 amaresh_ram <[email-masked]> wrote:
hi,

Find my comment inline as [Amaresh].

regards,

Amaresh

"=?iso-8859-1?q?mukta=20vasudeva?=" wrote: 

Hi,

I have another problem:

The RFC states that:

“If 

      no candidates remain, the latest event is removed from the 

      current dial string and a completion event is generated 

      indicating full match if one of the candidates from the previous 

      step was fully satisfied before the latest event was detected, or 

      partial match otherwise. The event removed from the current dial 

      string will then be reported as per the currently active event 

      processing mechanisms.”

 [Amaresh] This highlighted text is rephrased in the 2nd version of Megaco and it state that the event removed from the current dial string will then be reported a separate event, buffered, or discarded according to the rules described in the previous section.

Please refer to the Highlighted part: 

Q: Lets say the MG has received Message from MGC telling it to activate detection of  R2/R2Address event of the R2 Package (or it could be the DTMF Package :dd/ce completion event.).

In either case when it is found that the last event is generating a Full Match,.then the Current Dial String is sent as an Observed Parameter of the Notify generated corresponding to the R2Address event.

Now , the event that is mentioned in the highlighted region is the problem. How does the MG send This Event’s Notification? 

It is mentioned that MG uses the “currently active event processing mechanisms.”

   This implies that we cannot send this event without the activation from MGC. [Amaresh] Dump this event as no event descriptor is active.
   For the DTMF Package this is ok, since the MGC would activate detection of the Digits Event –wildcarded with choose. 

      3.But in case of R2 Package Which event would the MGC use to ask for this event’s notification? I could not find any event in R2 package which could be used for the purpose. [Amaresh] Same as 1.

Thanks,

Mukta Vasudeva

 Catch all the cricket action. Download Yahoo! Score tracker

---------------------------------
Get Your Private, Free E-mail from Indiatimes at http://email.indiatimes.com
Buy the best in Movies at http://www.videos.indiatimes.com
Now bid just 7 Days in Advance and get Huge Discounts on Indian Airlines Flights. So log on to http://indianairlines.indiatimes.com and Bid Now ! 
Catch all the cricket action. Download Yahoo! Score tracker

---

From: mukta vasudeva <[email-masked]>
Date: Tue, 14 Jan 2003 05:24:54 +0000 (GMT)

hi,

regards,

Amaresh

Hi,

I have another problem:

The RFC states that:

“If 

      processing mechanisms.”

Thanks,

Mukta Vasudeva