Subject: [Megaco] Events detection in LockStep mode

From: [email-masked]
Date: Wed, 15 Jan 2003 11:39:34 +0200

Hello,
When receiving a new Events Descriptor and EBC=LockStep, the MG has to send
Notify message.
Let's say there are already 4-5 events in the buffer, which all appear in
current Events Descriptor.
Should the Notify message include all the events from the buffer or only
the first one of them which appears in the Events Descriptor?

Regards,

Dana H.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 15 Jan 2003 09:14:11 -0500

Section 7.1.9 Case 1 2(a) is quite clear on this: a single event is reported
and the MG awaits a new Events Descriptor before taking further action.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Wednesday, January 15, 2003 4:40 AM
> To: [email-masked]
> Subject: [Megaco] Events detection in LockStep mode
> 
> 
> Hello,
> When receiving a new Events Descriptor and EBC=LockStep, the 
> MG has to send Notify message. Let's say there are already 
> 4-5 events in the buffer, which all appear in current Events 
> Descriptor. Should the Notify message include all the events 
> from the buffer or only the first one of them which appears 
> in the Events Descriptor?
> 
> Regards,
> 
> Dana H.
> 
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 15 Jan 2003 09:14:11 -0500

---

From: [email-masked]
Date: Thu, 16 Jan 2003 11:36:55 +0200

Thanks for replying. The RFC also says:

The MG may report several events in a single Transaction as long as
   this does not unnecessarily delay the reporting of individual events.

Does it mean reporting same events which happened as a result of same
trigger?

Dana H.

                      "Tom-PT Taylor"                                                                                                  
                      <taylor@nortelne         To:      "[email-masked]'" <[email-masked]>, [email-masked] 
                      tworks.com>              cc:                                                                                     
                                               Subject: RE: [Megaco] Events detection in LockStep mode                                 
                      15/01/03 16:14                                                                                                   

Section 7.1.9 Case 1 2(a) is quite clear on this: a single event is
reported
and the MG awaits a new Events Descriptor before taking further action.

---

From: [email-masked]
Date: Thu, 16 Jan 2003 11:36:55 +0200

Dana H.

                      "Tom-PT Taylor"

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 16 Jan 2003 08:54:16 -0500

There are two ways in which multiple events could be reported:

1) You are NOT operating in Lockstep mode, or

2) The first NOTIFY is accompanied by activation of an embedded Events
Descriptor which generates a second NOTIFY.

> Sent: Thursday, January 16, 2003 4:37 AM
> To: Taylor, Tom-PT [CAR:5N00:EXCH]; [email-masked]
> Cc: [email-masked]
> Does it mean reporting same events which happened as a result 
> of same trigger?
> 
> Dana H.
> 
> 
> 
>                                                               
>                                                               
>            
>                       "Tom-PT Taylor"                         
>                                                               
>            
>                       <taylor@nortelne         To:      
> "[email-masked]'" 
> <[email-masked]>, [email-masked] 
>                       tworks.com>              cc:            
>                                                               
>            
>                                                Subject: RE: 
> [Megaco] Events detection in LockStep mode                    
>              
>                       15/01/03 16:14                          
>                                                               
>            
>                                                               
>                                                               
>            
>                                                               
>                                                               
>            
> 
> 
> 
> Section 7.1.9 Case 1 2(a) is quite clear on this: a single 
> event is reported and the MG awaits a new Events Descriptor 
> before taking further action.
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 16 Jan 2003 08:54:16 -0500

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 16 Jan 2003 13:18:13 -0500

Sure.  Essentially what the spec is saying is that while you can notify
multiple events at once, you cannot hold events waiting for others to occur
solely to bundle them.

Since a significant number of applications for H.248 are real-time critical,
holding events will introduce race conditions, lag, and other undesirable
timing problems.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, January 16, 2003 4:37 AM
To: Taylor, Tom-PT [CAR:5N00:EXCH]; [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Events detection in LockStep mode

Dana H.

                      "Tom-PT Taylor"

                      <taylor@nortelne         To:
"[email-masked]'" <[email-masked]>,
[email-masked] 
                      tworks.com>              cc:

                                               Subject: RE: [Megaco] Events
detection in LockStep mode                                 
                      15/01/03 16:14

> From: [email-masked] [mailto:[email-masked]]

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 16 Jan 2003 13:18:13 -0500

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, January 16, 2003 4:37 AM
To: Taylor, Tom-PT [CAR:5N00:EXCH]; [email-masked]
Cc: [email-masked]
Subject: RE: [Megaco] Events detection in LockStep mode

Dana H.

                      "Tom-PT Taylor"

                      <taylor@nortelne         To: