Subject: RE: [Megaco] Error handling on MG

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 8 Jan 2003 09:26:12 -0500

Hello.  See below marked with [PTT].

> -----Original Message-----
> From: Garber, Zeev [mailto:[email-masked]] 
> Sent: Tuesday, January 07, 2003 3:06 PM
> To: [email-masked]
> Subject: [Megaco] Error handling on MG
> 
> 
> Hi All,
> 
> Lets consider following scenario:
> 
> MGC requests MG to Add physical and ephemeral($) terminations 
> to newly created context($). MG realizes that physical 
> termination is already added to another context. It responds 
> with AddReply containing Error Descriptor . 
> 
> 2 questions:
> 
> What is a context Id in response for the first Add command: $ 
> or some new context Id?

[PTT] I would certainly not use a specific context ID, since it is
irrelevant.  I am hesitating between $ for simplicity or null.  We've
already heard one vote for $.  Any other opinions?

> 
> What if Physical termination was successfully added to the 
> context but ephemeral wasn't (due to resource limitation for 
> example). What should be the ephemeral termination id in 
> response $ or some new termination Id?

[PTT] Again, a specific termination ID would be irrelevant and misleading.
Go with $.

> 
> Thanks a lot,
> > Ze`ev Garber
> > Software Engineer
> > Communications Infrastructure Test Group
> > p| 978.661.1211 f| 978.988.0148
> > email | [email-masked]
> > 205 Lowell Street | Wilmington, MA | 01887
> > E M P I R I X 
> > www.empirix.com
> > 
> 
> 
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco
> 
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 14 Jan 2003 11:20:13 +1100

G'Day,

Please see my responses below marked [CHG].

Christian

> already heard one vote for $.  Any other opinions?

[CHG] I would return what was in the request ie. $
H.248.8 (Annex L) "4.1.2.14 Error Code # : 433 Name: TerminationID is already in
a Context" gives guidance also what ContextID to place in the error descriptor.
> [PTT] Again, a specific termination ID would be irrelevant and misleading.

[CHG] Agreed

---

From: Christian Groves <[email-masked]>
Date: Tue, 14 Jan 2003 11:20:13 +1100

G'Day,

Christian

[CHG] Agreed