Subject: [Megaco] Question on Section 7.1.18 Megaco V2

From: Carl Rutter <[email-masked]>
Date: Tue, 7 Jan 2003 11:36:32 -0500

We need some clarifcation on the following statement:

(T1, T2, oneway) means that the Terminations that match T2 
        receive media from the Terminations matching T1, but not vice 
        versa.  In this case use of the ALL wildcard such that there 
        are Terminations that match both T1 and T2 is not allowed. 

The line in question is "... such that there are Terminations that match
both T1 and T2 is not allowed"

The way we read it this clause disproves the use of Wildcard (*,T2,Oneway)
becuase T2 will match * and T2.  Hence the statement "Terminations that
match both T1 and T2 is not allowed",
excludes us from doing this.  Is this correct?

Thx,
Carl

Carl Rutter
Telica, Inc.
Building G, Suite 100
734 Forest Street
Marlboro, MA 01752
Email [email-masked]
Voice 508-480-0909 x8178
Fax 508-480-0922 
www.telica.com

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 8 Jan 2003 09:18:45 -0500

I would agree with you.  Wildcarding is only permitted in this case in the
form of partially-specified names.  Not sure how useful that is.

> -----Original Message-----
> From: Carl Rutter [mailto:[email-masked]] 
> Sent: Tuesday, January 07, 2003 11:37 AM
> To: [email-masked]'
> Cc: Kang-Sen Lu
> Subject: [Megaco] Question on Section 7.1.18 Megaco V2
> 
> 
> The line in question is "... such that there are Terminations 
> that match both T1 and T2 is not allowed"
> 
> The way we read it this clause disproves the use of Wildcard 
> (*,T2,Oneway) becuase T2 will match * and T2.  Hence the 
> statement "Terminations that match both T1 and T2 is not 
> allowed", excludes us from doing this.  Is this correct?
> 
> 
> Thx,
> Carl
> 
> Carl Rutter
> Telica, Inc.
> Building G, Suite 100
> 734 Forest Street
> Marlboro, MA 01752
> Email [email-masked]
> Voice 508-480-0909 x8178
> Fax 508-480-0922 
> www.telica.com
> 
> 
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 8 Jan 2003 11:29:10 -0500

Inline, marked with [PTT].

> From: Kang-Sen Lu [mailto:[email-masked]] 
> Sent: Wednesday, January 08, 2003 9:48 AM
> To: Taylor, Tom-PT [CAR:5N00:EXCH]; Carl Rutter; [email-masked]'
> Cc: Kang-Sen Lu
> Subject: RE: [Megaco] Question on Section 7.1.18 Megaco V2
> 
> 
> Dear Mr. Taylor:
> 
> Thanks for your response.
> 
> I have two questions for you.
> 
> 1. If we meant to say (T1, T2, twoway), can we say (T1, T2, 
> oneway) and (T2, T1, oneway) instead? Since the document says 
> that (T1, T2, oneway) means that flow from T2 to T1 is not 
> allowed, I suppose we can not say (T1, T2,
> oneway) and (T2, T1, oneway) at all. Right?

[PTT] If you did say it, I believe the last-stated specification would
prevail.

> 
> 2. Any triplet of the form (X, X, Y), where X refers 
> termiantor ID(s), and Y refers association, is not very 
> useful and should be ignored by the MG without fear. Given 
> this, then (*, T2, oneway) then can be accepted to mean all 
> terminators, other than T2, to T2 is oneway and it is very 
> useful expression for describing T2 as a CALEA port.

[PTT] Yes, it would be useful, but we would need agreement from the list.
There is the problem that current implementations might not handle it
properly.

> Any comments?
> Kang-sen
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Wednesday, January 08, 2003 9:19 AM
> To: 'Carl Rutter'; [email-masked]'
> Cc: Kang-Sen Lu
> Subject: RE: [Megaco] Question on Section 7.1.18 Megaco V2
> 
> 
> I would agree with you.  Wildcarding is only permitted in 
> this case in the form of partially-specified names.  Not sure 
> how useful that is.
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 8 Jan 2003 11:29:10 -0500

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 8 Jan 2003 11:56:18 -0500

The triplet covers only terminations currently in the context or added to it
in the same action.  Future terminations get bothway access to all
pre-existing terminations, by default.

> Sent: Wednesday, January 08, 2003 11:42 AM
> To: Taylor, Tom-PT [CAR:5N00:EXCH]; Kang-Sen Lu; Carl Rutter; 
> [email-masked]'
> Thanks for the quick response.
> 
> One more question:
> 
> What is the current concensus about the meaning of a topology 
> triplet such as (*, T2, bothway)? especially the coverage of "*".
> 
> Does it cover only the terminators currently added into the 
> specific context, or it can cover all the terminators current 
> in the context as well as ALL the termiantors to be added 
> into the context at later time as well?
> 
> For example, if at the moment we have T1, T2 in the context. 
> Then (*, T2,
> bothway) is processed by the MG. Then terminator T3 is added 
> to the context, then would that "*" covers T3 as well?
> 
> Kang-sen
> 
> Sent: Wednesday, January 08, 2003 11:29 AM
> To: 'Kang-Sen Lu'; Carl Rutter; [email-masked]'
> [PTT] If you did say it, I believe the last-stated 
> specification would prevail.
> 
> > 
> [PTT] Yes, it would be useful, but we would need agreement 
> from the list. There is the problem that current 
> implementations might not handle it properly.
> 
> > 
> > Any comments?
> > 
> > Kang-sen
> > 
> > 
> > > The line in question is "... such that there are 
> Terminations that 
> > > match both T1 and T2 is not allowed"
> > > 
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/megaco
> > > 
> > 
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 8 Jan 2003 11:56:18 -0500

---

From: Kang-Sen Lu <[email-masked]>
Date: Wed, 8 Jan 2003 09:48:10 -0500

Dear Mr. Taylor:

1. If we meant to say (T1, T2, twoway), can we say (T1, T2, oneway) and (T2,
T1, oneway) instead? Since the document says that (T1, T2, oneway) means
that flow from T2 to T1 is not allowed, I suppose we can not say (T1, T2,
oneway) and (T2, T1, oneway) at all. Right?

2. Any triplet of the form (X, X, Y), where X refers termiantor ID(s), and Y
refers association, is not very useful and should be ignored by the MG
without fear. Given this, then (*, T2, oneway) then can be accepted to mean
all terminators, other than T2, to T2 is oneway and it is very useful
expression for describing T2 as a CALEA port.

Any comments?

Kang-sen

---

From: Kang-Sen Lu <[email-masked]>
Date: Wed, 8 Jan 2003 11:42:19 -0500

Dear Mr. Taylor:

One more question:

What is the current concensus about the meaning of a topology triplet such
as (*, T2, bothway)? especially the coverage of "*".

Does it cover only the terminators currently added into the specific
context, or it can cover all the terminators current in the context as well
as ALL the termiantors to be added into the context at later time as well?

For example, if at the moment we have T1, T2 in the context. Then (*, T2,
bothway) is processed by the MG. Then terminator T3 is added to the context,
then would that "*" covers T3 as well?

Kang-sen

---

From: Kang-Sen Lu <[email-masked]>
Date: Wed, 8 Jan 2003 09:48:10 -0500

Dear Mr. Taylor:

Any comments?

Kang-sen

---

From: Kang-Sen Lu <[email-masked]>
Date: Wed, 8 Jan 2003 11:42:19 -0500

Dear Mr. Taylor:

One more question:

Kang-sen

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 14 Jan 2003 13:31:54 -0500

I concur with Christian on this.  It seems to me that the ability to
wildcard one of the positions makes the TP descriptor better able to
describe the desired topology, without adding complexity.  Being forced to
utilize one triple for each combination -- especially in contexts with large
numbers of terms -- would make the TP descriptor so heavy and complex as to
be almost useless.

Any suggestions for wording for this item?  I'll try to put something
together later today or tomorrow, but suggestions are always welcome.

Kevin

-----Original Message-----
From: Christian Groves [mailto:[email-masked]] 
Sent: Monday, January 13, 2003 6:52 PM
To: Taylor, Tom-PT [CAR:5N00:EXCH]
Cc: 'Carl Rutter'; [email-masked]'; Kang-Sen Lu; Boyle, Kevin
[NCRTP:3R90:EXCH]
Subject: Re: [Megaco] Question on Section 7.1.18 Megaco V2

G'Day Tom and Carl,

I had always read this to mean that you should not use * wilcard in both of
the T1,T2 positions that refer to the same terminations. I think the
construction
(T*,T2,oneway) where only one of the T1,T2 positions is * wildcarded is
useful. Maybe this is something for the IG?

Regards, Christian

Tom-PT Taylor wrote:
> 
> I would agree with you.  Wildcarding is only permitted in this case in 
> the form of partially-specified names.  Not sure how useful that is.
> 
> > The line in question is "... such that there are Terminations that 
> > (*,T2,Oneway) becuase T2 will match * and T2.  Hence the statement 
> > "Terminations that match both T1 and T2 is not allowed", excludes us 
> > from doing this.  Is this correct?
> >
> >
> > Thx,
> > Carl
> >
> > Carl Rutter
> > Telica, Inc.
> > Building G, Suite 100
> > 734 Forest Street
> > Marlboro, MA 01752
> > Email [email-masked]
> > Voice 508-480-0909 x8178
> > Fax 508-480-0922
> > www.telica.com
> >
> >
> >

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 14 Jan 2003 13:31:54 -0500

Kevin

-----Original Message-----
From: Christian Groves [mailto:[email-masked]] 
Sent: Monday, January 13, 2003 6:52 PM
To: Taylor, Tom-PT [CAR:5N00:EXCH]
Cc: 'Carl Rutter'; [email-masked]'; Kang-Sen Lu; Boyle, Kevin
[NCRTP:3R90:EXCH]

G'Day Tom and Carl,

Regards, Christian