Subject: [Megaco] Events accumulating and events notification

From: [email-masked]
Date: Thu, 9 Jan 2003 18:20:47 +0200

Hello,

1) According to RFC3015:
      The EventBuffer Descriptor contains a list of events, with their
parameters if any, that the MG is requested to detect and buffer when
EventBufferControl equals LockStep
Does it actually mean that control property Off disables the accumulating
completely?

2) When control property equals LockStep, should the MG wait for Notify
reply (Like in MGCP) in order to process the next accumulated event or only
wait for a new eventsDescriptor?
In this case, should waiting for a new eventDescriptor after sending each
Notify is mandatory?

Regards,

Dana H.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 9 Jan 2003 12:37:01 -0500

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, January 09, 2003 11:21 AM
To: [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked]
Subject: [Megaco] Events accumulating and events notification

Hello,

1) According to RFC3015:
      The EventBuffer Descriptor contains a list of events, with their
parameters if any, that the MG is requested to detect and buffer when
EventBufferControl equals LockStep Does it actually mean that control
property Off disables the accumulating completely?

[KJBII] Correct.

[KJBII] It must wait for a new Events Descriptor.

[KJBII] Yes.

Regards,

Dana H.

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 9 Jan 2003 12:37:01 -0500

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, January 09, 2003 11:21 AM
To: [email-masked]
Cc: [email-masked]; [email-masked];

Hello,

1) According to RFC3015:

[KJBII] Correct.

 

[KJBII] Yes.

Regards,

Dana H.

---

From: Raphael Tryster <[email-masked]>
Date: Thu, 9 Jan 2003 20:24:34 +0200

Kevin,

I would like to verify that Off disables accumulating in the sense that
events are handled immediately according to the latest event descriptor, not
in the sense that they are thrown away.

Would it be fair to say that Megaco LockStep = MGCP Step, and Megaco Off =
MGCP Loop?

Thank you,

Raphael Tryster

	-----Original Message-----
	From:	Kevin Boyle [SMTP:[email-masked]]
	Sent:	Thursday, 09 January, 2003 7:37 PM
	To:	[email-masked]; [email-masked]
	Cc:	[email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked]
	Subject:	RE: [Megaco] Events accumulating and events
notification

	Comments inline. [KJBII]

	Kevin

	-----Original Message-----
	From: [email-masked]
[mailto:[email-masked]] 
	Sent: Thursday, January 09, 2003 11:21 AM
	To: [email-masked]
	Cc: [email-masked]; [email-masked];
	[email-masked]; [email-masked];
[email-masked]
	Subject: [Megaco] Events accumulating and events notification

	Hello,

	1) According to RFC3015:
	      The EventBuffer Descriptor contains a list of events, with
their
	parameters if any, that the MG is requested to detect and buffer
when
	EventBufferControl equals LockStep Does it actually mean that
control
	property Off disables the accumulating completely?

	[KJBII] Correct.

	2) When control property equals LockStep, should the MG wait for
Notify
	reply (Like in MGCP) in order to process the next accumulated event
or only
	wait for a new eventsDescriptor?

	In this case, should waiting for a new eventDescriptor after sending
each
	Notify is mandatory?

	[KJBII] Yes.

	Regards,

	Dana H.

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 9 Jan 2003 13:57:11 -0500

Raphael,
 
That is an excellent clarification.  Note that if a Notify has been sent
from the MG that is operating under LockStep and then the MGC sets EB off,
that the previous Events Descriptor was "disabled" as part of the EB
process, so that the MG does not have an active Events Descriptor.  So, if
the latest E descriptor has been satisfied and not replaced at the time that
LockStep is removed, then the MG will not be actively attempting to detect
any events.  If the E descriptor has not been fulfilled when LockStep is
removed, then that E descriptor should remain as the active descriptor, and
the MG should continue to detect the events specified therein.
 
Kevin

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]] 
Sent: Thursday, January 09, 2003 1:25 PM
To: Boyle, Kevin [NCRTP:3R90:EXCH]; [email-masked];
[email-masked]
Subject: RE: [Megaco] Events accumulating and events notification

Kevin, 

Thank you, 

Raphael Tryster 

	BM__MailData-----Original Message----- 

	Comments inline. [KJBII] 

	Kevin 

	-----Original Message----- 
From: [email-masked] [mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Thursday, January 09, 2003 11:21 AM 
To: [email-masked] 
Cc: [email-masked]; [email-masked]; 
[email-masked]; [email-masked]; [email-masked] 
Subject: [Megaco] Events accumulating and events notification 

	Hello, 

	1) According to RFC3015: 

	[KJBII] Correct. 

  

	[KJBII] Yes. 

	Regards, 

	Dana H. 

	_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>  
_______________________________________________ 
Megaco mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 9 Jan 2003 13:57:11 -0500

Raphael,

Kevin

-----Original Message-----
From: Raphael Tryster [mailto:[email-masked]] 
Sent: Thursday, January 09, 2003 1:25 PM
To: Boyle, Kevin [NCRTP:3R90:EXCH]; [email-masked];
[email-masked]

Kevin, 

Thank you, 

Raphael Tryster 

	Comments inline. [KJBII] 

	Kevin 

	-----Original Message----- 

	Hello, 

	1) According to RFC3015: 

	[KJBII] Correct. 

  

	[KJBII] Yes. 

	Regards, 

	Dana H.