Subject: [Megaco] Events + Events Bufer Descriptors

From: [email-masked]
Date: Wed, 15 Jan 2003 07:35:10 +0200

Hello,

I have two questions regarding Events Descriptor and Events Buffer
Descriptor:

1) When event is being detected and EBC=LockStep, should it be accumulated
if it appears in Events Descriptor only, but not in the EB Descriptor?

2) If EBC=LockStep and the MG has just sent a Notify command, look at the
following possible MGC message towards the MG:
      MEGACO/1 [1.1.1.1]:1111

      Transaction = 500 {Context = 50 {

            Modify = S17/E1_1/1 {

                        Media {TerminationState {EventBufferControl = OFF
      }},

                  Events = {dd/d1}}}}

What should I do first ? :
a) Clean the buffer, and then process the new Events Descriptor, or
b) Act as EBC is still in LockStep, process the next "d1" event which
appears in the EB (send Notify for it), and only finally clean the buffer

Regards,
Dana H.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 15 Jan 2003 09:02:26 -0500

Hi.  See below.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Wednesday, January 15, 2003 12:35 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: [Megaco] Events + Events Bufer Descriptors
> 
> 
> Hello,
> 
> 1) When event is being detected and EBC=LockStep, should it 
> be accumulated if it appears in Events Descriptor only, but 
> not in the EB Descriptor?
[PTT] It should be accumulated only if it appears in the EB Descriptor.

> 
> 2) If EBC=LockStep and the MG has just sent a Notify command, 
> look at the following possible MGC message towards the MG:
>       MEGACO/1 [1.1.1.1]:1111
> 
> b) Act as EBC is still in LockStep, process the next "d1" 
> event which appears in the EB (send Notify for it), and only 
> finally clean the buffer
[PTT] Clean the buffer first.

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 15 Jan 2003 09:02:26 -0500

Hi.  See below.