Subject: RE: [Megaco] two transactions in the same message

From: "VND Wang JuLin" <[email-masked]>
Date: Mon, 6 Jan 2003 10:50:05 +0800

HI,
I think it is not strictly confined to what type of transaction in the message.Please see the following example:

Mar 14 2002 06:28:50.536|TRANSPORT.0|RECEIVE|MEGACO/1 [172.24.202.224]
Transaction=2{
 Context=-{
  Notify=agw_julw/1{ObservedEvents=1{19700101T00000855:al/of}}
 }
}
Transaction=3{
 Context=-{
  Notify=agw_julw/2{ObservedEvents=1{19700101T00000855:al/of}}
 }
}
Transaction=4{
 Context=-{
  Notify=agw_julw/3{ObservedEvents=1{19700101T00000855:al/of}}
 }
}
Transaction=5{
 Context=-{
  Notify=agw_julw/4{ObservedEvents=1{19700101T00000855:al/of}}
 }
}
 
Mar 14 2002 06:28:50.686|Timer Mgr|SEND|MEGACO/1 [172.24.201.125]
Reply=2{
 Context=-{
  Notify=agw_julw/1
 }
}
Transaction=9{
 Context=-{
  Modify=agw_julw/1{
   Events=1{al/on, dd/ce{DigitMap=dialplan0}},
   Signals{cg/dt},
   DigitMap=dialplan0{xxx}
  }
 }
}
Reply=3{
 Context=-{
  Notify=agw_julw/2
 }
}
Transaction=10{
 Context=-{
  Modify=agw_julw/2{
   Events=1{al/on, dd/ce{DigitMap=dialplan0}},
   Signals{cg/dt},
   DigitMap=dialplan0{xxx}
  }
 }
}
Reply=4{
 Context=-{
  Notify=agw_julw/3
 }
}
Transaction=11{
 Context=-{
  Modify=agw_julw/3{
   Events=1{al/on, dd/ce{DigitMap=dialplan0}},
   Signals{cg/dt},
   DigitMap=dialplan0{xxx}
  }
 }
}
Reply=5{
 Context=-{
  Notify=agw_julw/4
 }
}
Transaction=12{
 Context=-{
  Modify=agw_julw/4{
   Events=1{al/on, dd/ce{DigitMap=dialplan0}},
   Signals{cg/dt},
   DigitMap=dialplan0{xxx}
  }
 }
}
TransactionResponseAck{1-8}

 best  regards 
:-)Jerry Wang 
tel:(8621)58541240 ext 9531 
mailto:[email-masked] 
Alcatel Shanghai Bell Co.LTD 

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]]
Sent: Tuesday, December 31, 2002 2:45 PM
To: Fernando Vallejo Lazaro; Megaco
Subject: [Megaco] two transactions in the same message

Hi,
 
Is it possible to have differing type of the transactions in the same message
or
Does the message always contains the same type of transactions and another type of transaction (e.g. TransactionReply) goes into separate message.
 
with regds,
/anil.

----- Original Message ----- 
From: Anil  <mailto:[email-masked]> Jangam 
To: Fernando Vallejo Lazaro <mailto:[email-masked]>  ; Megaco <mailto:[email-masked]>  
Cc: Tom-PT Taylor <mailto:[email-masked]>  ; Madhu Babu  <mailto:[email-masked]> Brahmanapally 
Sent: Tuesday, November 12, 2002 2:33 PM
Subject: Re: [Megaco] two transactions in the same message

Hi,
 
As per the protocol encoding rule, there is NO COMMA separator between two transactions in a message. Hence the your option-b may result into a syntax error (400). The option-a is correct one. You have to read each transaction with the transaction token and corresponding start and end brace.
 
Note: What was the reason for not using any separator for multiple transactions in a message unlike in other cases?
 
/anil.

----- Original Message ----- 
From: Fernando Vallejo  <mailto:[email-masked]> Lazaro 
To: Megaco <mailto:[email-masked]>  
Sent: Tuesday, November 12, 2002 1:48 PM
Subject: [Megaco] two transactions in the same message

Hi all, 

If I wish to send two transactions within the 
same message which of the next two options is the right one? 

Option a) 

MEGACO/1 [123.123.123.4]:55555 
   Transaction = 9999 { 
       Context = - { 
           Modify = A4444 {... } 
        } 
  } 
   Transaction = 10000 { 
       Context = - { 
           Modify = A4445 {... } 
        } 
  } 

Option b) 

MEGACO/1 [123.123.123.4]:55555 
   Transaction = 9999 { 
       Context = - { 
           Modify = A4444 {... } 
        } 
  },                                            <----- Note the comma here 
   Transaction = 10000 { 
       Context = - { 
           Modify = A4445 {... } 
        } 
  } 

Regards 
Fernando 

-- 

Fernando Vallejo Lazaro

Phone:  +34 91 330 8279

SW  Wireline ASD-Madrid

       ALCATEL

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "VND Wang JuLin" <[email-masked]>
Date: Mon, 6 Jan 2003 10:50:05 +0800

HI,

 best  regards 
:-)Jerry Wang 

-----Original Message-----
From: Anil Jangam [mailto:[email-masked]]
Sent: Tuesday, December 31, 2002 2:45 PM
To: Fernando Vallejo Lazaro; Megaco
Subject: [Megaco] two transactions in the same message

Hi,

with regds,
/anil.

----- Original Message ----- 
From: Anil  <mailto:[email-masked]> Jangam 
To: Fernando Vallejo Lazaro <mailto:[email-masked]>  ; Megaco <mailto:[email-masked]>  
Cc: Tom-PT Taylor <mailto:[email-masked]>  ; Madhu Babu  <mailto:[email-masked]> Brahmanapally 
Sent: Tuesday, November 12, 2002 2:33 PM
Subject: Re: [Megaco] two transactions in the same message

Hi,

 
/anil.

----- Original Message ----- 
From: Fernando Vallejo  <mailto:[email-masked]> Lazaro 
To: Megaco <mailto:[email-masked]>  
Sent: Tuesday, November 12, 2002 1:48 PM
Subject: [Megaco] two transactions in the same message

Hi all, 

Option a) 

Option b) 

Regards 
Fernando 

-- 

Fernando Vallejo Lazaro

Phone:  +34 91 330 8279

SW  Wireline ASD-Madrid

       ALCATEL