Subject: [Megaco] EventBufferControl and event handling.

From: [email-masked]
Date: Tue, 14 Jan 2003 12:00:34 +0200

Hi all.

According to chapter 7.1.9 in case the EventBufferControl = Off
the MG does not handle any event buffering for notifications.

Any way, is there any need form the MG to wait for an ACK from
the MGC for the previous notification before it sends a new notification
even if it is in Off state ?

If the answer for that question is no, is there any way to validate the
event notifications order from the
MG to the MGC in Off state without using a digit map ?

Thank you,
Eli Liluz.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 14 Jan 2003 14:02:10 -0500

The short answer is, "It depends."

The long answer is that some consideration has to be given to transport type
and to whether the Notifies are coming from the same term or not.

UDP does not guarantee message ordering.  Given that, then it is wise for
the MG to hold subsequent notifies until the outstanding one is acked.  This
allows the MG to ensure that proper ordering occurs -- especially in cases
where ordering is important, like digit collection.

Further, the MG can look at which term is generating the notify.  If the two
notifies are from different terms, then there is no reason to hold one while
waiting for the ACK on the other.  Ordering becomes important when the
notifies are coming from the same term.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, January 14, 2003 5:01 AM
To: [email-masked]
Subject: [Megaco] EventBufferControl and event handling.

Hi all.

According to chapter 7.1.9 in case the EventBufferControl = Off the MG does
not handle any event buffering for notifications.

Any way, is there any need form the MG to wait for an ACK from the MGC for
the previous notification before it sends a new notification even if it is
in Off state ?

If the answer for that question is no, is there any way to validate the
event notifications order from the MG to the MGC in Off state without using
a digit map ?

Thank you,
Eli Liluz.

---

From: "Kevin Boyle" <[email-masked]>
Date: Tue, 14 Jan 2003 14:02:10 -0500

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, January 14, 2003 5:01 AM
To: [email-masked]
Subject: [Megaco] EventBufferControl and event handling.

Hi all.

Thank you,
Eli Liluz.

---

From: [email-masked]
Date: Wed, 15 Jan 2003 11:36:55 +0200

----- Forwarded by Dana Herskowitz/ECI Telecom on 15/01/03 11:35 -----
                                                                                                                                       
                      Dana Herskowitz                                                                                                  
                                               To:      "Kevin Boyle" <[email-masked]>                                      
                      15/01/03 07:58           cc:                                                                                     
                                               Subject: RE: [Megaco] EventBufferControl and event handling.(Document link: Dana        
                                               Herskowitz)                                                                             

In this case, if we need to wait for reply, we have to accumulate later
detected events even if EBC=OFF. Then what's the difference between
OFF\LOCKSTEP? Doesn't this idea contradicts the RFC? Doesn't OFF mode
disables accumulation ?

Dana H.

                      "Kevin Boyle"                                                                                                    
                      <kboyle@nortelne         To:      [email-masked], [email-masked]                                         
                      tworks.com>              cc:                                                                                     
                      Sent by:                 Subject: RE: [Megaco] EventBufferControl and event handling.                            
                      megaco-admin@iet                                                                                                 
                      f.org                                                                                                            

                      14/01/03 21:02                                                                                                   

The long answer is that some consideration has to be given to transport
type
and to whether the Notifies are coming from the same term or not.

UDP does not guarantee message ordering.  Given that, then it is wise for
the MG to hold subsequent notifies until the outstanding one is acked.
This
allows the MG to ensure that proper ordering occurs -- especially in cases
where ordering is important, like digit collection.

Further, the MG can look at which term is generating the notify.  If the
two
notifies are from different terms, then there is no reason to hold one
while
waiting for the ACK on the other.  Ordering becomes important when the
notifies are coming from the same term.

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, January 14, 2003 5:01 AM
To: [email-masked]
Subject: [Megaco] EventBufferControl and event handling.

Hi all.

Thank you,
Eli Liluz.

---

From: [email-masked]
Date: Wed, 15 Jan 2003 11:36:55 +0200

----- Forwarded by Dana Herskowitz/ECI Telecom on 15/01/03 11:35 -----
                                                                                                                                       
                      Dana Herskowitz                                                                                                  

Dana H.

                      "Kevin Boyle"                                                                                                    

                      14/01/03 21:02                                                                                                   

Kevin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, January 14, 2003 5:01 AM
To: [email-masked]
Subject: [Megaco] EventBufferControl and event handling.

Hi all.

Thank you,
Eli Liluz.

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 15 Jan 2003 09:05:14 -0500

There's a difference between accumulating events (strictly an application
issue) and holding back messages (application-managed transport).  Kevin was
talking about the latter.

> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Wednesday, January 15, 2003 4:37 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [Megaco] EventBufferControl and event handling.
> 
> 
> 
>                                                To:      
> "Kevin Boyle" <[email-masked]>                     
>                  
>                       15/01/03 07:58           cc:            
>                                                               
>            
>                                                Subject: RE: 
> [Megaco] EventBufferControl and event handling.(Document 
> link: Dana        
>                                                Herskowitz)    
>                                                               
>            
>                                                               
>                                                               
>            
> 
> 
> 
> In this case, if we need to wait for reply, we have to 
> accumulate later detected events even if EBC=OFF. Then what's 
> the difference between OFF\LOCKSTEP? Doesn't this idea 
> contradicts the RFC? Doesn't OFF mode disables accumulation ?
> 
> Dana H.
> 
> 
> 
>                                                               
>                                                               
>            
>                       "Kevin Boyle"                           
>                                                               
>            
>                       <kboyle@nortelne         To:      
>                       Sent by:                 Subject: RE: 
> [Megaco] EventBufferControl and event handling.               
>              
>                       megaco-admin@iet                        
>                                                               
>            
>                       f.org                                   
>                                                               
>            
>                                                               
>                                                               
>            
>                                                               
>                                                               
>            
>                       14/01/03 21:02                          
>                                                               
>            
>                                                               
>                                                               
>            
>                                                               
>                                                               
>            
> 
> 
> 
> The long answer is that some consideration has to be given to 
> transport type and to whether the Notifies are coming from 
> the same term or not.
> 
> UDP does not guarantee message ordering.  Given that, then it 
> is wise for the MG to hold subsequent notifies until the 
> outstanding one is acked. This allows the MG to ensure that 
> proper ordering occurs -- especially in cases where ordering 
> is important, like digit collection.
> 
> Further, the MG can look at which term is generating the 
> notify.  If the two notifies are from different terms, then 
> there is no reason to hold one while waiting for the ACK on 
> the other.  Ordering becomes important when the notifies are 
> coming from the same term.
> 
> Kevin
> 
> According to chapter 7.1.9 in case the EventBufferControl = 
> Off the MG does not handle any event buffering for notifications.
> 
> Any way, is there any need form the MG to wait for an ACK 
> from the MGC for the previous notification before it sends a 
> new notification even if it is in Off state ?
> 
> If the answer for that question is no, is there any way to 
> validate the event notifications order from the MG to the MGC 
> in Off state without using a digit map ?
> 
> Thank you,
> Eli Liluz.
>

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 15 Jan 2003 09:05:14 -0500