Subject: RE: [Megaco] Reserved Value and Reserved Group as it applies to Codec Negotiation Question

From: Carl Rutter <[email-masked]>
Date: Mon, 13 Jan 2003 08:09:37 -0500

Thx for the feedback,

I wasn't sure on the multiple m= lines.
I know AVD-2128 indicates that but wasn't sure
if that was fully agreed on.

Thx,
carl

-----Original Message-----
From: Shambhu Dayal Rai [mailto:[email-masked]]
Sent: Sunday, January 12, 2003 11:44 PM
To: Carl Rutter
Cc: [email-masked]'
Subject: Re: [Megaco] Reserved Value and Reserved Group as it applies to
Codec Negotiation Question

Hi Carl,

comments inline..

Carl Rutter wrote:
> 
> I have a few questions on these.  I know this has been discussed before
but
> can't
> remember the resolution.  Does the following sound correct?
> 
> 1) Reserve Group - Applies to a Group of Session Descriptors. If true
> reserve
>                              resources to handle say the worse case
specifed
> codec.
> ie)
> v=
> .
> .
> m= audio ... 2
> v=
> .
> .
> m= audio ... 0
> 
> Make sure we reserve for either 0 or 2.

[Shambhu]: I think, Here resources should be reserved to support all session
descriptors.  Both 0 and 2.
 
> 2) Reserve Value
> 
> On the media line
> m= audio ... 0 2
> 
> Make sure we reserve for either 0 or 2.

[Shambhu]: I think, Here resources should be reserved to handle flow of all
mentioned types of codecs (here 0 and 2) if reserveValu
is set in the request.

> 
> What about the case where there is 2 or more media lines in a Session
> Decriptor
> ie)
> 
> m= audio ... 2
> m= audio ... 0
> 
> Is this legal?
> Would this quailify as a group?  So if Reserved Group was True and I had 1
> session descriptor with 2 m= lines would I reserve them both?
> 

[Shambhu]: Multiple "m-" lines are not legal in Megaco SDP.

> Also is RFC3264 the model moving forward for codec negotiation??
> 
> Thx,
> Carl
> 
> Carl Rutter
> Telica, Inc.
> Building G, Suite 100
> 734 Forest Street
> Marlboro, MA 01752
> Email [email-masked]
> Voice 508-480-0909 x8178
> Fax 508-480-0922
> www.telica.com

-- 
-------------------------------------------------------------------
Shambhu Dayal Rai                              [email-masked] 
Infosys - India SQA Team                    Phone:91-80-4166565
-------------------------------------------------------------------
_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Carl Rutter <[email-masked]>
Date: Mon, 13 Jan 2003 08:09:37 -0500

Thx for the feedback,

Thx,
carl

-----Original Message-----
From: Shambhu Dayal Rai [mailto:[email-masked]]
Sent: Sunday, January 12, 2003 11:44 PM
To: Carl Rutter
Cc: [email-masked]'
Subject: Re: [Megaco] Reserved Value and Reserved Group as it applies to

Hi Carl,

comments inline..

but
specifed