Subject: RE: [Megaco] Signal Descriptor Doubts

From: Raphael Tryster <[email-masked]>
Date: Thu, 16 Jan 2003 12:25:39 +0200

G'Day Christian,

You seem to be agreeing that a signal that has finished playing should not
be returned in reply to an audit.  Are you going further and saying that a
signal that has not yet started playing should also not be returned?  Or do
you agree that the term "active" can be stretched, as Kevin says, to mean
"what is currently playing and what is remaining to be "played"?  In other
words, not dead yet?  I think this is useful.

Raphael Tryster

	-----Original Message-----
	From:	Christian Groves [SMTP:[email-masked]]
	Sent:	Thursday, 16 January, 2003 6:34 AM
	To:	Kevin Boyle
	Cc:	Raphael Tryster; Tom-PT Taylor; 'mukta vasudeva'; 'Alan
Chou'; [email-masked]
	Subject:	Re: [Megaco] Signal Descriptor Doubts

	G'Day Kevin and Raphael,

	In v2 the specification already has text on what should happen:-
	7.2.5	AuditValue
	...
	o	To audit a signal the relevant signal list ID and/or signal
ID are provided.
	Only if the signal is active the values of all the signal parameters
are
	returned including: the keepactive indication, signal type,
duration, signal
	completion indication and package defined properties.

	Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Fri, 17 Jan 2003 11:19:37 +1100

G'Day Raphael,

I don't think we need to stretch any term. As far as Megaco is concerned the MG
returns a reply when it is sure the signals will play. Therefore as soon as the
reply is sent the signals are active. So to me signals/signal lists are either
active or finished. Active get reported, Finished ones do not.

Cheers, Christian

Raphael Tryster wrote:
> 
> G'Day Christian,
> 
> You seem to be agreeing that a signal that has finished playing should not be
> returned in reply to an audit.  Are you going further and saying that a signal
> that has not yet started playing should also not be returned?  Or do you agree
> that the term "active" can be stretched, as Kevin says, to mean "what is
> currently playing and what is remaining to be "played"?  In other words, not
> dead yet?  I think this is useful.
> 
> Raphael Tryster
> 
>      Cc:     Raphael Tryster; Tom-PT Taylor; 'mukta vasudeva'; 'Alan Chou';
>      [email-masked]
>      o       To audit a signal the relevant signal list ID and/or signal ID
>      are provided.
>      Only if the signal is active the values of all the signal parameters are
>      returned including: the keepactive indication, signal type, duration,
>      signal

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Fri, 17 Jan 2003 11:19:37 +1100

G'Day Raphael,

Cheers, Christian

---

From: "Anil Jangam" <[email-masked]>
Date: Mon, 20 Jan 2003 18:38:55 +0530

hi,

as per the AuditReturnParameter (inside ammsReply) definition, it is mentioned that it may contain the AuditItem. Also it may contain EventsDescriptor as well.

auditReturnParameter = (mediaDescriptor / modemDescriptor /
                              muxDescriptor / eventsDescriptor /
                              signalsDescriptor / digitMapDescriptor /
                              observedEventsDescriptor / eventBufferDescriptor /
                              statisticsDescriptor / packagesDescriptor /
                              errorDescriptor / auditItem) 

 ;at-most-once, and DigitMapToken and PackagesToken are not allowed ;in AuditCapabilities command
auditItem            = ( MuxToken / ModemToken / MediaToken /
                              SignalsToken / EventBufferToken /
                              DigitMapToken / StatsToken / EventsToken /
                              ObservedEventsToken / PackagesToken )

In above case, if the EventDescriptor is received empty, then how the corresponding Token should be treated?? Should it be treated as empty EventDescriptor OR be as AuditItem?? What is the difference between these two??

P.S.: The EventDescriptor is defined, where except token everything is optional:
eventsDescriptor     = EventsToken [ EQUAL RequestID LBRKT
                           requestedEvent *( COMMA requestedEvent ) RBRKT ]

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Anil Jangam" <[email-masked]>
Date: Mon, 20 Jan 2003 18:38:55 +0530

hi,