Subject: RE: [Megaco] Events accumulating and events notification

From: Raphael Tryster <[email-masked]>
Date: Thu, 9 Jan 2003 20:24:34 +0200

Kevin,

I would like to verify that Off disables accumulating in the sense that
events are handled immediately according to the latest event descriptor, not
in the sense that they are thrown away.

Would it be fair to say that Megaco LockStep = MGCP Step, and Megaco Off =
MGCP Loop?

Thank you,

Raphael Tryster

	-----Original Message-----
	From:	Kevin Boyle [SMTP:[email-masked]]
	Sent:	Thursday, 09 January, 2003 7:37 PM
	To:	[email-masked]; [email-masked]
	Cc:	[email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked]
	Subject:	RE: [Megaco] Events accumulating and events
notification

	Comments inline. [KJBII]

	Kevin

	-----Original Message-----
	From: [email-masked]
[mailto:[email-masked]] 
	Sent: Thursday, January 09, 2003 11:21 AM
	To: [email-masked]
	Cc: [email-masked]; [email-masked];
	[email-masked]; [email-masked];
[email-masked]
	Subject: [Megaco] Events accumulating and events notification

	Hello,

	1) According to RFC3015:
	      The EventBuffer Descriptor contains a list of events, with
their
	parameters if any, that the MG is requested to detect and buffer
when
	EventBufferControl equals LockStep Does it actually mean that
control
	property Off disables the accumulating completely?

	[KJBII] Correct.

	2) When control property equals LockStep, should the MG wait for
Notify
	reply (Like in MGCP) in order to process the next accumulated event
or only
	wait for a new eventsDescriptor?

	[KJBII] It must wait for a new Events Descriptor.
	 
	In this case, should waiting for a new eventDescriptor after sending
each
	Notify is mandatory?

	[KJBII] Yes.

	Regards,

	Dana H.

	_______________________________________________
	Megaco mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/megaco
	_______________________________________________
	Megaco mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/megaco

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 09 Jan 2003 13:55:44 -0500

Raphael Tryster wrote:

>
>
> Kevin,
>
> I would like to verify that Off disables accumulating in the sense
> that events are handled immediately according to the latest event
> descriptor, not in the sense that they are thrown away.
>
> Would it be fair to say that Megaco LockStep = MGCP Step, and Megaco
> Off = MGCP Loop?
>

Almost:

Megaco LockStep = MGCP Step, Process
Megaco Off    = MGCP Loop, Discard

-- Flemming

>      reply (Like in MGCP) in order to process the next accumulated
>      event or only
>      In this case, should waiting for a new eventDescriptor after
>      sending each
>      Notify is mandatory?
>
>      [KJBII] Yes.
>
>      Regards,
>
>      Dana H.
>

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 09 Jan 2003 13:55:44 -0500

Almost:

-- Flemming