Subject: Re: [Megaco] ALL in Topology descriptor and CHOOSE in command

From: [email-masked]
Date: Fri, 24 Jan 2003 14:36:53 +0530

Hi Chris,

In earlier mails it was stated that

Section 7.1.18 means that you must consider the topology descriptor before
addressing the
commands. You should then use the information that is in the topology descriptor
when you process the commands in the message.

Now with this implementation the final result should be
T1 is isolated from T2 and
T1 is isolated from T3 and
T2 is bothway connected to T3

Correct me if I have some wrong interpretation

Thanks and regards
Shobhit

Christian Groves <[email-masked]> on 01/22/2003 05:36:36 AM

To:   [email-masked]
cc:   [email-masked] (bcc: Shobhit Bansal/HSS)

Subject:  Re: [Megaco] ALL in Topology descriptor and CHOOSE in command

Hello Manfred,

In accordance to 7.1.18 "The Topology descriptor occurs before the commands in
an action." it would be b).

Christian

[email-masked] wrote:
>
> Hi all,
>
> Let's assume we have 2 terminations T1 and T2 which are oneway connected.
> Now we add a new termination T3 with the following topology settings.
>
> Topology (T1,ALL,isolate)
>   ADD $
>
> Which of the following results is correct?
>
> a.) T1 is isolated from T2 and
>     T1 is isolated from T3 and
>     T2 is bothway connected to T3
> b.) T1 is isolated from T2 and
>     T1 is bothway connected to T3 and
>     T2 is bothway connected to T3
>
> Thanks for your help.
>
> best regards Manfred
>
> _______________________________________________
> Megaco mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 30 Jan 2003 12:11:21 +1100

Hello,

I stand by what I stated you need it inspect the topology descriptor first. 
ie.
"The Topology descriptor occurs before the commands in an action."

To complete the topology descriptor you may need to look ahead in subsequent
commands in the case their is a "?" to get the relevant TID or the topology
triple contains a TID that is introduced to the context by an additional ADD
command. So you need to be sure at least that the TID is available. To
successfully execute the topology descriptor.

The commands themselves are then executed. If they fail then a TID will be
returned with the error message and the MGC can then fix the set topology if
need be. 

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Thu, 30 Jan 2003 12:11:21 +1100

Hello,

Regards, Christian