Subject: RE: [Megaco] Start and End Tone Detected Events in DTMF Detection Pkg

From: Bob Braisted <[email-masked]>
Date: Thu, 17 Jul 2003 14:10:12 -0400

as i understand it, the DTMF package extends the possible values for tone Id
in the 
"start tone detected"   (0x0001),
"end tone detected"     (0x0002),
and "long tone detected" (0x0003)  events.
(The only valid tone id defined from the base tone detection package was the
wildcard tone id.)

dd/d3 is therefore not really a valid pkgId/evtId to be included in an Event
descriptor. but rather d3 is just another tone id which could be included in
the tone id list as you indicated in the example of the subsequent long tone
detected event... dd/ltd {tl=[d3]).  

DTMF detection package also extends the tone detection package by defining
one additional event, dd/ce (0x0004) digit completion event. so the only
valid events related to DTMF detection package would be  dd/std, dd/etd,
dd/ltd, and dd/ce.

for what it's worth?

thanks
bob

-----Original Message-----
From: Juergen Stoetzer [mailto:[email-masked]]
Sent: Thursday, July 17, 2003 12:24 PM
To: [email-masked]
Subject: [Megaco] Start and End Tone Detected Events in DTMF Detection
Pkg

Hello,

Since the DTMF Detection Package extends the
Tone Detection Package an MGC could subscribe
for a start tone or long tone detected event with
a tone id list parameter containing a certain DTMF digit and,
at the same time, subscribe for that DTMF digit
as an event of its own.

Thus, from the protocol's point of view the following
Events descriptor in an Add or Modify command is
perfectly valid, isn't it?

Events = 1 {
    dd/d3,
    dd/ltd {tl=[d3]}
}

However, does such a combination actually make sense
from the MGC's point of view?
Are there any conceivable "real world" applications
which might use such a combination of events?

Thank you very much in advance!

Kind Regards,
Juergen Stoetzer

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 17 Jul 2003 14:41:56 -0400

No, dd package defines DTMF digits as events (see RFC 3525, E.6.2 Events).
Thus dd/d3 is a valid event.

As for original question:
Suppose MGC wants to detect "regular" brief d3 and "long" (say 2 sec) d3, then
I guess it could ask for something like { dd/d3, dd/ltd { tl = d3, dur = 
2000 }}
Then if d3 was short it would only get Notify with dd/d3, otherwise if d3
lasted for 2 sec it would get Notify for dd/d3 and dd/ltd

Although to avoid extra Notify I think more appropriate would be to ask for
dd/etd { tl = d3 } and then on receipt of Notify check observed event's "dur"
parameter to determine ether it was "short" or "long" digit.

But again, nothing precludes MGC from using former form.

Regards,
         Aleks

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 17 Jul 2003 14:41:56 -0400

Regards,
         Aleks