Subject: [Megaco] At-Most-Once functionality and MId

From: "Jay H Kim" <[email-masked]>
Date: Tue, 22 Jul 2003 21:52:53 +0900

Hi All,
 
If I receve a Msg1  and receive a Msg2 later like this :
 
Msg1   mId(a.b.c.d:1234) TrsReq:transactionID=1000   with source IP Address and port (l.m.n.p:1234)
Msg2   mId(a.b.c.d:1234) TrsReq:transactionID=1000   with source IP Address and port (p.q.r.s:1234)
            (  l.m.n.p != p.q.r.s)
 
is the Msg2  retransmitted transaction of Msg1 or not?
I think Msg2 is Not the retransmitted transacion of Msg1 because the source IP Address and port is different, 
although the mIds are same.

But,.......
rfc3525 and draft-ietf-megaco-h248v2-04 Annext D1.1.1 says :
retransmiited transactions are detected as following scheme :
"The transaction  identifier of each incoming message is compared to the transaction
   identifiers of the recent responses sent to the same MId."

Could anybody give me a clarification?
G'Day

---------------------------------------------------------
Jay H Kim
R&D Center  XENER Systems Inc.
Office: +82-2-3482-4900. ext.411
Fax: +82-2-3483-4902
+mailto:[email-masked]
Homepage: www.xener.com
--------------------------------------------------------

---

From: zhangtao <[email-masked]>
Date: Wed, 23 Jul 2003 11:36:23 +0800

MSG2 is a retransmitted message.
Because  one MID(namely MG or MGC) maybe have many IP ADDRESS or port.
  ----- Original Message ----- 
  From: Jay H Kim 
  To: [email-masked] 
  Sent: Tuesday, July 22, 2003 8:52 PM
  Subject: [Megaco] At-Most-Once functionality and MId

  Hi All,

   

  But,.......

---

From: zhangtao <[email-masked]>
Date: Wed, 23 Jul 2003 11:36:23 +0800

----- Original Message ----- 
  From: Jay H Kim 
  To: [email-masked] 
  Sent: Tuesday, July 22, 2003 8:52 PM
  Subject: [Megaco] At-Most-Once functionality and MId

  Hi All,

   

  But,.......