Subject: [Megaco] StreamIds in SCTP as transport

From: "Rashim Anand" <[email-masked]>
Date: Tue, 22 Jul 2003 18:10:33 -0700

Hi,

In H.248 annex H (transport over SCTP), section H.7, a recommendation is
given -

It is recommended that transactions related to one context are transported
over the same stream.

Now suppose the following sequence of messages is exchanged ->

   MGC  ------STR 1-----------> MG
          T=1 { C=$ ... }

   MGC  <---------------------- MG
          Reply=1 { C=5 ... }

   MGC  ------STR 2-----------> MG
          T=2 { C=5 ... }

   MGC  ------STR 2-----------> MG
          T=3 { C=5 ... }

   MGC  ------STR 2-----------> MG
          T=4 { C=5 ... }

where, "T=[0-9]* { C=... }" refers to transaction requests while,
"Reply=[0-9]* { C=... }" refers to transaction replies,
"C" stands for ContextId and
STR1, STR2 refer to the outgoing stream identifiers used by the MGC.

The question is - does having STR2 different from STR1 violate the
philosophy behind the H.7 recommendation?

IMHO, it does not since the context id 5 becomes known to the MGC only after
getting a reply from the MG. Without the assigned context id, the MGC can
not send any transactions related to that context and so can not cause any
head of line blocking to transactions related to other contexts.

Please let me know your opinion?

Thanks,
Rashim Anand

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Ranjith Mukundan" <[email-masked]>
Date: Wed, 23 Jul 2003 09:29:44 +0530

rashim, 

i guess you are refering to section H.8 (& not H.7) - atleast thats the
way it is numbered in the (latest?) annex  that i am seeing; anyways:

there are two parts to this recommendation:

1- unrelated transactions to be transmitted on different streams
2- transactions related to one context should be transported over the
same stream.

In your e.g., though you are compliant to 2; you are not exactly
complaint to 1 as T1 and T2-4 are related to certain extent as both have
C5 as the common link. Non-compliance to this could result in a new
*unrelated* transaction queued behind T2-4 (in STR2) to be blocked
(perhaps owing to some issues in C5 related processing/transactions);
you are better off having this C5 affect an unrelated transaction on
STR-1  rather than (probalistically) "spread" the "C5 effect" across
other streams (in this case STR-2).

-- ranjith..

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of Rashim Anand
>Sent: Wednesday, July 23, 2003 6:41 AM
>To: [email-masked]
>Subject: [Megaco] StreamIds in SCTP as transport
>
>
>Hi,
>
>In H.248 annex H (transport over SCTP), section H.7, a 
>recommendation is given -
>
>It is recommended that transactions related to one context are 
>transported over the same stream.
>
>The question is - does having STR2 different from STR1 violate 
>the philosophy behind the H.7 recommendation?
>
>IMHO, it does not since the context id 5 becomes known to the 
>MGC only after getting a reply from the MG. Without the 
>assigned context id, the MGC can not send any transactions 
>related to that context and so can not cause any head of line 
>blocking to transactions related to other contexts.
>

---

From: "Ranjith Mukundan" <[email-masked]>
Date: Wed, 23 Jul 2003 09:29:44 +0530

rashim, 

-- ranjith..