Subject: [Megaco] +AFs-Megaco+AF0- question about signal descriptor in Modify's response

From: "FND-AD Wang JuLin" <[email-masked]>
Date: Fri, 18 Jul 2003 11:19:23 +0800

Hi,List,
Can anybody help me on this item which i had posted before? Thanks a lot!

Jerry

>-----Original Message-----
>From: FND-AD Wang JuLin 
>Sent: Wednesday, July 09, 2003 1:22 PM
>To: Megaco (E-mail)
>Subject: [Megaco] question about signal descriptor in Modify's response
>
>
>Hi all,
>According to the protocol,signal descriptor can be modified 
>and returned in Modify's response.Can we construct the Modify 
>'s response whatever we want to implement our product 
>features?Here are two examples as follows.
>Example 1:
>MGC--->MG
>MEGACO/1 [15.8.1.10]:2944 
>   Transaction = 10001 { 
>       Context = - { 
>           Modify = ROOT {Signals  {xxx/yyy   {k=1,
>                                                     ea = 1, 
>                                                     random =1224}}    
>           } 
>       } 
>   } 
>
>MG--->MGC
>MEGACO/1 [15.8.1.18]:2944 
>Reply = 10001 { 
>Context = - {Modify = ROOT{
>Signals {xxx/yyy{key=22,
>ea = 1 
>}}    
>           } } }
>Example 2: 
>MGC--->MG
>MEGACO/1 [15.8.1.10]:2944 
>   Transaction = 10001 { 
>       Context = - { 
>           Modify = ROOT {Signals  {xxx/zzz   {t=1},
>                                                         
>xxx/yyy   {k=2,
>                                                     ea = 1, 
>                                                     random =1223}}    
>           } 
>       } 
>   } 
> 
>MG--->MGC
>MEGACO/1 [15.8.1.18]:2944 
>Reply = 10001 { 
>Context = - {Modify = ROOT}}
>
>I wonder if the above  two examples are suitable or not when 
>both are adopted in a scenario for gateway to implement some 
>features.Please clear my mind.Thanks in advance!
>
> best  regards 
>JJerry Wang 
>tel:(8621)58541240 ext 9531 
>MP:13621761050 
>mailto:[email-masked] 
>Alcatel Shanghai Bell Co.LTD 
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco
>

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 17 Jul 2003 23:34:37 -0400

Uhhh... Where, exactly, does the spec indicate that the MG can modify a
signal applied by the MGC?  That is not how I read the spec.

Example 1 is not correct.  Example 2 is.

Kevin

-----Original Message-----
From: FND-AD Wang JuLin [mailto:[email-masked]] 
Sent: Thursday, July 17, 2003 11:19 PM
To: Megaco (E-mail)
Subject: [Megaco] +AFs-Megaco+AF0- question about signal descriptor in
Modify's response

Hi,List,

Jerry

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 17 Jul 2003 23:34:37 -0400

Kevin

-----Original Message-----
From: FND-AD Wang JuLin [mailto:[email-masked]] 
Sent: Thursday, July 17, 2003 11:19 PM
To: Megaco (E-mail)
Subject: [Megaco] +AFs-Megaco+AF0- question about signal descriptor in
Modify's response

Hi,List,

Jerry

---

From: "wangfei" <[email-masked]>
Date: Fri, 18 Jul 2003 17:2:22 +0800

Hi Wang JuLin

    I think Signal descriptor can be modified, but only by MGC. So...

	It's just my opinion. If i'm wrong, Plz tell me. Thanks! 

>Hi, Kevin,
>In chapter Add command, it was written:
>All descriptors that can be modified could be returned by MG if a parameter was underspecified or overspecified.  ObservedEvents, Statistics, and Packages, and the EventBuffer Descriptors are returned only if requested in the AuditDescriptor.
>I wonder the Signal descriptor can be modified or not. In what case can the gateway send Add/Modify/Subtract command reply with signal descriptor?  
>Please correct me if i misunderstood the protocol.
>
>>From: Kevin Boyle [mailto:[email-masked]]
>>Sent: Friday, July 18, 2003 11:35 AM
>>To: FND-AD Wang JuLin; Megaco (E-mail)
>>Subject: RE: [Megaco] +AFs-Megaco+AF0- question about signal descriptor
>>in Modify's response
>>
>>
>>>                                                     random 
>>=1224}}    
>>>                                                     random 
>>=1223}}    
>.

---

From: "wangfei" <[email-masked]>
Date: Fri, 18 Jul 2003 17:2:22 +0800

Hi Wang JuLin

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 18 Jul 2003 07:55:10 -0400

The Signals descriptor cannot be underspecified, or overspecified.
Therefore, it cannot be modified.

The only way an MG would be able to respond with the Signals descriptor is
if it were audited.

Kevin

-----Original Message-----
From: FND-AD Wang JuLin [mailto:[email-masked]] 
Sent: Friday, July 18, 2003 4:39 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Megaco (E-mail); [email-masked]
Subject: RE: [Megaco] +AFs-Megaco+AF0- question about signal descriptor in
Modify's response

Hi, Kevin,
In chapter Add command, it was written:
All descriptors that can be modified could be returned by MG if a parameter
was underspecified or overspecified.  ObservedEvents, Statistics, and
Packages, and the EventBuffer Descriptors are returned only if requested in
the AuditDescriptor. I wonder the Signal descriptor can be modified or not.
In what case can the gateway send Add/Modify/Subtract command reply with
signal descriptor?  
Please correct me if i misunderstood the protocol.

>>According to the protocol,signal descriptor can be modified and 
>>returned in Modify's response.Can we construct the Modify 's response 
>>whatever we want to implement our product features?Here are two 
>>examples as follows. Example 1:
>>MGC--->MG
>>I wonder if the above  two examples are suitable or not when both are 
>>adopted in a scenario for gateway to implement some features.Please 
>>clear my mind.Thanks in advance!
>>
>> best  regards
>>JJerry Wang

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 18 Jul 2003 07:55:10 -0400

Kevin

-----Original Message-----
From: FND-AD Wang JuLin [mailto:[email-masked]] 
Sent: Friday, July 18, 2003 4:39 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; Megaco (E-mail); [email-masked]
Subject: RE: [Megaco] +AFs-Megaco+AF0- question about signal descriptor in
Modify's response

Hi, Kevin,