Subject: Re: [Megaco] continuity test

From: [email-masked]
Date: Sun, 17 Aug 2003 13:29:03 +0300

Thank you for replying.
I'll refer in this e-mail to the H.248 call flow examples document by
Madhubabu Brahmanapally from March 2002.
From example 2.12, case (b) :

Step 1
MGC to TGW:
MEGACO/1 [216.33.33.61]: 27000
   Transaction = 1234 {
       Context = '-' {
          Modify = Trunk1/line1  {Media {
                    TerminationState {ServiceState = test}
                     LocalControl      { mode = loopback} }
            Signals = { ct/rsp }
           }
      }
   }

There can be two possible cases for responding to the continuity test
originated from the PSTN network. In the first case the Trunking Gateway
generates a signal whose frequency is different from the frequency of the
received signal and in the second case it loops back the received signal
to the switch that originated it. In this example we assume the case of
Loopback. The mode of the termination is also set to loopback to facilitate
this.

From these sentences I understand that the MGC may request for responding
with signal looped back, and from your response to my former question, I
understand that the MG does not have to respect the MGC Loopback mode
request as the COT signal is provisioned by the MG itself. Am I right?

Dana H.

                      Aleksandr Ryabin                                                                                                 
                      <kengr@motorola.         To:      <[email-masked]>, <[email-masked]>,                        
                      com>                     <[email-masked]>                                                           
                                               cc:                                                                                     
                      14/08/03 18:48           Subject: Re: [Megaco] continuity test                                                   

Hi,

No. Specific COT type is provisioned in MG on termination.
MGC should make no assumptions on type of COT is provisioned on MG.
MGC should always send ct/rsp when it wants MG to respond to COT.

Regards,
         Aleks

At 02:05 AM 8/14/2003, [email-masked] wrote:
>Hello,
>Does the following command, due to the absence of Loopback mode request,
>necessarily dictates generating a different frequency signal in the
>continuity test procedure?
>
>
>MEGACO/1 [1.2.3.4]:2427
>Transaction=111 {Context=- {Modify =PhysTerm {Signals{ct/rsp}}}}
>
>
>Regards,
>Dana H.
>
>
>
>_______________________________________________
>Megaco mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: David Auerbach <[email-masked]>
Date: Sun, 17 Aug 2003 07:50:37 -0700

Dana,

I believe that the call flow examples in this case are not a good 
example.  I had an email
discussion with one of the authors and asked that this be changed.  I was 
under the impression
that it would be modified in a future draft of the document.  It 
contradicts (or confuses) RFC 3525
(H.248.1) and I believe the RFC should have priority over a draft document. 
The comments by Aleksandr
in a previous response seem correct.

E.10 provides a simple way to provide COT regardless of whether the test is 
a loopback or dual
tone test.   Technically, using the mode loopback for that mode of test 
would give the same
result but using loopback for dual tone is contradictory and 
inconsistent.  You certainly do
not want a loopback in that case.  Why use the mode?  Just use E.10.

I also agree with Aleksandr that the termination state, servicestate should 
not be "test" but
E.10 is silent on the service state value to use.  I would hope that media 
gateways do not
enforce a specific servicestate by returning an error.

Best regards,
David

At 13:29 17/08/2003 +0300, [email-masked] wrote:

>                       Aleksandr 
> Ryabin 
>                       <kengr@motorola.         To: 
> <[email-masked]>, <[email-masked]>,
>                       com>

---

From: David Auerbach <[email-masked]>
Date: Sun, 17 Aug 2003 07:50:37 -0700

Dana,

Best regards,
David