Subject: [Megaco] loopback mode and incoming continuity test

From: [email-masked]
Date: Wed, 13 Aug 2003 21:31:16 +0300

Hello,
I have two questions:

A) Are the following 2 commands cause the same operations eventually?
(Is Loopback mode request is the same as Incoming COT request)

(1)
MEGACO/1 [1.1.1.1]:2427
Transaction = 777 {Context=$ {Add=Physical1 {Signals{ct/rsp}}}}

(2)
MEGACO/1 [1.1.1.1]:2427
Transaction=888 {Context=$ {Add=Physical1 {Media{LocalControl{Mode =
Loopback}}}}}

B) Is the following command valid in order to perform COT or should it
include also a "ct" signal? If this command is enough for performing COT -
what kind of COT is it - Incoming or Outgoing?

MEGACO/1 [1.1.1.1]:2427
Transaction=999 {Context=$ {Modify =Physical1 {Media{TerminationState{State
= Test}}}}}

Regards,
Dana H.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 14 Aug 2003 11:39:17 -0400

Hi,
Please see my comments below inline [AR].
Regards,
         Aleks

>(Is Loopback mode request is the same as Incoming COT request)

[AR] Physically might be in some cases, logically not.
Please see RFC 3525 p 177 "E.10.5 Procedures" for more details.

>what kind of COT is it - Incoming or Outgoing?

[AR] No, COT procedures are described in RFC section referenced above.
MGC needs to apply ct/ct signal and request ct/cmp event
for outgoing COT, and apply ct/rsp signal for incoming COT.

[AR] Termination state "test" has nothing to do with COT tests.
My understanding that termination state "test" means that
some maintenance work is being performed on the termination
itself and not on connection between termination and its peer
entity (which COT does).

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 14 Aug 2003 11:39:17 -0400

Hi,