Subject: [Megaco] [Megaco]Question about R2 signaling

From: [email-masked]
Date: Wed, 6 Aug 2003 15:25:17 +0900

Hi, All.

It is natural that MGC is responsible for signaling control and MG is
responsible for media control in MGC-MG model. So, I think that ,for R2
signaling service, 
MGC should perform protocol state machine for R2 and MG should just report
R2 related signals and trigger R2 related signals by MGC. Bu, according to
H.248.26 "Basic CAS Packages", CAS Failure event means that MG is acting
like operating protocol state machine for R2 signaling.

Is it necesary that both MGC and MG have protocol state machine for R2
signaling? If it is OK, Is the reason that the protocol state machine of MG
corrects that of MGC?

Thanks.

------------------------------------------------------------ 
Seunghan Choi 
VoIP Technology Team, Network Service Dept. 
Electronics & Telecommunications Research Institute 
161 Kajong-Dong, Yusong-Gu, Taejon, Korea 
Tel  + 82 42 860 6343    Fax  + 82 42 860 6342 
Mobile  011 455 9524    Email  [email-masked] 

spamcontrol

---

From: [email-masked]
Date: Wed, 6 Aug 2003 20:35:59 +0530

MGC runs the call state machine and MG runs the protocol signalling state
machine.
Irrespective of the CAS protocol running at MG, the MGC call state machine
does not change.
The objective is to hide the MGC from the CAS protocol differences and
variants as far as possible.
Further, having all CAS protocol states recognised/triggered by MGC
a) increases MGC-MG traffic
b) results into CAS protocol timeouts at MG.

regards,
Kushanava

[email-masked]@ietf.org on 08/06/2003 11:55:17 AM

Sent by:    [email-masked]

To:    [email-masked]
cc:

Subject:    [Megaco] [Megaco]Question about R2 signaling

Hi, All.

Thanks.

spamcontrol

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Wed, 6 Aug 2003 20:35:59 +0530

regards,
Kushanava

To:    [email-masked]
cc:

Hi, All.

Thanks.

spamcontrol