Subject: [Megaco] ServiceChange/ Restart question

From: Troy Cauble <[email-masked]>
Date: Fri, 07 Nov 2003 19:28:31 -0500

ON STARTUP an MG sends:
==========

MEGACO/1 [192.168.17.217]
Transaction = 667 {
   Context = - {
     ServiceChange = ROOT {
       Services {
         Method = Restart
       }
     }
   }
}

Does the use of ROOT imply that all terminations are InService?

If the MG is configured (via SNMP for example) to have some terminations
disabled, should it send "Method = Restart" for each enabled termination
instead of one for ROOT?  (All in the same Context/Transaction/Message?)

If so, should it also send "Method = Forced" or "Method = Graceful"
for the disabled terminations?

Thanks,

-troy

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Venugopal Sharma <[email-masked]>
Date: Sun, 09 Nov 2003 00:09:58 +0530

Troy,

I think ROOT termination indicates MG as a whole. In Service and Out of
Service messages are sent only at the MG level and not per terminations.
Hence 'In service' should only indicate that the H248 stack is up and
running in the MG.

thanks / Venu
--------------

---

From: Venugopal Sharma <[email-masked]>
Date: Sun, 09 Nov 2003 00:09:58 +0530

Troy,

thanks / Venu
--------------