Subject: RE: [Megaco] Question about Tone list

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 7 Nov 2003 13:59:42 -0500

Two comments:

First, this signalling is illegal, as it is missing the ind parameter, and
ind has no default value.  The MG would reject this Signals descriptor.

Second, duration means duration.  Start at the beginning of the list, and
play out the tones in order until you reach the duration specified.  At that
time the signal will halt, regardless of which digit is being played out.
Duration does not have any effect on inter-tone duration -- only on overall
duration.

Kevin

-----Original Message-----
From: Venkata Narasimha Murthy Nanduri [mailto:[email-masked]] 
Sent: Friday, November 07, 2003 1:50 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Megaco] Question about Tone list

Hi,

When the MGC specify:

"-Signals "{dg/pt {tl=[d5,d5,d6,d7,d8,d9], Duration = 15000}}"

Does it mean that Timeout between two consecutive tones is 15000/5
milliseconds?

Thanks
Venkata

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: skyeung <[email-masked]>
Date: Fri, 07 Nov 2003 11:06:06 -0800

Hi Kevin:

        How long will each signal be played?  Is each individual 
signal's play
time equal to:  Duration divided by the total number of signals, i.e.
15000/6?

        Or does the duration includes the inter-signal gap?

Thank you very much!

Kevin Boyle wrote:

> Two comments:
>
> First, this signalling is illegal, as it is missing the ind parameter, 
> and ind has no default value.  The MG would reject this Signals 
> descriptor.
>
> Second, duration means duration.  Start at the beginning of the list, 
> and play out the tones in order until you reach the duration 
> specified.  At that time the signal will halt, regardless of which 
> digit is being played out.  Duration does not have any effect on 
> inter-tone duration -- only on overall duration.
>
> Kevin
>

-- 
Steve Yeung
Software Engineer
408-853-4214

---

From: skyeung <[email-masked]>
Date: Fri, 07 Nov 2003 11:06:06 -0800

Hi Kevin:

Thank you very much!

-- 
Steve Yeung
Software Engineer
408-853-4214

---

From: Julie Quan <[email-masked]>
Date: Fri, 7 Nov 2003 11:16:47 -0800 (PST)

Hi, Kevin,

If each digit timeout value is default to 100 millisecond, and the
Inter-Digit duration default is 60 millisecond.
The time spending on playing digits is 6*100 + 5*60 = 900 millisecond.
But there is still 14+ seconds left on specified duration.
Do we play the last digit till the 15 seoncds timeout? or do we stop?

Thanks a lot.
- Julie

> Does it mean that Timeout between two consecutive tones is 15000/5

================================================================
Julie Quan

Phone & Fax: 949-823-1428
Pager: [email-masked]
       1-800-796-7363
       PIN 100-9425
Cisco Systems
121 Theory Dr.
Irvine, CA 92612

---

From: Julie Quan <[email-masked]>
Date: Fri, 7 Nov 2003 11:16:47 -0800 (PST)

Hi, Kevin,

Thanks a lot.
- Julie