Subject: [Megaco] discovering physical terminations

From: Troy Cauble <[email-masked]>
Date: Fri, 07 Nov 2003 13:36:08 -0500

Can someone suggest a minimal, wildcarded request from the MGC
that would cause an MG to return the list of all physical
terminations?

-troy

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Tue, 11 Nov 2003 12:42:08 +1100

G'Day Troy,

There's no simple command that returns a list of all physical terminations. 
These terminations could be in the NULL context or being used in other contexts. 
  I would think that most implementations would use a certain TID structure. So 
you could do an audit Context=ALL, TID=TDM/* and you should get back the 
individual contextID and TID.

Regards, Christian

---

From: Christian Groves <[email-masked]>
Date: Tue, 11 Nov 2003 12:42:08 +1100

G'Day Troy,

Regards, Christian

---

From: Troy Cauble <[email-masked]>
Date: Tue, 11 Nov 2003 10:06:29 -0500

Thanks,

I'm pretty sure that Context=ALL doesn't include the NULL Context,
so I'll have to send
	Context = * { AuditValue = TDM/* }   AND
	Context = - { AuditValue = TDM/* }

Yes?

-troy

Christian Groves wrote:

> G'Day Troy,
> 
> There's no simple command that returns a list of all physical 
> terminations. These terminations could be in the NULL context or being 
> used in other contexts.  I would think that most implementations would 
> use a certain TID structure. So you could do an audit Context=ALL, 
> TID=TDM/* and you should get back the individual contextID and TID.
> 
> Regards, Christian
> 
> Troy Cauble wrote:
> 
>>

---

From: Troy Cauble <[email-masked]>
Date: Tue, 11 Nov 2003 10:06:29 -0500

Thanks,

Yes?

-troy

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 11 Nov 2003 11:22:08 -0500

Hi,

That is the closest would be as follows (substitute TerminationId * with
your physical TerminationId wildcard, e.g. TDM/*).

Note that AuditValue in NULL context should be marked as optional
in case if there is no terminations in NULL context, such that
MG would place an error for it, but will continue on to Context = *

MEGACO/1 [10.1.2.3]:1234
Transaction = 168377 {
   Context = - {
     O-AuditValue = * {
       Audit {}
     }
   },
   Context = * {
     AuditValue = * {
       Audit {}
     }
   }
}

MG could return TerminationIds in "condensed" form (as specified by
the spec) for each context, e.g.:

MEGACO/1 [10.1.2.5]:4321
Reply = 168377 {
   Context = - {
     AuditValue = Context {
       Term1, Term2, Term3 ; all terminations in context NULL
     }
   },
   Context = 123 {
     AuditValue = Context {
       Term4, Term5; all terminations in context 123
     }
   },
   Context = 456 {
     AuditValue = Context {
       Term6, Term7      ; all terminations in context 456
     }
     ; ... etc.
   }
}

Of course caution must be taken with the size of reply.
E.g. TCP should be used, or request should be repeated with
decreased TerminationId wildcard granularity if MG returns error
533 (Response exceeded max PDU size)

BTW. I don't want to be pain, but I wish we could've added "split"
package support, or one of the other solutions discussed on the
list in "Segmentation" thread about a year ago.

Regards,
         Aleks

At 08:42 PM 11/10/2003, Christian Groves wrote:
>used in other contexts.  I would think that most implementations would use 
>a certain TID structure. So you could do an audit Context=ALL, TID=TDM/* 
>and you should get back the individual contextID and TID.
>
>Regards, Christian
>
>Troy Cauble wrote:
>

---

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 11 Nov 2003 11:22:08 -0500

Hi,

MEGACO/1 [10.1.2.3]:1234
Transaction = 168377 {
   Context = - {
     O-AuditValue = * {
       Audit {}
     }
   },
   Context = * {
     AuditValue = * {
       Audit {}
     }
   }
}

MEGACO/1 [10.1.2.5]:4321
Reply = 168377 {
   Context = - {
     AuditValue = Context {

Regards,
         Aleks

---

From: Christian Groves <[email-masked]>
Date: Wed, 12 Nov 2003 09:00:18 +1100

Yes, I was too lazy to add NULL, the main thing was the audit on the partial TID.

Christian

---

From: Christian Groves <[email-masked]>
Date: Wed, 12 Nov 2003 09:00:18 +1100

Christian