Subject: [Megaco] a problem about audit

From: "� �" <[email-masked]>
Date: Mon, 10 Nov 2003 09:01:03 +0800

All,
When MGC restart or HA, Maybe it need audit the context and termination of 
MG, and it can send the command
Context = * {
AuditValue= ROOT {Audit { } }
and the MG should return
Context = 100 {
AuditValue= TermA, TermB
}
Context = 200 {
AuditValue= TermC, TermD
}
Context = 300 {
AuditValue= TermE, TermF
}
And my problem is if the MG has a lot of context and a megaco message can't 
include them, So how do the mg return all its context, thanks!

juniper

_________________________________________________________________
Add photos to your messages with MSN 8. Get 2 months FREE*. 
http://join.msn.com/?page=features/featuredemail

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Sun, 9 Nov 2003 22:25:52 -0500

If you use TCP, there really isn't a limit to the message length, since the
transport will segment the message.

For UDP, I can suggest using short form tokens and removing all
non-mandatory whitespace.  This will help keep the message size down.  Other
than that, at this moment, there's not a lot you can do about the message
size.

Kevin

-----Original Message-----
From: å® ä» [mailto:[email-masked]] 
Sent: Sunday, November 09, 2003 8:01 PM
To: [email-masked]
Subject: [Megaco] a problem about audit

All,
When MGC restart or HA, Maybe it need audit the context and termination of
MG, and it can send the command Context = * { AuditValue= ROOT {Audit { } }
and the MG should return Context = 100 { AuditValue= TermA, TermB } Context
= 200 { AuditValue= TermC, TermD } Context = 300 { AuditValue= TermE, TermF
} And my problem is if the MG has a lot of context and a megaco message
can't include them, So how do the mg return all its context, thanks!

juniper

---

From: "Kevin Boyle" <[email-masked]>
Date: Sun, 9 Nov 2003 22:25:52 -0500

Kevin

-----Original Message-----
From: å® ä» [mailto:[email-masked]] 
Sent: Sunday, November 09, 2003 8:01 PM
To: [email-masked]
Subject: [Megaco] a problem about audit

All,

juniper

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 10 Nov 2003 10:03:38 -0500

The question was how to return all the contexts in existence on the MG.  So,
my answer still stands -- there's not a lot that can be done to overcome the
MTU limitation in UDP.  TCP segments its messages based on the MTU size, so
there's not a problem there.

Kevin

-----Original Message-----
From: FND-AD Wang JuLin [mailto:[email-masked]] 
Sent: Monday, November 10, 2003 12:46 AM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; ? ?; [email-masked]
Subject: RE: [Megaco] a problem about audit

IMO,It depends on the MTU size. If the message larger than it, gateway can
trigger the reply message with error code 533 "RSP EXCEEDS MAX TRANSPORT PDU
SIZE" .

>>From: Kevin Boyle [mailto:[email-masked]]
>>Sent: Monday, November 10, 2003 11:26 AM
>>To: å® ä»; [email-masked]
>>Subject: RE: [Megaco] a problem about audit
>>
>>
>>If you use TCP, there really isn't a limit to the message length, 
>>since the transport will segment the message.
>>
>>non-mandatory whitespace.  This will help keep the message size down.  
>>Other than that, at this moment, there's not a lot you can do about 
>>the message size.
>>
>>Kevin
>>
>>When MGC restart or HA, Maybe it need audit the context and 
>>termination of MG, and it can send the command Context = * { 
>>AuditValue= ROOT {Audit { } } and the MG should return Context = 100 { 
>>AuditValue= TermA, TermB } Context = 200 { AuditValue= TermC, TermD } 
>>Context = 300 { AuditValue= TermE, TermF } And my problem is if the MG 
>>has a lot of context and a
>megaco message

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 10 Nov 2003 10:03:38 -0500

Kevin

---

From: "FND-AD Wang JuLin" <[email-masked]>
Date: Mon, 10 Nov 2003 13:46:26 +0800

IMO,It depends on the MTU size. If the message larger than it, gateway can trigger the reply message with error code 533 "RSP 
EXCEEDS MAX TRANSPORT PDU SIZE" .

>>To: 瀹 浠; [email-masked]
>>From: 瀹 浠 [mailto:[email-masked]] 
>>termination of
��(����x%��Lz��'�~����i����
bz���j)fj��b��?��r

---

From: "FND-AD Wang JuLin" <[email-masked]>
Date: Mon, 10 Nov 2003 13:46:26 +0800

---

From: "� �" <[email-masked]>
Date: Tue, 11 Nov 2003 09:20:39 +0800

So, If MGC can't audit all the context of the MG When MGC switchover, How 
can MGC keep the coherence in the context and termination with MG?

>From: "Kevin Boyle" <[email-masked]>
>To: FND-AD Wang JuLin <[email-masked]>,        ? ? 
><[email-masked]>, [email-masked]
>Date: Mon, 10 Nov 2003 10:03:38 -0500
>

_________________________________________________________________
Add photos to your e-mail with MSN 8. Get 2 months FREE*. 
http://join.msn.com/?page=features/featuredemail

---

From: "� �" <[email-masked]>
Date: Tue, 11 Nov 2003 09:20:39 +0800

---

From: "� �" <[email-masked]>
Date: Fri, 14 Nov 2003 09:20:12 +0800

All,
     If MG found some connection has some problem, And How can MG notify the 
MGC? thanks!

Mark

>From: "å® ä»" <[email-masked]>
>To: [email-masked], [email-masked],        
>[email-masked]
>Date: Tue, 11 Nov 2003 09:20:39 +0800
>

_________________________________________________________________
STOP MORE SPAM with the new MSN 8 and get 2 months FREE* 
http://join.msn.com/?page=features/junkmail

---

From: "� �" <[email-masked]>
Date: Fri, 14 Nov 2003 09:20:12 +0800

All,

Mark

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 14 Nov 2003 10:14:53 -0500

If the MGC has sent the netfail event in the Events descriptor, the MG can
utilize that.  The MG could also send a ServiceChange command.  It would
depend upon the situation and the current descriptor values of the
termination in question.

Kevin

-----Original Message-----
From: å® ä» [mailto:[email-masked]] 
Sent: Thursday, November 13, 2003 8:20 PM
To: [email-masked]; Boyle, Kevin [NCRTP:3Z40:EXCH];
[email-masked]; [email-masked]
Subject: RE: [Megaco] a problem about audit

All,

Mark

>So, If MGC can't audit all the context of the MG When MGC switchover, 
>How can MGC keep the coherence in the context and termination with MG?
>
>
>>my answer still stands -- there's not a lot that can be done to 
>>overcome the MTU limitation in UDP.  TCP segments its messages based 
>>on the MTU size, so there's not a problem there.
>>
>>Kevin
>>
>>IMO,It depends on the MTU size. If the message larger than it, gateway 
>>can trigger the reply message with error code 533 "RSP EXCEEDS MAX 
>>TRANSPORT PDU SIZE" .
>>
>> >>AuditValue= ROOT {Audit { } } and the MG should return Context = 
>> >>100 { AuditValue= TermA, TermB } Context = 200 { AuditValue= TermC, 
>> >>TermD } Context = 300 { AuditValue= TermE, TermF } And my problem 
>> >>is if the MG has a lot of context and a
>> >megaco message

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 14 Nov 2003 10:14:53 -0500

Kevin

-----Original Message-----
From: å® ä» [mailto:[email-masked]] 
Sent: Thursday, November 13, 2003 8:20 PM
To: [email-masked]; Boyle, Kevin [NCRTP:3Z40:EXCH];

All,

Mark

---

From: "� �" <[email-masked]>
Date: Sat, 15 Nov 2003 09:12:59 +0800

Kevin,
       Thank you for help, So, If MG doubt the status of some connection or 
termination aren't coherence with the MGC, How MG audit these connection or 
termination with MGC?

Mark

>To: å® ä» <[email-masked]>, [email-masked],        
>[email-masked]
>Date: Fri, 14 Nov 2003 10:14:53 -0500
>

---

From: "� �" <[email-masked]>
Date: Sat, 15 Nov 2003 09:12:59 +0800

Kevin,

Mark

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 17 Nov 2003 13:52:37 -0500

MGs cannot audit.  It must wait for the MGC to figure out that something is
not right.

Kevin

-----Original Message-----
From: å® ä» [mailto:[email-masked]] 
Sent: Friday, November 14, 2003 8:13 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked];
[email-masked]

Kevin,

Mark

>If the MGC has sent the netfail event in the Events descriptor, the MG 
>can utilize that.  The MG could also send a ServiceChange command.  It 
>would depend upon the situation and the current descriptor values of 
>the termination in question.
>
>Kevin
>
>      If MG found some connection has some problem, And How can MG 
>notify the MGC? thanks!
>
>Mark
>
>
> >>IMO,It depends on the MTU size. If the message larger than it, 
> >>gateway can trigger the reply message with error code 533 "RSP 
> >> >>Other than that, at this moment, there's not a lot you can do 
> >> >>about the message size.
> >> >>
> >> >>Kevin
> >> >>
> >> >>100 { AuditValue= TermA, TermB } Context = 200 { AuditValue= 
> >> >>TermC, TermD } Context = 300 { AuditValue= TermE, TermF } And my 
> >> >>problem is if the MG has a lot of context and a
> >> >megaco message

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 17 Nov 2003 13:52:37 -0500

Kevin

-----Original Message-----
From: å® ä» [mailto:[email-masked]] 
Sent: Friday, November 14, 2003 8:13 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]; [email-masked];
[email-masked]

Kevin,

Mark