Subject: [Megaco] when do I send TransactionResponseAck

From: "Kumar.U." <[email-masked]>
Date: Wed, 19 Nov 2003 11:14:04 +0530

Hi All,
  We are implementing megaco MG with UDP and TCP as underlying transport
layers. Sending TransactionResponseAck is little bit of confusing for me.
When do I send TransactionResponseAck? .I feel that we need to send
TransactionResponseAck when the underlying transport layer is UDP. Is it
correct? Please clarify me on this.

Thanks & Regards,
Kumaraswamy.U.
Senior S/W engineer,
Analog Devices, INDIA.

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 20 Nov 2003 12:21:20 -0500

Actually, when using any non-guaranteed transport, the three-way handshake
may be used -- not just in the cases of ImmAckReq.

Kevin

-----Original Message-----
From: Anil Jangam (anilj) [mailto:[email-masked]] 
Sent: Thursday, November 20, 2003 1:43 AM
To: 'Kumar.U.'; [email-masked]
Subject: RE: [Megaco] when do I send TransactionResponseAck

Hi kumar,
TransactionResponseAck is part of Three-way-handshake process, refer to
D.1.2@rfc3525 broadly falling under the ALF.
It is sent under two different cases. First when the ImmAckRequiredToken is
explicitly specified in a TransactionReply and in second case when a
provisional response for a Transaction Request is received, upon reception
of final response, the TransactionResponseAck is sent. Refer to the
appropriate sections of the rfc for more details.
/anil.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf 
> Of Kumar.U.
> Sent: Wednesday, November 19, 2003 11:14 AM
> To: [email-masked]
> Subject: [Megaco] when do I send TransactionResponseAck
> 
> 
> Hi All,
>   We are implementing megaco MG with UDP and TCP as underlying 
> transport layers. Sending TransactionResponseAck is little bit of 
> confusing for me. When do I send TransactionResponseAck? .I feel that 
> we need to send TransactionResponseAck when the underlying transport 
> layer is UDP. Is it correct? Please clarify me on this.
> 
> Thanks & Regards,
> Kumaraswamy.U.
> Senior S/W engineer,
> Analog Devices, INDIA.
> 
>

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 20 Nov 2003 12:21:20 -0500

Kevin

-----Original Message-----
From: Anil Jangam (anilj) [mailto:[email-masked]] 
Sent: Thursday, November 20, 2003 1:43 AM
To: 'Kumar.U.'; [email-masked]
Subject: RE: [Megaco] when do I send TransactionResponseAck

Hi kumar,