Subject: [Megaco] ServiceChange/ Restart question

From: Troy Cauble <[email-masked]>
Date: Fri, 07 Nov 2003 19:28:31 -0500

ON STARTUP an MG sends:
==========

MEGACO/1 [192.168.17.217]
Transaction = 667 {
   Context = - {
     ServiceChange = ROOT {
       Services {
         Method = Restart
       }
     }
   }
}

Does the use of ROOT imply that all terminations are InService?

If the MG is configured (via SNMP for example) to have some terminations
disabled, should it send "Method = Restart" for each enabled termination
instead of one for ROOT?  (All in the same Context/Transaction/Message?)

If so, should it also send "Method = Forced" or "Method = Graceful"
for the disabled terminations?

Thanks,

-troy

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Sun, 9 Nov 2003 19:58:08 -0500

Not true.  ServiceStates is a parameter on every termination, not just Root.
Further, the spec indicates that the default value for the ServiceStates
parameter is "Inservice".  This means that upon registration, all
terminations are assumed to be inservice.  

The MG can prevent this by sending subsequent SC Forced messages on the
terminations that are out of service.

Kevin

-----Original Message-----
From: Venugopal Sharma [mailto:[email-masked]] 
Sent: Saturday, November 08, 2003 1:40 PM
To: Troy Cauble
Cc: MEGACO list
Subject: Re: [Megaco] ServiceChange/ Restart question

Troy,

I think ROOT termination indicates MG as a whole. In Service and Out of
Service messages are sent only at the MG level and not per terminations.
Hence 'In service' should only indicate that the H248 stack is up and
running in the MG.

thanks / Venu
--------------
Troy Cauble wrote:
> If the MG is configured (via SNMP for example) to have some 
> terminations disabled, should it send "Method = Restart" for each 
> enabled termination instead of one for ROOT?  (All in the same 
> Context/Transaction/Message?)
>

---

From: "Kevin Boyle" <[email-masked]>
Date: Sun, 9 Nov 2003 19:58:08 -0500

Kevin

-----Original Message-----
From: Venugopal Sharma [mailto:[email-masked]] 
Sent: Saturday, November 08, 2003 1:40 PM
To: Troy Cauble
Cc: MEGACO list
Subject: Re: [Megaco] ServiceChange/ Restart question

Troy,

thanks / Venu
--------------