Subject: [Megaco] LONG-TIMER expiry handling

From: vijayabama gurunathan <[email-masked]>
Date: Thu, 20 Nov 2003 03:32:16 -0800 (PST)

hi,
from megaco version-2,

 "The copy of the responses may be destroyed either
LONG-TIMER seconds 
   after the response is issued, or when the entity
receives a 
   confirmation that the response has been received,
through the 
   "Response Acknowledgement parameter"." 

When the long timer expires, what should be done?
   *) Destroy the copy of the responses.
                           or
   *) Resend the response and destroy the copy of the
response.

which one is correct?

thanks in advance,
bama

__________________________________
Do you Yahoo!?
Free Pop-Up Blocker - Get it now
http://companion.yahoo.com/

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Suman Choudhary <[email-masked]>
Date: Thu, 20 Nov 2003 19:48:44 +0530

Choice 1 is correct.
Destroy the copy of the responses.

--suman

---

From: Suman Choudhary <[email-masked]>
Date: Thu, 20 Nov 2003 19:48:44 +0530

Choice 1 is correct.

--suman

---

From: "Rasool Wani" <[email-masked]>
Date: Thu, 20 Nov 2003 19:55:53 +0800

Destroy it, first one.
Rasool Wani

---

From: "Rasool Wani" <[email-masked]>
Date: Thu, 20 Nov 2003 19:55:53 +0800

Destroy it, first one.
Rasool Wani

---

From: Krishnamurthy V <[email-masked]>
Date: Mon, 24 Nov 2003 12:48:19 -0500

hi rasool,

this is with respect to the document TSS&TP, ETSI TS 101 889-2,
which says the valid behaviour of an MGC should be :

"on expiry the Transaction Timer without the receipt of the
corresponding Transaction Response Acknowledge, resends
the previous Transaction Reply"

refer the test case TP/MGC/TR/BV-02, i.e. 5.2.10.1.

does it contradicts with the rfc or i got it wrong?

please clarify. thank you.
-krish.

-- 
-------------------------------------------------------------------------
V Krishnamurthy			Phone (O): 080-2263399 Ext:255
Internet Telephony Group,	      (R): 080-3339368
C-DoT, 71/1, Miller Road,	      (M): 98453 79041	
Bangalore - 560052
-------------------------------------------------------------------------
The very strength that protects the heart from injury is the strength
that prevents the heart from enlarging to its intended greatness within.
-Kahlil Gibran.
-------------------------------------------------------------------------

---

From: Krishnamurthy V <[email-masked]>
Date: Mon, 24 Nov 2003 12:48:19 -0500

hi rasool,

---

From: "Anil Jangam \(anilj\)" <[email-masked]>
Date: Mon, 24 Nov 2003 16:17:43 +0530

Hi Krish,

Upon the expiry of the retransmission timer, the given transaction
should be repeated/retransmitted. See [email-masked] (last para). 
According to this, in case of three-way-handshake, it is necessary to
repeat the Transaction Reply if the timer expiry happens before you
receive the TxnResAck. This behaviour will continue till the Long Timer
associated with the Transaction Reply expires.

/anil.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Krishnamurthy V
> Sent: Monday, November 24, 2003 11:18 PM
> To: Rasool Wani
> Cc: vijayabama gurunathan; [email-masked]
> Subject: Re: [Megaco] LONG-TIMER expiry handling
> 
> 
> hi rasool,
> 
> this is with respect to the document TSS&TP, ETSI TS 101 
> 889-2, which says the valid behaviour of an MGC should be :
> 
> corresponding Transaction Response Acknowledge, resends the 
> previous Transaction Reply"
> 
> >>   *) Resend the response and destroy the copy of the response.
> >>
> >>which one is correct?
> >>
> >>thanks in advance,
> >>bama
> >>
> >>    
> >>
> 
> -- 
> The very strength that protects the heart from injury is the 
> strength that prevents the heart from enlarging to its 
> intended greatness within. -Kahlil Gibran.

---

From: "Anil Jangam \(anilj\)" <[email-masked]>
Date: Mon, 24 Nov 2003 16:17:43 +0530

Hi Krish,

/anil.

---

From: "Rasool Wani" <[email-masked]>
Date: Mon, 24 Nov 2003 20:53:46 +0800

anil,
  you mean TransactionReply's  are to be retransmitted too.but [email-masked]
(last para) reads like this:

Applications SHOULD implement an application level timer per transaction.
Expiration of the timer should cause a retransmission of the request.
Receipt of a Reply should cancel the timer.  Receipt of Pending should
restart the timer.

I understand it only says about the  retransmission of TransactionRequest.

Rasool wani

----- Original Message -----
From: "Anil Jangam (anilj)" <[email-masked]>
To: "'Krishnamurthy V'" <[email-masked]>; "'Rasool Wani'"
<[email-masked]>
Cc: "'vijayabama gurunathan'" <[email-masked]>; <[email-masked]>
Sent: Monday, November 24, 2003 6:47 PM
Subject: RE: [Megaco] LONG-TIMER expiry handling

---

From: "Anil Jangam \(anilj\)" <[email-masked]>
Date: Mon, 24 Nov 2003 19:07:37 +0530

***The retransmission of the TransactionReply is an exceptional case in
Three-way-handshake only.*** In this perticular feature, unless you
receive the TxnResAck for the given TxnReply, the Three-way-handshake is
not completed. Once you send the TxnReply, how are you going to know
that the other side has really received it or not? 

> From: Rasool Wani [mailto:[email-masked]] 
> Sent: Monday, November 24, 2003 6:24 PM
> To: [email-masked]; 'Krishnamurthy V'
> Cc: 'vijayabama gurunathan'; [email-masked]
>   you mean TransactionReply's  are to be retransmitted 
> too.but [email-masked] (last para) reads like this:
> 
> Applications SHOULD implement an application level timer per 
> transaction. Expiration of the timer should cause a 
> retransmission of the request. Receipt of a Reply should 
> cancel the timer.  Receipt of Pending should restart the timer.
> 
> To: "'Krishnamurthy V'" <[email-masked]>; "'Rasool 
> Wani'" <[email-masked]>
> > should be repeated/retransmitted. See [email-masked] (last 
> para). According 
> > to this, in case of three-way-handshake, it is necessary to 
> repeat the 
> > Transaction Reply if the timer expiry happens before you 
> receive the 
> > TxnResAck. This behaviour will continue till the Long Timer 
> associated 
> > > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > > Of Krishnamurthy V
> > > >>   after the response is issued, or when the entity receives a
> > > strength that prevents the heart from enlarging to its intended 
> > > greatness within. -Kahlil Gibran.
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/megaco
> > >
> >
> >

---

From: "Anil Jangam \(anilj\)" <[email-masked]>
Date: Mon, 24 Nov 2003 19:07:37 +0530

---

From: "Rasool Wani" <[email-masked]>
Date: Mon, 24 Nov 2003 20:53:46 +0800

anil,

Rasool wani

----- Original Message -----
From: "Anil Jangam (anilj)" <[email-masked]>
To: "'Krishnamurthy V'" <[email-masked]>; "'Rasool Wani'"
<[email-masked]>