Subject: [Fwd: FW: [MEGACO] Can a gateway drop active calls?]

From: Tom Taylor <[email-masked]>
Date: Wed, 05 Nov 2003 08:14:24 -0500

-------- Original Message --------
Subject: 	FW: [MEGACO] Can a gateway drop active calls?
Date: 	Wed, 5 Nov 2003 14:58:11 +0200
From: 	Nurit Shenhar <[email-masked]>
To: 	Taylor, Tom-PT [CAR:5N00:EXCH]<[email-masked]>

Tom

Again, it didn’t reach the list…

Nurit

-----Original Message-----
*From:* Nurit Shenhar
*Sent:* Wednesday, November 05, 2003 9:00 AM
*To:* [email-masked]'
*Subject:* [MEGACO] Can a gateway drop active calls?

Hi

Assuming the following scenario:

    1. GW is active with open calls.
    2. Connection with the MGC is lost, and reconnection to all possible
       MGC is not successful. This state goes on for a long time
       (minutes, hours).

Is it legitimate for the GW in this state to drop the active calls?

*/ /*

*/Nurit Shenhar/*

*/H.248 Prime/*

**

E-Mail: [email-masked]

Fax.    +972-3-5394223

www.audiocodes.com <http://www.audiocodes.com/>

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 5 Nov 2003 09:16:40 -0500

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: Taylor, Tom-PT [CAR:5N00:EXCH] 
Sent: Wednesday, November 05, 2003 8:14 AM
To: [email-masked]
Subject: [Fwd: FW: [MEGACO] Can a gateway drop active calls?]

-------- Original Message --------
Subject: 	FW: [MEGACO] Can a gateway drop active calls?
Date: 	Wed, 5 Nov 2003 14:58:11 +0200
From: 	Nurit Shenhar <[email-masked]>
To: 	Taylor, Tom-PT [CAR:5N00:EXCH]<[email-masked]>

Tom

Again, it didn't reach the list...

Nurit

-----Original Message-----
*From:* Nurit Shenhar

Hi

[KJBII] Technically no.  However, if the MG is unable to connect to any
MGCs, how would the MGCs know the MG didn't undergo a cold boot?  Be very
careful here, though -- subscribers tend to complain a lot to their
providers when calls are dropped.  I think that if an MG wants to drop
calls, it better have a very good reason -- that is, it should cold reboot.

*/ /*

*/Nurit Shenhar/*

*/H.248 Prime/*

**

Fax.    +972-3-5394223

---

From: "Kevin Boyle" <[email-masked]>
Date: Wed, 5 Nov 2003 09:16:40 -0500

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: Taylor, Tom-PT [CAR:5N00:EXCH] 
Sent: Wednesday, November 05, 2003 8:14 AM
To: [email-masked]
Subject: [Fwd: FW: [MEGACO] Can a gateway drop active calls?]

-------- Original Message --------
Subject: 	FW: [MEGACO] Can a gateway drop active calls?
Date: 	Wed, 5 Nov 2003 14:58:11 +0200
From: 	Nurit Shenhar <[email-masked]>
To: 	Taylor, Tom-PT [CAR:5N00:EXCH]<[email-masked]>

Tom

Nurit

-----Original Message-----
*From:* Nurit Shenhar

Hi

*/ /*

*/Nurit Shenhar/*

*/H.248 Prime/*

**

Fax.    +972-3-5394223

---

From: Kalleitner Franz <[email-masked]>
Date: Thu, 6 Nov 2003 14:26:38 +0100

I would say, MGC would also detect that the MG is not accessable. If no
other possibility can be triggered to access the MG. MGC would start to
release the calls on signaling level. 
The end point would stop transferring user payload or start a bearer release
depending on the chosen L2/L3 protocol used for the connection.

ciao
Franz

-----Ursprungliche Nachricht-----
Von: Kevin Boyle [mailto:[email-masked]]
Gesendet: Mittwoch, 05. November 2003 15:17
An: [email-masked]
Betreff: RE: [Fwd: FW: [MEGACO] Can a gateway drop active calls?]

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: Taylor, Tom-PT [CAR:5N00:EXCH] 
Sent: Wednesday, November 05, 2003 8:14 AM
To: [email-masked]
Subject: [Fwd: FW: [MEGACO] Can a gateway drop active calls?]

-------- Original Message --------
Subject: 	FW: [MEGACO] Can a gateway drop active calls?
Date: 	Wed, 5 Nov 2003 14:58:11 +0200
From: 	Nurit Shenhar <[email-masked]>
To: 	Taylor, Tom-PT [CAR:5N00:EXCH]<[email-masked]>

Tom

Nurit

-----Original Message-----
*From:* Nurit Shenhar

Hi

*/ /*

*/Nurit Shenhar/*

*/H.248 Prime/*

**

Fax.    +972-3-5394223

---

From: Kalleitner Franz <[email-masked]>
Date: Thu, 6 Nov 2003 14:26:38 +0100

ciao
Franz

-----Ursprungliche Nachricht-----
Von: Kevin Boyle [mailto:[email-masked]]
Gesendet: Mittwoch, 05. November 2003 15:17
An: [email-masked]
Betreff: RE: [Fwd: FW: [MEGACO] Can a gateway drop active calls?]

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: Taylor, Tom-PT [CAR:5N00:EXCH] 
Sent: Wednesday, November 05, 2003 8:14 AM
To: [email-masked]
Subject: [Fwd: FW: [MEGACO] Can a gateway drop active calls?]

-------- Original Message --------
Subject: 	FW: [MEGACO] Can a gateway drop active calls?
Date: 	Wed, 5 Nov 2003 14:58:11 +0200
From: 	Nurit Shenhar <[email-masked]>
To: 	Taylor, Tom-PT [CAR:5N00:EXCH]<[email-masked]>

Tom

Nurit

-----Original Message-----
*From:* Nurit Shenhar

Hi

*/ /*

*/Nurit Shenhar/*

*/H.248 Prime/*

**

Fax.    +972-3-5394223

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 6 Nov 2003 11:36:47 -0500

The MGC could figure out that the MG has gone, but remember that the MGC
cannot establish control associations.  So, this means that the MGC has to
wait for the MG to make the next contact, not the other way around.  For the
primary MGC, this will be via a SC Disconnected.

The MG is specifically prohibited from altering terminations or contexts
without MGC direction.  Because of this prohibition, the MGC MUST intervene
to clean up any contexts that existed at the time of communications loss.
The only exception to this is if the MG undergoes a Cold Boot, at which time
the MGC can assume that all state is lost and the MG is in a newly started
state.

Also note that there is no such thing as an endpoint in H.248.  H.248
operates on terminations.  Terminations and endpoints are two different
concepts.

Kevin

-----Original Message-----
From: Kalleitner Franz [mailto:[email-masked]] 
Sent: Thursday, November 06, 2003 8:27 AM
To: [email-masked]
Subject: AW: [Fwd: FW: [MEGACO] Can a gateway drop active calls?]

ciao
Franz

-----Ursprungliche Nachricht-----
Von: Kevin Boyle [mailto:[email-masked]]
Gesendet: Mittwoch, 05. November 2003 15:17
An: [email-masked]
Betreff: RE: [Fwd: FW: [MEGACO] Can a gateway drop active calls?]

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: Taylor, Tom-PT [CAR:5N00:EXCH]
Sent: Wednesday, November 05, 2003 8:14 AM
To: [email-masked]
Subject: [Fwd: FW: [MEGACO] Can a gateway drop active calls?]

-------- Original Message --------
Subject: 	FW: [MEGACO] Can a gateway drop active calls?
Date: 	Wed, 5 Nov 2003 14:58:11 +0200
From: 	Nurit Shenhar <[email-masked]>
To: 	Taylor, Tom-PT [CAR:5N00:EXCH]<[email-masked]>

Tom

Nurit

-----Original Message-----
*From:* Nurit Shenhar

Hi

*/ /*

*/Nurit Shenhar/*

*/H.248 Prime/*

**

Fax.    +972-3-5394223

---

From: "Kevin Boyle" <[email-masked]>
Date: Thu, 6 Nov 2003 11:36:47 -0500

Kevin

-----Original Message-----
From: Kalleitner Franz [mailto:[email-masked]] 
Sent: Thursday, November 06, 2003 8:27 AM
To: [email-masked]
Subject: AW: [Fwd: FW: [MEGACO] Can a gateway drop active calls?]

ciao
Franz

-----Ursprungliche Nachricht-----
Von: Kevin Boyle [mailto:[email-masked]]
Gesendet: Mittwoch, 05. November 2003 15:17
An: [email-masked]
Betreff: RE: [Fwd: FW: [MEGACO] Can a gateway drop active calls?]

Comments inline. [KJBII]

Kevin

-----Original Message-----
From: Taylor, Tom-PT [CAR:5N00:EXCH]
Sent: Wednesday, November 05, 2003 8:14 AM
To: [email-masked]
Subject: [Fwd: FW: [MEGACO] Can a gateway drop active calls?]

-------- Original Message --------
Subject: 	FW: [MEGACO] Can a gateway drop active calls?
Date: 	Wed, 5 Nov 2003 14:58:11 +0200
From: 	Nurit Shenhar <[email-masked]>
To: 	Taylor, Tom-PT [CAR:5N00:EXCH]<[email-masked]>

Tom

Nurit

-----Original Message-----
*From:* Nurit Shenhar

Hi

*/ /*

*/Nurit Shenhar/*

*/H.248 Prime/*

**

Fax.    +972-3-5394223

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 06 Nov 2003 11:42:29 -0500

And what if signalling used is CAS handled by same MG using MEGACO?
         Aleks

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 06 Nov 2003 11:42:29 -0500