Subject: [Megaco] Question about Tone list

From: Venkata Narasimha Murthy Nanduri <[email-masked]>
Date: Fri, 07 Nov 2003 10:49:55 -0800

Hi,

When the MGC specify:

"-Signals "{dg/pt {tl=[d5,d5,d6,d7,d8,d9], Duration = 15000}}"

Does it mean that Timeout between two consecutive tones is 15000/5 
milliseconds?

Thanks
Venkata

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 7 Nov 2003 13:59:42 -0500

Two comments:

First, this signalling is illegal, as it is missing the ind parameter, and
ind has no default value.  The MG would reject this Signals descriptor.

Second, duration means duration.  Start at the beginning of the list, and
play out the tones in order until you reach the duration specified.  At that
time the signal will halt, regardless of which digit is being played out.
Duration does not have any effect on inter-tone duration -- only on overall
duration.

Kevin

-----Original Message-----
From: Venkata Narasimha Murthy Nanduri [mailto:[email-masked]] 
Sent: Friday, November 07, 2003 1:50 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Megaco] Question about Tone list

Hi,

When the MGC specify:

Thanks
Venkata

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 7 Nov 2003 14:12:19 -0500

The signals descriptor provided will play each digit for the length of time
provisioned in the MG.  There is no way to override the duration of one
signal in a list using playtone.  If you need to play a list of signals and
be able to override the signals individually, then you have to use the
SignalList construct.
 
Because playtone is, itself, a signal, the duration parameter applies to the
entire list as a whole (that is, it applies to pt, not the individual tones
in the tl list).  The tones in the list are played out according to their
provisioning in the MG.
 
Kevin

  _____  

From: skyeung [mailto:[email-masked]] 
Sent: Friday, November 07, 2003 2:06 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: Venkata Narasimha Murthy Nanduri; [email-masked]; [email-masked]
Subject: Re: [Megaco] Question about Tone list

Hi Kevin:

        How long will each signal be played?  Is each individual signal's
play
time equal to:  Duration divided by the total number of signals, i.e.
15000/6? 

        Or does the duration includes the inter-signal gap?

Thank you very much!

Kevin Boyle wrote:

Two comments: 

Kevin 

-----Original Message----- 
From: Venkata Narasimha Murthy Nanduri [mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Friday, November 07, 2003 1:50 PM 
To: [email-masked] <mailto:[email-masked]>  
Cc: [email-masked] <mailto:[email-masked]> ; [email-masked]
<mailto:[email-masked]>  
Subject: [Megaco] Question about Tone list 

Hi, 

When the MGC specify: 

Thanks 
Venkata 

_______________________________________________ 
Megaco mailing list 
[email-masked] <mailto:[email-masked]>  
https://www1.ietf.org/mailman/listinfo/megaco
<https://www1.ietf.org/mailman/listinfo/megaco>  

-- 

Steve Yeung

Software Engineer

408-853-4214

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 7 Nov 2003 14:12:19 -0500

Kevin

  _____  

Hi Kevin:

Thank you very much!

Kevin Boyle wrote:

Two comments: 

Kevin 

-----Original Message----- 

Hi, 

When the MGC specify: 

Thanks 
Venkata 

-- 

Steve Yeung

Software Engineer

408-853-4214

---

From: "Kevin Boyle" <[email-masked]>
Date: Sun, 9 Nov 2003 22:18:45 -0500

Well... I would think that the final tone would effectively be overridden to
fill out the duration of the list, so the former of the two options.  I
suppose, however, that it would be up to the MG.  

Note that with playtone, the ind parameter must be specified.

Kevin

-----Original Message-----
From: Julie Quan [mailto:[email-masked]] 
Sent: Friday, November 07, 2003 2:17 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: Venkata Narasimha Murthy Nanduri; [email-masked]; [email-masked]
Subject: RE: [Megaco] Question about Tone list

Hi, Kevin,

If each digit timeout value is default to 100 millisecond, and the
Inter-Digit duration default is 60 millisecond.
The time spending on playing digits is 6*100 + 5*60 = 900 millisecond.
But there is still 14+ seconds left on specified duration.
Do we play the last digit till the 15 seoncds timeout? or do we stop?

Thanks a lot.
- Julie

> Two comments:
>
> First, this signalling is illegal, as it is missing the ind parameter, 
> and ind has no default value.  The MG would reject this Signals
descriptor.
>
> Second, duration means duration.  Start at the beginning of the list, 
> and play out the tones in order until you reach the duration 
> specified.  At that time the signal will halt, regardless of which digit
is being played out.
> Duration does not have any effect on inter-tone duration -- only on 
> overall duration.
>
> Kevin
>

================================================================
Julie Quan

Phone & Fax: 949-823-1428
Pager: [email-masked]
       1-800-796-7363
       PIN 100-9425
Cisco Systems
121 Theory Dr.
Irvine, CA 92612

---

From: "Kevin Boyle" <[email-masked]>
Date: Sun, 9 Nov 2003 22:18:45 -0500

Kevin

-----Original Message-----
From: Julie Quan [mailto:[email-masked]] 
Sent: Friday, November 07, 2003 2:17 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: Venkata Narasimha Murthy Nanduri; [email-masked]; [email-masked]
Subject: RE: [Megaco] Question about Tone list

Hi, Kevin,

Thanks a lot.
- Julie

descriptor.
is being played out.