Subject: [Megaco] g/sc Notification during Subtract

From: "Harry Suede" <[email-masked]>
Date: Wed, 12 Nov 2003 06:06:28 -0500

Hi List,

A signal is being applied on a termination in Non-NULL context. Then MGC sends Subtract command on the termination. The MG will stop the signal during processing of Subtract command. Should MG send the Notify command for g/sc event with "NC" (Not completed, other cause) towards MGC?

I think , since all the active descriptors shall be reset during Subtract processing, so MG should **not** send g/sc notification as Events descriptor doesn't contain g/sc at that point of time.

Pls. respond.

Thanks
Harry.

-- 
__________________________________________________________
Sign-up for your own personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

Search Smarter - get the new eXact Search Bar for free!
http://www.exactsearchbar.com/

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Kevin Boyle" <[email-masked]>
Date: Fri, 14 Nov 2003 13:10:24 -0500

It is not possible to put an Events descriptor in a Subtract command.  I
believe Harry raises a good point -- the subtract results in the clearing of
the descriptors -- including the Events descriptor.  Since the MGC issued
the Subtract command, it should know that the signal halted without being
told by the MG.

I agree with Harry that the notification is suppressed by the Subtract
command, since there is the implied reset of the Events descriptor.

Kevin 

-----Original Message-----
From: Sampath Komanduri [mailto:[email-masked]] 
Sent: Friday, November 14, 2003 3:47 AM
To: 'Harry Suede'; [email-masked]
Subject: RE: [Megaco] g/sc Notification during Subtract

Hi Harry,
Assuming that there *wasn't* an empty events descriptor in the Subtract, MG
should send a g/sc event notification with method set to "NC" (Not
completed, other cause).

I don't find anything specified in the protocol with respect to special
handling of g/sc for Subtract. Therefore, normal handling (notify MGC if
Signal playout was aborted for any reason) of g/sc should apply.

Thanks,
Sampath

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Harry Suede
Sent: Wednesday, November 12, 2003 3:06 AM
To: [email-masked]
Subject: [Megaco] g/sc Notification during Subtract

Hi List,

A signal is being applied on a termination in Non-NULL context. Then MGC
sends Subtract command on the termination. The MG will stop the signal
during processing of Subtract command. Should MG send the Notify command for
g/sc event with "NC" (Not completed, other cause) towards MGC?

I think , since all the active descriptors shall be reset during Subtract
processing, so MG should **not** send g/sc notification as Events descriptor
doesn't contain g/sc at that point of time.

Pls. respond.

Thanks
Harry.

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 17 Nov 2003 13:09:19 -0500

Add only clears them if the descriptor in question is included.  In that
case, the descriptor is replaced with the new value.

Kevin

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]] 
Sent: Friday, November 14, 2003 5:56 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: Re: [Megaco] g/sc Notification during Subtract

Kevin Boyle wrote:

> It is not possible to put an Events descriptor in a Subtract command.  
> I believe Harry raises a good point -- the subtract results in the 
> clearing of the descriptors -- including the Events descriptor.  Since 
> the MGC issued the Subtract command, it should know that the signal 
> halted without being told by the MG.
> 

Also, from another thread....

Kevin Boyle wrote:
 > Everything is maintained during a Move command, including Signals and  >
Events.  This is what makes Move different from a Subtract/Add.
 > Kevin

So does an Add clear Events and Signals as well?

-troy

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 17 Nov 2003 13:09:19 -0500

Kevin

-----Original Message-----
From: Troy Cauble [mailto:[email-masked]] 
Sent: Friday, November 14, 2003 5:56 PM
To: Boyle, Kevin [NCRTP:3Z40:EXCH]
Cc: [email-masked]
Subject: Re: [Megaco] g/sc Notification during Subtract

-troy

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 17 Nov 2003 14:39:52 -0500

Generally speaking, the signal complete event is for the benefit of the MGC,
since it doesn't have any knowledge of exactly when a signal terminates.
There are four reportable possibilities as to WHY a signal terminated:
 
The signal reached the end of its natural duration (TO)
The signals descriptor was replaced (IBS)
An event was detected (IBE)
Something else happened (OR)
 
Remember that it may not be that the MGC wants to know just that the signal
terminated.  It may be that the MGC wants to know exactly WHEN the signal
terminated.  This can be determined by the timestamp on the Notify.  So,
returning the event is, in general, a good idea when at all possible.
 
There arises a problem with Subtract, however.  Subtract resets the values
of the descriptors to a default value.  This means that the Signals and
Events descriptors are (generally) cleared.  So the signal stops... but the
event detection ALSO stops.  So there is no event to be detected.  This is
similar to sending a Transaction where both the Signals and Events
descriptors are cleared in the same Modify command --  I would think that
the Notify would NOT be sent.
 
So, in the case of ServiceChange, send the Notify as long as you have an
Events descriptor that contains g/sc once the command has completed
execution.
 
Kevin

  _____  

From: Sampath Komanduri [mailto:[email-masked]] 
Sent: Friday, November 14, 2003 5:31 PM
To: 'Shobhit Bansal'; Boyle, Kevin [NCRTP:3Z40:EXCH]; 'Harry Suede';
[email-masked]
Subject: RE: [Megaco] g/sc Notification during Subtract

Shobhit,
My answers are based on Kevin's response to earlier mail on this issue:
 
There are two scenarios that we should consider:
a) MGC initiated termination out-of-service: MG needn't send the g/sc
notification to MGC (going by Kevin's logic that MGC can derive this
information). 
I don't know what should be MGC's behavior if it receives g/sc (with any
method) after it has sent SUBTRACT or ServiceChange message but before it
receives the corresponding response (Kevin ??)
b) MG initiated termination out-of-service: MG needn't send the g/sc
notification to MGC since (again) MGC can derive this information.
 
Sampath

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Shobhit Bansal
Sent: Friday, November 14, 2003 10:34 AM
To: Kevin Boyle; Sampath Komanduri; 'Harry Suede'; [email-masked]
Subject: RE: [Megaco] g/sc Notification during Subtract

Hi Kevin,
 
What should be the behaviour if a service change message is sent on the
termination on which the signals were playing. Should a notification be sent
to MGC in this scenario ?
 
Thanks
Shobhit

Kevin Boyle <[email-masked]> wrote:

Kevin 

-----Original Message-----
From: Sampath Komanduri [mailto:[email-masked]] 
Sent: Friday, November 14, 2003 3:47 AM
To: 'Harry Suede'; [email-masked]
Subject: RE: [Megaco] g/sc Notification during Subtract

Hi Harry,
Assuming that there *wasn't* an empty events descriptor in the Subtract, MG
should send a g/sc event notification with method set to "NC" (Not
co! mpleted, other cause).

Thanks,
Sampath

-----Original Message-----

Hi List,

Pls. respond.

Thanks
Harry.

 <http://yahoo.shaadi.com> Yahoo! India Matrimony: Find your partner online.
Post your  <http://yahoo.shaadi.com> profile.

---

From: "Kevin Boyle" <[email-masked]>
Date: Mon, 17 Nov 2003 14:39:52 -0500

Kevin

  _____  

Shobhit,

Sampath

-----Original Message-----

Hi Kevin,

Thanks
Shobhit

Kevin 

-----Original Message-----
From: Sampath Komanduri [mailto:[email-masked]] 
Sent: Friday, November 14, 2003 3:47 AM
To: 'Harry Suede'; [email-masked]
Subject: RE: [Megaco] g/sc Notification during Subtract

Hi Harry,

Thanks,
Sampath

-----Original Message-----

Hi List,

Pls. respond.

Thanks
Harry.