Subject: [Megaco] a doubt about sdp in h248 message

From: zhuning 17035 <[email-masked]>
Date: Tue, 01 Jun 2004 16:52:00 +0800

Hi,
    after  a rtp termination is added to a context and ip ,port and codec is reported to mgc ,if mgc wants to just change the codec but the ip and port will not be change .can mgc use '-' as ip and port in sdp of local?

1. MGC->MGW
MEGACO/1 [182.20.20.1]:2944 T=369361149{C=${A=A1{M{O{MO=SR,RV=OFF,RG=OFF}},E=369100037{al/*},SG{}},A=${M{O{MO=IN,RV=OFF,RG=OFF,nt/jit=40},L{v=0c=IN IP4 $m=audio $ RTP/AVP 8}}}}}

2.MGW->MGC
MEGACO/1 [182.020.020.050]:2944 P=369361149{C=116{A=A1,A=A100000039{M{O{MO=IN,RV=OFF,RG=OFF,nt/jit=40},L{v=0c=IN IP4 182.20.20.50m=audio 16856 RTP/AVP 8}}}}}

.
.
.
.
.
.
if mgc wants to change the codec of A100000039 to 18 ,can mgc use 
MEGACO/1 [182.20.20.1]:2944 T=370278656{C=116{MF=A1{M{O{RV=OFF,RG=OFF,tdmc/ec=ON}},E=369100040{al/*},SG{}},MF=A100000039{M{O{MO=SR,RV=OFF,RG=OFF,tdmc/ec=ON},L{v=0c=IN IP4 -m=audio - RTP/AVP 18},R{v=0c=IN IP4 182.20.20.50m=audio 16860 RTP/AVP 18}}}}}

to change it ?
(in the local sdp ,mgc use '-' ,the real ip and port  is not sent  )

Best Regards,
Neal

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: [email-masked]
Date: Wed, 2 Jun 2004 09:41:23 +0530

MGC should not use "-" for only  ip and port number in C field of SDP.

 "C" field is optional in SDP and when you do not want to change the
connection parameters better not to use this variable again.

-SReeram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of zhuning 17035
Sent: Tuesday, June 01, 2004 2:22 PM
To: [email-masked]
Subject: [Megaco] a doubt about sdp in h248 message

Hi,
    after  a rtp termination is added to a context and ip ,port and
codec is reported to mgc ,if mgc wants to just change the codec but the
ip and port will not be change .can mgc use '-' as ip and port in sdp of
local?

1. MGC->MGW
MEGACO/1 [182.20.20.1]:2944
T=369361149{C=${A=A1{M{O{MO=SR,RV=OFF,RG=OFF}},E=369100037{al/*},SG{}},A
=${M{O{MO=IN,RV=OFF,RG=OFF,nt/jit=40},L{v=0c=IN IP4 $m=audio $ RTP/AVP
8}}}}}

2.MGW->MGC
MEGACO/1 [182.020.020.050]:2944
P=369361149{C=116{A=A1,A=A100000039{M{O{MO=IN,RV=OFF,RG=OFF,nt/jit=40},L
{v=0c=IN IP4 182.20.20.50m=audio 16856 RTP/AVP 8}}}}}

.
.
.
.
.
.
if mgc wants to change the codec of A100000039 to 18 ,can mgc use 
MEGACO/1 [182.20.20.1]:2944
T=370278656{C=116{MF=A1{M{O{RV=OFF,RG=OFF,tdmc/ec=ON}},E=369100040{al/*}
,SG{}},MF=A100000039{M{O{MO=SR,RV=OFF,RG=OFF,tdmc/ec=ON},L{v=0c=IN IP4
-m=audio - RTP/AVP 18},R{v=0c=IN IP4 182.20.20.50m=audio 16860 RTP/AVP
18}}}}}

to change it ?

Best Regards,
Neal

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Wed, 2 Jun 2004 08:20:55 +0200

Hi,

Why not use the previously assigned IP address and port in the modified SDP, instead of "-"?

Regards,

Christer Holmberg
Ericsson Finland

> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of zhuning 17035
> Sent: 1. kesäkuuta 2004 11:52
> To: [email-masked]
>     after  a rtp termination is added to a context and ip 
> ,port and codec is reported to mgc ,if mgc wants to just 
> change the codec but the ip and port will not be change .can 
> mgc use '-' as ip and port in sdp of local?
> 
> 1. MGC->MGW
> T=369361149{C=${A=A1{M{O{MO=SR,RV=OFF,RG=OFF}},E=369100037{al/
> *},SG{}},A=${M{O{MO=IN,RV=OFF,RG=OFF,nt/jit=40},L{v=0c=IN IP4 
> $m=audio $ RTP/AVP 8}}}}}
> 
> 2.MGW->MGC
> P=369361149{C=116{A=A1,A=A100000039{M{O{MO=IN,RV=OFF,RG=OFF,nt
> /jit=40},L{v=0c=IN IP4 182.20.20.50m=audio 16856 RTP/AVP 8}}}}}
> 
> .
> .
> .
> .
> .
> .
> T=370278656{C=116{MF=A1{M{O{RV=OFF,RG=OFF,tdmc/ec=ON}},E=36910
> 0040{al/*},SG{}},MF=A100000039{M{O{MO=SR,RV=OFF,RG=OFF,tdmc/ec
> =ON},L{v=0c=IN IP4 -m=audio - RTP/AVP 18},R{v=0c=IN IP4 
> 182.20.20.50m=audio 16860 RTP/AVP 18}}}}}
> 
> to change it ?

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Wed, 2 Jun 2004 08:39:41 +0200

Hi,

>connection parameters better not to use this variable again.

The c= (connection) field is MANDATORY in SDP. It must be present either on the session- or media level.

In my opinion, like I said earlier, the best way is to use the IP address and port value that you already have, that was assigned to you when the termination was added.

Regards,

Christer Holmberg
Ericsson Finland

> [mailto:[email-masked]] On Behalf
> Of zhuning 17035
> *},SG{}},A
> /jit=40},L
> 0040{al/*}