Subject: [Megaco] ServiceChange Address lifetime

From: [email-masked]
Date: Thu, 10 Jun 2004 17:28:00 +0530

Hi
      For the scenario mentioned below what is the lifetime of the
ServiceChange Address:
1) Through Management interface MGC is configured for the transport address
of the MediaGateway.
2) MG does a registration with MGC using the configured transport address.
3) At the MG end, local transport address is changed through the management
interface
4) MG sends ServiceChange with ServiceChangeAddress to the MGC.
5) MGC modifies the remote entity information at its end.

Now should this changed address be considered persistent from this point
onwards or its validity is only for the time the association is active.
What if MGC or MG goes down and comes up again, then what should be the MG
address at the MGC end.

Regards
Venkat

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended solely for the use of the individual to whom it is
addressed. It may contain  privileged or confidential information and
should not be circulated or used for any purpose other than for what it is
intended. If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient, you are
notified that you are strictly prohibited from using, copying, altering, or
disclosing the contents of this message. HSS accepts no responsibility for
loss or damage arising from the use of the information transmitted by this
email including damage from virus."

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: "Umesh Sharma" <[email-masked]>
Date: Thu, 10 Jun 2004 18:52:24 +0530

Hi Venkat

>From protocol language it looks the changed address is not persistent:

>> ServiceChangeAddress provides an address to be used within the
>> context of the association currently being negotiated

regards
Umesh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of [email-masked]
Sent: Thursday, June 10, 2004 5:28 PM
To: [email-masked]
Subject: [Megaco] ServiceChange Address lifetime

Hi

Regards
Venkat

---

From: petric john <[email-masked]>
Date: Fri, 11 Jun 2004 16:21:17 +1000 (EST)

>From the protocol perspective, the service change
address remains active till the time you send another
SVC with SVCAddress. 

So given this condition, please see my comments below,
marked with [PJ].

 --- [email-masked] wrote: > 
> 1) Through Management interface MGC is configured
> for the transport address of the MediaGateway.
> 3) At the MG end, local transport address is changed
> through the management interface

[PJ] This scenario, I see as a change in the
provisioned information. This may not initiate any SVC
procedure during an active assiciation currently being
used.

> configured transport address.

[PJ] This is more a initial SVC message when MG is
coming up.

> Now should this changed address be considered
> persistent from this point onwards or its validity 
> is only for the time the association is active.
> What if MGC or MG goes down and comes up again, then
> what should be the MG address at the MGC end.
> 
[PJ] This is the text from 7.2.8@rfc3525@Page64:
------------------------------------------------
The MG may specify an address in the
ServiceChangeAddress parameter of the ServiceChange   
request, and the MGC may also do so in the
ServiceChange reply. In either case, the recipient
must use the supplied address as the destination for
all subsequent transaction requests within the   
association.

So to answer your question, 
1. This changed address should be considered
persistent only for the time the association is
active.
2. When the either MG or MGC goes down and comes up
again, it shall use whatever is
configured/provisioned.

Hope it helps.

Regds,
/PJ.

> Venkat

Find local movie times and trailers on Yahoo! Movies.
http://au.movies.yahoo.com

---

From: petric john <[email-masked]>
Date: Fri, 11 Jun 2004 16:28:02 +1000 (EST)

Hope it helps.

Regds,
/PJ.