Subject: [Megaco] [Fwd: Question on signal/event behaviour]

From: Steve Yeung <[email-masked]>
Date: Mon, 21 Jun 2004 13:20:52 -0700

Dear Sir/Madam:

       I am resending this email.  Would you please check to see whether
anyone can help me on this?  Thank you very much!

-------- Original Message --------
Subject: Question on signal/event behaviour
Date: Mon, 24 May 2004 12:36:05 -0700
From: Steve Yeung <[email-masked]>
Organization: Cisco Systems
To: [email-masked]
CC: Steve Yeung <[email-masked]>

Dear Sir/Madam:

       I want to confirm the following behaviour on Megaco (H.248).  The 
following
sequence of operation does not use the KeepActive option.

        When we have 2 sequences of commands going to MG as follow:

1.   event:  g/sc
     signal:  cg/dt, duration=60 seconds, notifycompletion = timeout,
     intbyevent, intbysigdesc, otherreason
2.   after 10 seconds
3.   event:  g/sc
     signal:  cg/bt, duration= 60 seconds, notifycompletion=timeout, 
     intbyevent, intbysigdesc, otherreason

Behaviour 1:
     After received the 2nd signal (i.e. cg/bt), the MG wll sent notify 
     with reason SD, then in a few millisecond, the MG will sent
     notify with reason EV to MGC.  The 2nd signal did not play (or
     played for a few millisecond only).

Behaviour 2:
     After received the 2nd signal (i.e. cg/bt), MG will sent notify 
     with reason SD, then the 2nd signal will play for 60 seconds.
     After the 2nd signal timeout, the MG will sent notify with
     reason TO to MGC.

My question is which behaviour is correct?
Thank you very much!

-- 
Steve Yeung
Software Engineer
408-853-4214

-- 
Steve Yeung
Software Engineer
408-853-4214

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Tom Taylor <[email-masked]>
Date: Wed, 23 Jun 2004 09:58:31 -0400

Behaviour 2 is the one that makes sense, in that it is more likely the desired 
behaviour.  Let's see if we can reason our way to it.

The sequence of operations when the new transaction arrives is this:

1) The new Events Descriptor is recognized and installed.

2) The new Signals Descriptor is recognized.

3) This recognition terminates the old signal.

4) The end of the old signal triggers a Signal Completion event.

5) The new Signals Descriptor is installed.

So basically you don't start playing the new signal until you clean up all the 
business associated with the old one.

If everyone agrees with that principle, you have your answer.

One other thought occurred to me in reading your question: what if g/sc had been 
absent from the new Events Descriptor?  In that case, I believe, based on the 
sequence of operations above, that no event would be reported.

---

From: Tom Taylor <[email-masked]>
Date: Wed, 23 Jun 2004 16:48:48 -0400

You are right: if no Events Descriptor is specified, the one previously in force 
continues to apply.

Steve Yeung wrote:
> Hi Tom:
> 
>         Thank you very much for your help!
>          I just want to confirm the last item you mentioned.  When the
> 2nd event descriptor is
> missing, then the 2nd signal descriptor received, should the MG still
> send the notify with TO
> after the 2nd signal completed?
> 
>          I am thinking the the 1st event descriptor of g/sc should
> continue to exist.  What do you
> think?   Thanks!
> 
> 
> Tom Taylor wrote:
> 
>  > Behaviour 2 is the one that makes sense, in that it is more likely the
>  > desired behaviour.  Let's see if we can reason our way to it.
>  >
>  > So basically you don't start playing the new signal until you clean up
>  > all the business associated with the old one.
>  >
>  > One other thought occurred to me in reading your question: what if
>  > g/sc had been absent from the new Events Descriptor?  In that case, I
>  > believe, based on the sequence of operations above, that no event
>  > would be reported.
>  >
>  > Steve Yeung wrote:
>  >
>  >>   Dear Sir/Madam:
>  >>
>  >>        I want to confirm the following behaviour on Megaco (H.248). 
>  >> The following
>  >>      After received the 2nd signal (i.e. cg/bt), the MG wll sent
>  >> notify      with reason SD, then in a few millisecond, the MG will sent

---

From: Christian Groves <[email-masked]>
Date: Thu, 24 Jun 2004 08:46:32 +1000

Hello Steve,

The second behaviour is correct the 2nd signal plays for 60 seconds.

Regards, Christian

Steve Yeung wrote:

> ------------------------------------------------------------------------
>

---

From: Steve Yeung <[email-masked]>
Date: Wed, 23 Jun 2004 12:14:16 -0700

Hi Tom:

-- 
Steve Yeung
Software Engineer
408-853-4214