Subject: [Megaco] Which error to use for errors in Topology descriptor?

From: Aleksandr Ryabin <[email-masked]>
Date: Tue, 22 Jun 2004 12:03:38 -0400

Hi,

Which error should be used to report errors detected within TopologyDescriptor?
If there are none yet, can one be added to H.248.8?

Thanks
	Aleks

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Thu, 24 Jun 2004 09:08:36 +1000

Hello Aleksandr,

What sort of error were you thinking about?

If there's something wrong with the syntax then this can be covered with 422 
syntax error in action. Invalid termination/stream ID can be covered by other 
errors.

Is the error something like "invalid topology" where the MG can't connect 
terminations according to the MGC's wishes?

Regards, Christian

---

From: Aleksandr Ryabin <[email-masked]>
Date: Wed, 23 Jun 2004 19:23:55 -0400

Hi Christian,

Yes, exactly, "invalid topology" or something like "could not apply topology"

Regards,
         Aleks

At 07:08 PM 6/23/2004, Christian Groves wrote:
>If there's something wrong with the syntax then this can be covered with 
>422 syntax error in action. Invalid termination/stream ID can be covered 
>by other errors.
>

---

From: Christian Groves <[email-masked]>
Date: Thu, 24 Jun 2004 13:38:45 +1000

Hello Aleksandr,

Sounds like a reasonable thing to add.

Christian

Aleksandr Ryabin wrote:

>> If there's something wrong with the syntax then this can be covered 
>> with 422 syntax error in action. Invalid termination/stream ID can be 
>> covered by other errors.
>>
>> Is the error something like "invalid topology" where the MG can't 
>> connect terminations according to the MGC's wishes?
>>
>> Regards, Christian
>>
>> Aleksandr Ryabin wrote:
>>
>>> Hi,

---

From: Aleksandr Ryabin <[email-masked]>
Date: Thu, 24 Jun 2004 10:07:03 -0400

Hi Christinan,

Can we agree on the error code number now and the document this is to added?
Can the editor of the appropriate document (i.e. IG, or H.248.8 update) 
please assign the number?

Thanks
         Aleks