Subject: [Megaco] Ambiguity in ABNF of indAudauditReturnParameter in H.248 v2

From: "Francois Plagnard" <[email-masked]>
Date: Thu, 3 Jun 2004 17:12:14 +0200

Hello,

In H.248v2, in indAudauditReturnParameter ABNF, according to my
understanding, there are several ambiguities.

For example,
      indAudmediaDescriptor   = MediaToken LBRKT indAudmediaParm RBRKT
means for me that you have only 1 instance of indAudmediaParm.

But, its definition is :
      ; at-most-once per item
      ; and either streamParm or streamDescriptor but not both
      indAudmediaParm = (indAudstreamParm / indAudstreamDescriptor /
                         indAudterminationStateDescriptor)
which implies that you may have several instances !

You have the same ambiguity with :
- indAudlocalParm
- indAudterminationStateParm
...

May we have 1 or several instances of them ?
And, if we may have several instances, how are they separated ?

Best regards,

===================================================================
Francois Plagnard,
Netbricks
31 rue Jean Rostand
91893 ORSAY -- FRANCE
Email: [email-masked]  - WEB : www.netbricks.com
Tel: +33 (0)1 69 33 12 57 -- Fax: +33 (0)1 69 85 54 26
===================================================================

_______________________________________________
Megaco mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/megaco

---

From: Christian Groves <[email-masked]>
Date: Mon, 07 Jun 2004 10:26:46 +1000

Hello Francois,

I'm having some problem understanding what the ambiguity is. Please see my 
comments below.

Regards, Christian

> means for me that you have only 1 instance of indAudmediaParm.

[CHG] Yes I agree.

> which implies that you may have several instances !

[CHG] Doesn't this imply that you "choose" one instance from the alternatives?

---

From: "Francois Plagnard" <[email-masked]>
Date: Tue, 8 Jun 2004 16:47:07 +0200

Christian,

I agree with you, but I still don't understand the meaning of the comment
       ; at-most-once per item
       ; and either streamParm or streamDescriptor but not both
if you can have only one instance.

For me, it looks like a too quick "copy and paste" from mediaDescriptor and
it is confusing.

Best regards,

Francois.

----- Original Message ----- 
From: "Christian Groves" <[email-masked]>
To: "Francois Plagnard" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, June 07, 2004 2:26 AM
Subject: Re: [Megaco] Ambiguity in ABNF of indAudauditReturnParameter in
H.248 v2

---

From: Anil Jangam <[email-masked]>
Date: Wed, 09 Jun 2004 09:47:13 +0530

Hi Francois,

Pls. see marked inline with [AJJ].

/anil.

>For me, it looks like a too quick "copy and paste" from mediaDescriptor and
[AJJ] The "at-most-once per item" means that no item will be repeated, 
if you have the list of  such similar items.

      ; at-most-once per item

In your case, as its a only parameter, it values could either be 'indAudstreamParm' or 'indAudstreamDescriptor' or 'indAudterminationStateDescriptor' ONLY. In addition to this according to the second condition, the 'indAudstreamDescriptor' and 'indAudterminationStateDescriptor' both CAN NOT be present at the same time.

I guess your confusion is more because of the 'indAudmediaParm' is a SINGLE item. Just consider the case if you had 'indAudmediaDescriptor' as a LIST instead. You would appriciate the meaning of "at-most-once per item".

(See below)

>>>May we have 1 or several instances of them ?
[AJJ] In above case there will be only one instance of "indAudmediaParm".

>>>And, if we may have several instances, how are they separated ?
[AJJ] If you have several instances of a given item, its seperated by a 
COMMA. I can give you one example from RFC3525.

            serviceChangeReplyDescriptor = ServicesToken LBRKT
                                    servChgReplyParm *(COMMA 
servChgReplyParm) RBRKT

Hope this resolves your all doubts. :-)

Regards,
/anil.